Podręcznik użytkownika Anuluj

Praca z elementami bibliotek

  1. Podręcznik użytkownika programu Dreamweaver
  2. Wprowadzenie
    1. Podstawy projektowania serwisów WWW o elastycznym układzie
    2. Dreamweaver — co nowego
    3. Programowanie zawartości WWW za pomocą programu Dreamweaver — przegląd
    4. Dreamweaver / Popularne pytania
    5. Skróty klawiszowe
    6. Wymagania systemowe programu Dreamweaver
    7. Podsumowanie funkcji
  3. Program Dreamweaver a platforma Creative Cloud
    1. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    2. Biblioteki Creative Cloud w programie Dreamweaver
    3. Używanie plików programu Photoshop w programie Dreamweaver
    4. Praca z programami Adobe Animate oraz Dreamweaver
    5. Wydzielanie przygotowanych do wyświetlania w Internecie plików SVG z bibliotek
  4. Przestrzenie robocze i widoki w programie Dreamweaver
    1. Przestrzeń robocza programu Dreamweaver
    2. Optymalizacja przestrzeni roboczej programu Dreamweaver do programowania wizualnego
    3. Wyszukiwanie plików według nazwy lub zawartości | Mac OS
  5. Konfigurowanie serwisów
    1. Informacje o serwisach programu Dreamweaver
    2. Konfigurowanie lokalnej wersji serwisu
    3. Nawiązywanie połączenia z serwerem publikacji
    4. Konfigurowanie serwera testowego
    5. Importowanie i eksportowanie ustawień serwisu programu Dreamweaver
    6. Przenoszenie istniejących serwisów z serwera zdalnego do lokalnego katalogu głównego serwisu
    7. Funkcje ułatwień dostępu w programie Dreamweaver
    8. Ustawienia zaawansowane
    9. Ustawianie preferencji serwisu dotyczących transferu plików
    10. Określanie ustawień serwera proxy w programie Dreamweaver
    11. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    12. Korzystanie z systemu Git w programie Dreamweaver
  6. Zarządzanie plikami
    1. Tworzenie i otwieranie plików
    2. Zarządzanie plikami i folderami
    3. Odbieranie plików i wysyłanie ich na serwer
    4. Pobieranie plików do edycji i odkładanie ich na serwer
    5. Synchronizacja plików
    6. Porównywanie plików w poszukiwaniu różnic
    7. Maskowanie plików i folderów w serwisie programu Dreamweaver
    8. Włączanie funkcji Uwagi do projektu w serwisach programu Dreamweaver
    9. Zapobieganie potencjalnemu obejściu funkcji Gatekeeper
  7. Układ i projekt
    1. Korzystanie z wizualnych pomocy do układu
    2. Informacje o tworzeniu układu strony za pomocą stylów CSS
    3. Projektowanie elastycznych serwisów WWW z użyciem struktury Bootstrap
    4. Tworzenie i używanie zapytań o media w programie Dreamweaver
    5. Prezentacja zawartości za pomocą tabel
    6. Kolory
    7. Tworzenie reagujących projektów za pomocą układów elastycznej siatki
    8. Narzędzie Extract w programie Dreamweaver
  8. CSS
    1. Podstawowe informacje o stylach CSS
    2. Tworzenie układu strony za pomocą panelu Projektant CSS
    3. Korzystanie z preprocesorów CSS w programie Dreamweaver
    4. Ustawianie preferencji stylów CSS w programie Dreamweaver
    5. Przenoszenie reguł CSS w programie Dreamweaver
    6. Konwertowanie stylu CSS wewnątrz znacznika na regułę CSS w programie Dreamweaver
    7. Posługiwanie się znacznikami DIV
    8. Stosowanie gradientów na tło
    9. Tworzenie i edytowanie efektów przejść CSS3 w programie Dreamweaver
    10. Formatowanie kodu
  9. Zawartość strony i zasoby
    1. Ustawianie właściwości strony
    2. Ustawianie właściwości CSS dla nagłówków i łączy
    3. Praca z tekstem
    4. Znajdowanie i zastępowanie tekstu, znaczników i atrybutów
    5. Panel DOM
    6. Edytowanie w widoku aktywnym
    7. Kodowanie znaków dokumentu w programie Dreamweaver
    8. Zaznaczanie i wyświetlanie elementów w oknie Dokument
    9. Ustawianie właściwości tekstu na panelu Inspektor właściwości
    10. Sprawdzanie pisowni na stronie internetowej
    11. Używanie linii poziomych w programie Dreamweaver
    12. Dodawanie i modyfikowanie kombinacji czcionek w programie Dreamweaver
    13. Praca z zasobami
    14. Wstawianie i aktualizowanie dat w programie Dreamweaver
    15. Tworzenie list ulubionych zasobów w programie Dreamweaver i zarządzanie nimi
    16. Wstawianie i edytowanie obrazów w programie Dreamweaver
    17. Dodawanie obiektów multimedialnych
    18. Dodawanie zawartości wideo w programie Dreamweaver
    19. Wstawianie wideo HTML5
    20. Wstawianie plików SWF
    21. Dodawanie efektów dźwiękowych
    22. Wstawianie obiektów audio HTML5 w programie Dreamweaver
    23. Praca z elementami bibliotek
    24. Stosowanie pisma arabskiego i hebrajskiego w programie Dreamweaver
  10. Łączenie i przeglądanie
    1. Informacje o łączeniu i przeglądaniu stron
    2. Tworzenie łączy
    3. Mapy obrazu
    4. Rozwiązywanie problemów dotyczących łączy
  11. Efekty i widgety jQuery
    1. Używanie widgetów jQuery interfejsu użytkownika i elementów mobilnych w programie Dreamweaver
    2. Używanie efektów jQuery w programie Dreamweaver
  12. Tworzenie kodu serwisów WWW
    1. Informacje o tworzeniu kodu w programie Dreamweaver
    2. Środowisko programistyczne w programie Dreamweaver
    3. Ustawianie preferencji kodowania
    4. Dostosowywanie ustawień kolorowania kodu
    5. Pisanie i edytowanie kodu
    6. Podpowiedzi i uzupełnianie kodu
    7. Zwijanie i rozwijanie kodu
    8. Ponowne wykorzystywanie fragmentów kodu za pomocą funkcji Urywki
    9. Linting: oczyszczanie kodu z błędów
    10. Optymalizacja kodu
    11. Edytowanie kodu w widoku Projekt
    12. Praca z zawartością znacznika HEAD strony
    13. Wstawianie dołączeń po stronie serwera w programie Dreamweaver
    14. Korzystanie z bibliotek znaczników w programie Dreamweaver
    15. Importowanie własnych znaczników do programu Dreamweaver
    16. Używanie zachowań JavaScript (instrukcje ogólne)
    17. Stosowanie wbudowanych zachowań JavaScript
    18. Omówienie języków XML i XSLT
    19. Wykonywanie transformacji XSL po stronie serwera w programie Dreamweaver
    20. Wykonywanie przekształceń XSL po stronie klienta w programie Dreamweaver
    21. Dodawanie encji znaków w kodzie XSLT w programie Dreamweaver
    22. Formatowanie kodu
  13. Obiegi pracy związane z wieloma produktami
    1. Instalowanie i używanie rozszerzeń programu Dreamweaver
    2. Aktualizacje w aplikacji w programie Dreamweaver
    3. Wstawianie dokumentów Microsoft Office w programie Dreamweaver (tylko Windows)
    4. Praca z programami Fireworks i Dreamweaver
    5. Edycja zawartości w stronach programu Dreamweaver za pomocą aplikacji Contribute
    6. Integracja programu Dreamweaver z aplikacją Business Catalyst
    7. Tworzenie spersonalizowanych kampanii rozsyłanych pocztą elektroniczną
  14. Szablony
    1. Informacje o szablonach programu Dreamweaver
    2. Rozpoznawanie szablonów oraz dokumentów opartych na szablonach
    3. Tworzenie szablonu programu Dreamweaver
    4. Tworzenie edytowalnych regionów w szablonach
    5. Tworzenie powtarzalnych regionów i tabel w programie Dreamweaver
    6. Używanie regionów opcjonalnych w szablonach
    7. Definiowanie edytowalnych atrybutów znacznika w programie Dreamweaver
    8. Tworzenie zagnieżdżonych szablonów w programie Dreamweaver
    9. Edytowanie, aktualizowanie i usuwanie szablonów
    10. Eksportowanie i importowanie zawartości XML w programie Dreamweaver
    11. Stosowanie szablonu lub usuwanie go z istniejącego dokumentu
    12. Edycja zawartości w szablonach programu Dreamweaver
    13. Reguły składni dla znaczników szablonu w programie Dreamweaver
    14. Ustawianie preferencji podświetlenia dla regionów szablonów
    15. Korzyści wynikające z używania szablonów w programie Dreamweaver
  15. Urządzenia mobilne i obsługa wielu ekranów
    1. Tworzenie zapytań o media
    2. Zmiana orientacji strony na urządzeniach mobilnych
    3. Tworzenie aplikacji internetowych przeznaczonych na urządzenia mobilne za pomocą programu Dreamweaver
  16. Dynamiczne serwisy, strony i formularze WWW
    1. Podstawowe informacje o aplikacjach internetowych
    2. Konfigurowanie komputera do programowania aplikacji
    3. Rozwiązywanie problemów z połączeniami z bazą danych
    4. Usuwanie skryptów połączenia w programie Dreamweaver
    5. Projektowanie stron dynamicznych
    6. Omówienie źródeł zawartości dynamicznej
    7. Definiowanie źródeł zawartości dynamicznej
    8. Dodawanie dynamicznej zawartości do stron
    9. Modyfikowanie dynamicznej zawartości w programie Dreamweaver
    10. Wyświetlanie rekordów z bazy danych
    11. Udostępnianie aktywnych danych w programie Dreamweaver oraz rozwiązywanie problemów z takimi danymi
    12. Dodawanie własnych zachowań serwerowych w programie Dreamweaver
    13. Tworzenie formularzy w programie Dreamweaver
    14. Zbieranie informacji od użytkowników za pomocą formularzy
    15. Tworzenie oraz włączanie formularzy ColdFusion w programie Dreamweaver
    16. Tworzenie formularzy WWW
    17. Rozszerzona obsługa elementów formularza w języku HTML5
    18. Tworzenie formularzy za pomocą programu Dreamweaver
  17. Tworzenie aplikacji metodą graficzną
    1. Tworzenie stron wzorca i szczegółów w programie Dreamweaver
    2. Tworzenie stron wyszukiwania i wyników
    3. Tworzenie strony wstawiania rekordów
    4. Tworzenie strony uaktualniania rekordów w programie Dreamweaver
    5. Tworzenie stron usuwania rekordów w programie Dreamweaver
    6. Używanie poleceń ASP do modyfikacji bazy danych w programie Dreamweaver
    7. Tworzenie strony rejestracji
    8. Tworzenie strony logowania
    9. Tworzenie strony, do której dostęp będą mieli tylko uwierzytelnieni użytkownicy
    10. Zabezpieczanie folderów w aplikacji ColdFusion za pomocą programu Dreamweaver
    11. Korzystanie ze składników ColdFusion w programie Dreamweaver
  18. Testowanie, podgląd i publikacja serwisów WWW
    1. Podgląd stron
    2. Podgląd stron WWW programu Dreamweaver na wielu urządzeniach
    3. Testowanie serwisu programu Dreamweaver

 

W tym temacie omówiono tworzenie, wstawianie i modyfikowanie elementów bibliotek w dokumentach w programie Dreamweaver.

Biblioteka jest specjalnym plikiem programu Dreamweaver zawierającym kolekcję indywidualnych zasobów lub kopii zasobów, które można umieścić na swoich stronach internetowych. Zasoby znajdujące się w bibliotece nazywane są elementami biblioteki. Do elementów, które można umieszczać w bibliotece, należą obrazy, tabele, pliki dźwiękowe oraz pliki utworzone w programie Adobe Flash. Wszystkie strony, które używają elementów biblioteki, mogą być automatycznie uaktualniane, po edycji elementów biblioteki.

Załóżmy na przykład, że tworzysz duży serwis dla firmy, która życzy sobie umieszczenia na każdej stronie sloganu reklamowego. Możesz utworzyć element biblioteki zawierający slogan i używać tego elementu na każdej stronie. Po zmianie sloganu, możesz zmienić element biblioteki i zostanie on uaktualniony na każdej stronie serwisu.

Program Dreamweaver umieszcza elementy biblioteki w folderze Biblioteka znajdującym się w lokalnym folderze głównym każdego serwisu. Każdy serwis ma swoją własną bibliotekę.

Element biblioteki można tworzyć z dowolnego elementu w głównej sekcji dokumentu, dołączając tekst, tabele, formularze, aplety Java, wtyczki, elementy ActiveX, paski nawigacji i obrazy.

Jeśli chodzi o elementy połączone, takie jak obrazy, to biblioteka przechowuje tylko odniesienia do nich. Oryginalne pliki muszą pozostać w zdefiniowanym miejscu, aby elementy biblioteki poprawnie funkcjonowały.

W dalszym ciągu może być użyteczne umieszczenie obrazu w elemencie biblioteki. Na przykład możesz umieścić pełny znacznik img w elemencie biblioteki, który pozwoli na łatwą zmianę tekstu alt obrazu, lub nawet jego atrybutu src. (Nie używaj tej techniki do zmiany atrybutów obrazu width oraz height, chyba że używasz także edytora obrazu, do zmiany bieżącego rozmiaru obrazu).

Uwaga:

Jeśli element biblioteki zawiera łącza, mogą one nie działać w nowym serwisie. Także obrazy znajdujące się w elemencie biblioteki nie są kopiowane do nowego serwisu.

Podczas korzystania z elementu biblioteki, program Dreamweaver umieszcza na stronie internetowej łącze, a nie sam element. Oznacza to, że program Dreamweaver wstawia w dokumencie kopię kodu źródłowego HTML dla tego elementu i dodaje komentarz HTML zawierający odniesienie do zewnętrznego, oryginalnego elementu. To właśnie takie odniesienie zewnętrzne sprawia, że możliwe jest automatyczne uaktualnianie.

Gdy tworzony jest element biblioteki zawierający element z dołączonym do niego zachowaniem programu Dreamweaver, program ten kopiuje element i jego moduł zdarzenia (atrybut, który określa zdarzenie wyzwalające operację, np. onClick, onLoad lub onMouseOver, oraz która operacja powinna zostać wywołana, gdy wystąpi zdarzenie) do pliku elementu biblioteki. Program Dreamweaver nie kopiuje do elementu biblioteki powiązanych funkcji JavaScript. Natomiast gdy do dokumentu wstawiany jest element biblioteki, program Dreamweaver automatycznie wstawia odpowiednie funkcje JavaScript do sekcji head tego dokumentu (jeśli jeszcze ich tam nie ma).

Uwaga:

Jeśli kod JavaScript jest pisany ręcznie (tj. bez korzystania z zachowań programu Dreamweaver), można go uczynić częścią elementu biblioteki, jeśli do wykonania kodu użytkownik korzysta z zachowania Call JavaScript. Jeśli użytkownik nie korzysta z zachowania programu Dreamweaver kodu do wykonania kodu, kod nie jest zachowany jako część elementu biblioteki.

Podczas edycji zachowań w elementach biblioteki, należy stosować się opracowanych specjalnych wymogów. Elementy biblioteki nie mogą zawierać arkuszy stylów, ponieważ kod dla tych elementów jest częścią sekcji nagłówek.

Tworzenie elementu biblioteki w oparciu o zaznaczenie

  1. W oknie dokumentu przełącz na widok Projekt i zaznacz część dokumentu przeznaczoną do zapisania jako element biblioteki.

  2. Wybierz polecenie Narzędzia > Biblioteka > Dodaj obiekt do biblioteki.

  3. Wpisz nazwę nowego elementu biblioteki i wciśnij klawisz Enter (Windows) lub Return (Macintosh).

    Program Dreamweaver zapisuje każdy element biblioteki jako oddzielny plik (z rozszerzeniem .lbi) w folderze Biblioteka w głównym folderze serwisu lokalnego.

Tworzenie pustego elementu biblioteki

  1. Upewnij się, że w oknie dokumentu nic nie jest zaznaczone.

    Jeśli jakiś obiekt jest zaznaczony, będzie on umieszczony w nowym elemencie biblioteki.

  2. W panelu Zasoby wybierz kategorię Biblioteka.

  3. Kliknij przycisk Nowy element biblioteki, umieszczony w dolnej części panelu.

  4. Gdy element jest jeszcze zaznaczony, wpisz dla niego nazwę i wciśnij klawisz Enter (Windows) lub Return (Macintosh).

Wstawianie elementu biblioteki do dokumentu

Gdy na stronie dodawany jest element biblioteki, w dokumencie wstawiana jest jego aktualna zawartość wraz z odniesieniem do elementu biblioteki.

  1. Umieść punkt wstawiania w oknie Dokument.
  2. W panelu Zasoby wybierz kategorię Biblioteka.

  3. Wykonaj jedną z następujących czynności:
    • Przeciągnij element biblioteki z panelu zasoby na okno Dokument.
    Uwaga:

    Aby wstawić zawartości biblioteki bez dołączania odniesienia do elementu w dokumencie, podczas przeciągania elementu z panelu Zasoby, wciśnij klawisz Control (Windows) lub Option (Macintosh). Jeśli element wstawiany jest w ten sposób, może być on edytowany w dokumencie, ale dokument nie będzie uaktualniany wraz z uaktualnieniem stron używających tego elementu biblioteki.

    • Wybierz element biblioteki i kliknij przycisk Wstaw.

Edycja elementów biblioteki i uaktualnianie dokumentów

Podczas edycji elementu biblioteki, możesz uaktualnić wszystkie dokumenty, które go używają. Jeśli zrezygnujesz z aktualizacji, dokumenty pozostaną powiązane z elementem biblioteki; można je uaktualnić później.

Możesz zmienić nazwy elementów, aby przerwać ich połączenie z dokumentami lub szablonami, usunąć elementy z biblioteki serwisu i odtworzyć brakujący element biblioteki.

Edycja elementów biblioteki

  1. W panelu Zasoby wybierz kategorię Biblioteka.

  2. Wybierz element biblioteki.
  3. Kliknij przycisk Edycja lub kliknij dwukrotnie element biblioteki.

    Program Dreamweaver otwiera nowe okno, podobne do okna Dokument, służące do edycji elementu biblioteki. Szare tło wskazuje, że zamiast dokumentu edytowany jest element biblioteki.

  4. Nanieś i zapisz swoje zmiany.
  5. Określ, czy uaktualnić dokumenty w lokalnym serwisie używającym elementu biblioteki. Wybierz opcje Uaktualnij, aby uaktualnić natychmiast. Jeśli wybierzesz opcję Nie uaktualniaj, dokumenty nie będą uaktualniane, dopóki nie wybierzesz polecenia Narzędzia > Biblioteka > Uaktualnij bieżącą stronę lub Uaktualnij strony.

Aktualizacja bieżącego dokumentu o bieżące wersje wszystkich elementów biblioteki

  1. Wybierz polecenie Narzędzia > Biblioteka > Uaktualnij bieżącą stronę.

Aktualizacja serwisu lub wszystkich dokumentów używających określonego elementu biblioteki

  1. Wybierz polecenie Narzędzia > Biblioteka > Uaktualnij strony.

  2. W wyskakującym menu „Szukaj w” określ pozycje do aktualizacji:
    • Aby uaktualnić wszystkie strony w wybranym serwisie, a tym samym móc używać aktualnych wersji wszystkich elementów z biblioteki, zaznacz opcję Cały serwis, a następnie wybierz nazwę serwisu z wyświetlonego obok wyskakującego menu.

    • Aby uaktualnić wszystkie te strony w bieżącym serwisie, które wykorzystują element biblioteki, zaznacz opcję Pliki, które używają, a następnie wybierz nazwę elementu z wyświetlonego obok wyskakującego menu

  3. Upewnij się, że pole wyboru Element biblioteki jest zaznaczone.
    Uwaga:

    Aby uaktualnić szablony w tym samym czasie, należy zaznaczyć także opcję Szablony.

  4. Kliknij przycisk Start.

    Program Dreamweaver uaktualnia pliki zgodnie ze wskazaniami. Jeśli wybrana została opcja Pokaż dziennik, program Dreamweaver wygeneruje raport o pomyślnej aktualizacji plików wraz z innymi informacjami.

Zmiana nazwy elementu biblioteki

  1. W panelu Zasoby wybierz kategorię Biblioteka.

  2. Wybierz element biblioteki, poczekaj chwilę i kliknij go ponownie. (Nie klikaj dwukrotnie; dwukrotne kliknięcie otwiera element do edycji).
  3. Wpisz nową nazwę.
  4. Kliknij w dowolnym miejscu lub wciśnij klawisz Enter (Windows) lub Return (Macintosh).
  5. Określ czy uaktualnić dokumenty używające elementu, wybierając Uaktualnij lub Nie uaktualniaj.

Usuwanie elementu biblioteki z biblioteki

Podczas usuwania elementu biblioteki, program Dreamweaver usuwa go z biblioteki, ale nie zmienia zawartości dokumentów, które używają tego elementu.

  1. W panelu Zasoby wybierz kategorię Biblioteka.

  2. Wybierz element biblioteki.
  3. Kliknij przycisk Usuń lub wciśnij klawisz Delete i potwierdź usuwanie elementu.
    Uwaga:

    Po usunięciu elementu biblioteki nie można go przywrócić za pomocą polecenia Cofnij. Jednak, można go odtworzyć.

Odtwarzanie brakującego lub usuniętego elementu biblioteki

  1. Zaznacz obiekt elementu w jednym z dokumentów.
  2. Kliknij przycisk Odtwórz w oknie inspektora Właściwości (Okno > Właściwości).

Dostosowywanie podświetlania elementów biblioteki

Ustawiając odpowiednio preferencje podświetlania można odpowiednio dostosować kolor podświetlania elementów biblioteki, a także ukrywać lub pokazywać podświetlenie.

Zmiana koloru podświetlenia elementów biblioteki

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh).
  2. Wybierz kategorię Podświetlenie, z listy po lewej stronie okna dialogowego Preferencje.
  3. Kliknij pole Kolor elementów biblioteki, następnie wybierz kolor podświetlenia za pomocą próbnika kolorów (lub w polu tekstowym wpisz szesnastkową wartość koloru).
  4. Wybierz opcję Pokaż, aby pokazać kolor podświetlenia w oknie Dokument.
  5. Kliknij przycisk OK.

Pokazywanie lub ukrywanie podświetlenia w oknie Dokument

  1. Wybierz polecenie Widok > Opcje widoku Projekt > Pomoce wizualne > Niewidoczne elementy. Aby ukryć podświetlenie, odznacz Niewidoczne elementy.

Edycja właściwości elementu biblioteki

Inspektor właściwości, może być używany do otwierania elementu biblioteki do edycji, odłączania wybranego elementu biblioteki od jego pliku źródłowego lub nadpisywania elementu aktualnie wybranym elementem biblioteki.

  1. Zaznacz element biblioteki w dokumencie.
  2. Wybierz jedną z następujących opcji w inspektorze Właściwości (Okno > Właściwości):

    Src

    Wyświetla nazwę pliku i położenie pliku źródłowego dla elementu biblioteki. Ta informacja nie może być edytowana.

    Otwórz

    Otwiera plik źródłowy elementu biblioteki do edycji. Jest to równoznaczne z zaznaczeniem elementu w panelu Zasoby i kliknięciem przycisku Edycja.

    Odłącz od oryginału

    Przerywa łącze między wybranym elementem biblioteki i jej plikiem źródłowym. Odłączony element może być edytowany w dokumencie, ale nie jest już dłużej elementem biblioteki i nie jest uaktualniany po zmianie oryginału.

    Odtwórz

    Nadpisuje oryginalny element biblioteki bieżącym zaznaczeniem. Użyj tej opcji do odtworzenia elementów biblioteki, jeśli brakuje oryginalnego element biblioteki lub został przypadkowo usunięty.

Umożliwianie edycji elementów biblioteki w dokumencie

Jeśli do dokumentu dodany został element biblioteki i chcesz edytować element specjalnie w odniesieniu do tej strony, musisz przerwać połączenie między elementem w dokumencie i biblioteką. Po włączeniu edycji w obiekcie elementu biblioteki, obiekt nie jest uaktualniany, po zmianie elementu biblioteki.

  1. Zaznacz element biblioteki w bieżącym dokumencie.
  2. Kliknij przycisk Odłącz od oryginału w oknie inspektora Właściwości (Okno > Właściwości).

Edycja zachowania w elemencie biblioteki

Aby zmienić zachowanie w elemencie biblioteki, najpierw należy wstawić element do dokumentu, następnie zmień element na edytowalny. Po utworzeniu zmian, możesz odtworzyć element biblioteki, zastępując element w bibliotece elementem edytowanym w dokumencie.

  1. Otwórz dokument zawierający element biblioteki.

    Zanotuj nazwę elementu biblioteki oraz znaczniki które zawiera. Informacja ta, będzie przydatna później.

  2. Wybierz element biblioteki, następnie kliknij opcję Odłącz od oryginału w oknie inspektora Właściwości (Okno > Właściwości).
  3. Wybierz element, który posiada dołączone zachowanie.
  4. W panelu Zachowania (Okno > Zachowania), dwukrotnie kliknij zadanie, które chcesz zmienić.
  5. W wyświetlonym oknie dialogowym, utwórz wymagane zmiany i kliknij przycisk OK.
  6. W panelu Zasoby wybierz kategorię Biblioteka.

  7. Zarejestruj dokładną nazwę z zachowaniem wielkości liter oryginalnego elementu biblioteki; zaznacz go i kliknij przycisk Usuń.
  8. W oknie Dokument, zaznacz wszystkie elementy wchodzące w skład elementu biblioteki.

    Należy uważać, aby zaznaczyć dokładnie te same elementy, które były w oryginalnym elemencie biblioteki.

  9. W panelu Zasoby kliknij przycisk Nowy element biblioteki, a następnie nadaj nowemu elementowi nazwę, jaką nosił usunięty element, zachowując pisownię i wielkość liter.

  10. Aby uaktualnić element biblioteki w innych dokumentach serwisu, wybierz polecenie Narzędzia > Biblioteka > Uaktualnij strony.

  11. W wyskakującym menu „Szukaj w” wybierz opcję „Pliki, które używają”.
  12. W przyległym wyskakującym menu, wybierz nazwę właśnie utworzonego elementu biblioteki.
  13. Upewnij się, że pole wyboru Element biblioteki jest zaznaczone, następnie kliknij przycisk Rozpocznij.
  14. Po zakończeniu uaktualniania, kliknij przycisk Zamknij.
Logo Adobe

Zaloguj się na swoje konto