Podręcznik użytkownika Anuluj

Edytowanie, aktualizowanie i usuwanie szablonów

  1. Podręcznik użytkownika programu Dreamweaver
  2. Wprowadzenie
    1. Podstawy projektowania serwisów WWW o elastycznym układzie
    2. Dreamweaver — co nowego
    3. Programowanie zawartości WWW za pomocą programu Dreamweaver — przegląd
    4. Dreamweaver / Popularne pytania
    5. Skróty klawiszowe
    6. Wymagania systemowe programu Dreamweaver
    7. Podsumowanie funkcji
  3. Program Dreamweaver a platforma Creative Cloud
    1. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    2. Biblioteki Creative Cloud w programie Dreamweaver
    3. Używanie plików programu Photoshop w programie Dreamweaver
    4. Praca z programami Adobe Animate oraz Dreamweaver
    5. Wydzielanie przygotowanych do wyświetlania w Internecie plików SVG z bibliotek
  4. Przestrzenie robocze i widoki w programie Dreamweaver
    1. Przestrzeń robocza programu Dreamweaver
    2. Optymalizacja przestrzeni roboczej programu Dreamweaver do programowania wizualnego
    3. Wyszukiwanie plików według nazwy lub zawartości | Mac OS
  5. Konfigurowanie serwisów
    1. Informacje o serwisach programu Dreamweaver
    2. Konfigurowanie lokalnej wersji serwisu
    3. Nawiązywanie połączenia z serwerem publikacji
    4. Konfigurowanie serwera testowego
    5. Importowanie i eksportowanie ustawień serwisu programu Dreamweaver
    6. Przenoszenie istniejących serwisów z serwera zdalnego do lokalnego katalogu głównego serwisu
    7. Funkcje ułatwień dostępu w programie Dreamweaver
    8. Ustawienia zaawansowane
    9. Ustawianie preferencji serwisu dotyczących transferu plików
    10. Określanie ustawień serwera proxy w programie Dreamweaver
    11. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    12. Korzystanie z systemu Git w programie Dreamweaver
  6. Zarządzanie plikami
    1. Tworzenie i otwieranie plików
    2. Zarządzanie plikami i folderami
    3. Odbieranie plików i wysyłanie ich na serwer
    4. Pobieranie plików do edycji i odkładanie ich na serwer
    5. Synchronizacja plików
    6. Porównywanie plików w poszukiwaniu różnic
    7. Maskowanie plików i folderów w serwisie programu Dreamweaver
    8. Włączanie funkcji Uwagi do projektu w serwisach programu Dreamweaver
    9. Zapobieganie potencjalnemu obejściu funkcji Gatekeeper
  7. Układ i projekt
    1. Korzystanie z wizualnych pomocy do układu
    2. Informacje o tworzeniu układu strony za pomocą stylów CSS
    3. Projektowanie elastycznych serwisów WWW z użyciem struktury Bootstrap
    4. Tworzenie i używanie zapytań o media w programie Dreamweaver
    5. Prezentacja zawartości za pomocą tabel
    6. Kolory
    7. Tworzenie reagujących projektów za pomocą układów elastycznej siatki
    8. Narzędzie Extract w programie Dreamweaver
  8. CSS
    1. Podstawowe informacje o stylach CSS
    2. Tworzenie układu strony za pomocą panelu Projektant CSS
    3. Korzystanie z preprocesorów CSS w programie Dreamweaver
    4. Ustawianie preferencji stylów CSS w programie Dreamweaver
    5. Przenoszenie reguł CSS w programie Dreamweaver
    6. Konwertowanie stylu CSS wewnątrz znacznika na regułę CSS w programie Dreamweaver
    7. Posługiwanie się znacznikami DIV
    8. Stosowanie gradientów na tło
    9. Tworzenie i edytowanie efektów przejść CSS3 w programie Dreamweaver
    10. Formatowanie kodu
  9. Zawartość strony i zasoby
    1. Ustawianie właściwości strony
    2. Ustawianie właściwości CSS dla nagłówków i łączy
    3. Praca z tekstem
    4. Znajdowanie i zastępowanie tekstu, znaczników i atrybutów
    5. Panel DOM
    6. Edytowanie w widoku aktywnym
    7. Kodowanie znaków dokumentu w programie Dreamweaver
    8. Zaznaczanie i wyświetlanie elementów w oknie Dokument
    9. Ustawianie właściwości tekstu na panelu Inspektor właściwości
    10. Sprawdzanie pisowni na stronie internetowej
    11. Używanie linii poziomych w programie Dreamweaver
    12. Dodawanie i modyfikowanie kombinacji czcionek w programie Dreamweaver
    13. Praca z zasobami
    14. Wstawianie i aktualizowanie dat w programie Dreamweaver
    15. Tworzenie list ulubionych zasobów w programie Dreamweaver i zarządzanie nimi
    16. Wstawianie i edytowanie obrazów w programie Dreamweaver
    17. Dodawanie obiektów multimedialnych
    18. Dodawanie zawartości wideo w programie Dreamweaver
    19. Wstawianie wideo HTML5
    20. Wstawianie plików SWF
    21. Dodawanie efektów dźwiękowych
    22. Wstawianie obiektów audio HTML5 w programie Dreamweaver
    23. Praca z elementami bibliotek
    24. Stosowanie pisma arabskiego i hebrajskiego w programie Dreamweaver
  10. Łączenie i przeglądanie
    1. Informacje o łączeniu i przeglądaniu stron
    2. Tworzenie łączy
    3. Mapy obrazu
    4. Rozwiązywanie problemów dotyczących łączy
  11. Efekty i widgety jQuery
    1. Używanie widgetów jQuery interfejsu użytkownika i elementów mobilnych w programie Dreamweaver
    2. Używanie efektów jQuery w programie Dreamweaver
  12. Tworzenie kodu serwisów WWW
    1. Informacje o tworzeniu kodu w programie Dreamweaver
    2. Środowisko programistyczne w programie Dreamweaver
    3. Ustawianie preferencji kodowania
    4. Dostosowywanie ustawień kolorowania kodu
    5. Pisanie i edytowanie kodu
    6. Podpowiedzi i uzupełnianie kodu
    7. Zwijanie i rozwijanie kodu
    8. Ponowne wykorzystywanie fragmentów kodu za pomocą funkcji Urywki
    9. Linting: oczyszczanie kodu z błędów
    10. Optymalizacja kodu
    11. Edytowanie kodu w widoku Projekt
    12. Praca z zawartością znacznika HEAD strony
    13. Wstawianie dołączeń po stronie serwera w programie Dreamweaver
    14. Korzystanie z bibliotek znaczników w programie Dreamweaver
    15. Importowanie własnych znaczników do programu Dreamweaver
    16. Używanie zachowań JavaScript (instrukcje ogólne)
    17. Stosowanie wbudowanych zachowań JavaScript
    18. Omówienie języków XML i XSLT
    19. Wykonywanie transformacji XSL po stronie serwera w programie Dreamweaver
    20. Wykonywanie przekształceń XSL po stronie klienta w programie Dreamweaver
    21. Dodawanie encji znaków w kodzie XSLT w programie Dreamweaver
    22. Formatowanie kodu
  13. Obiegi pracy związane z wieloma produktami
    1. Instalowanie i używanie rozszerzeń programu Dreamweaver
    2. Aktualizacje w aplikacji w programie Dreamweaver
    3. Wstawianie dokumentów Microsoft Office w programie Dreamweaver (tylko Windows)
    4. Praca z programami Fireworks i Dreamweaver
    5. Edycja zawartości w stronach programu Dreamweaver za pomocą aplikacji Contribute
    6. Integracja programu Dreamweaver z aplikacją Business Catalyst
    7. Tworzenie spersonalizowanych kampanii rozsyłanych pocztą elektroniczną
  14. Szablony
    1. Informacje o szablonach programu Dreamweaver
    2. Rozpoznawanie szablonów oraz dokumentów opartych na szablonach
    3. Tworzenie szablonu programu Dreamweaver
    4. Tworzenie edytowalnych regionów w szablonach
    5. Tworzenie powtarzalnych regionów i tabel w programie Dreamweaver
    6. Używanie regionów opcjonalnych w szablonach
    7. Definiowanie edytowalnych atrybutów znacznika w programie Dreamweaver
    8. Tworzenie zagnieżdżonych szablonów w programie Dreamweaver
    9. Edytowanie, aktualizowanie i usuwanie szablonów
    10. Eksportowanie i importowanie zawartości XML w programie Dreamweaver
    11. Stosowanie szablonu lub usuwanie go z istniejącego dokumentu
    12. Edycja zawartości w szablonach programu Dreamweaver
    13. Reguły składni dla znaczników szablonu w programie Dreamweaver
    14. Ustawianie preferencji podświetlenia dla regionów szablonów
    15. Korzyści wynikające z używania szablonów w programie Dreamweaver
  15. Urządzenia mobilne i obsługa wielu ekranów
    1. Tworzenie zapytań o media
    2. Zmiana orientacji strony na urządzeniach mobilnych
    3. Tworzenie aplikacji internetowych przeznaczonych na urządzenia mobilne za pomocą programu Dreamweaver
  16. Dynamiczne serwisy, strony i formularze WWW
    1. Podstawowe informacje o aplikacjach internetowych
    2. Konfigurowanie komputera do programowania aplikacji
    3. Rozwiązywanie problemów z połączeniami z bazą danych
    4. Usuwanie skryptów połączenia w programie Dreamweaver
    5. Projektowanie stron dynamicznych
    6. Omówienie źródeł zawartości dynamicznej
    7. Definiowanie źródeł zawartości dynamicznej
    8. Dodawanie dynamicznej zawartości do stron
    9. Modyfikowanie dynamicznej zawartości w programie Dreamweaver
    10. Wyświetlanie rekordów z bazy danych
    11. Udostępnianie aktywnych danych w programie Dreamweaver oraz rozwiązywanie problemów z takimi danymi
    12. Dodawanie własnych zachowań serwerowych w programie Dreamweaver
    13. Tworzenie formularzy w programie Dreamweaver
    14. Zbieranie informacji od użytkowników za pomocą formularzy
    15. Tworzenie oraz włączanie formularzy ColdFusion w programie Dreamweaver
    16. Tworzenie formularzy WWW
    17. Rozszerzona obsługa elementów formularza w języku HTML5
    18. Tworzenie formularzy za pomocą programu Dreamweaver
  17. Tworzenie aplikacji metodą graficzną
    1. Tworzenie stron wzorca i szczegółów w programie Dreamweaver
    2. Tworzenie stron wyszukiwania i wyników
    3. Tworzenie strony wstawiania rekordów
    4. Tworzenie strony uaktualniania rekordów w programie Dreamweaver
    5. Tworzenie stron usuwania rekordów w programie Dreamweaver
    6. Używanie poleceń ASP do modyfikacji bazy danych w programie Dreamweaver
    7. Tworzenie strony rejestracji
    8. Tworzenie strony logowania
    9. Tworzenie strony, do której dostęp będą mieli tylko uwierzytelnieni użytkownicy
    10. Zabezpieczanie folderów w aplikacji ColdFusion za pomocą programu Dreamweaver
    11. Korzystanie ze składników ColdFusion w programie Dreamweaver
  18. Testowanie, podgląd i publikacja serwisów WWW
    1. Podgląd stron
    2. Podgląd stron WWW programu Dreamweaver na wielu urządzeniach
    3. Testowanie serwisu programu Dreamweaver

 

Informacje o edytowaniu, aktualizowaniu i usuwaniu szablonów w programie Dreamweaver oraz aktualizowaniu szablonów w serwisie Contribute.

Kiedy wykonasz zmiany i zapiszesz szablon, wszystkie dokumenty oparte na tym szablonie zostaną uaktualnione. Możesz także ręcznie uaktualnić dokument oparty na szablonie lub, w razie potrzeby, cały serwis.

Uwaga:

Aby edytować szablony dla serwisu programu Contribute, należy użyć programu Dreamweaver. Szablonów nie można edytować w programie Contribute.

Skorzystaj z kategorii Szablony na panelu Zasoby, aby zarządzać istniejącymi szablonami, w tym zmieniać nazwy plików szablonów oraz usuwać je.

Za pomocą panelu Zasoby można wykonywać następujące zadania administracyjne:

  • Tworzenie szablonu

  • Zmiana i uaktualnianie szablonów

  • Nadawania i usuwanie szablonu z istniejącego dokumentu

Program Dreamweaver sprawdza składnię podczas zapisywania szablonu, ale dobrym pomysłem jest ręczne sprawdzenie składni szablonu podczas jego edytowania.

Otwieranie szablonu do edycji

Możesz otworzyć bezpośrednio szablon do edycji lub otworzyć dokument oparty na szablonie, a następnie otworzyć do edycji dołączony szablon.

Kiedy robisz zmiany w szablonie, Dreamweaver prosi o uaktualnienie dokumentów opartych na szablonie.

Uwaga:

Możesz także ręcznie zaktualizować dokumenty na podstawie zmian w szablonie.

Otwieranie i edytowanie pliku szablonu

  1. Przejdź do panelu Zasoby (Okno > Zasoby) i kliknij ikonę Szablony po lewej stronie panelu.

    Panel Zasoby wyświetla listę wszystkich dostępnych szablonów dla twojego serwisu i wyświetla podgląd wybranego.

  2. Wykonaj jedną z następujących czynności na liście wszystkich szablonów:
    • Kliknij szablon prawym przyciskiem myszy i wybierz opcję Edytuj.
    • Dwukrotnie kliknij nazwę szablonu, który chcesz edytować.
    • Wybierz szablon do edycji, a następnie kliknij przycisk Edycja znajdujący się na dole panelu Zasoby.
  3. Zapisz szablon. Dreamweaver zapyta czy chcesz uaktualnić strony w oparciu o szablon.
  4. Kliknij opcję Uaktualnij, aby zaktualizować wszystkie dokumenty oparte na zmodyfikowanym szablonie. Kliknij opcję Nie uaktualniaj, jeżeli nie chcesz uaktualniać dokumentów opartych na zmodyfikowanym szablonie.

    Program Dreamweaver wyświetla dziennik wskazujący, które pliki zaktualizowano.

Otwieranie i modyfikowanie szablonu dołączonego do bieżącego dokumentu

  1. Otwórz dokument oparty na szablonie w oknie Dokument.
  2. Wybierz polecenie Narzędzia > Szablony > Otwórz dołączony szablon.

  3. Modyfikowanie treści szablonu
    Uwaga:

    Aby zmodyfikować właściwości strony szablonu, wybierz polecenie Plik > Właściwości strony. (Dokumenty oparte na szablonie dziedziczą właściwości strony z szablonu).

  4. Zapisz szablon. Dreamweaver zapyta czy chcesz uaktualnić strony w oparciu o szablon.
  5. Kliknij opcję Uaktualnij, aby zaktualizować wszystkie dokumenty oparte na zmodyfikowanym szablonie. Kliknij opcję Nie uaktualniaj, jeżeli nie chcesz uaktualniać dokumentów opartych na zmodyfikowanym szablonie.

    Program Dreamweaver wyświetla dziennik wskazujący, które pliki zaktualizowano.

Modyfikowanie nazwy szablonu

  1. Przejdź do panelu Zasoby (Okno > Zasoby) i kliknij ikonę Szablony po lewej stronie panelu.

  2. Kliknij nazwę szablonu, aby go zaznaczyć
  3. Kliknij nazwę ponownie, aby tekst stał się edytowalnym i wprowadź nową nazwę.

    Jest to metoda identyczna z metodą zmiany nazwy w Eksploratorze Windows (Windows) lub programie Finder (Macintosh). Podobnie jak w przypadku Eksploratora Windows oraz programu Finder, trzeba zrobić krótkie przerwy pomiędzy kliknięciami. Nie należy dwukrotnie klikać na nazwę, ponieważ to powoduje otwarcie szablonu do edycji.

  4. Kliknij na inny obszar w panelu Zasoby lub wciśnij Enter (Windows) lub Return (Macintosh), aby wprowadzić zmiany/

    Pojawi się zapytanie, czy chcesz uaktualnić dokumenty oparte na tym szablonie.

  5. Aby uaktualnić wszystkie dokumenty w serwisie oparte na tym szablonie, kliknij opcję Uaktualnij. Kliknij opcję Nie uaktualniaj, jeśli nie chcesz uaktualniać dokumentu w oparciu o ten szablon.

Modyfikowanie opisu szablonu

W trakcie tworzenia strony z istniejącego szablonu opis szablonu jest wyświetlany w oknie dialogowym Nowy dokument.

  1. Wybierz polecenie Narzędzia > Szablony > Opis.

  2. Zmień opis i kliknij przycisk OK w oknie dialogowym Opis szablonu.

Ręcznie aktualizowanie dokumentów opartych na szablonach

Kiedy zrobisz zmiany w szablonie, program Dreamweaver prosi o uaktualnienie dokumentów opartych na szablonie, ale możesz także ręcznie zaktualizować dokumenty lub cały serwis na podstawie zmian w szablonie Ręczne uaktualnianie dokumentów opartych na szablonie jest tożsame z ponownym nadaniem szablonu.

Zastosowanie zmian w szablonie w bieżącym dokumencie opartym na szablonie

  1. Wyświetl dokument w oknie Dokument.
  2. Wybierz polecenie Narzędzia > Szablony > Uaktualnij bieżącą stronę.

    Program Dreamweaver aktualizuje dokument na podstawie zmian w szablonie.

Uaktualnienie całego serwisu lub wszystkich dokumentów, które używają określonego szablonu

Możesz zaktualizować wszystkie strony serwisu lub tylko te, które są oparte na określonym szablonie.

  1. Wybierz polecenie Narzędzia > Szablony > Uaktualnij strony.

  2. W menu „Szukaj w” wykonaj jedną z następujących czynności:
    • Aby zaktualizować wszystkie pliki w wybranym serwisie w oparciu o ich szablony, wybierz opcję Cały serwis, a następnie nazwę serwisu z menu wyskakującego obok.

    • Aby zaktualizować pliki w oparciu o wybrany szablon, wybierz opcję „Pliki, które używają”, a następnie nazwę szablonu z menu wyskakującego obok.

    Aktualizacja dokumentów w szablonach
    Aktualizacja dokumentów w szablonach

  3. Upewnij się, że w sekcji Uaktualnij została wybrana opcja Szablony.
  4. Jeżeli nie chcesz widzieć dziennika plików, które program Dreamweaver aktualizuje, usuń zaznaczenie opcji Pokaż dziennik. W innych przypadkach zostaw tę opcję zaznaczoną.
  5. Kliknij przycisk Start, aby uaktualnić pliki według zadanych ustawień. Jeżeli wybrano opcję Pokaż log, program Dreamweaver wyświetli informacje na temat plików, które zamierzał uaktualnić, dołączając także informacje, które z nich zostały zaktualizowane pomyślnie.
  6. Kliknij przycisk Zamknij.

Uaktualnianie szablonów w serwisie Contribute

Użytkownicy programu Contribute nie mogą dokonywać zmian w szablonach programu Dreamweaver. Można jednak użyć programu Dreamweaver, aby zmodyfikować szablon serwisu Contribute.

Uaktualniając szablony na serwerze Contribute trzeba mieć następujące przesłanki na względzie:

  • Program Contribute pobiera nowe i zmienione szablony z serwera tylko kiedy jest uruchamiany i kiedy użytkownik programu zmienia parametry połączenia. Jeżeli zrobisz zmiany w szablonie w momencie, kiedy użytkownik programu Contribute edytuje plik oparty na tym szablonie, nie będzie on widział zmian w szablonie do czasu kiedy ponownie nie uruchomi programu Contribute.

  • Jeżeli usuniesz edytowalny region z szablony, użytkownik programu Contribute edytujący stronę opartą na tym szablonie może być skonfundowany, nie wiedząc co ma zrobić z treścią, która była w tym edytowalnym szablonie.

Aby zaktualizować szablon na serwerze Contribute, wykonaj następujące kroki:

  1. Otwórz szablon programu Contribute w programie Dreamweaver, zmodyfikuj go, a następnie zapisz. Instrukcje na ten temat znajdują się w części Otwieranie szablonu do edycji.
  2. Powiadom wszystkich użytkowników programu Contribute, którzy pracują nad serwisem, aby go ponownie uruchomili.

Usuwanie pliku szablonu

  1. Przejdź do panelu Zasoby (Okno > Zasoby) i kliknij ikonę Szablony po lewej stronie panelu.

  2. Kliknij nazwę szablonu, aby go zaznaczyć.
  3. Kliknij przycisk Usuń  znajdujący się na dole panelu, a następnie potwierdź, że chcesz usunąć szablon.
    Uwaga:

    Po usunięciu pliku szablony, nie możesz go już odzyskać. Plik szablonu jest usunięty z serwera.

    Dokumenty oparte na usuniętym szablonie nie zostały odłączone od szablonu; zachowują strukturę oraz edytowalne regiony, które miał szablon zanim został usunięty. Możesz zmienić taki dokument w plik HTML bez edytowalnych i zablokowanych regionów.

Logo Adobe

Zaloguj się na swoje konto