Podręcznik użytkownika Anuluj

Ustawianie preferencji kodowania

  1. Podręcznik użytkownika programu Dreamweaver
  2. Wprowadzenie
    1. Podstawy projektowania serwisów WWW o elastycznym układzie
    2. Dreamweaver — co nowego
    3. Programowanie zawartości WWW za pomocą programu Dreamweaver — przegląd
    4. Dreamweaver / Popularne pytania
    5. Skróty klawiszowe
    6. Wymagania systemowe programu Dreamweaver
    7. Podsumowanie funkcji
  3. Program Dreamweaver a platforma Creative Cloud
    1. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    2. Biblioteki Creative Cloud w programie Dreamweaver
    3. Używanie plików programu Photoshop w programie Dreamweaver
    4. Praca z programami Adobe Animate oraz Dreamweaver
    5. Wydzielanie przygotowanych do wyświetlania w Internecie plików SVG z bibliotek
  4. Przestrzenie robocze i widoki w programie Dreamweaver
    1. Przestrzeń robocza programu Dreamweaver
    2. Optymalizacja przestrzeni roboczej programu Dreamweaver do programowania wizualnego
    3. Wyszukiwanie plików według nazwy lub zawartości | Mac OS
  5. Konfigurowanie serwisów
    1. Informacje o serwisach programu Dreamweaver
    2. Konfigurowanie lokalnej wersji serwisu
    3. Nawiązywanie połączenia z serwerem publikacji
    4. Konfigurowanie serwera testowego
    5. Importowanie i eksportowanie ustawień serwisu programu Dreamweaver
    6. Przenoszenie istniejących serwisów z serwera zdalnego do lokalnego katalogu głównego serwisu
    7. Funkcje ułatwień dostępu w programie Dreamweaver
    8. Ustawienia zaawansowane
    9. Ustawianie preferencji serwisu dotyczących transferu plików
    10. Określanie ustawień serwera proxy w programie Dreamweaver
    11. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    12. Korzystanie z systemu Git w programie Dreamweaver
  6. Zarządzanie plikami
    1. Tworzenie i otwieranie plików
    2. Zarządzanie plikami i folderami
    3. Odbieranie plików i wysyłanie ich na serwer
    4. Pobieranie plików do edycji i odkładanie ich na serwer
    5. Synchronizacja plików
    6. Porównywanie plików w poszukiwaniu różnic
    7. Maskowanie plików i folderów w serwisie programu Dreamweaver
    8. Włączanie funkcji Uwagi do projektu w serwisach programu Dreamweaver
    9. Zapobieganie potencjalnemu obejściu funkcji Gatekeeper
  7. Układ i projekt
    1. Korzystanie z wizualnych pomocy do układu
    2. Informacje o tworzeniu układu strony za pomocą stylów CSS
    3. Projektowanie elastycznych serwisów WWW z użyciem struktury Bootstrap
    4. Tworzenie i używanie zapytań o media w programie Dreamweaver
    5. Prezentacja zawartości za pomocą tabel
    6. Kolory
    7. Tworzenie reagujących projektów za pomocą układów elastycznej siatki
    8. Narzędzie Extract w programie Dreamweaver
  8. CSS
    1. Podstawowe informacje o stylach CSS
    2. Tworzenie układu strony za pomocą panelu Projektant CSS
    3. Korzystanie z preprocesorów CSS w programie Dreamweaver
    4. Ustawianie preferencji stylów CSS w programie Dreamweaver
    5. Przenoszenie reguł CSS w programie Dreamweaver
    6. Konwertowanie stylu CSS wewnątrz znacznika na regułę CSS w programie Dreamweaver
    7. Posługiwanie się znacznikami DIV
    8. Stosowanie gradientów na tło
    9. Tworzenie i edytowanie efektów przejść CSS3 w programie Dreamweaver
    10. Formatowanie kodu
  9. Zawartość strony i zasoby
    1. Ustawianie właściwości strony
    2. Ustawianie właściwości CSS dla nagłówków i łączy
    3. Praca z tekstem
    4. Znajdowanie i zastępowanie tekstu, znaczników i atrybutów
    5. Panel DOM
    6. Edytowanie w widoku aktywnym
    7. Kodowanie znaków dokumentu w programie Dreamweaver
    8. Zaznaczanie i wyświetlanie elementów w oknie Dokument
    9. Ustawianie właściwości tekstu na panelu Inspektor właściwości
    10. Sprawdzanie pisowni na stronie internetowej
    11. Używanie linii poziomych w programie Dreamweaver
    12. Dodawanie i modyfikowanie kombinacji czcionek w programie Dreamweaver
    13. Praca z zasobami
    14. Wstawianie i aktualizowanie dat w programie Dreamweaver
    15. Tworzenie list ulubionych zasobów w programie Dreamweaver i zarządzanie nimi
    16. Wstawianie i edytowanie obrazów w programie Dreamweaver
    17. Dodawanie obiektów multimedialnych
    18. Dodawanie zawartości wideo w programie Dreamweaver
    19. Wstawianie wideo HTML5
    20. Wstawianie plików SWF
    21. Dodawanie efektów dźwiękowych
    22. Wstawianie obiektów audio HTML5 w programie Dreamweaver
    23. Praca z elementami bibliotek
    24. Stosowanie pisma arabskiego i hebrajskiego w programie Dreamweaver
  10. Łączenie i przeglądanie
    1. Informacje o łączeniu i przeglądaniu stron
    2. Tworzenie łączy
    3. Mapy obrazu
    4. Rozwiązywanie problemów dotyczących łączy
  11. Efekty i widgety jQuery
    1. Używanie widgetów jQuery interfejsu użytkownika i elementów mobilnych w programie Dreamweaver
    2. Używanie efektów jQuery w programie Dreamweaver
  12. Tworzenie kodu serwisów WWW
    1. Informacje o tworzeniu kodu w programie Dreamweaver
    2. Środowisko programistyczne w programie Dreamweaver
    3. Ustawianie preferencji kodowania
    4. Dostosowywanie ustawień kolorowania kodu
    5. Pisanie i edytowanie kodu
    6. Podpowiedzi i uzupełnianie kodu
    7. Zwijanie i rozwijanie kodu
    8. Ponowne wykorzystywanie fragmentów kodu za pomocą funkcji Urywki
    9. Linting: oczyszczanie kodu z błędów
    10. Optymalizacja kodu
    11. Edytowanie kodu w widoku Projekt
    12. Praca z zawartością znacznika HEAD strony
    13. Wstawianie dołączeń po stronie serwera w programie Dreamweaver
    14. Korzystanie z bibliotek znaczników w programie Dreamweaver
    15. Importowanie własnych znaczników do programu Dreamweaver
    16. Używanie zachowań JavaScript (instrukcje ogólne)
    17. Stosowanie wbudowanych zachowań JavaScript
    18. Omówienie języków XML i XSLT
    19. Wykonywanie transformacji XSL po stronie serwera w programie Dreamweaver
    20. Wykonywanie przekształceń XSL po stronie klienta w programie Dreamweaver
    21. Dodawanie encji znaków w kodzie XSLT w programie Dreamweaver
    22. Formatowanie kodu
  13. Obiegi pracy związane z wieloma produktami
    1. Instalowanie i używanie rozszerzeń programu Dreamweaver
    2. Aktualizacje w aplikacji w programie Dreamweaver
    3. Wstawianie dokumentów Microsoft Office w programie Dreamweaver (tylko Windows)
    4. Praca z programami Fireworks i Dreamweaver
    5. Edycja zawartości w stronach programu Dreamweaver za pomocą aplikacji Contribute
    6. Integracja programu Dreamweaver z aplikacją Business Catalyst
    7. Tworzenie spersonalizowanych kampanii rozsyłanych pocztą elektroniczną
  14. Szablony
    1. Informacje o szablonach programu Dreamweaver
    2. Rozpoznawanie szablonów oraz dokumentów opartych na szablonach
    3. Tworzenie szablonu programu Dreamweaver
    4. Tworzenie edytowalnych regionów w szablonach
    5. Tworzenie powtarzalnych regionów i tabel w programie Dreamweaver
    6. Używanie regionów opcjonalnych w szablonach
    7. Definiowanie edytowalnych atrybutów znacznika w programie Dreamweaver
    8. Tworzenie zagnieżdżonych szablonów w programie Dreamweaver
    9. Edytowanie, aktualizowanie i usuwanie szablonów
    10. Eksportowanie i importowanie zawartości XML w programie Dreamweaver
    11. Stosowanie szablonu lub usuwanie go z istniejącego dokumentu
    12. Edycja zawartości w szablonach programu Dreamweaver
    13. Reguły składni dla znaczników szablonu w programie Dreamweaver
    14. Ustawianie preferencji podświetlenia dla regionów szablonów
    15. Korzyści wynikające z używania szablonów w programie Dreamweaver
  15. Urządzenia mobilne i obsługa wielu ekranów
    1. Tworzenie zapytań o media
    2. Zmiana orientacji strony na urządzeniach mobilnych
    3. Tworzenie aplikacji internetowych przeznaczonych na urządzenia mobilne za pomocą programu Dreamweaver
  16. Dynamiczne serwisy, strony i formularze WWW
    1. Podstawowe informacje o aplikacjach internetowych
    2. Konfigurowanie komputera do programowania aplikacji
    3. Rozwiązywanie problemów z połączeniami z bazą danych
    4. Usuwanie skryptów połączenia w programie Dreamweaver
    5. Projektowanie stron dynamicznych
    6. Omówienie źródeł zawartości dynamicznej
    7. Definiowanie źródeł zawartości dynamicznej
    8. Dodawanie dynamicznej zawartości do stron
    9. Modyfikowanie dynamicznej zawartości w programie Dreamweaver
    10. Wyświetlanie rekordów z bazy danych
    11. Udostępnianie aktywnych danych w programie Dreamweaver oraz rozwiązywanie problemów z takimi danymi
    12. Dodawanie własnych zachowań serwerowych w programie Dreamweaver
    13. Tworzenie formularzy w programie Dreamweaver
    14. Zbieranie informacji od użytkowników za pomocą formularzy
    15. Tworzenie oraz włączanie formularzy ColdFusion w programie Dreamweaver
    16. Tworzenie formularzy WWW
    17. Rozszerzona obsługa elementów formularza w języku HTML5
    18. Tworzenie formularzy za pomocą programu Dreamweaver
  17. Tworzenie aplikacji metodą graficzną
    1. Tworzenie stron wzorca i szczegółów w programie Dreamweaver
    2. Tworzenie stron wyszukiwania i wyników
    3. Tworzenie strony wstawiania rekordów
    4. Tworzenie strony uaktualniania rekordów w programie Dreamweaver
    5. Tworzenie stron usuwania rekordów w programie Dreamweaver
    6. Używanie poleceń ASP do modyfikacji bazy danych w programie Dreamweaver
    7. Tworzenie strony rejestracji
    8. Tworzenie strony logowania
    9. Tworzenie strony, do której dostęp będą mieli tylko uwierzytelnieni użytkownicy
    10. Zabezpieczanie folderów w aplikacji ColdFusion za pomocą programu Dreamweaver
    11. Korzystanie ze składników ColdFusion w programie Dreamweaver
  18. Testowanie, podgląd i publikacja serwisów WWW
    1. Podgląd stron
    2. Podgląd stron WWW programu Dreamweaver na wielu urządzeniach
    3. Testowanie serwisu programu Dreamweaver

 

Informacje o ustawianiu preferencji kodowania, motywów kodu, formatowania i poprawiania kodu w programie Dreamweaver.

Preferencje kodowania, dotyczące między innymi formatowania i kolorów kodu, pozwalają dostosować wygląd kodu do własnych potrzeb.

Uwaga:
  • Aby ustawić zaawansowane preferencje, użyj Edytora biblioteki znaczników (zobacz Zarządzanie bibliotekami znaczników).
  • Dreamweaver obsługuje formatowanie plików CSS, JS i PHP. Informacje o tym, jak dostosowywać sposób formatowania kodu PHP, CSS i JS, podano w artykule Formatowanie kodu.

Określanie ustawień wyglądu kodu

W menu Widok > Opcje widoku Kod można ustawić opcje zawijania wierszy, wyświetlania numerów wierszy kodu, kolorowania składni w poszczególnych elementów kodu, wcięć oraz sposobu wyświetlania ukrytych znaków.

  1. Wyświetl dokument w widoku Kod lub Inspektorze kodu.
  2. Wybierz polecenie Widok > Opcje widoku Kod.

  3. Zaznacz lub wyłącz dowolne z następujących opcji:

    Zawijanie tekstu

    Zawija kod tak, aby można było go przeglądać bez przewijania okna w poziomie. Ta opcja nie powoduje wstawiania znaków podziałów wiersza, pozwala ona tylko na łatwiejsze czytanie kodu.

    Numery wierszy

    Wyświetla numery wierszy obok kodu.

    Ukryte znaki

    Wyświetla specjalne znaki w miejscu odstępów. Na przykład kropka zastępuje każdą spację, podwójny szewron (strzałka skierowana w dół) — każdy znak tabulatora, a znacznik akapitu zastępuje każdy znak końca wiersza.

    Uwaga:

    Miękkie znaki podziału wiersza, których program Dreamweaver używa do zawijania tekstu, nie są oznaczane za pomocą symbolu akapitu.

    Oznaczanie składni kolorami

    Włącza i wyłącza kolorowanie składni. Więcej informacji na temat zmieniania schematu kolorowania można znaleźć w temacie Ustawianie kolorowania kodu.

    Automatyczne wcięcie

    Powoduje, że kod zostaje wcięty automatycznie za każdym razem, gdy wciśniesz Enter w czasie pisania kodu. Nowe linie kodu są wcinanie na tym samym poziomie co poprzednia linia. Więcej informacji na temat zmieniania odstępów wcięcia można znaleźć w opisie opcji Rozmiar tabulatora w temacie Zmiana formatu kodu.

Zmiana formatu kodu

Wygląd kodu można zmienić, określając preferencje formatowania, takie jak wcięcie, długość wierszy oraz wielkość liter w nazwach znaczników oraz atrybutów.

Wszystkie opcje formatowania kodu oprócz opcji Przesłaniaj wielkość są stosowane automatycznie tylko do nowo tworzonych dokumentów oraz fragmentów dodawanych do dokumentów.

Aby zmienić formatowanie istniejących dokumentów HTML, otwórz dokument i wybierz polecenie Edycja > Kod > Zastosuj formatowanie źródła.

  1. Wybierz polecenie Edycja > Preferencje.
  2. Z listy Kategoria po lewej stronie wybierz pozycję Formatowanie kodu.
  3. Ustaw dowolne spośród poniższych opcji:

    Wcięcie

    Wskazuje, czy kod generowany przez program Dreamweaver powinien być wcięty (zgodnie z regułami wcięcia określonymi w tych preferencjach), czy też nie.

    Uwaga:

    Większość opcji w tym oknie dialogowym ma zastosowanie tylko do kodu generowanego przez program Dreamweaver, a nie do kodu wpisywanego przez użytkownika. Aby każdy nowy wiersz miał takie samo wcięcie, jak poprzedni, wybierz polecenie Widok > Opcje widoku Kod, a następnie opcję Autowcięcie. Więcej informacji znajduje się w części Ustawianie kolorowania kodu.

    Z

    (Pole tekstowe oraz menu wyskakujące) Określa liczbę spacji oraz tabulatorów stosowanych przez program Dreamweaver do sformatowania wcięcia generowanego kodu. Na przykład wpisanie w tym polu tekstowym liczby 3 i wybranie opcji Tabulatory z menu wyskakującego spowoduje, że kod generowany przez program Dreamweaver będzie wcięty za pomocą trzech tabulatorów na każdym poziomie zagnieżdżenia.

    Rozmiar tabulatora

    Określa, ile znaków szerokości będzie miał w oknie kodu każdy tabulator. Jeżeli na przykład rozmiar tabulatora został ustawiony na wartość 4, każdy tabulator wyświetlany w widoku Kod będzie miał szerokość czterech spacji. Ponadto jeśli opcja Wcięcie przez jest ustawiona na wartość 3 tabulatorów, to kod generowany przez program Dreamweaver zostanie przesunięty za pomocą trzech znaków tabulacji na każdym poziomie zagnieżdżenia, co spowoduje, ze w widoku Kod odstępy będą miały szerokość 12 znaków.

    Uwaga:

    Program Dreamweaver tworzy wcięcia za pomocą spacji lub tabulatorów, nie konwertuje natomiast wielu spacji na tabulator, gdy wstawia kod.

    Emmet

    Wybierz tę opcję, jeśli planujesz używać skrótów Emmet podczas wpisywania kodu. Gdy ta opcja jest zaznaczona, po naciśnięciu klawisza Tab program Dreamweaver przekształci skrót Emmet w pełny kod HTML lub CSS. Więcej informacji: Używanie pakietu narzędzi Emmet w połączeniu z programem Dreamweaver.

    Typ podziałów wierszy

    Określa typ zdalnego serwera (Windows, Macintosh lub UNIX), na którym znajduje się twój zdalny serwis. Wybranie odpowiedniego typu znaków końca wiersza powoduje, że kod źródłowy HTML będzie wyglądał poprawnie, kiedy będzie oglądany na zdalnym serwerze. To ustawienie jest przydatne, gdy pracujesz z zewnętrznym edytorem tekstowym, który rozpoznaje tylko niektóre znaki końca wiersza. Przykład: użyj CR LF (Windows) jeżeli zewnętrznym edytorem jest Notatnik; użyj znaku CR (Macintosh), jeżeli zewnętrznym edytorem jest SimpleText.

    Uwaga:

    W przypadku serwerów korzystających z protokołu FTP opcja ta ma znaczenie tylko w trybie transmisji binarnej, natomiast w trybie transmisji ASCII program Dreamweaver pomija tę opcję. W przypadku pobierania plików w trybie ASCII program Dreamweaver ustawia znaki końca wiersza zgodnie z ustawieniami systemu operacyjnego komputera. Gdy wczytujesz pliki w tym trybie, wszystkie znaki końca wiersza mają postać CR LF.

    Znacznik TD: Nie wstawiaj przerwy wewnątrz znacznika TD

    Rozwiązuje problem wyświetlania, który występuje w starszych wersjach przeglądarek, kiedy następuje odstęp lub łamanie linii bezpośrednio po znaczniku <td> lub bezpośrednio przed znacznikiem </td>. Gdy opcja ta jest zaznaczona, program Dreamweaver nie zapisuje znaków końca wiersza bezpośrednio po znacznikach <td> oraz przed znacznikiem </td>, nawet jeżeli formatowanie w Bibliotece znaczników wskazuje, że zakończenie wiersza powinno znaleźć się w tym miejscu.

    Formatowanie zaawansowane

    Pozwala ustawić opcje formatowania poszczególnych znaczników i atrybutów w Edytorze biblioteki znaczników.

    Znak odstępu

    (Tylko wersja japońska) Umożliwia wybranie znaku &nbsp; albo znaku spacji Zenkaku do użycia w kodzie HTML. Znak odstępu wybrany w tej opcji będzie stosowany w pustych znacznikach podczas tworzenia tabeli oraz w sytuacji, gdy zostanie włączona opcja „Dopuszczaj wiele kolejnych spacji” dla stron w kodowaniu japońskim.

    Minimalny rozmiar zwijania kodu

    Domyślny rozmiar zwijania kodu to dwa wiersze. Przy tym ustawieniu domyślnym zwijane będą wszystkie fragmenty, które zawierają co najmniej dwa wiersze kodu. Fragmenty kodu krótsze niż dwa wiersze można zwijać po zaznaczeniu takiego kodu. Więcej informacji: Zwijanie i rozwijanie kodu.

Ustawianie preferencji poprawiania kodu

Za pomocą preferencji poprawiania kodu można określić, jak i kiedy program Dreamweaver ma modyfikować kod użytkownika podczas otwierania dokumentów, kopiowania i wklejania elementów formularzy oraz wstawiania wartości atrybutów i adresów URL za pomocą takich narzędzi, jak Inspektor właściwości. Te preferencje nie mają zastosowania podczas edytowania kodu HTML oraz skryptów w widoku Kod.

Jeżeli wyłączy się opcje poprawiania kodu, w oknie Dokument będą wyświetlane nieprawidłowe elementy znaczników kodu HTML, który inaczej zostałby poprawiony.

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh).
  2. Z listy Kategoria po lewej stronie wybierz pozycję Przebudowa kodu.
  3. Ustaw dowolne spośród poniższych opcji:

    Napraw błędnie zagnieżdżone i niezamknięte znaczniki

    Poprawia nakładające się znaczniki Na przykład kod <b><i>tekst</b></i> zostanie poprawiony na <b><i>tekst</i></b>. Ta opcja powoduje także wstawienie znaków cudzysłowu oraz zamykających nawiasów, jeżeli ich brakuje.

    Zmień nazwy pozycji formularza podczas wklejania

    Zapewnia, że nie masz zduplikowanych nazw obiektów formularza. Ta opcja jest domyślnie włączona.

    Uwaga:

    W przeciwieństwie do innych ustawień w tym oknie dialogowym preferencji, ta opcja nie jest stosowana w czasie otwierania dokumentu, lecz podczas kopiowania i wklejania elementów formularza.

    Usuń dodatkowe znaczniki końcowe

    Usuwa zamykające znaczniki, które nie mają odpowiadających im znaczników otwierających.

    Ostrzegaj o naprawianiu lub usuwaniu znaczników

    Wyświetla opis technicznie nieprawidłowego dokumentu HTML, który program Dreamweaver usiłował poprawić. Opis zawiera informacje o położeniu problemu (z podaniem numeru wiersza oraz kolumny), co pozwala odszukać poprawkę oraz upewnić się, że jest poprawnie renderowana.

    Nigdy nie przebudowuj kodu: w plikach z rozszerzeniami

    Wyłącza poprawianie kodu przez program Dreamweaver w plikach mających określone rozszerzenia. Ta opcja jest szczególnie użyteczna w przypadku plików, które używają niestandardowych znaczników.

    Zakoduj znaki <, >, & oraz " w wartościach atrybutów za pomocą znaku &

    Powoduje, że wartości atrybutów wprowadzane lub edytowane za pomocą narzędzi programu Dreamweaver (takich jak Inspektor właściwości) będą zawierać tylko dozwolone znaki. Ta opcja jest domyślnie włączona.

    Uwaga:

    Ta opcja i następujące opcje nie mają zastosowania do adresu URL, który wpisujesz w widoku Kod. Podobnie, nie powoduje ona zmiany w kodzie już istniejącym w pliku.

    Nie koduj znaków specjalnych

    Zapobiega zmianie adresu URL przez program Dreamweaver na zawierający tylko dozwolone znaki. Ta opcja jest domyślnie włączona.

    Zakoduj znaki specjalne w adresie URL, używając znaku &#

    Powoduje, że adresy URL wprowadzane lub edytowane za pomocą narzędzi programu Dreamweaver (takich jak Inspektor właściwości) będą mogły zawierać tylko dozwolone znaki.

    Zakoduj znaki specjalne w adresie URL, używając znaku %

    Działa w ten sam sposób jak poprzednia opcja, ale używa innej metody zakodowania znaków specjalnych. Ta metoda zakodowania znaków (za pomocą znaku procenta) jest bardziej zgodna ze starszymi wersjami przeglądarek, ale nie działa dobrze z znakami z niektórych języków.

Ustawianie preferencji wskazówek do kodu

Preferencje podpowiedzi do kodu umożliwiają skonfigurowanie sposobu działania tej funkcji. 

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh).

    Ustawianie preferencji wskazówek do kodu

  2. Z listy kategorii po lewej stronie wybierz pozycję Podpowiedzi do kodu.

  3. Ustaw dowolne spośród poniższych opcji:

    Zamykaj znaczniki

    Określa sposób, w jaki program Dreamweaver będzie zamykać znaczniki.

    • Po wpisaniu „</” – 
    • Po wpisaniu znaku „>” znacznika otwierającego — zaznacz tę opcję, jeśli program Dreamweaver ma automatycznie dodawać znacznik zamykający po wpisaniu znaku zamykającego znacznik otwierający.
    • Nigdy — zaznacz tę opcję, jeśli nie chcesz, aby program Dreamweaver automatycznie dodawał znaczniki zamykające.

    Włączanie podpowiedzi do kodu

    Zaznacz tę opcję, aby włączyć lub wyłączyć podpowiedzi i uzupełnianie kodu w programie Dreamweaver. Więcej informacji na temat tych funkcji w programie Dreamweaver: Podpowiedzi i uzupełnianie kodu.

    Włącz podpowiedzi opisowe

    Zaznacz tę opcję, aby włączyć wyświetlanie opisów wraz z podpowiedziami. Są to opisy zawierające dodatkowe informacje o tworzonym właśnie kodzie.

    Automatycznie wstawiaj klamry  Gdy ta opcja jest zaznaczona, program automatycznie wstawia nawias zamykający, jeśli użytkownik wpisał nawias otwierający. Gdy ta opcja nie jest zaznaczona, po wstawieniu nawiasu otwierającego przez użytkownika program nie wstawia nawiasu zamykającego. Dotyczy to wszystkich rodzajów nawiasów oraz wszystkich typów plików (html, php,css, js).

    Automatycznie wstawiaj cudzysłowy  Gdy ta opcja jest zaznaczona, program automatycznie wstawia cudzysłów zamykający, jeśli użytkownik wpisał cudzysłów otwierający. Gdy ta opcja nie jest zaznaczona, po wstawieniu cudzysłowu otwierającego przez użytkownika program nie wstawia cudzysłowu zamykającego. Dotyczy to zarówno cudzysłowów podwójnych, jak i pojedynczych we wszystkich typach plików (html, php,css, js).

Ustawianie preferencji autouzupełniania kodu

Opcje automatycznego zamykania nawiasów i cudzysłowów można włączać i wyłączać, wykonując następujące czynności:

  1. Otwórz plik brackets.json z następującej lokalizacji:

    • Win: %appdata%\Adobe\Dreamweaver CC 2018\en_US\Configuration\Brackets\
    • Mac: ~/Library/Application Support/Adobe/Dreamweaver CC 2018/en_US/Configuration/Brackets/
  2. Aby wyłączyć automatyczne zamykanie nawiasów, ustaw parametr autoCloseBraces na wartość False.

  3. Aby wyłączyć automatyczne wstawianie pasujących cudzysłowów, ustaw parametr autoCloseQuotes na wartość Flase.

    Natomiast jeśli chcesz włączyć automatyczne zamykanie nawiasów i dodawanie cudzysłowów, ustaw powyższe parametry na wartość True.

    Ustawianie preferencji autouzupełniania kodu w programie Dreamweaver
    Ustawianie preferencji autouzupełniania kodu w programie Dreamweaver

  4. Zapisz plik .json i ponownie uruchom program Dreamweaver.

Ustawianie preferencji PHP

W programie można skonfigurować pożądane parametry środowiska tworzenia kodu PHP. Konfigurację tę można ustawić zarówno w odniesieniu do poszczególnych serwisów, jak i jako ogólne ustawienia dla wszystkich plików PHP zapisywanych poza serwisami programu Dreamweaver.

Program Dreamweaver skonfiguruje podpowiedzi do kodu i opcje lintingu odpowiednio do wybranej wersji PHP.

Aby ustawić preferencje wersji PHP plików nieprzypisanych do konkretnego serwisu, wykonaj następujące czynności:

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh).

  2. Na liście kategorii po lewej stronie wybierz pozycję PHP.

  3. Z rozwijanej listy Wersja PHP wybierz odpowiednią wersję i kliknij przycisk Zastosuj.

Aby ustawić wersję PHP dla konkretnego serwisu, wykonaj następujące czynności:

  1. Otwórz okno dialogowe Konfiguracja serwisu i w sekcji Ustawienia zaawansowane wybierz opcję PHP.

  2. Z rozwijanej listy Wersja PHP wybierz odpowiednią wersję i kliknij przycisk Zapisz.

    Ustawianie preferencji PHP dla konkretnego serwisu
    Ustawianie preferencji PHP dla konkretnego serwisu

Ustawianie motywów kolorów i motywów kodu

Podczas uruchamiania programu Dreamweaver można wybrać preferowany motyw kolorystyczny. Można również zmienić te preferencje w dowolnej chwili.

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh).
  2. Z listy Kategoria po lewej stronie wybierz pozycję Interfejs.

  3. Wybierz motyw z listy Motywy kolorów.

  4. Po ustawieniu motywu interfejsu określ motyw kodu.

    Można wybrać motyw jasny albo ciemny.

  5. Kliknij przycisk Zastosuj, aby zapisać wprowadzone zmiany.

    Kolory kodu można dostosowywać także w większym stopniu, stosownie do własnych potrzeb. Więcej informacji: Dostosowywanie kolorowania kodu.

Używanie zewnętrznego edytora

Możesz określić zewnętrzny edytor do edycji plików o określonych rozszerzeniach. Można na przykład określić, że w celu edycji plików JavaScript (JS) z poziomu programu Dreamweaver ma być uruchamiany edytor tekstu, taki jak BBEdit, Notatnik lub TextEdit.

Do różnych rozszerzeń plików można przypisać różne edytory zewnętrzne.

Ustawianie zewnętrznego edytora dla danego typu pliku

  1. Wybierz polecenie Edycja > Preferencje.
  2. Wybierz opcję Typy plików/Edytory z listy Kategorie po lewej stronie, ustaw opcje i kliknij przycisk OK.

    Otwórz w widoku Kod

    Określa rozszerzenia plików, które automatycznie otwierają się w widoku Kod w programie Dreamweaver.

    Wczytaj ponownie zmodyfikowane pliki

    Określa zachowanie programu Dreamweaver w przypadku wykrycia zmian wprowadzonych zewnętrznie w dokumencie, który jest obecnie otwarty w programie Dreamweaver.

    Zapisz przy uruchamianiu

    Określa, czy program Dreamweaver powinien zawsze zapisywać bieżący dokument przed uruchomieniem edytora, nigdy nie zapisywać, albo też pytać o zapisywanie przy każdym uruchomieniu zewnętrznego edytora.

    Fireworks

    Wpisując tutaj ścieżkę do aplikacji Fireworks, można połączyć ją z programem Dreamweaver.

Logo Adobe

Zaloguj się na swoje konto