Informacje o używaniu tabel w celu prezentacji zawartości serwisu WWW, Ponadto strona zawiera informacje o dzieleniu i scalaniu komórek tabeli oraz importowaniu i eksportowaniu danych tabelarycznych.

Tabele są bardzo wydajnym narzędziem do prezentacji danych oraz rozmieszczania tekstu i grafik na stronie HTML. Tabela składa się z jednego lub kilku wierszy, z których każdy zawiera jedną lub kilka komórek. Kolumny nie są definiowane bezpośrednio w kodzie HTML, ale program Dreamweaver umożliwia modyfikowanie zarówno kolumn, jak i wierszy oraz komórek.

Gdy tabela jest zaznaczona lub gdy znajduje się w niej punkt wstawiania, program Dreamweaver wyświetla szerokość tabeli i kolumny dla wszystkich kolumn. Obok szerokości wyświetlane są strzałki dla menu nagłówka tabeli i menu nagłówka kolumny. Menu te ułatwiają dostęp do poleceń dotyczących tabeli. Funkcje szerokości i menu mogą być włączane i wyłączane.

Jeśli szerokość tabeli lub kolumny nie jest widoczna, to znaczy, że dana tabela lub kolumna nie posiadają szerokości określonej w kodzie HTML. Jeśli wyświetlane są dwie wartości, to znaczy, że szerokość wizualna wyświetlona w widoku Projekt nie pokrywa się z szerokością określoną w kodzie HTML. Sytuacja taka jest możliwa po zmianie wielkości tabeli przez przeciąganie jej prawego dolnego rogu lub po dodaniu zawartości przekraczającej określoną szerokość komórki.

Na przykład jeśli szerokość kolumny określono na 200 pikseli i dodano zawartość szeroką na 250 pikseli, to dla danej kolumny będą wyświetlane obie wartości: 200 (szerokość określona w kodzie) oraz (250) w nawiasach (wizualna szerokość kolumny renderowanej na ekranie).

Uwaga:

Warto pamiętać, że układ strony można tworzyć również za pomocą kodu CSS.

Formatowanie tabel w języku HTML

Formatowanie tabel w widoku Projekt umożliwia określanie właściwości dla całej tabeli lub zaznaczonych wierszy, kolumn lub komórek tabeli. Jeśli właściwość taka jak kolor tła lub wyrównanie jest różnie określana dla całej tabeli i wybranych komórek, to informacje dotyczące formatowania komórek mają pierwszeństwo przed informacjami dotyczącymi formatowania wierszy, które z kolei ma pierwszeństwo przed formatowaniem tabeli.

Porządek formatowania tabeli jest następujący:

  1. Komórki
  2. Wiersze
  3. Tabela

Na przykład jeśli dla wybranej komórki zostanie zdefiniowany niebieski kolor tła, a kolorem tła całej tabeli będzie żółty, to kolor niebieskiej komórki pozostanie bez zmian, ponieważ formatowanie komórki ma pierwszeństwo przed formatowaniem tabeli.

Uwaga:

Podczas określania właściwości dla kolumny program Dreamweaver zmienia atrybuty znacznika td odnoszącego się do każdej komórki w tej kolumnie.

Omówienie dzielenia i scalania komórek tabeli

Scalić można dowolną liczbę przylegających do siebie komórek, pod warunkiem, że są one położone w jednym rzędzie lub tworzą kształt prostokąta. Powstała w wyniku scalania komórka obejmuje swoim zakresem kilka kolumn lub wierszy. Komórka może być dzielona na dowolną liczbę wierszy lub kolumn, bez względu na to, czy była wcześniej scalana. Program Dreamweaver automatycznie modyfikuje strukturę tabeli (dodając w razie potrzeby atrybuty colspan lub rowspan), aby utworzyć wskazany układ.

W opisanym przykładzie komórki na środku pierwszych dwóch wierszy zostały scalone w jedną komórkę, która zajmuje dwa wiersze.

Scalone komórki
Scalone komórki

Wstawianie tabeli i dodawanie zawartości

Użyj panelu Wstaw lub menu Wstaw do utworzenia nowej tabeli. Dodaj tekst lub obrazy do komórek tabeli tak samo, jak dodajesz tekst lub obrazy poza tabelami.

  1. Umieść punkt wstawienia tam, gdzie ma się pojawić dynamiczna tabela.

    Uwaga:

    Jeśli dokument jest pusty, kursor można umieścić tylko na początku dokumentu.

    • Wybierz polecenie Wstaw > Tabela.

    • W kategorii HTML panelu Wstaw kliknij opcję Tabela.

  2. Określ atrybuty w oknie dialogowym Tabela i kliknij przycisk OK, aby utworzyć tabelę.
    Tworzenie tabeli
    Tworzenie tabeli

    Wiersze

    Określa liczbę wierszy w tabeli.

    Kolumny

    Określa liczbę kolumn w tabeli.

    Szerokość tabeli

    Określa szerokość tabeli w pikselach lub w jako procent szerokości okna przeglądarki.

    Grubość krawędzi

    Określa grubość krawędzi tabeli, wyrażoną w pikselach.

    Odstępy między komórkami

    Określa liczbę pikseli pomiędzy przylegającymi komórkami tabeli.

    Uwaga:

    Jeśli nie określisz grubości krawędzi, odstępów między komórkami lub odstępu komórki od krawędzi, to większość przeglądarek wyświetli tabelę z krawędzią i odstępem od krawędzi o wartości 1 i odstępami między komórkami o wartości 2. Aby zapewnić wyświetlanie tabeli bez widocznych krawędzi, odstępów od krawędzi i odstępów między komórkami, wpisz 0 w polach Odstęp od krawędzi komórki i Odstępy między komórkami.

    Odstęp od krawędzi komórki

    Określa liczbę pikseli pomiędzy zawartością a krawędzią komórki.

    Brak

    Nie tworzy nagłówków kolumny lub wiersza dla danej tabeli.

    Po lewej

    Przekształca pierwszą kolumnę tabeli w kolumnę nagłówków. Pozwala to wpisać nagłówek dla każdego wiersza tabeli.

    Na górze

    Przekształca pierwszy wiersz tabeli w wiersz nagłówka, co pozwala wpisać nagłówek dla każdej z kolumn tabeli.

    Oba

    Umożliwia wpisanie nagłówków kolumn i wierszy tabeli.

    Uwaga:

    Dobrze jest stosować nagłówki, ponieważ są przydatne użytkownikom korzystającym z czytników ekranu. Czytniki ekranu odczytują nagłówki tabeli i ułatwiają użytkownikom korzystanie z tabel.

    Podpis

    Umożliwia podanie tytułu tabeli wyświetlanego poza samą tabelą.

    Podsumowanie

    Umożliwia podanie opisu tabeli. Czytniki ekranu odczytują podsuwanie tekstu, ale sam tekst nie jest wyświetlany w przeglądarce.

Importowanie i eksportowanie tabel

Dane tabelaryczne utworzone w innej aplikacji (np. Microsoft Excel) można zapisać w formacie tekstu rozdzielonego (np. tabulatorami, przecinkami, średnikami lub dwukropkami), po czym zaimportować do programu Dreamweaver jako tabelę.

Można również wyeksportować dane tabelaryczne z programu Dreamweaver do pliku tekstowego w formacie, w którym zawartość poszczególnych komórek jest rozdzielana odpowiednimi ogranicznikami. Takimi ogranicznikami mogą być przecinki, średniki, dwukropki lub spacje. Operacja eksportowania obejmuje całą tabelę; nie można eksportować części tabeli.

Uwaga:

Aby wyeksportować wybraną część danych tabeli (np. pierwszych sześć wierszy lub pierwszych sześć kolumn), skopiuj komórki z wybranymi danymi, wklej je poza tabelą (tworząc w ten sposób nową tabelę) i wyeksportuj tę nową tabelę.

Importowanie danych tabeli

  1. Wybierz polecenie Plik > Import > Dane tabelaryczne.

  2. Określ opcje dla danych tabelarycznych i kliknij przycisk OK.

    Plik danych

    Nazwa pliku wybranego do importu. Kliknij przycisk Przeglądaj i zaznacz wybrany plik.

    Ogranicznik

    Ogranicznik używany w importowanym pliku.

    Jeśli wybierzesz opcję Inny, po prawej stronie menu zostanie wyświetlone pole tekstowe. Wpisz ogranicznik użyty w danym pliku.

    Uwaga:

    Określ, jaki ogranicznik został użyty podczas zapisywania pliku danych. Jeśli nie podasz tej informacji, nie będzie możliwe prawidłowe zaimportowanie pliku, a dane nie zostaną poprawnie sformatowane w tabeli.

    Szerokość tabeli

    Określa szerokość tabeli.

    • Zaznacz opcję Dopasuj do danych, aby uzyskać kolumny o szerokości odpowiadającej najdłuższym zawartym w nich ciągom znaków.

    • Zaznacz opcję Ustaw, aby określić stałą szerokość tabeli wyrażoną w pikselach lub jako procent szerokości okna przeglądarki.

    Krawędź

    Określa grubość krawędzi tabeli, wyrażoną w pikselach.

    Odstęp od krawędzi komórki

    Liczba pikseli pomiędzy zawartością a krawędzią komórki.

    Odstępy między komórkami

    Liczba pikseli między sąsiednimi komórkami tabeli.

    Uwaga:

    Jeśli nie określisz grubości krawędzi, odstępów między komórkami lub odstępu komórki od krawędzi, to większość przeglądarek wyświetli tabelę z krawędzią i odstępem od krawędzi o wartości 1 i odstępami między komórkami o wartości 2. Jeżeli chcesz, aby przeglądarka wyświetlała tabelę bez odstępów między komórkami oraz między treścią a krawędzią komórki, ustaw obie te wartości na zero. Aby wyświetlić komórki oraz obrys tabeli w sytuacji, gdy krawędź jest ustawiona na wartość 0, wybierz polecenie Widok > Pomoce wizualne > Krawędzie tabeli.

    Formatuj górny wiersz

    Określa formatowanie stosowane do górnego wiersza tabeli. Zaznacz jedną z czterech opcji formatowania: brak formatowania, pogrubione, pochylone, pogrubione pochylone.

Eksportowanie tabeli

  1. Umieść punkt wstawiania w dowolnej komórce tabeli.
  2. Wybierz polecenie Plik > Eksportuj > Tabela.
  3. Ustaw następujące opcje:

    Ogranicznik

    Określa znak ogranicznika, który będzie używany do rozdzielania danych w eksportowanym pliku.

    Znaki łamania wiersza

    Określa w jakim systemie operacyjnym będzie otwierany eksportowany plik: Windows, Macintosh lub UNIX. (Poszczególne systemy operacyjne w różny sposób definiują zakończenia wierszy tekstu.)

  4. Kliknij przycisk Eksportuj.
  5. Wpisz nazwę pliku i kliknij przycisk Zapisz.

Zaznaczanie elementów tabeli

Zaznaczenie może objąć całą tabelę, wiersz lub kolumnę. Zaznaczać można też jedną lub kilka poszczególnych komórek.

Podczas przesuwania kursora myszy nad tabelą, wierszem, kolumną lub komórką, program Dreamweaver podświetla wszystkie komórki objęte zaznaczeniem. Pozwala to stwierdzić, które komórki zostaną zaznaczone. Operacja ta jest przydatna przy zaznaczaniu tabel bez krawędzi, komórek scalonych na kilku kolumnach lub wierszach, a także tabel zagnieżdżonych. Kolor podświetlenia może być zmieniony w preferencjach.

Uwaga:

Jeśli umieścisz kursor nad krawędzią tabeli i wciśniesz klawisz Control (Windows) lub Command (Macintosh), to podświetlenie obejmie całą strukturę tabeli (tzn. wszystkie komórki w tabeli). Operacja taka jest przydatna, gdy stosuje się tabele zagnieżdżone i potrzebna jest informacja o strukturze jednej z tabel.

Zaznaczanie całej tabeli

Wykonaj jedną z następujących czynności, aby zaznaczyć tabelę:

  • Kliknij zakładkę w lewym górnym rogu tabeli, aby ją zaznaczyć.
  • Kliknij w komórce tabeli i wybierz znacznik z selektora znaczników w lewym dolnym rogu okna Dokument.
  • Kliknij komórkę tabeli. menu nagłówka tabeli w potem wybierz opcję Zaznacz tabelę. Na zaznaczonych dolnej i prawej krawędzi tabeli pojawiają się uchwyty zaznaczenia.
  • Kliknij komórkę tabeli, a następnie wybierz polecenie Edycja > Tabela > Zaznacz tabelę.

Zaznaczanie jednego lub wielu wierszy lub kolumn

  1. Umieść kursor tak, by wskazywał lewą krawędź wiersza lub górną krawędź kolumny.
  2. Gdy kursor zmieni się w strzałkę zaznaczenia, kliknij, aby zaznaczyć wiersz lub kolumnę, lub przeciągnij, zaznaczając kilka wierszy lub kolumn.
    Wybierz wiersz
    Wybierz wiersz

Zaznaczanie jednej kolumny

  1. Kliknij kolumnę.
  2. Kliknij menu nagłówka kolumny i wybierz polecenie Zaznacz kolumnę.

Zaznaczanie jednej komórki

  1. Wykonaj jedną z następujących czynności:

    • Kliknij komórkę tabeli i wybierz znacznik <td>, dostępny w selektorze znaczników, w lewym dolnym rogu okna Dokument.
    • Przytrzymaj klawisz Control (Windows) lub Command (Macintosh) i kliknij komórkę.

Zaznaczanie wiersza lub prostokątnego bloku komórek

Wykonaj jedną z następujących czynności:
  • Przeciągnij kursorem z jednej komórki do drugiej.

  • Kliknij jedną komórkę, kliknij tę samą komórkę z wciśniętym klawiszem Control (Windows) lub Command (Macintosh), aby ją zaznaczyć, a następnie kliknij inną komórkę z wciśniętym klawiszem Shift.

Zaznaczanie bloku komórek
Zaznaczanie bloku komórek

Zaznaczanie komórek nieprzylegających do siebie

Przytrzymując klawisz Control (Windows) lub Command (Macintosh), kliknij komórki, wiersze lub kolumny, które chcesz zaznaczyć.

Niezaznaczone komórki, wiersze lub kolumny, które kliknięto z wciśniętym klawiszem Control lub Command, zostaną dodane do zaznaczenia. Jeśli kliknięte elementy były wcześniej zaznaczone, to kliknięcie spowoduje usunięcie ich z zaznaczenia.

Zmiana koloru podświetlenia elementów tabeli

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh).
  2. Wybierz opcję Podświetlanie, dostępną na liście kategorii po lewej stronie, wprowadź zmiany i kliknij przycisk OK.
    • Aby zmienić kolor podświetlenia dla elementów tabeli, kliknij pole koloru Najazd i zaznacz kolor podświetlenia przy pomocy próbnika kolorów (lub wpisz w polu tekstowym wartości szesnastkowe wybranego koloru).

    • Aby włączyć lub wyłączyć podświetlanie elementów tabeli, zaznacz lub usuń zaznaczenie opcji Pokaż dla opcji Najazd.

    Uwaga:

    Te opcje dotyczą wszystkich obiektów, które program Dreamweaver podświetla po najechaniu na nie wskaźnikiem myszy.

Określanie właściwości tabeli

Tabele można edytować za pomocą inspektora Właściwości.

  1. Zaznacz tabelę.
  2. Zmień stosowne opcje w Inspektorze właściwości (Okno > Właściwości).
    Właściwości tabeli
    Właściwości tabeli

    ID tabeli

    Identyfikator tabeli.

    Wiersze i kolumny

    Liczba wierszy i kolumn w tabeli.

    W

    Szerokość tabeli w pikselach lub w procentach (jako odpowiedni procent szerokości okna przeglądarki).

    Uwaga:

    Wysokość tabeli nie wymaga zwykle określania.

    Odst. wewn. kom.

    Liczba pikseli między zawartością a krawędzią komórki.

    Odst. między kom.

    Liczba pikseli między sąsiednimi komórkami tabeli.

    Wyrównaj

    Określa położenie tabeli względem innych elementów tego samego akapitu (np. tekstu lub obrazów).

    Opcja Do lewej wyrównuje tabelę do lewej strony elementów (tak, by tekst w tym samym akapicie oblewał tabelę po prawej stronie); opcja Do prawej wyrównuje tabelę do prawej strony innych elementów (z oblewaniem tekstem wokół elementu po lewej), a opcja Do środka umieszcza tabelę na środku (tekst jest wtedy rozmieszczany nad i/lub pod tabelą). Opcja Domyśla wskazuje, że przeglądarka powinna zastosować swoje wyrównanie domyślne.

    Uwaga:

    Jeśli wyrównanie jest Domyślne, to inna zawartość nie jest wyświetlana obok tabeli. Aby wyświetlić tabelę obok innej zawartości, zastosuj wyrównanie Do lewej lub Do prawej.

    Krawędź

    Określa grubość krawędzi tabeli, wyrażoną w pikselach.

    Uwaga:

    Jeśli nie określisz grubości krawędzi, odstępów między komórkami lub odstępu komórki od krawędzi, to większość przeglądarek wyświetli tabelę z krawędzią i odstępem od krawędzi o wartości 1 i odstępami między komórkami o wartości 2. Aby zapewnić wyświetlanie tabeli bez odstępów od krawędzi i między komórkami, wpisz 0 w polach Krawędź, Odstęp od krawędzi komórki i Odstępy między komórkami. Aby wyświetlić komórki oraz obrys tabeli w sytuacji, gdy krawędź jest ustawiona na wartość 0, wybierz polecenie Widok > Pomoce wizualne > Krawędzie tabeli.

    Klasa

    Służy do określania klasy CSS tabeli.

    Uwaga:

    Jeśli poniższe opcje nie są widoczne, możesz rozwinąć Inspektora właściwości. Aby rozwinąć Inspektora właściwości tabeli, kliknij strzałkę rozwijania w prawym dolnym rogu.

    Wyczyść szerokości kolumn / Wyczyść wysokości wierszy

    i Wyczyść wysokość wierszy — te opcje umożliwiają usunięcie wszystkich oddzielnie określonych wartości wysokości wierszy i szerokości kolumn w danej tabeli.

    Konwertuj szerokości w tabeli na piksele

    i Konwertuj wysokości tabeli na piksele — te opcje umożliwiają określenie szerokości lub wysokości każdej z kolumn w tabeli zgodnie z jej bieżącą szerokością w pikselach (oraz szerokości całej tabeli zgodnie z jej bieżącą szerokością w pikselach).

    Konwertuj szerokości w tabeli na procenty

    i Konwertuj wysokości tabeli na procenty — te opcje umożliwiają określenie szerokości lub wysokości każdej kolumny w tabeli zgodnie z jej szerokością bieżącą w procentach szerokości okna Dokument (oraz szerokości całej tabeli zgodnie z jej szerokością bieżącą w procentach szerokości okna Dokument).

    Po wpisaniu wartości w polu tekstowym wciśnij klawisz Tab lub Enter (Windows) albo Return (Macintosh), aby zastosować wybraną wartość.

Określanie właściwości komórki, wiersza lub kolumny

Komórki i wiersze tabeli mogą być edytowane przy pomocy inspektora Właściwości.

  1. Zaznacz wybraną kolumnę lub wiersz.
  2. W inspektorze Właściwości (Okno > Właściwości) ustaw dowolne z następujących opcji:

    Poz.

    Określa wyrównanie w poziomie zawartości komórki, wiersza lub kolumny. Zawartość może być wyrównywana do lewej, prawej lub do środka komórek lub wyrównywana zgodnie z domyślnym ustawieniem przeglądarki (zwykle jest to wyrównanie do lewej komórek zwykłych i wyrównanie do środka w komórkach nagłówka).

    Pion.

    Określa wyrównanie w pionie zawartości komórki, wiersza lub kolumny. Zawartość może być wyrównywana do górnej krawędzi, dolnej lub linii bazowej komórek lub wyrównywana zgodnie z domyślnym ustawieniem przeglądarki (zwykle jest to wyrównanie środka).

    Wys. i Sz.

    Szerokość i wysokość zaznaczonych komórek, wyrażona w pikselach lub w postaci ułamka szerokości lub wysokości całej tabeli. Aby podać wartość procentową, umieść za nią symbol %. Jeśli przeglądarka ma sama określić odpowiednią szerokość i wysokość na podstawie zawartości komórki oraz szerokości i wysokość innych kolumn i wierszy, pozostaw pole puste (domyślne).

    Domyślnie, przeglądarka wybiera wysokość wiersza i szerokość kolumny tak, by pomieścić najszerszy obraz lub najdłuższy ciąg znaków w kolumnie. Z tego powodu kolumna, do której dodano zawartość, staje się czasami dużo szersza od innych kolumn tabeli.

    Uwaga:

    Wysokość można definiować jako procent ogólnej wysokości tabeli. Może się jednak zdarzyć, że dana przeglądarka nie wyświetli wiersza w podanej wysokości.

    Tło

    Kolor tła komórki, kolumny lub wiersza, wybrany za pomocą próbnika kolorów.

    Scal komórki

    Scala zaznaczone komórki, wiersze lub kolumny w jedną komórkę. Komórki mogą być scalane tylko wtedy, gdy tworzą prostokąt lub linię.

    Podziel komórkę

    Dzieli komórkę, tworząc dwie lub więcej komórek. W jednej operacji można podzielić tylko jedną komórkę, ponieważ przycisk jest nieaktywny po zaznaczeniu więcej niż jednej komórki.

    Bez zawijania

    Wyłącza zawijanie wierszy, utrzymując cały tekst w wybranej komórce w jednym wierszu. Jeśli opcja Bez zawijania jest włączona, to komórki są rozszerzane stosownie do danych wpisywanych lub wklejanych do komórki. (Zwykle komórki są powiększane w poziomie tak, by zmieścić najdłuższy wyraz lub najszerszy obraz w komórce, a potem powiększane w pionie, stosownie do innej zawartości.)

    Nagłówek

    Formatuje zaznaczone komórki jako komórki nagłówka tabeli. Zawartość komórek nagłówka tabeli jest domyślnie zapisana czcionka pogrubioną i wyrównana do środka.

    Uwaga:

    Szerokości i wysokości mogą być podawane w pikselach lub w postaci procentowej. Można również konwertować wartości w pikselach na procenty i odwrotnie.

    Uwaga:

    Określenie właściwości kolumny spowoduje, że program Dreamweaver zmieni atrybuty znacznika td każdej komórki w tej kolumnie. Natomiast gdy określi się pewne właściwości wiersza, program Dreamweaver zmieni atrybuty znacznika tr, a nie atrybuty poszczególnych znaczników td w tym wierszu. Jeśli wszystkie komórki w danym wierszu mają mieć ten sam format, warto zastosować formatowanie do znacznika tr, ponieważ generuje to prostszy i bardziej przejrzysty kod HTML.

  3. Naciśnij klawisz Tab, Enter (Windows) lub Return (Macintosh), aby zastosować wybraną wartość.

Formatowanie tabel i komórek

Aby zmienić wygląd tabel, można zmodyfikować właściwości wybranej tabeli i jej komórek przez zastosowanie predefiniowanego stylu. Przed określeniem właściwości tabeli i komórek zwróć uwagę na kolejność formatowania, która obejmuje najpierw komórki, a potem potem wiersze i na końcu tabele.

Uwaga:

Aby sformatować tekst w komórce tabeli, zastosuj te same procedury, których używasz do formatowania tekstu poza tabelami.

Zmiana formatowania tabeli, wiersza, komórki lub kolumny

  1. Zaznacz tabelę, komórkę, wiersz lub kolumnę.
  2. W inspektorze Właściwości (Okno > Właściwości) kliknij strzałkę rozwijania umieszczoną w prawym dolnym rogu i odpowiednio zmień wybrane właściwości.
  3. Zmień wybrane właściwości.

    Aby uzyskać więcej informacji na temat opcji, kliknij ikonę Pomoc w inspektorze Właściwości.

    Uwaga:

    Określenie właściwości kolumny spowoduje, że program Dreamweaver zmieni atrybuty znacznika td każdej komórki w tej kolumnie. Natomiast gdy określi się pewne właściwości wiersza, program Dreamweaver zmieni atrybuty znacznika tr, a nie atrybuty poszczególnych znaczników td w tym wierszu. Jeśli wszystkie komórki w danym wierszu mają mieć ten sam format, warto zastosować formatowanie do znacznika tr, ponieważ generuje to prostszy i bardziej przejrzysty kod HTML.

Dodawanie lub edycja wartości dostępności dla tabeli w widoku Kod

Przeprowadź odpowiednie edycje atrybutów w kodzie

Uwaga:

Aby szybko odszukać wybrane znaczniki w kodzie, kliknij tabelę, a potem wybierz znacznik <table> z selektora znaczników na dole okna Dokument.

Dodawanie lub edycja wartości dostępności dla tabeli w widoku Projekt

  • Aby przeprowadzić edycję podpisu, podświetl go i wpisz nowy podpis.
    • Aby zmienić wyrównanie podpisu, umieść kursor w podpisie tabeli, kliknij go prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) i wybierz opcję Edytuj kod znacznika.

    • Aby zmodyfikować podsumowanie tabeli, zaznacz wybraną tabelę, kliknij ją prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) i wybierz opcję Edytuj kod znacznika.

Zmiana rozmiaru tabel, kolumn i wierszy

Zmiana rozmiaru tabel

Zmiana rozmiaru może objąć całą tabelę lub wybrane wiersze i kolumny. W przypadku zmiany rozmiaru całej tabeli wszystkie komórki tabeli są zmieniane proporcjonalnie. Jeśli dla komórek tabeli podano określone szerokości lub wysokości, to zmiana rozmiarów tabeli powoduje wizualną zmianę wielkości komórek w oknie Dokument, ale nie wpłynie na ustawione szerokości i wysokości tych komórek.

Rozmiary tabeli można zmieniać, przesuwając odpowiednie uchwyty zaznaczenia. Gdy tabela zostanie zaznaczona lub gdy umieści się w niej punkt wstawiania, program Dreamweaver wyświetli szerokość oraz menu nagłówka tabeli w jej górnej lub dolnej części.

Czasami szerokości kolumny określone w kodzie HTML nie odpowiadają szerokościom na ekranie. W takim przypadku można uspójnić szerokości. Szerokości tabel i kolumn oraz menu nagłówka są wyświetlane jako elementy ułatwiające tworzenie układu tabel, ale w razie potrzeby można je wyłączyć.

Zmiana rozmiaru kolumn i wierszy

Szerokość kolumny i wysokość wiersza można zmienić w Inspektorze właściwości lub przez przeciąganie krawędzi kolumny lub wiersza. Jeśli zmiana rozmiaru sprawia trudności, można wyczyścić szerokości kolumny i wysokości wiersza, aby rozpocząć proces od nowa.

Uwaga:

Szerokości i wysokości komórek można zmieniać bezpośrednio w kodzie HTML, korzystając z widoku Kod.

Gdy tabela jest zaznaczona lub gdy znajduje się w niej punkt wstawiania, program Dreamweaver wyświetla szerokość kolumn oraz menu nagłówka tabeli w górnej lub dolnej części kolumny. Wyświetlanie menu nagłówka kolumny można włączać lub wyłączać stosownie do potrzeb.

Zmiana rozmiaru tabeli

Zaznacz wybraną tabelę. Jeśli pracujesz w widoku aktywnym, po zaznaczeniu tabeli zostanie wyświetlone okienko Monitor elementu. Kliknij ikonę kanapki, aby uaktywnić tryb formatowania tabeli.

  • Aby zmienić rozmiar tabeli w poziomie, przeciągnij uchwyt zaznaczenia po prawej stronie.

  • Aby zmienić rozmiar tabeli w pionie, przeciągnij uchwyt zaznaczenia na dole.

  • Aby zmienić rozmiar tabeli jednocześnie w poziomie i w pionie, przeciągnij uchwyt zaznaczenia w prawym dolnym rogu.

Aby opuścić tryb formatowania tabeli w widoku aktywnym, naciśnij klawisz Esc lub kliknij poza tabelą. Opcje w menu Edycja > Tabela umożliwiają dalszą modyfikację tabel.

Uwaga: Opcje dostępne w menu Edycja > Tabela zależą od tego, czy została zaznaczona cała tabela, czy pojedyncza komórka. Podczas pracy w widoku aktywnym okienko Monitor elementu wyświetla znacznik „table”, gdy jest zaznaczona cała tabela, albo znacznik „td”, gdy jest zaznaczona konkretna komórka. Aby przejść z trybu formatowania komórek do trybu formatowania tabeli, kliknij krawędź tabeli.

Zmiana szerokości kolumny przy zachowaniu szerokości całej tabeli

  1. W widoku Projekt przeciągnij prawą krawędź kolumny, którą chcesz zmienić.

    Szerokość przylegającej kolumny ulegnie zmianie, co oznacza, że wykonana operacja spowoduje w rzeczywistości zmianę szerokości dwóch kolumn. Na ekranie widoczne jest dopasowanie szerokości kolumn, ale szerokość całej kolumny pozostaje bez zmiany.

    Zmiana szerokości kolumny przy zachowaniu szerokości tabeli
    Zmiana szerokości kolumny przy zachowaniu szerokości tabeli

    Uwaga:

    W tabelach, w których szerokości są określone procentowo (a nie w pikselach), przeciągnięcie prawej krawędzi ostatniej kolumny po prawej stronie spowoduje zmianę szerokości całej tabeli oraz proporcjonalne rozszerzenie lub zwężenie wszystkich kolumn.

Zmiana szerokości kolumny przy zachowaniu rozmiaru innych kolumn

  1. W widoku Projekt przytrzymaj klawisz Shift i przeciągnij krawędź wybranej kolumny.

    Szerokość jednej kolumny zmieni się. Na ekranie widoczne jest dopasowanie szerokości kolumn, szerokość całej tabeli zmienia się tak, by zmieścić zmieniającą się kolumnę.

    Zmiana szerokości kolumny przy zachowaniu rozmiaru innych kolumn
    Zmiana szerokości kolumny przy zachowaniu rozmiaru innych kolumn

Wizualna zmiana wysokości wiersza

Przeciągnij dolną krawędź wybranego wiersza.

Dopasowanie szerokości kolumn w kodzie do szerokości wizualnych

  1. Kliknij komórkę.
  2. Kliknij menu nagłówka tabeli i zaznacz opcję Uspójnij wszystkie szerokości.

    Program Dreamweaver resetuje szerokość określoną w kodzie do szerokości widocznej na ekranie.

Czyszczenie wszystkich wartości szerokości lub wysokości zdefiniowanych dla tabeli

  1. Zaznacz wybraną tabelę.
  2. Wykonaj jedną z następujących czynności:
    • Wybierz polecenie Edycja > Tabela > Wyczyść dane szerokości komórek lub Edycja > Tabela > Wyczyść dane wysokości komórek.

    • W Inspektorze właściwości (Okno > Właściwości) kliknij przycisk Wyczyść wysokości wierszy lub Wyczyść szerokości kolumn .

    • Kliknij menu nagłówka tabeli i wybierz opcję Wyczyść wszystkie dane wysokości lub Wyczyść wszystkie dane szerokości.

Czyszczenie szerokości zdefiniowanej dla kolumny

Kliknij wybraną kolumnę, potem kliknij menu nagłówka kolumny i wybierz polecenie Wyczyść dane szerokości kolumny.

Włączanie lub wyłączanie szerokości i menu tabel oraz kolumn w widoku Projekt

Wybierz polecenie Widok > Opcje widoku Projekt > Szerokości tabeli.

Dodawanie i usuwanie wierszy oraz kolumn

Aby dodać lub usunąć wiersze i kolumny, skorzystaj z polecenia Modyfikuj > Tabela lub z menu nagłówka kolumny.

Uwaga:

Naciśnięcie klawisza Tab w ostatniej komórce tabeli powoduje automatyczne dodanie nowego wiersza do tej tabeli.

Dodawanie pojedynczego wiersza lub kolumny

Kliknij komórkę i wykonaj jedną z następujących czynności:
  • Wybierz polecenie Edycja > Tabela > Wstaw wiersz lub Edycja > Tabela > Wstaw kolumnę.

    Nowy wiersz zostanie dodany nad punktem wstawiania / nowa kolumna zostanie dodana po lewej stronie punktu wstawienia.

  • Kliknij menu nagłówka kolumny i wybierz opcję Wstaw kolumnę po lewej lub Wstaw kolumnę po prawej.

     

Dodawanie kilku wierszy i kolumn

  1. Kliknij komórkę.
  2. Wybierz polecenie Edycja > Tabela > Wstaw wiersze lub kolumny, wypełnij okno dialogowe i kliknij przycisk OK.

    Wstaw

    Określa, czy wstawiane mają być wiersze, czy kolumny.

    Liczba wierszy lub Liczba kolumn

    Liczba wierszy lub kolumn do wstawienia.

    Gdzie

    Określa, czy nowe wiersze lub kolumny mają się pojawić przed czy po wierszu lub kolumnie, w której znajduje się zaznaczona komórka.

Usuwanie wiersza lub kolumny

Wykonaj jedną z następujących czynności:
  • Kliknij komórkę w wierszu lub kolumnie wybranej do usunięcie i wybierz polecenie Edycja > Tabela > Usuń wiersz lub Edycja > Tabela > Usuń kolumnę.

  • Zaznacz cały wiersz lub kolumnę, a następnie naciśnij klawisz Delete.

  • Wykonaj jedną z następujących czynności w Inspektorze właściwości (Windows > Właściwości):
    • Aby dodać lub usunąć wiersze, zwiększ lub zmniejsz wartość pola Wiersze.
    • Aby dodać lub usunąć kolumny, zwiększ lub zmniejsz wartość w polu Kolumny.

Uwaga:

Program Dreamweaver nie ostrzega przed usuwaniem wierszy lub kolumn zawierających dane.

Dzielenie i scalanie komórek

Aby podzielić lub scalić komórki, użyj Inspektora właściwości lub poleceń podmenu Edycja > Tabela.

Scalanie dwóch lub więcej komórek w tabeli

  1. Zaznacz komórki układające się w jeden rząd lub tworzące kształt prostokąta.

    Na podanej ilustracji, zaznaczenie obejmuje powierzchnię prostokąta utworzonego przez komórki, które mogą być scalone.

    Scalać można komórki tworzące prostokąt
    Scalać można komórki tworzące prostokąt

    Na poniższej ilustracji zaznaczenie nie ma kształtu prostokąta, więc komórki nie mogą zostać scalone.

    Komórek nie można scalić, jeśli zaznaczenie nie jest prostokątem
    Komórek nie można scalić, jeśli zaznaczenie nie jest prostokątem

  2. Wykonaj jedną z następujących czynności:
    • Wybierz polecenie Edycja > Tabela > Scal komórki.

    • W rozwiniętym Inspektorze właściwości HTML (Okno > Właściwości) kliknij opcję Scal komórki.

    Uwaga:

    Jeśli przycisk tej opcji nie jest widoczny, kliknij strzałkę rozwijania w prawym dolnym rogu panelu Inspektor właściwości. Spowoduje to wyświetlenie wszystkich opcji.

    Zawartość poszczególnych komórek jest rozmieszczona w scalonej komórce. Właściwości pierwszej komórki grupy scalanych komórek zostaje zastosowana do scalonej komórki.

Dzielenie komórki

  1. Kliknij wybraną komórkę i wykonaj jedną z następujących czynności:
    • Wybierz polecenie Edycja > Tabela > Podziel komórkę.

    • W rozwiniętym Inspektorze właściwości HTML (Okno > Właściwości) kliknij opcję Podziel komórkę.

    Uwaga:

    Jeśli przycisk tej opcji nie jest widoczny, kliknij strzałkę rozwijania w prawym dolnym rogu panelu Inspektor właściwości. Spowoduje to wyświetlenie wszystkich opcji.

  2. W oknie Podziel komórkę określ zasady dzielenia komórki:

    Podziel komórkę na

    Określa, czy komórkę należy podzielić na wiersze, czy na kolumny.

    Liczba wierszy lub Liczba kolumn

    Określa liczbę oczekiwanych wierszy lub kolumn.

Zwiększanie lub zmniejszanie liczby wierszy lub kolumn pochodzących z jednej komórki

Wykonaj jedną z następujących czynności:
  • Wybierz polecenie Edycja > Tabela > Zwiększ zakres wierszy lub Edycja > Tabela > Zwiększ zakres kolumn.

  • Wybierz polecenie Edycja > Tabela > Zmniejsz zakres wierszy lub Edycja > Tabela > Zmniejsz zakres kolumn.

Kopiowanie, wklejanie i usuwanie komórek

Kopiowanie, wklejanie lub usuwanie może obejmować jedną komórkę tabeli lub kilka komórek jednocześnie. Formatowanie tych komórek zostanie zachowane.

Komórki mogą być wklejane w miejscu kursora lub w miejscu zaznaczenia utworzonego w istniejącej tabeli. Aby wkleić kilka komórek tabeli jednocześnie, zawartość Schowka musi być zgodna ze strukturą tabeli lub zaznaczeniem w tabeli, do której będą wklejane komórki.

Wycinanie lub kopiowanie komórek tabeli

  1. Zaznacz pojedynczą komórkę albo komórki układające się w jeden rząd lub tworzące kształt prostokąta.

    Na podanej ilustracji, zaznaczenie obejmuje powierzchnię prostokąta utworzonego przez komórki, które mogą być wycinane lub kopiowane.

    Wycinać lub kopiować można komórki tworzące prostokąt
    Wycinać lub kopiować można komórki tworzące prostokąt

    Na poniższej ilustracji zaznaczenie nie ma kształtu prostokąta, więc komórek nie można wyciąć ani skopiować.

    Komórek nie można wyciąć lub skopiować, jeśli zaznaczenie nie jest prostokątem
    Komórek nie można wyciąć lub skopiować, jeśli zaznaczenie nie jest prostokątem

  2. Wybierz polecenie Edycja > Wytnij lub Edycja > Kopiuj.

    Uwaga:

    Po zaznaczeniu całego wiersza lub kolumny i wybraniu polecenia Edycja > Wytnij, z tabeli zostanie usunięty cały wiersz lub kolumna (a nie sama zawartość komórek).

Wklejanie komórek tabeli

  1. Zaznacz miejsce wybrane dla wklejanych komórek:
    • Aby zastąpić istniejące komórki komórkami wklejanymi, zaznacz zestaw istniejących komórek o takim samym układzie, co komórki w schowku. (Na przykład jeśli kopiujesz lub wycinasz blok 3 x 2 komórki, to możesz zaznaczyć inny blok 3 x 2 komórki, który zostanie zastąpiony w wyniku wklejania).

    • Aby wkleić pełny wiersz komórek nad konkretną komórką, kliknij tę komórkę.

    • Aby wkleić pełną kolumnę na lewo od konkretnej komórki, kliknij tę komórkę.

    Uwaga:

    Jeśli w schowku znajduje się niepełny wiersz lub niepełna kolumna, po kliknięciu w komórce i wklejeniu zawartości kliknięta komórka i komórki wokół mogą (w zależności od ich położenia w tabeli) zostać zastąpione wklejanymi komórkami.

    • Aby utworzyć nową tabelę z wklejanych komórek, umieść kursor poza tabelą.
  2. Wybierz polecenie Edycja > Wklej.

    Jeśli wklejasz całe wiersze lub kolumny do istniejącej tabeli, to wiersze i kolumny zostaną dodane do tej tabeli. Jeśli wklejasz pojedynczą komórkę, zawartość wybranej komórki jest zastępowana. Jeśli wklejasz poza tabelę, to wiersze, kolumny lub komórki zostaną użyte do zdefiniowania nowej tabeli.

Usuwanie zawartości komórki bez zmiany komórek

  1. Zaznacz przynajmniej jedną komórkę.

    Uwaga:

    Upewnij się, że zaznaczenie nie składa się jedynie z pełnych wierszy lub kolumn.

  2. Naciśnij klawisz Delete.

    Uwaga:

    Jeśli przy wybieraniu polecenia Edycja > Wyczyść lub wciśnięciu klawisza Delete zaznaczone są tylko pełne wiersze lub kolumny, to z tabeli zostają usunięte całe wiersze lub kolumny, a nie tylko ich zawartość.

Usuwanie wierszy lub kolumn zawierających scalone komórki

  1. Zaznacz wybraną kolumnę lub wiersz.
  2. Wybierz polecenie Edycja > Tabela > Usuń wiersz lub Edycja > Tabela > Usuń kolumnę.

Zagnieżdżanie tabeli

Zagnieżdżona tabela jest tabelą wewnątrz komórki innej tabeli. Zagnieżdżona tabela może być formatowana tak, jak inna tabela, ale jej szerokość jest ograniczona szerokością komórki, w której się znajduje.

  1. Kliknij komórkę istniejącej tabeli.
  2. Wybierz polecenie Wstaw > Tabela, określ opcje Wstaw Tabelę i kliknij przycisk OK.

Sortowanie tabel

Wiersze tabeli mogą być sortowane na podstawie zawartości jednej kolumny. Tabela może być sortowana także w bardziej złożony sposób na podstawie zawartości dwóch kolumn.

Nie można sortować tabel zawierających atrybuty colspan lub rowspan, czyli tabel zawierających komórki scalone.

  1. Zaznacz wybraną tabelę lub kliknij w dowolnej komórce.
  2. Wybierz polecenie Edycja > Tabela > Sortuj tabelę, określ opcje w oknie dialogowym i kliknij przycisk OK.

    Sortuj wg

    Określa kolumnę, której wartości zostaną użyte do sortowania wierszy tabeli.

    Porządek

    Umożliwia określenie, czy kolumna ma być sortowana alfabetycznie czy numerycznie, oraz zdefiniowanie kolejności jej sortowania (rosnąco od A do Z i od najniższej wartości do najwyższej) lub malejąco.

    Jeśli zawartość kolumny stanowią wartości liczbowe, zaznacz opcję Liczbowo. Sortowanie alfabetyczne zastosowane do listy liczb jedno i dwu-cyfrowych powoduje układanie ich jakby były wyrazami (1, 10, 2, 20, 3, 30) zamiast poprawnego sortowania liczbowego (1, 2, 3, 10, 20, 30).

    Następnie wg / Porządek

    Określa kolejność sortowania dla sortowania drugorzędnego na podstawie innej kolumny. W menu Następnie wg określ drugorzędną kolumnę sortowania. Wybierz kolejność drugorzędnego sortowania z menu Porządek.

    Sortowanie obejmuje pierwszy wiersz

    Określa, że pierwszy wiersz tabeli powinien być dołączony do sortowania. Jeśli pierwszy wiersz jest nagłówkiem, który nie powinien być przenoszony, to nie zaznaczaj tej opcji.

    Sortuj wiersze nagłówka

    Określa sortowanie wszystkich wierszy sekcji thead tabeli (jeśli takie są) przy pomocy tych samych kryteriów, co wierszy zwykłych. (Zwróć uwagę, że wiersze thead zostają zachowane w sekcji thead i są wciąż wyświetlane w górnej części tabeli nawet po sortowaniu.) Informacje na temat znacznika thead znajdują się w panelu Odniesienie (polecenie Pomoc > Odniesienie).

    Sortuj wiersze stopki

    Określa sortowanie wszystkich wierszy sekcji tfoot tabeli (jeśli takie są) przy pomocy tych samych kryteriów, co wierszy zwykłych. (Zwróć uwagę, że wiersze tfoot zostają zachowane w sekcji tfoot i są wciąż wyświetlane w dolnej części tabeli nawet po sortowaniu.) Informacje na temat znacznika tfoot znajdują się w panelu Odniesienie (polecenie Pomoc > Odniesienie).

    Zachowaj niezmienione kolory wierszy po zakończeniu sortowania

    Określa zachowywanie atrybutów wierszy tabeli (np. koloru) przy zawartości po zakończeniu sortowania. Jeśli wybrane wiersze tabeli są sformatowane przy pomocy dwóch różnych kolorów, to nie zaznaczaj tej opcji, jeśli chcesz pozostawić te kolory bez zmian. Jeśli dla zawartości każdego wiersza są podane specyficzne atrybuty, zaznacz tę opcję, aby zachować powiązanie atrybutów z odpowiednimi wierszami w posortowanej tabeli.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online