Måder at kombinere objekter på

Du kan kombinere vektorobjekter for at oprette former på mange forskellige måder i Illustrator. Kurverne eller formerne i den endelige illustration er forskellige afhængigt af den metode, du bruger til at kombinere objekterne.

Kurvefindereffekter

Med kurvefindereffekter kan du kombinere flere objekter ved hjælp af interaktionstilstande. Når du bruger kurvefindereffekter, kan du ikke redigere interaktionerne mellem objekter. Se Kombinering af objekter ved hjælp af kurvefindereffekter.

Sammensatte former

Med sammensatte former kan du kombinere flere objekter og angive, hvordan hvert objekt skal interagere med de øvrige objekter. Sammensatte former er mere alsidige end sammensatte kurver, fordi de giver mulighed for fire former for interaktion: tilføje, trække fra, skære og udelade. De underliggende objekter ændres derudover ikke, så du kan markere hvert objekt i en sammensat form for at redigere det eller ændre dets interaktionstilstand. Se Kombinering af objekter ved hjælp af sammensatte former.

Sammensatte kurver

Sammensatte kurver gør det muligt at bruge et objekt til at skære et hul i et andet objekt. Du kan f.eks. oprette en kransform på grundlag af to indlejrede cirkler. Når du har oprettet en sammensat kurve, fungerer kurverne som grupperede objekter. Du kan markere og redigere objekterne enkeltvist med værktøjet Direkte markering eller Gruppemarkering, eller du kan markere og redigere den kombinerede kurve. Se Kombinering af objekter ved hjælp af sammensatte kurver.

Bemærk:

Du kan også føje elementer til et objekt med værktøjet Klatpensel. Når du bruger denne pensel, føjes kurver, du maler, til tilgrænsende kurver, som bruger identiske fyldattributter. Se Tegning og fletning af kurver med klatpenselværktøjet og Oprettelse af nye former med værktøjet Opret form.

Kombiner objekter ved hjælp af kurvefindereffekter

Naviger på panelet Kurvefinder

Du bruger panelet Kurvefinder (Vindue > Kurvefinder) til at kombinere objekter til nye former.

Kurvefinder panel oversigt
Kurvefinder panel

Brug den øverste række af knapper i panelet for at oprette kurver eller sammensatte kurver. Du kan oprette sammensatte former ved at bruge knapperne i disse rækker, mens du trykker på Alt eller Alternativ-tasten. 

Vælg mellem følgende formtilstande:

Føj til formområde

Føjer komponentområdet til den underliggende geometri.

Subtraher fra formområde

Klipper komponentområdet ud af den underliggende geometri.

Gennemskær formområder

Bruger komponentområdet til at udklippe den underliggende geometri som en maske.

Udelad overlappende formområder

Bruger komponentområdet til at invertere den underliggende geometri og ændre udfyldte områder til huller og omvendt.

Brug den nederste række af knapper i panelet, også kaldet kurvefindereffekter, til at oprette endelige formkombinationer ved første klik. (Se Anvendelse af kurvefindereffekter.)

Kurvefindereffekter
Formtilstande

A. Alle komponenter i tilføjelsestilstand B. Subtraktionstilstand anvendt på firkanter C. Skæringstilstand anvendt på firkanter D. Udeladelsestilstand anvendt på firkanter 

Angiv kurvefinderindstillinger

Angiv kurvefinderindstillinger i panelmenuen Kurvefinder eller ved at dobbeltklikke på en kurvefindereffekt i panelet Udseende.

Præcision

Påvirker, hvor nøjagtigt Kurvefinder-effekterne beregner et objekts kurve. Jo mere præcis beregningen er, desto mere nøjagtig bliver tegningen, og desto mere tid kræves der for at oprette kurven.

Fjern overflødige punkter

Fjerner overflødige punkter, når du klikker på en kurvefinderknap.

Opdel og Kontur fjerner umalede illustrationer

Fjerner umalede illustrationer for at slette de ikke-udfyldte objekter i den markerede illustration, når du klikker på knappen Opdel eller knappen Kontur.

Anvendelse af kurvefindereffekter

Med kurvefindereffekter kan du oprette nye former ud fra overlappende objekter. Anvend kurvefindereffekter ved hjælp af menuen Effekter eller panelet Kurvefinder.

  • Kurvefindereffekter i menuen Effekter kan kun anvendes på grupper, lag og tekstobjekter. Når du har anvendt en effekt, kan du stadig markere og redigere de oprindelige objekter. Du kan også bruge panelet Udseende til at redigere eller fjerne effekten. Se Anvend en kurvefindereffekt ved hjælp af menuen Effekter.

  • Kurvefindereffekter i panelet Kurvefinder kan anvendes på alle kombinationer af objekter, grupper og lag. Den endelige kombination af former oprettes, når du klikker på en kurvefinderknap. Derefter kan du ikke redigere de oprindelige objekter. Hvis effekter resulterer i flere objekter, grupperes de automatisk sammen. Se Anvend en kurvefindereffekt ved hjælp af panelet Kurvefinder.

Anvendelse af en kurvefindereffekt ved hjælp af menuen Effekter

  1. Benyt en af følgende fremgangsmåder:
    • Grupper de objekter, du vil bruge, og marker gruppen.

      -eller-

    • Flyt de objekter, du vil bruge, til et separat lag, og marker laget.

  2. Vælg Effekt > Kurvefinder, og vælg derefter en kurvefindereffekt.

    Bemærk:

    Du kan hurtigt anvende den samme kurvefindereffekt igen ved at vælge Effekt > Anvend [effekt].

Anvendelse af en kurvefindereffekt ved hjælp af panelet Kurvefinder

  1. Marker de objekter, du vil anvende effekten på.

    Du kan anvende en kurvefindereffekt på en gruppe eller et lag ved at markere gruppen eller laget.

  2. Klik på en kurvefinderknap (i nederste række) i panelet Kurvefinder, eller hold Alt (Windows) eller Alternativ (Mac OS) nede, og klik på en formtilstandsknap (i øverste række).

Opsummering af kurvefindereffekter

Tilføj

Vektoriserer konturen af alle objekter, som om de var et enkelt, flettet objekt. Den efterfølgende form får det øverste objekts maleattributter.

Skæring

Vektoriserer konturen af det område, som alle objekterne overlapper.

Udelad

Vektoriserer alle områder af objekterne, som ikke overlapper hinanden, og gør overlappende områder gennemsigtige. Hvis et lige antal objekter overlapper hinanden, bliver overlapningen gennemsigtig. Hvis et ulige antal objekter overlapper hinanden, udfyldes overlapningen.

Subtraher

Trækker de forreste objekter fra det bageste objekt. Du kan bruge denne kommando til at slette områder i en illustration ved at justere stablingsrækkefølgen.

Minus bageste

Trækker de bageste objekter fra det forreste objekt. Du kan bruge denne kommando til at slette områder i en illustration ved at justere stablingsrækkefølgen.

Opdel

Opdeler en illustration i de flader, der er fyldt med komponenter (en flade er et område, som ikke er opdelt af et stregsegment).

Bemærk: Når du bruger knappen Opdel i panelet Kurvefinder, kan du bruge værktøjet Direkte markering eller Gruppemarkering til at redigere de efterfølgende flader uafhængigt af hinanden. Du kan også vælge at slette eller bevare udfyldte objekter, når du bruger kommandoen Opdel.

Renskær

Fjerner den del af et udfyldt objekt, der er skjult. Fjerner alle streger og fletter ikke objekter med samme farve.

Flet

Fjerner den del af et udfyldt objekt, der er skjult. Fjerner alle streger og fletter tilstødende eller overlappende objekter, der er udfyldt med samme farve.

Beskær

Opdeler en illustration i de flader, den er udfyldt af komponenter, og sletter derefter alle dele af illustrationen, som ligger uden for det øverste objekts grænser. Kommandoen fjerner også alle streger.

Kontur

Opdeler et objekt i de stregsegmenter, eller kanter, det består af. Denne kommando er praktisk til at forberede illustrationer, som skal have en diffusering til at overprinte objekter Se Opret en diffusering.

Bemærk: Når du bruger knappen Kontur i panelet Kurvefinder, kan du bruge værktøjet Direkte markering eller Gruppemarkering til at redigere hver kant for sig. Du kan også vælge at slette eller bevare objekter, der ikke er udfyldt, når du bruger kommandoen Kontur.

Hård

Kombinerer farver ved at vælge den højeste værdi for hver farvekomponent. Hvis Farve 1 f.eks. er 20 % cyan, 66 % magenta, 40 % gul og 0 % sort, og Farve 2 er 40 % cyan, 20 % magenta, 30 % gul og 10 % sort, er den viste farve 40 % cyan, 66 % magenta, 40 % gul og 10 % sort.

Blød

Gør de underliggende farver synlige gennem de illustrationer, der overlapper hinanden, og opdeler derefter billedet i dets komponentflader. Du angiver den synlighedsprocent, der skal være i de farver, som overlapper hinanden.

Diffusering

Kompenserer for potentielle afstande mellem farver i illustrationer ved at oprette et lille overlapområde (kaldet en diffusering) mellem to tilstødende farver.

Kombinering af objekter ved hjælp af sammensatte former

En sammensat form er grafik, som kan redigeres og består af to eller flere objekter, som hver har fået tildelt en formtilstand. Sammensatte former gør det nemt at oprette komplekse former, fordi du nøjagtigt kan redigere formtilstanden, stablingsrækkefølgen, formen, placeringen og udseendet af hver medtaget kurve.

Sammensatte forme fungerer som grupperede objekter og vises som elementer af typen <Sammensat form> i panelet Lag. Du kan bruge panelet Lag til at få vist, markere og redigere indholdet af en sammensat form. Du kan f.eks. ændre komponenternes stablingsrækkefølge. Du kan også bruge værktøjet Direkte markering eller Gruppemarkering til at markere en sammensat forms komponenter.

Når du opretter en sammensat form, får den male- og gennemsigtighedsattributterne for den øverste komponent i tilføjelses-, skærings- eller udeladelsestilstand. Du kan efterfølgende ændre den sammensatte forms male-, typografi- eller gennemsigtighedsattributter. Illustrator gør denne proces nem ved automatisk at markere hele den sammensatte form, når du markerer en del af den, medmindre du udtrykkeligt markerer en komponent i panelet Lag.

Sammensatte former
Arbejde med sammensatte former

A. Originale objekter B. Sammensat form oprettet C. Individuelle formtilstande anvendt på hver komponent D. Typografi anvendt på hel sammensat form 

Oprettelse af en sammensat form

  1. Marker alle objekter, der skal være en del af den sammensatte form.

    Du kan medtage kurver, sammensatte kurver, grupper, andre sammensatte former, blandinger, tekst, konvolutter og fordrejninger i en sammensat form. Åbne kurver lukkes automatisk.

  2. Benyt en af følgende fremgangsmåder:
    • Hold Alt (Windows) eller Alternativ (Mac OS) nede i panelet Kurvefinder, og klik på en formtilstandsknap. Hver komponent i den sammensatte form tildeles den formtilstand, du har valgt.

      -eller-

    • Vælg Opret sammensat form i menuen i panelet Kurvefinder. Hver komponent i den sammensatte form tildeles som standard tilføjelsestilstanden.

  3. Du kan vælge en ny formtilstand til en komponent ved at markere den med værktøjet Direkte markering eller i panelet Lag og klikke på en formtilstandsknap.

    Bemærk: Du behøver aldrig ændre den bageste komponents tilstand, fordi den ikke har betydning i forhold til den sammensatte form.

    Bemærk:

    Maksimal ydeevne opnås ved at oprette komplekse, sammensatte former og indlejre andre sammensatte former (som hver indeholder op til omkring 10 komponenter) i stedet for at bruge mange enkeltkomponenter.

Ændring af en sammensat form

  1. Brug værktøjet Direkte markering eller panelet Lag til at markere en enkelt komponent i den sammensatte form.
  2. Se efter den fremhævede formtilstandsknap i panelet Kurvefinder for at finde ud af, hvilken tilstand der er anvendt på en markeret komponent.

    Bemærk:

    Hvis du har markeret to eller flere komponenter, som bruger forskellige tilstande, indeholder formtilstandsknapperne spørgsmålstegn.

  3. Klik på en anden formtilstandsknap i panelet Kurvefinder.

Ophævning eller udvidelse af en sammensat form

Når du ophæver en sammensat form, opdeles den i de separate objekter igen. Når du udvider en sammensat form, bevares det sammensatte objekts form, men du kan ikke længere markere de enkelte komponenter.

  1. Marker den sammensatte form ved hjælp af markeringsværktøjet eller panelet Lag.
  2. Benyt en af følgende fremgangsmåder:
    • Klik på Udvid i panelet Kurvefinder.

      -eller-

    • Vælg Udvid sammensat form i panelmenuen Kurvefinder.

      Den sammensatte form konverteres til et element af typen <Kurve> eller <Sammensat kurve> i panelet Lag, afhængigt af den anvendte formtilstand.

      -eller-

    • Vælg Ophæv sammensat form i panelmenuen Kurvefinder.

Flytning af sammensatte former mellem Illustrator og Photoshop

Formlagene og lagfritlægningskurverne (vektormasker) i Adobe Photoshop er typer af sammensatte former. Du kan importere formlag og lagfritlægningskurver til Illustrator som sammensatte former og fortsætte med at redigere dem. Du kan derudover eksportere sammensatte former til Photoshop. Vær opmærksom på følgende, når du bruger sammensatte former med Photoshop:

  • Det er kun sammensatte former, der ligger øverst i laghierarkiet, som eksporteres til Photoshop som formlag.

  • En sammensat form, der er malet med en streg ved hjælp af en anden sammenføjning end rund eller med en tykkelse i punkter, som ikke er et heltal, rasteriseres, når den eksporteres til PSD-filformatet.

Kombinering af objekter ved hjælp af sammensatte kurver

En sammensat kurve indeholder to eller flere kurver, der males, så der forekommer huller, hvor kurverne overlapper hinanden. Når du definerer objekter som en sammensat kurve, får alle objekter i den sammensatte kurve male- og formatattributterne for det bageste objekt i stablingsrækkefølgen.

Sammensatte kurver fungerer som grupperede objekter og vises som elementer af typen <Sammensat kurve> i panelet Lag. Brug værktøjet Direkte markering eller Gruppemarkering til at markere en del af en sammensat kurve. Du kan ændre formen på de enkelte komponenter i en sammensat kurve, men du kan ikke ændre attributter for udseende, grafikformater eller effekter for enkelte komponenter, ligesom du heller ikke kan redigere komponenterne enkeltvis i panelet Lag.

Bemærk:

Hvis du vil have større fleksibilitet ved oprettelse af sammensatte kurver, kan du oprette en sammensat form og derefter udvide den.

Skæring af et hul i et objekt med en sammensat kurve

  1. Marker det objekt, der skal bruges som hul, og placer det, så det overlapper de objekter, du vil tilskære. Gentag dette trin for eventuelle andre objekter, du vil bruge som huller.
  2. Marker alle objekter, du vil medtage i den sammensatte kurve.
  3. Vælg Objekt > Sammensat kurve > Opret.

Anvendelse af udfyldningsregler på sammensatte kurver

Du kan angive, om en sammensat kurve er en ikke-snoet eller lige/ulige sammensat kurve.

Ikke-snoet udfyldningsregel

Bruger matematiske ligninger til at bestemme, om et punkt ligger uden for eller inden for en form. Illustrator bruger som standard reglen for ikke-snoet udfyldning.

Lige/Ulige udfyldningsregel

Bruger matematiske ligninger til at bestemme, om et punkt ligger uden for eller inden for en form. Denne regel er mest forudsigelig, fordi hvert andet område i en lige/ulige sammensat kurve er et hul, uanset kurveretningen. Visse apps som f.eks. Adobe Photoshop bruger som standard lige/ulige-reglen, så sammensatte kurver, der er importeret fra disse apps, bruger lige/ulige-reglen.

Selvgennemskærende kurver er kurver, der gennemskærer sig selv. Du kan vælge at gøre disse kurver enten ikke-snoede eller lige/ulige afhængigt af, hvordan de skal se ud.

Sammensatte kurver
Selvgennemskærende kurve med Brug ikke-snoet udfyldningsregel (venstre) sammenlignet med Brug lige/ulige udfyldningsregel (højre)

Når du opretter en ikke-snoet sammensat kurve, kan du angive, om overlappende kurver skal vises med huller eller udfyldes, ved at klikke på knappen Omvend kurveretning i panelet Attributter.

Fire cirkelformede kurver
Udfyldningsregler

A. Fire cirkelformede kurver B. Markerede cirkelformede kurver, konverteret til sammensat kurve C. Omvendt kurveretning anvendt på den inderste kurve 

Ændring af udfyldningsreglen for en sammensat kurve

  1. Marker den sammensatte kurve ved hjælp af markeringsværktøjet eller panelet Lag.
  2. Klik på knappen Brug ikke-snoet udfyldningsregel  eller knappen Brug lige/ulige udfyldningsregel  i panelet Attributter.

Ændring af et hul i en sammensat kurve til et udfyldt område

  1. Sørg for, at den sammensatte kurve bruger en ikke-snoet udfyldningsregel.
  2. Brug værktøjet Direkte markering til at markere den del af den sammensatte kurve, der skal vendes om. Du skal ikke markere hele den sammensatte kurve.

  3. Klik på knappen Omvend kurveretning slået fra  eller Omvend kurveretning slået til i panelet Attributter.

Gendannelse af en sammensat kurves oprindelige komponenter

  1. Marker den sammensatte kurve ved hjælp af markeringsværktøjet eller panelet Lag.
  2. Vælg Objekt > Sammensat kurve > Ophæv.

Dette arbejde har licens under en Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Opslag på Twitter™ og Facebook er ikke omfattet af vilkårene for Creative Commons.

Juridiske meddelelser   |   Politik for beskyttelse af personlige oplysninger online