Příručka uživatele Zrušit

Pole formulářů PDF s čárovým kódem

  1. Průvodce uživatele aplikace Acrobat
  2. Úvod do aplikace Acrobat
    1. Získejte přístup k aplikaci Acrobat z počítače, mobilního zařízení a webu
    2. Co je nového v aplikaci Acrobat
    3. Klávesové zkratky
    4. Systémové požadavky
  3. Pracovní plocha
    1. Základy práce s pracovní plochou
    2. Otevírání a prohlížení souborů PDF
      1. Otevírání souborů PDF
      2. Navigace ve stránkách PDF
      3. Zobrazení předvoleb PDF
      4. Úpravy zobrazení souborů PDF
      5. Povolení náhledu miniatur souborů PDF
      6. Zobrazit soubor PDF v prohlížeči
    3. Práce s online účty úložiště
      1. Získejte přístup k souborům ze služby Box
      2. Získejte přístup k souborům ze služby Dropbox
      3. Získejte přístup k souborům ze služby OneDrive
      4. Získejte přístup k souborům ze služby SharePoint
      5. Získejte přístup k souborům ze služby Disk Google
    4. Aplikace Acrobat a systém macOS
    5. Oznámení aplikace Acrobat
    6. Mřížky, vodítka a měření v souborech PDF
    7. Asijský, řecký a zprava doleva psaný text v souborech PDF
  4. Vytváření PDF
    1. Přehled vytváření dokumentů PDF
    2. Vytvořit dokumenty PDF pomocí aplikace Acrobat
    3. Vytvořit soubory PDF pomocí aplikace PDFMaker
    4. Používání tiskárny Adobe PDF
    5. Převod webových stránek do PDF
    6. Tvorba souborů PDF pomocí Acrobat Distiller
    7. Nastavení převodu souborů PDF v aplikaci Acrobat
    8. Písma PDF
  5. Úpravy souborů PDF
    1. Úpravy textu v souborech PDF
    2. Úpravy obrázků nebo objektů v PDF
    3. Otočení, přesunutí, odstranění a přečíslování stránek PDF
    4. Úpravy naskenovaných PDF
    5. Vylepšení fotografií dokumentů pořízených fotoaparátem mobilního zařízení
    6. Optimalizace souborů PDF
    7. Vlastnosti a metadata souborů PDF
    8. Odkazy a přílohy v souborech PDF
    9. Vrstvy PDF
    10. Miniatury stránek a záložky v dokumentech PDF
    11. Průvodce akcí (Acrobat Pro)
    12. Dokumenty PDF převedené na webové stránky
    13. Nastavení dokumentů PDF pro prezentaci
    14. Články PDF
    15. Geoprostorové dokumenty PDF
    16. Použití akcí a skriptů na dokumenty PDF
    17. Změna výchozího písma pro přidávání textu
    18. Odstranit stránky z dokumentu PDF
  6. Skenování a OCR
    1. Skenování dokumentů do PDF
    2. Vylepšení fotografií dokumentů
    3. Řešení potíží při skenování pomocí aplikace Acrobat
  7. Formuláře
    1. Základy formulářů PDF
    2. Vytvořte si vlastní formulář v aplikaci Acrobat
    3. Tvorba a rozeslání formulářů PDF
    4. Vyplnit formuláře PDF
    5. Vlastnosti polí formuláře PDF
    6. Vyplnit a podepsat formuláře PDF
    7. Nastavení tlačítek akcí ve formulářích PDF
    8. Publikování interaktivních webových formulářů PDF
    9. Základy polí formulářů PDF
    10. Pole formulářů PDF s čárovým kódem
    11. Shromáždit a spravovat data formulářů PDF
    12. O nástroji Sledování formulářů
    13. Nápověda k formulářům PDF
    14. Odeslat formuláře PDF příjemcům pomocí e-mailu nebo interního serveru
  8. Slučování souborů
    1. Kombinování nebo sloučení souborů do jednoho PDF
    2. Otočení, přesunutí, odstranění a přečíslování stránek PDF
    3. Přidání záhlaví, zápatí a Batesova čísla do souborů PDF
    4. Oříznout stránky PDF
    5. Přidat vodoznaky do souborů PDF
    6. Přidat pozadí do souborů PDF
    7. Práce s dílčími soubory v portfoliu PDF
    8. Publikování a sdílení portfolií PDF
    9. Přehled portfolií PDF
    10. Vytváření a přizpůsobení portfolií PDF
  9. Sdílení, kontrola a přidávání poznámek
    1. Sdílet a sledovat soubory PDF online
    2. Vyznačit úpravy textu
    3. Příprava k recenzi dokumentu PDF
    4. Zahájení recenze PDF
    5. Hosting sdílených kontrol na webech SharePoint nebo Office 365
    6. Účast na kontrole souboru PDF
    7. Přidat poznámky do souborů PDF
    8. Přidávání razítek do souboru PDF
    9. Pracovní postupy schvalování
    10. Správa poznámek | zobrazení, odpověď, tisk
    11. Import a export poznámek
    12. Sledování a správa kontrol souborů PDF
  10. Ukládání a export dokumentů PDF
    1. Ukládání PDF
    2. Převést soubor PDF do formátu Word
    3. Převést soubor PDF do formátu JPG
    4. Převést nebo exportovat dokumenty PDF do jiných formátů souborů
    5. Možnosti formátu souborů pro export do formátu PDF
    6. Opakované použití obsahu PDF
  11. Zabezpečení
    1. Rozšířená nastavení zabezpečení pro soubory PDF
    2. Zabezpečení souborů PDF pomocí hesel
    3. Správa digitálních ID
    4. Zabezpečení souborů PDF pomocí certifikátů
    5. Otevření zabezpečených souborů PDF
    6. Odstranění důvěrného obsahu ze souborů PDF
    7. Nastavení zásad zabezpečení pro soubory PDF
    8. Možnost metody zabezpečení pro dokumenty PDF
    9. Upozornění zabezpečení při otevření souboru PDF
    10. Zabezpečení souborů PDF pomocí serveru Adobe Experience Manager
    11. Funkce chráněného zobrazení pro soubory PDF
    12. Přehled zabezpečení v aplikaci Acrobat a v dokumentech PDF
    13. JavaScript v dokumentech PDF jako riziko zabezpečení
    14. Přílohy jako bezpečnostní rizika
    15. Povolení nebo zablokování odkazů v dokumentech PDF
  12. Elektronické podpisy
    1. Podepsat dokumenty PDF
    2. Zachyťte svůj podpis na mobilu a používejte jej všude
    3. Odeslat dokumenty k elektronickému podpisu
    4. O podpisech certifikátů
    5. Podpisy založené na certifikátech
    6. Ověření digitálních podpisů
    7. Program Adobe Approved Trust List
    8. Spravovat důvěryhodné identity
  13. Tisk
    1. Základní tiskové úlohy PDF
    2. Tisk brožur a portfolií PDF
    3. Další nastavení tisku PDF
    4. Tisk do souboru PDF
    5. Tisk barevných souborů PDF (Acrobat Pro)
    6. Tisk souborů PDF ve vlastních velikostech
  14. Usnadnění přístupu, tagy a přeformátování
    1. Vytvořit a ověřit usnadnění přístupu souboru PDF
    2. Funkce pro usnadnění přístupu v dokumentech PDF
    3. Nástroj Pořadí čtení pro dokumenty PDF
    4. Čtení PDF s přeformátováním a usnadnění přístupu
    5. Upravit strukturu dokumentu pomocí panelů Obsah a Tagy
    6. Tvorba souborů PDF s usnadněním přístupu
  15. Prohledávání a indexování
    1. Tvorba indexů PDF
    2. Prohledávání souborů PDF
  16. Multimédia a 3D modely
    1. Přidat audio, video a interaktivní objekty do dokumentů PDF
    2. Přidání 3D modelů do souborů PDF (Acrobat Pro)
    3. Zobrazení 3D modelů v souborech PDF
    4. Interakce s 3D modely
    5. Měření 3D objektů v souborech PDF
    6. Nastavení 3D zobrazení v souborech PDF
    7. Povolit 3D obsah v souborech PDF
    8. Přidat multimédia do souborů PDF
    9. Přidávání komentářů k 3D návrhům v souborech PDF
    10. Přehrávání videa, zvuku a multimediálních formátů v dokumentech PDF
    11. Přidat poznámky do videí
  17. Nástroje pro tiskovou produkci (Acrobat Pro)
    1. Přehled nástrojů pro tiskovou produkci
    2. Tiskové značky a vlasové čáry
    3. Náhled výstupu
    4. Sloučení průhledností
    5. Převod barev a správa tiskových barev
    6. Vytváření přesahů barev
  18. Kontrola před výstupem (Acrobat Pro)
    1. Soubory vyhovující PDF/X, PDF/A a PDF/E
    2. Profily kontroly před výstupem
    3. Rozšířené kontroly před výstupem
    4. Zprávy kontroly před výstupem
    5. Zobrazení výsledků kontroly před výstupem, objektů a zdrojů
    6. Výstupní záměry v souborech PDF
    7. Oprava problémových oblastí pomocí nástroje Kontrola před výstupem
    8. Automatická analýza dokumentu pomocí akcí dropletu nebo kontroly před výstupem
    9. Analýza dokumentů pomocí nástroje Kontrola před výstupem
    10. Dodatečné kontroly v nástroji Kontrola před výstupem
    11. Knihovny kontroly před výstupem
    12. Proměnné kontroly před výstupem
  19. Správa barev
    1. Zachování shodných barev
    2. Nastavení barev
    3. Správa barev v dokumentech
    4. Práce s profily barev
    5. Principy správy barev

Tento dokument vysvětluje pole čárového kódu ve formuláři PDF v aplikaci Acrobat. (Pokud hledáte více informací o vlastnostech polí formuláře, klikněte na příslušný odkaz výše.)

 

O čárových kódech

Pole s čárovými kódy převádějí uživatelovy údaje ve formuláři do vizuálního vzorku, který je možné naskenovat, interpretovat a zahrnout do databáze. Čárové kódy jsou užitečné v případě, že uživatelé odesílají formulář na papíru nebo faxem.

Výhodou čárových kódů je, že šetří čas, odstraňují nutnost ručního čtení a záznamu odpovědí a eliminují možnosti výskytu chyb při zadávání dat.

Obvyklý pracovní postup s čárovými kódy zahrnuje následující fáze:

  • Autor formuláře zkontroluje, že v předvolbách pro formuláře je vybraná možnost Automaticky počítat hodnoty polí a pak vytvoří v aplikaci Acrobat formulář se všemi ostatními poli nastavenými jako obvykle.

  • Autor formuláře přidá do formuláře pole čárového kódu a nastaví čárový kód tak, že zachytí požadovaná data.

  • Autor formuláře povolí vyplňování formuláře pro uživatele aplikace Acrobat Reader (pokud autor chce umožnit uživatelům této aplikace ukládat jejich vlastní vyplněné kopie formuláře nebo pokud formulář obsahuje některé typy polí čárových kódů).

  • Autor formuláře rozešle formulář ostatním uživatelům.

  • Uživatelé na svých počítačích vyplní formulář, elektronicky ho odešlou nebo vytisknou kopii a doručí ji distributorovi formuláře.

  • Přijatá data čárového kódu jsou interpretována jedním z následujících způsobů a pak je může příjemce formuláře zkontrolovat, uspořádat a použít:

    Formuláře odeslané faxem na faxový server

    Příjemce formuláře může pomocí aplikace Adobe Acrobat Capture® získat TIFF obrázky z faxového serveru a umístit je do sledované složky programu Adobe LiveCycle Barcoded Forms Decoder, pokud tyto produkty vlastní.

    Formuláře doručené na papíře

    Příjemce formuláře může naskenovat papírové formuláře a pak pomocí aplikace, jako je například LiveCycle Designer Barcoded Forms Decoder, dekódovat čárové kódy v těchto formulářích.

Poznámka:

Aplikace Acrobat Capture a Adobe LiveCycle Barcoded Forms Decoder jsou samostatné produkty vhodné pro firemní pracovní postupy a prodávají se nezávisle na aplikaci Acrobat.

Tipy pro návrh s čárovými kódy

Návrh a umístění čárových kódů ovlivňuje především použitelnost a zabrané místo. Například velikost čárového kódu může omezovat množství dat, která v něm mohou být zakódována. Chcete-li dosáhnout nejlepších výsledků, dodržujte tato pravidla.

  • Umístěte čárový kód tak, aby bylo nepravděpodobné, že se ohne při vložení do obálky, a dostatečně daleko od okrajů stránky, aby se neoříznul při tisku nebo odesílání faxem.

  • Umístěte jej tak, aby byl dobře viditelný a skenovatelný. Pokud se bude používat ruční skener, vyhněte se čárovým kódům, které jsou širší než 10,3 cm (4 palce). V tomto případě obvykle fungují nejlépe vysoké a úzké čárové kódy. Také se při používání ručního skeneru vyhněte komprimaci obsahu čárového kódu.

  • Zkontrolujte, že velikost čárového kódu má kapacitu pro množství dat, která chcete zakódovat. Pokud je oblast čárového kódu příliš malá, změní barvu na sytě šedou. Před distribucí otestujte vyplněný formulář, abyste se přesvědčili, že oblast čárového kódu má dostatečnou velikost.

Vytváření, testování a úpravy polí s čárovými kódy

Jeden ze způsobů, kterým můžete vylepšit čárový kód PDF formuláře je vytváření uživatelských skriptů. Psaní takových skriptů vyžaduje základní znalosti JavaScriptu a zkušenost s JavaScriptem specifickým pro Acrobat. Další informace viz příručka Vývoj aplikací Acrobat® s využitím jazyka JavaScript™ na webu www.adobe.com/go/learn_acr_javascript_en (PDF, pouze v angličtině). Více informací o základním JavaScriptu najdete v libovolném z mnoha dostupných zdrojů o tomto předmětu.

Poznámka:

Po vložení čárového kódu maximální velikosti může změna velikost buňky nebo podmínek dekódování způsobit, že čárový kód přesáhne přes okraje stránky. Tomu můžete předejít výběrem přiměřené velikosti buňky a podmínek dekódování čárového kódu.

Přidání pole s čárovým kódem

  1. Otevřete formulář v aplikaci Acrobat. Otevřete dialogové okno Předvolby (Upravit > Předvolby) a vlevo vyberte možnost Formuláře. Pak vyberte možnost Automaticky počítat hodnoty polí.

  2. Vyberte možnost Nástroje > Připravit formulář.

  3. Na panelu nástrojů klikněte na ikonu Čárový kód .

  4. Tažením nakreslete obdélník definující oblast s čárovým kódem a poté dvojitým kliknutím na pole s čárovým kódem otevřete dialogové okno Vlastnosti.
  5. Na kartě Hodnota proveďte jeden z následujících úkonů:
    • Vyberte Kódovat pomocí a pak vyberte formát (XML nebo Oddělovaný tabulátory). Klikněte na tlačítko Vybrat a vyberte pole, která chcete zakódovat do pole čárového kódu. Pokud nechcete do dat čárového kódu zahrnout názvy polí, odznačte možnost Zahrnout názvy polí.

    • Vyberte Vlastní skript výpočtu, klikněte na Upravit a pak zadejte svůj vlastní kód JavaScriptu v dialogovém okně Editor JavaScriptu.

  6. Na kartě Možnosti proveďte jeden z následujících úkonů:
    • Vyberte možnost Symbologie: PDF417, QR Code nebo Data Matrix.

    • Pokud chcete použít komprimaci, vyberte Komprimovat data před zakódováním do čárového kódu. Pokud je ke čtení dat z vrácených formulářů použit ruční skener, tuto možnost nevybírejte.

    • V nabídce Podmínka dekódování zvolte typ hardwaru pro zpracování vrácených formulářů: Ruční skener čárových kódů, faxový server,dokumentový skener nebo vlastní.

    • Pokud je to nezbytné, klikněte na Vlastní a zadejte hodnoty pro Rozměr X, Poměr Y/X a Úroveň korekce chyb.

  7. Proveďte libovolné další změny na kartě Všeobecné a Akce. Potom zavřete dialogové okno Vlastnosti pole čárového kódu.

    Kód JavaScriptu k zašifrování vybraných polí do formátu XML nebo Oddělený tabulátory je vygenerován automaticky. Dialogové okno Vlastnosti pole čárového kódu se uzavře a čárový kód, pro který jste zadali hodnoty, se zobrazí ve formuláři.

    Poznámka:

    Pokud po vytvoření čárového kódu přidáte do formuláře nové pole, není automaticky zahrnuto mezi data pro již existující čárové kódy. Ale další datová pole můžete do čárového kódu přidat ručně.

Testování pole s čárovým kódem

  1. Na panelu nástrojů klikněte na tlačítko Náhled.

  2. Vyplňte formulář. Použijte vzorové údaje, které představují maximální množství informací pro každé pole, nebo množství informací, které očekáváte, že uživatelé budou zadávat.
  3. Pokud je pole s čárovým kódem zobrazeno tlumeně, postupujte podle libovolného postupu pro změnu velikosti pole s čárovým kódem nebo pro změnu údajů obsahu. (Viz následující úlohy.)
  4. Ujistěte se, že je oblast pole s čárovým kódem dostatečně velká, aby se do ní vešly všechny vstupní údaje. Chcete-li odstranit vzorová data, klikněte v pravém panelu na příkaz Více > Vymazat formulář.

  5. Vyberte příkaz Soubor > Uložit.

Pole formuláře s čárovým kódem je nyní připraveno k distribuci.

Zahrnutí dalších datových polí do čárového kódu

  1. Nejste-li v režimu úprav formuláře, vyberte možnost Nástroje > Připravit formulář.

  2. Dvakrát klikněte na pole s čárovým kódem.
  3. Na kartě Hodnota proveďte jeden z následujících úkonů:
    • Pokud je vybraná možnost Kódovat pomocí, klikněte na možnost Vybrat a vyberte další pole formuláře, která chcete zakódovat.

    • Pokud je vybraná možnost Vlastní skript výpočtu, klikněte na možnost Upravit a zapište další JavaScript, který zahrne další pole.

Po zahrnutí nových datových polí do čárového kódu se nezapomeňte přesvědčit, že oblast čárového kódu je dostatečně velká pomocí testování se vzorovými daty. Pokud je oblast s čárovým kódem zobrazena tlumeně, upravte velikost čárového kódu nebo vlastnosti textového pole, aby se údaje do oblasti s čárovým kódem vešly.

Jak nastavit datový obsah, aby se vešel do pole s čárovým kódem

  1. Nejste-li v režimu úprav formuláře, vyberte možnost Nástroje > Připravit formulář.

  2. Dvakrát klikněte do pole čárového kódu a použijte některý z následujících postupů:

    • Na kartě Možnosti klikněte na tlačítko Vlastní a zadejte nižší hodnoty pro položky Úroveň korekce chyb a Poměr Y/X.

    • Na kartě Možnosti vyberte možnost Komprimovat data před zakódováním do čárového kódu, pouze však v případě, že používáte softwarový dekodér Adobe.

    • Na kartě Možnosti vyberte jako formát kódování dat místo možnosti XML spíše možnost Oddělený tabulátory. XML vyžaduje pro zakódování informací větší oblast čárového kódu než Oddělený tabulátory.

    • Na kartě Možnosti vyberte jinou možnost Symbologie.

    • Na kartě Hodnota klikněte na tlačítko Vybrat a zrušte označení všech polí, která nemusí být kódována. Například nezahrnujte pole s nadbytečnými informacemi..

    • Na kartě Hodnota zadejte vlastní skript, který v rámci procesu kódování upraví uživatelem zadaný text tak, že budou všechny znaky převedeny na malá nebo velká písmena.

    Poznámka:

    Pravidla asociace NACTP (National Association of Computerized Tax Processors), používaná americkým úřadem pro daňové příjmy a státními daňovými úřady, doporučují používat pro data 2D čárového kódu velká písmena.

  3. Pokud potřebujete minimalizovat oblast s čárovým kódem obsahující data, dvakrát klikněte na pole s čárovým kódem a na kartě Hodnota napište vlastní skript, který omezí údaje na alfanumerické znaky a na jednotnou velikost znaků. (Text, který je celý buď velkými nebo malými písmeny, vyžaduje menší oblast čárového kódu než stejný text zapsaný střídavě velkými a malými písmeny.)
Poznámka:

Zvažte vytvoření dalších polí čárového kódu ve formuláři a mapování různých dat do jednotlivých polí čárového kódu.

Nastavení navigace mezi poli formuláře

Pokud nemá dokument PDF nastaveno pořadí procházení polí pomocí tabulátoru a pokud uživatel nezrušil výběr u možnosti Pořadí polí v předvolbách Usnadnění přístupu, je výchozí pořadí procházení polí založeno na struktuře dokumentu.

Pořadí procházení polí můžete změnit po vytvoření polí. Pokud se nacházíte v režimu úprav formuláře, můžete pořadí procházení polí seřadit podle struktury dokumentu (výchozí), podle řádku nebo podle sloupce. Pořadí polí také můžete změnit automaticky jejich přetažením v panelu Pole. Pokud se nenacházíte v režimu úprav, můžete pole seřadit podle řádku nebo sloupce ve vlastnostech stránky. Pořadí polí však nemůžete přizpůsobit ručně.

Nastavení pořadí procházení v režimu úprav

  1. Nejste-li v režimu úprav formuláře, vyberte možnost Nástroje > Připravit formulář.

  2. V panelu Pole po pravé straně se ujistěte, že není vybrána možnost Seřadit podle > Pořadí polí.

  3. (Volitelné) Chcete-li zobrazit pořadí procházení polí, tak na panelu Pole vyberte příkaz Pořadí procházení > Zobrazit čísla procházení.

  4. Vyberte možnost Pořadí polí:

    Seřadit pole podle struktury

    Pořadí polí založené na struktuře dokumentu sledující pořadí nastavené ve struktuře tagování.

    Seřadit pole podle řádku

    Pomocí tabulátoru prochází pole od levého horního pole, nejdříve zleva doprava a pak dolů, řádek po řádku.

    Seřadit pole podle sloupce

    Pomocí tabulátoru prochází pole od levého horního pole, nejdříve shora dolů a pak napříč zleva doprava, sloupec po sloupci.

    Seřadit pole ručně

    Umožňuje přetahování polí na požadované místo v panelu Pole. Pole nelze přesunout na jinou stránku, přepínací tlačítko nelze přesunout do jiné skupiny a pole nelze přesunout mezi přepínací tlačítka.

    Neurčené pořadí polí

    Sděluje, že nebylo určeno žádné pořadí polí. Pořadí polí je určeno nastavením ve vlastnostech stránky.

Nastavení pořadí procházení polí v okně Vlastnosti stránky

  1. Jste-li v režimu pro úpravy formulářů, tak tento režim ukončete kliknutím na tlačítko s křížkem v pravé části panelu nástrojů.

  2. Klikněte na tlačítko Miniatury stránek nebo vyberte možnost Zobrazení > Zobrazit/Skrýt > Navigační panely >Miniatury stránek a otevře se panel Miniatury stránek.

  3. Vyberte jednu nebo více ikon stránek a poté v nabídce Možnosti na panelu Miniatury stránek vyberte položku Vlastnosti stránky. Můžete také kliknout pravým tlačítkem a vybrat možnost Vlastnosti stránky.

  4. Vyberte možnost Pořadí polí:

    Použít pořadí po řádcích

    Pomocí tabulátoru prochází pole od levého horního pole, nejdříve zleva doprava a pak dolů, řádek po řádku.

    Použít pořadí po sloupcích

    Pomocí tabulátoru prochází pole od levého horního pole, nejdříve shora dolů a pak napříč zleva doprava, sloupec po sloupci.

    Použít strukturu dokumentu

    Pro formuláře s tagovanými poli se použije pořadí nastavené v tagování.

    Neurčené

    Použije stávající pořadí.

  5. Klikněte na OK.

Logo Adobe

Přihlaste se ke svému účtu.