Vytvoření a správa indexu v PDF

Vložením indexu slov do dokumentu můžete zkrátit dobu potřebnou k prohledání dlouhého PDF. Acrobat DC umí prohledat index mnohem rychleji než dokument. Vložený index je zahrnutý i do rozesílaných nebo sdílených kopií PDF. Uživatelé prohledávají PDF s vloženým indexem přesně stejně, jako bez vloženého indexu – nejsou potřebné žádné kroky navíc.

Přidání indexu do PDF

  1. Když je dokument otevřený v Acrobatu DC, vyberte Nástroje > Index.

    Na sekundárním panelu nástrojů se zobrazí sada nástrojů Index.

  2. Na sekundárním panelu nástrojů klikněte na položku Správa vloženého indexu.

  3. V dialogovém okně Správa vloženého indexu klikněte na Vložit index.

  4. Přečtěte si zprávy, které se objeví, a klikněte na OK.

    Poznámka:

    V Outlooku a Lotus Notes máte možnost vložit index, když převádíte e-mailové zprávy nebo složky do PDF. To se doporučuje zejména pro složky obsahující velké množství e-mailových zpráv.

Aktualizace nebo odstranění vloženého indexu v PDF

  1. Zvolte Nástroje > Index.

    Na sekundárním panelu nástrojů se zobrazí sada nástrojů Index.

  2. Na sekundárním panelu nástrojů klikněte na položku Správa vloženého indexu.

  3. Klikněte buď na Aktualizovat index nebo na Odstranit index.

O funkci Katalog (Acrobat Pro DC)

Specifickou skupinu souborů PDF můžete definovat jako katalog a vytvořit sjednocený index pro celou tuto kolekci dokumentů. Pokud uživatel hledá v souborech PDF v katalogu určitou informaci, je hledání díky indexu mnohem rychlejší.

Když distribuujete kolekci na CD, můžete k souborům PDF přidat i index.

Katalog můžete vytvořit pro dokumenty psané latinkou nebo čínskými, japonskými nebo korejskými znaky. Do katalogu můžete zahrnout text dokumentu, poznámky, záložky, pole formulářů, tagy, metadata objektů a dokumentu, přílohy, informace o dokumentu, digitální podpisy, obrazová metadata XIF (extended image file format) a uživatelské vlastnosti dokumentu.

Příprava souborů PDF pro indexování (Acrobat Pro DC)

Začněte vytvořením složky, která bude obsahovat soubory PDF, které chcete indexovat. Všechny PDF by měly mít hotový jak obsah, tak i elektronické vlastnosti, jako jsou vazby, záložky a pole formuláře. Pokud jsou mezi indexovanými soubory také skenované dokumenty, zkontrolujte, zda je možné jejich text prohledávat. Rozdělte dlouhé dokumenty do menších souborů podle kapitol, abyste zvýšili rychlost prohledávání. Můžete také přidat informace do vlastností dokumentu, abyste zlepšili vyhledatelnost souboru.

Dříve než začnete indexovat kolekci dokumentů, je nezbytné, abyste vytvořili strukturu dokumentů na disku nebo síťovém serveru a zkontrolovali názvy souborů pro různé platformy. Názvy souborů se mohou při prohledávání na jiné platformě zkrátit a jejich vyhledání může být obtížné. Chcete-li těmto problémům předejít, dodržujte tato pravidla:

  • Přejmenujte soubory, složky a indexy podle konvencí pro pojmenovávání souborů pro MS-DOS (osm nebo méně znaků následovaných třemi znaky přípony souboru), zvláště pokud plánujete dodávat kolekci dokumentů a index na CD-ROM disku ve formátu ISO 9660.

  • Odstraňte rozšířené znaky, jako jsou znaky s diakritikou a ne-anglické znaky, z názvů souborů a složek. (Písmo používané funkcí Katalog nepodporuje znaky s kódy 133 až 159.)

  • Nepoužívejte hluboko vnořené složky nebo názvy cest, které jsou delší než 256 znaků, pro indexy, které budou prohledávány uživateli Mac OS.

  • Pokud používáte Mac OS se serverem OS/2 LAN, konfigurujte server IBM® LAN Server Macintosh (LSM) tak, aby vyžadoval konvence pojmenování souborů pro MS-DOS, nebo indexujte pouze svazky se systémem FAT (File Allocation Table). (Svazky HPFS [High Performance File System] mohou obsahovat dlouhé, nenačítatelné názvy souborů.)

    Pokud struktura dokumentů obsahuje podsložku, kterou nechcete indexovat, můžete jí během procesu indexaci vyloučit.

Přidání metadat do vlastností dokumentu (Acrobat Pro DC)

Chcete-li usnadnit vyhledání PDF, můžete do vlastností dokumentu přidat informace o souboru nazývané metadata. (Vlastnosti právě otevřeného PDF si můžete zobrazit pomocí příkazu Soubor > Vlastnosti dokumentu a kliknutím na záložku Popis.)

Když přidáváte údaje do vlastností dokumentu, řiďte se podle následujících doporučení:

  • V poli Titul použijte vhodný popisný titul. Název souboru dokumentu by se měl objevit v dialogovém okně Výsledky hledání.

  • Pro podobné informace používejte vždy stejnou volbu (pole). Nepřidávejte například důležité informace v některých dokumentech do pole Předmět a v jiných dokumentech do pole Klíčová slova.

  • Používejte stále jeden termín pro stejnou informaci. Nepoužívejte například v některých dokumentech geografie a v jiných dokumentech zeměpis .

  • Pro identifikaci osoby nebo skupiny osob, které zodpovídají za obsah dokumentu, použijte pole Autor. Například autorem dokumentu o náborové politice firmy by mohlo být Personální oddělení.

  • Pokud používáte evidenční čísla dokumentů, přidejte je jako Klíčová slova. Zadejte například do pole Klíčová slova dok=m234, abyste označili specifický dokument mezi stovkami dokumentů na určité téma.

  • Pro kategorizaci dokumentů podle typu použijte pole Předmět nebo Klíčová slova nebo obě tato pole společně. Jako údaj v poli Předmět můžete například použít slovo výkaz a jako údaj v poli Klíčová slova použít pro jednotlivé dokumenty týdenní nebo měsíční .

    Pokud již máte speciální znalosti o Adobe PDF, můžete při vytváření indexu definovat vlastní datová pole, například Typ dokumentu, Číslo dokumentu nebo Identifikátor dokumentu. Tento postup se doporučuje pouze pro pokročilé uživatele a není popsán ani v úplné nápovědě pro Acrobat.

Vytvoření indexu pro kolekci (Acrobat Pro DC)

Když sestavujete nový index, Acrobat DC vytvoří soubor s příponou .pdf a novou pomocnou složku, která obsahuje jeden nebo více souborů s příponou .idx. Soubory IDX obsahují položky indexu. Všechny tyto soubory musí být dostupné pro uživatele, který chce index prohledávat.

  1. Zvolte Nástroje > Index.

    Na sekundárním panelu nástrojů se zobrazí sada nástrojů Index.

  2. Na sekundárním panelu nástrojů klikněte na Fulltextový index s modulem Katalog.

    Zobrazí se dialogové okno Katalog.

  3. V dialogovém okně Katalog klikněte na Nový index.

    Zobrazí se dialogové okno Definice nového indexu.

    Definice nového indexu v Acrobatu
    Dialogové okno Definice nového indexu.

  4. V poli Titul indexu zadejte název pro soubor indexu.

  5. Do pole Popis indexu napište pár slov o typu indexu a jeho účelu.

  6. Klikněte na Volby, vyberte libovolné pokročilé volby, které chcete pro index aplikovat, a klikněte na OK.

    Dialogové okno Volby v Acrobatu
    V dialogovém okně Volby můžete určit pokročilé volby pro nový index.

  7. Pod Zahrnout tyto složky klikněte na Přidat, vyberte složku obsahující některé nebo všechny soubory PDF, které chcete indexovat, a klikněte na OK. Chcete-li přidat více složek, zopakujte tento krok.

    Poznámka:

    Všechny složky vnořené pod zahrnutou složkou budou také zahrnuty do procesu vytváření indexu. Pokud nebudete přemísťovat index ani jednotlivé soubory v kolekci dokumentů, můžete přidat složky z více serverů nebo disků.

  8. V části Vyloučit tyto podsložky klikněte na Přidat a vyberte libovolnou vnořenou složku obsahující soubory PDF, které nechcete indexovat. Klikněte na OK a tento krok opakujte podle potřeby.

  9. Zkontrolujte volby. Chcete-li upravit seznamy zahrnutých nebo vyloučených složek, vyberte složku, kterou chcete změnit, a klikněte na Odstranit.

  10. Klikněte na Vytvořit a pak určete umístění souboru indexu. Klikněte na Uložit a pak:

    • Klikněte na Zavřít, až vytváření indexu skončí.

    • Klikněte na Stop, chcete-li vytváření indexu zrušit.

    Poznámka:

    Pokud proces indexování zastavíte, nemůžete obnovit daný proces indexování, ale nemusíte znovu zadávat volby. Výběr voleb a složek zůstane beze změn. Můžete klepnout na na Otevřít index, vybrat částečně dokončený index a opravit ho.

    Poznámka:

    Pokud se názvy dlouhých cest ve volbách Zahrnout tyto složky a Vyloučit tyto podsložky zkrátí, podržte ukazatel nad třemi tečkami (...), dokud se neobjeví tip, ve kterém se zobrazí celá cesta zahrnuté nebo vyloučené složky.

Dialogové okno Volby indexování

Nezahrnout čísla

Vyberte tuto volbu, chcete-li z indexu vyloučit všechna čísla, která se vyskytují v textu dokumentu. Vyloučením čísel můžete dosáhnout podstatného zmenšení indexu a tím zrychlení prohledávání.

Přidat ID k souborům Adobe PDF v 1.0

Vyberte tuto volbu, pokud vaše kolekce obsahuje PDF vytvořené ve starší verzi aplikace než Acrobat 2.0, která automaticky nepřidávala identifikační čísla. Identifikační čísla jsou potřebná, když se dlouhé názvy souborů Mac OS zkrátí při jejich převodu na názvy souborů MS-DOS. Acrobat 2.0 a novější verze přidávají identifikátory automaticky.

Při hledání neupozorňovat na změněné dokumenty

Když tato volba není vybraná, objeví se zpráva při prohledávání dokumentů, které byly změněny od posledního vytvoření indexu.

Uživatelské vlastnosti

Použijte tuto volbu, chcete-li do indexu zahrnout uživatelské vlastnosti dokumentu. Budou se indexovat pouze uživatelské vlastnosti dokumentu, které již v indexovaných PDF existují. Zapište vlastnost, proveďte výběr z nabídky Typ, a pak klepněte na Přidat. Tyto vlastnosti se objeví jako další kritéria v rozbalovacích nabídkách voleb hledání v okně Prohledat PDF při prohledávání výsledného indexu. Pokud například zadáte uživatelskou vlastnost Název dokumentu a v nabídce Typ zvolíte, že je to textová vlastnost, uživatel prohledávající index pak může hledat v této uživatelské vlastnosti, když vybere Název dokumentu z nabídky Použít tato další kritéria.

Poznámka:

Když vytvoříte uživatelská pole v aplikaci Microsoft Office a máte v modulu PDFMaker vybranou volbu Převést informace o dokumentu, pole se přenese do všech souborů PDF, které vytvoříte.

Pole XMP

Použijte tuto volbu, pokud chcete zahrnout uživatelská pole XMP. Uživatelská pole XMP se budou indexovat a objeví se v rozbalovacích nabídkách dalších kritérií, abyste je mohli prohledávat ve vybraných indexech.

Vyloučená slova

Použijte k vyloučení určitých slov (maximálně 500) z výsledků prohledávání indexu. Zadejte slovo, klepněte na Přidat, a opakujte to podle potřeby. Vyloučení slov z indexu ho může zmenšit o 10 až 15 %. Vyloučená slova mohou mít až 128 znaků a rozlišují se v nich malá a velká písmena.

Poznámka:

Chcete-li předejít tomu, že uživatelé budou zkoušet hledat fráze, které obsahují tato slova, uveďte seznam slov, která nejsou indexovaná v souboru Čtěte pro daný katalog.

Tagy struktury

Použijte tuto volbu, aby bylo možné prohledávat specifické tagy elementů v dokumentech, které mají tagovanou logickou strukturu.

Poznámka:

Nastavení pro Uživatelské vlastnosti, Vyloučená slova a Tagy se vztahují pouze na současný index. Chcete-li aplikovat tato nastavení globálně na všechny vytvářené indexy, můžete změnit výchozí nastavení pro uživatelská pole, vyloučená slova a tagy v panelu Katalog v dialogovém okně Předvolby.  

Soubory Čtěte pro katalog (Acrobat Pro DC)

Často je vhodné vytvořit samostatný soubor Čtěte a umístit ho do složky s indexem. Tento soubor Čtěte může obsahovat podrobnosti o indexu, například:

  • Druh indexovaných dokumentů.

  • Podporované volby prohledávání.

  • Kontaktní osoba nebo telefonní číslo pro případné dotazy.

  • Seznam čísel nebo slov, která jsou z indexu vyloučena.

  • Seznam složek obsahujících dokumenty zařazené do indexu v síti LAN nebo seznam dokumentů zařazených do indexu na disku. Můžete připojit i stručný popis obsahu každé ze složek nebo každého z dokumentů.

  • Seznam hodnot pro každý dokument, pokud jste hodnoty přiřadili do polí v dialogovém okně Informace o dokumentu.

    Pokud katalog obsahuje mimořádně velký počet dokumentů, zvažte vložení tabulky s přehledem hodnot přiřazených jednotlivým dokumentům. Tato tabulka může být součástí souboru Čtěte nebo může být v samostatném souboru. Při vytváření indexu můžete tuto tabulku použít k zajištění jednotnosti.

Revidování indexu (Acrobat Pro DC)

Existující index můžete aktualizovat, obnovit nebo vyčistit.

  1. Zvolte Nástroje > Index.

    Na sekundárním panelu nástrojů se zobrazí sada nástrojů Index.

  2. Na sekundárním panelu nástrojů klikněte na Fulltextový index s modulem Katalog.

    Zobrazí se dialogové okno Katalog.

  3. V dialogovém okně Katalog klikněte na Otevřít index.

  4. Najděte a vyberte soubor definice indexu (PDX) a klikněte na Otevřít.

  5. Pokud byl index vytvořen v Acrobatu 5.0 nebo starším, vyberte Vytvořit kopii, abyste vytvořili nový index (bez přepsání starší verze), nebo vyberte Přepsat starý index, chcete-li dřívější index přepsat.

  6. V dialogovém okně Definice indexu proveďte požadované změny a pak klikněte na funkci, kterou má Acrobat DC provést:

    Vytvořit

    Vytvoří nový soubor IDX se stávajícími informacemi a aktualizuje ho přidáním nových položek a označením změněných a zastaralých položek jako neplatných. Pokud jste provedli velké množství změn, nebo jste tuto volbu použili opakovaně místo vytvoření nového indexu, časy prohledávání se mohou prodloužit.

    Znovu vytvořit

    Vytvoří nový index a přitom přepíše stávající složku indexu a její obsah (soubory IDX).

    Vyčistit

    Odstraní obsah indexu (soubory IDX), ale neodstraní vlastní soubor indexu (PDX).

Předvolby katalogu (Acrobat Pro DC)

Můžete nastavit předvolby pro indexování, které se použijí globálně pro všechny další vytvářené indexy. Některé z těchto předvoleb pak můžete pro jednotlivé indexy změnit, když při vytváření indexu vyberete nové volby.

V dialogovém okně Předvolby vyberte v části Kategorie položku Katalog. Mnohé z voleb jsou stejné jako ty popsané pro proces vytváření indexu.

Poznámka:

Volba Vynutit kompatibilitu složek s ISO 9660 je užitečná, pokud nechcete při přípravě dokumentů k indexování měnit dlouhé názvy souborů PDF na názvy MS‑DOS. Ale přesto musíte používat konvenci názvů MS-DOS pro názvy složek (8 nebo méně znaků), třebaže to není nutné pro názvy souborů.

Naplánované aktualizace indexu (Acrobat Pro DC)

S použitím funkce Katalog a dávkového souboru katalogu PDX (.bpdx) naplánujte, kdy a jak často chcete automaticky sestavovat, obnovovat, aktualizovat a čistit index. Soubor BPDX je textový soubor, který obsahuje seznam cest souborů indexů závislých na platformě a příznaky. Pro zobrazení souboru BPDX v programu Acrobat DC použijte aplikaci pro plánování, například Plánovač úloh pro Windows. Acrobat DC pak index znovu vytvoří podle příznaků v souboru BPDX.

Poznámka:

Použití souborů BPDX zapněte výběrem volby Povolit spouštění dávkových souborů katalogu (.bpdx) v části Katalog dialogového okna Předvolby.

Přemísťování kolekcí a jejich indexů (Acrobat Pro DC)

Kolekci indexovaných dokumentů můžete vytvořit a otestovat na lokálním pevném disku a pak dokončenou kolekci dokumentů přemístit na síťový server nebo na jiný disk. Definice indexu obsahuje relativní cesty mezi definičním souborem indexu (PDX) a složkami obsahujícími indexované dokumenty. Pokud se tyto relativní cesty nezmění, není třeba index vytvářet znovu poté, co jste sadu indexovaných dokumentů přemístili. Pokud je soubor PDX ve stejné složce jako složky obsahující indexované dokumenty, můžete zachovat jejich relativní cesty tím, že jednoduše přemístíte celou tuto složku.

Pokud se relativní cesty změní, musíte po přemístění kolekce indexovaných dokumentů vytvořit nový index. Můžete k tomu ale použít původní soubor PDX. Abyste tento původní soubor PDX mohli dále používat, přemístěte nejdříve indexované dokumenty. Pak zkopírujte soubor PDX do složky, kde chcete vytvořit nový index, a podle potřeby upravte seznamy zahrnutých a vyloučených složek a podsložek indexu.

Pokud je index umístěn na lokálním disku nebo na síťovém disku nezávisle na jakékoli části kolekce indexovaných dokumentů, potom přemístěním indexu nebo sady dokumentů se index poškodí. Pokud hodláte kolekci dokumentů přemístit na jiné místo na síti nebo na CD disk, vytvořte index ve stejném místě, kde je kolekce dokumentů.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online