User Guide Cancel

Customize keyboard shortcuts

  1. Illustrator User Guide
  2. Get to know Illustrator
    1. Introduction to Illustrator
      1. What's new in Illustrator
      2. Common questions
      3. Illustrator system requirements
      4. Illustrator for Apple silicon
    2. Workspace
      1. Workspace basics
      2. Learn faster with the Illustrator Discover panel
      3. Create documents
      4. Toolbar
      5. Default keyboard shortcuts
      6. Customize keyboard shortcuts
      7. Introduction to artboards
      8. Manage artboards
      9. Customize the workspace
      10. Properties panel
      11. Set preferences
      12. Touch Workspace
      13. Microsoft Surface Dial support in Illustrator
      14. Undo edits and manage design history
      15. Rotate view
      16. Rulers, grids, and guides
      17. Accessibility in Illustrator
      18. Safe Mode
      19. View artwork
      20. Use the Touch Bar with Illustrator
      21. Files and templates
    3. Tools in Illustrator
      1. Tools at a glance
      2. Select tools
        1. Selection
        2. Direct Selection
        3. Group Selection
        4. Magic Wand
        5. Lasso
        6. Artboard
      3. Navigate tools
        1. Hand
        2. Rotate View
        3. Zoom
      4. Paint tools
        1. Gradient
        2. Mesh
        3. Shape Builder
      5. Text tools
        1. Type
        2. Type on a Path
        3. Vertical Type
      6. Draw tools
        1. Pen
        2. Add Anchor Point
        3. Delete Anchor Point
        4. Anchor Point
        5. Curvature
        6. Line Segment
        7. Rectangle
        8. Rounded Rectangle
        9. Ellipse
        10. Polygon
        11. Star
        12. Paintbrush
        13. Blob Brush
        14. Pencil
        15. Shaper
        16. Slice
      7. Modify tools
        1. Rotate
        2. Reflect
        3. Scale
        4. Shear
        5. Width
        6. Free Transform
        7. Eyedropper
        8. Blend
        9. Eraser
        10. Scissors
        11. Dimension
    4. Generative AI (not available in mainland China)
      1. Generate a vector graphic using a text prompt
      2. Recolor your artwork using a text prompt
    5. Quick actions
      1. Retro text
      2. Neon glow text
      3. Old school text
      4. Recolor
      5. Convert sketch to vector
  3. Illustrator on the web (beta)
    1. Illustrator on the web (beta) overview
    2. Illustrator on the web (beta) FAQ
    3. Troubleshooting issues FAQ
    4. Keyboard shortcuts for Illustrator on the web (beta)
    5. Create and combine shapes on the web
    6. Add and edit text on the web
    7. Apply colors and gradients on the web
    8. Draw and edit paths on the web
    9. Work with cloud documents on the web
    10. Invite collaborators to edit on the web
  4. Illustrator on the iPad
    1. Introduction to Illustrator on the iPad
      1. Illustrator on the iPad overview
      2. Illustrator on the iPad FAQs
      3. System requirements | Illustrator on the iPad
      4. What you can or cannot do on Illustrator on the iPad
    2. Workspace
      1. Illustrator on the iPad workspace
      2. Touch shortcuts and gestures
      3. Keyboard shortcuts for Illustrator on the iPad
      4. Manage your app settings
    3. Documents
      1. Work with documents in Illustrator on the iPad
      2. Import Photoshop and Fresco documents
    4. Select and arrange objects
      1. Create repeat objects
      2. Blend objects
    5. Drawing
      1. Draw and edit paths
      2. Draw and edit shapes
    6. Type
      1. Work with type and fonts
      2. Create text designs along a path
      3. Add your own fonts
    7. Work with images
      1. Vectorize raster images
    8. Color
      1. Apply colors and gradients
  5. Cloud documents
    1. Basics
      1. Work with Illustrator cloud documents
      2. Share and collaborate on Illustrator cloud documents
      3. Share documents for review
      4. Upgrade cloud storage for Adobe Illustrator
      5. Illustrator cloud documents | Common questions
    2. Troubleshooting
      1. Troubleshoot create or save issues for Illustrator cloud documents
      2. Troubleshoot Illustrator cloud documents issues
  6. Add and edit content
    1. Drawing and dimensioning
      1. Drawing basics
      2. Edit paths
      3. Draw pixel-perfect art
      4. Draw with the Pen, Curvature, or Pencil tool
      5. Draw simple lines and shapes
      6. Draw rectangular and polar grids
      7. Draw and edit flares
      8. Image Trace
      9. Simplify a path
      10. Symbolism tools and symbol sets
      11. Adjust path segments
      12. Design a flower in 5 easy steps
      13. Create and edit a perspective grid
      14. Draw and modify objects on a perspective grid
      15. Use objects as symbols for repeat use
      16. Draw pixel-aligned paths for web workflows
      17. Measure and plot dimensions
    2. 3D objects and materials
      1. About 3D effects in Illustrator
      2. Create 3D graphics
      3. Map artwork over 3D objects
      4. Create 3D Text
      5. Create 3D objects
    3. Color
      1. About color
      2. Select colors
      3. Use and create swatches
      4. Adjust colors
      5. Use the Adobe Color Themes panel
      6. Color groups (harmonies)
      7. Color Themes panel
      8. Recolor your artwork
    4. Painting
      1. About painting
      2. Paint with fills and strokes
      3. Live Paint groups
      4. Gradients
      5. Brushes
      6. Transparency and blending modes
      7. Apply stroke on an object
      8. Create and edit patterns
      9. Meshes
      10. Patterns
    5. Select and arrange objects
      1. Select objects
      2. Layers
      3. Group and expand objects
      4. Move, align, and distribute objects
      5. Stack objects    
      6. Lock, hide, and delete objects
      7. Copy and duplicate objects
      8. Rotate and reflect objects
      9. Intertwine objects
      10. Create realistic art mockups
    6. Reshape objects
      1. Crop images
      2. Transform objects
      3. Combine objects
      4. Cut, divide, and trim objects
      5. Puppet Warp
      6. Scale, shear, and distort objects
      7. Blend objects
      8. Reshape using envelopes
      9. Reshape objects with effects
      10. Build new shapes with Shaper and Shape Builder tools
      11. Work with Live Corners
      12. Enhanced reshape workflows with touch support
      13. Edit clipping masks
      14. Live shapes
      15. Create shapes using the Shape Builder tool
      16. Global editing
    7. Type
      1. Add text and work with type objects
      2. Create bulleted and numbered lists
      3. Manage text area
      4. Fonts and typography
      5. Convert text within images into editable text
      6. Add basic formatting to text
      7. Add advanced formatting to text
      8. Import and export text
      9. Format paragraphs
      10. Special characters
      11. Create type on a path
      12. Character and paragraph styles
      13. Tabs
      14. Find missing fonts (Typekit workflow)
      15. Arabic and Hebrew type
      16. Fonts | FAQ and troubleshooting tips
      17. Create 3D text effect
      18. Creative typography designs
      19. Scale and rotate type
      20. Line and character spacing
      21. Hyphenation and line breaks
      22. Spelling and language dictionaries
      23. Format Asian characters
      24. Composers for Asian scripts
      25. Create text designs with blend objects
      26. Create a text poster using Image Trace
    8. Create special effects
      1. Work with effects
      2. Graphic styles
      3. Appearance attributes
      4. Create sketches and mosaics
      5. Drop shadows, glows, and feathering
      6. Summary of effects
    9. Web graphics
      1. Best practices for creating web graphics
      2. Graphs
      3. SVG
      4. Slices and image maps
  7. Import, export, and save
    1. Import
      1. Place multiple files
      2. Manage linked and embedded files
      3. Links information
      4. Unembed images
      5. Import artwork from Photoshop
      6. Import bitmap images
      7. Import Adobe PDF files
      8. Import EPS, DCS, and AutoCAD files
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Save
      1. Save artwork
    4. Export
      1. Use Illustrator artwork in Photoshop
      2. Export artwork
      3. Collect assets and export in batches
      4. Package files
      5. Create Adobe PDF files
      6. Extract CSS | Illustrator CC
      7. Adobe PDF options
      8. Document info panel
  8. Printing
    1. Prepare for printing
      1. Set up documents for printing
      2. Change the page size and orientation
      3. Specify crop marks for trimming or aligning
      4. Get started with large canvas
    2. Printing
      1. Overprint
      2. Print with color management
      3. PostScript printing
      4. Print presets
      5. Printer's marks and bleeds
      6. Print and save transparent artwork
      7. Trapping
      8. Print color separations
      9. Print gradients, meshes, and color blends
      10. White Overprint
  9. Automate tasks
    1. Data merge using the Variables panel
    2. Automation with scripts
    3. Automation with actions
  10. Troubleshooting 
    1. Known issues
    2. Crash issues
    3. Recover files after crash
    4. File issues
    5. Supported file formats
    6. GPU device driver issues
    7. Wacom device issues
    8. DLL file issues
    9. Memory issues
    10. Preferences file issues
    11. Font issues
    12. Printer issues
    13. Share crash report with Adobe
    14. Improve Illustrator performance

Learn how to customize, define, clear, or delete shortcuts in Illustrator.

Keyboard shortcuts make you more productive in Illustrator. You can use the default shortcuts or add and customize shortcuts to suit your needs.

You can define your own sets of shortcuts, change individual shortcuts within a set, and switch between sets of shortcuts. You can create separate sets for different workspaces by going to Window > Workspace.

Define new keyboard shortcuts

  1. Go to Edit > Keyboard Shortcuts.

  2. Select a set of shortcuts from the Set options in the Keyboard Shortcuts dialog.

  3. Select a shortcut type from the menu above the shortcut display.

    Menu Commands

    You can customize keyboard shortcuts for items in the menu bar and panel menus.

    Tools

    You can customize keyboard shortcuts for tools in the toolbox.

  4. Follow any of these options:

    • Select the Shortcut column of the scroll list and type a new shortcut to change an existing one. If you enter a shortcut assigned to another command or tool, you'll view an alert. Select Undo to undo the change, or Go To Conflict to go to the other command or tool and give it a new shortcut. In the Symbol column, type the symbol in the menu or tool tip for the command or tool and then select OK. You can use any of the characters allowed in the Shortcut column.
    • Select OK to save a new set of shortcuts. Enter a name for the new shortcut set, and select OK. The new key set will appear in the pop‑up menu under the new name.
    • Select Export Text... to export the displayed shortcuts into a text file. In the Save Key Set File As dialog, enter a filename for the current key set, and select OK. You can use this text file to print a copy of your keyboard shortcuts.
    Note:

    macOS does not allow you to assign Command+Option+8 as a menu shortcut.


Example: Create a custom keyboard shortcut for Crop Image

Here's an example of creating a shortcut to Crop Image:

  1. Go to Edit > Keyboard Shortcuts.

  2. Select Menu Commands.

  3. Select Object > Crop Image.

  4. Type a new shortcut.

    An alert appears if the keyboard shortcut is already assigned to another command or tool in the set. Reassign a shortcut, select OK and Go To Conflict to assign a new shortcut to the other command or tool.

  5. Enter a name for the saved keyset.

  6. Select OK.

You can also clear shortcuts from a command or tool and delete a set of shortcuts.

Clear a single shortcut

  1. Select Edit > Keyboard Shortcuts.

  2. Select the command or tool name whose shortcut you want to delete in the Keyboard Shortcuts dialog.

  3. Select Clear and then select OK.

Delete a set of shortcuts

  1. Go to Edit > Keyboard Shortcuts.

  2. Select the shortcut set you want to delete in the Set drop-down list.

  3. Select the Delete   icon and then select OK.

Customize keyboard shortcuts for text formatting

  1. To customize your keyboard shortcuts, navigate to Edit > Keyboard Shortcuts.

  2. Select Menu Commands > Other Text, then navigate to the Bold, Italics, or Underline section.

  3. Assign a new shortcut, and then select OK.

The customized keyboard shortcut you create should be unique and accompanied by a modifier key (like Ctrl or Command).

Locate custom shortcuts on your machine

The custom Illustrator keyboard shortcuts are saved in the following locations:

macOS:

user/Library/Preferences/Illustrator CC Settings/[language]/mycustomshortcut.kys

Windows:

<rootdir>\Users\[user name]\AppData\Roaming\Adobe\Adobe Illustrator
CC Settings\[language]\mycustomshortcut.kys
Note:

In addition to keyboard shortcuts, you can access many commands using context-sensitive menus. Context-sensitive menus display commands relevant to the active tool, selection, or panel. To display a context-sensitive menu, right-click (Windows) or control-click (macOS) in the document window or panel.

If you've previously saved a set of keyboard shortcuts other than the default, then the keyboard shortcuts are stored in a .kys file in the preferences folder. You can copy this file into the same location on the new computer. You can then choose this set from the Keyboard Shortcuts dialog.

You can use the same .kys file across platforms as long as the modified shortcuts are valid.


Related resources

Talk to us

We would love to hear from you. Share your thoughts with the Adobe Illustrator Community

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online