Obs!

En komplett lista över artiklar om säkerhet finns i Översikt över säkerhet i Acrobat DC och PDF-filer.

Varför skulle jag vilja redigera eller ta bort känsligt innehåll?

Innan du distribuerar en PDF-fil kan du behöva undersöka dokumentet för att hitta känsligt innehåll eller privat information som kan användas för att spåra dokumentet till dig. Använd bortredigeringsverktygen för att ta bort eller redigera känsliga bilder och text som är synlig i en PDF-fil.

Använd funktionen Ta bort dold information för att hitta och ta bort dolt innehåll från en PDF-fil. Om du t.ex. har skapat en PDF-fil, visas ditt namn som filens författare i dokumentets metadata. Du kan även ta bort innehåll som av misstag ändrar dokumentets utseende. JavaScript, åtgärder och formulärfält är typer av innehåll som kan ändras.

Redigera känsligt innehåll (Acrobat Pro DC)

Redigera bort är en process som permanent tar bort synliga bilder och synlig text från dokumentet. Du använder bortredigeringsverktygen för att ta bort innehållet. I stället för de borttagna objekten kan du ha borttagningsmarkeringar som visas som färgade rutor eller så kan du lämna området tomt. Du kan ange att egen text eller bortredigeringskoder ska visas ovanpå bortredigeringsmarkeringarna.

Obs!

Om du vill söka efter och ta bort specifika ord, tecken eller fraser använder du verktyget Sök efter text  i stället.

Redigera känsligt innehåll
Text markerad för borttagning (vänster) och borttagen (höger)

  1. Välj Verktyg > Redigera bort.

    Bortredigeringsverktygen visas i det sekundära verktygsfältet.

  2. Välj Markera för bortredigering > Text och bilder i det sekundära verktygsfältet.

  3. (Valfritt) Om du vill ställa in utseendet på bortredigeringsmarkeringarna klickar du på Egenskaper i det sekundära verktygsfältet.  (Se Ändra utseendet på bortredigeringsmarkeringar.)

  4. Markera objekt som du vill ta bort genom att göra något av följande:
    • Markera ett ord eller en bild genom att dubbelklicka på den.
    • Dra för att välja en linje, ett textblock, ett objekt eller ett område.
    • Tryck på Ctrl samtidigt som du drar för att markera sidområden i ett skannat dokument.

    Obs!

    Håll pekaren över det markerade området för att förhandsgranska hur bortredigeringsmarkeringarna visas.

  5. Använd flera kodposter på en bortredigering genom att högerklicka på bortredigeringsmarkeringen och välja ett alternativ. Mer information finns i Använda kodposter för en bortredigering.

  6. (Valfritt) Om du vill upprepa en bortredigeringsmarkering högerklickar du på den och väljer Upprepa markering över sidor. Den här funktionen är lämplig om det finns ett sidhuvud, en sidfot eller en vattenstämpel på samma plats på flera sidor.

  7. När du har markerat de objekt som du vill redigera, klickar du på Använd i det sekundära verktygsfältet för att ta bort objekten. Klicka sedan på OK.

    Objekten tas inte bort för alltid från dokumentet förrän du sparar dokumentet.

  8. Klicka på Ja i dialogrutan om du vill söka efter och ta bort dold information i dokumentet med hjälp av funktionen Ta bort dold information. Annars klickar du på Nej.

  9. Välj Arkiv > Spara och ange ett filnamn och en plats. Suffixet ”_Bortredigerad” läggs till efter filnamnet. Om du inte vill skriva över den ursprungliga filen sparar du den med ett annat namn, på en annan plats eller både och.

Söka och ta bort text (Acrobat Pro DC)

Använd verktyget Sök efter text om du vill hitta och ta bort ord eller fraser i en eller flera PDF-filer som innehåller sökbar text.

Obs!

Verktyget Sök efter text söker inte i skyddade (krypterade) PDF-filer.

  1. Välj Verktyg > Redigera bort.

    Bortredigeringsverktygen visas i det sekundära verktygsfältet.

  2. Välj Markera för bortredigering > Sök efter text i det sekundära verktygsfältet.

  3. Ange i dialogrutan Sök om du vill söka i aktuell PDF-fil eller alla PDF-filer på en annan plats.

  4. Gör något av följande:
    • Välj Enskilt ord eller fras och skriv ordet eller frasen i textrutan för att söka efter ett enskilt ord eller en fras.
    • Om du vill söka efter flera ord väljer du Flera ord eller fraser och klickar sedan på Välj ord. Skriv varje ord i textrutan Nya ord och fraser och klicka på Lägg till. Du kan även importera en textfil med en lista över ord och fraser som du vill söka efter.
    • Om du vill söka efter ett mönster (t.ex. telefonnummer, kontokortsnummer, e-postadresser, personnummer eller datum) klickar du på Mönster. Välj ett av de tillgängliga mönstren. Du kan ändra mönstrens språkversion. (Se Välja en annan språkversion för mönstren.)
  5. Klicka på Sök efter och ta bort text.

  6. Klicka på plustecknet (+) intill dokumentnamnet i sökresultaten för att visa en lista över alla förekomster av ordet eller frasen. Välj sedan de förekomster som du vill markera för bortredigering:
    • Om du vill markera alla förekomster i listan klickar du på Markera alla.
    • Om du vill välja enskilda förekomster markerar du kryssrutan för var och en av förekomsterna som du vill bortredigera. Visa förekomsten på sidan genom att klicka på texten bredvid en kryssrutan.
    • Om du inte vill markera någon av förekomsterna stänger du dialogrutan Sök eller klickar på Ny sökning för att börja om från början.
    • Markera hela ord eller delar av ord (tecken) för bortredigering genom att välja ett alternativ under Alternativ för bortredigeringsmarkering. För delar av ord väljer du Markera delar av ord för bortredigering. Nu öppnas dialogrutan Inställningar. Ange i dialogrutan Inställningar antalet och platsen för de tecken som ska bortredigeras. Teckenbortredigering är användbart om du söker efter ett mönster, som kreditkortsnummer, och vill lämna delar av numret synligt i identifieringssyfte.
  7. Om du valde förekomster som du vill markera för bortredigering klickar du på Bortredigeringsmarkera markerade resultat.

    De artiklar som du har markerat i listan visas med markeringar för bortredigering.

    Obs!

    Om du inte har sparat filen kan du välja bortredigeringsmarkeringar i dokumentet och ta bort dem genom att trycka på Ta bort. Bortredigeringsmarkeringarna blir permanenta när du har sparat filen.

  8. För att bort markerade objekt klickar du på Använd i det sekundära verktygsfältet och sedan på OK.

    Objekten tas inte bort för alltid från dokumentet förrän du sparar dokumentet.

  9. Klicka på Ja om du vill söka efter och ta bort dold information i dokumentet med hjälp av funktionen Ta bort dold information. Annars klickar du på Nej.

  10. Välj Arkiv > Spara och ange ett filnamn och en plats. Om du inte vill skriva över den ursprungliga filen sparar du den med ett annat namn, på en annan plats eller både och.

Hitta och ta bort dolt innehåll

Använd funktionen Ta bort dold information för att hitta och ta bort innehåll från ett dokument som du inte vill ha, t ex dold text, metadata, kommentarer och bilagor. När du tar bort vissa objekt tas även andra objekt automatiskt bort från dokumentet. De objekt som tas bort innefattar digitala signaturer, dokumentinformation som läggs till av insticksprogram från tredje part och program och specialfunktioner som gör det möjligt för Adobe Reader-användare att granska, underteckna och fylla i PDF-dokument.

Obs!

Om du alltid vill kontrollera om PDF-filer innehåller dolt innehåll innan du stänger dem eller skickar dem via e-post, anger du det alternativet i inställningarna för Dokument i dialogrutan Inställningar.

  1. Välj Verktyg > Redigera bort.

    Bortredigeringsverktygen visas i det sekundära verktygsfältet.

  2. I det sekundära verktygsfältet klickar du på Ta bort dold information.

    Om det finns sådana objekt visas de i panelen Ta bort dold information med en markerad kryssruta bredvid varje objekt.

  3. Kontrollera att det bara är kryssrutorna för de objekt som du vill ta bort från dokumentet som är markerade. (Se Alternativen för Ta bort dold information.)
  4. Ta bort markerade objekt från filen genom att klicka på Ta bort och sedan på OK.

  5. Välj Arkiv > Spara och ange ett filnamn och en plats. Om du inte vill skriva över den ursprungliga filen sparar du den med ett annat namn, på en annan plats eller både och.

Det markerade innehållet tas bort för alltid när du sparar filen. Om du stänger filen utan att spara den måste du upprepa den här processen och se till att du sparar filen.

Alternativen för Ta bort dold information

Metadata

Metadata innehåller information om dokumentet och dess innehåll, t.ex. författarens namn, nyckelord och copyright-information. Om du vill visa metadata väljer du Arkiv > Egenskaper.

Bifogade filer

Filer i alla filformat kan bifogas till PDF-filen som en bilaga. Om du vill visa bilagor väljer du Visa > Visa/Dölj > Navigeringsrutor > Bifogade filer.

Bokmärken

Bokmärken är länkar med hänvisande text som öppnar specifika sidor i PDF-filen. Om du vill visa bokmärken väljer du Visa > Visa/Dölj > Navigeringsrutor > Bokmärken.

Kommentarer och markeringar

Detta kommando inkluderar alla kommentarer som har lagts till i PDF-filen med kommentars- och markeringsverktygen, inklusive filer som har lagts till som kommentarer. Om du vill visa kommentarer väljer du Verktyg > Kommentarer.

Formulärfält

Detta kommando inkluderar formulärfält (inklusive fält för underskrift) och alla åtgärder och beräkningar som är kopplade till formulärfält. Om du tar bort det här kommandot förenklas alla formulärfält och de kan inte längre fyllas i, redigeras eller undertecknas.

Dold text

Detta visar text i PDF-filen som antingen är genomskinlig, täcks av annat innehåll eller har samma färg som bakgrunden.

Dolda lager

PDF-filer kan innehålla flera lager som kan visas eller döljas. Om du tar bort dolda lager tas de bort från PDF-filen varvid resterande lager förenklas till ett enda lager. Om du vill visa lager väljer du Visa > Visa/Dölj > Navigeringsrutor > Lager.

Inbäddat sökindex

Ett inbäddat sökindex påskyndar sökningar i PDF-filen. Om du vill avgöra om PDF-filen innehåller ett sökindex väljer du Verktyg > Index och klickar sedan på Hantera inbäddat index i det sekundära verktygsfältet. Om du tar bort index minskar filstorleken medan söktiden för PDF-filen förlängs.

Borttaget eller beskuret innehåll

I PDF-filer finns det ibland kvar innehåll som har tagits bort och inte längre är synligt, t.ex. beskurna eller borttagna sidor eller borttagna bilder.

Länkar, åtgärder och JavaScript-skript

Det här objektet innehåller webblänkar, åtgärder som lagts till av Åtgärdsguiden samt JavaScript-skript i hela dokumentet.

Överlappande objekt

Det här objektet innehåller objekt som överlappar varandra. Objekten kan vara bilder (bestående av bildpunkter), vektorgrafik (bestående av sökvägar), övertoningar eller mönster.

Välja en annan språkversion för mönstren (Acrobat Pro DC)

Lokaliserade mönster visas på panelen Sök (Redigera bort > Markera för bortredigering > Sök efter text).

  1. Välj Redigera > Inställningar (Windows) eller Acrobat > Inställningar (Mac OS).

  2. Välj Dokument under Kategorier till vänster.

  3. Välj ett språk på menyn Välj lokalisering för sök- och textbortagningsmönster i bortredigeringsområdet. Sedan klickar du på OK.

Ändra utseendet på bortredigeringsmarkeringar (Acrobat Pro DC)

Som standard visas tunna röda konturer runt bilder och text som du markerar för bortredigering och svarta rutor visas i stället för bilder och text som har bortredigerats. Du kan ställa in standardutseendet på bortredigeringsmarkeringarna innan du markerar objekt för bortredigering. Du kan även ändra utseendet på bortredigeringsmarkeringarna innan du tillämpar bortredigeringen.

Ställa in standardutseende för alla markeringar

  1. Klicka på Verktyg > Redigera bort.

    Bortredigeringsverktygen visas i det sekundära verktygsfältet.

  2. Välj Egenskaper i det sekundära verktygsfältet.

    Dialogrutan Egenskaper för bortredigeringsverktyget öppnas.

  3. Gå till fliken Utseende, välj de alternativ som du vill ändra och klicka sedan på OK:

    • Klicka på ikonen Fyllningsfärg för bortredigerat område och välj en fyllningsfärg på färgpaletten för de rutor som ersätter borttagna objekt. Välj Ingen färg om du vill låta det bortredigerade området vara tomt.
    • Välj Använd överläggningstext om du vill välja alternativ för egen text eller bortredigeringskod. Välj teckensnitt, storlek och textjustering.
    • Välj Egen text och skriv sedan den text som du vill ska visas i det bortredigerade området.
    • Välj Bortredigeringskod och välj sedan en kod i en befintlig uppsättning eller klicka sedan på Redigera koder för att definiera en ny kod eller koduppsättning. (Se Skapa bortredigeringskoder och koduppsättningar.)
    • Klicka på ikonen Konturfärg eller Fyllningsfärg eller båda i Utseende på bortredigeringsmarkering. Välj en färg från färgpaletten för de bilder och den text som du markerar för bortredigering. Flytta reglaget så att opaciteten för färgen justeras. Välj Ingen färg om du vill lämna det markerade området tomt.

Egenskaper för bortredigeringstext (Acrobat Pro DC)

Egen text

Visar texten som du skriver i rutan Egen text över bortredigeringsmarkeringen.

Teckensnitt

Visar egen text i valt teckensnitt.

Teckensnittsstorlek

Visar egen text i vald teckensnittsstorlek.

Anpassa textstorlek efter bortredigeringsområde

Ändrar storleken på egen text så att den passar i det bortredigerade området. Om du väljer det här alternativet åsidosätts inställningen av Teckensnittsstorlek för överläggningstexten.

Teckenfärg

Visar egen text i vald färg som du kan ändra genom att klicka på färgrutan.

Upprepa överläggningstext

Fyller i det bortredigerade området med så många förekomster av den egna texten som behövs utan att ändra teckensnittsstorleken. Om du t.ex. anger bokstaven x eller ett bindestreck (-) som egen text, upprepas dessa tecken i hela det bortredigerade området.

Textjustering

Justerar texten till vänster, höger eller centrerat.

Bortredigeringskoder (Acrobat Pro DC)

Acrobat använder övertäckningstext för att göra övertryck på de områden som väljs för bortredigering. Ett exempel på övertäckningstext är en bortredigeringskod, som består av en eller flera kodposter från en koduppsättning. Acrobat inkluderar koduppsättningarna U.S. FOIA och U.S. Privacy Act, så att du kan använda dem. Du kan använda koder eller egen text för att skapa övertäckningstext. Skillnaden mellan dem är att bortredigeringskoder är textposter som du kan spara, exportera och importera. En koduppsättning kan innehålla flera koder.

Obs!

Koder sparar inte de aktuella attributen för överläggningstext som del av koddefinitionen, t.ex. färger, teckenegenskaper, textupprepning eller textstorlek. Koder gör det bara möjligt att återanvända själva överläggningstexten i framtiden och av andra användare som du delar koduppsättningar med. Du ställer in andra attribut för koden i dialogrutan Egenskaper för bortredigeringsverktyget.

Skapa bortredigeringskoder och koduppsättningar

  1. Klicka på Verktyg > Redigera bort.

    Bortredigeringsverktygen visas i det sekundära verktygsfältet.

  2. Välj Egenskaper i det sekundära verktygsfältet.

    Dialogrutan Egenskaper för bortredigeringsverktyget öppnas.

    Egenskaper för bortredigeringsverktyget i Acrobat
    Skapa bortredigeringskoder med dialogrutan Egenskaper för bortredigeringsverktyget.

  3. Välj Använd överläggningstext.

  4. Välj Bortredigeringskod.

    • Om du vill lägga till flera kodposter i en bortredigeringskod, väljer du en post i listan Kodposter och klickar på Lägg till markerad post. Upprepa efter behov. Välj Ta bort markerad post för att ta bort en kodpost som finns i listan Bortredigeringskod.
    • Klicka på Redigera koder om du vill göra andra ändringar.
  5. Gå till dialogrutan Redigerare för bortredigeringskod och klicka på Lägg till uppsättning.

  6. (Valfritt) Skriv ett nytt namn för uppsättningen i textrutan nedanför listan med koduppsättningar och klicka sedan på Byt namn på uppsättning.

  7. Klicka på Lägg till kod och använd sedan textrutan nedanför kodlistan för att skriva den text som du vill ska visas som överläggningstext. Klicka därefter på Byt namn på kod.

  8. Upprepa föregående steg om du vill lägga till ytterligare kod till den koduppsättningen, eller upprepa föregående tre steg om du vill skapa ytterligare koduppsättningar och koder.

Redigera bortredigeringskoder och koduppsättningar (Acrobat Pro DC)

  1. Klicka på Verktyg > Redigera bort.

    Bortredigeringsverktygen visas i det sekundära verktygsfältet.

  2. Välj Egenskaper i det sekundära verktygsfältet.

    Dialogrutan Egenskaper för bortredigeringsverktyget öppnas.

  3. Välj Använd överläggningstext och sedan Bortredigeringskod.

  4. Markera en koduppsättning i listan till vänster och klicka sedan på Redigera koder.

  5. Gör något av följande i dialogrutan Redigerare för bortredigeringskod:

    • Om du vill ta bort en koduppsättning och alla kodposter i den uppsättningen, markerar du en post i uppsättningen och klickar sedan på Ta bort uppsättning.
    • Markera en koduppsättning som du vill exportera till en separat XML-fil som du kan återanvända i andra PDF-filer. Klicka på Exportera uppsättning, ange ett filnamn och en plats, och klicka sedan på Spara.
    • Om du vill importera en tidigare sparad koduppsättning klickar du på Importera uppsättning, markerar filen och klickar sedan på Öppna.
    • Om du vill byta namn på en koduppsättning markerar du en post i koduppsättningen, skriver ett nytt namn i rutan nedanför listan och klickar sedan på Byt namn på uppsättning.
  6. När koduppsättningen är markerad, väljer du den kodpost som du vill redigera och gör något av följande:

    • Klicka på Ta bort kod för att ta bort en kodpost.
    • Om du vill byta namn på en kodpost skriver du ett nytt namn i rutan nedanför listan och klickar sedan på Byt namn på kod.

Använda flera kodposter på en enda bortredigering

  1. Högerklicka på bortredigeringsmarkeringen.

  2. Välj en koduppsättning i listan längst ned på snabbmenyn och välj sedan en kodpost i nedrullningsmenyn. En bock visas bredvid kodposten när koden används.

  3. Upprepa föregående steg om du vill lägga till en till kodpost i bortredigeringen.

Håll pekaren över bortredigeringsmarkeringen för att se kodposterna, som separeras med komma.

Obs!

Om du vill tillämpa samma kod på flera bortredigeringar ställer du in Egenskaper för bortredigering innan du markerar innehållet. Klicka på Egenskaper i det sekundära verktygsfältet. Välj Använd överläggningstext och sedan Bortredigeringskod. Välj en koduppsättning och en kodpost. Klicka sedan på Lägg till vald post.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy