Issue

When you try to print, InDesign returns the following error:

"Printing Error: The Adobe Print Engine has failed to output your data due to an unknown problem."

Solutions

Do one or more of the following:

Solution 1: Re-create the InDesign preferences file.

  1. Quit InDesign.
  2. Rename the InDesign SavedData file and the InDesign Defaults file (for example, to InDesign SavedData.old, InDesign Defaults.old) in the following location:
    • Windows XP: C:/Documents and Settings/[user name]/Application Data/Adobe/InDesign/[Version]
    • Windows 7/Vista: C:/Users/[user name]/AppData/Roaming/Adobe/InDesign/[Version]
    • Mac OS: /Users/[user name]/Library/Preferences/Adobe InDesign/[Version]
  3. Start InDesign. InDesign creates preference files.
  4. If the problem persists, you can restore the original preferences by deleting the new files and renaming the old preference files back to their original names.

Solution 2: Re-create the gradient so that spot colors are from the same color space.

If you print an EPS file exported from an InDesign document with a gradient, make sure that spot colors in the gradient are from the same color space, and then re-export the EPS. (For example, make sure that the gradient doesn't contain one RGB spot color and one LAB spot color.)

Solution 3: Change print options in the Print dialog box.

Change the settings in the Print dialog box as follows:

  • If you print a section that contains only one odd page, deselect Even Pages Only.
  • If you print a section that contains only one even page, deselect Odd Pages Only.

Solution 4: Replace out-of-range colors with in-range colors.

If you print an InDesign document that contains imported tagged text, check to see if the tagged text file contains an out-of-range color. Out-of-range colors appear in the Swatches palette with an appended value, such as "+5," that indicates the nearest in-range value.

To replace an out-of-range color with an in-range color, do the following:

  • Define a new color swatch in InDesign and then use the Find/Change feature to replace the color in the tagged text file with the new color.
  • Redefine the color value in the tagged text file and then reimport the file into InDesign. The color values are defined with a color table tag (<Color Table>). For more information about Tagged Text color definitions and tags, see the Tagged Text PDF file on the InDesign CD-ROM.

Solution 5: Export the file to PDF and then print from Adobe Acrobat 5 or later.

Export the file to PDF and then print the PDF file from Adobe Acrobat 5 or later or Adobe Acrobat Reader 5.0 or later.

Solution 6: Remove OPI 2.0 comments from the PDF file.

Remove OPI 2.0 comments from the PDF file, place the PDF file into InDesign, and then print the document.

To remove OPI 2.0 comments, do one of the following tasks:

  • In Adobe Acrobat, manually remove the OPI 2.0 comments and then re-create the PDF file.
  • In Acrobat, use Enfocus Pitstop to remove the OPI 2.0 comments.
  • Use OPI 1.3 comments.
  • In Acrobat Distiller, choose Settings > Edit Adobe PDF Settings, click the Advanced tab, deselect Preserve OPI Comments, and then distill the PDF file.
  • Use a proxy OPI workflow and embed proxies in the PDF (no Omit).
  • In InDesign, select the PDF and apply a transparency option. See "Specifying transparency" in InDesign Help for instructions.

Solution 7: Replace the PDF file with an EPS image.

Use an image-editing application such as Adobe Photoshop to save the PDF file as an EPS image. Then place the EPS image into the InDesign document.

Solution 8: Use Ink Manager to convert all spot colors to process colors.

To verify the number of spot colors you are using, open your Swatches palette. Swatch names followed by a square with a gray circle in it are spot colors.

To convert all colors to process colors via Ink Manager, do the following:

  1. Open the Swatches palette.
  2. Select Ink Manager from the menu.
  3. Select All Spots To Process in the lower left corner of the dialogue box and click OK.

If you select the Output page in the Print dialog, you see that only Cyan, Magenta, Yellow, and Black inks are listed in the Inks section.

Note: This problem only occurs when you print to a PostScript printer. If you have access to a non-PostScript printer, you can use it to print composites of your file.

Solution 9: Save the source file to a different file format.

Open the source file in the application that created it and save it to a format other than PDF. For more information, see the documentation included with the application.

Solution 10: Export the document to InDesign Interchange (.inx)format, and then check the font information.

  1. In InDesign CS, choose File > Export, and choose InDesign Interchange from the Save As Type menu.
  2. Click Save.

Solution 11: Export the PDF file from InDesignas a JPEG file.

Place the PDF file in a new InDesign document. Export the PDF file as a JPEG file, and then place the JPEG file in the original InDesign document.

  1. Create an InDesign document.
  2. Choose File > Place, select the PDF file, and click Open.
  3. Click the page to place the PDF file.
  4. While the PDF file is selected, choose File > Export.
  5. Choose JPEG from the Format menu, name the file, and then click Save.
  6. Select the export options you want, and then click Export.
  7. Open the original InDesign document that wouldn't print.
  8. Choose File > Place, select the JPEG file that you saved in step 5, and click Open.
  9. Click the page to place the JPEG file.

Solution 12: Use the Convert To PDF tool in Microsoft Office to create the PDF file.

  1. Open the document in Microsoft Excel, Microsoft PowerPoint or Microsoft Word.
  2. Click Convert To Adobe PDF in the toolbar.
  3. Name and save the PDF file.

Solution 13: Create a PostScript file and convert it to PDF by using Adobe Acrobat Distiller.

To create a PostScript file in the source application, see the documentation included with the application.

To convert a PostScript file to a PDF file, do the following:

  1. Start Acrobat Distiller.
  2. Choose a setting from the Default Setting menu.
  3. Choose File > Open.
  4. Select the PostScript file and choose Open. A PDF file appears in the same location as the PostScript file.

Solution 14: Check for font damage.

To determine if the problem is related to a damaged font, try switching all fonts used in the document to a standard font. (For example, change Arial or Times New Roman.)

If the problem recurs after you switch fonts, then it is not font-related. If the problem doesn't recur, then the original font could be damaged or out-dated (that is, created before 1992). Try reinstalling the font or obtaining an updated version from the font manufacturer.

Solution 15: Re-create the Adobe font list files.

On Windows:

  1. Quit all Adobe applications.
  2. Choose Start > Search > For Files Or Folders.
  3. Search for the font list files:
  • On Windows XP and Windows Vista, type "Adobefnt*.lst" (including the quotation marks) in the All Or Part Of The File Name box, and then click Search.
  • On Windows 2000, type "Adobefnt*.lst" (including the quotation marks) in the Named box, and then click Find Now.
  1. Select all files listed, and choose File > Delete. (If you delete a font list file for another Adobe application, the file is re-created the next time the Adobe application is started.)
  2. Restart InCopy or InDesign. The font list files are re-created during startup.

On Mac OS X:

  1. Quit all Adobe applications.
  2. Choose File > Find, and do one of the following:
  • On Mac OS X v10.4.x, click the Computer button, type Adobefnt in the text field beside File Name Is, and then click Enter.
  • On Mac OS X v10.2.x-v10.3.x, choose Local Disks from the Search In menu, type Adobefnt in the box beside File Name Is, and then click Search.
  1. Select the file, and choose File > Move To Trash.
  2. Repeat steps 2-3 for the files Adobefnt05.lst and Adobefnt06.lst.
  3. Restart InCopy or InDesign. The font list files are re-created during startup.

Note: For Mac OS 10.5x, if no adobefnt.lst file is found, then add system files in the search criteria in the File > Find dialog box.

  1. Select Other in the Kind pop-up menu and wait for the Select a Search Attribute dialog to display.
  2. Type system.
  3. Select System Files from the list and click OK.
  4. Also check the In Menu checkbox if you want System Files to appear in your criteria in the future.

Additional information

This error has several potential causes. Re-creating the preference files corrects the most common causes, which include the following:

  • Printing to a non-PostScript printer immediately after printing to a PostScript printer with Scale To Fit selected.
  • Canceling a print job during the printing or spooling process.
  • Printing with damaged preference files.

Other potential causes include the following:

  • Printing a PDF file that contains OPI 2.0 comments.
  • Printing a gradient that contains spot colors from different color spaces.
  • Printing a tagged text file that uses out-of-range colors.
  • Printing without having selected a printer in the Chooser.
  • Printing with the Chooser open after making a printer selection.

In some cases, printing a PDF version of the file is a workaround. The error doesn't always occur with InDesign 1.5 or later because those versions include many printing enhancements.

InDesign returns an error when you try to print OPI 2.0 comments. The error can occur when you place PDF files that were created in QuarkXPress 5.x into an InDesign document. The issue doesn't occur with OPI 1.3 comments. Most proxies don't contain OPI 2.0 comments.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy