Issue

When you launch an Adobe application on systems running macOS 10.12 (Sierra) or macOS 10.13 (High Sierra) with Cylance antivirus, the application crashes and returns the following error: Adobe application cannot be opened because of a problem. 

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Example: Error message returned when InDesign crashes
Example-(Ps)-Crash-due-Cylance-security
Example: Error message returned when Photoshop crashes

Cause

This issue occurs because Cylance antivirus quarantines the Mac Crash Reporter binary executive file: AdobeCrashReporter. 

Workaround

Contact your IT administrator to request whitelisting Adobe Crash Reporter Client from the Cylance web-based management console. You can share the following paths for whitelisting Adobe Crash Reporter Client with your IT administrator:

  • /Applications/<Adobe application>/<Adobe application>.app/Contents/Frameworks/AdobeCrashReporter.framework/Versions/A/AdobeCrashReporter
  • /Applications/<Adobe application>/<Adobe application>.app/Contents/Frameworks/AdobeCrashReporter.framework/Versions/Current/AdobeCrashReporter
  • /Users/<username>.Trash/AdobeCrashReporter.framework/Versions/Current/AdobeCrashReporter

Note:

Replace  <Adobe application> with the name and version of the application installed on your system. For example, if you have the March 2018 release of Adobe InDesign installed on your system, replace <Adobe application> with Adobe InDesign CC 2018.

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