Guida utente Annulla

Generare risorse di immagini dai livelli

  1. Guida utente di Photoshop
  2. Introduzione a Photoshop
    1. Sognare e creare.
    2. Novità di Photoshop
    3. Modificare la prima foto
    4. Creare documenti
    5. Photoshop | Domande comuni
    6. Requisiti di sistema per Photoshop
    7. Scopri Photoshop
  3. Photoshop e altri servizi e prodotti Adobe
    1. Lavorare con la grafica di Illustrator su Photoshop
    2. Operazioni con file Photoshop in InDesign
    3. Materiali Substance 3D per Photoshop
    4. Usare l’estensione Capture in-app in Photoshop
  4. Photoshop su iPad (non disponibile nella Cina continentale)
    1. Photoshop su iPad | Domande comuni
    2. Scoprire l’area di lavoro
    3. Requisiti di sistema | Photoshop per iPad
    4. Creare, aprire ed esportare i documenti
    5. Aggiungi foto
    6. Utilizzare i livelli
    7. Disegnare e dipingere con i pennelli
    8. Effettuare selezioni e aggiungere maschere
    9. Ritoccare le composizioni
    10. Operazioni con i livelli di regolazione
    11. Regolare la tonalità dei compositi con Curve
    12. Applicare le operazioni di trasformazione
    13. Ritagliare e ruotare le composizioni
    14. Rotazione, panning, zoom e reimpostazione dell’area di lavoro
    15. Operazioni con i livelli di testo
    16. Operazioni con Photoshop e Lightroom
    17. Ottenere font mancanti in Photoshop su iPad
    18. Testo giapponese in Photoshop su iPad
    19. Gestire le impostazioni dell’app
    20. Scorciatoie e movimenti touch
    21. Scelte rapide da tastiera
    22. Modificare le dimensioni dell’immagine
    23. Livestream durante la creazione in Photoshop su iPad
    24. Correggere le imperfezioni con il Pennello correttivo
    25. Creare pennelli in Capture e usarli in Photoshop su iPad
    26. Lavorare con i file Camera Raw
    27. Creare e lavorare con gli oggetti avanzati
    28. Regolare l’esposizione nelle immagini con Scherma e brucia
    29. Comandi di regolazione automatica in Photoshop su iPad
    30. Sfumare aree nelle immagini con Photoshop su iPad
    31. Aggiungere o togliere saturazione alle immagini con lo strumento Spugna
    32. Riempimento in base al contenuto per iPad
  5. Photoshop per il Web (non disponibile nella Cina continentale)
    1. Domande frequenti
    2. Requisiti di sistema
    3. Scelte rapide da tastiera
    4. Tipi di file supportati
    5. Introduzione all’area di lavoro
    6. Aprire e lavorare con i documenti cloud
    7. Funzioni di IA generativa
    8. Concetti di base dell’editing
    9. Azioni rapide
    10. Utilizzare i livelli
    11. Ritoccare le immagini e rimuovere le imperfezioni
    12. Effettuare selezioni rapide
    13. Migliorare le immagini con i livelli di regolazione
    14. Spostare, trasformare e ritagliare le immagini
    15. Disegnare e dipingere
    16. Operazioni con i livelli di testo
    17. Collaborare con chiunque sul Web
    18. Gestire le impostazioni dell’app
    19. Genera immagine
    20. Genera sfondo
    21. Immagine di riferimento
  6. Photoshop (beta) (non disponibile nella Cina continentale)
    1. Introduzione alle versioni beta delle app Creative Cloud
    2. Photoshop (beta) per desktop
    3. Generare immagini con prompt di testo descrittivi
    4. Generare sfondi con prompt di testo descrittivi
  7. IA generativa (non disponibile nella Cina continentale) 
    1. Domande frequenti sulla IA generativa in Photoshop
    2. Riempimento generativo di Photoshop per desktop
    3. Espansione generativa in Photoshop per desktop
    4. Riempimento generativo in Photoshop su iPad
    5. Espansione generativa in Photoshop su iPad
    6. Funzioni di IA generativa in Photoshop per il Web
  8. Autenticità dei contenuti (non disponibile nella Cina continentale)
    1. Credenziali del contenuto in Photoshop
    2. Identità e provenienza dei NFT
    3. Connettere un account per l’attribuzione creativa
  9. Documenti cloud (non disponibili nella Cina continentale)
    1. Documenti cloud di Photoshop | Domande comuni
    2. Documenti cloud di Photoshop | Domande sul flusso di lavoro
    3. Gestione e lavoro con i documenti cloud in Photoshop
    4. Aggiornare l’archiviazione cloud per Photoshop
    5. Impossibile creare o salvare un documento cloud
    6. Risolvere i problemi dei documenti cloud di Photoshop
    7. Raccogliere i registri di sincronizzazione dei documenti cloud
    8. Invitare altri utenti a modificare i documenti cloud
    9. Condividere file e commenti direttamente dall’app
  10. Area di lavoro
    1. Nozioni di base sull’area di lavoro
    2. Preferenze
    3. Imparare più velocemente con il pannello Discover di Photoshop
    4. Creare documenti
    5. Inserire file
    6. Scelte rapide da tastiera predefinite
    7. Personalizzare le scelte rapide da tastiera
    8. Panoramica degli strumenti
    9. Preferenze per le prestazioni
    10. Utilizzare gli strumenti
    11. Predefiniti
    12. Griglia e guide
    13. Movimenti touch
    14. Usare la Touch Bar con Photoshop
    15. Funzionalità touch e aree di lavoro personalizzabili
    16. Anteprime tecnologiche
    17. Metadati e note
    18. Funzionalità touch e aree di lavoro personalizzabili
    19. Inserire immagini di Photoshop in altre applicazioni
    20. Righelli
    21. Visualizzare o nascondere gli elementi extra non stampabili
    22. Specificare le colonne per un’immagine
    23. Annullare e il pannello Storia
    24. Pannelli e menu
    25. Posizionare elementi con allineamento
    26. Posizionare con lo strumento righello
  11. Creazione di contenuti per il Web, per lo schermo e app
    1. Photoshop per la progettazione
    2. Tavole da disegno
    3. Anteprima dispositivo
    4. Copiare CSS dai livelli
    5. Dividere in sezioni una pagina Web
    6. Opzioni HTML per sezioni
    7. Modificare la disposizione delle sezioni
    8. Lavorare con la grafica per il Web
    9. Creare gallerie di foto per il Web
  12. Concetti di base sul colore e sulle immagini
    1. Come ridimensionare le immagini
    2. Utilizzare immagini raster e vettoriali
    3. Dimensioni e risoluzione dell’immagine
    4. Acquisire le immagini da fotocamere e scanner
    5. Creare, aprire e importare le immagini
    6. Visualizzare immagini
    7. Errore: Marcatore JPEG non valido | Apertura immagini
    8. Visualizzare più immagini
    9. Personalizzare i selettori colore e i campioni
    10. Immagini HDR (High Dynamic Range)
    11. Ottenere colori corrispondenti nell’immagine
    12. Convertire le immagini in un altro metodo di colore
    13. Metodi di colore
    14. Cancellare parti di un’immagine
    15. Metodi fusione
    16. Scegliere i colori
    17. Personalizzare le tavole dei colori per immagini in scala di colore
    18. Informazioni sulle immagini
    19. I filtri di distorsione sono non disponibili
    20. Il colore
    21. Regolazioni a colori e monocromatiche con i canali
    22. Scegliere i colori nei pannelli Colore e Campioni
    23. Campionare
    24. Metodo di colore o Metodo di immagine
    25. Dominante di colore
    26. Aggiungere una modifica di metodo condizionale a un’azione
    27. Aggiungere campioni da file HTML, CSS e SVG
    28. Profondità di bit e preferenze
  13. Livelli
    1. Nozioni di base sui livelli
    2. Modifiche non distruttive
    3. Creare e gestire livelli e gruppi
    4. Selezionare, raggruppare e collegare i livelli
    5. Inserire immagini nelle cornici
    6. Opacità e fusione dei livelli
    7. Mascherare i livelli
    8. Applicare filtri avanzati
    9. Composizioni di livelli
    10. Spostare, sovrapporre e bloccare i livelli
    11. Mascherare i livelli con maschere vettoriali
    12. Gestire livelli e gruppi
    13. Stili ed effetti di livello
    14. Modificare le maschere di livello
    15. Estrarre le risorse
    16. Rivelare i livelli con maschere di ritaglio
    17. Generare risorse di immagini dai livelli
    18. Utilizzare gli oggetti avanzati
    19. Metodi fusione
    20. Combinare più immagini in un ritratto di gruppo
    21. Combinare le immagini con Fusione automatica livelli
    22. Allineare e distribuire i livelli
    23. Copiare CSS dai livelli
    24. Caricare selezioni dai bordi di un livello o di una maschera di livello
    25. Foratura per rivelare il contenuto di altri livelli
  14. Selezione
    1. Introduzione alle selezioni
    2. Effettuare selezioni nella composizione
    3. Area di lavoro Seleziona e maschera
    4. Selezionare con gli strumenti di selezione
    5. Selezionare con gli strumenti lazo
    6. Regolare selezioni di pixel
    7. Spostare, copiare ed eliminare i pixel selezionati
    8. Creare una maschera veloce temporanea
    9. Selezionare un intervallo di colori in un’immagine
    10. Convertire i tracciati in bordi di selezione e viceversa
    11. Nozioni di base sui canali
    12. Salvare selezioni e maschere di canali alfa
    13. Selezionare le aree di interesse di un’immagine
    14. Duplicare, dividere e unire i canali
    15. Calcoli per le operazioni con i canali
  15. Regolazioni delle immagini
    1. Sostituire il colore degli oggetti
    2. Alterare la prospettiva
    3. Ridurre la sfocatura causata da fotocamera mossa
    4. Esempi di utilizzo del pennello correttivo
    5. Esportare le tavole di consultazione del colore
    6. Regolare la nitidezza e la sfocatura dell’immagine
    7. Le regolazioni di colore
    8. Applicare una regolazione Luminosità/contrasto
    9. Regolare i particolari nelle aree di ombra e di luce
    10. Regolazioni Valori tonali
    11. Regolare tonalità e saturazione
    12. Regolare la vividezza
    13. Regolare la saturazione dei colori in un’area dell’immagine
    14. Effettuare regolazioni tonali rapide
    15. Applicare effetti speciali di colore alle immagini
    16. Migliorare l’immagine con le regolazioni di Bilanciamento colore
    17. Immagini HDR (High Dynamic Range)
    18. Visualizzare istogrammi e valori dei pixel
    19. Ottenere colori corrispondenti nell’immagine
    20. Ritagliare e raddrizzare le foto
    21. Convertire un’immagine a colori in bianco e nero
    22. Livelli di regolazione e riempimento
    23. Regolazioni Curve
    24. Metodi fusione
    25. Preparare immagini per la stampa
    26. Regolare colore e tonalità con i contagocce di Valori tonali e Curve
    27. Effettuare regolazioni con Esposizione HDR e Viraggio HDR
    28. Schermare o bruciare un’area dell’immagine
    29. Eseguire regolazioni selettive del colore
  16. Adobe Camera Raw
    1. Requisiti di sistema per Camera Raw
    2. Novità in Camera Raw
    3. Introduzione a Camera Raw
    4. Creare panorami
    5. Obiettivi supportati
    6. Effetti Vignettatura, Granulosità e Rimuovi foschia in Camera Raw
    7. Scelte rapide da tastiera predefinite
    8. Correzione prospettica automatica in Camera Raw
    9. Filtro radiale in Camera Raw
    10. Gestione delle impostazioni di Camera Raw
    11. Aprire, elaborare e salvare le immagini in Camera Raw
    12. Riparare le immagini con lo strumento rimozione macchie ottimizzato di Camera Raw
    13. Ruotare, ritagliare e ritoccare le immagini
    14. Regolare la riproduzione dei colori in Camera Raw
    15. Versioni di processo in Camera Raw
    16. Apportare regolazioni locali in Camera Raw
  17. Ritocco e riparazione delle immagini
    1. Rimuovere oggetti dalle foto con Riempimento in base al contenuto
    2. Correzione e spostamento in base al contenuto
    3. Ritoccare e riparare le foto
    4. Correzione della distorsione e del disturbo di un’immagine
    5. Procedure di base per la risoluzione della maggior parte dei problemi
  18. Miglioramento e trasformazione delle immagini
    1. Sostituire il cielo nelle immagini
    2. Trasformare gli oggetti
    3. Regolare il ritaglio, la rotazione e la dimensione del quadro
    4. Come ritagliare e raddrizzare le foto
    5. Creare e modificare immagini panoramiche
    6. Alterare immagini, forme e tracciati
    7. Fuoco prospettico
    8. Ridimensionamento in base al contenuto
    9. Trasformare immagini, forme e tracciati
  19. Disegnare e colorare
    1. Disegnare pattern simmetrici
    2. Disegnare rettangoli e modificare le opzioni di traccia
    3. Il disegno
    4. Disegnare e modificare le forme
    5. Strumenti di pittura
    6. Creare e modificare i pennelli
    7. Metodi fusione
    8. Aggiungere colore ai tracciati
    9. Modificare i tracciati
    10. Colorare con lo strumento pennello miscela colori
    11. Pennelli predefiniti
    12. Sfumature
    13. Interpolazione sfumatura
    14. Applicare riempimento e traccia a selezioni, livelli e tracciati
    15. Disegnare con gli strumenti penna
    16. Creare i pattern
    17. Generare un pattern con Crea pattern
    18. Gestire i tracciati
    19. Gestire le librerie di pattern e i predefiniti
    20. Disegnare o colorare con una tavoletta grafica
    21. Creare pennelli con texture
    22. Aggiungere elementi dinamici ai pennelli
    23. Sfumatura
    24. Colorare con tratti stilizzati con lo strumento pennello artistico storia
    25. Applicare un pattern
    26. Sincronizzare i predefiniti su più dispositivi
    27. Migrazione di predefiniti, azioni e impostazioni
  20. Testo
    1. Aggiungere e modificare il testo
    2. Unified Text Engine
    3. Utilizzare i font SVG OpenType
    4. Formattare i caratteri
    5. Formattare i paragrafi
    6. Come creare effetti di testo
    7. Modificare il testo
    8. Spaziatura tra righe e caratteri
    9. Testo in arabo e in ebraico
    10. Font
    11. Risoluzione dei problemi relativi ai font
    12. Testo asiatico
    13. Creare il testo
  21. Filtri ed effetti
    1. Utilizzare la Galleria sfocatura
    2. Nozioni di base sui filtri
    3. Presentazione degli effetti dei filtri
    4. Aggiungere effetti di luce
    5. Usare il filtro Grandangolo adattato
    6. Usare il filtro Dipinto a olio
    7. Utilizzare il filtro Fluidifica
    8. Stili ed effetti di livello
    9. Applicare filtri specifici
    10. Sfumare un’area dell’immagine
  22. Salvataggio ed esportazione
    1. Salvare i file in Photoshop
    2. Esportare i file in Photoshop
    3. Formati di file supportati
    4. Salvare i file in formati grafici
    5. Spostare i progetti tra Photoshop e Illustrator
    6. Salvare ed esportare video e animazioni
    7. Salvare i file PDF
    8. Protezione Digimarc del copyright
  23. Gestione del colore
    1. Comprendere la gestione del colore
    2. Mantenere i colori coerenti
    3. Impostazioni del colore
    4. Immagini a due tonalità
    5. Utilizzare i profili colore
    6. Gestione del colore nei documenti da visualizzare online
    7. Gestione del colore dei documenti durante la stampa
    8. Gestione del colore nelle immagini importate
    9. Prove colore
  24. Creazione di contenuti per il Web, per lo schermo e app
    1. Photoshop per la progettazione
    2. Tavole da disegno
    3. Anteprima dispositivo
    4. Copiare CSS dai livelli
    5. Dividere in sezioni una pagina Web
    6. Opzioni HTML per sezioni
    7. Modificare la disposizione delle sezioni
    8. Lavorare con la grafica per il Web
    9. Creare gallerie di foto per il Web
  25. Video e animazioni
    1. Modifiche video in Photoshop
    2. Modificare i livelli di animazioni e video
    3. Panoramica su video e animazioni
    4. Anteprima di video e animazioni
    5. Colorare i fotogrammi nei livelli video
    6. Importare file video e sequenze di immagini
    7. Creare animazioni di fotogrammi
    8. Creative Cloud 3D Animation (anteprima)
    9. Creare animazioni nella timeline
    10. Creare le immagini per i video
  26. Stampa
    1. Stampare oggetti 3D
    2. Stampare da Photoshop
    3. Stampa con la gestione del colore
    4. Provini a contatto e presentazioni PDF
    5. Stampare le foto con un layout Pacchetto d’immagini
    6. Stampa di tinte piatte
    7. Stampare immagini con una macchina da stampa
    8. Migliorare le stampe a colori da Photoshop
    9. Risoluzione dei problemi di stampa | Photoshop
  27. Automazione
    1. Creazione delle azioni
    2. Creare la grafica basata su dati
    3. Script
    4. Elaborare i file in batch
    5. Eseguire e gestire le azioni
    6. Aggiungere azioni condizionali
    7. Le azioni e il pannello Azioni
    8. Registrare gli strumenti nelle azioni
    9. Aggiungere una modifica di metodo condizionale a un’azione
    10. Toolkit dell’interfaccia utente di Photoshop per plug-in e script
  28. Risoluzione dei problemi
    1. Problemi risolti 
    2. Problemi noti
    3. Ottimizzare le prestazioni di Photoshop
    4. Risoluzione dei problemi di base
    5. Risoluzione dei problemi di blocco o arresto anomalo
    6. Risoluzione dei problemi dovuti a errori nel programma
    7. Risoluzione dell’errore “Disco di memoria virtuale pieno”
    8. Risoluzione dei problemi relativi a GPU e driver della scheda grafica
    9. Trovare strumenti mancanti
    10. Photoshop | Domande frequenti sulla rimozione delle funzioni 3D

Potete generare risorse di immagini JPEG, PNG, GIF o SVG dai contenuti di un livello o gruppo di livelli di un file PSD. Le risorse vengono generate automaticamente quando aggiungete l’estensione di un formato immagine supportato al nome di un livello o gruppo di livelli. Facoltativamente, potete anche specificare i parametri di qualità e dimensione da applicare alle risorse di immagini generate.

La generazione delle risorse di immagini da un file PSD è utile in particolare per la progettazione Web per dispositivi diversi.

Per informazioni su come creare ed esportare grafica per il Web, consultate Come esportare i file in diversi formati da Photoshop.

Generare risorse di immagini da livelli o gruppi di livelli

Per comprendere meglio il funzionamento del generatore di immagini, potete esaminare un semplice file PSD (che potete scaricare da questo collegamento) contenente la seguente gerarchia di livelli:

Generare le risorse di immagini in Photoshop
Esempio di file PSD con relativa struttura di livelli

Questo file ha due gruppi di livelli: Rounded_rectangles e Ellipses. Ciascun gruppo contiene cinque livelli.

Per generare risorse di immagini da questo file PSD, effettuate i passaggi seguenti:

  1. Con il file PSD aperto, selezionate File > Genera > Risorse immagine.
  2. Aggiungete l'estensione del formato desiderato (.jpg, .png.gif o .svg) ai nomi dei livelli o gruppi di livelli da cui desiderate generare le risorse di immagine. Ad esempio, modificate il nome dei gruppi di livelli Rounded_rectangles e Ellipses in Rounded_rectangles.jpg e Ellipses.png e quello del livello Ellipse_4 in Ellipse_4.gif.
Nota:

I nomi di livelli non possono contenere i caratteri speciali :*.

Photoshop genera le risorse di immagini e le salva in una sottocartella nella cartella del file PSD originale. Se il file PSD originale non era ancora stato salvato, Photoshop salva le risorse generate in una sottocartella nella cartella Desktop.

Nomi delle risorse di immagini in Photoshop
I nomi delle risorse di immagini vengono generati dal nome del relativo livello/gruppo di livelli

Nota:

La generazione delle risorse di immagini è abilitata per il documento corrente. Una volta abilitata, resta disponibile anche se il documento viene chiuso e riaperto. Per disabilitare la generazione delle risorse di immagini per il documento corrente, deselezionate File > Genera > Risorse immagine.

Generare risorse per documenti cloud

Se state lavorando con un documento cloud, le risorse saranno salvate nella directory “Photoshop Cloud Associates”:

  • Windows: C:\Users\yourname\Documents\Adobe\Photoshop Cloud Associates
  • macOS: /Users/yourname/Documents/Adobe/Photoshop Cloud Associates

Generare più risorse da un livello o gruppo di livelli

Per generare più risorse da un livello o gruppo di livelli, separate con una virgola i nomi delle risorse. Ad esempio, il nome del livello di seguito genera tre risorse:

Ellipse_4.jpg, Ellipse_4b.png, Ellipse_4c.png

Salvare le risorse in una sottocartella

Potete scegliere di salvare le risorse grafiche generate da particolari livelli o gruppi di livelli in una sottocartella diretta della cartella delle risorse del documento. Includete il nome della sottocartella nel nome del livello/gruppo di livelli; ad esempio:

[sottocartella]/Ellipse_4.jpg 

Esempio di utilizzo per un lavoro di progettazione Web

La generazione delle risorse di immagini da un file PSD è utile in particolare per la progettazione Web per dispositivi diversi. Considerate la seguente progettazione Web e la relativa struttura di livelli:

Progettazione Web con struttura di livelli

Per estrarre l’icona in alto e la riga superiore della griglia di immagini Global Hotspots come risorse di immagini:

  • Aggiungete le estensioni del formato immagine ai nomi dei relativi livelli.
Rinominare i livelli o gruppi di livelli in Photoshop

Rinominare i livelli o gruppi di livelli in Photoshop

Rinominare i livelli o gruppi di livelli

Nota:

Dal contenuto di un livello o gruppo di livello viene generata una singola risorsa di immagine. Ad esempio, il gruppo di livelli AdventureCo Logo dell’immagine qui sopra contiene un livello forma e un livello di testo dinamico. Quando da questo gruppo viene generata una risorsa di immagine, tali livelli vengono rasterizzati.

Photoshop genera le risorse di immagini e le salva nello stesso percorso del file PSD originale.

Risorse di immagini generate in Photoshop
Risorse di immagini generate

Specificare i parametri di qualità e dimensione

Per impostazione predefinita, le risorse JPG vengono generate con qualità 90%. Per impostazione predefinita, le risorse PNG vengono generate come immagini a 32 bit. Le risorse GIF vengono generate con trasparenza alfa di base.

Quando si rinominano i livelli o gruppi di livelli per la generazione di risorse, è possibile specificare i parametri di qualità e dimensione.

Parametri per risorse JPEG

  • Per specificare la qualità di output desiderata, aggiungete un suffisso al nome della risorsa: .jpg(1-10) o .jpg(1-100%). Ad esempio:
    • Ellipse_4.jpg5
    • Ellipse_4.jpg50%
  • Per aggiungere le dimensioni di output desiderate (relative o in una delle unità di misura supportate: px, in, cm e mm), aggiungete un prefisso al nome della risorsa. Photoshop ridimensiona di conseguenza l’immagine. Ad esempio:
    • 200% Ellipse_4.jpg
    • 300 x 200 Rounded_rectangle_3.jpg
    • 10 in x 200 mm Rounded_rectangle_3.jpg

Nota: ricordate di aggiungere uno spazio tra il prefisso e il nome della risorsa. Per specificare le dimensioni in pixel, è possibile omettere l’unità. Ad esempio, 300 x 200.

Nota:

Come illustrato, nelle dimensioni di output specificate potete utilizzare unità di misura diverse e pixel. Ad esempio, 4in x 100 Rounded_rectangle_3.jpg è un nome di livello valido per la generazione di risorse.

Parametri per risorse PNG

  • Per specificare la qualità di output desiderata, aggiungete un suffisso al nome della risorsa: 8, 24 o 32. Ad esempio:
    • Ellipse_4.png24
  • Per aggiungere le dimensioni di output desiderate (relative o in una delle unità di misura supportate: px, in, cm e mm), aggiungete un prefisso al nome della risorsa. Photoshop ridimensiona di conseguenza l’immagine. Ad esempio:
    • 42% Ellipse_4.png
    • 300 mm x 20 cm Rounded_rectangle_3.png
    • 10 in x 50 cm Rounded_rectangle_3.png

Nota: ricordate di aggiungere uno spazio tra il prefisso e il nome della risorsa. Per specificare le dimensioni in pixel, è possibile omettere l’unità. Ad esempio, 300 x 200.

Nota:

Come illustrato, nelle dimensioni di output specificate potete utilizzare unità di misura diverse e pixel. Ad esempio, 4in x 100 Rounded_rectangle_3.png è un nome di livello valido per la generazione di risorse.

Parametri per risorse GIF

  • Per aggiungere le dimensioni di output desiderate (relative o in una delle unità di misura supportate: px, in, cm e mm), aggiungete un prefisso al nome della risorsa. Ad esempio:
    • 42% Ellipse_4.gif
    • 300 mm x 20 cm Rounded_rectangle_3.gif
    • 20 in x 50 cm Rounded_rectangle_3.gif

Nota: ricordate di aggiungere uno spazio tra il prefisso e il nome della risorsa. Per specificare le dimensioni in pixel, è possibile omettere l’unità. Ad esempio, 300 x 200.

Nota:

Come illustrato, nelle dimensioni di output specificate potete utilizzare unità di misura diverse e pixel. Ad esempio, 4in x 100 Rounded_rectangle_3.gif è un nome di livello valido per la generazione di risorse.

I parametri di qualità non sono disponibili per le risorse GIF.

Specificare nomi di livelli complessi

Utilizzando i parametri nei nomi dei livelli per la generazione delle risorse, potete specificare nomi di risorse complessi. Ad esempio:

120% Delicious.jpg, 42% Delicious.png24, 100x100 Delicious_2.jpg90%, 250% Delicious.gif

Da questo livello vengono generate le seguenti risorse:

  • Delicious.jpg (immagine JPG con qualità 8 ridimensionata al 120%)
  • Delicious.png (immagine PNG a 24 bit ridimensionata al 42%)
  • Delicious_2.jpg (Immagine JPG con qualità 90% e dimensione assoluta di 100x100 px)
  • Delicious.gif (immagine GIF ridimensionata al 250%)

Esempi di ridimensionamento assoluto

Buoni esempi di ridimensionamento assoluto

  • 100 x 80 foo.png (ridimensionamento assoluto semplice)
  • 80 x 100 px foo.png (spazi tra lunghezze)
  • 4In x 100 foo.png (mix di unità e nessuna unità)
  • 90 mm x120 cm foo.png (mix di diverse unità)
  • 100 x? Foo.png (carattere jolly)
  • ?x60in foo.png (carattere jolly all’inizio)

Cattivi esempi di ridimensionamento assoluto

  • 100 x 100foo.png (senza spazio prima del nome del file)
  • 80 x 100 60% foo.png (mix di ridimensionamento assoluto e relativo)
  • 50% 80 x 100 foo.png (mix di ridimensionamento assoluto e relativo)
  • 20in cm x 50cm foo.png (unità multiple)
  • 30nm x 20 nano.png (unità non valida)

Formattazione e separazione di più file

Buoni esempi

  • Layer 1.png (lo spazio nel nome del file è consentito e si ottiene un singolo file denominato “Layer 1.png”)
  • Layer 1.png,Layer 2.jpg (virgola come separatore)
  • Layer 1.png, Layer 2.jpg (virgola seguita da spazio come separatore)
  • Layer 1.png+Layer 2.jpg (segno + come separatore)
  • Layer 1.png + Layer 2.jpg (segno + seguito da spazio come separatore)

Mettendo tutto insieme

100% Delicious, 42% Layer 1.png24 + 100x100 Layer.jpg-90% , 250% Quux/Foo Bar Baz.gif dà origine a tre file (la stringa “100% Delicious” viene ignorata perché non è un nome di file):

  • Layer 1.png, ridimensionata al 42%, come PNG a 24 bit
  • Layer.jpg, come dimensione assoluta di 100x100 pixel, come un JPG di qualità al 90%
  • Foo Bar Baz.gif nella sottocartella Quux, ridimensionato al 250%, come una GIF.

Specificare impostazioni predefinite per le risorse

Potete specificare impostazioni predefinite a livello di documento per le risorse generate. Effettuate le seguenti operazioni:

  1. Selezionate un livello vuoto nel documento.
  2. Iniziate il nome del livello con la parola chiave default. Poi, specificate le impostazioni che desiderate applicare a tutte le risorse grafiche generate dal documento. Ad esempio:

default hi-res/

Genera tutte le risorse di immagine in una sottocartella denominata hi-res. Ad esempio, [cartella_risorse]/hi-res/Delicious.jpg.

default hi-res/@2x

Genera tutte le risorse di immagine in una sottocartella denominata hi-res. Inoltre, aggiunge il suffisso @2x ai nomi delle risorse. Ad esempio, [cartella_risorse]/hi-res/Delicious@2x.jpg.

default 50% lo-res/

Salva le risorse di immagine con dimensioni ridotte del 50% nella sottocartella lo-res sotto la cartella delle risorse del documento 

default hi-res/@2x + 50% lo-res/

Genera due risorse di immagine da un livello:

  • Nella sottocartella hi-res, una risorsa con il suffisso @2x aggiunto al nome
  • Nella sottocartella lo-res, una risorsa con dimensioni ridotte del 50%
Nota:

I fattori di ridimensionamento predefiniti sono sostituiti da quelli specificati per i singoli livelli.

Disattivare la generazione di risorse di immagini per tutti i documenti

Potete disattivare la generazione delle risorse di immagini globalmente per tutti i documenti Photoshop modificando le Preferenze.

  1. Scegliete Modifica > Preferenze > Plug-in.
  2. Deselezionate Abilita Generatore.
  3. Fate clic su OK.
Nota:

Quando la generazione delle risorse di immagini viene disabilitata dalle Preferenze, il comando di menu File > Genera non è più disponibile. finché tale funzione non venga nuovamente abilitata nella finestra di dialogo Preferenze.

Domande frequenti

I nomi delle risorse devono essere univoci per ogni singolo documento.

Per impostazione predefinita, le risorse JPG vengono generate con qualità 90%. Per impostazione predefinita, le risorse PNG vengono generate come immagini a 32 bit. Le risorse GIF vengono generate con trasparenza alfa di base.

Sì. La trasparenza e altri effetti applicati a un livello vengono mantenuti nelle risorse generate dal livello. Tuttavia, tali effetti potrebbero risultare rasterizzati nella risorsa generata.

Le risorse vengono ritagliate in base ai limiti del documento. Se un’immagine non rientra nei limiti del documento, Generator non crea le relative risorse di immagini.

Oltre alla virgola, è possibile usare come separatore il simbolo più (+). Ad esempio:

42% Rounded_rectangle_1.png24 + 100x100 Rounded_rectangle_1.jpg90%

è equivalente a:

42% Rounded_rectangle_1.png24, 100x100 Rounded_rectangle_1.jpg90%

Altri argomenti correlati

 Adobe

Ottieni supporto in modo più facile e veloce

Nuovo utente?

Adobe MAX 2024

Adobe MAX
La conferenza sulla creatività

14-16 ottobre Miami Beach e online

Adobe MAX

La conferenza sulla creatività

14-16 ottobre Miami Beach e online

Adobe MAX 2024

Adobe MAX
La conferenza sulla creatività

14-16 ottobre Miami Beach e online

Adobe MAX

La conferenza sulla creatività

14-16 ottobre Miami Beach e online