Poznámka:

Nástroje 3D jsou nezávislé na nástrojích perspektivní mřížky a objekty 3D jsou zpracovány jako jakýkoli jiný objekt v perspektivě.

Vytváření 3D objektů

Pomocí 3D efektů můžete vytvářet trojrozměrné (3D) objekty z dvourozměrných (2D) kreseb. Vzhled 3D objektů můžete nastavit pomocí světel, stínů, otočení a dalších vlastností. Můžete také mapovat kresbu na každý povrch 3D objektu.

Existují dva způsoby jak vytvořit 3D objekt: vytlačením nebo obkroužením. Navíc můžete také natočit 2D nebo 3D objekt ve třech rozměrech. Chcete-li aplikovat nebo změnit 3D efekty pro existující 3D objekt, vyberte tento objekt, a pak poklepejte na efekt v panelu Vzhled.

Poznámka:

3D objekty se mohou na obrazovce zobrazovat s artefakty vyhlazení, které se ale neobjeví při tisku, ani v kresbě optimalizované pro web.

Podívejte se na video o práci s 3D objekty v aplikaci Illustrator Moving into the world of 3D (Cesta do světa 3D).

Vytvoření 3D objektu vytlačením

Vytlačení rozšíří 2D objekt podél jeho osy z, a tím přidá objektu hloubku. Pokud například vytlačíte 2D elipsu, stane se z ní válec.

Poznámka:

Osa objektu je vždy kolmá k přednímu povrchu objektu a pohybuje se vzhledem k objektu, pokud objekt natočíte v dialogovém okně Volby 3D.

Vytlačení objektu
Vytlačení objektu

  1. Vyberte objekt.
  2. Zvolte Efekt > 3D > Vytlačit a zkosit.
  3. Klikněte na možnost Více voleb, chcete-li zobrazit úplný seznam voleb, nebo na Méně voleb, chcete-li další volby skrýt.
  4. Vyberte Náhled, chcete-li zobrazit náhled efektu v okně dokumentu.
  5. Určete volby:

    Umístění

    Nastaví, jak je objekt natočený, a perspektivu, ze které ho pozorujete. (Viz Nastavení voleb polohy 3D natočení.)

    Vytlačení a zkosení

    Určí hloubku objektu a rozsah přidaného nebo odříznutého zkosení. (Viz Volby vytlačení a zkosení.)

    Povrch

    Vytvoří celou řadu různých povrchů, od matných a nestínovaných povrchů až po lesklé a osvětlené povrchy, které vypadají jako plastická fólie. (Viz Volby stínování povrchu.)

    Osvětlení

    Přidá jedno nebo více světel, změní intenzitu světla, změní barvu stínování objektu a posune světla kolem objektu, čímž se vytvoří zajímavé efekty. (Viz Volby osvětlení.)

    Mapovat

    Mapuje kresbu na povrchy 3D objektu. (Viz Mapování kresby na 3D objekt.)

  6. Klepněte na OK.
    Vytlačení objektu
    Vytlačený objekt bez zkoseného okraje (vlevo), objekt se zkosením dovnitř (uprostřed) a se zkosením ven (vpravo)

Vytvoření 3D objektu obkroužením

Obkroužení posunuje cestu neboli profil v kruhovém směru kolem globální osy y (osy obkroužení), a tím vytvoří 3D objekt. Protože osa obkroužení je ve svislém směru pevná, je obvykle třeba, aby zdrojová otevřená nebo zavřené cesta znázorňovala polovinu požadovaného profilu 3D objektu ve svislé poloze; v dialogovém okně efektu pak můžete polohu 3D objektu natočit.

Obkroužení objektu
Obkroužení objektu

  1. Vyberte objekt.

    Poznámka:

    Při aplikování efektu 3D obkroužení na jeden nebo více objektů najednou se každý objekt otáčí kolem vlastní osy. Každý objekt je ve svém vlastním 3D prostoru a nemůže protínat jiné 3D objekty. Na druhou stranu, když aplikujete efekt obkroužení na cílovou skupinu nebo vrstvu, objekty se obkrouží kolem jedné osy.

    Poznámka:

    Obkroužení vyplněné cesty bez tahu je mnohem rychlejší, než obkroužení vytažené cesty.

  2. Zvolte Efekt > 3D > Obkroužit.
  3. Vyberte Náhled, chcete-li zobrazit náhled efektu v okně dokumentu.
  4. Klikněte na možnost Více voleb, chcete-li zobrazit úplný seznam voleb, nebo na Méně voleb, chcete-li další volby skrýt.

    Umístění

    Nastaví, jak je objekt natočený, a perspektivu, ze které ho pozorujete. (Viz Nastavení voleb polohy 3D natočení.)

    Obkroužení

    Určuje způsob obkroužení cesty okolo objektu, aby vznikl trojrozměrný objekt. (Viz Volby obkroužení.)

    Povrch

    Vytvoří celou řadu různých povrchů, od matných a nestínovaných povrchů až po lesklé a osvětlené povrchy, které vypadají jako plastická fólie. (Viz Volby stínování povrchu.)

    Osvětlení

    Přidá jedno nebo více světel, změní intenzitu světla, změní barvu stínování objektu a posune světla kolem objektu, čímž se vytvoří zajímavé efekty. (Viz Volby osvětlení.)

    Mapovat

    Mapuje kresbu na povrchy 3D objektu. (Viz Mapování kresby na 3D objekt.)

  5. Klepněte na OK.

Nastavte volby

Nastavení voleb polohy 3D natočení

  1. Proveďte libovolný z následujících úkonů:
    • Zvolte přednastavenou polohu z nabídky Poloha.

    • Nastavte libovolné natočení přetažením povrchu ovládací kostky. Přední strana objektu je reprezentovaná modrou plochou ovládací kostky, horní a spodní strany jsou světle šedé, boční strany jsou středně šedé a zadní strana je tmavě šedá.

    • Chcete-li omezit natočení na natočení podle globální osy, podržte Shift při vodorovném tažení (globální osa y) nebo svislém tažení (globální osa x). Chcete-li natočit objekt kolem globální osy z, přetáhněte modrý pruh, který obklopuje ovládací kostku.

    • Chcete-li omezit natočení na natočení kolem osy objektu, přetáhněte hranu ovládací kostky. Ukazatel se změní na dvoustrannou šipku a hrana kostky změní barvu, aby se označila osa, kolem které se bude objekt otáčet. Červené hrany představují osu x objektu, zelené osu y objektu a modré hrany osu z objektu.

    • Zadejte hodnoty mezi –180 a 180 do textových polí pro vodorovnou (x) osu , svislou (y) osu a pro osu hloubky (z) .

    • Chcete-li nastavit perspektivu, zadejte hodnotu mezi 0 a 160 do textového pole Perspektiva. Menší úhel je podobný teleobjektivu fotoaparátu; větší úhel je podobný širokoúhlému objektivu.

Poznámka:

Při úhlu objektivu větším než 150 se může objekt roztáhnout mimo zorné pole a může vypadat zdeformovaný. Také si uvědomte, že existují osy x, y a z objektu a globální osy x, y a z. Osy objektu zůstávají relativní k poloze objektu v jeho 3D prostoru. Globální osy jsou pevné vzhledem k obrazovce počítače; osa x je vodorovná, osa y svislá a osa z je kolmá k obrazovce.

Osy objektu
Osy objektu (černé) se přemísťují s objektem; globální osy (šedivé) jsou pevné.

Volby vytlačení a zkosení

Hloubka vytlačení

Nastaví hloubku objektu pomocí hodnoty mezi 0 a 2000.

Konce

Určuje, zda objekt bude vypadat jako plný (Zapnout zakončení ) nebo dutý (Vypnout zakončení ).

Zkosení

Aplikuje zvolený typ zkosení okraje do hloubky (osa z) objektu.

Výška

Nastaví výšku mezi 1 a 100. Je-li výška zkosení pro objekt příliš velká, může způsobit, že objekt protne sám sebe, a vznikne neočekávaný výsledek.

Zkosení ven

Přidá zkosení k původnímu tvaru objektu.

Zkosení dovnitř

Odřízne zkosení od původního tvaru objektu.

Vytlačený objekt se zakončením
Vytlačený objekt se zakončením (vlevo nahoře) a bez zakončení (vpravo nahoře); objekt bez zkosených okrajů (vlevo dole) a objekt se zkosenými okraji (vpravo dole)

Volby obkroužení

Úhel

Nastaví velikost úhlu obkroužení cesty ve stupních mezi 0 a 360.

Konce

Určuje, zda objekt bude vypadat jako plný (Zapnout zakončení ) nebo dutý (Vypnout zakončení ).

Odsazení

Přidá vzdálenost mezi osou obkroužení a cestou, aby se vytvořil například objekt ve tvaru prstence. Můžete zadat hodnotu mezi 0 a 1000.

Od

Nastaví osu, kolem které se objekt otáčí, buď Levý okraj nebo Pravý okraj.

Volby stínování povrchu

Povrch

Umožňuje vybrat volby pro stínování povrchů:

Drátový model

Vykreslí obrysy geometrie objektu a změní povrchy na průhledné.

Bez stínování

Nepřidá k objektu žádné nové vlastnosti povrchu. 3D objekt bude mít stejnou barvu jako původní 2D objekt.

Rozptýlené stínování

Nastaví, aby objekt odrážel světlo měkkým rozptýleným způsobem.

Plastické stínování

Nastaví, aby objekt odrážel světlo, jako by byl vyrobený z lesklého materiálu.

Poznámka: Podle toho, jakou možnost zvolíte, budou k dispozici různé možnosti osvětlení. Jestliže objekt používá jen efekt 3D natočení, budou mezi volbami povrchu dostupné jen možnosti Rozptýlené stínování nebo Žádné stínování.

Intenzita světla

Nastaví intenzitu světla mezi 0 % a 100 %.

Okolní světlo

Nastaví globální osvětlení, které mění jas všech povrchů objektu stejně. Zadejte hodnotu mezi 0 % a 100 %.

Intenzita zvýraznění

Nastaví, nakolik objekt odráží světlo, s hodnotami v rozsahu od 0 % do 100 %. Nižší hodnoty vytvářejí matný povrch a vyšší hodnoty vytvářejí lesklejší povrch.

Velikost zvýraznění

Nastaví velikost zvýraznění od velkého (100 %) po malé (0 %).

Kroků prolnutí

Určuje, jak plynulé bude stínování povrchů objektu. Zadejte hodnotu mezi 1 a 256. Vyšší čísla vytvářejí hladší stínování a více cest než nižší čísla.

Kreslit skryté povrchy

Zobrazí skryté zadní plochy objektu. Zadní plochy budou viditelné, pokud je objekt průhledný, nebo když objekt rozdělíte a pak roztáhnete.

Poznámka: Pokud objekt obsahuje průhlednost a chcete, aby se skryté zadní plochy zobrazovaly přes průhledné přední plochy, aplikujte na objekt příkaz Objekt > Seskupit před aplikováním 3D efektu.

Zachovat přímé barvy (efekt Vytlačení a zkosení, efekt Obkroužení a efekt Natočení)

Umožní zachovat přímé barvy objektu. Přímé barvy nelze zachovat, pokud jste zvolili vlastní barvu z nabídky Barva stínování.

Příklady různých variant stínování povrchu
Příklady různých variant stínování povrchu

A. Drátový model B. Bez stínování C. Rozptýlené stínování D. Plastické stínování 

Volby osvětlení

Světlo

Definuje umístění světla. Přetáhněte světlo na kouli do požadované polohy.

Tlačítko Přemístit světlo dozadu

Přemístí vybrané světlo za objekt.

Tlačítko Přemístit světlo dopředu

Přemístí vybrané světlo před objekt.

Tlačítko nové světlo

Přidá světlo. Standardně se nové světlo objeví uprostřed před koulí.

Tlačítko Odstranit světlo

Odstraní vybrané světlo.

Poznámka: Standardně 3D efekt přiřadí objektu jedno světlo. Světla můžete přidávat a odstraňovat, ale objekt musí mít vždy alespoň jedno světlo.

Intenzita světla

Mění intenzitu vybraného světla mezi 0 % a 100 %.

Barva stínování

Nastaví barvu stínování objektu, v závislosti na vybraném příkazu:

Žádné

Nepřidá žádnou barvu stínování.

Vlastní

Umožní vybrat vlastní barvu. Pokud vyberete tuto volbu, klepněte na pole Barva stínování a vyberte barvu v dialogu pro výběr barvy. Přímé barvy se změní na výtažkové.

Přetisk černé

Zabrání použití výtažkových barev v pracovním postupu s přímými barvami. Objekt se bude stínovat přetiskováním černých odstínů přes barvu výplně objektu. Chcete-li zobrazit stínování, zvolte Zobrazení > Náhled přetisku.

Zachovat přímé barvy

Umožní zachovat přímé barvy objektu. Přímé barvy nelze zachovat, pokud jste zvolili vlastní barvu z nabídky Barva stínování.

Koule osvětlení
Koule osvětlení

A. Vybrané světlo vpředu B. Tlačítko přemístění vybraného světla dopředu nebo dozadu C. Tlačítko nové světlo D. Tlačítko odstranit světlo 

Přidání vlastní cesty zkosení

  1. Otevřete soubor Bevels.ai, umístěný ve složce Adobe Illustrator [verze]\Support Files\Required\Resources\en_US\ (Windows) nebo Adobe Illustrator [verze]\Required\Resources\en_US ((Mac OS).

  2. Vytvořte v souboru Bevels.ai otevřenou cestu.
  3. Zvolte Okna > Symboly a jedním z následujících úkonů vytvořte z cesty symbol:
    • Přetáhněte cestu do panelu Symboly.

    • S vybranou cestou klepněte na tlačítko Nový symbol v panelu Symboly nebo zvolte Nový symbol z nabídky panelu.

  4. Chcete-li symbol přejmenovat, poklepejte na něj v panelu Symboly, zadejte název v dialogovém okně Volby symbolu, a klepněte na OK.
  5. Zvolte Soubor > Uložit.
  6. Ukončete a pak znovu spusťte Illustrator.

    V nabídce Zkosení v dialogovém okně Volby 3D vytlačení a zkosení se objeví nová položka.

  7. Chcete-li aplikovat vlastní zkosení, proveďte jeden z následujících úkonů:
    • Chcete-li aplikovat zkosení na vytlačený 3D objekt, vyberte 3D objekt, a pak poklepejte na efekt 3D vytlačení a zkosení v panelu Vzhled. V dialogovém okně Volby 3D vytlačení a zkosení zvolte zkosení z nabídky Zkosení.

    • Chcete-li aplikovat vlastní zkosení na dvojrozměrnou (2D) kresbu, vyberte 2D objekt a pak zvolte Efekt > 3D > Vytlačit a zkosit. V dialogovém okně Volby 3D vytlačení a zkosení zvolte vlastní zkosení z nabídky Zkosení.

Natočení objektu ve třech rozměrech

  1. Vyberte objekt.
  2. Zvolte Efekt > 3D > Natočit.
  3. Vyberte Náhled, chcete-li zobrazit náhled efektu v okně dokumentu.
  4. Klikněte na možnost Více voleb, chcete-li zobrazit úplný seznam voleb, nebo na Méně voleb, chcete-li další volby skrýt.
  5. Určete volby:

    Umístění

    Nastaví, jak je objekt natočený, a perspektivu, ze které ho pozorujete. (Viz Nastavení voleb polohy 3D natočení.)

    Povrch

    Vytvoří celou řadu různých povrchů, od matných a nestínovaných povrchů až po lesklé a osvětlené povrchy, které vypadají jako plastická fólie. (Viz Volby stínování povrchu.)

  6. Klepněte na OK.

Mapování kresby na 3D objekt

Každý 3D objekt se skládá z více povrchů. Například ze čtverce se vytlačením stane kostka, která se skládá ze šesti povrchů: přední a zadní strany a čtyř bočních stran. Na každý povrch 3D objektu můžete mapovat 2D kresbu. Můžete například mapovat nálepku nebo text na objekt ve tvaru láhve nebo jednoduše přidat různé textury na různé strany objektu.

3D objekt s kresbami mapovanými na každou stranu
3D objekt s kresbami mapovanými na každou stranu

A. Kresba symbolu B. Kresba symbolu C. A a B mapované na 3D objekt 

Na 3D objekt můžete mapovat pouze 2D kresby, které jsou uložené v panelu Symboly. Symbolem může být libovolný objekt kresby aplikace Illustrator, včetně cest, složených cest, textu, rastrových obrazů, mřížkových objektů a skupin objektů.

Když mapujete 3D objekty, pamatujte si následující:

  • Protože funkce Mapovat kresbu používá pro mapování symboly, můžete upravit instanci symbolu, aby se automaticky aktualizovaly všechny povrchy, na kterých je tento symbol namapovaný.

  • Se symbolem v dialogovém okně Mapovat kresbu můžete pracovat pomocí normálních ovladačů ohraničovacího rámečku, chcete-li objekt přemístit, změnit jeho velikost nebo ho otočit.

  • 3D efekt si pamatuje každý mapovaný povrch na objektu jako číslo. Pokud upravíte 3D objekt nebo aplikujete stejný efekt na nový objekt, může vzniknout více nebo méně stran než má originál. Pokud vznikne méně povrchů, než je počet definovaných povrchů v původním mapování, nadbytečné kresby se budou ignorovat.

  • Protože poloha symbolu je určena vzhledem ke středu povrchu objektu, pokud se geometrie povrchu změní, symbol se přemapuje vzhledem k novému středu objektu.

  • Kresbu můžete mapovat na objekty, na které jsou použité efekty Vytlačení a zkosení nebo Obkroužení, ale nemůžete mapovat kresbu na objekty, na které je použitý pouze efekt Natočení.

  1. Vyberte 3D objekt.
  2. V panelu Vzhled poklepejte na efekt 3D vytlačení a zkosení nebo 3D obkroužení.
  3. Klepněte na Mapovat obraz.
  4. Z rozbalovací nabídky Symbol zvolte kresbu, kterou chcete mapovat na vybraný povrch.
  5. Chcete-li vybrat, na který povrch chcete mapovat, klikněte na tlačítko šipek pro první , předcházející , další nebo poslední povrch nebo do textového pole zadejte číslo povrchu.

    Na površích, které jsou právě viditelné, se objeví světle šedá značka. Na površích, které jsou v současné poloze objektu skryté, se objeví tmavě šedá značka. Když v dialogovém okně vyberete povrch, v okně dokumentu se vybraný povrch zvýrazní červeným obrysem.

  6. Proveďte libovolný z následujících úkonů:
    • Chcete-li symbol přemístit, umístěte ukazatel dovnitř ohraničovacího rámečku a přetáhněte jej; chcete-li změnit jeho velikost, přetahujte za postranní nebo rohový úchyt; chcete-li symbol otočit, přetahujte jej mimo ohraničovacího rámečku poblíž úchytu.

    • Chcete-li přizpůsobit mapovanou kresbu hranicím vybraného povrchu, klepněte na Přizpůsobit velikosti.

    • Chcete-li odstranit kresbu z jednoho povrchu, vyberte povrch pomocí voleb Povrch, a pak buď vyberte Žádný z nabídky Symbol nebo klepněte na Vymazat.

    • Chcete-li odstranit všechna mapování ze všech povrchů 3D objektu, klepněte na Vymazat vše.

    • Chcete-li mapovanou kresbu stínovat a aplikovat na ni osvětlení objektu, vyberte Stínovat kresbu.

    • Chcete-li zobrazit pouze mapování kresby a ne geometrii 3D objektu, vyberte Neviditelná geometrie. To je užitečné, když chcete použít funkci 3D mapování jako nástroj pro trojrozměrné pokřivení. Tuto volbu můžete například použít, chcete-li mapovat text na boční stranu vytlačené vlnité čáry tak, aby text vypadal pokřivený, jako by byl na vlajce.

    • Chcete-li zobrazit náhled efektu, vyberte Náhled.

  7. Klepněte na OK v dialogovém okně Mapovat obraz.

    Poznámka:

    3D nástroje nejsou na nástrojích perspektivní mřížky aplikace Illustrator závislé. 3D objekty umístěné v perspektivní mřížce se upravují stejně jako jiné obrazy.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online