Vybírání cest, segmentů a kotevních bodů

Před tím, než budete moci změnit tvar křivky nebo ji upravit, musíte vybrat kotevní body cesty, segmenty cesty nebo kombinaci bodů a cest.

Vybírání kotevních bodů

Proveďte libovolný z následujících úkonů:

  • Pokud vidíte body, můžete na ně klepnout nástrojem pro přímý výběr a tím je vybrat. Klepnutím se stisknutou klávesou Shift vyberte více bodů.
  • Vyberte nástroj pro přímý výběr a tažením vytvořte ohraničovací rámeček kolem kotevních bodů. Tažením se stisknutou klávesou Shift kolem dalších kotevních bodů je vyberte.
  • Kotevní body můžete vybrat z vybraných nebo nevybraných cest. Přesuňte nástroj pro přímý výběr na kotevní bod a ukazatel se změní na zvětšený prázdný čtverec v případě nevybraných cest a na vyplněný čtverec v případě vybraných cest, a poté klikněte na kotevní bod. Klepnutím se stisknutou klávesou Shift na další kotevní body je vyberte.
  • Vyberte nástroj laso a táhněte kolem kotevních bodů. Tažením se stisknutou klávesou Shift kolem dalších kotevních bodů je vyberte.

Vybírání segmentů cesty

Proveďte libovolný z následujících úkonů:

  • Vyberte nástroj pro přímý výběr a klikněte do vzdálenosti 2 pixelů od segmentu nebo přetáhněte výběr přes část segmentu. Klepnutím nebo tažením se stisknutou klávesou Shift kolem dalších segmentů cesty je vyberte.
  • Vyberte nástroj laso a přetáhněte kolem části segmentu cesty. Tažením se stisknutou klávesou Shift kolem dalších segmentů cesty je vyberte.

Výběr všech kotevních bodů a segmentů cesty

  1. Vyberte nástroj pro přímý výběr nebo nástroj laso (v aplikaci Illustrator).
  2. Táhněte kolem celé cesty.

    Pokud je cesta vyplněná, můžete také kliknout dovnitř cesty nástrojem pro přímý výběr a tím vybrat všechny kotevní body.

Kopírování cesty

Vyberte cestu nebo segment nástrojem pro výběr nebo nástrojem pro přímý výběr, a proveďte jeden z následujících úkonů:

  • Pomocí standardních funkcí nabídky zkopírujte a vložte cesty v rámci aplikace nebo mezi aplikacemi.
  • Stiskněte a podržte klávesu Alt (Windows) nebo Option (Mac OS) a přetáhněte cestu do požadovaného umístění, pak uvolněte tlačítko myši a klávesu Alt/Option.

Přidávání a odstraňování kotevních bodů

Přidání kotevních bodů vám umožní lépe nastavit tvar cesty nebo může prodloužit otevřenou cestu. Je ale dobré nepřidávat více bodů, než je nezbytně nutné. Cesty s menším počtem bodů se snadněji upravují, zobrazují a tisknou. Složitost cesty můžete snížit odstraněním nepotřebných bodů. Přidávání a odstraňování kotevních bodů se provádí ve všech aplikacích Adobe podobně.

Panel nástrojů obsahuje tři nástroje pro přidávání nebo odstraňování bodů: nástroj pero , nástroj pro přidání kotevního bodu a nástroj pro odstranění kotevního bodu . Kromě toho lze použít tlačítko Odstranit vybrané kotevní body v ovládacím panelu.

Standardně se nástroj pero změní na nástroj pro přidání kotevního bodu, když ho umístíte nad vybranou cestu, nebo na nástroj pro odstranění kotevního bodu, když ho umístíte nad kotevní bod.

Poznámka:

K odstraňování kotevních bodů nepoužívejte klávesy Delete a Backspace ani příkazy Úpravy > Vyjmout a Úpravy > Odstranit: tyto klávesy a příkazy odstraní nejen vybraný bod, ale i segmenty čáry, které jsou k tomuto bodu připojené.

Přidávání a odstraňování kotevního bodu

  1. Vyberte cestu, kterou chcete změnit.

  2. Chcete-li přidat bod ukotvení, vyberte nástroj pero nebo nástroj pro přidání bodu ukotvení, umístěte ukazatel nad segment cesty a klepněte.

  3. Chcete-li odstranit bod ukotvení, proveďte libovolný z následujících úkonů:

    • Vyberte bod nástrojem pro přímý výběr a v ovládacím panelu klepněte na tlačítko Odstranit vybrané kotevní body .

    • Vyberte nástroj pero nebo nástroj pro odstranění kotevního bodu, umístěte ukazatel nad kotevní bod a klepněte.

Vyhledání a odstranění osamocených kotevních bodů

Osamocené kotevní body jsou jednotlivé body, které nejsou spojené s dalšími kotevními body. Je dobrý zvykem osamocené kotevní body najít a odstranit.

  1. Odznačte všechny objekty.

  2. Zvolte Výběr > Objekt > Osamocené body.

  3. Zvolte Úpravy > Vyjmout nebo Úpravy > Odstranit nebo na klávesnici stiskněte Delete nebo Backspace.

Vypnutí nebo dočasné potlačení automatického přepínání nástroje pero

Automatické přepínání na nástroj pro přidání kotevního bodu nebo na nástroj pro odstranění kotevního bodu lze dočasně potlačit nebo úplně vypnout.

  • Chcete-li přepínání dočasně potlačit, podržte při umísťování nástroje pero nad vybranou cestu nebo kotevní bod stisknutou klávesu Shift. To je užitečné, když chcete začít novou cestu nad existující cestou. Aby klávesa Shift neomezovala pohyb nástroje pero, uvolněte klávesu Shift dříve než tlačítko myši.

  • Chcete-li přepínání úplně vypnout, zvolte položky Úpravy > Předvolby > Obecné (Windows) nebo Illustrator > Předvolby > Obecné (Mac OS) a vyberte položku Nepřepínat pero na +/-.

Vyhlazení a zjednodušení cest

Cesty můžete vyhladit a také je zjednodušit odstraněním nadbytečných kotevních bodů.

Vyhlazení cesty

  1. Vyberte objekt.

  2. Vyberte nástroj vyhlazení .

  3. Táhněte nástrojem podél segmentu cesty, který chcete vyhladit.

  4. Pokračujte ve vyhlazování, až je cesta požadovaným způsobem hladká.

    Používání nástroje vyhlazení
    Používání nástroje vyhlazení

    A. Původní cesta B. Tažení podél cesty nástrojem vyhlazení C. Výsledek / Akce 
  5. Chcete-li změnit míru vyhlazení, poklepejte na nástroj vyhlazení a nastavte následující volby:

    Věrnost

    Určuje, jak daleko musíte posunout myš nebo pero, aby Illustrator přidal k cestě nový kotevní bod. Například hodnota věrnosti 2,5 znamená, že pohyby nástroje o méně než 2,5 obrazového bodu se nezaznamenají. Věrnost může být v rozsahu 0,5 až 20 obrazových bodů; čím vyšší hodnota, tím bude cesta hladší a jednodušší.

    Hladkost

    Určuje míru vyhlazení, které Illustrator aplikuje při používání nástroje. Hladkost může být v rozsahu od 0 % do 100 %; čím vyšší hodnota, tím bude cesta hladší.

Poznámka:

Křivku je možné vyhladit a zachovat přitom ostatní křivky netknuté. Vyberte nástroj Kotevní bod, stiskněte klávesu Option/ Alt a klikněte na kterékoli táhlo, abyste spárovali protější táhla a vytvořili hladký bod.

Spárování protilehlých táhel pomocí nástroje Kotevní bod

A. Rohové body mají táhla, která nejsou spárovaná B. Protilehlá táhla jsou spárována, výsledkem je hladká křivka 

Zjednodušení cesty

Zjednodušení cesty odstraní nadbytečné kotevní body bez změny tvaru cesty. Odstraněním nepotřebných kotevních bodů kresbu zjednodušíte, čímž se zmenší velikost souboru a zrychlí se zobrazování a tisk.

  1. Vyberte objekt.

  2. Zvolte Objekt > Cesta > Zjednodušit.

  3. Nastavením volby Přesnost křivky určete, jak těsně má zjednodušená cesta sledovat originální cestu.

    Poznámka:

    Vyberte Náhled, abyste zobrazili náhled zjednodušené cesty a počet bodů v originální a zjednodušené cestě.

  4. Vyberte další volby a klepněte na OK:

    Přesnost křivky

    Zadejte hodnotu mezi 0 % a 100 %, která určuje, jak těsně má zjednodušená cesta sledovat originální cestu. Vyšší hodnota v procentech vytvoří více bodů a těsněji sleduje původní cestu. Všechny existující kotevní body se ignorují, kromě koncových bodů křivky a rohových bodů (pokud nezadáte hodnotu do pole Práh úhlů).

    Práh úhlu

    Zadejte hodnotu mezi 0 a 180°, která určuje hladkost rohů. Pokud je úhel v rohovém bodě menší než práh úhlů, rohový bod se nezmění. Tato volba pomáhá udržet ostré rohy, i když je hodnota Přesnosti křivky nízká.

    Rovné čáry

    Vytvoří přímé čáry mezi původními kotevními body objektu. Rohové body se odstraní, pokud mají větší úhel než je hodnota nastavená v poli Práh úhlů.

    Zobrazit originál

    Ukáže originální cestu za zjednodušenou cestou.

Zprůměrování polohy kotevních bodů

  1. Vyberte dva nebo více kotevních bodů (na stejné cestě nebo na různých cestách).

  2. Zvolte Objekt > Cesta > Sjednotit.

  3. Určete, zda se má poloha zprůměrovat pouze podle vodorovné osy (x), svislé osy (y) nebo podle obou os, a klepněte na OK.

Změna hladkého bodu na rohový bod a naopak

Body na cestě můžete převádět z rohových na hladké a naopak. Pomocí voleb v ovládacím panelu můžete rychle převést více kotevních bodů. Nástrojem pro změnu kotevního bodu lze pro převod vybrat jen jednu stranu bodu, a převedením bodu tak velmi přesně změnit tvar křivky.

Převedení jednoho nebo více kotevních bodů pomocí ovládacího panelu

Chcete-li použít volby v ovládacím panelu pro převod bodů ukotvení, vyberte pouze příslušné body ukotvení, nikoli celý objekt. Pokud vyberete více objektů, jeden z nich musí být vybraný jen částečně. Když jsou vybrané celé objekty, volby v ovládacím panelu se změní na volby, které se vztahují na celý objekt.

  1. Chcete-li převést jeden nebo více rohových bodů na hladké body, vyberte požadované body a pak v ovládacím panelu klepněte na tlačítko Převést vybrané kotevní body na hladké .

  2. Chcete-li jeden nebo více hladkých bodů převést na rohové body, vyberte požadované body a pak v ovládacím panelu klepněte na tlačítko Převést vybrané kotevní body na rohové .

Přesné převedení kotevního bodu s použitím nástroje pro převod kotevního bodu

  1. Vyberte celou cestu, kterou chcete upravit, abyste viděli její kotevní body.

  2. Vyberte nástroj pro změnu kotevního bodu .

  3. Umístěte nástroj pro změnu kotevního bodu nad kotevní bod, který chcete převést, a proveďte jeden z následujících úkonů:

    • Chcete-li změnit rohový bod na hladký bod, vytáhněte směrový bod z rohového bodu.

    změnit kotevní bod, nástroj
    Vytvoření hladkého bodu vytažením směrového bodu z rohového bodu

    • Chcete-li změnit hladký bod na rohový bod bez směrových úseček, klepněte na hladký bod.

    změnit kotevní bod, nástroj
    Vytvoření rohového bodu klepnutím na hladký bod

    • Chcete-li změnit hladký bod na rohový bod s nezávislými směrovými úsečkami, přetáhněte jeden ze směrových bodů.

    změnit kotevní bod, nástroj
    Změna hladkého bodu na rohový bod

    • Chcete-li změnit rohový bod bez směrových úseček na rohový bod s nezávislými směrovými úsečkami, nejdříve vytáhněte směrový bod z rohového bodu (tím z něj uděláte hladký bod se směrovými úsečkami). Uvolněte pouze tlačítko myši (nepouštějte klávesy, které jste případně použili pro přepnutí na nástroj pro změnu kotevního bodu), a pak přetáhněte jeden ze směrových bodů.

Vymazání kresby

Části kresby můžete vymazat nástrojem pro mazání cest, nástrojem guma nebo gumou na peru tabletu Wacom. Nástroj pro mazání cest umožňuje mazat části cesty tažením podél cesty. Tento nástroj je užitečný, když chcete vymazat určitý segment cesty, například jednu stranu trojúhelníka. Nástroj guma a také guma na peru tabletu Wacom umožňuje vymazat jakoukoli oblast kresby bez ohledu na její strukturu. Nástroj guma lze používat na cesty, složené cesty, cesty uvnitř skupin živé malby a ořezové cesty.

Vymazání kresby
Použití nástroje mazání cest k vymazání části cesty (vlevo), použití nástroje guma k vymazání části seskupeného objektu (vpravo)

Vymazání části cesty nástrojem pro mazání cest

  1. Vyberte objekt.

  2. Vyberte nástroj pro mazání cest .

  3. Táhněte nástrojem podél segmentu cesty, který chcete vymazat. Abyste dosáhli dobrých výsledků použijte při tažení jeden plynulý pohyb.

Mazání objektů nástrojem guma

  1. Proveďte jeden z následujících úkonů:

    • Chcete-li vymazat určité objekty, vyberte je nebo je otevřete v izolovaném režimu.

    • Chcete-li vymazat jakýkoli objekt na kreslicí ploše, nechte všechny objekty nevybrané.

    Když není nic vybráno, nástroj guma maže ve všech vrstvách.

  2. Vyberte nástroj guma .

  3. (Volitelně) Poklepejte na nástroj guma a nastavte požadované volby.

  4. Táhněte přes plochu, kterou chcete vymazat. Nástroj můžete regulovat libovolným z následujících způsobů:

    • Chcete-li nástroj guma omezit jen na svislý, vodorovný nebo diagonální směr, držte při přetahování stisknutou klávesu Shift.

    • Chcete-li vytvořit kolem určité oblasti rámeček výběru a vymazat vše uvnitř této oblasti, držte při přetahování stisknutou klávesu Alt (Windows) nebo Option (Mac OS). Chcete-li tvar rámečku výběru omezit na čtverec, držte při přetahování stisknuté klávesami Alt + Shift (Windows) nebo Option + Shift (Mac OS).

Mazání objektů gumou pera tabletu Wacom

Když pero otočíte, automaticky se aktivuje nástroj guma. Když pero otočíte zase zpět, znovu se aktivuje naposledy používaný nástroj.

  • Otočte pero a táhněte přes oblast, kterou chcete vymazat. Zvyšte tlak, chcete-li vymazanou cestu rozšířit. (Nejdříve je nutné zapnout volbu Přítlak pera v dialogu voleb nástroje guma.)

Volby nástroje guma

Po poklepání na nástroj guma v panelu nástrojů můžete změnit jeho volby.

Poznámka:

Průměr můžete také kdykoli změnit průměr stiskem ] (zvětšení) nebo [ (zmenšení).

Úhel

Určuje úhel natočení nástroje. Přetáhněte šipku v náhledu nebo zadejte hodnotu do textového pole Úhel.

Zaoblení

Určuje zaoblení pro nástroj. Přetáhněte černý bod v náhledu od středu nebo ke středu nebo zadejte hodnotu do textového pole Zaoblení. Čím je tato hodnota vyšší, tím je zaoblení větší.

Průměr

Určuje průměr nástroje. Použijte jezdec Průměr nebo zadejte hodnotu do textového pole Průměr.

Rozbalovací seznam vpravo od každé volby umožňuje nastavit proměnlivost tvaru nástroje. Vyberte jednu z následujících voleb:

Pevně

Použije pevně daný úhel, zaoblení nebo průměr.

Náhodně

Použije náhodně se měnící úhel, zaoblení nebo průměr. Zadejte hodnotu do textového pole Variace, abyste určili rozsah, ve kterém se může charakteristika stopy měnit. Když je například hodnota Průměr 15 a hodnota Variace je 5, může být průměr 10 nebo 20 nebo jakákoli hodnota mezi tím.

Přítlak

Mění úhel, zaoblení nebo průměr podle přítlaku hrotu kreslicího pera tabletu. Tato volba je nejužitečnější při použití pro Průměr. Je dostupná pouze v případě, že máte grafický tablet. Zadejte hodnotu do textového pole Variace, abyste určili, o kolik může být parametr stopy větší nebo menší původní hodnota. Například když je hodnota Zaoblení 75 % a hodnota Variace 25 %, bude nejslabší tah 50 % a nejsilnější 100 %. Čím je přítlak slabší, tím bude stopa štětce více zkosená.

Kolečko pera

Průměr stopy se mění na základě manipulace s kolečkem pera.

Náklon

Mění úhel, zaoblení nebo průměr podle sklonu kreslicího pera tabletu. Tato volba je nejužitečnější při použití pro Zaoblení. Je dostupná pouze v případě, že máte grafický tablet, který umí detekovat směr naklonění pera.

Směr

Mění úhel, zaoblení nebo průměr podle přítlaku hrotu kreslicího pera tabletu. Tato volba je nejužitečnější při použití pro ovládání úhlu kaligrafických stop štětců, zejména když používáte stopu jako štětec. Tato volba je dostupná pouze v případě, že máte grafický tablet, který umí detekovat, jak se směr držení pera blíží vertikále.

Natočení

Mění úhel, zaoblení nebo průměr podle natočení hrotu kreslicího pera tabletu. Tato volba je nejužitečnější pro ovládání úhlu kaligrafických stop štětců, zejména když používáte stopu jako štětec. Je dostupná pouze v případě, že máte grafický tablet, který umí detekovat tento typ natočení pera.

Rozdělení cesty

Cesta se dá rozdělit v libovolném kotevním bodu nebo podél libovolného segmentu. Při rozdělování cesty si pamatujte:

  • Pokud chcete rozdělit uzavřenou cestu na dvě otevřené cesty, musíte ji rozdělit na dvou místech. Pokud rozdělíte uzavřenou cestu pouze v jednom místě, výsledkem bude jedna cesta s mezerou.

  • Každá výsledná cesta po rozdělení převezme nastavení původní cesty, například tloušťku tahu a barvu výplně. Zarovnání tahu je automaticky vynulováno na střed.

  1. (Volitelně) Vyberte cestu, aby se zobrazily její aktuální kotevní body.

  2. Proveďte jeden z následujících úkonů:

    • Vyberte nástroj nůžky a klepněte na cestu v místě, kde ji chcete rozdělit. Když cestu rozdělíte uprostřed segmentu, vytvoří se dva nové koncové body ležící na sobě a jeden z nich bude vybraný.
    • Vyberte nástroj Nůž a přetáhněte ukazatel nad objektem. Řezy vytvořené pomocí nože se na objektu jeví jako tahy.
    • Vyberte kotevní bod, ve kterém chcete cestu rozdělit, a pak v ovládacím panelu klepněte na tlačítko Rozříznout cestu ve vybraných kotevních bodech . Když cestu rozdělíte v kotevním bodě, vytvoří se nad původním bodem nový kotevní bod a jeden z těchto kotevních bodů bude vybraný.

    Podrobnosti naleznete v tématu Vyjímání, rozdělování a ořezávání objektů.

  3. Nový kotevní bod nebo segment cesty můžete upravit pomocí nástroje pro přímý výběr.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online