Pomocí panelu Proměnné aplikace Illustrator můžete snadno vytvářet více variant svých kreseb tím, že sloučíte soubor zdroje dat (ve formátu CSV nebo XML) s dokumentem aplikace Illustrator. Například místo ruční úpravy objektů v šabloně využijte funkci slučování pro rychlé a přesné vytvoření stovek variant šablony pro různé výstupní plochy. Obdobně můžete měnit jména účastníků události na jmenovkách nebo obměňovat obrázky na webových reklamních proužcích či pohlednicích bez nutnosti přepracovávat kresbu. Jednoduše vytvořte jeden návrh, a poté rychle vytvářejte varianty pomocí importu jmen či obrázků ze souboru zdroje dat.

variable-panel
Vytvářejte vlastní varianty designu šablon pro různé projekty, například plakáty pro tisk, webové reklamní proužky a odznaky událostí, pomocí panelu Proměnné.

Předpoklady

Všechno, co ke sloučení dat potřebujete, je zdrojový datový soubor a cílový dokument. 

  • Soubor zdroje dat obsahuje informace, které se v jednotlivých opakováních cílového dokumentu mění – například jména, fotografie a adresy příjemců vzorových dopisů. Soubor zdroje dat může být soubor s položkami oddělenými čárkou (.csv) nebo soubor jazyka Extensible Markup Language (.xml).
  • Cílový dokument je dokument aplikace Illustrator obsahující základní kresbu, která se použije jako šablona. Tento dokument může obsahovat zástupné datové pole a položky, které zůstávají stejné v každém opakování sloučeného dokumentu.

Přístup k funkci slučování dat

Funkce slučování dat je přístupná z panelu Proměnné aplikace Illustrator (Okno > Proměnné). V seznamu v panelu je uveden typ a název každé proměnné v dokumentu. Pokud je proměnná navázaná na objekt, zobrazí se ve sloupci Objekty název navázaného objektu, jak se objevuje v panelu Vrstvy. Můžete seřadit řádky kliknutím na položku v pruhu záhlaví: podle názvu proměnné, názvu objektu nebo typu proměnné.

Panel Proměnné
Panel Proměnné

A. Sada dat B. Nabídka panelu C. Přepínání mezi sadami dat D. Název navázaného objektu E. Název proměnné F. Typ proměnné G. Zamknout proměnné H. Změnit objekt na dynamický I. Změnit viditelnost na dynamickou J. Zrušit navázání proměnných K. Vytvoření proměnných L. Odstranění proměnných 

Rychlé kroky pro slučování dat

  1. Vytvořte dokument aplikace Illustrator, který použijete jako šablonu.

  2. Nastavte soubor zdroje dat do formátu CSV nebo XML. Další informace naleznete v části Příprava souboru zdroje dat.

  3. Pomocí panelu Proměnné proveďte import souboru zdroje dat do aplikace Illustrator. Další informace naleznete v části Import souboru zdroje dat.

  4. Navažte proměnnou k objektu v šabloně. Další informace naleznete v části Navazování proměnných k objektům.

  5. Před exportem všech souborů zobrazte náhled dokumentu s každou sadou dat. Další informace naleznete v části Zobrazení náhledu dokumentu s každou sadou dat.

  6. Proveďte export dávky souborů z dat pomocí panelu Akce v aplikaci Illustrator. Další informace naleznete v části Export souborů pomocí panelu Akce.

Příprava souboru zdroje dat

Soubory zdrojů dat musí být uloženy ve formátu s položkami oddělenými čárkou (.csv) nebo ve formátu jazyka Extensible Markup Language (.xml).

Nastavení zdrojových souborů CSV

V souboru s položkami oddělenými čárkou (.csv) jsou záznamy oddělené znaky konce odstavce a pole jsou oddělená čárkami nebo tabulátory. Soubor zdroje dat může také obsahovat text nebo cesty, které odkazují na obrazy na disku. Před importem souboru CSV proveďte následující, aby aplikace Illustrator dokázala identifikovat typ proměnné.

  1. Otevřete tabulku.

  2. Do prvního řádku tabulky zadejte název datového pole. Poté proveďte následující:

    • Na začátek názvu datového pole přidejte symbol „zavináče“ (@), abyste mohli vložit texty nebo cesty, které odkazují na soubory obrazů. Symbol @ je vyžadován pouze na prvním řádku, další řádky by měly obsahovat pouze cesty pro obrazy.
    • Podobně na začátek názvu datového pole přidejte symbol „procenta“ (%) pro grafy a symbol „mřížky“ (#) pro zajištění viditelnosti.

    Poznámka:

    • Názvy datových polí v tabulce by neměly obsahovat mezery. Název datového pole můžete například zadat jako Název_společnosti namísto Název společnosti.
    • Obdobně by ani cesty odkazující na soubory s obrázky a grafy neměly obsahovat mezery. Cesta k souboru s obrázkem by například měla být C:\Photos\BillTucker namísto C:\Photos\Bill Tucker.
    • Všechny soubory s grafy propojené z vašeho souboru zdroje dat by měly být uloženy jako soubory s položkami oddělenými čárkou (.csv).
    • Způsobí-li přidání symbolu @ na začátek pole chybu, zapište apostrof (') před symbol @ (například '@Fotografie), aby byla tato funkce platná. Některé aplikace, například Microsoft Excel, vyhrazují symbol @ pro funkce.

    (Windows) Příklad odkazů na obrázky a grafy v souboru zdroje dat

    Název Věk @Fotografie %Grafy
    Bill Tucker 36 C:\Photos\BillTucker.jpg C:\Photos\BillTucker.csv
    Dat Nguyen 53 C:\MyDocuments\dat.jpg C:\MyDocuments\dat.csv
    Maria Ruiz 26 C:\Photos\Ruiz.jpg C:\Photos\Ruiz.csv

    (macOS) Příklad odkazů na obrázky a grafy v souboru zdroje dat

    Název Věk @Fotografie %Grafy
    Bill Tucker 36 /Users/photos/BillTucker.jpg
    /Users/photos/BillTucker.csv
    Dat Nguyen 53 /Users/family/photos/dat.jpg
    /Users/family/photos/dat.csv
    Maria Ruiz 26 /Users/alpha/photos/Ruiz.jpg /Users/alpha/photos/Ruiz.csv
  3. Zadejte do tabulky údaje.

  4. Proveďte jeden z následujících úkonů:

    • Tabulky vytvořené v nejnovější verzi aplikace Microsoft Excel (verze 2016) uložte v jednom z následujících formátů:
      • CSV (s položkami oddělenými čárkou) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Tabulky vytvořené v aplikaci Apple Numbers uložte ve formátu CSV s kódováním Unicode (UTF-8).

    Poznámka:

    Aplikací Illustrator jsou momentálně podporovány soubory CSV vyexportované ve výše zmíněných formátech. Další formáty souborů CSV, jako je soubor s položkami oddělenými čárkou pro počítače Macintosh (.csv), nejsou pro slučování dat podporovány.

Příprava souboru XML

  1. Definujte v dokumentu proměnnou. Podrobnosti naleznete v části Navazování proměnných k objektům.

  2. Klikněte na tlačítko Zachytit sadu dat () na panelu Proměnné. Nebo zvolte možnost Zachytit sadu dat v nabídce panelu Proměnné.

  3. Po vytvoření požadovaného počtu datových sad vyberte na panelu Proměnné položku Uložit knihovnu proměnných pro uložení datových sad do souboru XML. Zadejte název souboru a jeho umístění a klikněte na tlačítko Uložit.

    save-variable-as-xml-file
    Export proměnných vytvořených v aplikaci Illustrator do souboru XML
  4. Nyní soubor XML upravte v aplikaci pro úpravu textu, jako jsou Notepad++ (Windows) nebo TextWrangler (macOS), pro zahrnutí datových sad do tohoto souboru.

    example-XML-file
    Příklad: Úprava souboru XML pomocí libovolné aplikace pro úpravu textu

    A. Nahrazení cesty k obrázku B. Nahrazení textového řetězce 
  5. Soubor XML naimportujete do aplikace Illustrator výběrem položky Načíst knihovnu proměnných z nabídky panelu Proměnné. Vyberte soubor XML a klikněte na tlačítko Otevřít.

    load-variable-to-data-set
    Import proměnných do aplikace Illustrator

Import souboru zdroje dat

Pokud chcete navázat proměnné k požadovaným datům, importujte na panelu Proměnné zdroj dat. Pro každý dokument můžete vybrat pouze jeden soubor zdroje dat.

  1. Zvolte možnosti Okno > Proměnné.

  2. Na panelu Proměnné klikněte na možnost Import.

    import-data-set_1
    Import souboru zdroje dat pomocí panelu Proměnné
  3. V dialogovém okně Načíst knihovnu proměnných vyberte soubor zdroje dat ve formátu CSV nebo XML a klikněte na tlačítko Otevřít.

    select-a-data-source-file_1
    Výběr souboru zdroje dat ve formátu CSV nebo XML
  4. (Volitelné) Později můžete sadu dat upravit, přejmenovat nebo odstranit tak, že ji nejdříve vyberete v rozbalovací nabídceSada data poté upravíte její volby.

    • Pokud chcete přepínat mezi sadami dat, vyberte požadovanou sadu dat v seznamu Sada dat na panelu Proměnné. Nebo klikněte na tlačítko Předcházející sada dat () či na tlačítko Následující sada dat ().
    • Pokud chcete použít data na kreslicím plátně pro aktuální sadu dat, zvolte možnost Aktualizovat sadu dat v nabídce panelu Proměnné.
    • Pokud chcete přejmenovat sadu dat, upravte text přímo v textovém poli Sada dat. Můžete také poklikat na slova Sada dat (vlevo od textového pole Sada dat, zadat nový název a kliknout na tlačítko OK.
    • Pokud chcete odstranit sadu dat, klikněte na ikonu Odstranit. Můžete také zvolit možnost Odstranit  sadu dat z nabídky panelu Proměnné.

Navazování proměnných k objektům

Proměnné se používají k definování těch prvků šablony, které chcete změnit. Můžete definovat čtyři typy proměnných: proměnnou Viditelnost, proměnnou Textový řetězec, proměnnou Připojený soubor a proměnnou Data grafu. Typ proměnné určuje, které atributy objektu jsou proměnlivé (dynamické). V seznamu v panelu je uveden typ a název každé proměnné v dokumentu. Pokud je proměnná navázaná k objektu, zobrazí se ve sloupci Objekty název navázaného objektu tak, jak se objevuje na panelu Vrstvy.

Typ proměnné Ikona znázorňující typ proměnné
Definice
Proměnné Viditelnost Umožňují zobrazit nebo skrýt kresbu.
Proměnné Textový řetězec Umožňují vyměnit textový řetězec.
Proměnné Připojený soubor Umožňují vyměnit objekt na kreslicím plátně za objekt z jiného souboru.
Proměnné Data grafu Umožňují vyměnit hodnoty v grafu.
Proměnná Bez typu (nenavázaná) Není navázaná k žádnému objektu.

Při definování proměnných v aplikaci Illustrator postupujte následovně:

  1. Vyberte objekt.

  2. Na panelu Proměnné (Okno > Proměnné) vyberte proměnnou, kterou chcete svázat se zvoleným objektem.

  3.  Při svazování objektu s proměnnou proveďte jeden z následujících úkonů:

    • Klikněte na tlačítko Změnit objekt na dynamický ().
    • V nabídce panelu zvolte možnost Změnit objekt na dynamický.

Při vytváření proměnné bez jejího navázání k objektu postupujte následovně:

  1. Klikněte na tlačítko Nová proměnná () na panelu Proměnné nebo zvolte možnost Nová proměnná v nabídce panelu.

  2. Budete-li později chtít navázat objekt k této proměnné, vyberte objekt a proměnnou a klikněte na tlačítko Změnit viditelnost na dynamickou () nebo Změnit objekt na dynamický (). Můžete také zvolit jednu z těchto možností v nabídce panelu.

Práce s proměnnými

Pomocí panelu Proměnné můžete změnit název nebo typ proměnné, zrušit navázání proměnné nebo proměnnou zamknout.

Zrušení navázání proměnné přeruší vazbu mezi proměnnou a objektem. Když jsou proměnné zamknuté, nemůžete vytvářet proměnné, odstraňovat proměnné a upravovat volby proměnných. Můžete ale navazovat a rušit navázání objektů k zamknutým proměnným.

Změna názvu a typu proměnné

  1. Poklikejte na proměnnou v panelu Proměnné. Nebo vyberte proměnnou na panelu Proměnné a zvolte možnost Volby proměnné v nabídce panelu Proměnné.

Zrušení navázání proměnné

  1. Klikněte na tlačítko Zrušit navázání proměnné () na panelu Proměnné nebo zvolte možnost Zrušit navázání proměnné v nabídce panelu Proměnné.

Zamknutí nebo odemknutí všech proměnných v dokumentu

  1. Klikněte na tlačítko Zamknout/Odemknout proměnné nebo na panelu Proměnné.

Odstranění proměnných

Když odstraníte proměnnou, odstraní se z panelu Proměnné. Když odstraníte proměnnou, která je navázaná na objekt, změní se objekt na statický (pokud tento objekt není také navázaný na proměnnou jiného typu).

  1. Vyberte proměnnou, kterou chcete odstranit.

  2. Proveďte jeden z následujících úkonů:

    • Klikněte na tlačítko Odstranit proměnnou () na panelu Proměnné nebo zvolte možnost Odstranit proměnnou v nabídce panelu Proměnné.

    • Chcete-li odstranit proměnnou bez potvrzení, přetáhněte ji na tlačítko Odstranit proměnnou ().

Úpravy dynamických objektů

Data spojená s proměnnou změníte úpravou objektu, ke kterému je proměnná navázaná. Pokud například pracujete s proměnnou Viditelnost, změníte stav viditelnosti objektu v panelu Vrstvy. Úpravy dynamických objektůvám umožňují vytvořit více datových sad pro použití v šabloně.

  1. Vyberte dynamický objekt na kreslicím plátně, nebo proveďte jeden z následujících úkonů, abyste automaticky vybrali dynamický objekt:

    • Klikněte se stisknutou klávesou Alt (Windows) nebo Option (Mac OS) na proměnnou v panelu Proměnné.

    • Vyberte proměnnou na panelu Proměnné a zvolte možnost Vybrat navázaný objekt v nabídce panelu Proměnné.

    • Chcete-li vybrat všechny dynamické objekty, zvolte možnost Vybrat všechny navázané objekty z nabídky panelu Proměnné.

  2. Upravte data spojená s objektem následujícími způsoby:

    • Pro text upravte textový řetězec na kreslicí ploše.

    • Pro připojené soubory nahraďte obraz pomocí panelu Vazby nebo příkazu Soubor > Umístit.

    • Pro grafy upravte data v dialogovém okně Data grafu.

    • Pro všechny objekty s dynamickou viditelností změňte stav viditelnosti objektu v panelu Vrstvy.

Identifikování dynamických objektů pomocí identifikátorů XML

V panelu Proměnné se zobrazují názvy dynamických objektů tak, jak se objevují v panelu Vrstvy. Pokud uložíte předlohu ve formátu SVG pro použití s dalšími produkty Adobe, musí tyto názvy objektů odpovídat konvencím názvů XML. Například názvy XML musí začínat písmenem, podtržítkem nebo dvojtečkou a nesmí obsahovat mezery.

Illustrator automaticky přiřadí platný identifikátor XML ke každému dynamickému objektu, který vytvoříte. Chcete-li zobrazit, upravit nebo exportovat názvy objektů pomocí identifikátorů XML, zvolte položky Úpravy > Předvolby > Jednotky (Windows) nebo Illustrator > Předvolby > Jednotky (Mac OS) a vyberte možnost Identifikátor XML.

Zobrazení náhledu dokumentu s každou sadou dat

Chcete-li vidět, jak bude výsledná grafika vypadat, můžete před exportem všech souborů zobrazit jejich náhledy. Pomocí kláves se šipkami, které se nacházejí na panelu Proměnné vedle textu Sada dat, přejděte na požadovanou sadu dat v dokumentu a zobrazte její náhled.

Export souborů pomocí panelu Akce

Jakmile máte definované proměnné a jednu nebo více sad dat, můžete vytvořit kresbu v dávkovém režimu s využitím hodnot obsažených v sadách dat. Postupujte takto:

  1. Přejděte na panel Akce (Okno > Akce) a zaznamenejte akci pro uložení dokumentu v požadovaném formátu. Podrobné informace naleznete v části Automatizace pomocí akcí.

  2. V nabídce panelu Akce zvolte možnost Dávka a vyberte akci, kterou jste vytvořili v předchozím kroku.

  3. Pro možnost Zdroj vyberte volbu Sady dat, aby se akce spustila pro každou sadu dat v aktuálním souboru.

  4. Prostřednictvím možnosti Cíl určete, co chcete provést se zpracovanými soubory. Můžete ponechat soubory otevřené bez uložení změn (Žádný), uložit a zavřít soubory v jejich současném umístění (Uložit a zavřít) nebo můžete soubory uložit do jiného umístění (Složka).

    V závislosti na vybrané volbě pro možnost Cíl můžete nastavit další možnosti pro ukládání souborů. Další informace naleznete v části Spuštění akce pro dávku souborů.

  5. Klikněte na OK.

Uložení šablony pro slučování dat

Když definujete proměnné v dokumentu aplikace Illustrator, vytváříte tím šablonu pro slučování dat. Předlohu můžete uložit ve formátu SVG pro použití s dalšími produkty Adobe, jako je Adobe Graphics Server. Například vývojář pracující s produktem Adobe Graphics Server může navázat proměnné obsažené v souboru SVG přímo k databázi nebo jinému zdroji dat.

  1. Zvolte možnosti Soubor > Uložit jako, zadejte název souboru, jako formát souboru vyberte SVG a klikněte na tlačítko Uložit.

  2. Klikněte na možnost Více voleb a vyberte volbu Zahrnout data serveru Adobe Graphics Server. Tato volba umožní zahrnout do souboru SVG všechny informace potřebné pro nahrazování proměnných.

  3. Klikněte na OK.

Máte při importu souboru CSV potíže?

Pokud se vám při nahrávání souboru zdroje dat CSV zobrazuje chyba The incoming variable library is invalid (Příchozí knihovna proměnných je neplatná), zkontrolujte, že:

  • Soubor CSV není prázdný.
  • Tabulky vytvořené pomocí nejnovější verze aplikace Microsoft Excel se ukládají ve formátu CSV (s položkami oddělenými čárkou) (*.csv) nebo CSV (MS-DOS) (*.csv) a tabulky vytvořené pomocí aplikace Apple Numbers se ukládají ve formátu CSV s kódováním Unicode (UTF-8). Soubory zdroje dat uložené v jakémkoli jiném formátu, jako je soubor s položkami oddělenými čárkami pro počítače Macintosh (.csv), nejsou pro slučování dat podporovány.
  • Všechny sloupce mají název datového pole. Aplikace Illustrator například zobrazí chybovou zprávu, když sloupec v souboru zdroje dat obsahuje data, ale nemá název datového pole.
  • Soubor zdroje dat nemá mezi vyplněnými sloupci prázdný sloupec. Aplikace Illustrator například zobrazí chybovou zprávu, když sloupce B a D v souboru zdroje dat obsahují data, ale sloupec C je prázdný.
Example-errors-while-importing-CSV-files
Příklad: chyby při nastavování zdrojového souboru CSV pro slučování dat

A. U sloupce chybí název datového pole B. Mezi vyplněnými sloupci je prázdný sloupec 
  • Názvy datových polí v tabulce neobsahují mezery.
  • Cesty odkazující na soubory s obrázky a grafy ve zdrojovém souboru neobsahují mezery.
  • Soubory s grafy propojené z vašeho souboru zdroje dat jsou uloženy jako soubory s položkami oddělenými čárkou (.csv).

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online