Když kresbu ukládáte nebo exportujete, Illustrator zapíše data kresby do souboru. Struktura dat je závislá na formátu souboru, který vyberete.

Existuje pět základních formátů souborů – AI, PDF, EPS, FXG a SVG – do kterých můžete kresbu uložit. Tyto formáty se nazývají nativní formáty, protože umožňují zachovat všechna data aplikace Illustrator, včetně několika kreslicích pláten. (Pro formáty PDF a SVG musíte vybrat volbu Zachovat možnosti úprav v aplikaci Illustrator, aby se zachovala všechna data aplikace Illustrator.) Formáty EPS a FXG umožňují uložení jednotlivých kreslicích pláten jako samostatných souborů. SVG uloží jen aktivní kreslicí plátno, zobrazen je však obsah všech pláten.

Kresbu můžete také exportovat v různých formátech souborů použitelných mimo Illustrator. Tyto formáty se nazývají ne-nativní formáty, protože aplikace Illustrator nemůže obnovit všechna data, když soubor znovu otevřete v aplikaci Illustrator. Z tohoto důvodu doporučujeme ukládat kresbu ve formátu AI dokud práci nedokončíte, a pak kresbu exportovat do požadovaného formátu.

Poznámka:

Při ukládání kresby, která obsahuje připojené soubory EPS, se můžete objevit chybová zpráva, pokud tyto soubory byly uloženy v binárním formátu (například ve výchozím formátu EPS aplikace Photoshop). V takovém případě znovu uložte soubory EPS ve formátu ASCII, vložte připojené soubory do kresby aplikace Illustrator, nebo uložte kresbu ve formátu AI nebo PDF místo formátu EPS.

Podívejte se na video o ukládání pro web Save artwork for the web.

Uložení ve formátu Illustrator

Pokud dokument obsahuje více než jedno kreslicí plátno a chcete dokument uložit do předchozí verze aplikace Illustrator, můžete zvolit uložení jednotlivých pláten jako samostatných souborů nebo zkombinovat obsah všech pláten do jednoho souboru.

  1. Zvolte Soubor > Uložit jako nebo Soubor > Uložit kopii.

  2. Zadejte název souboru a zvolte umístění souboru.

  3. Jako formát souboru zvolte Illustrator (*.AI) a klepněte na Uložit.

  4. V dialogovém okně Volby aplikace Illustrator nastavte požadované volby a klepněte na OK:

    Verze

    Určuje verzi aplikace Illustrator, se kterou chcete mít soubor kompatibilní. Staré formáty nepodporují všechny funkce současné verze aplikace Illustrator. Proto když vyberete jinou verzi než současnou, nebudou dostupné některé volby pro ukládání a některé typy dat se změní. Nezapomeňte si přečíst varování dole v dialogovém okně, abyste věděli, jak se data změní.

    Podmnožiny vložených písem, když je podíl použitých znaků menší než

    Určuje, kdy se má vložit celé písmo (na rozdíl od vložení pouze znaků použitých v dokumentu) na základě počtu znaků písma použitých v dokumentu. Pokud například písmo obsahuje tisíc znaků, ale v dokumentu je použito pouze 10 z nich, můžete rozhodnout, že vložení písma nevyváží zvětšení velikosti souboru.

    Vytvořit soubor kompatibilní s PDF

    Uloží do souboru aplikace Illustrator PDF reprezentaci dokumentu. Vyberte tuto volbu, pokud chcete, aby soubor aplikace Illustrator byl kompatibilní s ostatními aplikacemi Adobe.

    Vložit připojené soubory

    Vloží do kresby soubory, které jsou k ní připojené.

    Vložit ICC profily

    Vytvoří dokument se správou barev.

    Použít kompresi

    Komprimuje data PDF v souboru aplikace Illustrator. Použití komprese zvýší čas potřebný pro uložení dokumentu, proto tuto volbu odznačte, máte-li problémy s rychlostí ukládání (8 až 15 minut).

    Uložit jednotlivá kreslicí plátna jako samostatný soubor

    Uloží každé kreslicí plátno do samostatného souboru. Je také vytvořen samostatný hlavní soubor, který obsahuje všechna kreslicí plátna. Veškerý obsah související s kreslicím plátnem je obsažen v souboru příslušného kreslicího plátna. Pokud je nutné kresbu přesunout, aby se vešla na jedno kreslicí plátno, zobrazí se informační zpráva. Jestliže nevyberete tuto možnost, budou kreslicí plátna sloučena do jednoho dokumentu a převedena na vodicí čáry a oblasti ořezu (v aplikaci Illustrator CS3) objektu. Kreslicí plátno použité pro uložený soubor je vytvořeno na základě velikosti úvodního profilu výchozího dokumentu.

    Volby průhlednosti

    Určuje, co se stane s průhlednými objekty, když zvolíte formát starší verze aplikace Illustrator než 9.0. Vyberte možnost Zachovat cesty, chcete-li vypustit efekty průhlednosti a obnovit průhledné kresby na krytí 100 % a režim prolnutí na Normální. Vyberte možnost Zachovat vzhled a přetisky, chcete-li zachovat přetisky, které se neovlivňují s průhlednými objekty. Přetisky, které se ovlivňují s průhlednými objekty, se sloučí.

    Poznámka: Pokud kresba obsahuje složité překrývající se oblasti a vy potřebujete výstup ve vysokém rozlišení, klikněte na Zrušit a před pokračováním nastavte volby rastrování.

Uložení ve formátu EPS

Prakticky všechny aplikace pro sazbu stránek, zpracování textu a grafiky umějí importovat nebo umístit soubory EPS (Encapsulated PostScript). Formát EPS zachová mnoho grafických prvků, které můžete v aplikaci Adobe Illustrator vytvořit. To znamená, že soubory EPS lze znovu otevřít a upravovat jako soubory aplikace Illustrator. Protože soubory EPS jsou založeny na jazyce PostScript, mohou obsahovat jak vektorové, tak bitmapové grafiky. Obsahuje-li kresba více kreslicích pláten, budou tato plátna zachována při uložení souboru ve formátu EPS.

  1. Pokud vaše kresba obsahuje průhlednost (včetně přetisků) a vyžadujete výstup s vysokým rozlišením, zvolte Okna > Náhled sloučení průhledností, abyste si prohlédli náhled efektů sloučení.

  2. Zvolte Soubor > Uložit jako nebo Soubor > Uložit kopii.

  3. Zadejte název souboru a zvolte umístění souboru.

  4. Jako formát souboru zvolte Illustrator EPS (*.EPS) a klepněte na Uložit.

  5. Chcete-li vytvořit samostatné soubory pro každé kreslicí plátno, klepněte na volbu Použít kreslicí plátna a zapněte přepínač Vše nebo zadejte rozsah. Samostatní soubory jsou uloženy s hlavním souborem EPS, obsahujícím všechna kreslicí plátna. Pokud zrušíte výběr této možnosti, bude vytvořen jeden soubor EPS se zachováním všech kreslicích pláten.

  6. V dialogovém okně Volby EPS nastavte požadované volby a klepněte na OK:

    Verze

    Určuje verzi aplikace Illustrator, se kterou chcete mít soubor kompatibilní. Staré formáty nepodporují všechny funkce současné verze aplikace Illustrator. Proto když vyberete jinou verzi než současnou, nebudou dostupné některé volby pro ukládání a některé typy dat se změní. Nezapomeňte si přečíst varování dole v dialogovém okně, abyste věděli, jak se data změní.

    Formát

    Určují vlastnosti obrazu náhledu, který se uloží do souboru. Obraz náhledu se zobrazuje v aplikacích, které neumějí přímo zobrazovat kresby EPS. Pokud nechcete vytvořit obraz náhledu, zvolte Žádný z nabídky Formát. Jinak vyberte černobílý nebo barevný formát.

    Pokud vyberete formát TIFF (8bitové barvy), vyberte volbu pozadí pro obraz náhledu:

    Průhledná

    Vytvoří průhledné pozadí.

    Neprůhledná

    Vytvoří neprůhledné pozadí. (Vyberte Neprůhledné, když bude dokument EPS používán v aplikacích Microsoft Office.)

    Volby průhlednosti

    Určují, co se stane s průhlednými objekty a přetisky. Dostupné volby se mění v závislosti na verzi formátu, kterou vyberete nahoře v dialogovém okně.

    Pokud zvolíte formát CS, určete, jak se uloží překrývající se barvy, které jsou nastavené na přetiskování, a vyberte přednastavení (sadu voleb) pro sloučení průhledností. Klepněte na Vlastní, chcete-li upravit nastavení sloučení.

    Pokud zvolíte starý formát starší než 8.0, vyberte Zachovat cesty, chcete-li vypustit efekty průhlednosti a obnovit průhledné kresby na 100 % krytí a režim prolnutí na Normální. Vyberte Zachovat vzhled a přetisky, chcete-li zachovat přetisky, které se neovlivňují s průhlednými objekty. Přetisky, které se ovlivňují s průhlednými objekty, se sloučí.

    Vložit písma (pro jiné aplikace)

    Vloží všechna písma, která obsahují příslušná práva od dodavatele písem. Vložení písem zajistí, že se při umístění souboru do jiné aplikace, například do aplikace Adobe InDesign, zobrazí a vytiskne původní písmo. Pokud ale soubor otevřete v aplikaci Illustrator na počítači, kde písmo není nainstalované, písmo bude vytvořeno uměle nebo se nahradí. To je ochrana proti nelegálnímu používání vložených písem.

    Poznámka: Když vyberete Vložit písma, zvětší se velikost uloženého souboru.

    Vložit připojené soubory

    Vloží do kresby soubory, které jsou k ní připojené.

    Vložit miniaturu dokumentu

    Vytvoří miniaturní obraz kresby. Miniatura se v aplikaci Illustrator zobrazí v dialogovém okně Otevřít nebo Umístit.

    Zahrnout CMYK PostScript do souborů RGB

    Umožní, aby se dokumenty s barvami RGB mohly tisknout i z aplikací, které nepodporují výstup RGB. Když se soubor EPS znovu otevře v aplikaci Illustrator, zachovají se barvy RGB.

    Kompatibilní tisk přechodů a mřížek přechodů

    Umožní tisk přechodů a mřížek přechodů i na starších tiskárnách a PostScriptových zařízeních pomocí převodu objektů přechodů do formátu JPEG. Zapnutí této volby může zpomalit tisk na tiskárnách, které nemají problémy s přechody.

    Adobe PostScript®

    Určuje verzi jazyka PostScript, která se použije pro uložení kresby. PostScript Level 2 popisuje barevné i šedotónové vektorové a bitmapové obrazy a podporuje barevné modely RGB, CMYK a CIE pro vektorové i bitmapové grafiky. PostScript Level 3 přidává k Level 2 další funkce, včetně možnosti tisku mřížek přechodů na tiskárny podporující PostScript® 3™. Protože při tisku na zařízení s PostScriptem Level 2 se převádějí mřížky přechodů na bitmapové obrazy, je vhodnější tisknout kresby obsahující mřížky přechodů na tiskárnu s PostScriptem 3.

Uložení ve formátu SVG

SVG je vektorový formát, který poskytuje vysoce kvalitní interaktivní webové grafiky. Existují dvě verze formátu SVG: SVG a komprimovaný SVG (SVGZ). SVGZ může zmenšit velikost souboru o 50 až 80 %, ale soubory SVGZ nemůžete upravovat pomocí textového editoru.

Když uložíte kresbu ve formátu SVG, mřížkové objekty se rastrují. Navíc obrazy, které nemají žádný alfa kanál, se převedou do formátu JPEG. Obrazy s alfa kanálem se převedou do formátu PNG. Jestliže dokument obsahuje více kreslicích pláten a zvolíte uložení do formátu SVG, bude zachováno aktivní kreslicí plátno. Jednotlivá kreslicí plátna nelze uložit jako samostatné soubory SVG.

  1. Pokud kresba obsahuje nějaké efekty SVG, vyberte všechny položky, na které jsou tyto efekty SVG aplikované, a přesuňte efekty na spodní konec panelu Vzhled (těsně nad položku Krytí). Pokud za efektem SVG následuje nějaký jiný efekt, bude výstup SVG obsahovat rastrový objekt. Dále jestliže kresba obsahuje více kreslicích pláten, vyberte plátno, které chcete exportovat.

  2. Zvolte Soubor > Uložit jako nebo Soubor > Uložit kopii.

  3. Zadejte název souboru a zvolte umístění souboru.

  4. Zvolte formát souboru SVG (*.SVG) nebo SVG komprimovaný (*.SVGZ) a klepněte na Uložit.

  5. V dialogovém okně Volby SVG nastavte požadované volby a klepněte na OK:

    Profily SVG

    Určuje definici typu dokumentu (DTD) SVG XML pro exportovaný soubor.

    SVG 1.0 a SVG 1.1

    Vhodné pro soubory SVG, které budou prohlíženy na stolním počítači. SVG 1.1 je plná verze specifikace SVG, jejímiž podmnožinami jsou verze SVG Tiny 1.1, SVG Tiny 1.1 Plus a SVG Basic 1.1.

    SVG Basic 1.1

    Vhodné pro soubory SVG, které budou prohlíženy na středně výkonných přístrojích, jako jsou například kapesní přístroje. Mějte na paměti, že ne všechny kapesní počítače podporují profil SVG Basic. Z toho vyplývá, že výběr této volby nezaručuje, že soubor SVG bude zobrazitelný na všech kapesních počítačích. SVG Basic nepodporuje neobdélníkové oříznutí a některé efekty filtrů SVG.

    SVG Tiny 1.1 a SVG Tiny 1.1+

    Vhodné pro soubory SVG, které budou prohlíženy na malých přístrojích, jako jsou mobilní telefony. Mějte na paměti, že ne všechny mobilní telefony podporují profily SVG Tiny a SVG Tiny Plus. Z toho vyplývá, že výběr některé této volby nezaručuje, že soubor SVG bude zobrazitelný na všech malých zařízeních.

    SVG Tiny 1.2

    Vhodné pro soubory SVG, které budou prohlíženy na celé řadě zařízení, od organizátorů PDA a mobilních telefonů po přenosné počítače a stolní počítače.

    SVG Tiny nepodporuje přechody, průhlednost, oříznutí, masky, symboly, vzorky, podtržený text, přeškrtnutý text, svislý text ani efekty filtrů SVG. SVG Tiny Plus zahrnuje možnost zobrazit přechody a průhlednost, ale nepodporuje oříznutí, masky, symboly ani efekty filtrů SVG.

    Tip: Další informace o profilech SVG najdete ve specifikaci SVG na webových stránkách sdružení World Wide Web Consortium (W3C) (www.w3.org).

    Typ písem

    Určuje, jak se exportují písma:

    Adobe CEF

    Používá hinty písma pro lepší vykreslování malých písem. Tento typ písem podporuje prohlížeč Adobe SVG Viewer, ale nemusí ho podporovat jiné prohlížeče SVG.

    SVG

    Nepoužívá hinty písem. Tento typ písem podporují všechny prohlížeče SVG.

    Převést na obrysy

    Převede písma na vektorové cesty. Tuto volbu použijte pro zachování vizuálního vzhledu písma ve všech prohlížečích SVG.

    Podmnožiny písem

    Určuje, které glyfy (znaky určitého písma) se vloží do exportovaného souboru SVG. Zvolte Žádné, pokud se můžete spolehnout na to, že na systémech konečných uživatelů budou potřebná písma nainstalovaná. Zvolte možnost Pouze použité glyfy, chcete-li vložit pouze glyfy pro texty, které v současné kresbě existují. Ostatní hodnoty (Běžné anglické, Běžné anglické + použité glyfy, Běžné latinkové, Běžné latinkové + Použité glyfy, Všechny glyfy) jsou užitečné v případě, že je textový obsah souboru SVG dynamický (například text generovaný na serveru nebo text interaktivně zadávaný uživatelem).

    Umístění obrazů

    Určuje, zda budou rastrové obrazy vložené přímo do souboru nebo navázané na obrazy JPEG nebo PNG, exportované z originálního souboru aplikace Illustrator. Vložení obrazů zvětší velikost souboru, ale zajistí, že rastrové obrazy budou vždy dostupné.

    Zachovat možnost úprav v aplikaci Illustrator

    Zachová specifická data aplikace Illustrator vložením souboru AI do souboru SVG (výsledkem je větší velikost souboru). Vyberte tuto volbu, pokud máte v úmyslu soubor SVG znovu otevřít a upravit v aplikaci Illustrator. Pokud ale ručně změníte data SVG, tyto změny se neprojeví, když soubor znovu otevřete. Je to proto, že Illustrator načte AI část souboru a ne část SVG.

    Vlastnosti CSS

    Určuje jakým způsobem se atributy stylů uloží do kódu SVG. Výchozí metoda Prezentační atributy aplikuje vlastnosti v nejvyšším bodě v hierarchii, což umožňuje nejvyšší pružnost pro specifické úpravy a transformace. Metoda Atributy stylu vytvoří soubory, které jsou všeobecně čitelné, ale může zvětšit velikost souborů. Zvolte tuto metodu, pokud bude kód SVG používán v transformacích, například v transformacích používajících XSLT (Extensible Stylesheet Language Transformation). Metoda Atributy stylu <Odkazy na entity> vede k rychlejšímu vykreslování a zmenšuje velikost souboru SVG. Metoda Elementy stylu se používá, když sdílíte soubory s dokumenty HTML. Když vyberete Elementy stylu, můžete pak upravit soubor SVG tak, aby se element stylu přesunul do externího souboru seznamu stylů, na který se také odkazuje soubor HTML; volba Elementy stylu má ale také za následek pomalejší vykreslování.

    Počet desetinných míst

    Určuje přesnost vektorových dat v souboru SVG. Můžete nastavit hodnotu 1 až 7 desetinných míst. Vyšší hodnota má za následek větší velikost souboru a vyšší kvalitu obrazu.

    Kódování

    Určuje způsob kódování znaků v souboru SVG. Kódování UTF (Unicode Transformation Format) podporují všechny procesory XML. (UTF-8 je 8bitový formát; UTF-16 je 16bitový formát.) Kódování ISO 8859-1 a UTF-16 nezachovají metadata souboru.

    Optimalizovat pro prohlížeč Adobe SVG Viewer

    Zachová největší úroveň dat aplikace Illustrator a přitom je stále možné soubor SVG upravovat ručně. Vyberte tuto volbu, chcete-li využít rychlejší vykreslování pro funkce, jako jsou efekty filtrů SVG.

    Zahrnout data serveru Adobe Graphics Server

    Vloží do souboru SVG všechny informace potřebné pro nahrazování proměnných.

    Včetně dat rozdělení na řezy

    Vloží informace o umístění řezů a nastavení optimalizace.

    Zahrnout XMP

    Vloží do souboru SVG metadata XMP. Chcete-li metadata zadat, zvolte Soubor > Informace nebo použijte prohlížeč Bridge.

    Vytvořit méně elementů <tspan>

    Dovoluje aplikaci Illustrator při exportu ignorovat nastavení automatického vyrovnání párů, což vede k tomu, že v souboru je méně elementů <tspan>. Vyberte tuto volbu, chcete-li vytvořit soubor SVG, který je snadněji upravitelný a kompaktnější. Odznačte tuto volbu, pokud je důležité zachování vzhledu automatického vyrovnání párů.

    Použít element <textPath> pro text na cestě

    Exportuje text na cestě jako element <textPath>. Uvědomte si ale, že text se může v prohlížeči SVG Viewer zobrazit jinak než v aplikaci Illustrator, protože tento režim exportu není vždy schopen zachovat vizuální shodu. Zejména přesahující text bude v prohlížeči SVG viditelný.

    Zobrazit kód SVG

    Zobrazí kód souboru SVG v okně prohlížeče.

    Webový náhled

    Zobrazí soubor SVG v okně prohlížeče.

    Device Central

    Otevře soubor v aplikaci Device Central pro zobrazení náhledu na konkrétním mobilním telefonu nebo jiném zařízení.

Uložení kresby pro Microsoft Office

Příkaz Uložit pro Microsoft Office umožňuje vytvořit soubor PNG, který můžete použít v aplikacích Microsoft Office.

  1. Zvolte Soubor > Uložit pro Microsoft Office.

  2. V dialogovém okně Uložit pro Office vyberte umístění souboru, zadejte název souboru a klepněte na tlačítko Uložit.

    Poznámka:

    Pokud chcete upravit nastavení PNG, například rozlišení, průhlednost nebo barvu pozadí, použijte příkaz Export místo příkazu Uložit pro Microsoft Office. Kresbu můžete uložit do formátu PNG také příkazem Uložit pro web a zařízení.

Změna vektorových grafik na bitmapové obrazy

O rastrování

Rastrování je proces změny vektorové grafiky na bitmapový obraz. Při rastrování převádí Illustrator cesty grafiky na obrazové body. Volby rastrování, které nastavíte, určí velikost a další charakteristiky výsledných obrazových bodů.

Jednotlivé vektorové objekty můžete rastrovat příkazem Objekt > Rastrovat nebo efektem Rastrovat. Můžete také rastrovat celý dokument tím, že ho exportujete do bitmapového formátu jako je JPEG, GIF nebo TIFF.

Rastrování vektorového objektu

  1. Vyberte jeden nebo více objektů.

  2. Proveďte jeden z následujících úkonů:

    • Chcete-li objekty rastrovat trvale, zvolte Objekt > Rastrovat.

    • Chcete-li vytvořit rastrovaný vzhled beze změny základní struktury objektu, zvolte Efekt > Rastrovat.

  3. Nastavte volby rastrování a klikněte na tlačítko OK.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online