Přečtěte si, jak vytvářet text a jak s ním pracovat v aplikaci Adobe Illustrator...

Zadávání textu v bodě

Bodový text je vodorovný nebo svislý řádek textu, který začíná tam, kde klepnete, a rozšiřuje se, když zadáváte znaky. Každý řádek textu je samostatný – při úpravách textu se délka řádku prodlužuje nebo zkracuje, ale text se nezalomí na další řádek. Zadávání textu tímto způsobem je užitečné, když do kresby přidáváte jen několik slov.

  1. Vyberte textový nástroj nebo nástroj svislý text .

    Ukazatel se změní na I v tečkovaném rámečku. Malá vodorovná linka v dolní části I označuje polohu účaří písma, na kterém text spočívá.

  2. (Volitelně) Nastavte volby formátování textu v ovládacím panelu, v panelu Znaky nebo v panelu Odstavec.

  3. Klepněte v místě, kde chcete, aby řádek textu začínal.

    Poznámka:

    Neklepněte na existující objekt, protože by se tím textový objekt převedl na text v ploše nebo text na cestě. Pokud je jiný objekt v místě, kde chcete zadat text, zamkněte nebo skryjte tento objekt.

  4. Zadejte text. Stiskněte Enter nebo Return, chcete-li začít nový řádek textu ve stejném textovém objektu.

    Poznámka:

    Od verze CC 2017 aplikace Illustrator při použití nástroje text nebo nástroje svislý text standardně vkládá zástupný text. Další podrobnosti najdete v článku Vyplnění textových objektů zástupným textem.

  5. Až skončíte se zadáváním textu, klepněte na nástroj pro výběr , aby se vybral celý textový objekt. Nebo klepněte na text se stisknutou klávesou Ctrl (Windows) nebo Command (Mac OS).

Poznámka:

Další informace o práci s textem v aplikaci Illustrator obsahuje toto video.

Zadávání textu v ploše

Text v ploše (nazývaný také odstavcový text) používá hranice objektu k řízení natékání znaků, buď vodorovně nebo svisle. Když text dosáhne hranice, automaticky se zalomí tak, aby se vešel dovnitř ohraničené plochy. Tento způsob zadávání textu je užitečný, když chcete vytvořit jeden nebo více odstavců, například v letáku.

  1. Určete ohraničovací plochu:
    • Vyberte textový nástroj nebo nástroj svislý text a šikmým tažením vymezte obdélníkovou ohraničovací plochu.

    • Nakreslete objekt, který chcete použít jako ohraničovací plochu. (Nezáleží na tom, zda má objekt atributy tahu nebo výplně, protože Illustrator je automaticky odstraní.) Pak vyberte textový nástroj , nástroj svislý text , nástroj text v ploše nebo nástroj svislý text v ploše a klepněte kdekoli v cestě objektu.

    Vytvoření textového pole
    Vytvoření oblasti pro text tažením (nahoře) a převedení existujícího tvaru na textovou plochu (dole)

    Poznámka:

    Pokud je objekt otevřená cesta, musíte k určení ohraničovací plochy použít nástroj text v ploše. Illustrator nakreslí imaginární čáru mezi koncovými body cesty, aby definoval ohraničení.

  2. (Volitelně) Nastavte volby formátování textu v ovládacím panelu, v panelu Znaky nebo v panelu Odstavec.
  3. Zadejte text. Stiskněte Enter nebo Return, chcete-li začít nový odstavec.
  4. Až skončíte se zadáváním textu, klepněte na nástroj pro výběr , aby se vybral celý textový objekt. Nebo klepněte na text se stisknutou klávesou Ctrl (Windows) nebo Command (Mac OS).

    Pokud zadáte více textu, než se vejde dovnitř plochy, objeví se u dolního okraje ohraničovací oblasti čtvereček obsahující symbol plus (+).

    Přesahující text
    Příklad přesahujícího textu

    Chcete-li zobrazit přesahující text, můžete změnit velikost textové plochy nebo protáhnout cestu. Můžete také zřetězit text do jiného objektu.

    Poznámka:

    Další informace o práci s textem v aplikaci Illustrator obsahuje toto video.

Import textu do cesty nebo tvaru

Nově v aplikaci Illustrator CC, vydání 2017

Vložte text z podporovaného souboru přímo do objektu, například do tvaru. Text můžete umístit ze souborů ve formátu .txt nebo .rtf nebo ze souborů textových editorů. Můžete například umístit text ze souboru .rtf do mnohoúhelníkového tvaru.

  1. Pomocí libovolného nástroje pro kreslení, například nástroje Obdélník, nástroje Shaper nebo nástroje Pero vytvořte cestu nebo tvar. Do tohoto tvaru umístěte textový soubor.

  2. Zvolte možnost Soubor > Umístit a vyberte textový soubor, který chcete umístit.

  3. Klikněte na položku Umístit.

  4. Po načtení textového souboru do umísťovacího kurzoru klikněte na cestu tvaru.

    Text se umístí dovnitř tvaru. Na text nyní můžete použít požadované styly a efekty.

Umístěte text z textového souboru do mnohoúhelníkové cesty nebo tvaru.

Vyplnění textových objektů zástupným textem

Nově v aplikaci Illustrator CC, vydání 2017

Vyplněním textových objektů zástupným textem můžete zdůraznit vizualizaci svého návrhu. Aplikace Illustrator ve výchozím nastavení automaticky vyplní nové objekty vytvořené pomocí textového nástroje zástupným textem. Zástupný text použije písmo a velikost aplikované na předcházející textový objekt.

Ukázky textových objektů se zástupným textem vytvořených pomocí textových nástrojů

A. Textový nástroj B. Nástroj text na cestě C. Nástroj svislý text v ploše 

Vyplnění zástupným textem pouze vybraných textových objektů

Výchozí chování aplikace Illustrator založené na vyplnění všech nových textových objektů zástupným textem můžete zakázat. Zrušte výběr volby Předvolby > Text > Vyplnit nové textové objekty zástupným textem.

Zakázání výchozího chování založeného na vyplnění všech nových textových objektů zástupným textem

I po zakázání výchozího chování můžete zástupným textem vyplnit vybrané textové objekty. Postupujte takto:

  1. Pomocí nástroje Text v bodu nebo Text v ploše vytvořte textový objekt. Případně můžete na kreslicím plátnu vybrat existující textový objekt.

  2. Proveďte jeden z následujících úkonů:

    • Vyberte možnost Text > Vyplnit zástupným textem.
    • Kliknutím pravým tlačítkem na textový rámeček otevřete místní nabídku. Vyberte možnost Vyplnit zástupným textem.

    Aplikace Illustrator vyplní textový objekt zástupným textem.

Správa textové oblasti

Změna velikosti textové oblasti

Velikost textu lze změnit několika způsoby, v závislosti na tom, zda v cestě vytváříte bodový text, text v ploše nebo text.

Množství textu je neomezené, přičemž text lze psát s použitím bodového textu. Proto není v tomto případě nutná změna velikosti textového rámečku.

Při používání nástroje text v ploše přetáhněte objekt a typ dovnitř vybrané oblasti. Pokud změníte velikost objektu s použitím nástroje pro přímý výběr, změní se v tomto případě i velikost textu.

Pokud podél cesty zadáte text, který se do vybrané cesty nevejde, lze text mezi objekty zřetězit (více informací najdete v části Zřetězení textu mezi objekty. Budete-li měnit velikost objektu s použitím nástroje pro přímý výběr, i v takovém případě se velikost textu změní.

Poznámka:

Zkontrolujte, zda je ohraničovací rámeček nastaveno na Ohraničovací rámeček. Pokud není ohraničovací rámeček zobrazen, klepněte na volby Zobrazit > Ohraničovací rámeček.

  1. Chcete-li změnit velikost, proveďte jeden z následujících úkonů:
    • Vyberte textový objekt pomocí nástroje pro výběr nebo panelu Vrstvy a přetáhněte táhlo na ohraničovacím rámečku.

    Změna velikosti textové oblasti nástrojem pro výběr
    Změna velikosti textové oblasti nástrojem pro výběr

    • Vyberte okraj nebo roh textové cesty nástrojem pro přímý výběr . Pak tažením upravte tvar cesty.

      Tip: Úpravy textové cesty nástrojem pro přímý výběr jsou snadnější, když jste v zobrazení Obrysy.

    Změna velikosti textové oblasti nástrojem pro přímý výběr
    Změna velikosti textové oblasti nástrojem pro přímý výběr

    • Vyberte textový objekt pomocí nástroje pro výběr nebo panelu Vrstvy a zvolte Text > Volby textu v ploše. Zadejte hodnoty v polích Šířka a Výška a klepněte na OK. Pokud textová oblast není obdélníková, určují tyto hodnoty rozměry ohraničovacího rámečku objektu.

Změna okrajů kolem textové plochy

Při práci s objektem textu v ploše můžete nastavit okraje mezi textem a ohraničovací cestou. Tento okraj se nazývá odstup vsazení.

  1. Vyberte objekt textu v ploše.
  2. Zvolte Text > Volby textu v ploše.
  3. Určete hodnotu pro Odstup vsazení a klepněte na OK.
    Odstup vsazení textu
    Text bez odstupu vsazení (vlevo) a text s odstupem vsazení (vpravo)

Posunutí prvního účaří v textové oblasti nahoru nebo dolů

Při práci s objektem textu v ploše můžete nastavit zarovnání prvního řádku textu vzhledem k hornímu okraji objektu. Toto zarovnání se nazývá odsazení prvního účaří. Můžete například vytvořit text vyčnívající nad horní okraj objektu nebo posunutý o určitou vzdálenost pod horní okraj objektu.

Účaří textu v textové oblasti
Text s prvním účařím nastaveným na Výška verzálek (vlevo) a text s prvním účařím nastaveným na Proklad (vpravo)

  1. Vyberte objekt textu v ploše.
  2. Zvolte Text > Volby textu v ploše.
  3. Pro První účaří zvolte jednu z následujících voleb:

    Horní dotažnice

    Výška znaku „d“ bude pod horním okrajem textového objektu.

    Výška verzálek

    Horní okraje velkých písmen se budou dotýkat horního okraje textového objektu.

    Proklad

    Jako vzdálenost mezi účařím prvního řádku textu a horním okrajem textového objektu se použije hodnota prokladu textu.

    Výška x

    Výška znaku „x“ bude pod horním okrajem textového objektu.

    Výška em rámečku

    Horní okraj em rámečku v asijských písmech se bude dotýkat horního okraje textového objektu. Tato volba je dostupná bez ohledu na předvolbu Zobrazit asijské volby.

    Pevně

    Vzdálenost mezi účařím prvního řádku textu a horním okrajem textového objektu se určí v textovém poli Minimální.

    Starší verze

    Používá první výchozí základní čáru použitou v programu Adobe Illustrator 10 nebo ve dřívější verzi.

  4. Do pole Minimální zadejte hodnotu pro odsazení účaří.

Vytváření řádků a sloupců textu

  1. Vyberte objekt textu v ploše.
  2. Zvolte Text > Volby textu v ploše.
  3. V sekcích Řádky a Sloupce v dialogovém okně nastavte následující volby:

    Počet

    Určuje počet řádků a sloupců, které má objekt obsahovat.

    Rozsah

    Určuje výšku jednotlivých řádků a šířku jednotlivých sloupců.

    Pevně

    Určuje, co se stane s rozsahem řádků a sloupců, pokud změníte velikost textové oblasti. Když je tato volba vybraná, může změna velikosti oblasti změnit počet řádků a sloupců, ale ne jejich šířku. Nechte tuto volbu odznačenou, pokud chcete, aby se při změně velikosti textové oblasti měnily šířky řádků a sloupců.

    Volby pro změnu velikosti řádků a sloupců
    Volby pro změnu velikosti řádků a sloupců

    Mezera

    Určuje vzdálenost mezi řádky nebo sloupci.

  4. V sekci Volby dialogového okna vyberte volbu Natékání textu, která určí způsob natékání textu mezi řádky a sloupci: Po řádcích nebo Po sloupcích .
  5. Klepněte na OK.

Přizpůsobení nadpisu přes celou šířku textové oblasti

  1. Vyberte textový nástroj a klepněte v odstavci, který chcete přizpůsobit přes textovou oblast.
  2. Zvolte Text > Přizpůsobit titulek.

    Poznámka:

    Pokud změníte formátování textu, musíte příkaz Přizpůsobit titulek aplikovat znovu.

Zřetězení textu mezi objekty

Chcete-li text zřetězit (navázat) z jednoho objektu do dalšího, musíte tyto objekty propojit. Propojené textové objekty mohou mít libovolný tvar, ale text musí být zadaný v ploše nebo podél cesty (ne v bodě).

Každý objekt textu v ploše obsahuje vstupní bod a výstupní bod, které umožňují propojení s dalšími objekty a vytvoření propojené kopie textového objektu. Prázdný vstupní a výstupní bod označuje, že je viditelný celý text, a že objekt není propojený. Šipka ve vstupním nebo výstupním bodu označuje, že objekt je propojený s jiným objektem. Červený znak plus ve výstupním bodu označuje, že objekt obsahuje další text. Tento zbývající neviditelný text se nazývá přesahující text.

Vstupní a výstupní body propojených textových objektů
Vstupní a výstupní body propojených textových objektů

Zřetězení můžete přerušit a nechat text natéci buď do prvního nebo do následujícího objektu, nebo můžete odstranit všechna zřetězení a text nechat na místě.

Poznámka:

Při práci se zřetězeným textem může být užitečné, je-li toto zřetězení viditelné. Chcete-li zobrazit zřetězení, zvolte Zobrazení > Zobrazovat zřetězení textu, a pak vyberte propojený objekt.

Zřetězení textu

  1. Pomocí nástroje pro výběr vyberte objekt textu v ploše.
  2. Klepněte na vstupní nebo výstupní bod vybraného textového objektu. Ukazatel se změní na ikonu načteného textu .
  3. Proveďte jeden z následujících úkonů:
    • Chcete-li vytvořit spojení s existujícím objektem, umístěte ukazatel na cestu objektu. Ukazatel se změní na . Klepněte na cestu, abyste objekty propojili.

    • Chcete-li vytvořit propojení s novým objektem, klepněte nebo přetáhněte prázdnou část kreslicí plochy. Klepnutím se vytvoří objekt stejné velikosti a tvaru jako původní; tažení umožňuje vytvořit pravoúhlý objekt libovolné velikosti.

      Jiná metoda, jak zřetězit text mezi objekty, je vybrat objekt textu v ploše, vybrat objekt (nebo objekty), které chcete propojit, a pak zvolit Text > Zřetězený text > Vytvořit.

Odstranění nebo přerušení zřetězení

  1. Vyberte objekt zřetězeného textu.
  2. Proveďte libovolný z následujících úkonů:
    • Chcete-li přerušit zřetězení mezi dvěma objekty, poklepejte na vstupní nebo výstupní bod na libovolném konci zřetězení. Text nateče do prvního objektu.

    • Chcete-li uvolnit objekt ze zřetězení textu, zvolte Text > Zřetězený text > Uvolnit výběr. Text nateče do následujícího objektu.

    • Pokud chcete odstranit všechna zřetězení, zvolte Text > Zřetězený text > Odstranit zřetězení. Text zůstane na svém místě.

Obtékání textu kolem objektů

Textová plocha může obtékat kolem libovolného objektu, včetně textových objektů, importovaných obrazů a objektů, které nakreslíte v aplikaci Illustrator. Pokud obtékaný objekt je vložený bitmapový obraz, Illustrator obtéká text kolem neprůhledných nebo částečně neprůhledných obrazových bodů a ignoruje plně průhledné obrazové body.

Obtékání je určeno pořadím překrývání objektů, které si můžete prohlédnout v panelu Vrstvy klepnutím na trojúhelník vedle názvu vrstvy. Pokud chcete, aby text obtékal kolem určitého objektu, musí být obtékaný objekt ve stejné vrstvě jako text a musí být v hierarchii vrstvy umístěný přímo nad textem. Chcete-li změnit hierarchii, můžete v panelu Vrstvy přetáhnout obsah nahoru nebo dolů.

Text obtékající kolem objektů
Text obtékající kolem objektů

A. Obtékané objekty B. Obtékající text 

Obtékání textu

  1. Zkontrolujte, že jsou pro text, který chcete obtékat, splněné následující podmínky:
    • Je to v ploše (zapsaný do textového pole).

    • Je ve stejné vrstvě jako obtékaný objekt.

    • Je v hierarchii vrstvy umístěný přímo pod obtékaným objektem.

    Poznámka:

    Pokud vrstva obsahuje více textových objektů, přesuňte všechny textové objekty, které nemají obtékat kolem obtékaného objektu, buď do jiné vrstvy nebo nad obtékaný objekt.

  2. Vyberte objekt nebo objekty, kolem kterých má text obtékat.
  3. Zvolte Objekt > Obtékání textu > Vytvořit.

Nastavení voleb obtékání

Volby obtékání je možné nastavit před vytvořením obtékání textu nebo až později.

  1. Vyberte obtékaný objekt.
  2. Zvolte Objekt > Obtékání textu > Volby obtékání textu a určete následující volby:

    Odsazení

    Určuje velikost mezery mezi textem a obtékaným objektem. Můžete zadat kladnou nebo zápornou hodnotu.

    Invertovat obtékání

    Text bude obtékat kolem opačné strany objektu.

Zrušení obtékání textu kolem objektu

  1. Vyberte obtékaný objekt.
  2. Zvolte Objekt > Obtékání textu > Uvolnit.

Zarovnání textu k objektu

Chcete-li zarovnat text podle ohraničovacího rámečku skutečných glyfů namísto podle metrik písem, postupujte takto:

  1. Živý efekt Obrysy objektu se dá na textový objekt aplikovat příkazem Efekt > Cesta > Obrysy objektu.

  2. Výběrem položky Použít hranice náhledu v nabídce panelu Zarovnání (rozbalovací nabídce) zapnete používání těchto hranic v panelu.

Po aplikaci těchto nastavení získáte stejné zarovnání jako u textu převedeného na obrysy, text ale zůstane „živý“.

Odstranění prázdných textových objektů z kresby

Když odstraníte nepoužité textové objekty, bude se vaše kresba snadněji tisknout a zmenší se velikost souboru. Prázdné textové objekty můžete vytvořit, když například v oblasti kresby nechtěně klepnete textovým nástrojem a pak zvolíte jiný nástroj.

  1. Zvolte Objekt > Cesta > Vyčistit.
  2. Vyberte Prázdné textové cesty a klepněte na OK.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online