Poznámka:

Tento článek se vztahuje k aplikaci Adobe Illustrator CS5 a starším. Od aplikace Adobe Illustrator CS6 poskytuje aplikace Illustrator nové rozhraní pro vektorizaci obrazu. Při vektorizaci obrazu můžete nově vybrat z celé řady přednastavení nebo použít intuitivní a jednoduché ovládací prvky pro získání prémiových výsledků. Další podrobnosti naleznete v tématu Vektorizace obrazu.

Chcete-li novou kresbu založit na existujícím obraze, můžete ho vektorizovat. Můžete například vytvořit grafiku podle náčrtku tužkou na papíře nebo podle rastrového obrazu, uloženého v jiném grafickém programu. Stačí takovou kresbu dostat do aplikace Illustrator a převést ji na vektorovou grafiku (vektorizovat ji).

Nejjednodušší způsob, jak kresbu vektorizovat, je otevřít nebo umístit soubor do aplikace Illustrator a automaticky kresbu obkreslit příkazem Živá vektorizace. Můžete nastavit úroveň detailů a způsob vyplnění výsledků vektorizace. Když jste s výsledky spokojeni, můžete vektorizaci převést na vektorové cesty nebo na objekt živé malby.

Před a po obkreslení bitmapového obrazu příkazem Živá vektorizace
Před a po obkreslení bitmapového obrazu příkazem Živá vektorizace

Vektorizace kresby

  1. Otevřete nebo umístěte soubor, který chcete použít jako zdrojový obraz pro vektorizaci.

  2. S vybraným zdrojovým obrazem proveďte jeden z následujících úkonů:

    • Chcete-li vektorizovat obraz pomocí přednastavení vektorizace, klikněte na položku Přednastavení vektorizace a poté na Volby ovládacím panelu a vyberte přednastavení.

    • Chcete-li obraz vektorizovat pomocí výchozích voleb vektorizace, klikněte v ovládacím panelu na položku Živá vektorizace nebo zvolte možnost Objekt > Živá vektorizace > Vytvořit.

    • Chcete-li před vektorizací obrazu nastavit volby vektorizace, klikněte na položku Přednastavení vektorizace a Volby ovládacím panelu a vyberte položku Volby vektorizace. Nebo zvolte Objekt > Živá vektorizace > Volby vektorizace. Nastavte volby vektorizace, a pak klikněte na Vektorizovat.

  3. (Volitelně) Upravte výsledky vektorizace.

  4. (Volitelně) Převeďte vektorizaci na cesty nebo na objekt živé malby.

Volby vektorizace

Přednastavení

Určuje přednastavení vektorizace.

Režim

Určuje barevný režim pro výsledek vektorizace.

Práh

Určuje hodnotu pro generování černého a bílého výsledku vektorizace z původního obrazu. Všechny obrazové body světlejší než hodnota Práh se převedou na bílé; všechny obrazové body tmavší než hodnota Práh se převedou na černé. (Tato volba je dostupná pouze v případě, že je režim nastavený na Černá a bílá.)

Paleta

Určuje paletu pro generování barevné nebo šedotónové vektorizace z původního obrazu. (Tato volba je dostupná pouze v případě, že je režim nastavený na Barvy nebo Stupně šedi.)

Chcete-li, aby barvy ve vektorizaci určila aplikace Illustrator, vyberte možnost Automaticky. Chcete-li pro vektorizaci použít vlastní paletu, vyberte název knihovny vzorníku. (Knihovna vzorníku musí být otevřená, aby se zobrazila v nabídce Paleta.)

Max. barev

Určuje maximální počet barev, které se použijí v barevném nebo šedotónovém výsledku vektorizace. (Tato volba je dostupná pouze v případě, že je režim nastavený na Barvy nebo Stupně šedi a paleta je nastavená na Automaticky.)

Výstup do vzorníku

Vytvoří v panelu Vzorník nové políčko pro každou barvu ve výsledku vektorizace.

Rozostření

Rozostří původní obraz před generováním výsledku vektorizace. Vyberte tuto volbu, chcete-li potlačit malé artefakty a vyhladit zubaté okraje ve výsledku vektorizace.

Převzorkovat

Převzorkuje původní obraz na určené rozlišení před generováním výsledku vektorizace. Tato volba je užitečná pro urychlení procesu vektorizace pro velké obrazy, ale může zhoršit výsledky.

Poznámka: Rozlišení převzorkování se neuloží, když vytvoříte přednastavení.

Výplně

Vytvoří ve výsledku vektorizace vyplněné oblasti.

Tahy

Vytvoří ve výsledku vektorizace vytažené cesty.

Max. tloušťka tahu

Určuje maximální šířku prvků v originálním obraze, které se mohou vytáhnout. Prvky větší než maximální šířka se do výsledku vektorizace převedou jako ohraničené oblasti.

Min. délka tahu

Určuje minimální délku prvků v originálním obraze, které se mohou vytáhnout. Prvky menší než minimální délka se z výsledku vektorizace vypustí.

Přizpůsobení cest

Určuje vzdálenost mezi vektorizovaným tvarem a původní rastrovým tvarem. S nižší hodnotou se vytvoří věrnější cesty, vyšší hodnoty vytvoří volněji sledované cesty.

Minimální plocha

Určuje nejmenší prvek v původním obraze, který se bude vektorizovat. Například hodnota 4 určuje, že prvky menší než 2 obrazové body na šířku a 2 na výšku se z výsledku vektorizace vypustí.

Úhel rohů

Určuje ostrost ohybu v původním obraze, který se považuje za rohový kotevní bod ve výsledku vektorizace. Další informace o rozdílu mezi rohovým kotevním bodem a hladkým kotevním bodem viz O cestách.

Rastrový

Určuje, jak se zobrazí rastrová součást vektorizovaného objektu. Toto nastavení zobrazení se neukládá jako součást přednastavení vektorizace.

Vektorový

Určuje, jak se zobrazí výsledek vektorizace. Toto nastavení zobrazení se neukládá jako součást přednastavení vektorizace.

Poznámka:

V dialogovém okně Volby vektorizace vyberte položku Náhled, aby se zobrazil náhled výsledku použití aktuálních nastavení. Chcete-li nastavit výchozí volby vektorizace, zrušte výběr všech objektů před otevřením dialogového okna Volby vektorizace. Až skončíte s nastavováním voleb, klepněte na Nastavit výchozí.

Video o používání živé vektorizace najdete na www.adobe.com/go/vid0043_cz. Výukovou lekci o nastavení voleb živé vektorizace pro dosažení co nejlepších výsledků najdete na www.adobe.com/go/learn_ai_tutorials_livetrace_cz.

Změna zobrazení vektorizovaného objektu

Vektorizovaný objekt se skládá ze dvou součástí: z původního zdrojového obrazu a z výsledku vektorizace (což je vektorová kresba). Standardně je viditelný pouze výsledek vektorizace. Můžete ale změnit zobrazení jak původního obrazu tak i výsledku vektorizace, aby vyhovovalo vašim požadavkům.

  1. Vyberte vektorizovaný objekt.

    Poznámka:

    Standardně jsou všechny vektorizované objekty v panelu Vrstvy pojmenovány „Vektorizace“.

  2. Proveďte libovolný z následujících úkonů:

    • Chcete-li změnit zobrazení výsledku vektorizace, klikněte na tlačítko Zobrazit vektorové ovládacím panelu nebo vyberte položku Objekt > Živá vektorizace a vyberte možnost zobrazení: Žádný výsledek vektorizace, Výsledek vektorizace, Obrysy nebo Obrysy s vektorizací.

    • Chcete-li změnit zobrazení zdrojového obrazu, klikněte na tlačítko Zobrazit rastrové ovládacím panelu nebo vyberte položku Objekt > Živá vektorizace a vyberte možnost zobrazení:Žádný obraz, Původní obraz, Upravený obraz (volba, která zobrazí obraz s úpravami, které byly aplikovány během vektorizace) nebo Průhledný obraz.

      Poznámka: Abyste viděli zdrojový obraz, musíte nejdříve změnit volbu Zobrazit vektorovéna Žádný výsledek vektorizace nebo Obrysy.

Nastavení výsledků vektorizace objektu

Jakmile vytvoříte vektorizovaný objekt, můžete kdykoliv upravit výsledky vektorizace.

  1. Vyberte vektorizovaný objekt.

  2. Proveďte libovolný z následujících úkonů:

    • Nastavte základní volby v ovládacím panelu.

    • Klepnutím na tlačítko Dialog voleb vektorizace  v ovládacím panelu zobrazte všechny volby vektorizace. Nebo zvolte Objekt > Živá vektorizace > Volby vektorizace. Nastavte volby a klikněte na Vektorizovat.

    Poznámka:

    Chcete-li rychle změnit výsledky vektorizace, použijte předvolby vektorizace.

Nastavení barev použitých k vektorizaci

  1. Vytvořte knihovnu vzorníku, která obsahuje barvy, které chcete použít při vektorizaci.

  2. Zajistěte, aby tato knihovna vzorníku byla otevřená, a klikněte na tlačítko Dialog voleb vektorizace ovládacím panelu. Nebo zvolte Objekt > Živá vektorizace > Volby vektorizace.

  3. Vyberte název knihovny vzorníku z nabídky Paleta a klikněte na Vektorizovat.

Použití přednastavení vektorizace

Přednastavení vektorizace poskytují předem nastavené volby vektorizace pro určité typy kreseb. Pokud například vektorizujete obraz, který chcete použít jako technický výkres, zvolte přednastavení Technický výkres. Všechny volby vektorizace se změní tak, aby byly optimální pro vektorizaci technického výkresu: barvy se nastaví na černou a bílou, rozostření se nastaví na 0 ob, tloušťka tahu se omezí na 3 ob a tak dále.

Určení přednastavení

  • Vyberte položku Objekt > Živá vektorizace > Volby vektorizace. (Nebo vyberte vektorizovaný objekt a klikněte na tlačítko Dialog voleb vektorizace ovládacím panelu.) Nastavte volby vektorizace přednastavených a klikněte na položku Uložit přednastavení. Zadejte název přednastavených a klikněte na tlačítko OK.

  • Vyberte položku Upravit > Přednastavení vektorizace. Klikněte na Nové, nastavte volby vektorizace pro přednastavené a klikněte na tlačítko Hotovo.

    Tip: Chcete-li odvodit nové předvolby od existujících, vyberte předvolbu a klepněte na tlačítko Nové.

Úpravy nebo odstranění přednastavení

  1. Vyberte položku Upravit > Přednastavení vektorizace.

  2. Vyberte přednastavení a klikněte na Upravit nebo Odstranit.

    Poznámka:

    Nemůžete upravit nebo odstranit výchozí přednastavení (která se zobrazují v hranatých závorkách [ ]). Můžete ale vytvořit upravitelnou kopii výchozího přednastavení, když přednastavení vyberete a klepnete na Nové.

Sdílení přednastavení s ostatními uživateli

  1. Zvolte Úpravy > Přednastavení vektorizace.

  2. Proveďte jeden z následujících úkonů:

    • Kliknutím na Export uložte přednastavení do souboru.

    • Kliknutím na Import načtěte přednastavení ze souboru.

Převedení vektorizovaného objektu na objekt živé malby

Když jste s výsledky vektorizace spokojeni, můžete vektorizovaný objekt převést na cesty nebo na objekt živé malby. Tento závěrečný krok vám umožní pracovat s vektorizací stejně jako s jinými vektorovými kresbami. Když ale vektorizovaný objekt převedete, již nebudete moci změnit volby jeho vektorizace.

  1. Vyberte vektorizovaný objekt.

  2. Proveďte jeden z následujících úkonů:

    • Chcete-li vektorizaci převést na cesty, klikněte na položku Rozdělit na ovládacím panelu nebo zvolte položku Objekt > Živá vektorizace > Rozdělit. Tuto metodu použijte, pokud chcete se součástmi vektorizované kresby pracovat jako se samostatnými objekty. Výsledné cesty jsou seskupené.

    • Chcete-li vektorizaci převést na cesty a přitom zachovat aktuální volby zobrazení, zvolte položku Objekt > Živá vektorizace > Rozdělit dle zobrazení. Pokud jsou například volby zobrazení pro výsledek vektorizace nastavené na Obrysy, pak rozbalené cesty budou pouze obrysy (nebudou vyplněné ani vytažené). Navíc se zachová snímek vektorizace s platnými volbami zobrazení, a seskupí se s rozdělenými cestami. Tuto metodu použijte, pokud chcete zachovat vektorizovaný obraz jako vodítko pro rozdělené cesty.

    • Chcete-li vektorizaci převést na objekt živé malby, klikněte na ovládacím panelu na Živá malba nebo zvolte položku Objekt > Živá vektorizace > Převést na živou malbu. Tuto metodu použijte, pokud chcete na vektorizovanou kresbu aplikovat výplně a tahy pomocí nástroje plechovka živé malby.

Poznámka:

Chcete-li v jednom kroku vytvořit vektorizaci a převést vektorizovaný objekt, zvolte Objekt > Živá vektorizace > Vytvořit a rozdělit nebo Objekt > Živá vektorizace > Vytvořit a převést na živou malbu.

Video o vektorizaci najdete na www.adobe.com/go/vid0043_cz.

Uvolnění vektorizovaného objektu

Pokud chcete vypustit vektorizaci, ale zachovat původní umístěný obraz, můžete vektorizovaný objekt uvolnit.

  1. Vyberte vektorizovaný objekt.

  2. Zvolte Objekt > Živá vektorizace > Uvolnit.

Manuální vektorizace kresby s použitím vrstev předlohy

Vrstvy předloh jsou zamknuté netištěné vrstvy, které můžete využít k ručnímu obkreslování obrazů. Vrstvy předloh jsou ztlumené na 50 %, takže můžete snadno vidět všechny cesty, které nakreslíte před touto vrstvou. Vrstvu předlohy můžete vytvořit při umísťování obrazu nebo z existující vrstvy.

  1. Proveďte jeden z následujících úkonů:

    • Chcete-li obraz umístit jako vrstvu předlohy pro vektorizaci, zvolte položky Soubor > Umístit, vyberte soubor EPS, PDF nebo rastrového obrazu, který chcete vektorizovat, vyberte možnost Předloha, a pak klikněte na tlačítko Umístit. Nová vrstva předlohy se objeví pod aktuální vrstvou v panelu.

    • Chcete-li vektorizovat existující obraz, zkontrolujte, zda je ve své vlastní vrstvě, pak na tuto vrstvu poklikejte v panelu Vrstvy, vyberte možnost Předloha a klikněte na tlačítko OK; nebo vrstvu vyberte a z nabídky panelu zvolte možnost Předloha.

    Ikona oka se nahradí ikonou předlohy , a vrstva se zamkne.

  2. Obsah souboru obkreslete pomocí nástroje pero nebo tužka.

  3. Chcete-li vrstvu předlohy skrýt, zvolte položku Zobrazení > Skrýt předlohu. Chcete-li vrstvu předlohy znovu zobrazit, zvolte položku Zobrazení > Zobrazit předlohu.

  4. Chcete-li vrstvu předlohy změnit na normální vrstvu, poklikejte na vrstvu předlohy v panelu Vrstvy, odznačte položku Předloha a klikněte na tlačítko OK.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online