Apply color

Adobe InDesign provides a number of tools for applying color, including the Toolbox, the Swatches panel, the Color panel, the Color Picker, and the Control panel.

When you apply a color, you can specify whether the color applies to the stroke or fill of an object. The stroke is the border or frame of an object, and the fill is the background of an object. When you apply a color to a text frame, you can specify whether the color change affects the text frame or the text inside the frame.

  1. Select the object you want to color by doing one of the following:
    • For a path or frame, use the Selection tool  or the Direct Selection tool , as necessary.
    • For a grayscale or monochrome (1‑bit) image, click the Content Grabber or use the Direct Selection tool. You can apply only two colors to a grayscale or monochrome image.
    • For text characters, use the Type tool  to change the text color of a single word or the entire text within a frame.

    Note:

    To change the color of gaps in a dashed, dotted, or striped stroke, use the Stroke panel.

  2. In the Toolbox or in the Color or Swatches panel, select the Formatting Affects Text or Formatting Affects Container to determine if color is applied to the text or the text frame.

  3. In the Toolbox or in the Color or Swatches panel, select the Fill box or the Stroke box to specify the fill or stroke of the object. (If you selected an image, the Stroke box has no effect.)
    Specify how color is applied in the Toolbox
    Specify how color is applied in the Toolbox

    A. Fill box B. Formatting Affects Container C. Stroke box D. Formatting Affects Text 
  4. Do one of the following:
    • Select a color, tint, or gradient using the Swatches or Gradient panel.
    • Select a color, tint, or gradient from the Fill or Stroke menu in the Control panel.
    • Double-click either the Fill or Stroke box in the Toolbox or the Color panel to open the Color Picker. Select the desired color, and click OK.

Note:

You can apply color to any grayscale image, provided it does not contain alpha or spot channels. If you import an image with a clipping path, select the clipping path using the Direct Selection tool to apply color to the clipped area only.

Select a color with the Color Picker

The Color Picker lets you choose colors from a color field or specify colors numerically. You can define colors using the RGB, Lab, or CMYK color model.

  1. Double-click either the Fill or Stroke box in the Toolbox or the Color panel to open the Color Picker.
  2. To change the color spectrum displayed in the Color Picker, click a letter: R (Red), G (Green), or B (Blue); or L (luminance), a (green-red axis), or b (blue-yellow axis).
    Color Picker
    Color Picker

    A. Original color B. New color C. Color field D. Color slider triangles E. Color spectrum 
  3. To define a color, do any of the following:
    • Click or drag inside the color field. Cross-hairs indicate the color’s position in the color field.
    • Drag the color slider triangles along the color spectrum or click inside the color spectrum.
    • Enter values in any of the text boxes.
  4. To save the color as a swatch, click Add CMYK Swatch, Add RGB Swatch, or Add Lab Swatch. InDesign adds the color to the Swatches panel, using the color values as its name.
  5. Click OK.

Apply the last used color

The Toolbox displays the last color or gradient you applied. You can apply this color or gradient directly from the Toolbox.

  1. Select the object or text you want to color.
  2. In the Toolbox, click the Fill button or Stroke button depending on which portion of the text or object you want to color.
  3. In the Toolbox, do one of the following:
    • Click the Color button  to apply the last selected solid color in the Swatches or Color panel.
    • Click the Gradient button  to apply the last selected gradient in the Swatches or Gradient panel.
    • Click the None button  to remove the object’s fill or stroke.

Remove fill or stroke color

  1. Select the text or object whose color you want to remove.
  2. In the Toolbox, click the Fill button or Stroke button depending on which portion of the text or object you want to change.
  3. Click the None button  to remove the object’s fill or stroke.

Apply colors using drag-and-drop

An easy way to apply colors or gradients is to drag them from a color source to an object or panel. Drag-and-drop lets you apply colors or gradients to objects without first selecting the objects. You can drag the following:

  • The Fill or Stroke box in the Toolbox or a panel.

  • The Gradient box in the Gradient panel.

  • Swatches from the Swatches panel.

  • The last-used, in-gamut color swatch located next to the out-of-gamut icon  in a panel.

You can drop colors or gradients on the following objects and panels:

  • The fill or stroke of a path. To drop color on a fill or stroke, position the center of the drag icon precisely over the path’s fill or stroke while you drag a color, and then release the mouse button.

  • The Swatches panel.

 

If you drag one or more Swatches panel swatches, or the color swatch next to an out‑of‑gamut icon, you can drop them into another InDesign document window, which adds the swatches to that document’s Swatches panel.

Apply a color or gradient swatch

  1. Using the Selection tool , select a text or object frame; or using the Text tool , select a range of text.

  2. If the Swatches panel is not open, choose Window > Color > Swatches.

  3. In the Swatches panel, select the Fill box or the Stroke box.

  4. Do one of the following:

    • To apply color to selected text, click the Text button .

    • To apply color to a selected object or text container (such as a frame or a table), click the Object button .

  5. Click a color or gradient swatch. The selected color or gradient is applied to any selected text or object, and it appears in the Color panel and in the Fill box or Stroke box in the Toolbox.

Note:

You can set the default fill or stroke colors the same way you set other InDesign defaults. Choose Edit > Deselect All to make sure that no objects are selected, and then choose a color.

Apply color using the Color panel

Although the Swatches panel is the recommended panel for working with colors, you can also mix colors by using the Color panel. You can add the current Color panel color to the Swatches panel at any time. The Color panel is most useful for mixing unnamed colors.

Note:

If you select an object that currently uses a named swatch, editing its color using the Color panel changes the color of that object only. If you want to edit the color throughout the document, double-click its swatch in the Swatches panel.

Edit the fill or stroke color

  1. Select the object or text you want to change.
  2. If the Color panel is not displayed, choose Window > Color.
  3. Select the Fill box or the Stroke box in the Color panel.
    Color panel
    Color panel

    A. Fill box B. Stroke box C. Formatting Affects Container D. Formatting Affects Text 
  4. If you selected a text frame, select the Container box  or Text box  to change the color of either the fill or text within the frame.
  5. Do one of the following:
    • Adjust the Tint slider, which appears by default if the object uses a swatch from the Swatches panel.
    • Choose a Lab, CMYK, or RGB color model in the Color panel menu, and use the sliders to change the color values. You can also enter numeric values in the text boxes next to the color sliders.
    • Position the pointer over the color bar, and click.
    • Double-click the Fill or Stroke box, and select a color from the Color Picker. Then click OK.
  6. If an out-of-gamut alert icon  appears, and you want to use the CMYK color values closest to the color you originally specified, click the small color box next to the alert icon.

Create a swatch from a color in the Color panel

  1. In the Color panel, make sure that the active Fill or Stroke box displays the color you want to add.
  2. Choose Add To Swatches in the panel menu.

Cycle through color modes

  • Do one of the following:
    • In the Color panel, Shift-click the color bar at the bottom of the panel.
    • In the New Color Swatch or Swatch Options dialog box, Shift-click the color box.
    • In the New Gradient or Gradient Options dialog box, select a gradient stop, make sure that RGB, LAB, or CMYK is selected in the Stop Color menu, and then Shift-click the color box.

Generate color themes using the Color Theme tool

You can extract color themes from selected areas, images, or objects in your InDesign document. You can also choose a color from an image, the whole image, or the whole layout. Basically, you can generate color themes from any colors in your artwork. Use the Color Theme tool to pick a single color or theme and add the color theme to the swatches panel. 

Add these colors to the layout, add them to the Swatches panel. You can also save them to your Creative Cloud libraries.

  1. Click the Color Theme tool on the Tools panel. You can use the shortcut I to toggle between the Color Theme tool and the Eyedropper tool.

    Color Theme tool
    Color Theme tool

  2. Click any part of the layout to pick a color. You can also leverage colors from any artwork placed in Adobe Photoshop, Illustrator, or any other file.

    Color is retained once selected using the theme tool. After picking up colors, if you switch tool to perform some other operation, say drawing any object, and then reselect the Color Theme tool, the theme picked up earlier would be retained. Unless you press the ESC key to close the panel, the theme picked up is retained for reuse. On pressing the ESC key, everything gets cleared.

  3. Roll your mouse to observe areas marked automatically by InDesign where you can create a color theme from. Click a section and InDesign creates a color theme.

  4. A color theme is made of five different colors. Click the flyout menu to view the other color choices generated.

  5. Color theme tool - options
    Color theme tool - options

    A. Click to view all themes B. Add the current color theme to swatches C. Save to current CC Library 

    A color theme is made of five different colors. Click the flyout menu (A from the image), to see the other theme choices generated for the same color theme, such as Colorful, Bright, Deep, and Muted.

    If you do not like the color theme generated, press the Esc key and try again, or press the Alt key to temporarily switch to Pick mode to collect new theme.

    Shift+Click to pick a single (precise) color as the base color for the theme. Color themes are generated based on Adobe Color rules: Analogous, Monochromatic, Triad, Complementary, Compound, Shades.

  6. To apply the colors, you can select a single color on the Color Theme tool. Roll over the mouse to the page item. The Eyedropper appears half-full, click to change the fill or stroke.

    When you roll over the mouse over text, the eyedropper changes to text. You can apply a color generated from the Color Theme tool on text.

  7. Double-click the Color Theme tool. Colors picked and added to swatches honor document intent and automatically converts to appropriate color space before being added to swatches or dropped on other objects. Three options are provided to choose from:

    1. Convert as per document Intent.
    2. Convert to CMYK.
    3. Convert to RGB.
    Color theme options
    Color theme options

  8. Color theme tool - options
    Color theme tool - options

    A. Click to view all themes B. Add the current color theme to swatches C. Save to the current CC Library 

    Click B to add these colors to the Swatches panel. The color theme gets added to the Swatches panel as a folder.

    To add a specific color to the Swatches panel, press Alt and click “Add the current color theme to swatches” button.

  9. Color theme
    Color theme

    Click this button, the selected theme on the panel is saved to the current CC Library in the CC Libraries panel.

  10. You can apply color values using hexadecimal RGB code in Color picker, New Swatch, and Edit swatch workflow. You can apply color values using hexadecimal RGB code, as well. There are three ways in which you can apply a hex color value:

    • Using the Color Picker in a New Swatch: From the Swatch panel, click to expand the flyout menu and select New Color Swatch. In the New Color Swatch dialog, select RGB from the Color Mode.
      Click the screengrabber, hold down the mouse button, and click anywhere on the screen to view the hex color value from any source. Click Add to add the color swatch.
    New Swatch - Hexvalue
    New Swatch - Hexvalue

    • Edit Swatch: You can also edit a swatch and change its hex value. Double-click a swatch, from the Color Mode drop-down, select RGB.
    • Color Proxy: Double-click the color proxy in the Tools panel. You can pick the hex value from here.

Apply colors using the Eyedropper tool

Use the Eyedropper tool  to copy fill and stroke attributes, such as color, from any object in an InDesign file, including an imported graphic. By default, the Eyedropper tool loads all available fill and stroke attributes of an object and sets the default fill and stroke attributes of any new objects you draw. You can use the Eyedropper Options dialog box to change the attributes the Eyedropper tool copies. You can also use the Eyedropper tool to copy type and transparency attributes.

Note:

If an attribute is not listed in the Eyedropper Options dialog box, it can’t be copied with the Eyedropper tool.

Apply colors using the Eyedropper tool

  1. Select one or more objects that have the fill and stroke attributes you want to change.

  2. Select the Eyedropper tool .

  3. Click any object that has the fill and stroke attributes you want to sample. A loaded eyedropper appears , and the selected objects are automatically updated with the fill and stroke attributes of the object you clicked.

  4. To change other objects to the same attributes, click the objects with the loaded eyedropper. If an object is stroked and not filled, be sure to click the object’s outline.

Pick up new attributes when the Eyedropper tool is loaded

  1. Press Alt (Windows) or Option (Mac OS) while the Eyedropper tool  is loaded. The Eyedropper tool reverses direction, and appears empty , to indicate that it’s ready to pick up new attributes.

  2. Without releasing the Alt or Option key, click an object containing the attributes that you want to copy, and then release the Alt or Option key so that you can drop the new attributes on another object.

Change Eyedropper tool settings

  1. In the Toolbox, double-click the Eyedropper tool .

  2. Select the attributes in the Fill Settings and Stroke Settings sections that you want to copy with the Eyedropper tool, and then click OK.

Note:

To pick up only the fill or stroke color of an object and no other attributes, Shift-click the object with the Eyedropper tool. When you apply the color to another object, only the fill or stroke color is applied, depending on whether the stroke or fill is on top in the toolbar.

Apply colors to grayscale images

You can add color to a placed grayscale image in InDesign.

  1. Make sure that the image is saved as a grayscale or bitmap image and that it’s saved in PSD, TIFF, BMP, or JPG format.

    In Photoshop, you can choose Image > Mode > Bitmap or Image > Mode > Grayscale.

  2. Click the Content Grabber, or use the Direct Selection tool  to select the image.

  3. Select a color from the Swatches panel or Color panel.

An image in PSD format can contain multiple layers, but the bottom layer must be opaque. You cannot apply color to a PSD image with a transparent background in InDesign. In addition, the grayscale image cannot contain alpha or spot channels.

Add and manage color groups

Color groups enable you to organize your color schemes better and to exchange frequently used color swatches across applications. Color groups help you to:

  • Organize color swatches.
  • Load color groups from a project in Illustrator.

Adding color groups

  1. To create a color group, click the Color Group icon on the Swatches panel. Alternatively, you can also create a color group from the flyout and context menu.

    New Color Group
    New Color Group

    • Enter the name of the color group.
    • Select the option to create the color group scheme:
      • Selected Swatches:  Select this option, if you want to move the swatches to a color group at the time of creation. Hold Ctrl (Win) or Option (Mac) to select multiple color swatches before selecting the New Color Group option. If no swatches are selected, an empty color group is created.
      • Selected Page Items(s):  The swatches of the selected page items or artwork are added to the created color group. This option is selected by default when an artwork is selected.

    Note:

    To give a name to the color group at the time of creation, you can use any of the options or hold the Alt key (Win) or Option Key (Mac) when you click the new color group button.

  2. You can drag-and-drop multiple swatches from the root as well as from other color groups into the created color group.

  3. Right-click on a color swatch to explore other options. You can switch to a Color Group view and work extensively with color groups. Click the filter icon at the bottom of the panel and select Show Color Groups. This enables you to work with color groups extensively. Root swatches and gradients are not visible in this view.

    Show Color Groups
    Show Color Groups

Various operations to manage color groups

Following operations can be performed to manage color groups.

  • Add a swatch to a color group: Select the color group. Select a swatch and drag-and-drop it inside the color group.
  • Duplicate color group: You can duplicate from the context menu as well from the flyout. Right-click on a color group and select Duplicate Color Group. All swatches inside the color group get duplicated along with the color group. Swatches across different color groups are not created with same names, to avoid confusion.
  • Ungroup color group: Ungrouping can be done from the context menu as well from the flyout. Right-click on a color group and select Ungroup Color Group. On ungrouping, all swatches inside the group move to the root that is outside the color group.
  • Rename color group: Color Groups can be renamed by using the Color Group Options option in the context/flyout menu. Double-click a group to edit the color group name. You can also inline edit the color group.
  • Delete color group: Select a color group, right-click, and select Delete Color Group. Or, select the color group and select Delete Color Group from the flyout menu.

Note:

When you delete a color group, all the swatches within the color group get deleted.

Create a color group with selected page item(s)

You can select a page item(s) artwork in the document and create a color group from the swatches present in the page item(s). You can add swatches from the page item(s) into the color group.

  1. Select page item(s) in the document.

  2. From the Flyout or Context menu, select New Color Group.

  3. Select Selected Page Item(s) in the New Color group dialog box. In case more than one swatches are selected in the swatches panel, then the default selection is Selected Swatches.

  4. Color groups work in all list views (name, small name) as well as grid views (small swatch, large swatch). All the operations like creation, dragging swatches, color groups can be performed across all the different views inside the swatches panel.

Load and save swatches from an ASE file

ASE files help import and export color swatches across applications like Adobe Illustrator. You can import .ase files to load color groups in the swatches panel. Color groups can also be saved as .ase files from the Swatches flyout. Similarly, if the color groups are saved from Illustrator, they can be loaded inside InDesign.

Load swatches

  1. Select Load Swatches from the Swatches panel menu.

  2. Select the saved .ase file. Click Open.

Save swatches

You can save a color swatch or color group as a .ase file.

  1. Select the color group or swatch.

  2. From the flyout menu, select Save Swatches.

  3. Enter the name of the .ase file. Click Save.

Import themes from Color app

You can add themes from the Color panel into the Swatches panel as color groups in InDesign. These themes are created as a color group with the theme's name.

  1. Select Window > Color.

  2. In the Browse window, select a theme.

    You can do any of the following to export the theme to InDesign:

    • Click the arrow next to a theme and select Add to Swatches Panel.                       
    • Click the Add selected theme icon to import the theme to the Swatches panel.

     

    Add Swatches icon/option
    Add Swatches icon/option

  3. You can also go to the Create tab in Color, select a rule from Select Rule, and click the Add this theme to swatches icon.

    Add theme to Swatches menu
    Add theme to Swatches menu

Support of legacy behavior

If you open a .idml file with color group information in previous versions, the Swatches panel displays the flat swatch list with no color groups as color groups are not available in earlier versions.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy