Transform panel overview

Use the Transform panel to view or specify geometric information for any selected object, including values for position, size, rotation, and shearing. Commands in the Transform panel menu provide additional options and quick ways to rotate or reflect objects.

Note:

The buttons and panel menu commands in the Transform panel are also available in the Control panel.

Transform panel
Transform panel

A. Reference point locator B. Constrain Proportions icon C. Panel menu 

Display the Transform panel

  • Choose Window > Object & Layout > Transform.

View geometric information about objects

When you select an object, its geometric information appears in the Transform and Control panels. If you select multiple objects, the information represents all selected objects as a unit.

  • Select one or more objects, and display the Transform panel (Window > Object & Layout > Transform).

    Position information is relative to the ruler origin and the reference point of the object. Angle information is relative to the pasteboard, where a horizontal line has an angle of 0°.

Change transformation settings

The Transform panel includes several options that determine how objects are transformed and how transformations are displayed in the Transform and Control panels.

Change the reference point for selected objects

All transformations originate from a fixed point on or near the object, called the reference point. An icon is displayed at the reference point when a transformation tool, such as the Scale tool, is active.

Reference point moved to center (left), and object scaled (right)
Reference point moved to center (left), and object scaled (right)

  • Do one of the following:
    • To specify a different reference point for the selected object, click any of the nine points on the reference point locator  in the Transform or Control panel.


      As you click different reference points on the Transform or Control panel (top left and right), the reference point for the selected object changes (bottom left and right).

       

    • To move the selected object’s reference point to a specific location, select the Rotate tool , the Scale tool , or the Shear tool , position the tool over the reference point icon, and then drag it to a new location. Or, with one of these tools selected, click anywhere on the object or page. The reference point moves to that location.

Note:

When a transform tool is selected, clicking away from the object does not deselect it— it moves the reference point. Choose Edit > Deselect All to deselect an object.

The last-selected reference point on the reference point locator becomes the new default reference point for all tools and objects. If you drag an object’s reference point icon to a custom location (not on an anchor point), the panel reference point returns to the default position once the current object is no longer selected. InDesign preserves the default reference point position for new documents so you don’t have to reset it.

Change the information displayed for nested objects

The Transform panel orients an object to a spread’s pasteboard, where a horizontal line has a rotation angle of 0°. By default, this is true even if the object is nested inside a transformed container object (that is, if the object is part of a transformed group or pasted inside a transformed frame). For example, if you paste an unrotated graphic inside a frame, rotate the frame 10° with the graphic inside, and then select the graphic using the Direct Selection tool, the Transform panel displays the graphic’s rotation angle as 10°.

Object’s rotation angle displayed relative to pasteboard
Object’s rotation angle displayed relative to pasteboard

If you prefer, you can deselect the Transformations Are Totals command to see the same information relative to the nested object’s container. In the example above, if you deselect Transformations Are Totals, the Transform panel displays the graphic’s rotation angle as zero (the angle it has relative to its rotated container).

Object’s rotation angle displayed relative to container object
Object’s rotation angle displayed relative to container object

  1. Open the Transform panel or Control panel.
  2. In the Transform or Control panel menu, do one of the following:
    • Leave Transformations Are Totals selected (the default) to display transformation values for nested objects relative to the pasteboard.

    • Deselect Transformations Are Totals to display rotate, scale, and shear values for nested objects relative to the container object.

Measure the position of selected objects

The Show Content Offset command determines the appearance of the X and y values in the Transform panel for nested objects selected with the Direct Selection tool . The selected reference point in the reference point locator of the Transform and Control panels determines which of the nine reference points on the selected object is being compared to the zero point of the document or to the zero point of a container frame. The zero point of a container frame is always its upper-left corner.

The position of selected objects is measured from three positions:

  • The position of the container frame in relation to the zero point of the document. With Show Content Offset turned on or off, select the container frame using the Selection tool.

  • The position of the nested object in relation to the zero point of the document. Turn off Show Content Offset and select the nested object using the Direct Selection tool.

  • The position of the nested object in relation to the zero point (upper-left corner) of its container frame. Turn on Show Content Offset and select the nested object using the Direct Selection tool.

Parent frame’s position displayed relative to zero point of document
Parent frame’s position displayed relative to zero point of document

Nested object’s position displayed relative to zero point of document
Nested object’s position displayed relative to zero point of document

Nested object’s position displayed relative to container frame
Nested object’s position displayed relative to container frame

If Show Content Offset is selected, the X and Y values of the embedded object appear relative to the container object, and the X/Y icons in the Transform panel change to X+/Y+. If this command is deselected, the nested object values appear relative to the rulers.

  • In the Transform or Control panel menu, select or deselect Show Content Offset.

Include or exclude stroke weight in measurements

Stroke weight can affect an object’s size and position. You can change the stroke’s alignment and then choose whether the Transform panel measures an object’s size and position from the center or from the edge of its stroke. For information on changing stroke alignment, see Stroke panel options.

Note:

This option does not change how stroke weights are affected when scaling a frame, only whether any changes affect measurements.

  • In the Transform or Control panel menu, do one of the following:
    • Select Dimensions Include Stroke Weight when you want panel measurements to represent the outer edge of an object’s stroke. For example, if one frame is 2 points shorter than the other, but the shorter frame’s stroke is 2 points thicker, this setting will cause both frames to display the same height values in the Transform and Control panels.

    • Deselect Dimensions Include Stroke Weight when you want the panel measurements to represent an object’s path or frame regardless of its stroke weight. For example, two frames of the same height will display the same height values in the Transform and Control panels, regardless of differences in their stroke weights.

Transform objects

You can modify an object’s size or shape, and change its orientation on the pasteboard, by using tools and commands. The toolbox includes four transformation tools—the Rotate, Scale, Shear, and Free Transform tools. In addition, you can use the Selection tool to transform objects. All transformations, with the addition of reflection, are available in the Transform and Control panels, where you can precisely specify transformations.

Transformation tools (top) compared to Transform panel (bottom)
Transformation tools (top) compared to Transform panel (bottom)

A. Rotation options B. Shearing options C. Scaling options 

When transforming objects, note the following:

  • The results of a transformation can differ significantly, depending on what is selected. For example, when you rotate an image, what gets rotated depends on whether you select the image, the frame, or the frame and the image. Use the Selection tool  to transform (rotate, scale, or shear) an entire path and its content (click outside the content grabber); use the Direct Selection tool  to transform just the path without its content or the content without its path. To transform the content without its path, make sure that all anchor points are selected.

Note:

To resize both the frame and content, use the Scale X Percentage and Scale Y Percentage fields, not the W and H fields. The W and H fields change only the selected frame or content, not both. Keep in mind that you’re not limited to specifying percentages in the Scale fields. You can type dimensions by including the unit of measurement, such as “6p.”

  • A transformation affects all selected objects as a single unit. For example, if you select multiple objects and rotate them 30°, they all rotate around one reference point. If you want to rotate each selected object 30° around its own reference point, you must select and rotate them individually.

  • When transforming type, you can use either of two selection methods: Use the Selection or Direct Selection tool to select an entire text frame or text converted to outlines, and then use the transformation tools; or use the Type tool to select text or to click an insertion point in a text frame, and then specify transformations in the Transform panel, Control panel, or dialog boxes available when you double-click a tool. In both cases, the transformation affects the entire text frame.

  • When you rotate, skew, or scale a group, the settings apply to the entire group, as well as to the individual objects in the group. For example, if you rotate a group 30°, the rotation value in the Transform or Control panel is 30° whether you select the group itself or direct-select an object in the group.

Transform objects with the Transform panel

Use the selection tools to determine whether the content and frame are transformed together or separately.

  1. Select an object to transform.
    • To transform both the frame and its content, use the Selection tool to select the frame.

    • To transform the content without transforming its frame, use the Direct Selection tool  to direct-select the object, or use the Selection tool to click the content grabber of an image.

    • To transform a frame without transforming the content, direct-select the frame, and select all the anchor points.

  2. In the Transform panel or Control panel, specify the reference point for the transformation.

    All values in the panel refer to the bounding boxes of the objects. X and Y values refer to the selected reference point on the bounding box relative to the ruler origin.

  3. Do any of the following:
    • Enter new values in the text boxes.
    • Choose values from available pop‑up menus.
    • Choose commands from the panel menu

    Note:

    To maintain the object’s proportions when using the Scale X Percentage and Scale Y Percentage options, click the Constrain Proportions icon  in the panel. When the option is not selected, dots appear on both sides of the icon (like a broken chain link). You can also specify dimensions rather than percentages by specifying the unit of measurement, such as 6p.

  4. Press Tab, Enter (Windows), or Return (Mac OS) to apply the change.

Transform objects with the Selection tool

Use the Selection tool to move, resize, and rotate objects.

  1. Using the Selection tool , select an object. To transform an image within a frame, click the content grabber that appears when you hold the pointer over an image.
  2. Do any of the following:
    • To move objects, click anywhere within the bounding box, and then drag.

    • To scale objects, hold down Ctrl (Windows) or Command (Mac OS), and drag any bounding box handle until the object is the desired size. Include the Shift key to preserve the selection’s proportions. Include the Alt (Windows) or Option (Mac OS) key to scale objects from the center.

    • To rotate objects, position the pointer anywhere outside a bounding box handle. When the pointer changes to , drag until the selection is at the desired angle of rotation.

    • To reflect objects, drag a handle of the bounding box past the opposite edge or handle, until the object is at the desired level of reflection.

Transform objects with the Free Transform tool

The Free Transform tool works the same way it does in Adobe Photoshop and Adobe Illustrator, by providing a way to perform any transformation with just one tool. You can combine transformations, such as rotating and scaling, while the Free Transform tool is active.

Note:

You can use keyboard shortcuts to instantly switch among the Free Transform tool (press E), the Selection tool (V), and the Direct Selection tool (A).

  1. Using the appropriate selection tool, select the object or objects to transform.
  2. Select the Free Transform tool .
    • To move objects, click anywhere within the bounding box, and then drag.

    • To scale objects, drag any bounding box handle until the object is the desired size. Shift-drag the handle to preserve the selection’s proportions.

    • To scale objects from the center of the bounding box, Alt‑drag (Windows) or Option-drag (Mac OS).

    • To rotate objects, position the pointer anywhere outside the bounding box. When the pointer changes to , drag until the selection is at the desired angle of rotation.

    • To reflect objects, drag a handle of the bounding box past the opposite edge or handle, until the object is at the desired level of reflection.

    • To shear objects, begin dragging a handle, and then hold down Ctrl (Windows) or Command (Mac OS). Hold down Alt+Ctrl (Windows) or Command+Option to shear from both sides of the object.

Rotate objects

You can rotate objects using any of several methods.

Rotate an object using the Rotate tool

  1. Select an object to rotate. To rotate both the frame and its content, use the Selection tool to select the frame. To rotate the content without rotating its frame, click the Content Grabber or use the Direct Selection tool to select the object. To rotate a frame without rotating the content, direct-select the frame, and select all the anchor points.
  2. Select the Rotate tool .
  3. If you want to use a different reference point for the rotation, click where you want the reference point to appear.
  4. Position the tool away from the reference point, and drag around it. To constrain the tool to multiples of 45°, hold down Shift as you drag. For finer control, drag farther from the object’s reference point.

You can also rotate by using the Free Transform tool.

If Smart Guides (and Smart Dimensions) are turned on, visual clues indicate when you’re rotating an object the same degree as a nearby rotated object. For example, if you rotate one object on your page 24 degrees, a rotation icon appears as you rotate another object close to 24 degrees.

Rotate an object using the Selection tool

  • Using the Selection tool, position the pointer anywhere outside a selection handle. When the pointer changes to , drag until the selection is at the desired angle of rotation.

Rotate an object using the Transform or Control panel

  1. Select an object to rotate. To rotate both the frame and its content, use the Selection tool to select the frame. To rotate the content without rotating its frame, click the Content Grabber or use the Direct Selection tool to select the object. To rotate a frame without rotating the content, direct-select the frame, and select all the anchor points.
  2. Do any of the following:
    • To rotate clockwise or counterclockwise in 90° increments, click either of the Rotate buttons in the Control panel.

    • To rotate by a preset angle, choose an angle from the Rotation Angle  pop‑up menu in the Transform or Control panel.

    • In the Rotation Angle  box on the Transform or Control panel, type a positive angle to rotate selected objects counterclockwise, or type a negative angle to rotate selected objects clockwise, and then press Enter (Windows) or Return (Mac OS).

    • To create a copy of the object with the new rotation applied to the copy, type a value in the Rotation Angle box on the Transform panel and then hold down Alt (Windows) or Option (Mac OS) as you press Enter.

When you rotate a single object, the specified value remains displayed in the Transform or Control panel. When you rotate multiple objects, the Rotation Angle is reset to 0 degrees, even though the objects are rotated.

Rotate an object using the Rotate command

You can use the Rotate command to rotate an object by a specific amount. This command also lets you rotate a copy of the selected object, leaving the original in place.

  1. Select an object to rotate. To rotate both the frame and its content, use the Selection tool to select the frame. To rotate the content without rotating its frame, direct-select the object. To rotate a frame without rotating the content, direct-select the frame, and select all the anchor points.
  2. Do one of the following to open the Rotate dialog box:
    • Choose Object > Transform > Rotate.

    • Double-click the Rotate tool .

    • Select the Rotate tool and Alt‑click (Windows) or Option-click (Mac OS) on or near the object to select a new reference point.

  3. Enter the rotation angle, in degrees, in the Angle box. Enter a negative angle to rotate the object clockwise; enter a positive angle to rotate the object counterclockwise.
  4. Do one of the following:
    • To preview the effect before you apply it, select Preview.

    • To rotate the object, click OK.

    • To rotate a copy of the object, click Copy.

Move objects

You can move objects by cutting them from one spot and pasting them into another, by entering new horizontal and vertical coordinates, or by dragging them. Dragging also allows you to move a copy of an object or to copy objects between software applications.

The Smart Guides feature makes it easy to move objects to precise locations in your layout. As you drag an object, temporary guides appear, indicating that the object you’re moving is aligned with an edge or center of the page or with another page item.

Move objects

For best results, use the Selection tool to move multiple objects. If you use the Direct Selection tool to select multiple objects or paths, dragging moves only the selected graphic, path, or anchor points.

  1. Select an object to move. To move both the frame and its content, use the Selection tool to select the frame. To move the content without moving its frame, direct-select the object, or click the content grabber when you mouse over an image. To move a frame without moving the content, direct-select the frame, and select all the anchor points.
  2. Do one of the following:
    • To paste the object (or a copy of it) in a new location, choose Edit > Cut or Edit > Copy. Target the destination spread, and choose Edit > Paste. The objects appear in the center of the target spread.
    • To paste a copy at the same position as the original, choose Edit > Copy. Then, choose Edit > Paste In Place. (To offset the copy from the original, nudge it using the arrow keys.)

    Note:

    If you want an object to appear in the same position on many pages, consider creating a master page and paste the object on it.

    • To move an object to a specific numeric location, type a value for each of the X (horizontal) or Y (vertical) position options in the Transform or Control panel. Then press Enter (Windows) or Return (Mac OS).

    • To nudge an object slightly in one direction, press or hold an arrow key; to nudge an object ten times as far, hold down Shift as you press an arrow key.

    • To move an object by dragging, drag the object to a new position. Shift-drag to constrain the movement of the object horizontally, vertically, or diagonally (in multiples of 45°).

    Note:

    Drag the content grabber to move an image within its frame.

Move objects by a precise amount

You can use the Move command to move an object by a specific amount. This command also lets you move a copy of the selected object, leaving the original in place.

  1. Select an object to move. To move both the frame and its content, use the Selection tool to select the frame. To move the content without moving its frame, direct-select the object. To move a frame without moving the content, direct-select the frame, and select all the anchor points.
  2. Choose Object > Transform > Move, or double-click the icon for the Selection or Direct Selection tool in the toolbox.
  3. In the Move dialog box, do one of the following:
    • Enter the horizontal and vertical distances that you want the object to move. Positive values move the object down and to the right of the x axis; negative values move the object up and to the left.

    • To move an object a precise distance and angle, enter the distance and angle for the move. The angle you enter is calculated in degrees from the x axis. Positive angles specify a counterclockwise move; negative angles specify a clockwise move. You can also enter values between 180° and 360°; these values are converted to their corresponding negative values (for example, a value of 270° is converted to –90°).

  4. Do any of the following:
    • To preview the effect before you apply it, select Preview.

    • To move the object, click OK.

    • To move a copy of the object, click Copy.

Move objects to a precise location

  1. Select an object to move.
  2. If you want to use a different reference point for the move, click where you want the reference point to appear.

    For example, if you want to move the object to the upper-left corner of the page, select the upper-left reference point.

  3. In the X and Y fields on the Transform panel, enter the coordinates where you want the selection to be moved.

Specify the distance objects move when nudged

  1. Choose Edit > Preferences > Units & Increments (Windows) or InDesign > Preferences > Units & Increments (Mac OS).
  2. For Cursor Key, specify the distance you want each press of an arrow key to move selected objects, and then click OK.

Note:

If you hold down Shift while moving a selection, the selection moves ten times the distance you specify here.

Scaling vs. resizing objects

Resizing and scaling are different actions in InDesign. Resizing is simply changing the Width and Height values of an object. Scaling involves using a percentage value related to the original scale (100%) of the frame.

The difference between resizing and scaling isn’t always apparent. A good way to see the difference is to resize and scale a text frame that has a stroke applied to it. When you double the size of the text frame, the text size and stroke weight remain the same. When you double the scale of the text frame, the text size and stroke weight also double.

Resizing a frame

By default, when the frame (and not the frame contents) is selected, changing the values of the Width and Height fields changes only the frame, not its contents, regardless of which selection tool is active.

Scaling a frame and its contents

When the frame is selected with the Selection tool, changing the values of the Scale X Percentage and Scale Y Percentage fields changes the frame and its contents. If Auto-Fit is selected, the frame and its contents are resized together.

Resizing or scaling frame contents

If you want to change only the content (resize or scale) of a frame, click the Content Grabber or use the Direct Selection tool to select the contents. Once selected, you can use the Width and Height fields or the Scale fields, depending on your preference.

Overriding defaults

If you want to scale the frame or its contents by a percentage and have the results returned in the current measurement system, you can enter in a number with the percent sign to override the default measurement system. For example, if the current width is 12p, and you want the new width to be 75% of the current value, you can enter 75% in the Width field. After you press Enter, the new value for the Width displays as 9p.

Similarly, you can use other measurement system values if you want to scale to a specific increment but have the results display in percent of the original. For example, you can replace 100% with 9p, and InDesign figures out which percentage is required to make it that width/height.

Resize objects

Dragging the handle of a frame that includes contents, such as an imported graphic, does not resize the contents by default. It’s important to understand that the content and the container frame are separate items, each with its own bounding box. Simply dragging the frame of an imported graphic will either crop the graphic or leave a blank space outside the graphic, depending on which direction you drag. Being able to modify the frame apart from the contents adds flexibility, but it takes some time to get used to.

The Smart Guides feature makes it easy to resize objects based on other items in your layout. As you resize an object, temporary guides appear, indicating that the object is aligned with an edge or center of the page or is the same height or width as another page item.

Resizing an imported graphic
Resizing an imported graphic

A. Frame selected with Selection tool B. Frame resized C. Frame and content scaled 
  • To resize a frame, drag any handle using the Selection tool. If you hold down Ctrl (Windows) or Command (Mac OS) while dragging, the frame and the content are scaled. Adding the Shift key scales proportionally.

Note:

If Auto-Fit is selected, resizing the frame resizes the image within the frame.

  • To resize the content of a graphics frame, use the Selection tool to click the content grabber or direct-select the graphic, and then drag any of the graphics frame handles.
  • To resize a frame or its content to a precise size, select the object and enter the size in the width (W) or height (H) fields on the Control panel.

Note:

To maintain the original proportions of the object when using the Control panel, make sure the Constrain Proportions icon  is selected.

  • To resize both the frame and content, use the Scale X Percentage and Scale Y Percentage fields, not the W and H fields. The W and H fields change only the selected frame or content, not both. Rather than specifying percentages, you can type dimensions by including the unit of measurement, such as “6p.”
  • To resize a frame or its content to a percentage of its current size, select the object and enter the percentage in the width or height fields on the Transform panel.
  • To create a copy of the selected object with the new size applied to the copy, type a value in the width or height fields on the Transform panel and then hold down Alt (Windows) or Option (Mac OS) as you press Enter.

Note:

After you resize a frame or object, you can use a fitting option (Object > Fitting) to fit the content to the frame or the frame to the content.

Scale objects

Scaling an object enlarges or reduces it horizontally (along the x-axis), vertically (along the y-axis), or both horizontally and vertically, relative to the reference point you specify.

By default, InDesign scales strokes. For example, if you scale a selected object with a 4-point stroke by 200%, the Stroke panel indicates an 8-point stroke and the stroke visibly doubles in size. You can change the default stroke behavior by deselecting Adjust Stroke Weight When Scaling in the Transform or Control panel menu.

Scale an object using the Selection tool

  • To scale the content and frame simultaneously, use the Selection tool to select the object and hold down Ctrl (Windows) or Command (Mac OS). Add the Shift key to resize the object proportionally.

Scale an object using the Scale tool

  1. Select an object to scale. To scale both the frame and its content, use the Selection tool to select the frame. To scale the content without scaling its frame, click the Content Grabber to direct-select the object. To scale a frame without scaling the content, direct-select the frame, and select all the anchor points.
  2. Select the Scale tool .
  3. Position the Scale tool away from the reference point and drag. To scale the x or y axis only, start dragging the Scale tool along one axis only. To scale proportionally, hold down Shift as you drag the Scale tool. For finer control, start dragging farther from the object’s reference point.

    Note:

    You can also scale by using the Free Transform tool.

Scale an object using the Transform panel

To maintain the original proportions of the object when using the Transform panel, make sure the Constrain Proportions icon  is selected.

  1. Select an object to scale. To scale both the frame and its content, use the Selection tool to select the frame. To scale the content without scaling its frame, direct-select the object. To scale a frame without scaling the content, direct-select the frame, and select all the anchor points.
  2. In the Transform or Control panel, do one of the following:
    • Choose a preset percentage value in the Scale X Percentage  or Scale Y Percentage  pop‑up menu.

    • Type a percentage value (such as 120%), or a specific distance (such as 10p) in the Scale X Percentage or Scale Y Percentage box, and then press Enter or Return.

Scale an object using the arrow keys

  1. Select or direct-select the object or frame.
  2. In the Transform panel, click in the Scale X Percentage  or Scale Y Percentage  box.
  3. Press the Up or Down Arrow Keys to scale the object by 1% increments. By pressing the Shift key at the same time as the arrow keys you can scale the object by increments of 10%.

If you use this method to scale up by a percentage and scale down by that same percentage, the object returns to the original scale value if Adjust Scaling Percentage is selected in General preferences. For example, if you scale a 20-mm circle up 10% and then down 10%, the circle returns to 20 millimeters (not 19.8 mm).

Scale an object using the Scale command

  1. Select an object to scale. To scale both the frame and its content, use the Selection tool to select the frame. To scale the content without scaling its frame, direct-select the object. To scale a frame without scaling the content, direct-select the frame, and select all the anchor points.
  2. Do one of the following to open the Scale dialog box:
    • Choose Object > Transform > Scale.

    • Double-click the Scale tool .

    • Select the Scale tool and Alt‑click (Windows) or Option-click (Mac OS) on or near the object to select a new reference point.

  3. Type a percentage value in the Scale X or Scale Y box.

    Note:

    To maintain the original proportions of the object when using the Transform panel, make sure the Constrain Proportions icon  is selected.

  4. Do any of the following:
    • To preview the effect before you apply it, select Preview.

    • To scale the object, click OK.

    • To scale a copy of the object, click Copy.

Determine how scaling is tracked

You can determine how scaling is tracked in the interface. If the Apply To Content preference option is selected in General preferences, scaling values are reset to 100% in the Transform panel after the object is scaled. If Adjust Scaling Percentage is selected, scaling values remain as specified (such as 125%).

With multiple objects selected, the scaling value will always display as 100%. However, you can select objects individually to see the applied effect of the transform (such as 125%) if Adjust Scaling Percentage is selected.

  1. Choose Edit > Preferences > General (Windows) or InDesign > Preferences > General (Mac OS).
  2. Under When Scaling, select Apply To Content or Adjust Scaling Percentage, and then click OK.

Note:

If Adjust Scaling Percentage is selected and you scale an object, you can choose Redefine Scaling As 100% from the Transform or Control panel menu to reset the scaling percentages to 100%.

Adjust stroke weight when objects are scaled

  • Select the Adjust Stroke Weight When Scaling option in the Transform or Control panel menu.

For example, if you scale a 4-point stroke by 200% when this option is turned on, the stroke weight becomes 8 points. If you turn off this option, the object doubles in size but its stroke weight remains 4 points.

If this option is turned on and you scale an object disproportionally, InDesign applies the smallest stroke weight to all sides. For example, suppose that you scale a selected object with a 4-point stroke only in the X direction by 200%. Instead of applying an 8-point stroke in the X direction and a 4-point stroke in the Y direction, InDesign applies the smaller value (4 points) to all sides.

Scalability of an effect

If you created an object, and apply an effect, the effect scales consistently in proportion to the object scaling. The proportion in which you scale the object, the effect gets scaled in the same proportion.

In preferences, General > Apply to content > Include Effects. Deselect this option if you want only the objects to scale and not the effects.

Preferences - Include Effects
Preferences - Include Effects

Or

Window > Object & Layout > Transform. From the flyout menu, select Adjust Effects when Scaling to turn the effect scalability on or off.

Adjust Scaling
Adjust Scaling

This works similar to the way stroke effects work. So you can scale effects just like you scale strokes.

Reset scaling value to 100%

In some cases, if you want to reset the Scale X and Scale Y values of an object to 100% without resizing the object. For example, if you opened a document from a previous version of InDesign that has non-100% scaling values, or you have scaled an object with the Adjust Scaling Percentage preference setting selected. When you choose this command, the scaling values for all selected frames are reset to 100%. Choosing this command does not change the size or appearance of objects.

  1. Select one or more objects that have non-100% scaling values.

    This command is dimmed if you direct-select an imported image or if an object has 100% scaling values.

  2. Choose Redefine Scaling As 100% from the Transform or Control panel menu.

Note:

Choosing this command may result in unexpected behavior with objects in transformed groups.

Reflect (flip) objects

Reflecting an object flips the object across an invisible axis at the reference point you specify. (See Change transformation settings.)

Original object (top) reflected using Flip Horizontal (middle) and Flip Vertical (bottom)
Original object (top) reflected using Flip Horizontal (middle) and Flip Vertical (bottom)

The flip/rotate indicator (P) in the middle of the Control panel appears white with a black outline if an object is flipped. If the object is not flipped, the indicator is solid black.

  1. Select an object to flip. To flip both the frame and its content, use the Selection tool to select the frame. To flip the content without its frame, direct-select the object. To flip a frame without its content, direct-select the frame, and select all the anchor points.
  2. Do one of the following:
    • To reflect using the reference point as a horizontal axis, click the Flip Horizontal button in the Control panel.

    • To reflect using the reference point as a vertical axis, click the Flip Vertical button in the Control panel.

    Note:

    You can also reflect objects by using the Selection tool or Free Transform tool to pull one side of an object’s bounding box past the opposite side, or by typing negative values into the Scale X Percentage or Scale Y Percentage options in the Transform or Control panel.

Shear (skew) objects

Shearing an object slants or skews it along its horizontal or vertical axis, and can also rotate both of the object’s axes. Shearing is useful for:

  • Simulating some types of perspective, such as isometric projection.

  • Slanting a text frame.

  • Creating cast shadows when you shear a copy of an object.

Shear an object

  1. Select an object to shear. To shear both the frame and its content, use the Selection tool to select the frame. To shear the content without its frame, click the Content Grabber to direct-select the object. To shear a frame without scaling the content, direct-select the frame, and select all the anchor points.
  2. Do one of the following:
    • To shear selected objects by dragging, select the Shear tool . Then position the Shear tool away from the reference point, and drag. Shift-drag to constrain shearing to a perpendicular vertical or horizontal axis. If you start to drag at a non-perpendicular angle and then hold down the Shift key, shearing is constrained to that angle.


      Object being sheared by dragging Shear tool with reference point placed in center

    Note:

    If you want to use a different reference point for the shearing, click where you want the reference point to appear.

    • To shear using a preset value, in the Transform or Control panel, choose an angle from the Shear pop‑up  menu.
    • To shear using a specific value, in the Transform or Control panel, type a positive or negative angle in the Shear box, and press Enter or Return.
    • To create a copy of the object with the new shear applied to the copy, type a value in the Shear box in the Transform panel, and then hold down Alt (Windows) or Option (Mac OS) as press Enter.

When you shear a single object, the specified value remains displayed in the Transform or Control panel. When you shear multiple objects, the Shear Angle value is reset to 0 degrees, even though the objects are sheared.

Note:

You can also shear by using the Free Transform tool.

Shear an object using the Shear command

You can shear an object by a specific amount by using the Shear command. This command also lets you shear a copy of the selected object, leaving the original in place.

  1. Select an object to shear. To shear both the frame and its content, use the Selection tool to select the frame. To shear the content without its frame, click the Content Grabber to direct-select the object. To shear a frame without scaling the content, direct-select the frame, and select all the anchor points.
  2. Do one of the following to open the Shear dialog box:
    • Select Object > Transform > Shear.

    • Double-click the Shear tool .

    • Select the Shear tool and Alt‑click (Windows) or Option-click (Mac OS) to select a new reference point.

  3. Type a new shear angle.

    The shear angle is the amount of slant to be applied to the object, relative to a line perpendicular to the shear axis. (Shear angle is calculated clockwise from the current axis.)

  4. Specify the axis along which the object is to be sheared. You can shear an object along a horizontal or vertical axis.
  5. Do any of the following:
    • To preview the effect before you apply it, select Preview.

    • To shear the object, click OK.

    • To shear a copy of the object, click Copy.

Repeat transformations

You can repeat transformations, such as moving, scaling, rotating, resizing, reflecting, shearing, and fitting. You can repeat either a single transformation or a sequence of transformations, and you can apply those transformations to more than one object at a time. InDesign remembers all transformations until you select a different object or perform a different task.

Note:

Not all transformations are recorded. For example, modifying a path or its points is not recorded as a transformation.

  1. Select one or more objects, and perform all the transformations you want to repeat.
  2. Select the object or objects to which you want to apply the same transformations.
  3. Choose Object > Transform Again and then select one of the following options:

    Transform Again

    Applies the last single transform operation to the selection.

    Transform Again Individually

    Applies the last single transform operation to each selected object individually, rather than as a group.

    Transform Sequence Again

    Applies the last sequence of transform operations to the selection.

    Transform Sequence Again Individually

    Applies the last sequence of transform operations to each selected object individually.

Clear transformations

  1. Select the object or objects that have been transformed.
  2. Choose Clear Transformations from the Transform or Control panel menu.

    Unless all values are the default values, clearing transformations results in a change of appearance for the objects.

    Note:

    If the Scale values were reset at 100%, clearing the transformations will not change the scale.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy