Update to InDesign CC available

For more information, see the New features summary.


This release contains several enhancements and new features that provide you with pixel-perfect control over design and typography for publishing to all media. With Adobe Digital Publishing Suite, you can design and publish for tablet devices using the familiar InDesign workflows.

Alternate layouts and Liquid Layout page rules, give you the flexibility to design for multiple page sizes, orientations, or aspect ratios.

Alternate layouts

Use Alternate Layouts if you require different page sizes for print or digital publishing within the same document. You can use it to create different sizes of a print advertisement. Or to design the horizontal and vertical layouts for devices such as the Apple iPad or Android tablets.

Alternate Layouts
Alternate layouts and the updated Pages panel

Used in combination with Liquid Layout, you can significantly reduce the amount of manual work required to re-layout content for every new page size and orientation. You can also redefine liquid page rules, create links to original stories, automatically copy text styles to a new style group, and activate Smart Text Reflow to repaginate the story in the new page size.

To create an alternate layout, do one of the following:

  • Choose Layout > Create Alternate Layout
  • Choose Create Alternate Layout from the Pages panel menu

Liquid layouts

Liquid layouts
Liquid Layout

Liquid layouts make it easier to design content for multiple page sizes, orientations, or devices. Apply liquid page rules to determine how objects on a page are adapted when you create an alternate layout and change the size, orientation, or aspect ratio.

Use Liquid page rules to adapt layouts when using the Alternate Layout feature. Select the Page tool and click a page to select it. Then choose a liquid page rule from the control bar. You can also use the Liquid Layouts panel (Window > Interactive > Liquid Layout).

Note:

Using the Page tool, you can drag the corners and center points of the page to preview the Liquid layout.

For more information see Liquid Layouts.

Linked content

Use linked content functionality to duplicate page items, and place them on other pages. Both inter-document and intra-document links are supported. You can place and link stories, text frames, page items, interactive objects as well as groups. You can link content, with or without the frames that they are contained in. You can customize the link options to control the update aspects.

While links are useful for all types of publications, they are almost essential when you're working on multi-device publications. Alternate Layouts also use this functionality to link stories in the generated layouts.

To place and link page items, you can use the following:

  • Place and Link command (Edit > Place and Link)
  • Content Collector and Content Placer tools

For more information see Linked content.

For a quick overview, see Linked content video by Lynda.com.

Content collector and placer tools

Content Collector and Placer tools let you duplicate objects and place them on open InDesign documents. As content is collected, it is displayed in the Content Conveyor. Use Content Conveyor to easily and quickly place and link multiple page items within and across any open documents.

Click in the toolbox to open the Content Conveyor.

  • Use Content Collector tool to select an item and add it to the conveyor
  • Use Content Placer to place page items on a page
Content Conveyor
Content Conveyor

Custom style mapping

Text styles (paragraph, character, table, cell) or style groups can be mapped to different styles while linking. In the Link Options dialog box (Links panel > Link Options), enable Define Custom Style Mapping and then click Settings.

Custom style mapping comes in handy, for example, when you want to use sans serif fonts for digital and serif fonts for print publications. Or if you want, vary the text style between the horizontal and vertical layouts.

In the Link Options dialog box, enable Define Custom Style Mapping and then click Settings.

For more information, see Custom style mapping.

Preserve local edits

Use Preserve Local Edits option to modify linked content. Often, you would like the linked item to differ slightly from the original item. For example, if you place an image and then resize the frame or add a stroke to the frame, you can preserve these changes on updating the link.

In the Link Options dialog box (Links panel menu), select the options under preserve local edits.

Link Options dialog
Link Options dialog

For more information, see Preserve local edits.

Digital publishing

New document presets

In addition to the Web and Print intents, you can specify Digital Publishing intent while creating a document (File > New). You can specify sizes (including custom sizes) and orientations for several common devices. When you choose the Digital Publishing intent, page size is set to that of the chosen device size in pixels. The Primary Text Frame option is also enabled.

If you want more control on device size and orientation, create a Document Preset or specify a custom page size.

Primary text frame

You can now designate a text frame on the master page as the primary text frame. When you apply a new master page to a layout page, the story in the primary text frame flows into the primary text frame. Primary Text Frames are automatically overridden on layout pages, so that you no longer need to override them before adding text.

Primary text frame indicator
Primary text frame indicator

To designate a primary text frame, open a master page and do one of the following:

  • Click the symbol near the left-upper corner of the text frame
  • Right-click on text frame and choose Primary Text Frame

Note: Only a single text frame can be designated as primary on a master page.

Text frame fitting options

Flexible width columns

You can use the Flexible width option to adjust the number and width of columns as the text frame is resized. Columns are automatically added or deleted when the maximum column width is reached as the text frame is resized.

Choose Flexible Width from the Columns drop down list in the Text Frame Options dialog box (Object > Text Frame Options)

Persistent text frame fitting options

Auto-size text frame options make it possible to set up a text frame so that it is automatically resized when you add, delete, or edit text.
To access the Auto-size options, do the following:

  1. Select a text frame and choose Object > Text Frame Options
  2. Click Auto-size.
Auto Size options
Auto Size options

Packaging and preflight

The Package functionality (File > Package) now includes Digital Publishing Suite assets in Folio Overlays. If you've placed links from other InDesign documents, they are included as well.

Additional preflight profile for Digital Publishing is also available (Window > Output > Preflight).

Discoverable Folio Builder and Folio Overlay panels

The Folio Builder and Folio Overlay panels are located under the Window menu.

  • Folio Builder: Choose Window > Folio Builder
  • Folio Overlay: Choose Window > Folio Overlay

Note:

In InDesign CS5.5, Folio Overlay panel was called Overlay Creator, and these panels were available under the Windows > Extensions menu.

Digital publishing workspace

Use the Digital Publishing workspace to display all the tools and panels required for working on digital publications. Select Digital Publishing workspace from the workspace switcher in the Application bar.

EPUB and HTML5

EPUB Export workflows have been simplified, and you can now choose an EPUB version to export to. The Export to EPUB dialog box has been reorganized and simplified.

Watch this video by Lynda.com for a quick overview of how to Export to EPUB.

EPUB2 enhancements

Several enhancements were made in the EPUB2 export in InDesign CS6, to provide better control and efficiencies while export. EPUB2 remains the most dominant EPUB standard with a majority of devices and readers supporting it.

  • Specify options to float a frame either left or right. These options can be specified using the  Object Export Options.
  • Additional inline and anchored text frame attributes are translated to the CSS: Size, border style and width, fill color, padding (inset on text frame), and margin (on text wrap)
  • Specify different values for each margins in an EPUB
  • Link to multiple custom CSS files
  • Split an EPUB into smaller files based on export tags specified in paragraph styles.
  • New XHTML document is created when you link to an external eBook cover file
  • Support for converting InDesign table cell styles to CSS in the exported EPUB
  • EPUB table dimension includes attributes for column width and row minimum height
  • InDesign custom bullet and numbering marker strings now exported in EPUB
  • Added support for Japanese Ruby: font, size, and color

EPUB3

IDPF approved the EPUB3 standard in October, 2011. This format supports, among others, audio, video, JavaScript, and japanese vertical text. EPUB3 export for InDesign supports the following:

  • EPUB3 package format
  • Linking to multiple external JavaScripts
  • Vertical Japanese text
  • Audio and video tags
  • Placed HTML and Adobe Edge HTML animations during export

For more information see, Export content for EPUB.

NOTE: EPUB3 validators may report errors if placed HTML or HTML animations are not fully XHTML-compliant. However, EPUB3 viewers may still function correctly. Adobe Systems cannot guarantee how placed HTML or Adobe Edge animations will perform in third-party EPUB3 viewers.

EPUB3 with layout

EPUB3 with Layout is an experimental format that builds on the EPUB 3.0 specification. Support for alternate and adaptive layouts including: multiple columns, text wrap, and liquid layouts has been added. Using this technology it is possible to create true adaptive layouts that look good on all devices and screen sizes and minimizes autoflow issues.

Adobe has submitted this technology to the IDPF for consideration as an extension of the EPUB3 specification. At the time of CS6 launch, there are no publicly available EPUB viewers that support this feature.

HTML

Enhanced Export to HTML supports the following:

  • External CSS files for style information
  • Fallback support using Adobe Flash Player for placed video
  • Placed HTML and Adobe Edge animations
  • Linking to multiple custom CSS files
  • Linking to multiple custom external javascripts

Interactivity

Create PDF forms

You can design forms in InDesign and export them directly to PDF. InDesign now supports form fields and additional form actions. The Buttons and Forms library (Window > Interactive > Buttons and Forms) contains items that you can use to design interactive forms. You can also specify tab orders and tool tips without post-processing in Adobe Acrobat. Accessibility tags are also added to the exported PDF form.

Watch Create PDF forms video by Lynda.com for a quick overview.

Buttons and Forms panel
Buttons and Forms panel with PDF form components

  1. Choose Window > Interactive > Buttons and Forms to display the form components, and place them on the page. You can then modify them as desired, with custom labels, different colors, or different sizes.
  2. From the Buttons and Forms panel, choose Actions to apply a form action to the form fields.

For more information on adding form fields and specifying tab order, see Forms.

Export interactive PDF as pages

You can now export interactive PDFs as either spreads or pages. In the Export to Interactive PDF dialog box (File > Export), choose either Pages or Spreads. The default selection is spreads.

Place Adobe Edge designs

Use the new Adobe® Edge web motion and interaction design tool to bring animated content to websites, using web standards like HTML5, JavaScript, and CSS3. You can place an Adobe Edge package on your layout to add interactivity and animation to your Folio or HTML export.

  • Choose File > Place and navigate to the file (.OAM) to place it. The design is placed and InDesign fetches a poster image.

When you preview the folio or export to HTML, the placed Edge design plays.

Note:

Older versions of Adobe Edge do not support exporting to OAM. Zip the output folder and rename the extension to OAM.

Embed HTML snippets

You can embed common HTML elements, such as embed codes for YouTube videos or Google Maps. You can copy the HTML embed code and paste in into InDesign

  • Choose Object > Insert HTML, and paste the HTML code
  • Copy the code to the clipboard and paste it on your layout

InDesign automatically fetches a poster image. The embedded object is not interactive in the InDesign layout. Export the layout to HTML or preview the folio (File > Folio Preview)  to interact with the object.

Productivity enhancements

Split window

To compare two different layouts in the same document, you can split the active window. Use the two panes to view alternative layouts side by side.

Split layout view
Split layout view

  • Click the button in the lower-right corner of the document window
  • Choose Window > Arrange > Split Window
  • From the Layout menu in the Pages panel, choose Split Window to Compare Layouts

Recently used fonts

To find fonts easily and reduce scrolling, view the recently used fonts  at the top of the Font pop-up and Type > Fonts menus.

  • Specify the number of recent fonts to display under Edit > Preferences > Type > Number of recent fonts to display.
  • By default the recently used fonts are displayed in chronological order. To display them in alphabetical order, choose Edit > Preferences > Type > Sort Recent Fonts List Alphabetically.

Align to key object

An additional option is available for distributing objects in the Align panel.

  1. Select the objects to distribute, and in the Align panel (Windows > Align) choose Align To Key Object from the Align To list.
  2. The key object appears with a thick border. Click another object to select it as the key object.

Save backward to earlier versions

To open an InDesign document in a previous version, or to send it to someone who has not upgraded yet, save the document in the InDesign Markup Language (IDML) format. IDML files are supported by InDesign CS4 or later. Features not supported by the earlier version will not work.

The option to save documents to earlier versions is now available from the Save and Save As dialog boxes.

  1. Choose File > Save As
  2. From the Save As Type list, select InDesign CS4 or later (IDML)

Export and proof grayscale PDFs

You can now proof and export designs as grayscale PDFs. For example, use this feature to quickly export your layout for grayscale printing. The digital publication remains full color, and  you can avoid maintaining separate layouts for grayscale and color outputs.

Use Proof Setup (View > Proof Setup) to specify grayscale proof options, and choose a Dot Gain or Gamma destination. After you've setup the proof, choose View > Proof Colors to toggle between grayscale and color output.

You can also export a grayscale PDF from within InDesign. All page items, irrespective of their original color space, are converted to grayscale while exporting to PDF.

  1. Choose File > Export and select Adobe PDF (Print).
  2. In the export options dialog box, click the Output tab.
  3. Under Color Conversion, choose Convert To Destination.
  4. Under Destination, choose a Dot Gain or Gray Gamma destination.

Note:

Grayscale destinations are not available under the PDF/X-1a standard. The standard supports only CMYK intents. Similarly, PDF/X-2 or PDF/X-3 standards do not support Gamma Gray destinations.

Complex calculations in panels and dialog boxes

You can now perform complex calculations within the text fields in panels and dialog boxes. Enter a mathematical expression using mathematical operators, for example, 120p0/2 + 10.

Export to PNG

To export a selection or a range of pages as an image, choose File > Export and then select PNG from the Save As Type list. Use the Export Options dialog box to specify what to export and the export settings.

Export enhancements

  • SWF Export: The Export Options dialog box displays Font license information.
  • Export For: The File > Export For menu has been removed. All supported options are consolidated in the Save As Type list in the Export dialog box.
  • Options for exporting to Buzzword, SVG and SVG compressed are no longer available.

Language support

Adobe World-Ready composers and support for open-source HunSpell dictionaries enable you to use several additional languages using InDesign.

Placeholder text with specified alphabet

You can enter placeholder text Roman, Arabic, Hebrew, Chinese among others.

To specify the language of placeholder text, press Ctrl (Windows) or Command (Mac OS) when you choose Type > Fill With Placeholder Text. In the Fill Options dialog box, choose an alphabet and click OK.

HunSpell enhancements

For most languages, InDesign ships with open-source HunSpell dictionaries and HunSpell is the default dictionary provider. You can download and install additional spelling and hyphenation dictionaries for other languages from the OpenOffice website.

To use InDesign with additional languages, choose Edit > Preferences > Dictionary and then click HunSpell Info.

Indic support

Adobe World-Ready Composer (WRC) provides correct word shaping for many of the non-Western scripts, such as Devanagari. Adobe World-Ready composers in the International English version of InDesign, support several indian languages including Hindi, Marathi, Gujarati, Tamil, Punjabi, Bengali, Telugu, Oriya, Malayalam, and Kannada.

Hunspell spelling and hyphenation dictionaries are inluded, and so is the Adobe Devanagari font family.

Enable the Adobe World-Ready Composer through a paragraph style (Paragraph Style > Justification > Composer) or using the Paragraph panel menu.

Set indic preferences to work on indic scripts, and correctly import content into InDesign.

  1. Choose Window > Utilities > Scripts
  2. Double-click indicPreferences.js
  3. Open a new document or restart InDesign

Middle Eastern support

InDesign CS6 is also available in middle eastern and north african editions. It adds support for Arabic and Hebrew, and provides several features for working with right-to-left, bi-directional scripts, and other language-specific features. Enhanced functionality includes support for tables in the Story Editor, improved Kashida justification, enhanced diacritic positioning, and other text-handling improvements.

See Working with Arabic and Hebrew for more details.

Extension Manager CS6

With Extension Manager CS6, you can create, edit, activate, import, and export extension sets. Extension Manager CS6 supports the following:

  • User-level extension installation
  • Search and filter extensions
  • MXP to ZXP conversion
  • Extension dependency support
  • Installing extensions when multiple languages of a product are installed
  • Display additional extension information

For more information on using Extension Manager CS6, see Extension Manager CS6

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy