Användarhandbok Avbryt

SVG

  1. Användarhandbok för Illustrator
  2. Lär känna Illustrator
    1. Introduktion till Illustrator
      1. Nyheter i Illustrator
      2. Vanliga frågor
      3. Systemkrav för Illustrator
      4. Illustrator för Apple Silicon
    2. Arbetsyta
      1. Allmänt om arbetsytan
      2. Lär dig snabbare med panelen Upptäck i Illustrator
      3. Skapa dokument
      4. Verktygsfält
      5. Standardkortkommandon
      6. Anpassa kortkommandon
      7. Introduktion till ritytor
      8. Hantera ritytor
      9. Anpassa arbetsytan
      10. Egenskapspanelen
      11. Ange inställningar
      12. Toucharbetsytan
      13. Stöd för Microsoft Surface Dial i Illustrator
      14. Ångra redigeringar och hantera designhistorik
      15. Rotera vy
      16. Linjaler, stödraster och stödlinjer
      17. Tillgänglighet i Illustrator
      18. Säkert läge
      19. Visa illustrationer
      20. Använda Touch Bar med Illustrator
      21. Filer och mallar
    3. Verktyg i Illustrator
      1. Verktygsöversikt
      2. Markeringsverktyg
        1. Markering
        2. Direktmarkering
        3. Gruppmarkering
        4. Trollstav
        5. Lasso
        6. Rityta
      3. Navigeringsverktyg
        1. Hand
        2. Rotera vyn
        3. Zooma
      4. Målningsverktyg
        1. Övertoning
        2. Nät
        3. Formbyggaren
      5. Textverktyg
        1. Text
        2. Text på bana
        3. Lodrät text
      6. Ritverktyg
        1. Ritstift
        2. Lägg till fästpunkt
        3. Ta bort fästpunkt
        4. Fästpunkt
        5. Krökning
        6. Linjesegment
        7. Rektangel
        8. Rundad rektangel
        9. Oval
        10. Polygon
        11. Stjärna
        12. Pensel
        13. Plumppensel
        14. Penna
        15. Shaper
        16. Segment
      7. Ändringsverktyg
        1. Rotera
        2. Spegla
        3. Skalförändra
        4. Skeva
        5. Bredd
        6. Omforma fritt
        7. Pipett
        8. Övergång
        9. Suddgummi
        10. Sax
        11. Mått
    4. Generativ AI (inte tillgängligt i Fastlandskina)
      1. Generera vektorgrafik med en textbeskrivning
      2. Gör om färgerna i ditt alster med en textbeskrivning
    5. Snabbåtgärder
      1. Text i retrostil
      2. Text i neonljus
      3. Gammaldags text
      4. Ändra färg
      5. Konvertera en skiss till en vektorbild
  3. Illustrator på webben (beta)
    1. Översikt av Illustrator på webben (beta)
    2. Vanliga frågor om Illustrator på webben (beta)
    3. Vanliga frågor om felsökning
    4. Kortkommandon för Illustrator på webben (beta)
    5. Skapa och kombinera former på webben
    6. Lägg till och redigera text på webben
    7. Använd färger och övertoningar på webben
    8. Rita och redigera banor på webben
    9. Arbeta med molndokument på webben
    10. Bjuda in medarbetare att redigera på webben
  4. Illustrator på iPad
    1. Introduktion till Illustrator på iPad
      1. Illustrator på iPad – översikt
      2. Vanliga frågor om Illustrator på iPad
      3. Systemkrav | Illustrator på iPad
      4. Vad du kan och inte kan göra med Illustrator på iPad
    2. Arbetsyta
      1. Illustrator på iPad-arbetsytan
      2. Touchgenvägar och touchgester
      3. Kortkommandon för Illustrator på iPad
      4. Hantera appinställningarna
    3. Dokument
      1. Arbeta med dokument i Illustrator på iPad
      2. Importera Photoshop- och Fresco-dokument
    4. Markera och ordna objekt
      1. Skapa upprepade objekt
      2. Övergångsobjekt
    5. Rita
      1. Rita och redigera banor
      2. Rita och redigera former
    6. Text
      1. Arbeta med text och teckensnitt
      2. Skapa textdesign längs en bana
      3. Lägg till egna teckensnitt
    7. Arbeta med bilder
      1. Vektorisera rasterbilder
    8. Färg
      1. Använda färger och övertoningar
  5. Molndokument
    1. Grunderna
      1. Arbeta med Illustrator-molndokument
      2. Dela och samarbeta om Illustrator-molndokument
      3. Dela dokument för granskning
      4. Uppgradera molnlagringen för Adobe Illustrator
      5. Illustrator-molndokument | Vanliga frågor
    2. Felsökning
      1. Felsöka problem med att skapa eller spara molndokument i Illustrator
      2. Felsöka problem med molndokument i Illustrator
  6. Lägga till och redigera innehåll
    1. Rita och ta mått
      1. Teckningens grunder
      2. Redigera banor
      3. Skapa skarpa bilder
      4. Rita med pennan, krökningsverktyget eller pennverktyget
      5. Rita enkla linjer och former
      6. Rita rektangulära och polära stödraster
      7. Rita och redigera överstrålningar
      8. Bildkalkering
      9. Förenkla en bana
      10. Symbolverktyg och symboluppsättningar
      11. Justera bansegment
      12. Designa en blomma i fem enkla steg
      13. Skapa och redigera ett perspektivstödraster
      14. Rita och ändra objekt i ett perspektivstödraster
      15. Använd objekt som symboler för upprepad användning
      16. Rita pixeljusterade banor för webbarbetsflöden
      17. Mät och rita upp mått
    2. 3D-objekt och material
      1. Adobe 3D-effekter i Illustrator
      2. Skapa 3D-grafik
      3. Mappa en teckning över 3D-objekt
      4. Skapa 3D-text
      5. Skapa 3D-objekt
    3. Färg
      1. Om färg
      2. Välj färger
      3. Använda och skapa färgrutor
      4. Justera färger
      5. Använda temapanelen i Adobe Color
      6. Färggrupper (harmonier)
      7. Färgtemapanelen
      8. Färga om teckningar
    4. Måla
      1. Om färgläggning
      2. Färglägg med fyllningar och linjer
      3. Direktfärgsgrupper
      4. Övertoningar
      5. Penslar
      6. Genomskinlighet och blandningslägen
      7. Tillämpa linjer på ett objekt
      8. Skapa och redigera mönster
      9. Nät
      10. Mönster
    5. Markera och ordna objekt
      1. Markera objekt
      2. Lager
      3. Gruppera och expandera objekt
      4. Flytta, justera och fördela objekt
      5. Stapla objekt    
      6. Låsa, dölja och radera objekt
      7. Kopiera och duplicera objekt
      8. Rotera och spegla objekt
      9. Sammanfläta objekt
      10. Skapa realistiska konstmodeller
    6. Ändra form på objekt
      1. Beskär bilder
      2. Omforma objekt
      3. Kombinera objekt
      4. Skära ut, dela och beskära objekt
      5. Tänjning av marionett
      6. Skalförändra, skeva och förvränga objekt
      7. Övergångsobjekt
      8. Omforma med hjälp av omslag
      9. Ändra form på objekt med effekter
      10. Skapa nya former med verktygen Shaper och Formbyggare
      11. Arbeta med live-hörn
      12. Förbättrade arbetsflöden för att ändra form på objekt med stöd för touch
      13. Redigera urklippsmasker
      14. Live-former
      15. Skapa former med hjälp av verktyget Formbyggare
      16. Global redigering
    7. Format
      1. Lägg till text och jobba med textobjekt
      2. Skapa punktlistor och numrerade listor
      3. Hantera textområde
      4. Teckensnitt och typografi
      5. Konvertera text i bilder till redigerbar text
      6. Enkel formatering av text
      7. Avancerad formatering av text
      8. Importera och exportera text
      9. Formatera stycken
      10. Specialtecken
      11. Skapa text på en bana
      12. Tecken- och styckeformat
      13. Flikar
      14. Sök efter saknade teckensnitt (Typekit-arbetsflöde)
      15. Arabisk och hebreisk text
      16. Teckensnitt | Vanliga frågor och felsökningstips
      17. Skapa 3D-texteffekter
      18. Kreativ typografisk design
      19. Skalförändra och rotera text
      20. Rad- och teckenavstånd
      21. Avstavning och radbrytningar
      22. Stavnings- och språkordlistor
      23. Formatera asiatiska tecken
      24. Dispositioner för asiatisk skrift
      25. Skapa textdesign med övergångar mellan objekt
      26. Skapa en textaffisch med Bildkalkering
    8. Skapa specialeffekter
      1. Arbeta med effekter
      2. Grafikformat
      3. Utseendeattribut
      4. Skapa skisser och mosaik
      5. Skuggor, glöd och ludd
      6. Sammanfattning av effekter
    9. Webbgrafik
      1. Bästa sätten att skapa webbgrafik
      2. Diagram
      3. SVG
      4. Segment och bildscheman
  7. Importera, exportera och spara
    1. Importera
      1. Montera flera filer
      2. Hantera länkade och inbäddade filer
      3. Länkinformation
      4. Ångra inbäddning av bilder
      5. Importera teckningar från Photoshop
      6. Importera bitmappsbilder
      7. Importera Adobe PDF-filer
      8. Importera EPS-, DCS- och AutoCAD-filer
    2. Creative Cloud Libraries i Illustrator 
      1. Creative Cloud Libraries i Illustrator
    3. Spara
      1. Spara teckningar
    4. Exportera
      1. Använda Illustrator-bilder i Photoshop
      2. Exportera teckningar
      3. Samla resurser och exportera gruppvis
      4. Packa filer
      5. Skapa Adobe PDF-filer
      6. Extrahera CSS | Illustrator CC
      7. Adobe PDF-alternativ
      8. Panelen Dokumentinfo
  8. Skriva ut
    1. Förbereda för utskrift
      1. Ange utskriftsinställningar för dokument
      2. Ändra sidstorlek och orientering
      3. Ange skärmärken för beskärning eller justering
      4. Kom igång med stora arbetsytor
    2. Skriva ut
      1. Övertryck
      2. Skriva ut med färghantering
      3. PostScript-utskrift
      4. Utskriftsförinställningar
      5. Utskriftsmärken och utfall
      6. Skriva ut och spara genomskinliga teckningar
      7. Svällning
      8. Skriva ut färgseparationer
      9. Skriva ut övertoningar, nätövertoningar och färgövergångar
      10. Vitt övertryck
  9. Automatisera uppgifter
    1. Datasammanfogning med hjälp av panelen Variabler
    2. Automatisering med skript
    3. Automatisering med funktionsmakron
  10. Felsökning 
    1. Kända fel
    2. Problem med krascher
    3. Återställ filer efter kraschar
    4. Filproblem
    5. Filformat som stöds
    6. Problem med GPU-enhetsdrivrutiner
    7. Problem med Wacom-enheter
    8. Problem med DLL-filer
    9. Minnesproblem
    10. Problem med preferensfilen
    11. Problem med teckensnitt
    12. Skrivarproblem
    13. Skicka en kraschrapport till Adobe
    14. Förbättra prestandan för Illustrator

Lär dig arbeta med SVG för att skapa webbgrafik med XML och JavaScript som svarar på användaråtgärder med avancerade effekter, t.ex. markeringar, knappbeskrivningar, ljud och animeringar.

Om SVG

SVG är ett vektorformat som beskriver bilder som former, banor, text och filtereffekter. De färdiga filerna är komprimerade och ger högkvalitativ grafik på webben, i tryck och till och med på resursbegränsade, handhållna enheter, till skillnad från GIF, JPEG, WBMP och PNG, som är stora. Användaren kan göra en SVG-bild på skärmen större utan att skärpa, detaljer eller klarhet förloras. Dessutom har SVG gott stöd för text och färger vilket garanterar att användarna ser bilderna som de visas på Illustrator-ritytan.

SVG-formatet är helt XML-baserat och är fördelaktigt för utvecklare och användare. 

Du kan spara teckningar i SVG-format genom att använda kommandona Spara, Spara som, Spara kopia och Spara för webben och enheter. Använd kommandona Spara, Spara som och Spara kopia om du vill få tillgång till alla SVG-exportalternativ. Med kommandot Spara för webben och enheter får du tillgång till vissa SVG-exportalternativ som kan användas för webborienterat arbete.

Använda SVG-effekter

Du kan använda SVG-effekter om du vill lägga till grafiska egenskaper, t.ex. skuggor, i teckningar. SVG-effekter skiljer sig från motsvarande bitmappseffekter eftersom de är XML-baserade och oberoende av upplösning. En SVG-effekt är egentligen inget annat än en serie XML-egenskaper som beskriver olika matematiska operationer. Resultateffekten återges i målobjektet i stället för i källgrafiken.

I Illustrator finns en standarduppsättning med SVG-effekter. Du kan använda effekterna tillsammans med deras standardegenskaper, redigera XML-koden och skapa anpassade effekter och skriva nya SVG-effekter.

Obs!

Om du vill ändra SVG-standardfiltren i Illustrator använder du en textredigerare och redigerar filen Adobe SVG-filter. svg i mappen Documents and Settings/<användarkatalog>/Application Data/Adobe/Adobe Illustrator <versionsnummer> Settings/<plats>. Du kan ändra befintliga filterdefinitioner, ta bort filterdefinitioner och lägga till nya filterdefinitioner.

  1. Markera ett objekt eller en grupp (eller ange ett lager som mål på panelen Lager).
  2. Välj något av följande alternativ för att använda en effekt:

    Med standardinställningar

    Gå till Effekt > SVG-filter > Tillämpa SVG-filter.

    Med anpassade inställningar

    1. Gå till Effekt > SVG-filter > Tillämpa SVG-filter.

    2. Markera effekten i dialogrutan och välj sedan Redigera SVG-filter  . Redigera standardkoden och välj OK.

    Skapa och tillämpa en ny effekt

    1. Gå till Effekt > SVG-filter > Tillämpa SVG-filter.

    2. Markera effekten i dialogrutan och välj sedan Nytt SVG-filter  . Ange den nya koden och välj OK.

När du tillämpar en SVG-filtereffekt visas en rastrerad version av effekten på ritytan. Du kan styra upplösningen i den här förhandsvisningsbilden genom att ändra dokumentets inställning för rasterupplösning.

Obs!

En SVG-effekt måste vara den sista effekten när flera effekter används i ett objekt. Det innebär att den måste visas längst ned på panelen Utseende (alldeles ovanför Genomskinlighet). Om andra effekter används efter en SVG-effekt skapas ett rasterobjekt.

Importera effekter från en SVG-fil

  1. Välj Effekt > SVG-filter > Importera SVG-filter.

  2. Markera den SVG-fil som du vill importera effekter från och välj Öppna.

Panelen SVG-interaktivitet – översikt

Med panelen SVG-interaktivitet kan du visa alla händelser och JavaScript-filer som hör till den aktuella filen.
Du använder panelen SVG-interaktivitet (Fönster > SVG-interaktivitet) om du vill lägga till interaktivitet i teckningar som ska exporteras till en webbläsare för visning. Genom att skapa en händelse som startar ett JavaScript-kommando kan du snabbt skapa rörelse på en webbsida när användaren utför en åtgärd, t.ex. flyttar pekaren över ett objekt.

Ta bort en händelse från panelen SVG-interaktivitet

Du kan använda panelen SVG-interaktivitet för att radera en eller alla händelser.

Radera en händelse

  • Markera händelsen och välj Ta bort markerad uppgift  .

Radera alla händelser

  • Välj Radera alla händelser på panelmenyn  

Visa, lägga till och ta bort händelser som är länkade till en fil

Välj Länka JavaScript-filer   och välj Lägg till för att lägga till ytterligare JavaScript-filer. Om du vill ta bort den valda JavaScript-posten ska du välja Ta bort.

Lägga till SVG-interaktivitet i teckningar

  1. Markera en händelse på panelen SVG-interaktivitet. (Se SVG-händelser.)

  2. Ange motsvarande JavaScript och tryck på Enter.

SVG-händelser

onfocusin

Startar åtgärden när elementet fokuseras, t.ex. när det markeras med pekaren.

onfocusout

Startar åtgärden när elementet inte längre fokuseras, t.ex. när ett annat element fokuseras i stället).

onactivate

Startar åtgärden med ett musklick eller en tangenttryckning, beroende på SVG-elementet.

onmousedown

Startar åtgärden när musknappen trycks ned över ett element.

onmouseup

Startar åtgärden när musknappen släpps upp över ett element.

onclick

Startar åtgärden när användaren klickar på ett element med musen.

onmouseover

Startar åtgärden när pekaren flyttas till ett element.

onmousemove

Startar åtgärden när pekaren är över ett element.

onmouseout

Startar åtgärden när pekaren flyttas bort från ett element.

onkeydown

Startar åtgärden när en tangent trycks ned.

onkeypress

Startar åtgärden medan en tangent trycks ned.

onkeyup

Startar åtgärden när en tangent släpps upp.

onload

Startar åtgärden efter att SVG-dokumentet har tolkats av webbläsaren. Använd den här händelsen om du vill anropa engångsfunktioner för initiering.

onerror

Startar åtgärden när ett element inte läses in på rätt sätt eller om andra fel uppstår.

onabort

Startar åtgärden när sidinläsningen avbryts innan elementet hämtats.

onunload

Startar åtgärden när SVG-dokumentet tas bort från ett fönster eller en bildruta.

onzoom

Startar åtgärden när zoomnivån ändras i dokumentet.

onresize

Startar åtgärden när storleken på dokumentvyn ändras.

onscroll

Startar åtgärden när dokumentvyn rullas eller panoreras.

Tips om att skapa SVG-filer

  • Använd lager om du vill lägga till struktur i en SVG-fil. Varje lager görs om till ett gruppelement (<g>) när du sparar verket i SVG-format. (Ett lager med namnet Knapp1 blir t.ex. <g id="Knapp1_ver3.0"> i SVG-filen.) Kapslade lager blir SVG-kapslade grupper och dolda lager bevaras med SVG-formategenskapen ”display=none”.

  • Om du vill att objekt i olika lager ska vara genomskinliga justerar du opaciteten för varje objekt, inte för varje lager.

  • Rasterinformation kan inte skalas i SVG Viewer och inte redigeras som andra SVG-element. Du kan helt enkelt undvika att skapa teckningar som rastreras i SVG-filen. Använd SVG-effekter om du vill lägga till grafiska effekter utan att orsaka rastrering.

  • Använd symboler och förenkla banorna i teckningen för förbättrade SVG-prestanda. Om du prioriterar prestanda bör du dessutom undvika att använda penslar som ger mycket baninformation, t.ex. Träkol, Aska och Bläddringspenna.

  • Använd segment, bildscheman och skript om du vill lägga till webblänkar i en SVG-fil.

  • Skriptspråk, t.ex. JavaScript, möjliggör obegränsade funktioner i en SVG-fil. Rörelser med pekare och tangenttryckningar kan starta skriptfunktioner som rollover-effekter.

Exportalternativ för webboptimerad SVG

Ett nytt alternativ för SVG-export (Arkiv > Exportera > Exportera som > SVG) är tillgängligt. Med det nya arbetsflödet kan du skapa standardiserade webboptimerade SVG-filer för webb- och skärmdesignprojekt. Mer information finns i Exportalternativ för SVG.


Relaterade resurser

Kontakta oss

Fråga användarforumet

Om du har frågor eller förslag är du välkommen att delta i Adobe Illustrator-communityn. Vi vill gärna att du hör av dig.

 Adobe

Få hjälp snabbare och enklare

Ny användare?

Adobe MAX 2024

Adobe MAX
Kreativitetskonferensen

14–16 okt i Miami Beach och online

Adobe MAX

Kreativitetskonferensen

14–16 okt i Miami Beach och online

Adobe MAX 2024

Adobe MAX
Kreativitetskonferensen

14–16 okt i Miami Beach och online

Adobe MAX

Kreativitetskonferensen

14–16 okt i Miami Beach och online