Dozvíte se, jak lze urychlit a zefektivnit běh aplikace Illustrator v systému Windows.

Rychlost a efektivnost činnosti aplikace Adobe Illustrator ovlivňuje celá řada faktorů, například operační systém, konfigurace hardwaru, používané pracovní postupy nebo povolené volby. Pokud si všimnete, že aplikace Illustrator běží pomaleji než obvykle, zkuste pomocí níže uvedených metod optimalizovat nejen její výkon, ale i výkon ostatních aplikací.(Zlepšení výkonu je lépe patrné při práci s velkými soubory.)

Na úvod

Než začnete provádět níže uvedené úlohy, nezapomeňte si nainstalovat nejnovější verzi aplikace Illustrator, případně všechny aktualizace té verze, kterou používáte. Aktualizace softwaru často zahrnují opravy nebo vylepšení související s výkonem. 

Používáte-li verzi Illustrator CC, můžete aplikaci Illustrator aktualizovat prostřednictvím aplikace Creative Cloud pro stolní počítače.

Poznámka:

Postupy v tomto dokumentu jsou založeny na výchozím rozhraní. Pokud je rozhraní přizpůsobené, mohou se některé postupy lišit. Například cesta pro navigaci k Ovládacím panelům se může lišit. V závislosti na používané verzi systému Windows zvolte nabídku Start > Nastavení > Ovládací panely nebo Start > Ovládací panely.Tipy a obecné informace týkající se systému Windows získáte od podpory společnosti Adobepodpory společnosti Microsoft.

Optimalizace systému Windows

Nakonfigurováním operačního systému a zajištěním jeho efektivnějšího provozu zvýšíte množství paměti dostupné pro aplikace, což jim umožní plynulejší chod. Zde je několik metod, pomocí nichž můžete optimalizovat systém Windows a vylepšit výkon aplikace Illustrator.

Zvýšení dostupné paměti

Virtuální paměť umožňuje využít místo na pevném disku k ukládání informací, které jsou obvykle uloženy v paměti RAM. Získat přístup k informacím na pevném disku však trvá déle než získat přístup k informacím v paměti. Pokud se tedy musí systém příliš spoléhat na virtuální paměť, může to snížit jeho výkon.

Chcete-li výkon zvýšit, zvolte správnou velikost stránkovacího souboru (oblast pevného disku, kde je uložena virtuální paměť). Ke změně velikosti stránkovacího souboru je třeba mít práva správce. Aplikace Illustrator funguje nejlépe, když je maximální velikost stránkovacího souboru asi třikrát větší než množství nainstalované paměti RAM.

  1. Ukončete všechny aplikace.

  2. Vyberte možnost Start > Ovládací panely > Systém > Upřesnit nastavení systému.

  3. V dialogovém okně Vlastnosti systému vyberte kartu Upřesnit.

  4. V části Výkon klikněte na tlačítko Nastavení a potom vyberte kartu Upřesnit.

  5. V části Virtuální paměť klikněte na tlačítko Změnit.

  6. Zrušte zaškrtnutí políčka Automaticky spravovat velikost stránkovacího souboru pro všechny jednotky.

  7. V seznamu Jednotka vyberte pevný disk, na němž je alespoň třikrát více místa, než kolik činí kapacita nainstalované paměti RAM vašeho počítače. Pokud má počítač například 64 MB paměti RAM, vyberte pevný disk, který má alespoň 192 MB volného prostoru. K dosažení co nejlepšího výkonu vyberte pevný disk, který neslouží jako odkládací disk aplikace Illustrator.

Vypnutí funkcí ovladače

Některé ovladače grafických karet nabízejí pokročilá nastavení pro urychlení nebo úpravu grafického zobrazení. Někdy mohou tato nastavení nepříznivě ovlivnit výkon při překreslování obrazovky v aplikaci Illustrator. Zkuste vypnout funkce specifické pro ovladač a určit nejlepší nastavení pro použití s aplikací Illustrator. Další informace najdete v dokumentaci ke grafické kartě.

Správa písem

Každé nainstalované písmo zvyšuje množství paměti RAM používané systémem Windows. Chcete-li zlepšit výkon systému i aplikací, jež písma používají, nainstalujte si jen ta písma, která potřebujete. Při spravování mnoha písem může být užitečné použít nástroj pro správu písem.

Omezení počtu aplikací spouštěných při spuštění počítače

Aplikace, které se spouštějí v systému Windows automaticky, soupeří s aplikací Illustrator o volnou paměť RAM. Chcete-li aplikacím zabránit v automatickém spouštění, postupujte takto:

  1. Ukončete všechny aplikace.

  2. Spusťte Průzkumník Windows.
  3. Vypněte aplikace spouštěné při spuštění počítače, a to tak, že přesunete všechny ikony a zástupce ze složky Startup (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) do jiné složky.

  4. Restartujte systém Windows.

Chcete-li aplikace určené pro automatické spuštění zavřít v registru, postupujte takto:

  1. Restartujte systém Windows.
  2. Stiskněte klávesy Ctrl+Shift+Esc.

  3. Vyberte kartu Procesy.

  4. Vyberte název aplikace a potom klikněte na tlačítko Ukončit úlohu.

  5. Restartujte aplikaci Illustrator. Pokud se výkon aplikace Illustrator zlepší, obraťte se na výrobce dané aplikace a vyžádejte si pomoc ohledně trvalého vypnutí jejího automatického spouštění. Zopakujte kroky 2–5 pro každou zbývající aplikaci spouštěnou při spuštění počítače.

Opětovné povolení ikon a zástupců

Jestliže se výkon aplikace Illustrator po restartu nezlepší, potom znovu povolte ikony a zástupce v Průzkumníku Windows tím, že je vrátíte do složky Startup.

Pokud se výkon aplikace Illustrator zlepší, izolujte problém s výkonem na jeden či více programů a znovu povolte jejich ikony a zástupce jejich umístěním do složky Startup pomocí Průzkumníka Windows.

Potom, co znovu povolíte každou sadu ikon a zástupců, restartujte počítač a otestujte výkon aplikace Illustrator.

Tento postup opakujte tak dlouho, dokud se bude výkon aplikace Illustrator zhoršovat. Jakmile izolujete ikonu nebo zástupce, který způsobuje problém s výkonem, znovu je odeberte. Obraťte se na výrobce programu a zjistěte, zda je k dispozici aktualizace.

Optimalizace hardwaru

Použitý hardware ovlivňuje výkon aplikace Illustrator – čím rychlejší je procesor nebo pevný disk, tím rychleji je aplikace Illustrator schopna zpracovávat informace. Také další vylepšení hardwaru, například nainstalování další paměti RAM, použití víceprocesorového systému nebo optimalizace a defragmentace disků, může zlepšit výkon. Zkuste optimalizovat hardware pomocí těchto metod.

Použití rychlejšího procesoru

Rychlost centrální procesorové jednotky (CPU) počítače ovlivňuje rychlost aplikace Illustrator. Jelikož aplikace Illustrator pracuje s velkým množstvím dat a provádí mnoho výpočtů, její rychlost závisí na rychlosti procesoru. Zvažte použití počítače s rychlejším procesorem.

Instalace další paměti RAM

Pokud má aplikace Illustrator nedostatek paměti RAM, používá ke zpracování informací prostor na pevném disku (virtuální paměť, odkládací disk nebo obojí). Aplikace Illustrator pracuje nejrychleji, když může zpracovávat informace v paměti bez použití pevného disku.

Optimalizace prostoru na disku

Zde je několik způsobů, jak optimalizovat prostor na disku:

  • Zkontrolujte, zda se na pevném disku nevyskytují chyby, defragmentujte soubory a využijte co nejlépe dostupný prostor na pevném disku pomocí programů CHKDSK.exe a Defragmentace disku. Informace najdete v dokumentaci k systému Windows nebo v článku Zlepšení výkonu pro systém Windows.
  • Ukládejte soubory na disky s vyššími přístupovými rychlostmi. Používejte například interní pevný disk místo síťového serveru (síťový disk) nebo externího disku.
  • Chcete-li soubor uložit na síťový nebo externí disk, uložte jej nejprve na interní pevný disk. Potom soubor zavřete a pomocí Prohlížeče Windows ho zkopírujte na síť nebo na externí disk.

Použití tiskárny s podporou jazyka PostScript

Při tisku z aplikace Illustrator dosáhnete nejlepších výsledků, když použijete tiskárnu s podporou jazyka PostScript. Většina ne-PostScriptových tiskáren spoléhá při předávání tiskových informací tiskárně na informace z obrazovky, na zdroje z hostitelských počítačů a na značkové ovladače tiskáren. Proto jim tisk může trvat mnohem déle než PostScriptové tiskárně.

Efektivní použití funkcí aplikace Illustrator

To, jak v aplikaci Illustrator pracujete – zejména způsob, jakým zobrazujete kresby – může mít vliv na výkon aplikace Illustrator. Zde je uvedeno několik způsobů, jak používat funkce aplikace Illustrator efektivně.

Práce v zobrazení Osnova

Zobrazení Osnova skryje atributy vybarvení a zobrazí kresbu jako nevyplněné cesty. Práce v zobrazení Osnova může urychlit zobrazení složitých kreseb, například objektů obsahujících přechody nebo vzory. Zobrazení Osnova může rovněž usnadnit úpravu objektů skrytých za jinými vyplněnými objekty.

Chcete-li zobrazit dokument aplikace Illustrator v zobrazení Osnova, zvolte položku Zobrazení > Osnova.

Vytvoření uživatelských zobrazení

Můžete si vytvořit vlastní zobrazení svého dokumentu. Pomocí vlastních zobrazení lze rychle změnit režim zobrazení, zvětšení, pozici posuvu a možnosti vrstvy.

Chcete-li vytvořit vlastní zobrazení dokumentu aplikace Illustrator, nastavte atributy zobrazení, které chcete uložit. Potom zvolte položku Zobrazení > Nové zobrazení a do dialogového okna Nové zobrazení zadejte název. Vlastní zobrazení se objeví v nabídce Zobrazení.

Změna nastavení rastrových efektů

Změnou rozlišení rastrových efektů můžete optimalizovat výkon aplikace Illustrator.

Chcete-li změnit rozlišení rastrových efektů, zvolte položku Efekt > Nastavení rastrových efektů dokumentu. V rozevírací nabídce Rozlišení proveďte jednu z následujících akcí:

  • Zvolte položku Obrazovka, pokud upravujete soubory. Aplikace Illustrator použije pro rastrové efekty rozlišení 72 ppi, čímž se zvýší rychlost zobrazení.
  • Jestliže soubory tisknete, zvolte položku Vysoké. Aplikace Illustrator použije pro rastrové efekty rozlišení 300 ppi, čímž se sníží rychlost tisku, ale zvýší se jeho kvalita.

Potom klikněte na tlačítko OK.

Skrytí vrstev a odstranění miniatur

Uspořádání a úprava kreseb pomocí panelu Vrstvy Když skryjete vrstvy obsahující složité kresby nebo bitmapové obrázky s vysokým rozlišením, aplikace Illustrator bude rychleji překreslovat obrazovku.

Chcete-li vrstvu skrýt, klikněte na ikonu oka vlevo od názvu vrstvy. Pokud chcete skrýt všechny vrstvy kromě vybrané, klikněte na ikonu oka se stisknutou klávesou Alt (v systému Mac se stisknutou klávesou Option).

Na panelu Vrstvy mohou být zobrazeny miniatury pro vrstvy nejvyšší úrovně, vnořené vrstvy, skupiny a objekty. Chcete-li snížit počet miniatur, aby aplikace Illustrator překreslovala obrazovku rychleji, zvolte v nabídce panelu Vrstvy položku Volby panelu a snižte počet miniatur.

Panel Volby

Vypnutí náhledu Přetisk

Náhled Přetisk poskytuje „náhled tiskových barev“, který aproximuje vzhled prolnutí, průhlednosti a přetisku ve výstupu s barevnými výtažky. Chcete-li zlepšit výkon, náhled Přetisk nepoužívejte.

Pokud chcete náhled Přetisk zapnout nebo vypnout, zvolte položku Zobrazení > Náhled Přetisk.

Odstranění nepoužitých kreslicích pláten

Kreslicí plátna představují oblasti, které mohou obsahovat tisknutelnou kresbu. Chcete-li optimalizovat výkon, zvažte odstranění nepoužitých nebo zbytečných kreslicích pláten.

Pokud chcete spravovat kreslicí plátna, zvolte položku Okno > Kreslicí plátna. Vyberte kreslicí plátno, které chcete odstranit, a klikněte na tlačítko Odstranit.

Změna předvolby odkládacích disků

Když pracujete s vnořeným bitmapovým obrazem a systém nemá dostatek paměti RAM, aplikace Illustrator použije prostor na pevném disku jako odkládací disk. Získat přístup k informacím na pevném disku trvá déle než získat přístup k informacím v paměti. Proto může využití části pevného disku jako virtuální paměti vést ke snížení výkonu. Potřebujete-li k práci v aplikaci Illustrator více paměti, společnost Adobe doporučuje nainstalovat další paměť RAM.

Aplikace Illustrator standardně používá systémový disk jako primární odkládací disk. Změňte nastavení primárního odkládacího disku aplikace Illustrator na svůj nejrychlejší pevný disk.

Chcete-li změnit předvolbu odkládacího disku, postupujte takto:

  1. Vyberte možnost Úpravy > Předvolby > Zásuvné moduly a odkládací disky.

  2. V rozevírací nabídce Primární vyberte pevný disk. Pokud pracujete s velkými obrazy a máte více pevných disků, vyberte v rozevírací nabídce Sekundární další disk.

  3. Klikněte na tlačítko OK a aplikaci Illustrator restartujte.

Odstranění nepoužitých prvků z profilů dokumentu

Profily dokumentů aplikace Illustrator obsahují výchozí vzory, přechody, návrhy grafů, barvy, knihovny barev a štětce, které se objevují v nových dokumentech aplikace Illustrator. Tyto soubory určují také úroveň zvětšení, velikost okna, preference prohlížení a pozici posuvu pro nové dokumenty. Minimalizujte velikost souboru u nových dokumentů odstraněním zbytečných vzorků barev a štětců z nových profilů dokumentů aplikace Illustrator.

Pokyny týkající se vytváření vlastních profilů dokumentů v aplikaci Illustrator najdete v článku Profily při spuštění – skvělý nástroj k přizpůsobení nových dokumentů.

Odstranění nepoužitých prvků ze šablon

Šablony umožňují vytvářet dokumenty, které mají společná nastavení a prvky návrhu. Velikost souboru u nových dokumentů lze minimalizovat odstraněním zbytečných vzorků barev, symbolů, grafických stylů a štětců ze šablon.

Pokyny týkající se vytváření souborů šablon najdete v článku Soubory a šablony.

Povolení odkazů na obrázky

Vnořené bitmapové obrázky (například TIFF, BMP nebo Photoshop EPS) mohou výrazně zvětšit velikost dokumentu aplikace Illustrator a tím zpomalit její výkon. Chcete-li její výkon zlepšit, povolte při umisťování bitmapového obrázku volbu Odkaz. Volba Odkaz odkazuje na obrázek umístěný na pevném disku.

  • Vyberte možnost Soubor > Umístit. V dialogovém okně Umístění zvolte položku Odkaz.

Pokud servisní středisko vyžaduje vložené obrázky, pak uložte kopii souborů. Zvolte možnost Zahrnout připojené soubory v dialogovém okně Volby nativního formátu aplikace Illustrator nebo Volby formátu EPS .

Použití náhledu souborů EPS s nízkým rozlišením

Pokud dokument obsahuje připojené obrázky EPS, jež mají náhledy s vysokým rozlišením, bude aplikace Illustrator při úpravě kresby překreslovat obrazovku pomaleji. Chcete-li umožnit aplikaci Illustrator, aby překreslovala obrazovku rychleji, použijte náhledy EPS s nízkým rozlišením. Postupujte takto:

  1. Vyberte možnost Úpravy > Předvolby > Zpracování souborů a schránka.

  2. Zaškrtněte políčko Použít nízké rozlišení proxy pro připojené soubory EPS a klikněte na tlačítko OK.

Vypnutí zobrazení interakcí průhlednosti DCS

Dialogové okno Volby panelu Odkazy zahrnuje volbu Zobrazit interakce průhlednosti DCS. Je-li tato volba zaškrtnuta, je na panelu Odkazy zobrazena žlutá ikona značící připojené grafiky DCS EPS, které jsou průhledné nebo překrývají průhledné objekty. Jelikož tato volba nutí aplikaci Illustrator pravidelně zjišťovat, zda připojené soubory EPS interagují s průhledností, může snížit její výkon.

Chcete-li volbu Zobrazit interakce průhlednosti vypnout, postupujte takto:

  1. Vyberte možnost Okno > Vazby. V nabídce panelu Odkazy vyberte položku Volby panelu.

  2. Zrušte zaškrtnutí volby Zobrazit interakce průhlednosti DCS a klikněte na tlačítko OK.

Skrytí panelu Navigátor

Na panelu Navigátor je zobrazena miniatura náhledu aktuální kresby usnadňující navigaci. Doba potřebná pro zpracování při aktualizaci miniatury při každé změně dokumentu závisí na složitosti kresby. Chcete-li zlepšit rychlost při překreslování obrazovky u složitých dokumentů, skryjte panel Navigátor. V nabídce Okno zrušte zaškrtnutí volby Navigátor.

Můžete nastavit vlastní zobrazení a tím docílit efektivnějšího přiblížení konkrétních oblastí dokumentu.

Vypnutí vyhlazené kresby

Volba Vyhlazení kresby vyhlazuje text a grafiku smícháním barvy obrazových bodů okraje objektu s barvou sousedních obrazových bodů. Tento proces však může způsobit pomalé překreslování obrazovky. Chcete-li tuto volbu zakázat, postupujte takto:

  1. Vyberte možnost Úpravy > Předvolby > Všeobecné.

  2. Zrušte zaškrtnutí políčka Vyhlazená kresba a klikněte na tlačítko OK.

Použití příkazu Zjednodušit

Příkaz Zjednodušit sníží počet kotevních bodů v cestách a ve tvarech cest, čímž se zmenší velikost souboru a zvýší se výkon. Chcete-li použít příkaz Zjednodušit, vyberte požadovanou cestu nebo objekt a potom vyberte možnost Objekt > Cesta > Zjednodušit.

Další informace týkající se příkazu Zjednodušit najdete v článku Nápověda k aplikaci Illustrator.

Zakázání inteligentních vodítek

Pomocí inteligentních vodítek lze vytvářet, vyrovnávat, upravovat a přetvářet objekty aplikace Illustrator ve vztahu k dalším objektům. Osahuje-li kresba mnoho objektů, aplikace Illustrator potřebuje na zobrazení inteligentních vodítek více času. Pokud chcete inteligentní vodítka zakázat, z nabídky Zobrazení zrušte zaškrtnutí volby Inteligentní vodítka.

Další informace ohledně inteligentních vodítek najdete v článku Pravítka, mřížky, vodítka a ořezové značky.

Rastrování cest štětců se štětinami a vypnutí možností PDF

Tahy štětce se štětinami tvoří několik překrývajících se, vyplněných průhledných cest. Tyto cesty, podobně jako jakákoli jiná vyplněná cesta v aplikaci Illustrator, se vzájemně ovlivňují s barvou jiných objektů, včetně cest jiných štětců se štětinami.

Experimentujte a zkoušejte štětce se štětinami a ztvárnění barev, než se pustíte do rozsáhlé kresby. Změna atributů štětce a jejich opětovné použití vykreslí všechny použité štětce znovu.

Při použití štětců se štětinami lze dokument provedením následujících akcí zjednodušit a zmenšit velikost příslušného souboru:

  • Rastrování některých cest štětců se štětinami. Před rastrováním si nezapomeňte uložit kopii původní kresby.

Pokud kresba obsahuje velký počet štětců se štětinami (>30), zmenšete složitost a počet cest štětců se štětinami. Vyberte cesty ke štětcům se štětinami a potom vyberte možnost Objekt > Rastrovat.

  • Zakázání možností PDF.

Aplikace Illustrator standardně ukládá data PDF, díky kterým jsou soubory aplikace Illustrator (*ai) kompatibilní s ostatními aplikacemi Adobe. Vyberte možnost Soubor Uložit nebo Soubor > Uložit jako a klikněte na tlačítko Uložit. V dialogovém okně Možnosti aplikace Illustrator zrušte zaškrtnutí políčka Vytvořit soubor kompatibilní s PDF.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online