Läs vad du kan göra för Illustrator ska köras snabbt och effektivt i macOS.

Det finns många faktorer som påverkar hur snabbt och effektivt Adobe Illustrator kör, till exempel operativsystemet och maskinvarukonfigurationen, ditt arbetsflöde och de alternativ du väljer. Om du märker att Illustrator kör långsammare än vanligt finns det flera olika tekniker du kan använda för att optimera inte bara prestandan för Illustrator, utan även för övriga program.

En prestandaförbättring märks som tydligast när du arbetar med stora filer.

Innan du börjar

Innan du följer stegen nedan ska du se till att du har den senaste versionen av Illustrator eller har gjort alla uppdateringar av den version du använder. Programvaruuppdateringar innehåller oftast prestandarelaterade åtgärder och förbättringar.

Om du använder Illustrator CC kan du uppdatera Illustrator via Creative Cloud-datorprogrammet.

Optimera macOS

Genom att konfigurera ditt system för effektiv användning ökar du mängden ledigt minne för program så att de kan användas problemfritt. Prova dessa tekniker för att optimera macOS och förbättra prestandan för Illustrator.

Hantera teckensnitt

Varje teckensnitt du har ökar mängden RAM-minne som macOS utnyttjar. Installera bara de teckensnitt du behöver så förbättrar du både systemets prestanda och prestandan för de program som använder teckensnitt. Använd ett teckensnittsverktyg som hjälper dig hantera flera teckensnitt.

Använd en PostScript-skrivardrivrutin

Skrivardrivrutiner som inte är av typen PostScript kan hamna i konflikt med Illustrator. Adobe rekommenderar därför att du anger en PostScript-skrivardrivrutin som standardskrivare i macOS.

Steg 1. Ställ in en PostScript-skrivare som standardskrivare

Obs!

Slutför denna procedur genom att kontrollera att en PostScript-skrivaren är ansluten till datorn antingen direkt eller via ett nätverk.

  1. Från Apple-menyn väljer du Systeminställningar och klickar sedan på Skrivare och skanner.

  2. Om det inte visas någon PostScript-skrivare klickar du på +, går till PostScript-skrivare och klickar på Lägg till.

  3. Välj en PostScript-skrivare från pop-upmenyn Standardskrivare.

Steg 2. Konfigurera Illustrator så att den skriver ut till en skrivare som inte är angiven som standard

  1. Öppna valfritt dokument i Illustrator och välj Arkiv > Skriv ut.

  2. I dialogrutan Skriv ut väljer du Adobe PostScript-fil eller namnet på skrivaren i menyn Skrivare.

  3. Klicka på Spara.

Optimera maskinvarukonfigurationen

Maskinvaran du använder påverkar prestandan i Illustrator: ju snabbare processor eller hårddisk, desto snabbare kan Illustrator behandla information. Andra maskinvaruförbättringar, som att installera ytterligare RAM, använda ett system med multiprocessorer eller optimering och defragmentering av enheter kan också förbättra prestandan. Här är några steg du kan prova för att optimera maskinvarukonfigurationen och förbättra prestandan i Illustrator.

Använd en snabbare processor

Hastigheten hos datorns CPU (Central Processing Unit) påverkar hastigheten hos Illustrator. Eftersom Illustrator ändrar stora mängder data och utför många beräkningar, beror hastigheten på processorns hastighet. Överväg att använda en dator med snabbare processor.

Installera mer RAM-minne

Om Illustrator har otillräckligt med RAM-minne så använder det diskutrymme (alltså en testdisk) för att behandla information. Illustrator kör snabbast när det kan behandla information i minnet, utan att använda en hårddisk.

Optimera diskutrymmet

Här är några sätt du kan optimera diskutrymmet på:

  • Kontrollera om det finns fel på hårddisken eller defragmentera filer med ett skivverktyg från tredje part (t.ex. Norton Utilities). Om du kör macOS behöver hårddisken inte defragmenteras, men den kan behöva repareras med ett skivverktyg från tredje part.
  • Spara dina filer på enheter med snabbare åtkomsthastigheter. Använd exempelvis en intern hårddisk istället för en nätverksserver (nätverksenhet) eller en extern hårddisk.

Använda Illustrators funktioner effektivt

Hur du arbetar i Illustrator och speciellt hur du visar teckningar kan påverka prestandan för Illustrator. Här är några sätt att använda Illustrators funktioner som kan hjälpa dig att köra Illustrator problemfritt.

Arbeta i dispositionsläget

Dispositionsläget döljer färgattribut och visar teckningen som ofyllda banor. Att arbeta i dispositionsläget kan snabba upp visningen av komplexa teckningar, så som objekt som innehåller övertoningar och mönster. Dispositionsläget kan även göra det enklare att redigera objekt som finns dolda bakom andra fyllda objekt.

Visa ett Illustrator-dokument i dispositionsläge genom att välja Visa > Kontur.

Skapa anpassade vyer

Du kan skapa anpassade vyer för dokumentet. Med anpassade vyer kan du snabbt ändra visningsläge, förstoring, rullningsplacering och lageralternativ.

Skapa en anpassad vy av ett Illustrator-dokument genom att ställa in attributen som du vill spara. Välj sedan Visa > Ny vy och skriv ett namn i dialogrutan Ny vy. Den anpassade vyn visas sedan i Visa-menyn.

Ändra rastereffektsinställningar

Du kan ändra upplösningen på rastereffekter för att optimera prestandan i Illustrator.

Ändra upplösningen av rastereffekter genom att välja Effekter > Dokumentets rastereffektsinställningar och sedan välja något av följande från rullgardinslistan Upplösning :

  • Klicka på Bildskärm om du redigerar filer. Illustrator använder en upplösning på 72 ppi för rastereffekter för att öka visningshastigheten.
  • Klicka på Hög om du skriver ut filer. Illustrator använder en upplösning på 300 ppi för rastereffekter vilket minskar utskriftshastigheten, men ökar utskriftskvaliteten.

Klicka på OK.

Dölj lager och ta bort miniatyrer

Illustrator ritar om skärmen snabbare när du döljer lager som innehåller komplexa teckningar eller bitmappsbilder i hög upplösning.

Dölj ett lager genom att klicka på ögonikonen till vänster om lagrets namn, ta bort markeringen i Visa lager och klicka sedan på OK. Om du vill dölja alla lager utom det markerade alt-klickar du på ögonikonen.

Obs! Panelen Lager kan visa miniatyrbilder för översta lager, kapslade lager, grupper och objekt. För att minska antalet miniatyrbilder så att Illustrator ritar om skärmen snabbare väljer du Panelalternativ från menyn Lagerpanel och minskar sedan antalet miniatyrer.

  • För att ta bort alla miniatyrbilder från panelen Lager väljer du Liten i delen Radstorlek och klickar sedan OK.
  • För att ta bort alla miniatyrbilder för specifika element i panelen Lager avmarkerar du Lager, Grupper eller Objekt i delen Miniatyrbilder och klickar sedan på OK.

Avaktivera Förhandsvisa övertryck

Förhandsvisa övertryck ger en förhandsvisning av tryckfärg som visar ungefär hur övertoning, genomskinlighet och övertryck ser ut på färgseparerade utdata. Om du vill förbättra prestanda ska du undvika funktionen Förhandsvisa övertryck.

Aktivera och avaktivera Förhandsvisa övertryck genom att välja Visa > Förhandsvisa övertryck.

Ta bort ritytor som inte används

Ritytor representerar områden som kan innehålla utskrivbara teckningar. Om du vill optimera programmets prestanda bör du överväga att radera oanvända och onödiga ritytor.

Du hanterar ritytorna genom att välja Fönster > Ritytor. Välj sedan den rityta du vill ta bort och klicka på Ta bort.

Ändra inställningen för testdisken

När du arbetar med en inbäddad bitmappsbild och ditt system inte har tillräckligt RAM-minne, använder Illustrator hårddiskutrymme som en testdisk. Det tar längre tid att komma åt information på en hårddisk än i minnet. Om en del av hårddisken används som virtuellt minne kan det försämra prestanda. Om du behöver mer minne för att arbeta i Illustrator ska du lägga till mer RAM-minne.

Som standard använder Illustrator systemdisken som primär testdisk. Ändra Illustrators primära testdiskinställning till den snabbaste hårddisken.

Om du vill ändra inställningen för testdisken gör du följande:

  1. Välj Illustrator > Inställningar > Pluginprogram och testdisk.

  2. Välj en hårddisk från popup-menyn Primär. Om du arbetar med stora bilder och har mer än en hårddisk så väljer du ytterligare en disk från popup-menyn Sekundär.
  3. Klicka på OK och starta om Illustrator.

Ta bort oanvända element från dokumentprofiler

Illustrator-dokumentens profiler innehåller de standardmönster, övertoningar, diagram, färger, färgbibliotek och penslar som visas i nya Illustrator-dokument. Dessa filer bestämmer zoomnivå, fönsterstorlek, visningsinställningar och rullningsplacering för nya dokument. Minimera filstorleken för nya dokument genom att ta bort onödiga färgrutor och borstar från Illustrators nya dokumentprofiler.

Instruktioner om hur du skapar egna dokumentprofiler finns i Startprofiler: Ett bra sätt att anpassa nya dokument.

Ta bort element som inte används från mallar

Med hjälp av mallar kan du skapa dokument som delar vanliga inställningar och designelement. Du kan minimera filstorleken för nya dokument genom att ta bort onödiga färgrutor, symboler, grafiska stilar och penslar från mallarna.

Instruktioner om hur du skapar mallfiler finns i Filer och mallar.

Aktivera länkar till bilder

Inbäddade bitmappbilder (exempelvis TIFF, BMP eller Photoshop EPS) kan väsentligt öka storleken på ett Illustrator-dokument och därmed ge sämre prestanda. Aktivera alternativet Länka när du monterar en bitmappsbild för att förbättra prestanda. Alternativet Länka refererar till den placerade bilden på hårddisken.

  • Gå till Arkiv > Placera. Välj Länka i dialogrutan Placera.

Om en samarbetspartner kräver inbäddade bilder, så kan du spara en kopia av filerna. Välj Inkludera länkade filer i Illustrators interna formatalternativ eller dialogrutan EPS-formatalternativ.

Använd lågupplöst förhandsgranskning av EPS

Om ett dokument innehåller länkade EPS-bilder som har förhandsvisning med hög upplösning så kan det ta lång tid för Illustrator att rita om skärmen när du redigerar teckningar. För att tillåta Illustrator att rita om skärmen snabbare ska du använda lågupplösta EPS-förhandsvisningar. Gör så här:

  1. Välj Illustrator > Inställningar > Filhantering och urklipp.

  2. Välj Använd lågupplöst proxy för länkade EPS och klicka på OK.

Avaktivera Visa DCS genomskinlighetsinteraktion

Dialogrutan Panelen länkalternativ har alternativet Visa DCS genomskinlighetsinteraktion. Om detta alternativ är valt visar Länkpaletten en gul ikon för att identifiera länkad DCS EPS-grafik som är transparent eller överlappar transparenta objekt. Eftersom detta alternativ tvingar Illustrator att med jämna mellanrum avgöra om länkade EPS-filer interagerar med genomskinlighet kan det försämra prestandan.

Gör så här för att avaktivera alternativet Visa genomskinlighetsinteraktion:

  1. Välj Fönster > Länkar. Välj Panelalternativ i menyn Länkpalett.

  2. Avmarkera Visa DCS genomskinlighetsinteraktion och klicka sedan på OK.

Dölj panelen Överblick

Panelen Överblick visar en miniatyrbild av den aktuella teckning för att förenkla navigationen. Hur lång tid det tar att bearbeta uppdateringar av miniatyrbilder när du ändrar dokumentet beror på hur komplex grafiken är. För att förbättra hastigheten och prestanda för att rita om teckningar i ett komplext dokument, kan du dölja panelen Överblick.

  • Avmarkera Överblick i menyn Fönster.

Du kan ställa in anpassade vyer som mer effektivt zoomar in specifika områden i ditt dokument.

Avaktivera Kantutjämnad teckning

Alternativet Kantutjämnad teckning mjukar upp text och grafik genom att blanda färgen på ett objekts kantpixlar med färgen på pixlarna intill. Men denna process kan göra att det går långsamt att rita om skärmen. Om du vill inaktivera det här alternativet gör du följande:

  1. Välj Illustrator > Inställningar > Allmänt.

  2. Avmarkera Kantutjämnad teckning och klicka på OK.

Använd kommandot Förenkla

Kommandot Förenkla minskar antalet ankarpunkter i banor och banformer så att filstorleken minskar och prestandan förbättras. För att använda kommandot Förenkla väljer du önskad bana eller objekt och sedan Objekt > Bana > Förenkla.

Mer information om kommandot Förenkla finns i Redigera banor.

Avaktivera smarta stödlinjer

Smarta stödlinjer gör att du kan skapa, justera, redigera och omvandla Illustrator-objekt relativt till andra objekt. Om du har flera objekt i teckningen kommer Illustrator att behöva mer tid för att visa Smarta stödlinjer.

  • Klicka på menyn Visa för att avaktivera smarta stödlinjer och avmarkera Smarta stödlinjer.

Här kan du läsa mer om Smarta stödlinjer.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy