Läs mer om hur du kan göra Illustrator snabbt och effektivt i Windows.

Flera faktorer påverkar hur snabbt och effektivt Adobe Illustrator fungerar, till exempel operativsystemet, maskinvarukonfigurationen, ditt arbetsflöde och valda alternativ. Om du märker att Illustrator är långsammare än vanligt kan du prova metoderna nedan för att optimera inte bara Illustrators prestanda, utan även prestanda för andra program. (En förbättring av prestanda är mer märkbar när du arbetar med stora filer.)

Innan du börjar

Innan du går igenom uppgifterna nedan ska du se till att installera den senaste versionen av Illustrator eller eventuella uppdateringar av den version du använder. Programvaruuppdateringar innehåller oftast prestandarelaterade åtgärder och förbättringar. 

Om du använder Illustrator CC kan du uppdatera Illustrator via Creative Clouds skrivbordsapp.

Obs!

Procedurerna i det här dokumentet är baserade på standardgränssnittet. Om gränssnittet har anpassats kan vissa procedurer variera. Sökvägen för att navigera till Kontrollpanelen kan till exempel variera. Välj Start > Inställningar > Kontrollpannelen eller Start > Kontrollpanelen, beroende på Windows-version. Om du vill ha felsökningstips och allmän information om Windows kan du fråga Adobe Support och Microsoft Support.

Optimera Windows

Genom att konfigurera operativsystemet för effektiv användning ökar du mängden ledigt minne för program så att de kan användas problemfritt. Här är flera metoder för att optimera Windows och förbättra Illustrators prestanda.

Öka tillgängligt minne

Med virtuellt minne går det att använda hårddiskutrymme för att lagra information som normalt lagras i RAM-minnet. Det tar emellertid längre tid att komma åt information på en hårddisk än i minnet. Det kan alltså försämra prestanda om systemet är för beroende av virtuellt minne.

Om du vill öka prestanda bör du välja rätt storlek för växlingsfilen (området på hårddisken där virtuellt minne lagras). Administratörsbehörighet krävs för att ändra växlingsfilens storlek. Illustrator fungerar bäst när växlingsfilens maximala storlek är omkring tre gånger större än mängden installerat RAM-minne.

  1. Avsluta alla program.

  2. Välj Start > Kontrollpanelen > System > Avancerade systeminställningar.

  3. I dialogrutan Systemegenskaper ska du välja fliken Avancerat.

  4. Klicka på Inställningar i avsnittet Prestanda och välj sedan fliken Avancerat.

  5. I avsnittet Virtuellt minne klickar du på Ändra.

  6. Avmarkera kryssrutan Hantera automatiskt växlingsfilens storlek på varje enhet.

  7. I listan med Enheter väljer du en hårddisk som är minst tre gånger större än datorns installerade RAM. Om datorn exempelvis har 64 MB RAM-minne ska du välja en hårddisk som har minst 192 MB ledigt utrymme. För bästa prestanda bör du välja en hårddisk som inte används som Illustrators testdisk.

Inaktivera drivrutinsfunktioner

En del drivrutiner för grafikkort har avancerade inställningar för att accelerera eller modifiera grafikvisning. Ibland kan dessa inställningar påverka prestanda för skärmen och den ritas om i Illustrator. Försök med att inaktivera drivrutinspecifika funktioner så att du kan avgöra de bästa inställningarna då du använder Illustrator. Mer information finns i dokumentationen som medföljde grafikkortet.

Hantera teckensnitt

Varje teckensnitt du har ökar mängden RAM-minne som Windows utnyttjar. Installera bara de teckensnitt du behöver, för att förbättra systemets prestanda och prestanda för program som använder teckensnitt. Använd ett teckensnittsverktyg som hjälper dig hantera flera teckensnitt.

Begränsa startprogram

Program som startas automatiskt med Windows konkurrerar med Illustrator om tillgängligt RAM-minne. Om du vill förhindra att program startas automatiskt gör du följande:

  1. Avsluta alla program.

  2. Starta Windows Explorer.
  3. Inaktivera startprogram genom att flytta alla ikoner och genvägar från mappen Autostart (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) till en annan mapp.

  4. Starta om Windows.

Om du vill stänga program som ska startas automatiskt enligt registret gör du följande:

  1. Starta om Windows.
  2. Tryck Ctrl+Shift+Esc.

  3. Välj fliken Processer.

  4. Välj ett programnamn och klicka på Avsluta aktivitet.

  5. Starta om Illustrator. Om Illustrators prestanda förbättras kontaktar du programmets tillverkare för att få hjälp att inaktivera det permanent så att det inte startas automatiskt. Upprepa steg 2-5 för alla startprogram.

Aktivera ikoner och genvägar på nytt

Om Illustrators prestanda inte förbättras efter omstart aktiverar du ikonerna och genvägarna på nytt i Utforskaren genom att flytta tillbaka dem till mappen Autostart.

Om Illustrators prestanda förbättras isolerar du prestandaproblemet till ett eller flera program och aktiverar dess ikoner och genvägar på nytt genom att flytta tillbaka dem till mappen Autostart med hjälp av Utforskaren.

Starta om datorn när du har aktiverat en uppsättning ikoner och genvägar på nytt och testa Illustrators prestanda.

Upprepa processen tills prestandan på Illustrator försämras. När du har isolerat den ikon eller genväg som orsakar prestandaproblemet tar du bort den igen och kontaktar programmets tillverkare för att kontrollera om det finns en uppdatering.

Optimera maskinvara

Maskinvaran du använder påverkar Illustrators prestanda: ju snabbare processor eller hårddisk, desto snabbare kan Illustrator behandla information. Andra maskinvaruförbättringar, som att installera ytterligare RAM, använda ett system med multiprocessorer eller optimering och defragmentering av enheter kan också förbättra prestandan. Prova följande metoder för att optimera maskinvara.

Använd en snabbare processor

Hastigheten för datorns processor (CPU) påverkar hastigheten för Illustrator. Eftersom Illustrator ändrar stora mängder data och utför en rad beräkningar, beror dess hastighet på processorns hastighet. Överväg att använda en dator med snabbare processor.

Installera mer RAM-minne

Om Illustrator har otillräckligt med RAM-minne använder det hårddiskutrymme (virtuellt minne, testdisk eller båda) för att behandla information. Illustrator är snabbast då det kan behandla information i minnet utan att använda någon hårddisk.

Optimera diskutrymmet

Här är några sätt du kan optimera diskutrymmet på:

  • Kontrollera om det är fel på hårddisken, defragmentera filer och utnyttja tillgängligt hårddiskutrymme på bästa sätt med hjälp av programmen CHKDSK.exe och Diskdefragmenteraren. Information finns i Windows-dokumentationen eller Förbättra prestanda för Windows.
  • Spara dina filer till enheter med hastigheter för snabbare åtkomst. Använd till exempel en intern hårddisk och inte en nätverksserver (nätverksenhet) eller extern enhet.
  • Om du vill spara en fil på ett nätverk eller en extern enhet bör du först spara filen på en intern hårddisk. Stäng sedan filen och kopiera den med hjälp av Utforskaren till nätverket eller den externa enheten.

Använda en PostScript-skrivare

Du får det bästa resultatet om du använder en PostScript-skrivare då du skriver ut från Illustrator. De flesta skrivare utan PostScript utnyttjar visningsinformation, värddatorns resurser och egna skrivardrivrutiner för att överföra information till skrivaren. Därför kan utskrifterna ta mycket längre tid jämfört med en PostScript-skrivare.

Använda Illustrators funktioner effektivt

Det sätt du arbetar i Illustrator – speciellt det sätt du visar teckningar – kan påverka Illustrators prestanda. Här är några sätt att använda Illustrators funktioner effektivt.

Arbeta i dispositionsläge

Dispositionsläget döljer färgattribut och visar teckningen som ofyllda banor. Att arbeta i dispositionsläget kan snabba upp visningen av komplexa teckningar, så som objekt som innehåller övertoningar och mönster. Dispositionsläget kan även göra det enklare att redigera objekt som finns dolda bakom andra fyllda objekt.

Visa ett Illustrator-dokument i dispositionsläge genom att välja Visa > Kontur.

Skapa anpassade vyer

Du kan skapa anpassade vyer för dokumentet. Med anpassade vyer kan du snabbt ändra visningsläge, förstoring, rullningsplacering och lageralternativ.

Skapa en anpassad vy av ett Illustrator-dokument genom att ställa in attributen som du vill spara. Välj sedan Visa > Ny vy och skriv ett namn i dialogrutan Ny vy. Den anpassade vyn visas sedan i Visa-menyn.

Ändra inställningar för rastereffekter

Du kan ändra upplösningen på rastereffekter för att optimera Illustrators prestanda.

Ändra upplösningen på rastereffekter genom att välja Effekt > Inställningar för dokumentrastereffekter. Gör något av följande på pop-upmenyn Upplösning:

  • Om du redigerar filer väljer du Skärm. Illustrator använder en upplösning på 72 ppi för rastereffekter för att öka visningshastigheten.
  • Om du skriver ut filer väljer du Hög. Illustrator använder en upplösning på 300 ppi för rastereffekter vilket minskar utskriftshastigheten, men ökar utskriftskvaliteten.

Klicka på OK.

Dölja lager och ta bort miniatyrbilder

Använd panelen Lager för att organisera och modifiera teckningar. När du döljer lager som innehåller komplexa teckningar eller bitmappsbilder i hög upplösning ritar Illustrator om skärmen snabbare.

Dölj ett lager genom att klicka på ögonikonen till vänster om lagrets namn. Om du vill dölja alla lager utom det markerade Alt-klickar du på ögonikonen (Alternativ-klickar för Mac).

Obs! Panelen Lager kan visa miniatyrbilder för översta lager, kapslade lager, grupper och objekt. Om du vill minska antalet miniatyrbilder så att Illustrator ritar om skärmen snabbare väljer du Panelalternativ på panelmenyn Lager och minskar sedan antalet miniatyrbilder.

Panelen Alternativ

Inaktivera Förhandsvisa övertryck

Förhandsvisa övertryck ger en förhandsvisning av tryckfärg som visar ungefär hur övertoning, genomskinlighet och övertryck ser ut på färgseparerade utdata. Om du vill förbättra prestanda ska du undvika funktionen Förhandsvisa övertryck.

Aktivera och avaktivera Förhandsvisa övertryck genom att välja Visa > Förhandsvisa övertryck.

Ta bort oanvända ritytor

Ritytor representerar områden som kan innehålla utskrivbara teckningar. För att optimera prestanda bör du överväga att ta bort oanvända och onödiga ritytor.

Du hanterar ritytorna genom att välja Fönster > Ritytor. Markera en rityta du vill ta bort och klicka på Ta bort.

Ändra inställningen för testdisk

När du arbetar med en inbäddad bitmappsbild och systemet inte har tillräckligt med RAM-minne använder Illustrator hårddiskutrymme som en testdisk. Det tar längre tid att komma åt information på en hårddisk än i minnet. Om en del av hårddisken används som virtuellt minne kan det försämra prestanda. Om du behöver mer minne för att arbeta i Illustrator rekommenderar Adobe att du installerar mer RAM-minne.

Som standard använder Illustrator systemdisken som primär testdisk. Ändra Illustrators primära testdiskinställning till den snabbaste hårddisken.

Om du vill ändra inställningen för testdisken gör du följande:

  1. Välj Redigera > Inställningar > Pluginprogram och testdisk.

  2. Välj en hårddisk från pop-upmenyn Primär. Om du arbetar med stora bilder och har mer än en hårddisk så väljer du ytterligare en disk från pop-upmenyn Sekundär.

  3. Klicka på OK och starta om Illustrator.

Ta bort oanvända element från dokumentprofiler

Illustrator-dokumentens profiler innehåller de standardmönster, övertoningar, diagram, färger, färgbibliotek och penslar som visas i nya Illustrator-dokument. Dessa filer bestämmer zoomnivå, fönsterstorlek, visningsinställningar och rullningsplacering för nya dokument. Minimera filstorleken för nya dokument genom att ta bort onödiga färgrutor och borstar från Illustrators nya dokumentprofiler.

Instruktioner om hur du skapar anpassade dokumentprofiler i Illustrator finns i Startprofiler: Ett bra sätt att anpassa nya dokument.

Ta bort oanvända element från mallar

Med hjälp av mallar kan du skapa dokument som delar vanliga inställningar och designelement. Du kan minimera filstorleken för nya dokument genom att ta bort onödiga färgrutor, symboler, grafiska stilar och penslar från mallarna.

Instruktioner om hur du skapar mallfiler finns i Filer och mallar.

Aktivera länkar till bilder

Inbäddade bitmappbilder (exempelvis TIFF, BMP eller Photoshop EPS) kan väsentligt öka storleken på ett Illustrator-dokument och därmed ge sämre prestanda. Aktivera alternativet Länka när du monterar en bitmappsbild för att förbättra prestanda. Alternativet Länka refererar till den placerade bilden på hårddisken.

  • Välj Arkiv > Montera. Välj Länka i dialogrutan Placera.

Om en samarbetspartner kräver inbäddade bilder, så kan du spara en kopia av filerna. Välj Inkludera länkade filer i Illustrators interna formatalternativ eller dialogrutan EPS-formatalternativ .

Använd lågupplöst förhandsgranskning av EPS

Om ett dokument innehåller länkade EPS-bilder som har förhandsvisning med hög upplösning så kan det ta lång tid för Illustrator att rita om skärmen när du redigerar teckningar. För att tillåta Illustrator att rita om skärmen snabbare ska du använda lågupplösta EPS-förhandsvisningar. Gör så här:

  1. Välj Redigera > Inställningar > Filhantering och Urklipp.

  2. Lågupplösningsproxy finns för Väljer du Använd Länkade EPS och klicka på ok.

Inaktivera Visa DCS genomskinlighetsinteraktion

Dialogrutan Panelen länkalternativ har alternativet Visa DCS genomskinlighetsinteraktion. Om detta alternativ är valt visar Länkpaletten en gul ikon för att identifiera länkad DCS EPS-grafik som är transparent eller överlappar transparenta objekt. Eftersom detta alternativ tvingar Illustrator att med jämna mellanrum avgöra om länkade EPS-filer interagerar med genomskinlighet kan det försämra prestanda.

Om du vill inaktivera alternativet Visa genomskinlighetsinteraktion gör du följande:

  1. Välj Fönster > Länkar. Välj Panelalternativ på panelmenyn Länkar.

  2. Avmarkera Visa DCS genomskinlighetsinteraktion och klicka på OK.

Dölja panelen Överblick

Panelen Överblick visar en miniatyrbild av den aktuella teckning för att förenkla navigationen. Hur lång tid det tar att bearbeta uppdateringar av miniatyrbilder när du ändrar dokumentet beror på hur komplex grafiken är. Om du vill förbättra hastigheten för att rita om teckningar i ett komplext dokument kan du dölja panelen Överblick. Avmarkera Överblick under menyn Fönster.

Du kan ställa in anpassade vyer som mer effektivt zoomar in specifika områden i ditt dokument.

Inaktivera Kantutjämnad teckning

Alternativet Kantutjämnad teckning mjukar upp text och grafik genom att blanda färgen på ett objekts kantpixlar med färgen på pixlarna intill. Men denna process kan göra att det går långsamt att rita om skärmen. Om du vill inaktivera det här alternativet gör du följande:

  1. Välj Redigera > Inställningar > Allmänt.

  2. Avmarkera Kantutjämnad teckning och klicka på OK.

Använd kommandot Förenkla

Kommandot Förenkla minskar antalet ankarpunkter i banor och banformer så att filstorleken minskar och prestandan förbättras. För att använda kommandot Förenkla väljer du önskad bana eller objekt och sedan Objekt > Bana > Förenkla.

Mer information om kommandot Förenkla finns i Hjälp om Illustrator.

Inaktivera smarta stödlinjer

Smarta stödlinjer gör att du kan skapa, justera, redigera och omvandla Illustrator-objekt relativt till andra objekt. Om du har flera objekt i teckningen kommer Illustrator att behöva mer tid för att visa Smarta stödlinjer. Du inaktiverar smarta stödlinjer genom att avmarkera Smarta stödlinjer på menyn Visa.

Mer information om smarta stödlinjer finns i Linjaler, stödraster, stödlinjer och skärmärken.

Rastrera borstpenselbanor och inaktivera PDF-funktioner

Borstpenseldrag består av flera överlappande, fyllda, transparenta banor. Dessa banor, liksom alla andra fyllda banor i Illustrator, interagerar med färgen i andra objekt, inklusive andra borstpenselbanor.

Testa och experimentera med borstpenslar och färgrenderingar innan du ger dig på att skapa en större teckning. När penselattribut ändras och sedan används igen återges alla använda penslar på nytt.

När du använder borstpenslar kan du minska dokumentets komplexitet och filstorlek genom att göra följande:

  • Rastrera vissa borstpenselbanor. Se till att du sparar en kopia av originalteckningen innan du rastrerar.

Om dokumentets grafik innehåller ett stort antal (>30) borstpenslar kan du minska komplexiteten och antalet borstpenselbanor. Markera borstpenselbanorna och välj Objekt > Rastrera.

  • Inaktivera PDF-funktionerna.

Illustrator sparar som standard PDF-data som gör Illustrator (*ai)-filer kompatibla med andra Adobe-program. Välj Arkiv Spara eller Arkiv > Spara som och klicka på Spara.  Avmarkera Skapa PDF-kompatibel fil i dialogrutan Illustrator-alternativ.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy