Change corner appearance

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Toolbox
      3. Set preferences
      4. Touch workspace
      5. Default keyboard shortcuts
      6. Document recovery and undo
      7. Capture extension
  3. Create and lay out documents
    1. Documents and pages
      1. Create documents
      2. Work with parent pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Create book files
      7. Add basic page numbering
      8. Number pages, chapters, and sections
      9. Convert QuarkXPress and PageMaker documents
      10. Share content
      11. Understand a basic managed-file workflow
      12. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. Arabic and Hebrew features in InDesign
      4. Create type on a path
      5. Bullets and numbering
      6. Glyphs and special characters
      7. Text composition
      8. Text variables
      9. Generate QR codes
      10. Edit text
      11. Align text
      12. Wrap text around objects
      13. Anchored objects
      14. Linked content
      15. Format paragraphs
      16. Format characters
      17. Find/Change
      18. Spell check and language dictionaries
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    6. Styles
      1. Paragraph and character styles
      2. Object styles
      3. Drop caps and nested styles
      4. Work with styles
      5. Leading
    7. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    8. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
      11. Forms
    9. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Align and distribute objects
      10. Linked and embedded graphics
      11. Integrate AEM assets
    10. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Undertand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Share
    1. Share and collaborate        
    2. Share for Review
    3. Review a shared InDesign document
    4. Manage feedback 
  6. Publish
    1. Export and publish
      1. Publish Online
      2. Export content for EPUB
      3. Adobe PDF options
      4. Export content to HTML
      5. Export to Adobe PDF
      6. Export to JPEG format
      7. Export HTML
      8. DPS and AEM Mobile overview
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  7. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Capture extension in InDesign
      4. Scripting

You can use the Corner Options command to quickly apply corner effects to any path. Available corner effects range from simple, rounded corners to fancy ornamentation.

Effects of different line weights on corner shapes

A. Fancy corner effect with no stroke B. Same effect with 1‑point stroke C. Same effect with 4‑point stroke 

Apply corner shapes using the Corner Options dialog box

  1. Using a selection tool, select a path.

  2. Choose Object > Corner Options.

  3. To apply the corner effect to all four corners of a rectangle, select the Make All Settings The Same icon . When the option is not selected, dots appear on both sides of the icon (like a broken chain link).

  4. Choose a corner effect and specify a size for one or more of the corners.

    The size value determines the radius by which the corner effect extends from each corner point.

  5. Select Preview if you want to see the results of the effect before applying it. Then click OK.

Use Live Corners

With Live Corners, you can apply corner effects to rectangular frames by clicking the yellow box that appears on the frame and dragging. In addition, you can apply a different corner effect and a different corner radius to each corner.

  1. Select a rectangular frame, and click the yellow box.

    Four yellow diamonds appear on the selected frame, indicating Live Corners mode. If the yellow box does not appear on the selected frame, choose View > Extras > Show Live Corners.

  2. To add corner effects, do any of the following tasks:

    • To adjust the radii of all four corners together, drag one of the diamonds towards the center of the frame.

    • To adjust a single corner, hold down Shift as you drag a diamond.

    • To cycle through the various effects, Alt-click (Windows) or Option-click (Mac OS) a yellow diamond.

  3. To stop editing corners, click anywhere outside the selected frame.

To remove corner effects, choose Object > Corner Options, and then choose None.

If you don’t want the yellow box to appear when you select a frame, choose View > Extras > Hide Live Corners.

Guidelines for applying corner shapes

Note the following:

  • If you’ve obtained plug‑in software that adds more effects, the Corner Options command in the Stroke panel can include additional shapes.

  • Corner effects appear on all of a path’s corner points, but never on smooth points. The effects change angles automatically when you move a path’s corner points.

  • If a corner effect significantly changes the path by, for example, creating a bulge inward or outward, it may affect how a frame interacts with its contents or with other parts of the layout. Increasing the size of a corner effect may push an existing text wrap or frame inset farther away from the frame.

  • You can’t edit a corner effect, but you can change its appearance by changing the corner radius or modifying the stroke.

  • If you applied corner effects but can’t see them, make sure that the path uses corner points and that a stroke color or gradient has been applied to it. Then increase the Size option in the Corner Options dialog box, or increase the stroke weight in the Stroke panel.

Adobe logo

Sign in to your account