Podręcznik użytkownika Anuluj

Formatowanie znaków wschodnioazjatyckich

  1. Podręcznik użytkownika programu Illustrator
  2. Poznaj program Illustrator
    1. Wprowadzenie do programu Illustrator
      1. Co nowego w programie Illustrator
      2. Popularne pytania
      3. Wymagania systemowe programu Illustrator
      4. Program Illustrator na urządzenia z układem Apple silicon
    2. Przestrzeń robocza
      1. Podstawy pracy z przestrzenią roboczą
      2. Szybsza nauka dzięki panelowi Odkryj w programie Illustrator
      3. Tworzenie dokumentów
      4. Pasek narzędzi
      5. Domyślne skróty klawiaturowe
      6. Dostosowywanie skrótów klawiaturowych
      7. Wprowadzenie do obszarów roboczych
      8. Zarządzanie obszarami roboczymi
      9. Dostosowywanie przestrzeni roboczej
      10. Panel Właściwości
      11. Ustawianie preferencji
      12. Dotykowa przestrzeń robocza
      13. Obsługa pokrętła Microsoft Surface Dial w programie Illustrator
      14. Cofanie zmian i zarządzanie historią projektu
      15. Obracanie widoku
      16. Miarki, siatki i linie pomocnicze
      17. Ułatwienia dostępu w programie Illustrator
      18. Tryb bezpieczny
      19. Wyświetlanie kompozycji
      20. Używanie paska Touch Bar w programie Illustrator
      21. Pliki i szablony
    3. Narzędzia w programie Illustrator
      1. Przegląd narzędzi
      2. Zaznaczanie narzędzi
        1. Zaznaczenie
        2. Zaznaczanie bezpośrednie
        3. Zaznaczanie grupowe
        4. Różdżka
        5. Lasso
        6. Obszar ilustracji
      3. Narzędzia do nawigacji
        1. Rączka
        2. Obracanie widoku
        3. Lupka
      4. Narzędzia do malowania
        1. Gradient
        2. Siatka
        3. Generator kształtów
      5. Narzędzia tekstowe
        1. Tekst
        2. Tekst na ścieżce
        3. Tekst pionowy
      6. Narzędzia do rysowania
        1. Pióro
        2. Dodaj punkt kontrolny
        3. Usuń punkt kontrolny
        4. Punkt kontrolny
        5. Krzywizna
        6. Linia
        7. Prostokąt
        8. Prostokąt zaokrąglony
        9. Elipsa
        10. Wielokąt
        11. Gwiazda
        12. Pędzel malarski
        13. Kropla
        14. Ołówek
        15. Shaper
        16. Plasterek
      7. Narzędzia do modyfikacji
        1. Obróć
        2. Odbij
        3. Skaluj
        4. Ścinanie
        5. Szerokość
        6. Przekształcanie swobodne
        7. Kroplomierz
        8. Mieszanie
        9. Gumka
        10. Nożyczki
    4. Szybkie operacje
      1. Tekst retro
      2. Tekst z blaskiem neonu
      3. Oldschool tekst
      4. Zmień kolory
      5. Konwertowanie szkicu na wektory
  3. Illustrator na iPadzie
    1. Wprowadzenie do programu Illustrator na iPadzie
      1. Omówienie programu Illustrator na iPadzie
      2. Illustrator na iPadzie — często zadawane pytania
      3. Wymagania systemowe | Illustrator na iPadzie
      4. Możliwości i ograniczenia programu Illustrator na iPadzie
    2. Przestrzeń robocza
      1. Przestrzeń robocza programu Illustrator na iPadzie
      2. Gesty i skróty dotykowe
      3. Skróty klawiszowe w programie Illustrator na iPadzie
      4. Zarządzanie ustawieniami aplikacji
    3. Dokumenty
      1. Praca z dokumentami w programie Illustrator na iPadzie
      2. Importowanie dokumentów z programów Photoshop i Fresco
    4. Zaznaczanie i rozmieszczanie obiektów
      1. Tworzenie obiektów powtarzalnych
      2. Tworzenie przejść miedzy obiektami
    5. Rysowanie
      1. Rysowanie i edytowanie ścieżek
      2. Rysowanie i edytowanie kształtów
    6. Tekst
      1. Praca z tekstem i czcionkami
      2. Tworzenie napisów na ścieżce
      3. Dodawanie własnych czcionek
    7. Praca z obrazami
      1. Wektoryzowanie obrazów rastrowych
    8. Kolory
      1. Stosowanie kolorów i gradientów
  4. Pliki w chmurze
    1. Podstawy
      1. Korzystanie z dokumentów w chmurze w programie Illustrator
      2. Udostępnianie dokumentów w chmurze w programie Illustrator i współpraca nad nimi
      3. Udostępnianie dokumentów do recenzji
      4. Rozszerzanie przestrzeni dyskowej w chmurze na potrzeby programu Adobe Illustrator
      5. Pliki w chmurze w programie Illustrator | Częste pytania
    2. Rozwiązywanie problemów
      1. Rozwiązywanie problemów z tworzeniem lub zapisywaniem plików w chmurze programu Illustrator
      2. Rozwiązywanie problemów z plikami w chmurze programu Illustrator
  5. Dodawanie i edytowanie treści
    1. Rysowanie
      1. Podstawy rysowania
      2. Edycja ścieżek
      3. Rysowanie idealnych kompozycji
      4. Rysowanie za pomocą narzędzi Pióro, Krzywizna lub Ołówek
      5. Rysowanie prostych linii i kształtów
      6. Obrys obrazu
      7. Upraszczanie ścieżki
      8. Definiowanie siatki perspektywy
      9. Narzędzia obsługi symboli i zestawy symboli
      10. Dopasowywanie segmentów ścieżek
      11. Jak w 5 prostych krokach narysować kwiat
      12. Rysowanie perspektywiczne
      13. Symbole
      14. Rysowanie ścieżek wyrównanych do pikseli do zastosowań internetowych
    2. Obiekty 3D i materiały
      1. Informacje o efektach 3D w programie Illustrator
      2. Tworzenie grafiki 3D
      3. Nakładanie kompozycji na obiekty trójwymiarowe
      4. Tworzenie tekstu 3D
    3. Kolor
      1. Informacje o kolorze
      2. Wybieranie kolorów
      3. Używanie i tworzenie próbek
      4. Dopasowywanie kolorów
      5. Korzystanie z panelu Motywy Adobe Color
      6. Grupy kolorów (harmonie)
      7. Panel Motywy Color
      8. Zmiana kolorów kompozycji
    4. Malowanie
      1. Informacje o malowaniu
      2. Malowanie z wypełnieniami i obrysami
      3. Grupy aktywnego malowania
      4. Gradienty
      5. Pędzle
      6. Przezroczystość i tryby mieszania
      7. Stosowanie obrysów do obiektu
      8. Tworzenie i edycja wzorków
      9. Siatki
      10. Wzorki
    5. Zaznaczanie i rozmieszczanie obiektów
      1. Zaznaczanie obiektów
      2. Warstwy
      3. Grupowanie i rozwijanie obiektów
      4. Przesuwanie, wyrównywanie i rozmieszczanie obiektów
      5. Układanie obiektów w stos    
      6. Blokowanie, ukrywanie i usuwanie obiektów
      7. Kopiowanie i powielanie obiektów
      8. Obracanie i odbijanie obiektów
      9. Tworzenie splotu obiektów
    6. Przekształcanie obiektów
      1. Kadrowanie obrazów
      2. Przekształcanie obiektów
      3. Łączenie obiektów
      4. Wycinanie, dzielenie i przycinanie obiektów
      5. Wypaczenie marionetkowe
      6. Skalowanie, ścinanie i zniekształcanie obiektów
      7. Tworzenie przejść miedzy obiektami
      8. Zmiana kształtu za pomocą form
      9. Zmiana kształtu obiektów z efektami
      10. Tworzenie nowych kształtów za pomocą narzędzi Shaper i Generator kształtów
      11. Praca z aktywnymi narożnikami
      12. Udoskonalone obiegi pracy transformacji kształtu z obsługą dotykową
      13. Edytowanie maski przycinającej
      14. Aktywne kształty
      15. Tworzenie kształtów za pomocą narzędzia Generator kształtów
      16. Edycja globalna
    7. Tekst
      1. Dodawanie tekstu i praca z obiektami tekstowymi
      2. Tworzenie punktowanych i numerowanych list
      3. Zarządzanie obszarem tekstu
      4. Czcionki i typografia
      5. Formatowanie tekstu
      6. Importowanie i eksportowanie tekstu
      7. Formatowanie akapitów
      8. Znaki specjalne
      9. Tworzenie tekstu na ścieżce
      10. Korzystanie ze stylów znakowych i akapitowych
      11. Karty
      12. Tekst i pismo
      13. Znajdowanie brakujących czcionek (obieg pracy Typekit)
      14. Uaktualnianie tekstu z programu Illustrator 10
      15. Tekst arabski i hebrajski
      16. Czcionki | Często zadawane pytania i wskazówki dotyczące rozwiązywania problemów
      17. Tworzenie trójwymiarowego efektu tekstowego
      18. Kreatywne projekty typograficzne
      19. Skalowanie i obracanie tekstu
      20. Odstępy pomiędzy wierszami i znakami
      21. Opcje dzielenia wyrazów i łamania wierszy
      22. Udoskonalenia dotyczące tekstu
      23. Słowniki ortograficzne i językowe
      24. Formatowanie znaków azjatyckich
      25. Kompozytory języków azjatyckich
      26. Tworzenie projektów tekstowych z efektem przejścia między obiektami
      27. Tworzenie plakatu typograficznego za pomocą funkcji obrysowywania obrazu
    8. Tworzenie efektów specjalnych
      1. Praca z efektami
      2. Style grafiki
      3. Tworzenie cienia
      4. Atrybuty wyglądu
      5. Tworzenie szkiców i mozaik
      6. Cienie, blaski i wtapianie
      7. Podsumowanie efektów
    9. Grafika WWW
      1. Sprawdzone procedury tworzenia grafiki WWW
      2. Wykresy
      3. SVG 
      4. Tworzenie animacji
      5. Plasterki i mapy obrazów
  6. Importowanie, eksportowanie i zapisywanie
    1. Importowanie
      1. Umieszczanie wielu plików
      2. Zarządzaj plikami połączonymi i osadzonymi
      3. Informacje o łączach
      4. Cofanie osadzenia obrazów
      5. Importowanie kompozycji z programu Photoshop
      6. Importowanie obrazów bitmapowych
      7. Importowanie plików Adobe PDF
      8. Importowanie plików EPS, DCS i AutoCAD
    2. Biblioteki Creative Cloud w programie Illustrator
      1. Biblioteki Creative Cloud w programie Illustrator
    3. Zapisywanie
      1. Zapisywanie kompozycji
    4. Eksportowanie
      1. Używanie kompozycji z programu Illustrator w programie Photoshop
      2. Eksportowanie kompozycji
      3. Gromadzenie zasobów i eksportowanie zbiorcze
      4. Pliki pakietów
      5. Tworzenie plików Adobe PDF
      6. Wyodrębnianie kodu CSS | Illustrator CC
      7. Opcje Adobe PDF
      8. Informacje o pliku i metadane
  7. Drukowanie
    1. Przygotowanie do drukowania
      1. Przygotowywanie dokumentów do druku
      2. Zmiana rozmiaru i orientacji strony
      3. Definiowanie linii cięcia w celu przycinania lub wyrównywania
      4. Rozpoczynanie pracy z powiększonym obszarem dokumentu
    2. Drukowanie
      1. Nadruk
      2. Drukowanie z włączoną funkcją zarządzania kolorami
      3. Drukowanie w trybie PostScript
      4. Ustawienia predefiniowane drukowania
      5. Znaczniki drukarskie i spady
      6. Drukowanie i zapisywanie przezroczystej kompozycji
      7. Zalewkowanie
      8. Drukowanie rozbarwień
      9. Drukowanie gradientów, siatek i przejść kolorów
      10. Nadruk bieli
  8. Automatyzacja zadań
    1. Scalanie danych za pomocą panelu Zmienne
    2. Automatyzacja za pomocą skryptów
    3. Automatyzacja za pomocą operacji
  9. Rozwiązywanie problemów 
    1. Problemy związane z awarią
    2. Odzyskiwanie plików po awarii
    3. Problemy z plikami
    4. Obsługiwane formaty plików
    5. Problemy ze sterownikiem karty graficznej
    6. Problemy z urządzeniem Wacom
    7. Problemy z plikami DLL
    8. Problemy z pamięcią
    9. Problemy z plikiem preferencji
    10. Problemy z czcionkami
    11. Problemy z drukarką
    12. Udostępnianie raportu o awarii firmie Adobe
    13. Poprawianie wydajności programu Illustrator

Informacje o tym, w jaki sposób formatować tekst w językach wschodnioazjatyckich.

Program Illustrator zapewnia wiele opcji służących do formatowania znaków wschodnioazjatyckich. Dostępne są na przykład azjatyckie atrybuty czcionek Open Type i można używać Tate-chu-yoko, Aki, Warichu, Mojisoroe, Mojikumi, Kinsoku, Burasagari oraz Kurikaeshi Moji Shori. Ponadto można łączyć czcionki azjatyckie z łacińskimi i tworzyć czcionki kompozytowe.

Wyświetlanie opcji tekstu wschodnioazjatyckiego

W domyślnej konfiguracji programu Illustrator wszystkie opcje tekstu wschodnioazjatyckiego na panelach Typografia, Akapit i OpenType oraz w menu Tekst są ukryte.

  1. Wybierz polecenie Edycja > Preferencje > Tekst (Windows) lub Illustrator > Preferencje > Tekst (macOS).

  2. Zaznacz opcję Pokaż opcje wschodnioazjatyckie i kliknij przycisk OK.

    Można również określić sposób wyświetlania nazw czcionek (po angielsku lub w języku oryginalnym), wybierając polecenie Pokaż nazwy czcionek po angielsku.

Uwaga:

System operacyjny musi obsługiwać języki, które mają być używane. Dodatkowymi informacjami dysponują producenci oprogramowania systemowego.

Ustawianie atrybutów azjatyckich czcionek OpenType

Czcionki azjatyckie typu OpenType mogą zawierać wiele elementów, które nie są dostępne w tradycyjnych czcionkach typu PostScript i TrueType. Ponadto azjatyckie czcionki OpenType zawierają alternatywne glify wielu znaków.

  1. Zaznacz znaki lub obiekty, wobec których ma zostać zastosowane ustawienie. Jeśli nie jest zaznaczony żaden tekst, bieżące ustawienie będzie stosowane do nowo tworzonego tekstu.
  2. Wybierz azjatycką czcionkę OpenType z menu Tekst > Czcionka. Przy czcionkach OpenType wyświetlana jest ikona .

  3. Wybierz polecenie Okno > Tekst > OpenType i ustaw dowolne z następujących opcji:

    • Metryki proporcjonalne: Kerning zgodny z metryką proporcjonalną czcionki.
    • Styl H lub V: Włącza czcionki hiragana, które zawierają różne glify znaków pionowych lub poziomych odpowiadające na przykład podwójnym spółgłoskom i indeksom fonetycznym.
    • Łacińskie (kursywa): Zamienia znaki alfanumeryczne o połowie szerokości na kursywę.

Zastępowanie znaków azjatyckich glifami o innej formie

  1. Zaznacz znaki, które mają być zastąpione.
  2. Otwórz ekran Tekst > Glify i wybierz jedną z opcji z menu Glify. Jeśli opcje nie są widoczne, zaznacz opcję Pokaż opcje wschodnioazjatyckie w oknie preferencji tekstu. Jeśli jakaś opcja jest wygaszona, to odpowiadająca jej forma glifu nie jest dostępna:

    • Warianty tradycyjne: Zastępuje zaznaczone znaki tradycyjnymi formami.
    • Warianty eksperckie: Zastępuje zaznaczone znaki formami specjalistycznymi.
    • Warianty JIS 04: Zastępuje zaznaczone znaki formami JIS 04.
    • Warianty JIS 90: Zastępuje zaznaczone znaki formami JIS 90.
    • Warianty JIS 78: Zastępuje zaznaczone znaki formami JIS 78.
    • Warianty JIS 83: Zastępuje zaznaczone znaki formami JIS 83.
    • Warianty półfiretowe z czcionką o stałej szerokości: Zamienia glify zaznaczonych znaków łacińskich na hankaku o stałej szerokości (półfiretowe).
    • Warianty 1/3 firetu z czcionką o stałej szerokości: Zamienia glify zaznaczonych znaków łacińskich na hankaku o szerokości 1/3 firetu.
    • Warianty 1/4 firetu z czcionką o stałej szerokości: Zamienia glify zaznaczonych znaków łacińskich na hankaku o szerokości 1/4 firetu.
    Uwaga:

    Aby zamienić alternatywne glify z powrotem na formy domyślne, zaznacz je i wybierz polecenie Przywróć warianty domyślne z menu panelu Glify. Metody tej nie można zastosować do glifów alternatywnych, które uzyskano za pomocą stylu znaków.

Określanie sposobu pomiaru interlinii w tekście azjatyckim

  1. Zaznacz akapit do dostosowania.
  2. Otwórz ekran Okno > TekstAkapit i wybierz pierwszą opcję z menu panelu Akapit.

    • Interlinia góra-góra: Interlinia jest mierzona od górnej krawędzi jednego wiersza do górnej krawędzi następnego wiersza. Gdy jest używana opcja interlinii typu góra-góra, pierwszy wiersz tekstu w akapicie jest wyrównywany do górnej krawędzi obwiedni.
    • Interlinia dół-dół: W przypadku tekstu poziomego mierzy odległość pomiędzy wierszami tekstu od linii bazowej pisma. Gdy jest używana opcja interlinii typu dół-do-dołu, pierwsza linia tekstu jest odsunięta od obwiedni.
    Uwaga:

    Opcje interlinii nie mają wpływu na liczbę interlinii między wierszami, tylko na sposób ich poprowadzenia.

Obracanie znaków o szerokości połówkowej w tekście pionowym

W tekście pionowym zmienia się orientacja znaków półfiretowych, np. znaków łacińskich i liczb. Znaki o szerokości połówkowej są domyślnie obracane indywidualnie. Aby wyłączyć obracanie znaków o szerokości połówkowej, wyłącz zaznaczenie opcji Standardowe wyrównanie znaków łacińskich w pionie w menu panelu Typografia (Okno > Tekst > Typografia).

Znaki łacińskie przed obróceniem i po obróceniu
Znaki łacińskie przed obróceniem i po obróceniu

Korzystanie z bloków tate-chu-yoko

Tate-chu-yoko (nazywana również kumimoji i renmoji) to blok tekstu poziomego nałożony na wiersze tekstu pionowego. Bloki tate-chu-yoko ułatwiają czytanie znaków o połówkowej szerokości, takich jak liczby, daty i krótkie słowa obce, umieszczonych w tekście pionowym.

Liczebniki bez zastosowania tate-chu-yoko (po lewej) i liczebniki po zastosowaniu tate-chu-yoko (po prawej)
Liczebniki bez zastosowania tate-chu-yoko (po lewej) i liczebniki po zastosowaniu tate-chu-yoko (po prawej)

  1. Zaznacz znaki i wybierz polecenie Tate-chu-yoko z menu panelu Typografia (Okno > TekstTypografia). Jeśli nie opcja Tate-chu-yoko nie jest widoczna, zaznacz opcję Pokaż opcje wschodnioazjatyckie na ekranie preferencji tekstowych.

  2. Wybierz dowolne ustawienia tate-chu-yoko z menu panelu Typografia:

    • Góra/Dół: Umożliwia podanie wartości dodatnich w celu określenia przesunięcia w górę lub ujemnych w celu przesunięcia w dół.
    • Lewe/Prawe: Umożliwia podanie wartości dodatnich w celu określenia przesunięcia w prawo lub ujemnych w celu przesunięcia w lewo.

    Wybierz polecenie Pokaż opcje z menu panelu Typografia, a następnie kliknij opcję  Tsumelub ustaw światło zaznaczonych znaków na panelu Typografia, aby zmodyfikować odstępy między znakami w bloku tate-chu-yoko.

Stosowanie odstępów Aki

Aki to pusta przestrzeń przed lub za znakiem. Pomiędzy znakami zwykle umieszczany jest stały odstęp, zgodny z ustawieniem Mojikumi danego akapitu. W przypadku znaków specjalnych ustawienie mojikumi można zmienić, używając opcji Wstaw znak Aki dostępnej na panelu Typografia. Na przykład, aby dodać odstęp przed nawiasem otwierającym, użyj opcji Wstaw znak Aki (z lewej).

Nawias bez odstępu aki (po lewej) i nawias z odstępem aki (po prawej)
Nawias bez odstępu aki (po lewej) i nawias z odstępem aki (po prawej)

  1. Zaznacz znaki, które chcesz zmodyfikować, za pomocą narzędzia Tekst i przejdź na panel Typografia (Okno > Tekst > Typografia).

  2. Aby dodać odstęp aki przed lub po znaku, określ wielkość odstępu aki za pomocą rozwijanego menu Wstaw znak Aki (po lewej) lub Wstaw znak Aki (po prawej) na panelu Typografia. Na przykład wybranie opcji 2-bu spowoduje ustawienie odstępu o połowie szerokości spacji firetowej, a wybranie opcji 4-bu — o ćwierci szerokości spacji firetowej.

  3. Aby zmniejszyć odstępy aki pomiędzy znakami, określ wartość procentową Tsume . Im wyższa będzie ta wartość procentowa, tym węższe będą odstępy aki między znakami.

    Znak bez zastosowania tsume (po lewej) i znak po zastosowaniu tsume (po prawej)
    Znak bez zastosowania tsume (po lewej) i znak po zastosowaniu tsume (po prawej)

Jeśli opcje Wstaw znak aki lub Tsume nie są widoczne, zaznacz opcję Pokaż opcje wschodnioazjatyckie w preferencjach tekstu.

Stosowanie Warichu

Opcja Warichu na panelu Typografia umożliwia zmniejszenie rozmiaru kroju czcionki zaznaczonego tekstu do określonego ułamka wielkości oryginału i umieszczenie go w dwóch liniach w poziomie lub pionie, w zależności od orientacji tekstu.

Tekst pionowy i poziomy z warichu
Tekst pionowy i poziomy z warichu

  1. Wybierz polecenie Warichu z menu panelu Typografia.

  2. Wybierz opcję Ustawienia warichu z menu panelu Typografia i określ następujące ustawienia:

    • Wiersze: Określa, ile wierszy tekstu zostanie wyświetlonych jako znaki warichu.
    • Odstęp między wierszami: Określa odległość pomiędzy wierszami znaków warichu.
    • Skala: Określa rozmiar znaków warichu jako procent rozmiaru tekstu podstawowego.
    • Wyrównanie: Określa wyrównanie znaków warichu. Na przykład gdy tekst znajduje się w siatce ramki pionowej, opcja Wyrównanie do góry spowoduje wyrównanie początku znaków warichu do górnej krawędzi ramki. Podgląd wyrównania wskazuje, w jaki sposób tekst warichu będzie wyglądać w odniesieniu do tekstu podstawowego.
    • Opcje łamania wierszy: Określa minimalną liczbę znaków, które muszą poprzedzać podział wiersza, a także minimalną liczbę znaków, które muszą następować po nim.

Wyrównywanie znaków azjatyckich z użyciem mojisoroe

Mojisoroe to sposób wyrównania znaków w tekście azjatyckim. Gdy linia (wiersz lub kolumna) tekstu zawiera znaki o różnych rozmiarach, można określić sposób wyrównania tekstu do znaków największych: do górnej, dolnej lub środkowej krawędzi ramki pola znaku, do linii bazowej znaków łacińskich, do górnej lub dolnej krawędzi pola ICF (prawej lub dolnej w przypadku ramek pionowych). ICF (Ideographic Character Face) to średnia wysokość i szerokość używana przez autorów czcionek do projektowania znaków idiograficznych, które składają się na czcionkę.

Opcje wyrównania znaków
Opcje wyrównania znaków

A. Małe znaki wyrównane do dołu B. Małe znaki wyrównane do środka C. Małe znaki wyrównane do góry 

Otwórz menu panelu Typografia i wybierz jedną z opcji podmenu Wyrównanie znaków:

  • Linia bazowa znaków łacińskich: Małe znaki są wyrównywane na linii bazowej do znaków dużych.
  • Prawe górne pole znaku, Środkowe pole znaku lub Dolne lewe pole znaku: Małe znaki w wierszu są wyrównywane ze wskazanym miejscem na polu znaku dużego. W przypadku pionowych ramek tekstowych opcja Prawe górne pole znaku powoduje wyrównanie tekstu do prawej krawędzi ramki pola znaku, a opcja Dolne lewe pole znaku powoduje wyrównanie tekstu do lewej krawędzi ramki pola znaku.
  • Prawe górne pole ICF oraz Lewe dolne pole ICF: Małe znaki w wierszu są wyrównywane do pola ICF określonego przez duże znaki. W przypadku pionowych ramek tekstowych opcja Prawe górne pole ICF powoduje wyrównanie tekstu do prawej krawędzi pola ICF, a opcja Lewe dolne pole ICF powoduje wyrównanie tekstu do lewej krawędzi pola ICF.

Stosowanie mojikumi

Mojikumi to zbiór reguł określających odstępy między znakami japońskimi, łacińskimi, przestankowymi, specjalnymi, początku i końca wiersza, a także liczbami w piśmie japońskim. Zestaw pozwala też określić wcięcia akapitów.

Istniejące w programie Illustrator zasady odstępów między znakami są zgodne ze specyfikacją JIS (Japanese Industrial Standards), JISx4051‑1995. Program Illustrator zawiera gotowe zestawy mojikumi.

Można również tworzyć własne zestawy. W utworzonym przez siebie zestawie mojikumi można zmienić ustawienia niektórych odstępów, np. odstępu między kropką a nawiasem otwierającym. Można też utworzyć zestaw do celów specjalnych, np. zestaw, w którym pytania będą poprzedzane myślnikami, a odpowiedzi będą ujmowane w nawiasy.

Wybór ustawienia mojikumi akapitu

  1. Na panelu Typografia ustaw wartość opcji Ustaw kerning między znakami na zero.

  2. Na panelu Akapit wybierz jedną z następujących opcji, dostępnych w menu rozwijanym Zestaw Mojikumi:

    • Brak: Wyłącza stosowanie mojikumi.
    • YakumonoHankaku: Stosuje odstępy półfiretowe przy znakach przestankowych.
    • GyomatsuYakumonoHankaku: Stosuje odstępy pełnofiretowe w przypadku większości znaków z wyjątkiem ostatniego znaku w wierszu.
    YakumonoHankaku (po lewej) i GyomatsuYakumonoHankaku (po prawej)
    YakumonoHankaku (po lewej) i GyomatsuYakumonoHankaku (po prawej)

    • GyomatsuYakumonoZenkaku: Stosuje odstępy pełnofiretowe w przypadku większości znaków, w tym ostatniego znaku w wierszu.
    • YakumonoZenkaku: Stosuje odstępy pełnofiretowe przy znakach przestankowych.
    GyomatsuYakumonoZenkaku (po lewej) i YakumonoZenkaku (po prawej)
    GyomatsuYakumonoZenkaku (po lewej) i YakumonoZenkaku (po prawej)

Tworzenie zestawu mojikumi

  1. Wykonaj jedną z następujących czynności:
    • Wybierz polecenie Tekst > Ustawienia Mojikumi.

    • Przejdź na panel Akapit i wybierz polecenie Ustawienia Mojikumi z menu rozwijanego Zestaw Mojikumi.

  2. W oknie dialogowym Ustawienia Mojikumi kliknij opcję Nowy.

  3. Wprowadź nazwę nowego zestawu mojikumi i określ zestaw, na którym zostanie on oparty.

  4. Wybierz opcję % lub bu z rozwijanego menu Jednostki w oknie dialogowym Ustawienia Mojikumi.

  5. Określ wartości: Minimalne, Pożądane i Maksymalne w każdym z ustawień linii.

    Wartość Minimalna jest używana w celu zagęszczenia linii kinsoku (należy podać wartość mniejszą od wprowadzonej w polu Pożądana). Wartość Maksymalna umożliwia rozciąganie linii w przypadku pełnego justowania (należy podać wartość większą od wprowadzonej w polu Pożądana).

    W zależności od rodzaju znaków można podać takie same wartości w polach Minimalne, Pożądane i Maksymalne, aby pozostawić odstępy między znakami bez zmian.

Uwaga:

Jeśli w tej tekście japońskim występuje dużo spacji półfiretowych lub nawiasów łacińskich, mogą nasilić się problemy ze składaniem tekstu. Podczas składu tekstu japońskiego nie zaleca się używania łacińskich nawiasów okrągłych. Należy wtedy stosować firetowe nawiasy okrągłe. Nawiasów łacińskich należy używać tylko wtedy, gdy w tekście japońskim występują dość długie zdania po angielsku lub jeśli brak takich nawiasów powoduje jeszcze poważniejsze problemy.

Korzystanie z zestawów mojikumi

Na panelu Ustawienia Mojikumi wykonaj dowolną z następujących czynności:

  • Aby wyeksportować zestaw, kliknij opcję Eksportuj. Program Illustrator zapisze plik w formacie MJK.

  • Aby zaimportować zestaw, kliknij opcję Importuj i wybierz plik MJK.

  • Aby usunąć zestaw, wybierz go z listy rozwijanej Nazwa, a następnie kliknij opcję Usuń. Wszystkim znakom, do których był zastosowany usunięty zestaw mojikumi, zostaną przywrócone ustawienia domyślne.

    Nie można usuwać gotowych (predefiniowanych) zestawów mojikumi.

Stosowanie kinsoku

Kinsoku shori to zestaw reguł definiujących łamanie wierszy w tekście japońskim. Znaki, których nie można umieszczać ani na początku, ani na końcu linii, są nazywane znakami kinsoku. Program Illustrator zawiera dwa rodzaje zestawów Kinsoku: twarde i miękkie. W miękkich (słabych) zestawach kinsoku nie występują symbole długich samogłosek i małych znaków hiragana. Można użyć tych istniejących zestawów albo utworzyć nowe, dodając lub usuwając znaki kinsoku.

Można również definiować znaki wiszące stosowane w japońskiej interpunkcji wiszącej, a także znaki, które nie mogą być rozdzielane w przypadku przekroczenia pojemności linii.

Kolejna możliwość to określenie, czy tekst ma być wciągany, czy odpychany, aby uniknąć nieprawidłowego umieszczenia znaku kinsoku.

Wybieranie ustawień kinsoku dotyczących akapitu

Otwórz panel Akapit i wybierz jedną z opcji z rozwijanego menu Zestaw Kinsoku:

  • Brak: Wyłącza funkcję kinsoku.
  • Miękki/Twardy: Zapobiega pojawianiu się wybranych znaków na początku lub na końcu wiersza.

Tworzenie zestawu kinsoku

  1. Wykonaj jedną z następujących czynności:
    • Wybierz polecenie Tekst > Ustawienia Kinsoku Shori.

    • Wybierz polecenie Ustawienia Kinsoku z rozwijanego menu Zestaw Kinsoku na panelu Akapit.

  2. W oknie dialogowym Ustawienia Kinsoku Shori kliknij opcję Nowy zestaw.

  3. Wprowadź nazwę nowego zestawu kinsoku i określ zestaw, na którym zostanie on oparty.

  4. Aby dodać znak w jednym z pól, zaznacz to pole i wykonaj jedną z następujących czynności:
    • Wprowadź znak w polu Wprowadzanie, wybierz opcję Wpis bezpośredni i kliknij opcję Dodaj.

    • Określ system kodowania (Shift JIS, JIS, Kuten lub Unicode), wprowadź kod i kliknij opcję Dodaj.

    Aby usunąć znak z pola, zaznacz ten znak i kliknij opcję Usuń.

  5. Aby sprawdzić kod znaku aktualnie dodawanego do pola Wprowadzanie, wybierz opcję Shift JIS, JIS, Kuten lub Unicode.

Stosowanie zestawów kinsoku

W oknie dialogowym Ustawienia Kinsoku Shori wykonaj dowolne operacje:

  • Aby wyeksportować zestaw kinsoku, kliknij opcję Eksportuj. Program Illustrator zapisze plik w formacie KSK.

  • Aby zaimportować zestaw, kliknij opcję Importuj i wybierz plik KSK.

  • Aby usunąć zestaw kinsoku, otwórz rozwijane menu Zestaw kinsoku, wybierz zestaw do usunięcia, a następnie kliknij opcję Usuń zestaw.

    Nie można usuwać gotowych (predefiniowanych) zestawów kinsoku.

Określanie opcji łamania wierszy kinsoku

Aby użyć opisanych poniżej opcji łamania wierszy, należy wcześniej wybrać opcję kinsoku shori lub mojikumi.

Otwórz menu panelu Akapit, kliknij opcję Rodzaj Kinsoku Shori i wybierz jedną z następujących metod:

  • Umieść najpierw wewnątrz: Przenosi znaki do poprzedniej linii tak, by na końcu lub początku wiersza/kolumny nie zostawić zakazanych znaków.
  • Umieść najpierw na zewnątrz: Zawsze przenosi znaki do następnej linii tak, by na końcu lub początku wiersza/kolumny nie zostawić zakazanych znaków.
  • Umieść tylko na zewnątrz: Zawsze przenosi znaki do następnej linii tak, by na końcu lub początku wiersza/kolumny nie zostawić zakazanych znaków. Nie jest podejmowana próba umieszczania wewnątrz.

Włączanie lub wyłączanie zestawu bunri-kinshi

Gdy zaznaczona jest funkcja Bunri-kinshi, znaki określone w sekcji Bunri-Kinshi okna dialogowego Ustawienia Kinsoku Shori nie będą dzielone.

Z menu panelu Akapit wybierz opcję Bunri-kinshi.

Uwaga:

Opcja ta jest dostępna tylko wtedy, gdy jest włączona funkcja kinsoku shori.

Określanie opcji burasagari

Burasagari zezwala na postawienie jednobajtowych i dwubajtowych kropek, a także jednobajtowych i dwubajtowych przecinków na zewnątrz obwiedni akapitu.

  1. Z menu panelu Akapit wybierz opcję Burasagari.

  2. Wybierz jedną z opcji podmenu:
    • Brak: Wyłącza wiszącą interpunkcję.
    • Regularny: Włącza wiszącą interpunkcję, ale bez przyciągania nierównych linii do krawędzi obwiedni.
    • Wymuś: Wymusza wiszącą interpunkcję, rozciągając linie, które znajdują się wewnątrz obwiedni i kończą się jednym z wybranych znaków interpunkcyjnych.

    Opcje Burasagari nie są dostępne, gdy opcja Zestaw Kinsoku jest ustawiona na Brak.

Stosowanie opcji kurikaeshi moji shori

Sposobem postępowania z powtarzającymi się znakami w tekście japońskim można sterować za pomocą opcji Kurikaeshi Moji Shori na panelu Akapit. Domyślnie znacznik powtarzającego się znaku zastępuje drugi znak, gdy dwa identyczne znaki występują jeden po drugim. Po wybraniu opcji Kurikaeshi Moji Shori oba znaki będą wyświetlane, jeśli są oddzielone znakiem końca wiersza.

Tekst bez zaznaczonej opcji Kurikaeshi Moji Shori (po lewej) i tekst z zaznaczoną opcją Kurikaeshi Moji Shori (po prawej)
Tekst bez zaznaczonej opcji Kurikaeshi Moji Shori (po lewej) i tekst z zaznaczoną opcją Kurikaeshi Moji Shori (po prawej)

  1. Wybierz narzędzie Tekst i zaznacz akapit, do którego będzie stosowana obsługa powtarzających się znaków. 

  2. Z menu panelu Akapit wybierz opcję Kurikaeshi Moji Shori.


Zasoby pokrewne

Skontaktuj się z nami

Jeśli masz pytanie lub chcesz się podzielić pomysłem, dołącz do nas na forum użytkowników programu Adobe Illustrator. Chętnie poznamy Twoje opinie i zobaczymy utworzone przez Ciebie dzieła.

Logo Adobe

Zaloguj się na swoje konto