Gdy użytkownik zapisuje lub eksportuje kompozycję, program Illustrator umieszcza jej dane w pliku. Struktura danych zależy od wybranego przez użytkownika formatu pliku.

Dostępnych jest pięć podstawowych formatów plików (AI, PDF, EPS, FXG oraz SVG), w których można zapisać kompozycje. Formaty te nazywa się rodzimymi, ponieważ zachowują wszystkie dane programu Illustrator, w tym informacje o wielu obszarach roboczych. (W przypadku formatów PDF i SVG trzeba w tym celu zaznaczyć opcję Zachowaj możliwości edycyjne programu Ilustrator). Pliki EPS oraz FXG dają możliwość zapisania pojedynczych obszarów roboczych jako osobne pliki. W plikach SVG zapisywany jest wyłącznie aktywny obszar roboczy, lecz wyświetlana jest zawartość wszystkich obszarów roboczych.

Program Illustrator pozwala eksportować kompozycje do wielu formatów zewnętrznych, właściwych innym aplikacjom. Takie formaty nazywa się obcymi, ponieważ program Illustrator nie będzie mógł odzyskać wszystkich danych, gdy ponownie otworzy się plik w programie Illustrator. Z tego powodu zaleca się, aby podczas pracy nad kompozycją w programie Illustrator zapisywać ją w formacie AI, a dopiero po zakończeniu pracy wyeksportować ją do żądanego formatu.

Uwaga:

Podczas zapisywania kompozycji zawierającej połączone pliki EPS, które zapisano w formacie binarnym (np. w domyślnym formacie EPS programu Photoshop), może pojawić się komunikat o błędzie. W takich sytuacjach, zapisz pliki EPS w formacie ASCII, osadź je w kompozycji albo zapisz kompozycję w formacie AI lub PDF, a nie EPS.

Film przedstawiający zapisywanie prac w formacie odpowiednim do publikacji w Internecie można zobaczyć w artykule Zapisywanie kompozycji dla Internetu.

Zapisywanie w formacie programu Illustrator

Jeśli dokument zawiera więcej niż jeden obszar roboczy, a użytkownik chce dokonać zapisu do wcześniejszej wersji programu Illustrator, istnieje możliwość zapisania każdej warstwy jako osobnego pliku lub połączenia zawartości wszystkich obszarów w pojedynczym pliku.

  1. Wybierz polecenie Plik > Zapisz jako lub Plik > Zapisz kopię.

  2. Wpisz nazwę pliku i wybierz jego położenie.

  3. Wybierz format plików programu Ilustrator (*.AI) i kliknij Zapisz.

  4. W oknie dialogowym Opcje, ustaw wybrane opcje i kliknij OK.

    Wersja

    Określa wersję programu Illustrator, z którą ma być zgodny dany plik. Przestarzałe formaty nie obsługują wszystkich funkcji bieżącej wersji programu Illustrator. Dlatego też, po wybraniu wersji innej niż bieżąca, niektóre opcje zapisywania nie są dostępne i określone rodzaje danych zostaną zmienione. Zasady zmiany danych są opisywane w ostrzeżeniach wyświetlanych w dolnej części okna dialogowego.

    Podstaw osadzone czcionki, jeśli procent używanych znaków jest mniejszy od

    Opcja pozwala określić, ile znaków danej czcionki musi być używanych w dokumencie, aby można było osadzić całą czcionkę (a nie tylko jej wykorzystywane znaki). Na przykład, jeśli czcionka obejmuje 1000 znaków, a w dokumencie występuje tylko dziesięć z nich, użytkownik może zrezygnować z osadzania czcionki (zwłaszcza, że zwiększa to rozmiar pliku).

    Utwórz plik zgodny z formatem PDF

    Plik jest zapisywany w formacie programu Ilustrator zgodnym z formatem PDF. Wybierz tę opcję, aby plik był zgodny z innymi aplikacjami firmy Adobe.

    Dołącz połączone pliki

    Pliki połączone z kompozycją są osadzane.

    Osadź profile ICC

    Tworzy dokument z zarządzanymi kolorami.

    Użyj kompresji

    Dane PDF w pliku programu Illustrator są kompresowane. Gdy jest przeprowadzana kompresja, wydłuża się czas zapisywania pliku, dlatego też możesz zaobserwować bardzo długie czasy zapisu (od 8 do 15 minut).

    Zapisywanie każdego obszaru roboczego do osobnego pliku

    Każdy obszar roboczy jest zapisywany jako osobny plik. Tworzony jest także plik wzorcowy zawierający wszystkie obszary robocze. Cała zawartość mająca związek z danym obszarem roboczym jest zawarta w pliku tego obszaru. Jeśli trzeba zmienić położenie kompozycji, tak aby pasowała do pojedynczego obszaru roboczego, wyświetlone zostanie ostrzeżenie. Jeśli nie wybierzesz tej opcji, obszary robocze zostaną połączone w pojedynczy dokument i skonwertowane na linie pomocnicze obiektów i (w programie Illustrator CS3) obszary kadrowania. Obszar roboczy użyty dla zapisanego pliku bazuje na rozmiarze domyślnego profilu startowego dokumentu.

    Opcje przezroczystości

    Opcje pozwalają określić sposób traktowania obiektów przezroczystych w przypadku, gdy wybrano format programu Illustrator w wersji wcześniejszej niż 9.0. Zaznaczenie opcji Zachowaj ścieżki powoduje pominięcie wszystkich efektów przezroczystości, ustawienie 100-procentowego krycia i zwykłego trybu mieszania. Zaznaczenie opcji Zachowaj wygląd i nadruki powoduje zachowanie nadruków, które nie stykają się z obiektami przezroczystymi. Nadruki wchodzące w interakcje z obiektami przezroczystymi są spłaszczane.

    Uwaga: jeśli kompozycja zawiera złożone, nakładające się obszary, a zachodzi potrzeba korzystania z wysokiej rozdzielczości, kliknij Anuluj i określ ustawienia rasteryzacji.

Zapisywanie w formacie EPS

Praktycznie wszystkie programy DTP, edytory tekstu i edytory grafiki obsługują importowane lub umieszczane pliki EPS (Encapsulated PostScript). Format EPS zachowuje wiele elementów graficznych, które tworzy się w programie Adobe Illustrator. Znaczy to, że pliki EPS mogą być ponownie otwierane i edytowane jako pliki programu Illustrator. Ponieważ są one oparte na języku PostScript, pliki EPS mogą zawierać zarówno grafikę wektorową jak i bitmapową. Jeśli kompozycja zawiera wiele obszarów roboczych, obszary te są zachowane podczas zapisywania do pliku EPS.

  1. Jeśli kompozycja zawiera obszary przezroczyste (wraz z nadrukami), a materiał wyjściowy musi być w wysokiej rozdzielczości, sprawdź efekty spłaszczenia, wybierając polecenie Okno > Podgląd spłaszczania.

  2. Wybierz polecenie Plik > Zapisz jako lub Plik > Zapisz kopię.

  3. Wpisz nazwę pliku i wybierz jego położenie.

  4. Wybierz format EPS programu Illustrator (*.EPS) i kliknij Zapisz.

  5. Jeśli dla każdego obszaru roboczego zostanie utworzony osobny plik, kliknij opcję Użyj obszarów roboczych lub określ zakres. Osobne pliki są zapisywane wraz z głównym plikiem EPS, który zawiera wszystkie obszary robocze. Jeśli nie zaznaczysz tej opcji, utworzony zostanie pojedynczy plik EPS zawierający wszystkie obszary robocze.

  6. W oknie dialogowym Opcje EPS ustaw pożądane opcje i kliknij OK:

    Wersja

    Określa wersję programu Illustrator, z którą ma być zgodny dany plik. Przestarzałe formaty nie obsługują wszystkich funkcji bieżącej wersji programu Illustrator. Dlatego też, po wybraniu wersji innej niż bieżąca, niektóre opcje zapisywania nie są dostępne i określone rodzaje danych zostaną zmienione. Zasady zmiany danych są opisywane w ostrzeżeniach wyświetlanych w dolnej części okna dialogowego.

    Format

    Określa właściwości obrazu podglądu zapisywanego w pliku. Obrazek podglądu wyświetlany jest w aplikacjach, które nie mogą prawidłowo wyświetlać grafiki EPS. Jeśli nie ma potrzeby tworzenia obrazka podglądu, wybierz z menu Format polecenie Brak. W przeciwnym wypadku wybierz format kolorowy lub czarno-biały.

    Dla formatu TIFF (kolor 8-bitowy), wybierz opcję tła podglądu:

    Przezroczysty

    Daje przezroczyste tło.

    Kryjący

    Daje jednolite tło. (Jeśli dokument EPS będzie używany w aplikacji pakietu Microsoft Office, wybierz opcję Nieprzezroczyste).

    Opcje przezroczystości

    Określają zasady obsługi obiektów przezroczystych i nadruków. Dostępne opcje zmieniają się w zależności od wersji formatu wybranej w górnej części okna dialogowego.

    Po wybraniu formatu CS, określ zasady zapisywania nakładających się kolorów wybranych do nadruku oraz wybierz gotowy zestaw opcji dla spłaszczania przezroczystości. Kliknij Własny i utwórz własny zestaw ustawień spłaszczania.

    Po wybraniu formatu dziedziczonego wcześniejszego niż 8.0, wybierz opcję Zachowaj ścieżki dla usunięcia efektów przezroczystości i wyzerowania kompozycji przezroczystej do 100% krycia i trybu mieszania Normalny. Zaznaczenie opcji Zachowaj wygląd i nadruki powoduje zachowanie nadruków, które nie stykają się z obiektami przezroczystymi. Nadruki wchodzące w interakcje z obiektami przezroczystymi są spłaszczane.

    Odsadź czcionki (dla potrzeb innych aplikacji)

    Wszystkie czcionki o odpowiednich uprawnieniach są osadzane. Osadzanie czcionek daje pewność, że mimo przeniesienia pliku do innej aplikacji (np. Adobe InDesign), będą wyświetlane i drukowane oryginalne czcionki. Jeśli jednak plik zostanie otwarty na komputerze, na którym nie zainstalowano odpowiedniej czcionki, czcionka zostanie podstawiona. Zasada ta zapobiega nielegalnemu używaniu czcionek.

    Uwaga: wybór opcji Osadź czcionki zwiększa rozmiar zapisywanego pliku.

    Dołącz połączone pliki

    Pliki połączone z kompozycją są osadzane.

    Dołącz miniatury dokumentu

    Tworzona jest miniaturka kompozycji. Miniaturka ta jest wyświetlana w oknach dialogowych Otwórz i Umieść.

    Uwzględnij tryb CMYK PostScript w plikach RGB

    Umożliwia drukowanie dokumentów zapisanych z trybem koloru RGB za pomocą aplikacji, które nie obsługują tego trybu. Przy ponownym otwarciu pliku EPS w programie Illustrator kolory RGB są zachowywane.

    Drukowanie gradientów w trybie kompatybilności

    Opcja umożliwia drukowanie gradientów i obiektów z siatkami gradientu na starszych drukarkach i urządzeniach PostScript – gradienty są konwertowane na format JPEG. Jeśli opcja jest używana do drukarek bezbłędnie drukujących gradienty, może niepotrzebnie zwolnić proces drukowania.

    Adobe PostScript®

    Określa używany przy zapisywaniu pliku poziom języka Postscript. Język PostScript Language Level 2 (poziom 2) umożliwia opis zarówno obrazów wektorowych, jak i bitmapowych, niezależnie od tego, czy są to obrazy kolorowe, czy w skali szarości, i czy są zdefiniowane w modelu kolorów RGB, CMYK, czy CIE. W porównaniu z poziomem 2, język PostScript poziomu 3 udostępnia dodatkowe możliwości, na przykład możliwość drukowania obiektów siatkowych na drukarce PostScript® 3™. Ponieważ drukowanie na urządzeniach zgodnych z językiem PostScript Level 2 jest poprzedzane konwersją siatek gradientów na obrazy bitmapowe, zaleca się, by kompozycje zawierające siatki gradientów były drukowane na drukarkach PostScript 3.

Zapisywanie w formacie SVG

Format SVG jest formatem wektorowym, przeznaczonym do tworzenia wysokiej jakości, interaktywnej grafiki internetowej. Format SVG występuje w dwóch odmianach: SVG i Skompresowany SVG (SVGZ). Format SVGZ pozwala zmniejszyć rozmiary plików o 50% do 80%, niemniej uzyskanych plików nie można edytować za pomocą edytorów tekstowych.

Zapisywanie grafiki w formacie SVG powoduje rasteryzację obiektów z siatką gradientu. Co więcej obrazki kompozycji, które nie zawierają kanału alfa, są konwertowane do formatu JPEG. Obrazki z kanałem alfa są konwertowane do formatu PNG. Jeśli dokument zawiera więcej niż jeden obszar roboczy i zapiszesz go jako plik SVG, zachowany zostanie aktywny obszar roboczy. Nie można zapisać pojedynczych obszarów roboczych jako plików SVG.

  1. Jeśli kompozycja zawiera jakiekolwiek efekty SVG, zaznacz wszystkie elementy, do których zastosowano takie efekty i przenieś je na dół panelu Wygląd (tuż nad pozycję Krycie). Jeśli inne efekty następują po efekcie filtra SVG, plik SVG będzie zawierał obiekt rastrowy. Ponadto, jeśli kompozycja zawiera wiele obszarów roboczych, zaznacz ten obszar, który chcesz wyeksportować.

  2. Wybierz polecenie Plik > Zapisz jako lub Plik > Zapisz kopię.

  3. Wpisz nazwę pliku i wybierz jego położenie.

  4. Wybierz format SVG lub Skompresowany SVG (SVGZ) i kliknij Zapisz.

  5. W oknie dialogowym Opcje SVG ustaw wybrane opcje i kliknij OK:

    Profile SVG

    Określa wymagany typ definicji dokumentu SVG XML dla eksportowanego pliku.

    SVG 1.0 i SVG 1.1

    Odpowiedni dla plików SVG przeznaczonych do wyświetlania na komputerach. SVG 1.1 jest pełną wersją specyfikacji SVG, której podzestawami są SVG Tiny 1.1, SVG Tiny 1.1 Plus i SVG Basic 1.1.

    SVG Basic 1.1

    Odpowiednie dla plików SVG przeznaczonych do wyświetlania na urządzeniach typu palmtop. Należy jednak pamiętać, że nie wszystkie urządzenia tego typu obsługują profil SVG Basic. Co za tym idzie, nie zawsze wybranie tej opcji gwarantuje, że plik SVG będzie widoczny na wszystkich urządzeniach tego typu. SVG Basic nie obsługuje nieprostokątnego odcinania i niektórych efektów filtrów SVG.

    SVG Tiny 1.1 oraz SVG Tiny 1.1+

    Odpowiednie dla plików SVG przeznaczonych do wyświetlania na małych urządzeniach (np. telefonach komórkowych). Należy jednak pamiętać, że nie wszystkie telefony obsługują profile SVG Tiny i SVG Tiny Plus. Co za tym idzie, nie zawsze wybranie jednej z tych opcji gwarantuje, że plik SVG będzie widoczny na wszystkich małych urządzeniach.

    SVG Tiny 1.2

    Odpowiedni dla plików SVG przeznaczonych do wyświetlania na różnorodnych urządzeniach, od przenośnych organizatorów cyfrowych i telefonów komórkowych, do laptopów i komputerów biurkowych.

    Format SVG Tiny nie obsługuje gradientów, przezroczystości, odcinania, masek, symboli, wzorków, podkreślenia i przekreślenia tekstu, tekstu pionowego oraz efektów filtrów SVG. Format SVG Tiny Plus posiada możliwość wyświetlania gradientów i przezroczystości, ale nie obsługuje odcinania, masek, symboli i efektów filtrów SVG.

    Wskazówka: dodatkowe informacje na temat profilów SVG znajdują się w specyfikacji SVG na stronie World Wide Web Consortium (www.w3.org).

    Typ czcionki

    Określa zasady eksportu czcionek:

    Adobe CEF

    Używa hintingu czcionek do lepszego renderingu małych czcionek. Ten typ czcionki jest obsługiwany przez Adobe SVG Viewer, ale może być nieobsługiwany przez inne przeglądarki SVG.

    SVG

    Nie używa hintingu czcionek. Ten typ czcionki jest obsługiwany przez wszystkie przeglądarki SVG.

    Konwertuj na kontury

    Konwertuje tekst na ścieżki wektorowe. Opcja jest przeznaczona do zachowania wyglądu tekstu we wszystkich przeglądarkach SVG.

    Podstawianie czcionek

    Określa, które glify (znaki danej czcionki) zostaną osadzone w eksportowanym pliku SVG. Aby używać wyłącznie czcionek zainstalowanych w systemie użytkownika, wybierz ustawienie Brak. Aby osadzić tylko te glify, które występują w tekście bieżącej kompozycji, wybierz ustawienie Tylko używane glify. Pozostałe ustawienia (Typowe angielskie, Typowe angielskie + Glify, Typowe łacińskie, Typowe łacińskie + Glify, Wszystkie glify) są przydatne, gdy tekstowa zawartość pliku SVG ma charakter dynamiczny (np. jest to tekst generowany przez serwer lub tekst zmieniany w interakcji z użytkownikiem).

    Położenie obrazów

    Opcja Położenie obrazów decyduje o tym, czy obrazy rastrowe są osadzane bezpośrednio w pliku, czy są dołączane do eksportowanych obrazków JPEG lub PNG z oryginalnego pliku programu Illustrator. Osadzanie obrazów powoduje zwiększenie rozmiarów pliku, ale zapewnia ich dostępność.

    Zachowaj możliwości edycyjne programu Ilustrator

    Zachowuje dane charakterystyczne dla programu Ilustrator poprzez osadzenie pliku AI w pliku SVG (operacja zwiększa rozmiar pliku). Opcję tę wybierz, jeśli plik SVG ma być ponownie otwierany i edytowany w programie Illustrator. Należy pamiętać, że zmiany odręcznie wprowadzane do danych SVG nie są odtwarzane po powtórnym otwarciu pliku. Dzieje się tak, ponieważ program Illustrator odczytuje część AI danego pliku, pomijając część SVG.

    Właściwości CSS

    Opcja określa sposób zapisu atrybutów stylu w kodzie SVG. Metoda domyślna, Atrybuty prezentacji, polega na zastosowaniu własności w najwyższym punkcie hierarchii. Opcja zapewnia najwyższy stopień swobody konkretnych przekształceń i czynności edycyjnych. Metoda Atrybuty stylu pozwala tworzyć pliki najbardziej czytelne, ale może zwiększyć rozmiar pliku. Metodę tę wybierz, jeśli kod SVG będzie używany w przekształceniach (np. XSLT, czyli Extensible Stylesheet Language Transformation). Metoda Atrybuty stylu <Entity References> zapewnia szybszy rendering i mniejszy rozmiar wynikowego pliku SVG. Metoda Elementy stylu jest przeznaczona dla plików używanych wspólnie z dokumentami HTML. Po wybraniu opcji Elementy stylu można zmodyfikować plik SVG. Przenieść element stylu do zewnętrznego pliku arkusza stylów, który jest również wywoływany w pliku HTML. Opcja Elementy stylu wydłuża czas renderingu.

    Liczba miejsc po przecinku

    Określa dokładność danych wektorowych w pliku SVG. Można wybrać od 1 do 7 miejsc po przecinku. Wyższe wartości powodują zwiększenie rozmiarów pliku i jakości obrazu.

    Kodowanie

    Określa sposób kodowania znaków w pliku SVG. Kodowanie UTF (Unicode Transformation Format) jest obsługiwane przez wszystkie procesory XML. (Kodowanie UTF8 stosuje format 8-bitowy; kodowanie UTF16 stosuje format 16-bitowy). Kodowanie ISO 8859‑1 i UTF‑16 nie zachowuje metadanych pliku.

    Optymalizuj dla przeglądarki Adobe SVG

    Zachowuje najwyższy poziom danych programu Ilustrator, a jednocześnie zapewnia ręczną edycję pliku SVG. Opcja ta pozwala korzystać z zalet szybszego renderingu dla takich funkcji jak efekty filtra SVG.

    Dołącz dane serwera grafik Adobe

    Dołącza wszelkie informacje niezbędne do podstawiania zmiennych w pliku SVG.

    Dołącz dane odcinania

    Dołącza położenia odcięć i ustawienia optymalizacji.

    Dołącz XMP

    Dołącza metadane XMP w pliku SVG. Aby wpisać metadane, wybierz polecenie Plik > Informacje lub użyj przeglądarki Bridge.

    Generuj mniej elementów <tspan>

    Umożliwia pominięcie ustawień autokerningu podczas eksportu w programie Illustrator, co powoduje tworzenie pliku z mniejszą liczbą elementów <tspan>. Opcja jest przeznaczona do tworzenia bardziej edytowalnego i mniejszego pliku SVG. Opcja nie powinna być zaznaczona, jeśli istotne jest zachowanie wyglądu tekstu z autokerningiem.

    Użyj elementu <textPath> dla tekstu na ścieżce

    Eksportuje tekst na ścieżce w postaci elementu <textPath>. Należy jednak pamiętać, że tekst może być wyświetlony inaczej w przeglądarce SVG, niż w programie Illustrator, ponieważ dany tryb eksportu nie zawsze zachowuje wygląd. Należy zwrócić szczególną uwagę na wyświetlanie w przeglądarce SVG tekstu wylewającego się.

    Pokaż kod SVG

    Wyświetla kod dla pliku SVG w przeglądarce internetowej.

    Podgląd WWW

    Wyświetla plik SVG w przeglądarce internetowej.

    Device Central

    Otwiera plik w programie Device Central, umożliwiając podgląd na konkretnym telefonie komórkowym albo urządzeniu przenośnym.

Zapisz kompozycję dla Microsoft Office

Polecenie Zapisz dla Microsoft Office pozwala utworzyć plik PNG, który będzie można wykorzystać w aplikacjach z pakietu Microsoft Office.

  1. Wybierz polecenie Plik > Zapisz dla Microsoft Office.

  2. W oknie dialogowym Zapisz dla Office wybierz miejsce zapisania pliku, wpisz jego nazwę i kliknij Zapisz.

    Uwaga:

    Jeśli chcesz dostosować ustawienia PNG (np. rozdzielczość, przezroczystość i kolor tła), użyj polecenia Eksportuj, a nie polecenia Zapisz dla Microsoft Office. Zapis kompozycji w formacie PNG umożliwia również polecenie Zapisz dla Internetu i urządzeń.

Przekształcanie grafiki wektorowej w obrazy bitmapowe

Informacje o rasteryzacji

Rasteryzacja jest procesem przekształcania grafiki wektorowej na obrazy bitmapowe. W jego wyniku ścieżki graficzne są konwertowane na piksele. Wielkość pikseli oraz inne ich własności są wyznaczone przez opcje rasteryzacji.

Pojedyncze obiekty wektorowe mogą być rasteryzowane przy pomocy polecenia Obiekt > Rasteryzacja lub efektu Rasteryzacja. Rasteryzacja całego dokumentu jest możliwa poprzez wyeksportowanie go do formatu bitmapy (JPEG, GIF lub TIFF).

Rasteryzowanie obiektu wektorowego

  1. Zaznacz przynajmniej jeden obiekt.

  2. Wykonaj jedną z następujących czynności:

    • Aby wykonać rzeczywistą rasteryzację obiektów na stałe, wybierz polecenie Obiekt > Rasteryzacja.

    • Aby utworzyć wzrokowe wrażenie rasteryzacji bez zmiany struktury obiektu, wybierz polecenie Efekt > Rasteryzacja.

  3. Ustaw opcje rasteryzacji i kliknij przycisk OK.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online