Aby móc szybko tworzyć kształty wektorowe, należy korzystać z potężnych narzędzi Kształt. Większość kształtów jest kształtami aktywnymi, co oznacza, że można je dynamicznie dopasowywać — bez konieczności przełączania na inne narzędzia — przy użyciu wyświetlonych na kształcie widżetów sterowania lub elementów sterujących dostępnych w panelu Przekształcenia.

Aktywne kształty

Tworzenie i modyfikowanie aktywnych kształtów

  1. Narysuj aktywny kształt przy użyciu jednego z poniższych narzędzi:

    • Narzędzie Prostokąt ()
    • Narzędzie Prostokąt zaokrąglony ()
    • Narzędzie Elipsa ()
    • Narzędzie Wielokąt ()
    • Narzędzie Shaper ()
    • Narzędzie Linia ()

    Uwaga:

    • Aby obwiednia była wyświetlana przy zaznaczaniu obiektu, należy sprawdzić, czy w menu Widok (Widok > Pokaż obwiednię) została wybrana odpowiednia opcja.
    • Aby widzieć ekranowe widżety sterowania podczas wyboru kształtu, należy wybrać dowolne narzędzie rysowania aktywnych kształtów i upewnić się, że w panelu sterowania jest wybrane ustawienie Pokaż widżety kształtów ().

  2. Użyj poniższych widżetów sterowania kształtami, aby modyfikować aktywne kształty:

    Skalowanie aktywnych kształtów Obracanie aktywnych kształtów

    Aby skalować aktywny kształt, należy przeciągnąć dowolny z ośmiu uchwytów obwiedni.

    Aby obrócić aktywny kształt, należy odsuwać kursor od narożnika do chwili wyświetlenia ikony obrotu (), a następnie przeciągnąć go.


    Przenoszenie aktywnych kształtów Tworzenie kształtów kołowych

    Aby przenieść aktywny kształt, należy użyć widżetu punktu centralnego do przeciągnięcia go w pożądane miejsce.

    W przypadku elipsy, w celu stworzenia kształtu kołowego należy przeciągnąć jeden z widżetów wycinka.


    Dodawanie lub usuwanie boków wielokąta Zmiana promienia narożnika aktywnych kształtów

    Aby zmienić liczbę boków wielokąta, przeciągnij jego boczny widżet.

    Przeciągnij dowolny widżet, aby zmienić promień narożnika aktywnego kształtu.


    Uwaga:

    • Podczas przeciągania widżetów narożnika do maksymalnej możliwej wielkości podgląd zaokrąglonych narożników jest wyświetlany na czerwono.
    • Aby zmieniać style narożników (dostępne są narożniki zaokrąglone, odwrócone zaokrąglone i fazowane), należy kliknąć widżet narożnika z wciśniętym klawiszem Alt (Windows) lub Option (macOS) bądź nacisnąć strzałkę w górę lub dół, przeciągając jednocześnie widżet.
    • Aby otworzyć menu Narożniki w celu dostosowania parametrów wyglądu i zaokrąglenia, należy kliknąć dwukrotnie widżet przy użyciu narzędzia Zaznaczanie bezpośrednie. Szczegółowe informacje zawiera sekcja Praca z aktywnymi narożnikami.
    • Aby edytować narożnik indywidualnie, należy skorzystać z narzędzia Zaznaczanie bezpośrednie i kliknąć punkt kontrolny narożnika, który chcemy zmodyfikować.

  3. Można modyfikować kształty przy użyciu panelu sterowania, panelu Właściwości lub panelu Przekształcenia (Okno > Przekształcenia). Szczegółowe informacje zawiera sekcja Właściwości aktywnych kształtów.

    Uwaga:

    • Panel Przekształcenia można otworzyć, klikając dwukrotnie dowolny widżet narożnika.
    • Aby wybrać, czy panel Przekształcenia zostanie wyświetlony po utworzeniu aktywnego kształtu, użyj opcji Pokaż podczas tworzenia kształtu w menu panelu Przekształcenia.
    • Niezależnie od wybranego narzędzia po wybraniu kształtów tego samego typu modyfikowanie właściwości w panelu Przekształcenia będzie miało wpływ na zaznaczoną kompozycję.

Określanie opcji aktywnych kształtów

Aby wyświetlić lub edytować właściwości aktywnych kształtów, należy wykonać jedną z poniższych czynności:

  • Otwórz panel Przekształcenia poprzez dwukrotne kliknięcie dowolnego widżetu narożnika lub wybranie opcji Okno > Przekształcenia.
  • W sekcji Przekształcenia w panelu Właściwości (Okno > Właściwości) kliknij przycisk Więcej opcji ().

Określanie opcji aktywnych kształtów
Określanie opcji aktywnych kształtów

A. Panel Przekształcenia B. Panel Właściwości 

Prostokąt / Prostokąt zaokrąglony

Właściwości aktywnych kształtów | Prostokąt i prostokąt zaokrąglony
  • Szerokość/wysokość: określa wysokość lub szerokość prostokąta. Narożniki i ich promienie nie ulegają zmianie.
  • Kąt prostokąta: obracanie prostokąta za pomocą widżetu Skaluj/obróć.
  • Typ narożnika: określa typ narożnika dla dowolnych narożników prostokąta.
  • Promienie kątów: umożliwia zmianę wartości dla poszczególnych narożników prostokąta za pomocą strzałek lub przez wpisanie żądanej wartości w panelu Przekształcenia.
  • Ogranicz proporcje szerokości i wysokości: zaznacz pole wyboru Skaluj narożniki, aby wartość promieni narożników była modyfikowana proporcjonalnie do przekształcenia obiektu.

Elipsa

Właściwości aktywnych kształtów | Elipsa
  • Szerokość/wysokość: określa szerokość i wysokość elipsy. Gdy obie wartości są równe, elipsa jest okręgiem.
  • Kąt elipsy: określa kąt, pod którym elipsa jest umieszczana na obszarze roboczym.
  • Kąt początkowy / kąt końcowy wycinka: za pomocą widżetu Wycinek (na prawo od nowo utworzonej elipsy) można zaprezentować kształt jako wykres kołowy.
  • Ogranicz kąt wycinka: określa, czy różnica między kątem początkowym i końcowym wycinka musi zostać zachowana podczas modyfikowania ich wartości za pomocą panelu Przekształcenia.
  • Odwróć wycinek: określa, kiedy kąt początkowy i końcowy wycinka należy zamienić miejscami. Dzięki temu można utworzyć graficzną reprezentację wycinka koła.

Wielokąt

Właściwości aktywnych kształtów | Wielokąt
  • Liczba boków wielokąta: określa liczbę boków rysowanego wielokąta. 
    • Za pomocą widżetu ekranowego można wybrać liczbę boków od 3 do 11. 
    • Suwak umożliwia wybór wartości od 3 do 20. 
    • Jeśli liczba boków ma mieścić się w zakresie od 3 do 1000, należy wpisać ją ręcznie.
  • Kąt wielokąta: określa wartość kąta, pod którym zostanie narysowany lub umieszczony wielokąt względem obszaru roboczego.
  • Typ narożnika: określa typ narożnika dla wielokąta (zaokrąglony, zaokrąglony odwrócony lub fazowany).
  • Promień wielokąta: określa dokładny promień rysowanego wielokąta. Użyj widżetu ekranowego  w celu zmodyfikowania promienia.
  • Długość boku wielokąta: określa długość poszczególnych boków wielokąta.
  • Promień kąta: określa promienie kątów w wielokącie.
  • Wyrównaj krawędzie: jeśli aktywny kształt straci proporcje lub symetrię podczas modyfikowania wielokąta, skorzystaj z przycisku Wyrównaj krawędzie, aby dostosować boki wielokąta.

Linia

Właściwości aktywnych kształtów | Linia
  • Długość linii: określa długość rysowanej linii.
  • Kąt linii: określa kąt, pod którym linia jest rysowana względem obszaru roboczego.

Ukrywanie obwiedni i widżetów sterowania

Podczas korzystania z narzędzia Kształt można ukryć lub wyświetlić obwiednię. Wykonaj jedną z następujących czynności.

  • Aby przełączać się pomiędzy tymi dwiema opcjami, naciśnij (Windows) klawisze Shift+Ctrl+B lub (macOS) Shift+Cmd+B.
  • Wybierz polecenie Widok > Ukryj obwiednię lub Widok > Pokaż obwiednię.

Możesz również zdecydować o ukryciu lub wyświetleniu ekranowych widżetów sterowania, wybierając dowolne narzędzie rysowania aktywnych kształtów i klikając przycisk Ukryj / pokaż widżety kształtów () w panelu sterowania.

Wybierz aktywne kształty

Panel Warstwy

Aktywne kształty są wyświetlane jako obiekty różnego typu w panelu Warstwy. Na przykład podczas rysowania aktywnego prostokąta warstwa otrzymuje nazwę <Prostokąt> w panelu Warstwy. Pomaga to w identyfikowaniu dostępnych aktywnych kształtów podczas zaznaczania i modyfikowania.

Aktywny prostokąt i elipsa pojawiające się jako <Prostokąt> i <Elipsa> w panelu Warstwy
Przykład: aktywne prostokąty i elipsy pojawiające się jako <Prostokąt> i <Elipsa> w panelu Warstwy. Podobnie inne aktywne kształty są oznaczone w panelu Warstwy.

Wybieranie menu

Aby wybrać wszystkie aktywne kształty dostępne w dokumencie, wybierz opcję Zaznacz > Jednakowe > Kształt.

Konwertowanie kształtów

Konwertowanie ścieżek na aktywne kształty

  • Kształty znajdujące się w plikach zapisanych w starszych wersjach programu Illustrator nie będą automatycznie edytowalne jako aktywne kształty. Aby przekonwertować ścieżkę na aktywny kształt, zaznacz ją i wybierz polecenie Obiekt > Kształt > Konwertuj na kształt.

Konwertowanie aktywnych kształtów na ścieżki

  • Aby przekonwertować aktywny kształt na ścieżkę, zaznacz aktywny kształt i wybierz polecenie Obiekt > Kształt > Rozwiń kształt.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online