Podręcznik użytkownika Anuluj

Scalanie danych za pomocą panelu Zmienne

  1. Podręcznik użytkownika programu Illustrator
  2. Poznaj program Illustrator
    1. Wprowadzenie do programu Illustrator
      1. Co nowego w programie Illustrator
      2. Popularne pytania
      3. Wymagania systemowe programu Illustrator
      4. Program Illustrator na urządzenia z układem Apple Silicon
    2. Przestrzeń robocza
      1. Podstawy pracy z przestrzenią roboczą
      2. Szybsza nauka dzięki panelowi Odkryj w programie Illustrator
      3. Tworzenie dokumentów
      4. Pasek narzędzi
      5. Domyślne skróty klawiaturowe
      6. Dostosowywanie skrótów klawiaturowych
      7. Wprowadzenie do obszarów roboczych
      8. Zarządzanie obszarami roboczymi
      9. Dostosowywanie przestrzeni roboczej
      10. Panel Właściwości
      11. Ustawianie preferencji
      12. Dotykowa przestrzeń robocza
      13. Obsługa pokrętła Microsoft Surface Dial w programie Illustrator
      14. Cofanie zmian i zarządzanie historią projektu
      15. Obracanie widoku
      16. Miarki, siatki i linie pomocnicze
      17. Ułatwienia dostępu w programie Illustrator
      18. Tryb bezpieczny
      19. Wyświetlanie kompozycji
      20. Używanie paska Touch Bar w programie Illustrator
      21. Pliki i szablony
    3. Narzędzia w programie Illustrator
      1. Przegląd narzędzi
      2. Zaznaczanie narzędzi
        1. Zaznaczenie
        2. Zaznaczanie bezpośrednie
        3. Zaznaczanie grupowe
        4. Różdżka
        5. Lasso
        6. Obszar ilustracji
      3. Narzędzia do nawigacji
        1. Rączka
        2. Obracanie widoku
        3. Lupka
      4. Narzędzia do malowania
        1. Gradient
        2. Siatka
        3. Generator kształtów
      5. Narzędzia tekstowe
        1. Tekst
        2. Tekst na ścieżce
        3. Tekst pionowy
      6. Narzędzia do rysowania
        1. Pióro
        2. Dodawanie punktu kontrolnego
        3. Usuwanie punktu kontrolnego
        4. Punkt kontrolny
        5. Krzywizna
        6. Linia
        7. Prostokąt
        8. Prostokąt zaokrąglony
        9. Elipsa
        10. Wielokąt
        11. Gwiazda
        12. Pędzel malarski
        13. Kropla
        14. Ołówek
        15. Shaper
        16. Plasterek
      7. Narzędzia do modyfikacji
        1. Obracanie
        2. Odbicie
        3. Skalowanie
        4. Ścinanie
        5. Szerokość
        6. Przekształcanie swobodne
        7. Kroplomierz
        8. Mieszanie
        9. Gumka
        10. Nożyczki
        11. Wymiar
    4. Generatywna SI (niedostępna w Chinach kontynentalnych)
      1. Generowanie grafiki wektorowej za pomocą polecenia tekstowego
      2. Zmiana kolorów kompozycji za pomocą polecenia tekstowego
    5. Szybkie operacje
      1. Tekst retro
      2. Tekst z blaskiem neonu
      3. Tekst w starym stylu
      4. Zmiana kolorów
      5. Konwertowanie szkicu na wektory
  3. Illustrator w Internecie (beta)
    1. Illustrator w Internecie (beta) — omówienie
    2. Illustrator w Internecie (beta) — często zadawane pytania
    3. Często zadawane pytania dotyczące rozwiązywania problemów
    4. Skróty klawiaturowe w programie Illustrator w Internecie (beta)
    5. Tworzenie i łączenie kształtów w wersji internetowej
    6. Dodawanie i edycja tekstu w wersji internetowej
    7. Stosowanie kolorów i gradientów w wersji internetowej
    8. Rysowanie i edycja ścieżek w wersji internetowej
    9. Praca z dokumentami w chmurze w wersji internetowej
    10. Zapraszanie współpracowników do edycji w wersji internetowej
  4. Illustrator na iPadzie
    1. Wprowadzenie do programu Illustrator na iPadzie
      1. Omówienie programu Illustrator na iPadzie
      2. Illustrator na iPadzie — często zadawane pytania
      3. Wymagania systemowe | Illustrator na iPadzie
      4. Możliwości i ograniczenia programu Illustrator na iPadzie
    2. Przestrzeń robocza
      1. Przestrzeń robocza programu Illustrator na iPadzie
      2. Gesty i skróty dotykowe
      3. Skróty klawiszowe w programie Illustrator na iPadzie
      4. Zarządzanie ustawieniami aplikacji
    3. Dokumenty
      1. Praca z dokumentami w programie Illustrator na iPadzie
      2. Importowanie dokumentów z programów Photoshop i Fresco
    4. Zaznaczanie i rozmieszczanie obiektów
      1. Tworzenie obiektów powtarzalnych
      2. Tworzenie przejść miedzy obiektami
    5. Rysowanie
      1. Rysowanie i edytowanie ścieżek
      2. Rysowanie i edytowanie kształtów
    6. Tekst
      1. Praca z tekstem i czcionkami
      2. Tworzenie napisów na ścieżce
      3. Dodawanie własnych czcionek
    7. Praca z obrazami
      1. Wektoryzowanie obrazów rastrowych
    8. Kolory
      1. Stosowanie kolorów i gradientów
  5. Pliki w chmurze
    1. Podstawy
      1. Korzystanie z dokumentów w chmurze w programie Illustrator
      2. Udostępnianie dokumentów w chmurze w programie Illustrator i współpraca nad nimi
      3. Udostępnianie dokumentów do recenzji
      4. Rozszerzanie przestrzeni dyskowej w chmurze na potrzeby programu Adobe Illustrator
      5. Pliki w chmurze w programie Illustrator | Częste pytania
    2. Rozwiązywanie problemów
      1. Rozwiązywanie problemów z tworzeniem lub zapisywaniem plików w chmurze programu Illustrator
      2. Rozwiązywanie problemów z plikami w chmurze programu Illustrator
  6. Dodawanie i edytowanie treści
    1. Rysowanie i wymiarowanie
      1. Podstawy rysowania
      2. Edycja ścieżek
      3. Rysowanie idealnych kompozycji
      4. Rysowanie za pomocą narzędzi Pióro, Krzywizna lub Ołówek
      5. Rysowanie prostych linii i kształtów
      6. Rysowanie siatek prostokątnych i biegunowych
      7. Rysowanie i edycja flar
      8. Obrys obrazu
      9. Upraszczanie ścieżki
      10. Narzędzia obsługi symboli i zestawy symboli
      11. Dopasowywanie segmentów ścieżek
      12. Jak w 5 prostych krokach narysować kwiat
      13. Tworzenie i edytowanie siatki perspektywicznej
      14. Rysowanie i modyfikowanie obiektów na siatce perspektywicznej
      15. Używanie obiektów jako symboli do wielokrotnego użytku
      16. Rysowanie ścieżek wyrównanych do pikseli do zastosowań internetowych
      17. Mierzenie i nakreślanie wymiarów
    2. Obiekty 3D i materiały
      1. Informacje o efektach 3D w programie Illustrator
      2. Tworzenie grafiki 3D
      3. Nakładanie kompozycji na obiekty trójwymiarowe
      4. Tworzenie tekstu 3D
      5. Tworzenie obiektów 3D
    3. Kolor
      1. Informacje o kolorze
      2. Wybieranie kolorów
      3. Używanie i tworzenie próbek
      4. Dopasowywanie kolorów
      5. Korzystanie z panelu Motywy Adobe Color
      6. Grupy kolorów (harmonie)
      7. Panel Motywy Color
      8. Zmiana kolorów kompozycji
    4. Malowanie
      1. Informacje o malowaniu
      2. Malowanie z wypełnieniami i obrysami
      3. Grupy aktywnego malowania
      4. Gradienty
      5. Pędzle
      6. Przezroczystość i tryby mieszania
      7. Stosowanie obrysów do obiektu
      8. Tworzenie i edycja wzorów
      9. Siatki
      10. Wzory
    5. Zaznaczanie i rozmieszczanie obiektów
      1. Zaznaczanie obiektów
      2. Warstwy
      3. Grupowanie i rozwijanie obiektów
      4. Przesuwanie, wyrównywanie i rozmieszczanie obiektów
      5. Układanie obiektów w stos
      6. Blokowanie, ukrywanie i usuwanie obiektów
      7. Kopiowanie i powielanie obiektów
      8. Obracanie i odbijanie obiektów
      9. Tworzenie splotu obiektów
      10. Tworzenie realistycznych prototypów grafik
    6. Przekształcanie obiektów
      1. Kadrowanie obrazów
      2. Przekształcanie obiektów
      3. Łączenie obiektów
      4. Wycinanie, dzielenie i przycinanie obiektów
      5. Wypaczenie marionetkowe
      6. Skalowanie, ścinanie i zniekształcanie obiektów
      7. Tworzenie przejść miedzy obiektami
      8. Zmiana kształtu za pomocą form
      9. Zmiana kształtu obiektów z efektami
      10. Tworzenie nowych kształtów za pomocą narzędzi Shaper i Generator kształtów
      11. Praca z aktywnymi narożnikami
      12. Udoskonalone obiegi pracy transformacji kształtu z obsługą dotykową
      13. Edytowanie maski przycinającej
      14. Aktywne kształty
      15. Tworzenie kształtów za pomocą narzędzia Generator kształtów
      16. Edycja globalna
    7. Tekst
      1. Dodawanie tekstu i praca z obiektami tekstowymi
      2. Tworzenie punktowanych i numerowanych list
      3. Zarządzanie obszarem tekstu
      4. Czcionki i typografia
      5. Konwertowanie tekstu w obrazach na tekst edytowalny
      6. Dodawanie podstawowego formatowania do tekstu
      7. Dodawanie zaawansowanego formatowania do tekstu
      8. Importowanie i eksportowanie tekstu
      9. Formatowanie akapitów
      10. Znaki specjalne
      11. Tworzenie tekstu na ścieżce
      12. Korzystanie ze stylów znakowych i akapitowych
      13. Karty
      14. Znajdowanie brakujących czcionek (obieg pracy Typekit)
      15. Tekst arabski i hebrajski
      16. Czcionki | Często zadawane pytania i wskazówki dotyczące rozwiązywania problemów
      17. Tworzenie trójwymiarowego efektu tekstowego
      18. Kreatywne projekty typograficzne
      19. Skalowanie i obracanie tekstu
      20. Odstępy pomiędzy wierszami i znakami
      21. Opcje dzielenia wyrazów i łamania wierszy
      22. Słowniki ortograficzne i językowe
      23. Formatowanie znaków azjatyckich
      24. Kompozytory języków azjatyckich
      25. Tworzenie projektów tekstowych z efektem przejścia między obiektami
      26. Tworzenie plakatu typograficznego za pomocą funkcji obrysowywania obrazu
    8. Tworzenie efektów specjalnych
      1. Praca z efektami
      2. Style grafiki
      3. Atrybuty wyglądu
      4. Tworzenie szkiców i mozaik
      5. Cienie, blaski i wtapianie
      6. Podsumowanie efektów
    9. Grafika WWW
      1. Sprawdzone procedury tworzenia grafiki WWW
      2. Wykresy
      3. SVG 
      4. Plasterki i mapy obrazów
  7. Importowanie, eksportowanie i zapisywanie
    1. Importowanie
      1. Umieszczanie wielu plików
      2. Zarządzaj plikami połączonymi i osadzonymi
      3. Informacje o łączach
      4. Cofanie osadzenia obrazów
      5. Importowanie kompozycji z programu Photoshop
      6. Importowanie obrazów bitmapowych
      7. Importowanie plików Adobe PDF
      8. Importowanie plików EPS, DCS i AutoCAD
    2. Biblioteki Creative Cloud w programie Illustrator
      1. Biblioteki Creative Cloud w programie Illustrator
    3. Zapisywanie
      1. Zapisywanie kompozycji
    4. Eksportowanie
      1. Używanie kompozycji z programu Illustrator w programie Photoshop
      2. Eksportowanie kompozycji
      3. Gromadzenie zasobów i eksportowanie zbiorcze
      4. Pliki pakietów
      5. Tworzenie plików Adobe PDF
      6. Wyodrębnianie kodu CSS | Illustrator CC
      7. Opcje Adobe PDF
      8. Panel Informacje o dokumencie
  8. Drukowanie
    1. Przygotowanie do drukowania
      1. Przygotowywanie dokumentów do druku
      2. Zmiana rozmiaru i orientacji strony
      3. Definiowanie linii cięcia w celu przycinania lub wyrównywania
      4. Rozpoczynanie pracy z powiększonym obszarem dokumentu
    2. Drukowanie
      1. Nadruk
      2. Drukowanie z włączoną funkcją zarządzania kolorami
      3. Drukowanie w trybie PostScript
      4. Ustawienia predefiniowane drukowania
      5. Znaczniki drukarskie i spady
      6. Drukowanie i zapisywanie przezroczystej kompozycji
      7. Zalewkowanie
      8. Drukowanie rozbarwień
      9. Drukowanie gradientów, siatek i przejść kolorów
      10. Nadruk bieli
  9. Automatyzacja zadań
    1. Scalanie danych za pomocą panelu Zmienne
    2. Automatyzacja za pomocą skryptów
    3. Automatyzacja za pomocą operacji
  10. Rozwiązywanie problemów 
    1. Problemy związane z awarią
    2. Odzyskiwanie plików po awarii
    3. Problemy z plikami
    4. Obsługiwane formaty plików
    5. Problemy ze sterownikiem karty graficznej
    6. Problemy z urządzeniem Wacom
    7. Problemy z plikami DLL
    8. Problemy z pamięcią
    9. Problemy z plikiem preferencji
    10. Problemy z czcionkami
    11. Problemy z drukarką
    12. Udostępnianie raportu o awarii firmie Adobe
    13. Poprawianie wydajności programu Illustrator

Scal dokument programu Illustrator z plikiem źródła danych (plik CSV lub XML) za pomocą panelu Zmienne, aby utworzyć wiele wersji swojej kompozycji. Możesz zmieniać nazwiska uczestników na identyfikatorach lub obrazy na banerach internetowych i pocztówkach bez potrzeby zmieniania kompozycji. Przygotuj jeden projekt i szybko twórz jego różne warianty, importując nazwy obrazów z pliku źródła danych.

Używając panelu Zmienne, możesz tworzyć niestandardowe warianty szablonu dla różnych projektów, na przykład drukowalnych plakatów, banerów internetowych oraz identyfikatorów.

Zanim przejdziesz dalej

Do scalenia danych potrzeba jedynie pliku źródła danych i dokumentu docelowego. 

  • Plik źródła danych zawiera informacje zmieniające się w każdej wersji dokumentu docelowego, np. nazwisko, zdjęcie i adres odbiorcy listu. Plik źródła danych może być plikiem rozdzielanym przecinkami (.csv) lub w formacie Extensible Markup Language (.xml).
  • Dokument docelowy to dokument programu Illustrator zawierający podstawową kompozycję do użytku jako szablon. Ten dokument może zawierać treść zastępczą pola danych oraz elementy, które są takie same w każdej wersji scalonego dokumentu.

Uzyskiwanie dostępu do funkcji scalania danych

Scalanie danych jest dostępne w panelu Zmienne programu Illustrator (Okno > Zmienne). W panelu są wyświetlane typy i nazwy poszczególnych zmiennych występujących w dokumencie. Jeśli pewna zmienna jest związana z obiektem, w kolumnie Obiekty jest wyświetlana nazwa tego obiektu, zgodnie z nazwą w panelu Warstwy. Kliknięcie elementów w pasku górnym umożliwia układanie wierszy: wg nazwy zmiennej, nazwy obiektu lub typu zmiennej.

Panel Zmienne

A. Zestaw danych B. Menu panelu C. Przełączanie między zestawami danych D. Nazwa obiektu związanego E. Nazwa zmiennej F. Typ zmiennej G. Blokowanie zmiennych H. Tworzenie dynamicznego obiektu I. Tworzenie dynamicznego widoku J. Usuwanie powiązania zmiennych K. Tworzenie zmiennych L. Usuwanie zmiennych 

Scalanie danych — szybkie kroki

  1. Utwórz dokument programu Illustrator, który będzie używany jako szablon.

  2. Skonfiguruj plik źródła danych w formacie CSV lub XML. Więcej informacji znajduje się w części Przygotowywanie pliku źródła danych.

  3. Zaimportuj plik źródła danych do programu Illustrator za pomocą panelu Zmienne. Więcej informacji znajduje się w części Importowanie pliku źródła danych.

  4. Powiąż zmienną z obiektem w szablonie. Więcej informacji znajduje się w części Tworzenie powiązania zmiennych z obiektami.

  5. Wyświetl podgląd dokumentu z poszczególnymi zestawami danych przed wyeksportowaniem wszystkich plików. Więcej informacji znajduje się w części Podgląd dokumentu z poszczególnymi zestawami danych.

  6. Wyeksportuj partię plików z danych za pomocą panelu Operacje w programie Illustrator. Więcej informacji znajduje się w części Eksportowanie plików za pomocą panelu Operacje.

Przygotowywanie pliku źródła danych

Pliki źródła danych muszą być zapisane w formacie rozdzielanym przecinkami (.csv) lub Extensible Markup Language (.xml).

Konfigurowanie plików źródłowych CSV

W pliku rozdzielanym przecinkami (.csv) poszczególne rekordy są oddzielane znakami końca akapitu, natomiast pola są rozdzielane przecinkami lub tabulatorami. Plik źródła danych może również zawierać tekst lub ścieżki odsyłające do obrazów na dysku. Przed zaimportowaniem pliku CSV należy wykonać następujące czynności, aby umożliwić programowi Illustrator zidentyfikowanie typu zmiennej.

  1. Otwórz arkusz.

  2. W pierwszym wierszu arkusza podaj nazwę pola danych. Wykonaj następujące czynności:

    • Na początku nazwy pola danych wpisz symbol @, aby wstawić tekst lub ścieżkę odsyłającą do plików obrazów. Symbol @ musi się znaleźć tylko w pierwszym wierszu; kolejne wiersze powinny zawierać ścieżki do obrazów.
    • Analogicznie na początku nazwy pola danych wpisz symbol procentu (%) dla wykresów i symbol krzyżyka (#) dla widoczności.
    • Aby określić widoczność obiektu, podaj wartość true lub false dla każdego pola danych.
    Uwaga:
    • Nazwy pół danych w arkuszu nie mogą zawierać spacji. Na przykład zamiast nazywać pole danych Nazwa firmy, nadaj mu nazwę Nazwa_firmy.
    • Ścieżki plików obrazów i wykresów również nie mogą zawierać spacji. Przykładowa ścieżka do pliku powinna widnieć jako C:\Photos\BillTucker zamiast C:\Photos\Bill Tucker.
    • Wszystkie pliki wykresów powiązane z plikiem źródła danych należy zapisać jako pliki rozdzielone przecinkami (.csv).
    • Jeżeli po wpisaniu znaku @ na początku pola wyświetlony zostanie komunikat o błędzie, wprowadź apostrof (') przed symbolem @ (np. '@Zdjęcia), aby zatwierdzić funkcję. Niektóre aplikacje, np. Microsoft Excel, rezerwują symbol @ dla funkcji.

    (Windows) Przykłady odwołań do obrazów i wykresów w pliku źródła danych

    Nazwa

    Wiek

    @Zdjęcia

    %Wykresy

    #Widoczność

    Bill Tucker

    36

    C:\Photos\BillTucker.jpg

    C:\Photos\BillTucker.csv

    Prawda

    Dat Nguyen

    53

    C:\MyDocuments\dat.jpg

    C:\MyDocuments\dat.csv

    Prawda

    Maria Ruiz

    26

    C:\Photos\Ruiz.jpg

    C:\Photos\Ruiz.csv

    Fałsz

    (macOS) Przykłady odwołań do obrazów i wykresów w pliku źródła danych

    Nazwa

    Wiek

    @Zdjęcia

    %Wykresy

    #Widoczność

    Bill Tucker

    36

    /Users/photos/BillTucker.jpg

    /Users/photos/BillTucker.csv

    Prawda

    Dat Nguyen

    53

    /Users/family/photos/dat.jpg

    /Users/family/photos/dat.csv

    Prawda

    Maria Ruiz

    26

    /Users/alpha/photos/Ruiz.jpg

    /Users/alpha/photos/Ruiz.csv

    Fałsz

  3. Wprowadź dane do arkusza.

  4. Wykonaj jedną z następujących czynności:

    • Zapisz arkusze utworzone za pomocą najnowszej wersji programu Microsoft Excel (wersja z 2016 roku) w następujących formatach:
      • CSV (rozdzielany przecinkami) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Zapisz arkusze utworzone w programie Apple Numbers w formacie CSV z kodowaniem Unicode (UTF-8).
    Uwaga:

    Pliki CSV eksportowane w powyższych formatach są obecnie obsługiwane przez program Illustrator. Inne formaty plików CSV, takie jak Macintosh Comma Separated (.csv), nie są obsługiwane w przypadku scalania danych.

Przygotowywanie pliku XML

  1. Zdefiniuj zmienną w dokumencie. Więcej informacji znajduje się w części Tworzenie powiązania zmiennych z obiektami.

  2. Kliknij przycisk Przechwyć zestaw danych  w panelu Zmienne.

  3. Po utworzeniu żądanej liczby zestawów danych wybierz polecenie Zapisz bibliotekę zmiennych w menu panelu Zmienne, aby zapisać zestawy danych jako plik XML. Podaj nazwę i lokalizację pliku, a następnie wybierz polecenie Zapisz.

    Eksportowanie zmiennych utworzonych w programie Illustrator do pliku XML

  4. Aby włączyć zestawy danych do pliku XML, wyedytuj go w aplikacji do edycji tekstu, takiej jak Notepad++ (Windows) lub TextWrangler (macOS).

    Przykład: edycja pliku XML za pomocą aplikacji do edycji tekstu

    A. Zastępowanie ścieżki obrazu B. Zastępowanie ciągu tekstu  

  5. Wybierz opcję Wczytaj bibliotekę zmiennych z menu panelu Zmienne, aby zaimportować plik XML do programu Illustrator. Zaznacz plik XML i wybierz polecenie Otwórz.

    Importowanie zmiennych do programu Illustrator

Importowanie pliku źródła danych

Aby powiązać zmienne z żądanymi danymi, zaimportuj źródło danych w panelu Zmienne. Dla jednego dokumentu możesz wybrać tylko jeden plik źródła danych.

  1. Wybierz opcję Okno > Zmienne.

  2. W panelu Zmienne wybierz polecenie Importuj.

  3. W oknie dialogowym Wczytaj bibliotekę zmiennych wybierz plik źródła danych w formacie CSV lub XML, a następnie wybierz polecenie Otwórz.

  4. Operacje edycji, zmiany nazwy i usuwania zestawu danych można przeprowadzić później: wystarczy wybrać zestaw z menu podręcznego Zestaw danych i zmienić wybrane opcje.

    • Wybierz zestaw danych z listy Zestaw danych w panelu Zmienne, aby przełączać się między zestawami danych. Możesz też nacisnąć przycisk Poprzedni zestaw danych  lub Kolejny zestaw danych.
    • Aby zastosować dane z obszaru kompozycji do bieżącego zestawu danych, wybierz opcję Aktualizuj zestaw danych z menu panelu Zmienne.
    • Aby zmienić nazwę zestawu danych, edytuj tekst bezpośrednio w polu tekstowym Zestaw danych. Możesz dwukrotnie kliknąć wyrazy Zestaw danych (po lewej stronie pola tekstowego Zestaw danych), wybrać nową nazwę i kliknąć OK.
    • Aby usunąć zestaw danych, kliknij ikonę Usuń. Możesz także wybrać polecenie Usuń zestaw danych z menu panelu Zmienne.
    Uwaga:

    Pliki CSV (UTF-8 rozdzielane przecinkami) zawierające znaki dwubajtowe, które utworzono za pomocą programu Excel, nie mogą być importowane do panelu Zmienne. Jeśli otworzysz ten sam plik w formacie tekstowym, a następnie zapiszesz jako plik CSV z kodowaniem UTF-8, zostanie on poprawnie zaimportowany.

Tworzenie powiązania zmiennych z obiektami

Użyj zmiennych, aby zdefiniować elementy szablonu, które chcesz zmienić. Zdefiniować można cztery typy zmiennych: zmienna Widoczność, zmienna Ciąg tekstowy, zmienna Plik połączony i zmienna Dane wykresu. Typ zmiennej określa, które atrybuty obiektu mogą podlegać zmianom (są dynamiczne). W panelu są wyświetlane typy i nazwy poszczególnych zmiennych występujących w dokumencie. Jeśli zmienna jest związana z obiektem, w kolumnie Obiekty jest wyświetlana jego nazwa zgodna z nazwą widoczną w panelu Warstwy.

Typ zmiennej

Ikona wskazująca typ zmiennej

Definicja

Zmienne Widoczność

Wyświetlanie i ukrywanie kompozycji.

Zmienne Ciąg tekstowy

Zastępowanie ciągu tekstu.

Zmienne Plik połączony

Zastępowanie obiektu na obszarze roboczym obiektem z innego pliku.

Zmienne Dane wykresu

Zastępowanie wartości na wykresie.

Zmienna Brak typu (niepowiązana)

Brak powiązania z obiektami.

Wykonaj poniższe czynności, aby określić zmienne w programie Illustrator:

  1. Zaznacz obiekt.

  2. W panelu Zmienne (Okno > Zmienne) zaznacz zmienną, z którą chcesz powiązać obiekt.

  3. Kliknij przycisk Utwórz dynamiczny obiekt , aby powiązać obiekt ze zmienną.

Wykonaj poniższe kroki, aby utworzyć zmienną bez powiązywania jej z obiektem:

  1. Kliknij przycisk Nowa zmienna  w panelu Zmienne.

  2. Aby powiązać obiekt ze zmienną, zaznacz obiekt i zmienną, a następnie kliknij przycisk Utwórz dynamiczny widok  lub Utwórz dynamiczny obiekt .

Uwaga:

Nazwy zmiennych nie obsługują par zastępczych ani znaków 4-bajtowych. Użycie tych znaków w nazwie zmiennej spowoduje wyświetlenie komunikatu o błędzie.

Praca ze zmiennymi

Edycji podlegać mogą nazwa i typ zmiennych, usuwanie powiązania i blokowanie zmiennych. Zmienne edytowane są w panelu Zmienne.

Usuwanie powiązania zmiennej oznacza przerwanie połączenia pomiędzy zmienną i jej obiektem. Zablokowanie zmiennych uniemożliwia ich tworzenie, usuwanie i edycję ich opcji. Ze zmiennymi zablokowanymi można jednak wiązać obiekty i usuwać ustanowione wcześniej powiązania.

Zmiana nazwy i typu zmiennej

  1. Zaznacz zmienną w panelu Zmienne i wybierz z menu panelu polecenie Opcje zmiennej.

Usuwanie powiązania zmiennej z obiektem

  1. Kliknij przycisk Usuń powiązanie zmiennej  w panelu Zmienne.

Blokowanie lub odblokowywanie wszystkich zmiennych w dokumencie

  1. Naciśnij przycisk Zablokuj zmienne  lub Odblokuj zmienne na panelu Zmienne.

Usuwanie zmiennych

Usuń zmienną, aby usunąć ją z panelu Zmienne. Po usunięciu zmiennej powiązanej z pewnym obiektem, obiekt ten staje się statyczny (chyba, że obiekt ten jest także powiązany ze zmienną innego typu).

  1. Zaznacz zmienną wybraną do usunięcia.

  2. Postępuj według dowolnej z następujących opcji:

    • Kliknij przycisk Usuń zmienną  na panelu Zmienne.

    • Aby usunąć zmienną bez konieczności potwierdzania tej operacji, przeciągnij ją na przycisk Usuń zmienną .

Edycja dynamicznych obiektów

Dane skojarzone ze zmienną można modyfikować poprzez edycję związanego z nią obiektu. Na przykład w przypadku zmiennej typu Widoczność należy przejść do panelu Warstwy i zmienić w nim widoczność obiektu. Edytując obiekty dynamiczne, można tworzyć wiele zestawów danych w tym samym szablonie.

  1. Zaznacz obiekt dynamiczny na obszarze kompozycji lub wykonaj jedną z czynności umożliwiającą automatyczne zaznaczenie obiektu dynamicznego:

    • Kliknij zmienną w panelu Zmienne z wciśniętym klawiszem Alt (Windows) lub Option (macOS).

    • Zaznacz zmienną w panelu Zmienne i wybierz z menu panelu polecenie Zaznacz obiekt powiązany.

    • Wybierz opcję Wszystkie powiązane obiekty z menu panelu Zmienne, aby zaznaczyć wszystkie obiekty dynamiczne.

  2. Edytuj dane skojarzone z obiektem:

    • Dokonaj edycji ciągu tekstowego w obszarze kompozycji.

    • Zastąp obraz za pomocą panelu Łącza lub polecenia Plik > Umieść dla powiązanych plików.

    • Edytuj dane dla wykresów w oknie dialogowym Dane wykresu.

    • W przypadku dowolnego obiektu o dynamicznej widoczności, zmień stan jego widoczności w panelu Warstwy.

Identyfikowanie obiektów dynamicznych przy użyciu identyfikatorów XML

W panelu Zmienne wyświetlane są te same nazwy obiektów dynamicznych, co w panelu Warstwy. Zapisując szablon w formacie SVG odczytywanym przez inne produkty firmy Adobe, pamiętaj o tym, że nazwy obiektów muszą spełniać wymogi standardu XML. Na przykład nazwy XML muszą zaczynać się od litery, znaku podkreślenia lub średnika i nie mogą zawierać spacji.

Do każdego tworzonego obiektu dynamicznego program Illustrator automatycznie przypisuje identyfikator XML. Aby wyświetlać, edytować lub eksportować nazwy obiektów przy pomocy identyfikatorów XML, wybierz polecenie Edycja > Preferencje > Jednostki (Windows) lub Illustrator > Preferencje > Jednostki (Mac OS) i wybierz identyfikator XML.

Podgląd dokumentu z poszczególnymi zestawami danych

Aby sprawdzić wygląd końcowej grafiki, można wyświetlić jej podgląd przed wyeksportowaniem wszystkich plików. Użyj klawiszy strzałek obok pozycji Zestaw danych w panelu Zmienne, aby nawigować i wyświetlać podgląd żądanego zestawu danych w dokumencie.

Eksportowanie plików za pomocą panelu Operacje

Po utworzeniu zmiennych i zdefiniowaniu zestawów danych można wykorzystać je do wygenerowania kompozycji w trybie wsadowym. Wykonaj następujące czynności:

  1. Korzystając z panelu Operacje (Okno > Operacje), zarejestruj operację zapisu dokumentu w żądanym formacie. Więcej informacji znajduje się w części Automatyzacja z operacjami.

  2. Wybierz polecenie Wsad z menu panelu Operacje i wybierz operację utworzoną w poprzednim kroku.

  3. W części Źródło wybierz opcję Zestawy danych, aby odtworzyć operację dla poszczególnych zestawów danych w bieżącym pliku.

  4. W części Miejsce docelowe określ czynności, które chcesz wykonać dla przetworzonych plików. Pliki mogą pozostać otwarte bez zapisywania zmian (Brak), zapisane i zamknięte w aktualnym położeniu (Zapisz i zamknij) lub zapisane w innym miejscu (Folder).

    W zależności od zaznaczonych opcji, w części Miejsce docelowe zapisywane pliki mogą posiadać dodatkowe opcje. Więcej informacji znajduje się w części Odtwarzanie operacji dla partii plików.

  5. Kliknij przycisk OK.

Zapisywanie szablonu do scalania danych

Zdefiniowanie zmiennych w dokumencie programu Illustrator jest równoznaczne z utworzeniem szablonu dla scalenia danych. Szablon można zapisać w formacie SVG, co umożliwia jego stosowanie w innych programach firmy Adobe, na przykład Adobe® Graphics Server. Przykładowo programista korzystający z programu Adobe Graphics Server może powiązać zmienne z pliku SVG bezpośrednio z bazą danych lub innym źródłem danych.

  1. Wybierz polecenie Plik > Zapisz jako, wpisz nazwę pliku, wybierz format SVG i kliknij przycisk Zapisz.

  2. Kliknij Więcej opcji i zaznacz opcję Dołącz dane Adobe Graphics Server. Opcja ta powoduje dołączenie do pliku SVG wszystkich informacji potrzebnych do podstawiania zmiennych.

  3. Kliknij przycisk OK.

Podczas importowania pliku CSV występują problemy?

Jeżeli otrzymujesz komunikat o błędzie „przychodząca biblioteka zmiennych nie jest prawidłowa” podczas przesyłania pliku źródła danych w formacie CSV, sprawdź, czy:

  • Plik CSV nie jest pusty.
  • Arkusze utworzone w najnowszej wersji programu Microsoft Excel są zapisywane jako pliki CSV (rozdzielane przecinkami) (*.csv) lub CSV (MS-DOS) (*.csv), a tworzone w programie Apple Numbers są zapisywane w formacie CSV z kodowaniem Unicode (UTF-8). Pliki źródła danych zapisane w każdym innym formacie, takie jak pliki Macintosh Comma Separated (*.csv), nie są obsługiwane w przypadku scalania danych.
  • Wszystkie kolumny mają nazwy pól danych. Na przykład program Illustrator wyświetla komunikat o błędzie, jeżeli kolumna w pliku źródła danych zawiera dane, ale nie ma nazwy pola danych.
  • Plik źródła danych nie zawiera pustej kolumny pomiędzy dowolnymi wypełnionymi kolumnami. Na przykład program Illustrator wyświetla komunikat o błędzie, jeżeli kolumny B i D w pliku źródła danych zawierają dane, ale kolumna C jest pusta.
Przykład: błędy występujące podczas konfigurowania pliku źródłowego CSV w celu scalenia danych

A. Brak nazwy pola danych w kolumnie B. Pomiędzy wypełnionymi kolumnami znajduje się pusta kolumna 

  • Nazwy pół danych w arkuszu nie zawierają spacji.
  • Ścieżki do plików obrazów i wykresów w pliku źródłowym nie zawierają spacji.
  • Pliki wykresów powiązane z plikiem źródła danych są zapisywane jako pliki rozdzielone przecinkami (.csv).

zasoby pokrewne

Skontaktuj się z nami

Chętnie Cię poznamy. Podziel się swoimi opiniami na forum użytkowników programu Adobe Illustrator

Adobe

Pomoc dostępna szybciej i łatwiej

Nowy użytkownik?