Nie musisz tworzyć kompozycji w programie Adobe Illustrator od nowa — możesz zaimportować zarówno rysunki wektorowe jak i bitmapowe utworzone w innych aplikacjach. Program Illustrator rozpoznaje wszystkie powszechne formaty plików. Ścisła integracja pomiędzy produktami Adobe i obsługa wielu rodzajów formatów plików, ułatwia przenoszenie kompozycji z jednej aplikacji do innej z wykorzystaniem importu, eksportu lub kopiowania i wklejania.

Informacje o kompozycjach osadzonych i połączonych

Po umieszczeniu grafiki, w układzie pojawi się jej wersja w małej rozdzielczości. Pozwala to na oglądanie i przesuwanie grafiki. Jednak sam plik graficzny może być połączony z dokumentem lub osadzony w dokumencie.

  • Kompozycja połączona z dokumentem pozostaje od niego niezależna. Dzięki temu dokument ma mniejszy rozmiar. Kompozycję taką możesz modyfikować za pomocą narzędzi do przekształcania oraz efektów; nie możesz jednak zaznaczać i edytować jej elementów. Jednego połączonego elementu graficznego można użyć wiele razy, nie powiększając zbytnio wielkości pliku dokumentu. Można również jednocześnie uaktualnić wszystkie łącza. Podczas eksportowania lub drukowania dokumentu, program pobiera oryginalny plik graficzny. Dzięki temu ostateczny wydruk lub eksportowany materiał jest tworzony przy użyciu grafiki w pełnej rozdzielczości.

  • Grafika osadzona jest kopiowana do dokumentu z pełną rozdzielczością, Zwiększa to rozmiar dokumentu. Dokument można uaktualniać w dowolnym momencie. Dopóki grafika pozostaje w nim osadzona, dokument taki jest samowystarczalny.

Aby sprawdzić, czy kompozycja jest połączona, czy osadzona, albo zmienić jej stan z jednego na drugi, można posłużyć się panelem Łącza.

Jeśli osadzona kompozycja zawiera wiele elementów, można edytować je indywidualnie. Na przykład, jeśli kompozycja zawiera obiekt wektorowy, Illustrator konwertuje go na ścieżki, które w dalszej kolejności można będzie modyfikować za pomocą narzędzi i efektów programu. Program Illustrator zachowuje też obowiązującą w osadzonej kompozycji hierarchię obiektów, np. grup i warstw (dotyczy to tylko niektórych formatów).

Umieszczanie (importowanie) plików kompozycji

Polecenie Umieść jest podstawową metodą importu, ponieważ zapewnia najwyższy poziom obsługi formatów plików, opcji rozmieszczania i koloru. Po umieszczeniu pliku, można go zidentyfikować, zaznaczyć, monitorować i uaktualniać za pomocą panelu Łącza.

  1. Otworzyć dokument programu Ilustrator, w którym ma być umieszczona kompozycja.

  2. Wybierz polecenie Plik > Umieść i zaznacz plik tekstowy, który ma zostać umieszczony.

  3. Zaznacz opcję Połącz, aby utworzyć połączenie z plikiem lub usunąć zaznaczenie opcją Połącz i osadzić kompozycję w dokumencie programu Illustrator.

  4. Kliknij polecenie Umieść.

  5. Jeżeli trzeba, wykonaj jedną z następujących czynności:

    • Jeśli jest umieszczany wielostronicowy plik PDF, możesz wybrać stronę do umieszczenia i sposób kadrowania kompozycji.

    • Jeśli osadzany jest plik programu Adobe® Photoshop, możesz określić sposób konwersji warstw. Jeśli plik zawiera kompozycje warstw, możesz wybrać wersję obrazka, która zostanie zaimportowana.

Importowanie tekstu do ścieżki/kształtu

Wprowadzono w programie Illustrator CC 2017

Umieść tekst z obsługiwanego pliku bezpośrednio w obiekcie, np. w kształcie. Można umieszczać tekst z plików tekstowych w formatach .txt, .rtf lub plików edytorów tekstu. Można na przykład umieścić tekst z pliku .rtf w kształcie wielokąta.

  1. Utwórz ścieżkę/kształt, korzystając z dowolnego narzędzia rysowania, takiego jak Prostokąt, Shaper lub Pióro. W tym kształcie należy umieścić plik tekstowy.

  2. Wybierz polecenie Plik > Umieść i zaznacz plik, który ma zostać umieszczony.

  3. Kliknij polecenie Umieść.

  4. Po załadowaniu pliku tekstowego do modułu umieszczania, kliknij ścieżkę lub kształt.

    Tekst umieszczany jest wewnątrz kształtu. Można teraz zastosować wybrane style i efekty.

    Umieść tekst z pliku tekstowego na wielopunktowej ścieżce/w kontenerze.

Panel Łącza służy do wyświetlania wszystkich kompozycji połączonych i osadzonych oraz do zarządzania nimi. Na panelu wyświetlane są miniaturki kompozycji oraz ikony obrazujące ich stan.

Panel Łącza
Panel Łącza

A. Interakcje przezroczystości B. Brakująca kompozycja C. Kompozycja osadzona D. Kompozycja zmieniona E. Kompozycja połączona 

Plik połączony może być wyświetlany na panelu Łącza na kilka sposobów:

Aktualny

W przypadku pliku aktualnego wyświetlana jest tylko nazwa pliku oraz numer strony w dokumencie (dotyczy programu Adobe® InDesign®).

Zmieniony

Plik zmodyfikowany to taki, którego wersja na dysku jest nowsza, niż wersja w dokumencie. Może się to zdarzyć np. wówczas, gdy ktoś zmodyfikuje grafikę programu Photoshop, która została już umieszczona w programie Illustrator.

Brakujący

Plik brakujący to taki, którego nie ma już w miejscu, z którego została zaimportowana grafika. Jednak taki plik może istnieć w innym miejscu. Może się to zdarzyć, gdy ktoś przeniesie oryginalny plik do innego folderu lub na inny serwer po tym, gdy został on zaimportowany do dokumentu. Nie wiadomo, czy brakujący plik jest aktualny, dopóki nie odszuka się oryginału. Drukując lub eksportując dokument, w którym wyświetlona jest taka ikona należy pamiętać, że brakujący plik może nie zostać wydrukowany lub wyeksportowany w pełnej rozdzielczości.

Osadzony

Osadzenie zawartości połączonego pliku powoduje zawieszenie operacji zarządzania danym łączem.

  • Aby wyświetlić ten panel, wybierz polecenie Okno > Łącza. Panel podaje nazwę każdego pliku połączonego i pliku osadzonego.

  • Aby zaznaczyć i wyświetlić grafikę połączoną, zaznacz łącze i kliknij przycisk Przejdź do łącza , albo wybierz polecenie Przejdź do łącza z menu panelu Łącza. Obszar wyświetlania zostanie wyśrodkowany wokół zaznaczonej grafiki.

  • Aby zmienić rozmiar miniaturek, wybierz panel Opcje z menu panelu Łącza i zaznacz opcję wyświetlania miniaturek.

  • Aby posortować łącza w innej kolejności, wybierz pożądane polecenie typu 'Sortuj' z menu panelu.

  • Aby ukryć miniaturki, wybierz panel Opcje z menu panelu Łącza. Wybierz opcję Brak.

  • Aby zapoznać się z Informacjami przeźroczystości DCS, wybierz panel Opcje z menu panelu Łącza i wybierz polecenie Pokaż interakcje przeźroczystości DCS.

Jeżeli plik połączony lub umieszczony, zawiera metadane, można je wyświetlać za pomocą panelu Łącza. Nie można edytować ani zastępować metadanych związanych z przyłączonym plikiem; można jednak zachować ich kopię w szablonie i zastosować je do innych plików.

  1. Z menu panelu Łącza wybierz polecenie Informacje o pliku łącza.

  2. Aby zapisać metadane w postaci szablonu, wybierz polecenie Zapisz szablon metadanych z wyskakującego menu u góry okna dialogowego Informacje o pliku.

Wyświetlanie pliku informacji o kompozycji połączonej lub osadzonej

  1. Wykonaj jedną z następujących czynności:

    • Dwukrotnie kliknij łącze w panelu Łącza. Możesz również zaznaczyć łącze i z menu panelu wybrać Informacja łącza.

      Uwaga: w menu panelu Łącze nie pomyl pozycji „Informacji łącza” z „Plikiem informacji łącza”; pozycja „Plik informacji” dotyczy metadanych.

    • Zaznacz połączoną kompozycję w oknie ilustracji. Otwórz panel Sterowanie i kliknij nazwę pliku. Wybierz polecenie Informacja łącza.

Uwaga:

Aby zlokalizować połączoną lub osadzoną kompozycję w oknie dokumentu, zaznacz łącze i kliknij przycisk Przejdź do łącza. Przycisk ten możesz również wybrać w menu panelu.

  • Aby uaktualnić określone łącza, zaznacz jedno lub więcej zmodyfikowanych łączy w panelu Łącze, a następnie kliknij przycisk Uaktualnij łącze lub wybierz pozycję Uaktualnij łącze z menu panelu Łącze.

  • Aby uaktualnić określone łącza, zaznacz połączoną kompozycję w oknie ilustracji. Otwórz panel Sterowanie i kliknij nazwę pliku. Następnie wybierz Uaktualnij łącze.

Uwaga:

Domyślnie Illustrator będzie prosił o aktualizację łącza, jeśli plik źródłowy zmieni się. Aby określić, czy łącza mają być aktualizowane automatycznie, czy ręcznie, wybierz Edycja > Preferencje > Obsługa plików i schowek (Windows) lub Illustrator > Preferencje > Obsługa plików i schowek (Mac Os) i włącz opcję Aktualizacja łączy.

Możesz odtworzyć lub zastąpić brakujące łącze – takie, które w panelu Łącza oznaczone jest ikoną brakującego łącza – lub jakikolwiek plik połączony z innym plikiem źródłowym.

  1. Zaznacz połączoną kompozycję na danej stronie lub zaznacz nazwę łącza w panelu Łącza.

  2. Wykonaj jedną z następujących czynności:

    • Kliknij przycisk Łącz ponownie znajdujący się w panelu Łącza lub wybierz Łącz ponownie z menu panelu.

    • Kliknij połączoną nazwę pliku w panelu Sterowanie, a następnie wybierz Łącz ponownie. (Aby uzyskać dostęp do tej opcji, musisz zaznaczyć obraz w kompozycji).

  3. W kolejnym oknie dialogowym wykonaj jedną z następujących czynności:

    • Znajdź i wskaż plik do zamiany.

    • By zlokalizować ten plik, wpisz jego pierwszą lub pierwsze litery nazwy.

  4. Kliknij polecenie Umieść.

Uwaga:

Jeśli wszystkie brakujące łącza danego dokumentu znajdują się w tym samym folderze, można odtworzyć je wszystkie jednocześnie. W panelu Łącze zaznacz brakujące łącza, a następnie odtwórz jedno z nich; okno dialogowe Umieść pozostanie otwarte, byś mógł ponownie zaznaczyć każde z nich.

Określanie opcji umieszczania połączonej kompozycji

  1. Wykonaj jedną z następujących czynności:

    • Zaznacz połączoną kompozycję w oknie ilustracji. Otwórz panel Sterowanie i kliknij nazwę pliku. Wybierz Opcje rozmieszczania.

    • Otwórz panel Łącza, zaznacz wybrane łącze i wybierz polecenie Opcje umieszczania z menu panelu.

  2. Zaznacz opcję dla atrybutu Zachowaj.

    Dla wszystkich opcji z wyjątkiem Transformacje lub Obwiednie możesz wybrać punkt na ikonie Wyrównania, od której będzie wyrównywana kompozycja do obwiedni. Aby zapobiec efektowi zachodzenia kompozycji na obwiednię, zaznacz opcję Przytnij do obwiedni.

Osadzenie połączonego pliku

Zamiast tworzyć połączenie do umieszczonego pliku, można taki plik osadzić (czyli zapisać) w dokumencie. Osadzenie pliku powoduje zerwanie łącza z oryginałem. Panel Łącza nie ostrzega wówczas, że oryginał uległ zmianie. Nie można też automatycznie uaktualnić pliku.

Pamiętaj, że poza łączeniem z oryginałem osadzenie pliku zwiększa też rozmiar pliku dokumentu.

  1. W panelu Łącze zaznacz plik i wybierz Osadzony obraz z menu panelu.

  2. Zaznacz połączoną kompozycję w oknie ilustracji. Kliknij przycisk Osadzony w panelu Sterowanie.

Plik pozostanie w panelu Łącza, oznaczony ikoną pliku osadzonego .

  1. Zaznacz przynajmniej jeden osadzony plik w panelu Łącza.

  2. Kliknij przycisk Łącz ponownie  lub wybierz polecenie Łącz ponownie z menu panelu Łącza. Znajdź i zaznacz oryginalny plik i kliknij przycisk Umieść.

Edycja oryginalnej kompozycji

Polecenie Edytuj oryginał umożliwia edytowanie większości obrazów w aplikacji, w której powstały. Po zapisaniu oryginalnego pliku, dokument w którym jest on osadzony, zostanie uaktualniony nową wersją pliku.

  1. Wykonaj jedną z następujących czynności:

    • Zaznacz łącze w panelu sterowania i kliknij przycisk Edytuj oryginał . Możesz też wybrać polecenie z menu panelu Edytuj oryginał.

    • Zaznacz połączoną kompozycję na stronie i wybierz polecenie Edycja > Edytuj oryginał.

    • Zaznacz połączoną kompozycję i w panelu Sterowanie kliknij przycisk Edytuj oryginał.

  2. Po wprowadzeniu zmian w oryginalnej aplikacji, zapisz plik.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online