Uwaga:

Ten artykuł dotyczy programu Adobe Illustrator CC5 i starszych. Począwszy od wersji Adobe Illustrator CS6, program Illustrator udostępnia nową jakość funkcji Obrys obrazu. Podczas tworzenia obrysu obrazu można teraz wybierać z szerokiej gamy dostępnych ustawień predefiniowanych lub użyć intuicyjnych, łatwych w obsłudze elementów sterujących, aby uzyskać wysokiej jakości rezultaty. Więcej informacji można znaleźć w dokumencie Obrys obrazu.

Chcąc utworzyć nowy rysunek na podstawie istniejącej kompozycji, kompozycję tę można obrysować. Dla przykładu: do programu Illustrator można przenieść zeskanowany szkic albo obraz zapisany w innym programie graficznym, a następnie obrysować go.

Najłatwiejszym sposobem obrysowania kompozycji jest otwarcie lub umieszczenie pliku w programie Illustrator i automatyczne obrysowanie kompozycji przy pomocy polecenia Aktywny obrys. Możesz kontrolować poziom szczegółów i zasady wypełniania obrysu. Po uzyskaniu oczekiwanych rezultatów obrys może zostać przekonwertowany na ścieżki wektorowe lub obiekt Aktywnego malowania.

Przed i po obrysowaniu obrazu bitmapowego przy pomocy polecenia Aktywny obrys
Przed i po obrysowaniu obrazu bitmapowego przy pomocy polecenia Aktywny obrys

Obrysowywanie kompozycji

  1. Otwórz lub umieść plik źródłowy, który zawiera obraz do obrysowania.

  2. Zaznacz obraz źródłowy i wykonaj jedną z następujących czynności:

    • Aby obrysować obraz przy użyciu ustawień predefiniowanych, kliknij przyciskUstawienia obrysowywania i opcje w panelu sterowania i wybierz ustawienia predefiniowane.

    • Aby obrysować obraz bez stosowania domyślnych opcji obrysowywania, kliknij przycisk Aktywny obrys w panelu sterowania albo wybierz polecenie Obiekt > Aktywny obrys > Utwórz.

    • Aby określić opcje obrysu przed obrysowaniem obrazu, kliknij przycisk Ustawienia obrysowywania i opcje w panelu sterowania i wybierz Opcje obrysowywania. Możesz też wybrać polecenie Obiekt > Aktywny obrys > Opcje obrysowywania. Określ opcje obrysowywania i kliknij Obrysuj.

  3. (Opcjonalnie) Dopasuj wyniki obrysowywania.

  4. (Opcjonalnie) Przekonwertuj obrys na ścieżki lub obiekt aktywnego malowania.

Opcje obrysowywania

Predefiniowane ustawienie

Określa predefiniowane ustawienie obrysowywania.

Tryb

Określa tryb kolorów wyniku obrysowywania.

Próg

Określa wartość generowanego czarno-białego obrysu oryginalnego obrazu. Piksele jaśniejsze od progu są przekształcane na biel, a ciemniejsze — na czerń. (Opcja jest dostępna tylko po wybraniu trybu Czarno-biały).

Paleta

Określa paletę dla generowania obrysu kolorowego lub w skali szarości z obrazu oryginalnego. (Opcja jest dostępna tylko po wybraniu trybu Kolor lub Skala szarości).

Opcja Automatyczny umożliwia określenie kolorów obrysu przez program Illustrator. Aby wybrać własną paletę dla danego obrysu, zaznacz nazwę wybranej biblioteki próbek. (W menu Paleta wyświetlane są tylko otwarte biblioteki próbek).

Maks. liczba kolorów

Określa maksymalną liczbę kolorów użytą w obrysie kolorowym lub w skali szarości. (Opcja jest dostępna tylko po wybraniu trybu Kolor lub Skala szarości oraz przy automatycznym ustawieniu panelu).

Na próbki

Tworzy nową próbkę w panelu Próbki dla każdego koloru wyniku obrysu.

Rozmycie

Rozmywa oryginalny obraz przed wygenerowaniem wyniku obrysowywania. Opcja zmniejsza liczbę niewielkich elementów i wygładza nierówne krawędzie w obrysie.

Ponowne próbkowanie

Ponownie próbkuje obraz oryginalny do określonej rozdzielczości przed wygenerowaniem obrysu. Opcja przyspiesza obrysowywanie dużych obrazów, ale zmniejsza jakość obrysu.

Uwaga: rozdzielczość ponownego próbkowania nie jest zapisywana przy tworzeniu ustawień wstępnych.

Wypełnienia

Tworzy w obrysie obszary wypełnione.

Obrysy

Tworzy w obrysie ścieżki obrysowane.

Maks. grubość obrysu

Określa maksymalną szerokość elementów oryginalnego obrazu, które zostaną obrysowane. Elementy większe od podanej szerokości maksymalnej zostaną obrysowane.

Min. grubość obrysu

Określa minimalną szerokość elementów oryginalnego obrazu, które zostaną obrysowane. Elementy mniejsze od szerokości minimalnej zostaną pominięte w obrysie.

Dopasowywanie ścieżki

Kontroluje odległość pomiędzy obrysowanym kształtem i oryginalnym kształtem pikseli. Mniejsze wartości tworzą ciaśniejsze dopasowanie ścieżki, a wartości większe oznaczają dopasowanie luźniejsze.

Obszar minimalny

Określa najmniejszy element obrazu oryginalnego, który zostanie obrysowany. Na przykład, wartość 4 oznacza, że elementy mniejsze niż 2 na 2 piksele zostaną pominięte przy obrysowywaniu.

Kąt narożnika

Określa kąt narożników obrazu oryginalnego, które staną się narożnymi punktami kontrolnymi w obrysie. Aby uzyskać dodatkowe informacje na temat różnic pomiędzy punktami narożnymi i gładkimi zobacz Informacje o ścieżkach.

Raster

Określa zasady wyświetlania bitmapowych komponentów efektu obrysowywania. To ustawienie nie jest zapisywane jako część predefiniowanego ustawienia obrysowywania.

Wektor

Określa zasady wyświetlania efektu obrysowywania. To ustawienie nie jest zapisywane jako część predefiniowanego ustawienia obrysowywania.

Uwaga:

Zaznacz opcję Podgląd w oknie Opcje obrysowywania, aby wyświetlić efekty ustawień bieżących. Aby określić domyślne opcje obrysowywania, usuń zaznaczenie obiektów przed otwarciem okna Opcje obrysowywania. Po zakończeniu pracy kliknij Ustaw domyślne.

Film przedstawiający korzystanie z narzędzia Aktywny obrys można obejrzeć na stronie www.adobe.com/go/vid0043. Samouczek o zmienianiu opcji polecenia Aktywny obrys można znaleźć na stronie internetowej www.adobe.com/go/learn_ai_tutorials_livetrace_pl.

Zmiana sposobu wyświetlania obiektu obrysu

Obiekt obrysu składa się z dwóch elementów: oryginalnego obrazu źródłowego i wyniki obrysu (w postaci kompozycji wektorowej). Domyślnie, widoczny jest tylko wynik obrysu. Należy jednak pamiętać, że można zmienić zasady wyświetlania obrazu oryginalnego i wyniku obrysu stosownie do potrzeb danej kompozycji.

  1. Zaznacz wynik obrysowywania.

    Uwaga:

    Domyślnie, wszystkie obiekty obrysu mają w panelu Warstwy nazwy „Obrys”.

  2. Wykonaj jedną z następujących czynności:

    • Aby zmienić zasady wyświetlania wyników obrysu, kliknij przycisk Widok wektorowy w panelu sterowania lub wybierz Obiekt > Aktywny obrys i wybierz opcję wyświetlania Brak wyników obrysowywania, Wyniki obrysu, Kontury lub Kontury z obrysowaniem.

    • Aby zmienić sposób wyświetlania obrazu źródłowego, kliknij przycisk Widok rastrowy w panelu sterowania lub wybierz Obiekt > Aktywny obrys i wybierz opcję wyświetlania: Brak obrazu, Oryginalny obraz, Obraz dopasowany (wyświetla obraz bez dopasowania zastosowanego podczas obrysowywania) lub Przezroczysty obraz.

      Uwaga: aby wyświetlić obraz źródłowy, najpierw zmień Widok wektorowy na Brak wyników obrysowywania lub Kontury.

Dopasowywanie wyników obrysowywania obiekt

Wynik obrysowywania może być zmieniany w dowolnym czasie.

  1. Zaznacz wynik obrysowywania.

  2. Wykonaj jedną z następujących czynności:

    • Ustaw podstawowe opcje w panelu sterowania.

    • Kliknij przycisk Opcje obrysowywania  w panelu sterowania, aby wyświetlić wszystkie opcje obrysowywania. Możesz też wybrać polecenie Obiekt > Aktywny obrys > Opcje obrysowywania. Zmień opcje i kliknij Obrysowywanie.

    Uwaga:

    Efekty obrysowania mogą być szybko zmienione przy pomocy predefiniowanych ustawień obrysowywania.

Określanie kolorów używanych przy obrysowywaniu

  1. Utwórz bibliotekę próbek zawierającą kolory przeznaczone do obrysowywania.

  2. Upewnij się, że biblioteka próbek jest otwarta, i kliknij przycisk Opcje obrysowywania w panelu sterowania. Możesz też wybrać polecenie Obiekt > Aktywny obrys > Opcje obrysowywania.

  3. Zaznacz nazwę wybranej biblioteki próbek w menu Paleta i kliknij Obrysuj.

Korzystanie z predefiniowanych ustawień obrysowywania

Predefiniowane ustawienia obrysowywania to gotowe opcje obrysowywania kompozycji określonego typu. Na przykład, jeśli obrysowywany obraz będzie służył jako rysunek techniczny, wybierz ustawienie Rysunek techniczny. Wszystkie opcje zostaną dostosowane do wymagań rysunku technicznego: kolor — czarno-biały, rozmycie — 0 piks., szerokość obrysu — ograniczona do 3 piks. itd.

Określanie ustawień predefiniowanych

  • Wybierz polecenie Obiekt > Aktywny obrys > Opcje obrysowywania. (Możesz też zaznaczyć wynik obrysowywania i kliknąć przycisk Opcje obrysowywania w panelu sterowania). Ustaw opcje obrysowywania dla ustawienia predefiniowanego i kliknij opcję Zapisz ustawienia predefiniowane. Wprowadź nazwę ustawinia predefiniowanego i kliknij przycisk OK.

  • Wybierz polecenie Edytuj > Ustawienia obrysowywania. Kliknij Nowe, ustaw opcje obrysowywania dla ustawienia predefiniowanego , a następnie kliknij Gotowe.

    Wskazówka: aby utworzyć nowe ustawienie wstępne na bazie istniejącego, zaznacz je i kliknij Nowe.

Edycja lub usuwanie ustawienia predefiniowanego

  1. Wybierz polecenie Edytuj > Ustawienia obrysowywania.

  2. Wybierz ustawienie predefiniowane i kliknij polecenie Edytuj lub Usuń.

    Uwaga:

    Domyślne zestawy ustawień (wyświetlane nawiasach kwadratowych [ ]) nie mogą być edytowane lub usuwane. Należy jednak pamiętać, że można utworzyć edytowalną kopię domyślnego ustawienia poprzez zaznaczenie ustawienia i kliknięcie Nowe.

Współużytkowanie ustawień predefiniowanych

  1. Wybierz polecenie Edytuj > Ustawienia obrysowywania.

  2. Wykonaj jedną z następujących czynności:

    • Kliknij przycisk Eksportuj, aby wyeksportować ustawienia do pliku.

    • Kliknij przycisk Importuj, aby wczytać ustawienia z pliku.

Konwersja wyniku obrysowywania na obiekt aktywnego malowania

Po uzyskaniu oczekiwanych rezultatów obrys może zostać przekonwertowany na ścieżki wektorowe lub obiekt aktywnego malowania. Końcowe etapy pracy umożliwiają opracowywanie obrysu tak jak innych kompozycji wektorowych. Należy jednak pamiętać, że po przekonwertowaniu obiektu nie można już zmieniać opcji obrysowywania.

  1. Zaznacz wynik obrysowywania.

  2. Wykonaj jedną z następujących czynności:

    • Aby przekonwertować obrys na ścieżki, kliknij polecenie Rozwiń z panelu sterowania albo polecenie Obiekt > Aktywny obrys > Rozwiń. Metoda ta jest przeznaczona do późniejszego opracowywania elementów obrysowanej kompozycji jako oddzielnych obiektów. Otrzymane ścieżki są grupowane.

    • Aby przekonwertować obrys na ścieżki i zachować bieżące opcje wyświetlania, wybierz polecenie Obiekt > Aktywny obrys > Rozszerz w trakcie wyświetlania. Na przykład, jeśli dla wyników obrysowywania wybrano wyświetlanie w postaci konturów, to rozwinięte ścieżki będą tylko konturami (a nie obiektami wypełnionymi i obrysowanymi). Warto też pamiętać, że zdjęcie obrysu z bieżącymi opcjami wyświetlania jest zachowane i zgrupowane z rozwiniętymi ścieżkami. Metoda ta pozwala zachować obraz obrysu, który później będzie można wykorzystywać jako przewodnik rozwiniętych ścieżek.

    • Aby przekonwertować obrys na obiekt aktywnego malowania, kliknij opcję Aktywne malowanie w panelu sterowania lub wybierz polecenie Obiekt > Aktywny obrys > Konwertuj na aktywne malowanie. Metoda ta jest przydatna w sytuacji, gdy do obrysowanej kompozycji będą stosowane - za pomocą narzędzia Aktywne wiadro z farbą - wypełnienia i obrysy.

Uwaga:

Aby utworzyć obrys i przekonwertować wynik obrysowywania w jednej operacji, wybierz polecenie Obiekt > Aktywny obrys > Utwórz i rozszerz lub Obiekt > Aktywny obrys > Utwórz i konwertuj na aktywne malowanie.

Film przedstawiający obrysowywanie można obejrzeć na stronie internetowej www.adobe.com/go/vid0043.

Usuwanie wyniku obrysowywania

Aby anulować obrysowywanie i zachować oryginalny obraz, usuń wynik obrysowywania.

  1. Zaznacz wynik obrysowywania.

  2. Wybierz polecenie Obiekt > Aktywny obrys > Zwolnij.

Ręczne obrysowywanie kompozycji przy użyciu warstw szablonowych

Warstwy szablonowe są zablokowanymi, niedrukowalnymi warstwami, które mogą być użyte do odręcznego obrysowywania obrazów. Warstwy szablonowe są wyszarzone w 50%, tak by widoczne były wszelkie ścieżki rysowane na warstwie. Warstwy szablonowe mogą być tworzone przy umieszczaniu obrazu lub z istniejących warstw.

  1. Wykonaj jedną z następujących czynności:

    • Aby umieścić obraz w postaci warstwy szablonowej, która będzie używana przy obrysowywaniu, wybierz polecenie Plik > Umieść, zaznacz obraz EPS, PDF lub obraz rastrowy do obrysowania, zaznacz opcję Szablon, a następnie kliknij Umieść. W panelu pojawi się nowa warstwa szablonowa pod warstwą bieżącą.

    • Aby obrysować istniejący obraz, upewnij się, że obraz znajduje się na swojej własnej warstwie, kliknij dwukrotnie warstwę w panelu Warstwy, zaznacz opcję Szablon i kliknij OK; ewentualnie, zaznacz warstwę i wybierz z menu panelu polecenie Szablon.

    Ikonę oka  zastąpiła ikona szablonu , a warstwa zostaje zablokowana.

  2. Obrysuj obraz za pomocą narzędzia Pióro lub Ołówek.

  3. Aby ukryć warstwę szablonu, wybierz polecenie Widok > Ukryj szablon. Aby ponownie wyświetlić warstwę, wybierz polecenie Widok > Pokaż szablon.

  4. Aby zmienić warstwę szablonową na zwykłą warstwę, dwukrotnie kliknij warstwę szablonową w panelu Warstwy, usuń zaznaczenie opcji Szablon i kliknij OK.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online