Dowiedz się, jak zwiększyć szybkość i wydajność programu Illustrator w systemie Windows.

Na szybkość i wydajność programu Adobe Illustrator wpływa kilka czynników, przykładowo system operacyjny i konfiguracja sprzętu, obieg pracy, a także wybierane opcje. Jeśli program Illustrator zacznie pracować wolniej niż zwykle, można wypróbować kilka technik, aby zoptymalizować wydajność programu Illustrator, a także innych aplikacji. (Poprawa wydajności jest tym bardziej zauważalna, im większe są pliki).

Zanim zaczniesz

Przed wykonaniem poniższych czynności zainstaluj najnowszą wersję programu Illustrator lub sprawdź, czy dostępne są jakieś aktualizacje używanej wersji. Aktualizacje oprogramowania często obejmują poprawki lub ulepszenia związane z wydajnością. 

W przypadku programu Illustrator CC można zaktualizować program Illustrator za pomocą aplikacji komputerowej Creative Cloud.

Uwaga:

Procedury zawarte w tym dokumencie oparto na domyślnych ustawieniach interfejsu użytkownika systemu Jeśli interfejs został dostosowany przez użytkownika, niektóre procedury mogą się różnić. Przykładowo inna może być ścieżka wyświetlania okna Panel sterowania. W zależności od wersji systemu może to być Start > Ustawienia > Panel sterowania lub Start > Panel sterowaniaWięcej wskazówek dotyczących rozwiązywania problemów oraz informacji ogólnych o systemie Windows można uzyskać, kontaktując się z pomocą techniczną firmy Adobepomocą techniczną firmy Microsoft.

Optymalizowanie systemu Windows

Skonfigurowanie systemu operacyjnego, tak aby pracował wydajnie, pozwala zwiększyć ilość pamięci dostępnej dla aplikacji, co umożliwia ich bardziej płynną pracę. Poniżej przedstawiono kilka technik, które pozwolą zoptymalizować system Windows i poprawić wydajność programu Illustrator.

Zwiększanie ilości dostępnej pamięci

Pamięć wirtualna umożliwia wykorzystanie miejsca na dysku twardym do przechowywania informacji, które zwykle są przechowywane w pamięci RAM. Jednakże czas dostępu do informacji zapisanych na dysku twardym jest dłuższy niż w przypadku pamięci RAM. W związku z tym częste używanie pamięci wirtualnej powoduje spadek wydajności.

Aby poprawić wydajność, wybierz właściwą wielkość pliku stronicowania (jest to obszar dysku twardego, na którym przechowywana jest pamięć wirtualna). Do zmiany wielkości pliku stronicowania wymagane są uprawnienia administratora. Program Illustrator pracuje optymalnie, gdy maksymalna wielkość pliku stronicowania jest ustawiona na około trzykrotność pojemności zainstalowanej pamięci RAM.

  1. Zamknij wszystkie aplikacje.

  2. Wybierz opcję Start > Panel sterowania > System > Zaawansowane ustawienia systemu.

  3. W oknie dialogowym Właściwości systemu wybierz kartę Zaawansowane.

  4. Kliknij przycisk Ustawienia i przejdź do karty Zaawansowane.

  5. W obszarze Pamięć wirtualna kliknij przycisk Zmień.

  6. Usuń zaznaczenie pola wyboru Automatycznie zarządzaj rozmiarem pliku stronicowania dla wszystkich dysków.

  7. Na liście Dysk zaznacz dysk twardy z ilością wolnego miejsca odpowiadającą przynajmniej trzykrotności pojemności zainstalowanej pamięci RAM. Na przykład, jeśli w komputerze zainstalowano 64 MB pamięci RAM, zaznacz dysk twardy z przynajmniej 192 MB wolnego miejsca. Aby zapewnić największą wydajność pamięci wirtualnej, wybierz dysk twardy, na którym nie ma dysku magazynującego programu Illustrator.

Wyłączanie funkcji sterowników

Sterowniki niektórych kart graficznych są wyposażone w zaawansowane ustawienia do przyspieszania lub modyfikowania parametrów wyświetlacza. Część z tych ustawień może znacząco wpływać na szybkość odświeżania ekranu przez program Illustrator. Wyłącz kolejno funkcje sterownika, aby określić najlepszą konfigurację dla programu Illustrator. Więcej informacji można znaleźć w dokumentacji karty graficznej.

Zarządzanie czcionkami

Każda czcionka powoduje zwiększenie użycia pamięci RAM przez system Windows. Zainstaluj tylko potrzebne czcionki, aby poprawić wydajność systemu i wydajność aplikacji, które korzystają z czcionek. Użyj narzędzia do zarządzania czcionkami, aby ułatwić zarządzanie wieloma czcionkami.

Ograniczanie liczby aplikacji startowych

Aplikacje uruchamiane automatycznie z systemem Windows zużywają pamięć RAM, która mogłaby być używana przez program Illustrator. Aby uniemożliwić automatyczne uruchamianie tych aplikacji, wykonaj następujące czynności:

  1. Zamknij wszystkie aplikacje.

  2. Uruchom program Eksplorator Windows.
  3. Wyłącz wszystkie aplikacje startowe uruchamiane dla bieżącego użytkownika, przenosząc wszystkie ikony i skróty z folderu StartUp (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) do innego folderu.

  4. Uruchom system Windows ponownie.

Aby zamknąć aplikacje, które są uruchamiane automatycznie na podstawie wpisów rejestru, wykonaj następujące czynności:

  1. Uruchom system Windows ponownie.
  2. Naciśnij kombinację klawiszy Ctrl+Shift+Esc.

  3. Kliknij kartę Procesy.

  4. Zaznacz nazwę aplikacji, a następnie kliknij przycisk Zakończ zadanie.

  5. Ponownie uruchom program Illustrator. Jeśli wydajność programu Illustrator poprawi się, skontaktuj się z producentem aplikacji, aby uzyskać informacje o tym, jak trwale wyłączyć automatyczne uruchamianie takiej aplikacji. Powtórz kroki 2–5 dla pozostałych aplikacji startowych.

Przywracanie ikon i skrótów

Jeśli wydajność programu Illustrator nie poprawi się po ponownym uruchomieniu systemu, przywróć ikony i skróty za pomocą programu Eksplorator Windows, ponownie przenosząc je do folderu Autostart.

W przypadku zaobserwowania poprawy wydajności programu Illustrator zidentyfikuj programy powodujące spadek wydajności. W tym celu w programie Eksplorator Windows przenoś kolejno ikony i skróty programów do folderu Autostart.

Po włączeniu każdego zestawu ikon i skrótów ponownie uruchom komputer, aby przetestować wydajność programu Illustrator.

Powtarzaj ten proces aż do zaobserwowania spadku wydajności programu Illustrator. Po zidentyfikowaniu ikony lub skrótu programu, który powoduje problem z wydajnością, usuń go ponownie. Skontaktuj się z producentem programu, aby uzyskać informacje o dostępności aktualizacji.

Optymalizowanie sprzętu

Używany sprzęt wpływa na wydajność programu Illustrator: im szybszy procesor lub dysk twardy, tym szybciej program Illustrator może przetwarzać informacje. Inne ulepszenia sprzętu, takie jak rozbudowa pamięci RAM, płyta wieloprocesorowa lub optymalizacja i defragmentacja dysków, również mogą poprawić wydajność. Wypróbuj te techniki, aby zoptymalizować sprzęt.

Użycie szybszego procesora

Szybkość procesora komputera wpływa na szybkość pracy programu Illustrator. Ponieważ program Illustrator przetwarza ogromne ilości danych i wykonuje wiele obliczeń, jego szybkość zależy od szybkości procesora. Rozważ użycie komputera z szybszym procesorem.

Rozbudowa pamięci RAM

Jeśli ilość pamięci RAM jest niewystarczająca na potrzeby programu Illustrator, wykorzystuje on miejsce na dysku twardym (pamięć wirtualna, dysk magazynujący lub oba te rozwiązania) do przetwarzania informacji. Program Illustrator działa najszybciej, gdy może przetwarzać informacje w pamięci, bez użycia dysku twardego.

Optymalizowanie miejsca na dysku

Poniżej opisano kilka sposobów optymalizacji miejsca na dysku:

  • Sprawdź dysk twardy w poszukiwaniu błędów, zdefragmentuj pliki i zoptymalizuj użycie dostępnego miejsca na dysku twardym, używając programu CHKDSK.exe i Defragmentator dysków. Więcej informacji można znaleźć w dokumentacji systemu Windows lub na stronie Poprawianie wydajności systemu Windows.
  • Zapisz pliki na dyskach o szybszym dostępie. Na przykład użyj wewnętrznego dysku twardego zamiast serwera sieciowego (dysku sieciowego) lub dysku zewnętrznego.
  • Aby zapisać plik na dysku sieciowym lub zewnętrznym, najpierw zapisz go na wewnętrznym dysku twardym. Następnie zamknij plik i użyj programu Eksplorator Windows, aby skopiować go na dysk sieciowy lub zewnętrzny.

Używanie drukarki PostScript

Aby zoptymalizować drukowanie w programie Illustrator, użyj drukarki PostScript. Większość drukarek innych niż PostScript wykorzystuje informacje wyświetlacza, zasoby komputera głównego i zastrzeżone sterowniki drukarki przekazujące dane drukowania. W związku z tym drukowanie może zająć więcej czasu niż w przypadku drukarki PostScript.

Efektywne używanie funkcji programu Illustrator

Sposób pracy z programem Illustrator, w szczególności sposób przeglądania kompozycji, może wpływać na wydajność programu Illustrator. Poniżej przestawiono kilka sposobów efektywnego użycia funkcji programu Illustrator

Praca w widoku Kontur

W widoku Kontur ukrywane są atrybuty farby, a kompozycja jest wyświetlana w postaci niewypełnionych ścieżek. Praca w trybie Kontur może przyspieszyć wyświetlanie złożonych kompozycji, takich jak obiekty z gradientami lub wzorkami. Widok Kontur umożliwia też łatwiejszą edycję obiektów ukrytych za innymi wypełnionymi obiektami.

Aby wyświetlić dokument programu Illustrator w widoku Kontur, wybierz polecenia Widok > Kontur.

Tworzenie niestandardowych widoków

Program umożliwia tworzenie niestandardowych widoków dokumentów. Pozwalają one na szybką zmianę trybu widoku, poziomu powiększenia, pozycji przewijania i opcji warstw.

Aby utworzyć niestandardowy widok dokumentu programu Illustrator, ustaw atrybuty widoku, które mają być zapisane. Następnie wybierz polecenia Widok > Nowy widok i w oknie dialogowym Nowy widok wprowadź nazwę. Niestandardowy widok zostanie wyświetlony w menu Widok.

Zmiana ustawień efektów rastra

Możliwa jest zmiana rozdzielczości efektów rastra w celu zoptymalizowania wydajności programu Illustrator.

Aby zmienić rozdzielczość efektów rastra, wybierz polecenia Efekty > Ustawienia efektów rastra dokumentu. Po wyświetleniu listy rozwijanej Rozdzielczość wykonaj jedną z poniższych czynności:

  • Wybierz pozycję Ekranu w przypadku edycji plików. Program Illustrator będzie wykorzystywać rozdzielczość 72 ppi do przetwarzania efektów rastra, co pozwala zwiększyć szybkość wyświetlania.
  • Wybierz pozycję Wysoka w przypadku drukowania plików. W tym przypadku efekty rastra będą przetwarzane z rozdzielczością 300 ppi. Powoduje ona zmniejszenie szybkości drukowania, ale zwiększenie jakości druku.

Kliknij przycisk OK.

Ukrywanie warstw i usuwanie miniatur

Użyj panelu Warstwy do porządkowania i modyfikowania kompozycji. Program Illustrator będzie odświeżać ekran szybciej, jeśli zostaną ukryte warstwy zawierające złożone kompozycje lub obrazy bitmapowe wysokiej rozdzielczości.

Aby ukryć warstwę, kliknij ikonę oka po lewej stronie nazwy tej warstwy. Aby ukryć wszystkie warstwy poza żądaną warstwą, naciśnij przycisk Alt i kliknij ikonę oka (przycisk Option w systemie Mac OS).

W panelu Warstwy mogą być wyświetlane miniatury warstw głównych, warstw zagnieżdżonych, grup i obiektów. Aby zmniejszyć liczbę miniatur i dzięki temu przyspieszyć odświeżanie ekranu w programie Illustrator, wybierz z menu panelu Warstwy polecenie Opcje panelu, a następnie zmniejsz liczbę miniatur.

Panel Opcje

Wyłączanie podglądu nadruku

Podgląd nadruku umożliwia wyświetlanie podglądu atramentu uzyskanego przez urządzenie końcowe, po wykorzystaniu opcji mieszania, obszarów przezroczystych i nadrukowywania. Aby zwiększyć wydajność, wyłącz podgląd nadruku.

Podgląd nadruku można włączyć i wyłączyć, wybierając polecenia Widok > Podgląd nadruku.

Usuwanie nieużywanych przestrzeni roboczych

Obszary robocze to te obszary, które mogą zawierać kompozycje drukowalne. Aby zoptymalizować wydajność, zaleca się usunięcie nieużywanych lub niepotrzebnych przestrzeni roboczych.

Aby zarządzać przestrzeniami roboczymi, wybierz polecenia Okno > Przestrzenie robocze. Zaznacz przestrzeń roboczą, która ma być usunięta, i naciśnij klawisz Delete.

Zmiana preferencji dysku magazynującego

W przypadku pracy z osadzonymi obrazami bitmapowymi na komputerze z niewystarczającą ilością pamięci RAM program Illustrator wykorzystuje miejsce na dysku twardym jako dysk magazynujący. Jednakże czas dostępu do informacji zapisanych na dysku twardym jest dłuższy niż w przypadku pamięci RAM. Użycie części dysku twardego jako pamięci wirtualnej powoduje spadek wydajności. Jeśli potrzeba więcej pamięci do pracy z programem Illustrator, firma Adobe zaleca rozbudowę pamięci RAM.

Domyślnie program Illustrator tworzy podstawowy dysk magazynujący na dysku systemowym. Zaleca się zmianę lokalizacji podstawowego dysku magazynującego programu Illustrator na najszybszy dysk twardy.

Aby zmienić preferencje dysku magazynującego, wykonaj następujące czynności:

  1. Wybierz polecenia Edycja > Preferencje > Wtyczki i dyski magazynujące.

  2. Z menu podręcznego Podstawowy wybierz żądany dysk twardy. W przypadku pracy z dużymi obrazami i kilku dysków zainstalowanych w komputerze z menu Dodatkowy wybierz inny dysk.

  3. Kliknij przycisk OK i ponownie uruchom program Illustrator.

Usuwanie nieużywanych elementów z profili dokumentów

W profilach dokumentów programu Illustrator przechowywane są domyślne wzorki, gradienty, projekty wykresów, kolory, biblioteki kolorów i rodzaje pędzli, które są wyświetlane w nowych dokumentach programu Illustrator. W plikach tych zapisywane są też: poziom powiększenia, wielkość okna, preferencje widoku i pozycja przewijania nowych dokumentów. Można zminimalizować wielkość pliku nowych dokumentów, usuwając niepotrzebne próbki i rodzaje pędzli z profili nowych dokumentów programu Illustrator.

Więcej informacji o tworzeniu własnych profili dokumentów w programie Illustrator można znaleźć na stronie Profile startowe: wspaniałe narzędzie do dostosowywania nowych dokumentów.

Usuwanie nieużywanych elementów z szablonów

Szablony pozwalają tworzyć dokumenty o typowych ustawieniach i typowych elementach. Można zminimalizować wielkość pliku nowych dokumentów, usuwając niepotrzebne próbki, symbole, style graficzne i rodzaje pędzli z szablonów.

Więcej informacji o tworzeniu plików szablonów można znaleźć na stronie Pliki i szablony.

Włączanie łączy do obrazów

Osadzone obrazy bitmapowe (na przykład TIFF, BMP lub Photoshop EPS) mogą znacząco zwiększyć wielkość dokumentu programu Illustrator, obniżając jego wydajność. Aby poprawić wydajność, zaznacz pole wyboru Połącz podczas umieszczania obrazu bitmapowego. Opcja Połącz powoduje wstawienie odwołania do umieszczanego pliku na dysku twardym.

  • Wybierz polecenia Plik > Umieść. W oknie dialogowym Umieść zaznacz pole wyboru Połącz.

Jeśli studio poligraficzne wymaga osadzonych obrazów, zapisz kopię plików. Zaznacz pole wyboru Dołącz pliki połączone w oknie dialogowym Opcje programu Illustrator lub Opcje EPS .

Korzystanie z podglądów EPS o niskiej rozdzielczości

Jeśli dokument zawiera połączone obrazy EPS z podglądem wysokiej rozdzielczości, obniża to szybkość odświeżania ekranu w trakcie edycji kompozycji w programie Illustrator. Aby przyspieszyć odświeżanie ekranu programu Illustrator, użyj podglądów EPS o niskiej rozdzielczości. Wykonaj następujące czynności:

  1. Wybierz polecenia Edycja > Preferencje > Obsługa pliku i schowek.

  2. Zaznacz pole wyboru Niska rozdzielczość prewki połączonych plików EPS i kliknij przycisk OK.

Wyłączanie opcji Pokaż interakcje przezroczystości DCS

W oknie dialogowym Opcje panelu Łącza dostępne jest pole wyboru Pokaż interakcje przezroczystości DCS. Jeśli pole wyboru jest zaznaczone, w panelu Łącza wyświetlana jest żółta ikona wskazująca połączone pliki graficzne DCS EPS, które są przezroczyste lub nakładają się na obiekty przezroczyste. Ponieważ opcja ta wymusza częste sprawdzanie przez program Illustrator, czy połączone pliki EPS wchodzą w interakcje z przezroczystością, może to obniżać jego wydajność.

Aby wyłączyć opcję Pokaż interakcje przezroczystości DCS, wykonaj następujące czynności:

  1. Wybierz polecenia Okno >Łącza. Z menu panelu Łącza wybierz pozycję Opcje panelu.

  2. Usuń zaznaczenie pola wyboru Pokaż interakcje przezroczystości DCS i kliknij przycisk OK.

Ukrywanie panelu Nawigator

W panelu Nawigator wyświetlana jest miniatura widoku bieżącej kompozycji, która ma ułatwiać nawigację. Czas przetwarzania potrzebny na aktualizację miniatury po każdej zmianie dokumentu zależy od stopnia złożoności kompozycji. Aby w przypadku złożonych dokumentów zwiększyć szybkość odświeżania ekranu, ukryj panel Nawigator. W menu Okno usuń zaznaczenie pozycji Nawigator.

Można skonfigurować własne widoki, aby skuteczniej zmieniać poziom powiększenia poszczególnych obszarów dokumentu.

Wyłączanie wygładzania kompozycji

Opcja Kompozycja wygładzona pozwala wygładzić tekst i grafikę przez mieszanie kolorów pikseli brzegowych obiektów z kolorami sąsiadujących pikseli. Proces ten może jednak obniżyć szybkość odświeżania ekranu. Aby wyłączyć tę opcję, wykonaj następujące czynności:

  1. Wybierz polecenia Edycja > Preferencje > Ogólne.

  2. Usuń zaznaczenie pola wyboru Kompozycja wygładzona i kliknij przycisk OK.

Używanie polecenia Uproszczenie

Polecenie Uproszczenie umożliwia zmniejszenie liczby kotwic ścieżek i kształtów ścieżek, co pozwala zmniejszyć wielkość pliku i zwiększyć wydajność. Aby zastosować polecenie Uproszczenie, zaznacz żądaną ścieżkę lub obiekt, a następnie wybierz polecenia Obiekt > Ścieżka > Uproszczenie.

Więcej informacji o poleceniu Uproszczenie można znaleźć na stronie Pomoc programu Illustrator.

Wyłączanie inteligentnych linii pomocniczych

Inteligentne linie pomocnicze umożliwiają tworzenie, wyrównywanie, edytowanie i przekształcanie obiektów programu Illustrator względem innych obiektów. Jeśli w kompozycji jest wiele obiektów, czas potrzebny na wyświetlanie inteligentnych linii pomocniczych może ulec wydłużeniu. Aby wyłączyć inteligentne linie pomocnicze, w menu Widok usuń zaznaczenie pozycji Inteligentne linie pomocnicze.

Więcej informacji o inteligentnych liniach pomocniczych można znaleźć na stronie Linijki, siatki, linie pomocnicze i linie cięcia.

Raster ścieżek pędzla z włosia i wyłączanie funkcji plików PDF

Pociągnięcia pędzla z włosia składają się z kilkunastu nachodzących na siebie przezroczystych ścieżek. Ścieżki te, podobnie jak inne wypełnione ścieżki w programie Illustrator, wchodzą w interakcję z farbą innych obiektów, w tym również z innymi ścieżkami pędzla z włosia.

Przed przystąpieniem do wykonywania dużych kompozycji wypróbuj pędzle z włosia i sposób odwzorowania farby. Zmiana atrybutów pędzla i ich ponowne zastosowanie powoduje ponowne renderowanie wszystkich użytych pędzli.

W przypadku korzystania z pędzli z włosia można ograniczyć złożoność i wielość pliku dokumentu, wykonując następujące czynności:

  • Rasteryzuj niektóre ścieżki pędzla z włosia. Przed rasteryzacją trzeba zapisać kopię oryginalnej kompozycji.

Jeśli w kompozycji jest duża liczba (>30) pędzli z włosia, ogranicz złożoność i liczbę ścieżek pędzla z włosia. Zaznacz ścieżki pędzla z włosia i wybierz polecenia Obiekt > Rasteryzacja.

  • Wyłącz funkcje plików PDF.

Domyślnie program Illustrator zapisuje dane PDF, co zapewnia zgodność plików programu Illustrator (*ai) z innymi aplikacjami Adobe. Wybierz polecenia Plik > Zapisz lub Plik > Zapisz jako i kliknij przycisk Zapisz. W oknie dialogowym Opcje programu Illustrator usuń zaznaczenie pola wyboru Utwórz plik zgodny z PDF.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online