Learn about new features and enhancements in the November 2019 release of Photoshop on desktop (version 21.0).
align and distribute

Cloud documents

With Photoshop now on the iPad, use cloud documents to work seamelessly across Mac, Windows, and your iPad. Your documents are saved to Adobe's cloud as you work.  

align and distribute

Improvements to presets

Explore new swatches, gradients, patterns, shapes, and styles effortlessly. Presets are now more intuitive to use and easier to organize.

align and distribute

New Object Selection tool

Use the new Object Selection tool to better automate complex selections. Simply define a region and Photoshop does the rest.

align and distribute

Consistent transform behavior 

Proportionally transform multiple layers, regardless of the layer type, without using the Shift key.

Improved properties panel

Improved properties panel

Find even more of the controls you need in one central location. Easily change document settings, access all type layer settings, and conveniently use Quick Actions.

Smart Object to layers

Smart Object to layers

Easily convert your Smart Objects back into component layers to fine-tune your designs—all in one place, without having to switch between document windows.

Transform warp

Enhanced Transform Warp

Get more control with the Warp tool. Add control points anywhere or divide your image with a customizable grid to transform by individual nodes, or a larger selection.

Other enhancements

Other enhancements

Check out all the new enhancements to Photoshop and learn how you can simplify and accelerate your workflow.

Cloud documents

Some Adobe Creative Cloud features and services are currently not available on adobe.com in mainland China. As a result, Photoshop on the iPad and cloud documents are not available in this country/region.

Photoshop Cloud documents

Cloud documents are Adobe's cloud-native files that you can easily open and edit in any of Adobe's compatible apps. Cloud documents enable you to seamlessly access your work across devices. Simply connect to the Internet, open your PSD from the Cloud documents tab in the app home screen and pick where you left off.

Saving your creative work as a cloud document provides you with exclusive benefits:

  • Seamlessly access files across devices: Access your work from anywhere—Photoshop on your desktop, on your laptop, Photoshop on the iPad, and Adobe Fresco. Your work is saved safely in the cloud wherever you work.
  • Use one file across products: Simply create a cloud document in Photoshop on your desktop and work on it in Adobe Fresco or Photoshop on the iPad. Or vice versa.
  • Keep your files up-to-date and safe: Cloud documents automatically save your most recent version. Meaning you can pick up from where you left off across your devices, whether sitting at your desktop or while on the couch.
  • Work offline: Your offline version will automatically sync when you reconnect to the Internet. For Photoshop on the desktop, working offline has not changed from previous versions.

Cloud documents, Creative Cloud files, and other synced files are part of the Creative Cloud services included with your membership and count toward your Creative Cloud storage allocation.

Improvements to presets

Improved presets

Presets have been reimagined to bring a whole new experience in the latest release of Photoshop.

From the menu bar, go to Window > Swatches, Gradients, Patterns, Shapes, or Styles. You now get:  

  • New modern default presets like gradients, patterns, shapes and styles.
  • Dedicated panels for gradients, patterns, and shapes.
  • Ability to manage your presets by organizing them into groups. Simply drag and move the presets to rearrange and reorder within the panels.   
  • Ability to drag gradients, patterns, swatches, and styles from the presets panel onto the canvas.
  • A live preview on the canvas when you click through your presets to try different looks.

You can still access the familiar legacy presets by enabling the Legacy Presets option from the contextual panel menu. 

New Object Selection tool

Powered by Adobe Sensei

Object Selection Tool

Note:

Not seeing the Object Selection tool in your toolbar? See Tools missing from the toolbar.

Powered by Adobe Sensei, the new Object Selection tool simplifies the process selecting a single object, multiple objects, or parts of an object in an image—people, cars, furniture, pets, clothes, and more.

Simply draw a rectangular region or lasso around the object and the Object Selection tool will automatically select the object inside the defined region, speeding up even the most complex selections.

You can access the Object Selection tool at the following locations:

  • From the main application Tools panel in Photoshop, located in the same group as the Quick Selection and Magic Wand tool.
  • From the Tools panel in the Select And Mask workspace.

For detailed information, see Object Selection tool.

Consistent transform behavior

Consistent transform behavior

Regardless of the layer type, you can now proportionally transform multiple layers without having to press the Shift key.

In this release of Photoshop, the following changes and improvements have been made to the transform behavior:

Consistent transform behavior
  • The default transform behavior is now proportional scaling for all layer types and objects, indicated by the Maintain Aspect Ratio button (Link icon) in the ON state in the Options bar. 
  • To change the default transform behavior to non-proportional scaling, simply click the  Maintain Aspect Ratio button to turn it OFF. 
  • The Shift key, while pressed, now acts as a toggle for the Maintain Aspect Ratio button. If the Maintain Aspect Ratio button is ON, the Shift key toggles it OFF while pressed and vice versa.
  • Photoshop now remembers your last transform behavior setting—proportional or non-proportional scaling—it will be your default transform behavior when you start Photoshop the next time. 

Want to switch back to the legacy transform behavior?

From the menu bar, choose Edit (Win)/Photoshop (Mac) > Preferences > General, then select Legacy Free Transform.

For related helpful information, see the following links:

Improved Properties panel

Improved Properties panel

In the Properties panel, you easily discover even more controls for Document, Pixel Layer, and Type Layer properties without navigating through multiple panels and dialogs. The properties are shown contextually for the selected content. New Quick Actions will also accelerate your common tasks. For example, in a single click, you can now remove the background, select a subject while in the pixel layer properties panel, or quickly convert text layers into a frame or shape. 

Properties panel More properties added under Quick Actions added
Document properties
  • Canvas
  • Rulers & Grids
  • Guides
  • Image Size
  • Crop
  • Trim
  • Rotate
Pixel Layer properties
  • Transform
  • Align and Distribute
  • Remove Background
  • Select Subject
Type Layer properties
  • Transform
  • Character
  • Paragraph
  • Type Options
  • Convert to Frame
  • Convert to Shape

Convert Smart Object to layers

Convert Smart Object to Layers

In this release of Photoshop, you can easily convert a Smart Object back into its component layers without all of the extra steps.

Simply select the Smart Object in the Layers panel, then do any of the following:

  • Right-click/Control-click the Smart Object, then choose Convert To Layers from the context menu.
  • From the menu bar, choose Layers > Smart Objects > Convert To Layers

Enhanced Transform Warp

Transform Warp

With enhancements made to the Warp tool, you get more control over creative warping in Photoshop. Simply add control points anywhere or divide your image with a customizable grid, then transform by individual nodes or a larger selection. With the Warp tool, you can now:   

  • Choose new preset grid size options: 3 x 3, 4 x 4, 5 x 5. 
  • Create your own custom-sized grids.
  • Add your own gridlines and anchor points. 
  • Delete gridlines.
  • Select and drag multiple anchor points.
  • Undo individual steps of editing a warp.

To try it out, choose Edit > Transform > Warp.

For detailed information see, Warp images, shapes, and paths.

Other enhancements

Stylistic sets for OpenType fonts

Stylistic sets for OpenType fonts are available in Photoshop. Stylistic sets simplify your ability to access a font's alternate glyphs. Now, you can simply access the Stylistic Sets menu in the Properties panel to apply one or more stylistic sets to your text. 

Stylistic sets for OpenType fonts

To apply a stylistic set in Photoshop:

  1. Do one of the following:
    • Select the Type tool and create a new Type layer. 
    • Select one or more Type layers in the Layers panel.
    • Select the Type tool and select a specific text run within a Type layer.
  2. Go to the Properties panel (Window > Properties).
  3. In the Properties panel, scroll down to the Type options pod. Expand the pod, if necessary.
  4. Click the icon for Stylisctic Sets to open the menu.
  5. Choose the desired stylisctic set.

For related helpful information, see work with Work with OpenType SVG fonts.

Enhanced Content-Aware Fill

In this release of Photoshop, three new Sampling Area Options have been added to the Content-aware Fill workspace. You can use these options to determine the sampling area in your image where you want Photoshop to look for source pixels to fill content. 

  • Auto: Uses content similar to surrounding fill area.
  • Rectangular: Uses rectangular region around fill area. 
  • Custom: Uses a manually defined sampling area. You identify exactly which pixels to fill from.

To try out the new options, open an image and select an area to fill. Then choose Edit > Content-Aware Fill. The Sampling Area Options appear in the Content-Aware Fill panel on the right side of the workspace.

Sampling Area options

For related helpful information, see Adjust Content-Aware Fill settings.

32-bit adjustment layers for Brightness/Contrast and Curves

Especially useful for HDR workflows, you can now use Curves and Brightness/Contrast adjustments in 32-bit documents either as direct adjustments, adjustment layers, or smart filters.

Curves adjustments
Brightness/Contrast adjustments

For related helpful information, see the following links:

What's new screen within the app

You can now check out what's new in Photoshop right in the app.

To read an overview of the new features in Photoshop, go the Home screen, then click Open In The App on the right.  

What's new screen in Photoshop

For related helpful information, see Home screen.

New Shortcuts

Paint and erase with the same brush

Use the ~ tilde key (below the escape or Esc key) to toggle between painting and erasing with the same brush tip. This feature is also available as a touch shortcut in Photoshop on the iPad.

Zoom to a layer's contents

In the Layers panel, Alt+click (Win) / Option+click (Mac) on a layer to zoom to that layer's contents. Alternatively, you can also choose View > Fit Layer(s) To Screen from the menu bar. 

Rotate brush tip

You can now quickly rotate the brush tip by using the Left and Right Arrow keys when a brush tool is active.

  • Left Arrow key rotates the brush tip by 1 degree anti-clockwise.
  • Right Arrow key rotates the brush tip by 1 degree clockwise.
  • Shift + Left Arrow key rotates the brush tip by 15 degrees anti-clockwise.
  • Shift + Right Arrow key rotates the brush tip by 15 degrees clockwise.

A new user preference (Preferences > Tools > Arrow Keys Rotate Brush Tip) has also been added in the Preferences dialog. This preference is ON by default. 

To view a comprehensive list of shortcuts in Photoshop, see Default keyboard shortcuts.

Animated GIF support

You can now save Photoshop documents with frames in GIF format directly from the File > Save As option. While saving from File > Save As option, all the options that appear in the GIF Save Options dialog are supported to write animated GIF.

GIF Save Options

For related information, see Save in GIF format.

Improved New Document dialog performance

With improvements made in release of Photoshop, the New Document dialog (File > New) now opens almost instantaneously. 

Improved Lens Blur performance

With improvements made to Lens Blur, you can take more advantage of the depth information in the image captured by your camera. You can now set a focal point to choose what to blur and keep in focus in your image. With GPU improvements, you'll also notice faster performance while applying the Lens Blur filters.

For detailed information, see Add lens blur.

Documents tab improvement

A new Close Others option has been in this release, which allows you to close all open documents (windows, floating, or docked) other than your current document. You can access this option the following ways:

  • From the menu bar, choose File > Close Others.
  • Right-click (Win) / Control-click (Mac) on a document tab, then choose Close Others from the context menu.
  • Use keyboard shortcuts: 
    • Win: Ctrl + Alt + P
    • Mac: Command + Option + P

Smart Object and Layer Comp tracking

You can now save the variation of a Layer Comp within a Smart Object to save time from manually setting each variation. Choose Window > Layer Comps.

  • In the New Layer Comp dialog, a new Layer Comp Selection For Smart Objects option has been added.
Smart Object and Layer Comp tracking
  • In the Layer Comps window, a Toggle Layer Comps Selection For Smart Objects option has been added.
Toggle Smart Object and Layer Comp tracking
  • In the Layer Comps window, at the bottom, an option to update the Smart Object's Layer Comp selection has been added.
Update Smart Object and Layer Comp tracking

For more information, see Layer comps.

World-Ready Layout text engine option

A new World-Ready Layout text engine option has been introduced in this release of Photoshop, which provides correct word shaping for Indic, Middle Eastern, and South East Asian scripts in your documents. To set it as your preferred text engine option, choose Edit (Win) / Photoshop (Mac) > Preferences > Type, then select World-Ready Layout under Choose Text Engine Options

World-ready Layout

For detailed information, see the following links:

Preference setting to auto-show the home screen

In the preferences, you can choose to automatically show or disable the home screen when you launch Photoshop. Choose Edit (Win) / Photoshop (Mac) > Preferences > General, then select or deselect Auto-show The Home Screen.

Auto-show The Home Screen

For related helpful information, see Home screen.

Adobe Asset Link version 1.1 is now available to Creative Cloud for enterprise and AEM Assets customers. 

Adobe Asset Link streamlines collaboration between creatives and marketers in the content creation process. It connects Adobe Experience Manager Assets (AEM Assets) with Creative Cloud desktop apps InDesign, Photoshop, and Illustrator. The Adobe Asset Link panel allows creatives to access and modify content stored in AEM Assets without leaving the creative apps they are most familiar with.

To learn about the new features in Adobe Assets Link 1.1, see Adobe Asset Link.

What's changed

  • In addition to Preferences > General > Use Legacy Free Transform preference, the Maintain Aspect Ratio link icon on the transform options bar is now sticky between invocations (each time you select Edit > Free Transform or use the keyboard shortcut cmd/ctrl + T) and launches (each time quit Photoshop and relaunch). Note: Holding down Shift key does the opposite of whatever the state of the Maintain Aspect Ratio link icon is.
  • The Object Selection tool is now the default tool in 4th slot down where the Quick Select tool was default tool. Click and hold on the Object Selection tool to show the Quick Select tool and the Magic Wand tool or hit the w key to cycle through these tools.
  • Presets that shipped with previous versions of Photoshop are now called Legacy Presets and new presets have replaced them. To load Legacy Presets, go to the any of the preset panel's menus and choose Load Legacy PresetsNote: If Legacy presets aren't loaded, some actions may fail. Workaround.- Load legacy presets
  • If you get a Scratch Disk is Full error on launch, you are now presented with a user interface to select a different Scratch Disk so you can continue.
  • Preferences > General > Auto-Update Open Documents has been changed to Preferences > General > Auto-Update Open File-based Documents which determines whether to automatically re-read open file-based documents updated outside Photoshop; cloud documents are not affected by this setting.
  • Preferences > General > Disable the Home Screen has been changed to Preferences > General > Auto show the Home Screen which will automatically show the home screen when no documents are open.
  • Preferences > File Handling > Local Cloud Files Working Directory was added to let you choose the local directory for associated cloud document files.
  • Type > Add Fonts from Typekit... has been changed to Type > More from Adobe Fonts.
  • TOYO COLOR FINDER swatches no longer ship with Photoshop by default. Contact Toyo Ink to obtain their color libraries.

Fixed customer-reported issues

For detailed information, see Fixed issues in Photoshop.

Known Issues

For detailed information, see Known issues in Photoshop

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy