What's covered
Learn how to make Illustrator run quickly and efficiently on Windows.
On this page

    Several factors affect how quickly and efficiently Adobe Illustrator performs, such as your operating system, hardware configuration, your workflow, and selected options. If you notice Illustrator running more slowly than usual, try the techniques below for optimizing not only Illustrator performance, but performance of your other apps as well. (An improvement in performance is more noticeable when you work with large files.)

    Before you begin

    Before working through the tasks below, make sure to install the latest version of Illustrator or any updates to the version you are using. Software updates often include performance-related fixes or enhancements. 

    If you're using Illustrator CC, you can update Illustrator via the Creative Cloud desktop application.

    Note:

    The procedures in this document apply to Windows 8, 7, Vista, and XP, and are based on the default interface. If the interface is customized, then some procedures vary. For example, the path to navigate to the Control Panel may vary. Choose Start > Settings > Control Panel or Start > Control Panel, depending on your version of Windows. For troubleshooting tips and general information about Windows, consult Adobe Support and Microsoft Support.

    Optimize Windows

    By configuring your operating system to run efficiently, you increase the amount of memory available to apps, which helps them run smoothly. Here are several techniques to optimize Windows and improve Illustrator performance.

    Virtual memory lets you use hard disk space to store information normally stored in RAM. But it takes longer to access information on a hard disk than it does to access information in memory. So, it can decrease performance if your system has to rely too heavily on virtual memory.

    To increase performance, choose the right size for your paging file (the area of the hard drive that stores virtual memory). Administrator rights are required to change the paging file size. Illustrator performs best when the paging file's maximum size is about three times the amount of installed RAM.

    Windows 8/7/Vista: See Set the virtual memory paging file to the default size (Windows 7 and Vista).

    Windows XP: To create a paging file with a maximum size of three times your amount of installed RAM, do the following:

    1. Quit all apps.

    2. Choose Start > Control Panel and then double-click System.

    3. In the Performance Options dialog box, choose the Advanced tab, click Settings in the Performance section, and then choose the Advanced tab.

    4. In the Virtual Memory section, click Change.

    5. Clear the automatically manage paging file size for all drives check box.

    6. From the Drive list, select a hard drive that has at least three times the amount of your computer's installed RAM. For example, if your computer has 64 MB of RAM, select a hard drive that has at least 192 MB of free space. For best performance, choose a hard drive not used for the Illustrator scratch disk.

    Some video adapter drivers offer advanced settings for accelerating or modifying graphics display. Sometimes these settings can adversely affect screen redraw performance in Illustrator. Try disabling driver-specific features to determine the best settings for use with Illustrator. For more information, see the documentation for your video adapter.


    Every font you have increases the amount of RAM Windows uses. Install only the fonts you need, to improve system performance and the performance of apps that access fonts. Use a font management utility to help you manage many fonts.


    Apps that start automatically on Windows compete with Illustrator for available RAM. To prevent apps from starting automatically, do the following:

    Windows 8/7/Vista: See Restart Windows in a modified mode (Windows 7 and Vista).

    Windows XP: To remove programs from the Startup folder in Windows, follow these steps:

    1. Quit all apps.

    2. Start Windows Explorer.
    3. Disable startup apps that are specific to the current user by moving all icons and shortcuts from the Startup folder (Documents and Settings\[current user]\Start Menu\Programs\Startup) to another folder.

    4. Disable startup apps that are common to all users by moving all icons and shortcuts from the Startup folder (Documents and Settings\[All Users]\Start Menu\Programs\Startup) to another folder.

    5. Restart Windows.

    To close apps specified to start automatically in the registry, do the following:

    1. Restart Windows.
    2. Press Ctrl+Shift+Esc.

    3. Choose the Applications tab.

    4. Select an app name, and then click End Task.

    5. Restart Illustrator. If Illustrator performance improves, then contact the application's manufacturer for assistance to permanently disable it from starting automatically. Repeat steps 2-5 for each remaining startup app.

    Re-enable icons and shortcuts

    If Illustrator performance does not improve after restarting, then re-enable the icons and shortcuts in Windows Explorer by putting them back in the Startup folder.

    If the performance of Illustrator improves, then isolate the performance problem to one or more programs and re-enable their icons and shortcuts by place them in the Startup folder using Windows Explorer.

    Restart your computer after you re-enable each set of icons and shortcuts, and test Illustrator performance.

    Repeat this process until the performance of Illustrator degrades. When you have isolated the icon or shortcut that is causing the performance problem, remove it again. Contact the program's manufacturer to see if an update is available.


    Optimize hardware

    The hardware you use affects Illustrator performance: the faster the processor or hard drive, the faster Illustrator can process information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor system, or optimizing and defragmenting drives, can also improve performance. Try these techniques to optimize hardware.

    The speed of your computer's central processing unit (CPU) affects the speed of Illustrator. Because Illustrator manipulates large quantities of data and performs many calculations, its speed depends on the processor's speed. Consider using a computer with a faster processor.


    If Illustrator has insufficient RAM, it uses hard disk space (virtual memory, scratch disk, or both) to process information. Illustrator is fastest when it can process information in memory, without using a hard disk.


    Here are a few ways to optimize disk space:

    • Check your hard disk for errors, defragment files, and make best use of available hard disk space by using the CHKDSK.exe and Disk Defragmenter programs. For information, see your Windows documentation or Improve performance for Windows.
    • Save your files to drives with faster access speeds. For example, use an internal hard drive rather than a network server (network drive) or external drive.
    • If you want to save a file to a network or external drive, first save the file to an internal hard drive. Then close the file and use Windows Explorer to copy it to the network or external drive. If you use CS4, you can save the file to the network using Adobe Version Cue.

    For best results when printing from Illustrator, use a PostScript printer. Most non-PostScript printers rely on display information, host computer resources, and proprietary printer drivers to relay print information to the printer. Therefore, they can take much longer to print than a PostScript printer.


    Use Illustrator features effectively

    The way you work in Illustrator—especially the way you view artwork—can affect Illustrator performance. Here are some ways to use Illustrator features efficiently.

    Outline View hides paint attributes, displaying the artwork as unfilled paths. Working in Outline View can speed the display of complex artwork, such as objects containing gradients or patterns. Outline View can also make it easier to edit objects hidden behind other filled objects.

    To display an Illustrator document in Outline View, choose View > Outline.


    You can create custom views of your document. Custom views enable you to quickly change the view mode, magnification, scroll position, and layer options.

    To create a custom view of an Illustrator document, set the view attributes you want to save. Then choose View > New View and enter a name in the New View dialog box. The custom view appears in the View menu.


    Use the Hand tool to specify the quality and speed of the display of an Illustrator document.

    To specify display quality, choose Edit > Preferences > Units & Display Performance. Drag the Hand Tool slider to the left to improve display quality when you use the Hand tool. Move it to the right to improve speed.


    You can change the resolution of raster effects to optimize Illustrator performance.

    To change the resolution of raster effects, choose Effect > Document Raster Effects Settings. In the Resolution pop up menu, do one of the following:

    • Choose Screen if you are editing files. Illustrator uses a resolution of 72 ppi for raster effects, increasing display speed.
    • Choose High if you are printing files. Illustrator uses a resolution of 300 ppi for raster effects, decreasing printing speed, but increasing print quality.

    Then, click OK.


    Use the Layers panel to organize and modify artwork. When you hide layers that contain complex artwork or high-resolution bitmap images, Illustrator redraws the screen faster.

    To hide a layer, click the eye icon to the left of the layer name. To hide all but the selected layer, Alt-click (Option-click for Mac) the eye icon.

    The Layers panel can display thumbnails for top-level layers, nested layers, groups, and objects. To reduce the number of thumbnails so Illustrator redraws the screen faster, choose Panel Options from the Layers panel menu, then reduce the number of thumbnails.

    Options Panel

    Overprint Preview provides an “ink preview” that approximates how blending, transparency, and overprinting appear in color-separated output. To enhance performance, avoid using Overprint Preview.

    To enable and disable Overprint Preview, choose View > Overprint Preview.


    Artboards represent the regions that can contain printable artwork. To optimize performance, consider deleting unused or unnecessary Artboards.

    To manage your Artboards, choose Window > Artboards. Select an Artboard you want to remove and click Delete.


    When you work with an embedded bitmap image and your system doesn't have enough RAM, Illustrator uses hard disk space as a scratch disk. It takes longer to access information on a hard disk than it does to access information in memory. Therefore, using a portion of the hard disk as virtual memory can decrease performance. If you need more memory in order to work in Illustrator, Adobe recommends installing more RAM.

    By default, Illustrator uses the system drive as its primary scratch disk. Change the Illustrator primary scratch disk setting to your fastest hard drive.

    To change the scratch disk preference, do the following:

    1. Choose Edit > Preferences > Plug-ins & Scratch Disk.

    2. Choose a hard disk from the Primary pop-up menu. If you work with large images and have more than one hard disk, choose another disk from the Secondary pop-up menu.
    3. Click OK and restart Illustrator.


    Illustrator Document Profiles contain the default patterns, gradients, graph designs, colors, color libraries, and brushes that appear in new Illustrator documents. These files also determine zoom level, window size, viewing preferences, and scroll position for new documents. Minimize the file size of new documents by removing unnecessary swatches and brushes from Illustrator new document profiles.

    For instructions on creating custom document profiles in Illustrator, see Starup Profiles: A great tool to customize your new documents.


    Templates let you create new documents that share common settings and design elements. You can minimize the file size of new documents by removing unnecessary swatches, symbols, graphic styles, and brushes from templates.

    For instructions on creating template files, see Files and Templates.


    Embedded bitmap images (for example, TIFF, BMP, or Photoshop EPS) can dramatically increase the size of an Illustrator document, causing slower performance. To improve performance, enable the Link option when you place a bitmap image. The Link option references the placed image on the hard disk.

    • Select File > Place. In the Place dialog box, choose Link.

    If a service bureau requires embedded images, then save a copy of the files. Choose Include Linked Files in the Illustrator Native Format Options or EPS Format Options dialog box.


    If a document contains linked EPS images that have high-resolution previews, Illustrator redraws the screen slower as you edit artwork. To enable Illustrator to redraw the screen more quickly, use low-resolution EPS previews. Do the following:

    1. Choose Edit > Preferences > File Handling & Clipboard.

    2. Select Use Low Resolution Proxy For Linked EPS and click OK.


    The Links Panel Options dialog box includes a Show DCS Transparency Interactions option. If this option is selected, the Links panel displays a yellow icon to identify linked DCS EPS graphics that are transparent or overlap transparent objects. Because this option forces Illustrator to regularly determine if linked EPS files interact with transparency, it can decrease performance.

    To disable the Show Transparency Interactions option, do the following:

    1. Select Windows > Links. From the Links panel menu, choose Panel Options.

    2. Clear Show DCS Transparency Interactions and click OK.


    The Navigator panel displays a thumbnail view of your current artwork for easy navigation. The processing time required to update the thumbnail each time you change the document depends on the complexity of your artwork. To improve screen redraw speed in a complex document, hide the Navigator panel. Under the Window menu, deselect Navigator.

    You can set up custom views to more efficiently zoom to particular areas of your document.


    The Anti-alias Artwork option smooths text and graphics by blending the color of an object's edge pixels with the color of adjacent pixels. However, this process can cause slow screen redraw. To disable this option, do the following:

    1. Choose Edit > Preferences > General.

    2. Clear Anti-aliased Artwork and click OK.


    The Simplify command reduces the amount of anchor points in paths and path shapes, reducing file size and increasing performance. To apply the Simplify command, select the desired path or object, then choose Object > Path > Simplify.

    For more information on the Simplify command, see Illustrator Help.


    Smart Guides allow you to create, align, edit, and transform Illustrator objects relative to other objects. If you have many objects in your artwork, Illustrator requires more time to display Smart Guides. To disable Smart Guides, from the View menu, deselect Smart Guides.

    For more information on Smart Guides, see Rulers, grids, guides, and cropmarks.


    Bristle Brush strokes are made up of several overlapping, filled transparent paths. These paths, like any other filled path in Illustrator, interact with the paint of other objects, including other Bristle Brush paths.

    Test and experiment with Bristle Brushes and paint rendition before embarking on large-scale artwork. Changing brush attributes and reapplying them renders all used brushes over again.

    When using Bristle Brushes you can reduce the complexity and file size of your document by doing the following:

    • Rasterize some Bristle Brush paths. Be sure to save a copy of the original artwork before rasterizing.

    If the artwork contains a large number (>30) of Bristle Brushes, reduce the complexity and number of the Bristle Brush paths. Select the Bristle Brush paths and choose Object > Rasterize.

    • Disable the PDF capabilities.

    By default Illustrator saves PDF data that enables Illustrator (*ai) files to be compatible with other Adobe apps. Choose File > Save or File > Save As and click Save.  In the Illustrator Options dialog box, deselect Create PDF Compatible File.


     
    Back to top