Modifica le impostazioni di sistema operativo, hardware e applicazioni per fare in modo che il computer esegua Photoshop senza problemi e a una velocità ottimale. Se Photoshop viene eseguito più lentamente del previsto nel computer, o se si verificano blocchi o ritardi durante l’utilizzo di Photoshop, prova ad adottare i consigli e le tecniche descritte nel presente documento.

Nota:

Affinché Photoshop venga eseguito in modo ottimale, il computer deve rispettare alcuni requisiti di sistema minimi. Se Photoshop viene eseguito su un hardware non supportato o con una potenza non sufficiente, ad esempio un computer con un processore grafico (GPU) incompatibile, le prestazioni potrebbero risentirne.

Consigli generali per migliorare le prestazioni

In generale, ti consigliamo di adottare un approccio globale per l’ottimizzazione delle prestazioni di Photoshop per le tue esigenze. Leggi tutti i suggerimenti contenuti in questo documento e stabilisci quali implementare in base alla tua configurazione informatica, al tipo di file utilizzati e al flusso di lavoro prescelto. Per ottenere le prestazioni migliori in Photoshop, è necessario adottare una combinazione di tecniche che varia di volta in volta in base alle circostanze.

Le prestazioni di Photoshop vengono determinate da quattro fattori principali:

Il modo più semplice per migliorare le prestazioni, senza alcun costo in denaro, consiste nell’impostare le preferenze e regolare le funzionalità di Photoshop in modo da trarre vantaggio dalle modalità di utilizzo dell’applicazione e dalla tipologia di file più utilizzati.

Il modo più drastico di aumentare le prestazioni è investire in hardware più veloce e più potente.

Impostazione delle preferenze relative alle prestazioni

Photoshop fornisce un insieme di preferenze (Preferenze > Prestazioni) che contribuisce a ottimizzare l’utilizzo delle risorse del computer, ad esempio memoria, cache, processore grafico, monitor ecc. A seconda dell’utilizzo principale di Photoshop e del tipo di documenti su cui lavori di solito, potresti avere bisogno di una combinazione di tali impostazioni.

Vi sono altre impostazioni, ad esempio Dischi memoria virtuale, disponibili in altre schede della finestra di dialogo Preferenze, che potrebbero avere un’influenza diretta sulla velocità e la stabilità del computer.

Preferenze relative alle prestazioni di Photoshop
Preferenze per le prestazioni in Photoshop

Modifica della memoria allocata a Photoshop

Puoi migliorare le prestazioni aumentando la quantità di memoria/RAM allocata a Photoshop. L'area Uso memoria della finestra di dialogo Preferenze prestazioni (Preferenze > Prestazioni) indica quanta RAM è disponibile per Photoshop e mostra l'intervallo di allocazione di memoria a Photoshop ideale per il sistema in uso.

Per impostazione predefinita, Photoshop utilizza il 70% della RAM disponibile.

  1. Puoi assegnare più o meno RAM a Photoshop modificandone il valore nella casella Consenti a PS di usare. In alternativa, regola il cursore Uso memoria.
  2. Riavvia Photoshop per rendere effettive le modifiche.

Per determinare l’allocazione di RAM adatta al sistema, modifica il valore predefinito di incrementi del 5%, monitorando le prestazioni nell’indicatore di stato dell’efficienza. 

Si consiglia di non allocare più dell’85% della memoria del computer a Photoshop. In caso contrario, le prestazioni potrebbero risultare compromesse, poiché non rimarrebbe memoria sufficiente per altre applicazioni di sistema essenziali.

Nota:

Se si verificano errori determinati da RAM o memoria insufficiente in Photoshop, aumenta la RAM allocata a questo programma. Tuttavia, se la RAM allocata a Photoshop è troppo alta (>85%), le prestazioni di altre applicazioni in uso potrebbero risentirne, rendendo instabile il sistema. 

La soluzione migliore a questo problema è l'espansione della RAM del computer. Verifica con il produttore del computer le specifiche di RAM e la compatibilità.

Regolare i livelli di cache

Nozioni di base sulla cache

Photoshop utilizza la cache delle immagini per velocizzare l’aggiornamento dei documenti ad alta risoluzione mentre lavori su di essi. Puoi specificare fino a otto livelli di dati immagine memorizzati nella cache e scegliere una delle quattro dimensioni delle porzioni di cache disponibili.

Impostando i livelli di cache su un valore più elevato, otterrai tempi di risposta più rapidi durante l’utilizzo di Photoshop, ma il caricamento delle immagini richiederà più tempo. Le dimensioni della porzione di cache determinano la quantità di dati su cui Photoshop può operare contemporaneamente. Le porzioni più grandi consentono di velocizzare operazioni complesse, quali ad esempio l’utilizzo dei filtri di contrasto, mentre modifiche di entità minore, come i tratti del pennello, risultano più rapide quando si utilizzano porzioni più piccole.

Predefiniti cache

Nelle preferenze Prestazioni, sono disponibili tre valori predefiniti per la cache. Scegli quella più adatta all’utilizzo principale di Photoshop:

  • Progettazione Web/interfaccia utente: scegli questa opzione se utilizzi Photoshop principalmente per la progettazione di siti Web, app o schermate. Questa opzione è consigliata per i documenti che presentano diversi livelli di risorse con dimensioni in pixel da basse a medie.
  • Predefinita/foto: scegli questa opzione se utilizzi Photoshop principalmente per ritoccare o modificare immagini con dimensioni medie. Ad esempio, utilizzala se di norma modifichi con Photoshop foto scattate con il cellulare o la fotocamera digitale.
  • Dimensioni in pixel molto grandi: scegli questa opzione se lavori spesso in Photoshop su documenti di dimensioni molto grandi, ad esempio panorami, pitture di sfondi ecc.

Livelli cache

Per un controllo più dettagliato, specifica i livelli di cache manualmente; il valore predefinito è 4.

  • Se utilizzi file di dimensioni relativamente contenute (circa 1 megapixel o 1.280 x 1.024 pixel) e numerosi livelli (50 o più), imposta i livelli di cache su 1 o 2. Impostando l’opzione Livelli cache su 1, puoi disattivare la cache delle immagini; in questo caso, solo l’immagine della schermata corrente viene immessa nella cache.
  • Se utilizzi file di dimensioni maggiori (ad esempio, 50 megapixel o superiori), imposta Livelli cache su un livello superiore a 4. Livelli di cache elevati consentono di velocizzare l’aggiornamento.

Nota:

Se il valore dei livelli di cache è impostato su 1, potrebbe non essere possibile ottenere risultati di alta qualità con alcune funzionalità di Photoshop.

Limitare gli stati storia

Puoi risparmiare spazio sul disco di memoria virtuale e migliorare le prestazioni limitando o riducendo il numero di stati che Photoshop può salvare nel pannello Storia. La quantità di spazio risparmiato dipende dal numero di pixel modificati durante un’operazione. Ad esempio, lo stato storia relativo a un piccolo tratto di pennello o a un’operazione non distruttiva, come la creazione o la modifica di un livello di regolazione, consuma un esiguo spazio di memoria virtuale. Al contrario, l’applicazione di un filtro a un’immagine intera richiede molto più spazio.

Photoshop può salvare fino a 1000 stati storia; il numero predefinito è 50.

Per ridurre tale numero, accedi alla finestra di dialogo delle preferenze Prestazioni. Nella sezione Cronologia e cache
imposta il numero di Stati storia su un valore inferiore.

Configurazione delle impostazioni del processore grafico (GPU)

Il modo migliore per ottimizzare l’accelerazione GPU e, di conseguenza, velocizzare gli aggiornamenti dello schermo, consiste nel mantenere aggiornato il driver della scheda video.  Per istruzioni sull'aggiornamento dei driver della scheda video

Vedi Aggiornare il driver grafico.

Per ulteriori informazioni su come Photoshop utilizza il processore grafico, le schede testate e i requisiti minimi del processore grafico e del display. 

Vedi Domande frequenti sull’uso di schede video (GPU) in Photoshop.

Preferenze GPU

Photoshop offre impostazioni dedicate per la GPU sia nella sezione Prestazioni sia in quella 3D della finestra di dialogo Preferenze.

Impostazioni nella sezione Preferenze > Prestazioni

Se nel sistema viene rilevata una scheda video appropriata, il nome e il modello vengono visualizzati in Processore grafico rilevato nell'area Impostazioni processore grafico della sezione Prestazioni.

  • Se la scheda grafica è supportata, la casella di controllo "Usa processore grafico" è abilitata e spuntata per impostazione predefinita.
  • Se la scheda grafica non è supportata, la casella di controllo è disattivata e non spuntata per impostazione predefinita.
  • Se la scheda grafica è supportata e la casella di controllo "Usa processore grafico" non è spuntata, è probabile che Photoshop abbia rilevato un arresto causato da un driver grafico difettoso o da una configurazione errata. Vedi Risoluzione dei problemi del processore grafico (GPU) di Photoshop e dei driver della scheda grafica.

Impostazioni avanzate processore grafico

Per ottimizzare le prestazioni della scheda, fai clic sul pulsante Impostazioni avanzate. 

Regolazione del Metodo disegno

  • Base: utilizza la quantità minima di memoria GPU per eseguire le funzionalità base di OpenGL. Usa questa modalità se le modalità Normale e Avanzata restituiscono prestazioni non sufficientemente uniformi. Questo può accadere quando si eseguono periodicamente altri programmi che occupano la memoria del processore grafico. Seleziona questa opzione se noti aggiornamenti della schermata di bassa qualità o prestazioni peggiori durante l’utilizzo di funzionalità con accelerazione della GPU.
  • Normale: comporta l'utilizzo di una grande quantità di memoria GPU per supportare funzioni OpenGL avanzate ed eseguire corrispondenza dei colori, mappatura dei toni e fusione scacchiera. Questo libera la CPU per l'esecuzione di altre attività.
  • Avanzate: questa modalità utilizza il processore grafico con la massima intensità. Utilizza la stessa quantità di memoria della modalità Normale, ma consente di utilizzare tecniche più avanzate per migliorare le prestazioni durante il disegno. Questa impostazione è consigliabile quando lavori con immagini in 3D o utilizzi molto le funzionalità con accelerazione della GPU. Se questa modalità non sembra funzionare in modo uniforme, prova a passare alla modalità Normale o Base.

Nota:

Le modifiche alla modalità Disegno vengono applicate solo dopo il riavvio di Photoshop.

Altre impostazioni avanzate:

  • Usa processore grafico per accelerare l'elaborazione: attiva questa opzione per migliorare l'interattività delle anteprime alterazione e alterazione marionetta.
  • Usa OpenCL: disattiva questa opzione se Galleria sfocatura, Nitidezza avanzata, Seleziona area di interesse selezionata o Dimensione immagine con mantieni particolari non funzionano come previsto.
  • Guide e tracciati anti-alias: disattiva l'opzione se le guide e i tracciati appaiono troppo pesanti o troppo ampi
  • Monitor a 30 bit: abilita l'opzione per aumentare la fedeltà del colore su un monitor che supporta 30 bit.
  • Usa accelerazione GPU nativa del sistema operativo: abilita l'opzione per consentire l'uso di macOS Metal e Windows DirectX 12 in base alle esigenze.

Nota:

L’attivazione di OpenCL potrebbe migliorare le prestazioni durante l’utilizzo delle funzioni di Photoshop seguenti:

  • Galleria sfocatura: Campo Sfoca, Sfocatura diaframma, Scostamento inclinazione, Sfocatura percorso, Sfocatura rotazione (OpenCL accelerato)
  • Nitidezza avanzata (Riduzione del rumore: OpenCL accelerato)
  • Selezione e maschera (OpenCL accelerato)

Impostazioni nella sezione Preferenze > 3D

La sezione 3D della finestra di dialogo Prestazioni contiene un cursore VRAM simile al controllo della memoria situato nella sezione Prestazioni. Utilizza il cursore per determinare il limite superiore della RAM video (VRAM) disponibile per il motore 3D di Photoshop. Il valore totale equivale a una percentuale della VRAM totale disponibile. Anche se si imposta il valore sul 100%, una parte della VRAM totale verrà comunque destinata al sistema operativo. Valori superiori possono migliorare le prestazioni 3D generali, ma potrebbero pregiudicare quelle di altre applicazioni con funzionalità GPU abilitata.

memory-usage-3D
3D: uso della memoria

Gestire i dischi di memoria virtuale

Nota:

Se non è possibile avviare Photoshop a causa di spazio insufficiente nel disco di memoria, tieni premuti i tasti Comando+Opzione (macOS) o Ctrl+Alt (Windows) all'avvio per impostare un nuovo disco di memoria virtuale.

Un disco di memoria virtuale è un’unità disco o SSD utilizzata per la memorizzazione temporanea durante l’esecuzione di Photoshop. Photoshop utilizza questo spazio per memorizzare parti dei documenti e i relativi stati del pannello Storia che non trovano spazio nella memoria RAM. I file di memoria virtuale vengono inseriti in cartelle invisibili specificate dal sistema operativo, ad eccezione dei volumi non di avvio in Windows, nella directory principale dell’unità. Quando un’unità non di avvio viene utilizzata come disco di memoria virtuale, i file temporanei vengono posizionati nella directory principale dell’unità.

Per impostazione predefinita, Photoshop usa il disco rigido su cui è installato il sistema operativo come disco primario di memoria virtuale. 

Per ulteriori informazioni sulla gestione delle preferenze del disco di memoria virtuale, le impostazioni consigliate e la risoluzione dei problemi, vedi Configurare i dischi di memoria virtuale.

Indicatore di efficienza

Quando lavori in Photoshop, controlla l’indicatore dell’efficienza per monitorare le prestazioni. Fai clic sul menu a comparsa nella parte inferiore della finestra dell’immagine e scegli Efficienza dal menu a comparsa.

Se il valore dell’indicatore è inferiore al 100%, Photoshop ha utilizzato tutta la RAM disponibile e sta utilizzando il disco di memoria virtuale, rallentando così le prestazioni. Se l’efficienza è inferiore al 90%, assegna più RAM a Photoshop in Preferenze prestazioni Oppure, aggiungi ulteriore RAM al sistema.

Indicatore di efficienza
Indicatore di efficienza

Ottimizzazione delle funzionalità di Photoshop per le prestazioni

Disattivazione di righelli e sovrapposizioni

Righelli e sovrapposizioni (come griglie, sezioni e guide sensibili) possono rallentare alcune operazioni, ad esempio la pittura, la trasformazione e il trascinamento dei livelli sull’area di lavoro.

  • Per disattivare i righelli, deseleziona Righelli nel menu Visualizza
    .
  • Per disattivare le sovrapposizioni, vai al menu Visualizza > Mostra e seleziona Nessuna o disattiva i singoli elementi.

Vedi Visualizzare o nascondere gli elementi extra non stampabili.

Rispettare i limiti di dimensioni del file

I file di grandi dimensioni causano spesso problemi a livello di prestazioni.

Photoshop supporta file di dimensioni massime pari a 300.000 x 300.000 pixel, tranne che per i file PDF, il cui limite è 30.000 x 30.000 pixel e 200 x 200 pollici, e per Camera Raw, che supporta immagini con lunghezza o altezza fino a 65.000 pixel e fino a 512 megapixel.

Capacità di dimensioni file per Photoshop:

  • File PDS: 2 GB
  • File TIFF: 4 GB
  • File PSB: 4 exabyte (4.096 petabyte o 4 milioni di terabyte)
  • File PDF: 10 GB (dimensioni massime delle pagine: 200 pollici)

Chiudere finestre di documenti non necessari

Se ricevi un messaggio di errore di esaurimento RAM o se Photoshop funziona lentamente, è possibile che siano aperte troppe immagini contemporaneamente. Se ci sono più finestre aperte, provate a chiuderne alcune.

Riduzione del numero di impostazioni predefinite

Per ridurre la quantità di spazio utilizzata da Photoshop nel disco di memoria virtuale, riduci il numero dei predefiniti che mantieni caricati. I motivi e le punte dei pennelli sono alcuni dei predefiniti più grandi. Salva i predefiniti che non devi usare in questo momento in un file di predefiniti, quindi rimuovili e caricali solo quando ne hai bisogno.

Per ulteriori informazioni sulla gestione dei predefiniti, vedi Predefiniti.

Ridurre o disattivare le miniature di anteprima dei pannelli

Ogni volta che modifichi il documento, Photoshop aggiorna tutte le miniature visibili nei pannelli Livelli e Canali. L’aggiornamento può influire sui tempi di risposta quando si utilizzano opzioni rapide di disegno, spostamento o sfioramento di livelli. Maggiore è il numero di miniature visibili, migliore sarà l’effetto.

Per ridurre o disattivare le miniature di anteprima, fai clic sul menu del pannello e seleziona Opzioni pannello. Seleziona una dimensione inferiore per la miniatura o seleziona Nessuno, quindi fai clic su OK.

Pannello Livelli

Modificare le opzioni di compatibilità dei file

Se non devi utilizzare i file PSD e PSB con versioni precedenti di Photoshop o con applicazioni che non supportano i livelli, puoi disattivare una funzione di compatibilità dei file per velocizzare il salvataggio del documento:

  1. Per i documenti PSD e PSB a 16 e a 32 bit, seleziona Disattiva compressione di file PSD e PSB in Preferenze > Gestione file.

  2. Dal menu Massimizza compatibilità per file PSD e PSB, seleziona Chiedi o Mai.

    Massimizzare la compatibilità per file PSD e PSB

Utilizzare il metodo immagine a 8 bit

Photoshop consente di effettuare numerose operazioni con le immagini a 16 e 32 bit. L’elaborazione di queste immagini richiede tuttavia una maggior quantità di memoria e spazio di memoria virtuale e tempi più lunghi rispetto alle immagini a 8 bit.

Per convertire l'immagine in formato 8 bit per canale, seleziona Immagine > Modalità > 8 bit/canale.

Vedi Profondità bit e preferenze.

Nota:

La conversione a 8 bit/canale comporta l’eliminazione di alcuni dati dall’immagine. Prima di effettuare la conversione a 8 bit/canale, salva una copia dell’immagine originale a 16 o 32 bit.

Disattivare l'anteprima dei caratteri

Per velocizzare l'elaborazione dei caratteri in Photoshop, disattiva l'elenco delle anteprime dei caratteri selezionando Tipo > Dimensione anteprima carattere > Nessuno.

Ridurre la risoluzione dell’immagine

Più alta è la risoluzione dell’immagine, maggiore è la quantità di memoria e di spazio su disco richiesta da Photoshop per visualizzare, elaborare e stampare tale immagine. A seconda dell’output finale, una risoluzione più alta non è necessariamente sinonimo di maggiore qualità dell’immagine; al contrario, potrebbe comportare un rallentamento delle prestazioni e del processo di stampa e l’utilizzo di ulteriore spazio sul disco di memoria virtuale.La risoluzione ottimale delle immagini dipende dal modo in cui vengono visualizzate o stampate. 

Per le immagini da presentare sullo schermo, è opportuno ragionare in pixel. Per ridurre le dimensioni di un’immagine, seleziona Immagine > Dimensione immagine. Nella finestra di dialogo Dimensione immagine, verifica che l’opzione Ricampiona sia selezionata. Immetti un nuovo valore di larghezza o altezza (specificando il valore di una delle due dimensioni, entrambe vengono modificate).

Ridurre la risoluzione dell’immagine

Aumentare la risoluzione delle immagini stampate oltre 360 DPI, nella maggior parte dei casi comporta vantaggi insignificanti o nulli. Se produci un elevato numero di stampe, effettua alcune prove per individuare la risoluzione ideale. Per ridurre la risoluzione di un’immagine, seleziona Immagine > Dimensione immagine. Nella finestra di dialogo Dimensione immagine, seleziona l’opzione Ricampiona. Modifica i valori di larghezza e altezza in modo tale che rispecchino le dimensioni fisiche del documento stampato. Riduci quindi il valore della risoluzione e fai clic su OK.

Se intendi aumentare, anziché ridurre, la risoluzione dell’immagine da stampare, esegui questa operazione in coda, poco prima di stampare l’immagine. Questa modalità vi consente di non dover elaborare tutte queste informazioni supplementari nei primi passaggi.

Svuotare la memoria

Per migliorare le prestazioni del sistema, puoi liberare memoria e spazio sul disco virtuale non utilizzati da Photoshop e renderli disponibili per altri programmi. Per farlo, scegli una delle seguenti opzioni:

  • Modifica > Svuota memoria > Tutto
  • Modifica > Svuota memoria > Annulla
  • Tieni premuto il tasto Opzione (macOS) o Alt (Windows) e seleziona Informazioni su Photoshop

Se altri programmi stanno cercando di allocarsi o utilizzare la memoria, liberarla in Photoshop consentirà di migliorare le prestazioni. In caso di esaurimento del volume di un disco, potrebbe tornare utile liberare spazio sul disco di memoria virtuale. Quando viene liberata una notevole quantità di memoria o spazio su disco, la successiva apertura di file Photoshop di grandi dimensioni richiede più tempo, perché Photoshop deve allocare lo spazio.

Se desideri che Photoshop utilizzi sempre una minor quantità di memoria, seleziona Modifica > Preferenze > Prestazioni (Windows) oppure Photoshop > Preferenze > Prestazioni (macOS) e sposta il dispositivo di scorrimento Uso memoria verso sinistra.

Consulta Regolare l’utilizzo della memoria.

Nota:

La registrazione delle modifiche da parte delle applicazioni di monitoraggio e gestione delle attività e delle utilità di controllo del disco può richiedere alcuni secondi. In effetti, per alcune utilità potrebbe essere necessario richiedere esplicitamente l’aggiornamento.

Svuotare la memoria degli Appunti

Il contenuto degli Appunti è spesso voluminoso se i dati vengono copiati e incollati in documenti di grandi dimensioni. Inoltre, una volta terminata l’operazione, tale contenuto non si rivela di grande utilità. Per liberare la memoria RAM utilizzata dai dati immagine negli Appunti, seleziona Modifica > Svuota memoria > Appunti.

Nota:

Non è possibile annullare l’operazione Svuota memoria.

Utilizza la Galleria filtri

La Galleria filtri consente di provare uno o più filtri su un'immagine prima di applicarne gli effetti per accelerare i tempi di tale operazione e risparmiare memoria.

Vedi Panoramica della Galleria filtri.

Trascinare elementi da un file all’altro piuttosto che copiare e incollare

Trascinare i livelli o i file è più efficace di copiarli e incollarli, poiché è possibile saltare il passaggio della copia negli Appunti, trasferendo i dati direttamente. Copiare e incollare può comportare il trasferimento di una maggiore quantità di dati, riducendo l’efficienza.

Salvataggio di file TIFF senza compressione ZIP

Per esportare più velocemente i file TIFF, non selezionare la compressione ZIP. (La compressione ZIP consente tuttavia di ridurre al minimo le dimensioni dei file TIFF.)

Non eseguire l’esportazione degli Appunti

L’opzione Esporta Appunti consente a Photoshop di rendere disponibile il contenuto degli Appunti agli altri programmi. Se copi elevate quantità di dati in Photoshop, che tuttavia non intendi copiare in altre applicazioni, risparmia tempo disattivando questa opzione.

  1. Scegli Photoshop > Preferenze > Generali (macOS) oppure Modifica > Preferenze > Generali (Windows).

  2. Deseleziona Esporta Appunti.

  3. Fai clic su OK.

Disattivazione del pannello Librerie

  1. Nel menu a comparsa Librerie, scegli Chiudi.

    Menu a comparsa delle librerie
  2. Riavvia Photoshop.

Disattivazione del generatore

  1. Scegli Modifica > Preferenze > Plug-in.

  2. Deseleziona Abilita Generatore.

  3. Fai clic su OK.

Ottimizzazione della configurazione hardware per Photoshop

Se desideri modificare la configurazione hardware corrente (o se stai acquistando un nuovo sistema), utilizza le informazioni riportate di seguito per ottimizzarla per Photoshop.

Utilizzare un processore veloce

La velocità di elaborazione di Photoshop è limitata dalla velocità della CPU del computer.

Sebbene tutte le funzionalità di Photoshop vengano eseguite più velocemente nei sistemi con più processori core, per l’esecuzione di alcune di esse una potenza di elaborazione aggiuntiva risulta particolarmente vantaggiosa. Tuttavia, quando si utilizzano più processori core, esiste un punto oltre il quale all’aumento del numero dei core non corrisponde un uguale aumento delle prestazioni. Di conseguenza, l’elaborazione con Photoshop in un computer che utilizza 16 processori core non sarà quattro volte più veloce rispetto a un computer che ne utilizza quattro. La maggior parte degli utenti ritiene che l'aumento delle prestazioni ottenuto con un numero di core superiori a sei non giustifichi la spesa.

Nota:

Se usi Photoshop in un ambiente virtuale, l'utilizzo della GPU da parte di Photoshop può causare problemi di prestazioni. Le macchine virtuali non possono accedere alla GPU.

Aggiungere RAM

Photoshop utilizza la memoria ad accesso casuale (RAM) per l’elaborazione delle immagini. Se la memoria disponibile è insufficiente, per l’elaborazione delle informazioni viene utilizzato lo spazio sul disco rigido (detto anche disco di memoria virtuale). Poiché l’accesso alle informazioni nella memoria risulta più rapido di quello alle informazioni memorizzate sul disco rigido, Photoshop è più veloce quando è in grado di elaborare gran parte o la totalità delle informazioni delle immagini nella memoria RAM.

Per la versione più recente di Photoshop, si consiglia di utilizzare almeno 8 GB di RAM.

Per istruzioni su come specificare la quantità di RAM da assegnare a Photoshop, consulta Regolare l’utilizzo della memoria.

Utilizzo di una scheda grafica dedicata

Una scheda grafica separata e dedicata utilizza memoria propria (VRAM), ha una potenza di elaborazione maggiore e non consuma RAM.

I notebook ultraleggeri e i desktop di fascia bassa spesso utilizzano una scheda grafica integrata che utilizza meno energia, per risparmiare la batteria e condividere la memoria con la CPU.

Utilizzare un disco rigido capiente e veloce

Photoshop esegue la lettura e la scrittura delle informazioni immagine su disco quando la RAM disponibile nel sistema è insufficiente per contenerle tutte. L’indicatore di efficienza può essere utile per valutare se, utilizzando un disco rigido o un disco SSD, le prestazioni ne trarrebbero beneficio. Se l’indicatore di efficienza è generalmente superiore al 95%, ha poco senso investire denaro in un disco di memoria virtuale più veloce.

Per migliorare le prestazioni di Photoshop, utilizza un disco con un’elevata velocità di trasferimento dati, ad esempio un disco rigido interno o un disco esterno collegato direttamente al computer.

Nota:

I server di rete (disco rigido accessibile tramite una rete) offrono velocità di trasferimento dati più lente e sono sconsigliati per l'utilizzo con Photoshop.

Utilizza un disco a stato solido

Per ottenere il massimo dall’utilizzo di un disco SSD, utilizzalo come disco di memoria virtuale. Questa modalità di utilizzo garantisce miglioramenti significativi nelle prestazioni se disponi di immagini che non rientrano interamente nella RAM. Ad esempio, lo scambio di porzioni tra RAM e SSD è molto più veloce dello scambio tra RAM e disco rigido.

Se la quantità di spazio libero sul disco SSD non è sufficiente per un eventuale aumento di volume nel file di memoria virtuale, aggiungi un secondo o terzo disco rigido (dopo il disco SSD). Assicurati che i dischi vengano selezionati come dischi di memoria virtuale nelle preferenze delle Prestazioni.

Ancor più che con i dischi rigidi, le prestazioni dei dischi SSD variano notevolmente a seconda del modello. Se utilizzi un’unità meno recente e più lenta, il miglioramento potrebbe essere minimo rispetto a un disco rigido.

Nota:

Aggiungere RAM per migliorare le prestazioni è in genere più conveniente che acquistare un disco SSD.

Se l’indicatore di efficienza è già alto, l’utilizzo di un disco SSD non migliora le prestazioni. Più basso è l’indicatore di efficienza, maggiore sarà il miglioramento offerto da un disco SSD.

Anche gli array RAID 0 veloci sono ottimi come dischi di memoria virtuale, specie se l'array è utilizzato esclusivamente per il disco di memoria virtuale.

Riduzione della risoluzione del monitor

Ottimizzazione del sistema operativo per Photoshop

Utilizza le seguenti informazioni per installare e usare efficacemente il sistema operativo con Photoshop.

Chiusura di applicazioni ed elementi di avvio non necessari

Eventuali altre applicazioni ed elementi di avvio aperti possono ridurre la quantità di memoria disponibile per Photoshop. Per liberare memoria aggiuntiva, chiudi tutte le applicazioni, gli elementi di avvio e le estensioni non necessari.

Consulta Rendere disponibile una maggiore quantità di memoria per Photoshop.

Pulizia del disco (Windows)

Di tanto in tanto, esegui la pulizia del disco per rimuovere i file temporanei e altri file non in uso.

Consulta Pulizia disco in Windows 10.

Deframmentazione del disco rigido

Photoshop impiega più tempo per leggere o scrivere un file frammentato rispetto a un file salvato in una posizione contigua.

Consulta Deframmentare il tuo PC Windows 10.

Nota:

I dischi a stato solido non richiedono la deframmentazione, in quanto le prestazioni non subiscono un degrado significativo con i livelli di frammentazione standard.

La frammentazione è raramente un problema in macOS, salvo se lavori quasi sempre con l'unità disco quasi piena.

Attivare gli aggiornamenti automatici del sistema operativo

Gli aggiornamenti di Windows o macOS consentono di migliorare le prestazioni e la compatibilità con altre applicazioni.

Windows:

macOS:

Impostazione delle opzioni di risparmio energia

Nei computer con due schede grafiche, accertati che a Photoshop sia stata assegnata la scheda grafica ad alte prestazioni e non quella con impostazioni di risparmio energetico integrata.

Consulta Configurazione di computer con più schede grafiche.

Nota:

La modifica di queste impostazioni consumerà più rapidamente la batteria.