Varmista Photoshopin vakaa toiminta parhaalla mahdollisella nopeudella säätämällä käyttöjärjestelmää, laitteistoa ja sovellusasetuksia. Jos Photoshop toimii tietokoneessa odotettua hitaammin tai jos järjestelmä jumiutuu, laahaa tai hidastelee Photoshopin käytön aikana, kokeile tässä ohjeessa kerrottuja vinkkejä ja tekniikoita.

Huomautus:

Jotta Photoshop toimisi parhaalla mahdollisella tavalla, tietokoneen tulee täyttää tietyt järjestelmän vähimmäisvaatimukset. Jos Photoshopia ei käytetä riittävän tehokkaassa laitteistossa tai jos sitä käytetään ei-tuetussa laitteistossa – esimerkiksi tietokoneessa, jonka grafiikkasuoritin (GPU) ei ole yhteensopiva – suorituskyvyssä saattaa esiintyä ongelmia. 

Yleiset ohjeet suorituskyvyn parantamiseksi

Yleensä sinun kannattaa lähestyä Photoshopin omien tarpeidesi mukaista optimointia kokonaisvaltaisesti. Valitse tässä artikkelissa kerrotuista ehdotuksista ne, jotka sopivat parhaiten omaan käyttöympäristöösi, käyttämiisi tiedostoihin ja käyttötapaasi. Käyttöympäristöt vaihtelevat, ja Photoshopin parhaan suorituskyvyn saavuttaminen edellyttää eri menetelmien yhdistelemistä.

Suorituskykyyn voi vaikuttaa Photoshopissa neljällä päätavalla:

Helpoin tapa parantaa suorituskykyä ilman kustannuksia on määrittää Photoshopin suorituskyvyn oletusarvot ja hienosäätää sen toiminnot hyödyntämään työskentelytapaasi ja yleensä käyttämiäsi tiedostotyyppejä.

Tehokkain tapa lisätä suorituskykyä on hankkia nopeampia ja tehokkaampia laitteita.

Suorituskyvyn asetusten määrittäminen

Photoshopissa on asetuksia (Asetukset > Suorituskyky), joiden avulla voit optimoida tietokoneen resurssit, esimerkiksi muistin, välimuistin, grafiikkasuorittimen, näytöt jne. Näiden asetusten eri yhdistelmät vaihtelevat sen mukaan, miten pääasiassa käytät Photoshopia ja millaisia dokumentteja yleensä työstät. Lisäasetukset, esimerkiksi Työlevyt, joita voi määrittää Asetukset-valintaikkunan muilla välilehdillä, saattavat myös suoraan vaikuttaa tietokoneen suoritusnopeuteen ja vakauteen.

Photoshopin suorituskyvyn oletusarvot
Suorituskyvyn asetukset Photoshopissa

Säädä Photoshopille varattua muistia

Suorituskykyä voi parantaa lisäämällä Photoshopille varattua muistia tai RAM-muistia. Suorituskyky -asetusten Muistin käyttö -osiosta (Asetukset > Suorituskyky) näkee, kuinka paljon RAM-muistia on Photoshopin käytettävissä. Se näyttää myös käyttöjärjestelmääsi sopivat arvot muistin varaamiseen Photoshopille. Photoshop käyttää oletusarvoisesti 70 % käytettävissä olevasta RAM-muistista.

  1. Voit varata Photoshopille enemmän RAM-muistia muuttamalla Anna Photoshopin käyttää -numeroarvoa. Vaihtoehtoisesti voit säätää Muistin käyttö -liukusäädintä.
  2. Ota muutokset käyttöön käynnistämällä Photoshop uudelleen.

Kun haluat löytää parhaan mahdollisen RAM-muistin varauksen omassa järjestelmässäsi, muuta sitä 5 prosentin välein ja tarkkaile Tehokkuuden ilmaisinta. Lisätietoja kohdassa Tarkkaile tehokkuusilmaisinta.

Photoshopille ei kannata varata enempää kuin 85 % tietokoneen muistista. Jos varaat tätä enemmän muistia, se saattaa vaikuttaa suorituskykyyn niin, että järjestelmän muille oleellisille sovelluksille ei jää muistia.

Huomautus:

Jos kohtaat ”muisti ei riitä” -virheitä Photoshopissa, kasvata Photoshopille varatun RAM-muistin määrää. Jos Photoshopille on varattu liikaa muistia (>85 %), se saattaa vaikuttaa muiden käynnissä olevien sovellusten suorituskykyyn heikentäen järjestelmän vakautta. 

Paras ratkaisu ongelmaan on lisätä RAM-muistia tietokoneeseen.

Välimuistitasojen säätäminen

Välimuistin perusteet

Photoshop käyttää kuvavälimuistia nopeuttaakseen suuriresoluutioisten dokumenttien päivittämistä samalla, kun niitä työstetään. Voit määrittää jopa kahdeksan tasoa välimuistiin tallennetuille kuvatiedoille ja valita neljästä eri välimuistiruudun koosta.

Välimuistitason kasvattaminen parantaa Photoshopin vasteaikaa työskentelyn aikana, vaikka kuvan lataaminen voikin kestää pidempään. Välimuistiruudun koko määrittää tietomäärän, jota Photoshop käsittelee kerrallaan. Suuremmat ruutukoot nopeuttavat monimutkaisia toimintoja, kuten terävöittämissuotimia. Pienemmät muutokset, kuten siveltimenvedot, toimivat paremmin pienemmillä ruutuko’oilla.

Välimuistin esimääritykset

Suorituskyvyn asetuksissa on saatavilla kolme välimuistin esimääritystä. Valitse se, joka sopii pääasialliseen Photoshopin käyttötarkoitukseesi:

  • Verkko- tai käyttöliittymäsuunnittelu: Valitse tämä vaihtoehto, jos käytät Photoshopia pääasiassa verkko-, sovellus- tai näytön suunnitteluun. Tämä vaihtoehto sopii dokumentteihin, joissa on useassa tasossa kohteita, joiden pikselikoko on pieni tai keskikokoinen.
  • Oletus/Valokuvat: Valitse tämä vaihtoehto, jos käytät Photoshopia pääasiassa keskikokoisten kuvien retusoimiseen tai muokkaamiseen. Käytä tätä vaihtoehtoa, jos esimerkiksi yleensä muokkaat Photoshopissa valokuvia, jotka ovat peräisin mobiililaitteestasi tai digikamerasta.
  • Erittäin suuret pikselimitat: Valitse tämä vaihtoehto, jos työstät Photoshopissa enimmäkseen suurikokoisia dokumentteja, esimerkiksi panoraamoja, mattapintaisia maalauksia jne.

Välimuistin tasot

Voit hienosäätää välimuistin tasoja manuaalisesti; oletusarvo on 4.

  • Jos käsittelet suhteellisen pieniä, noin yhden megapikselin tai 1 280 × 1 024 pikselin tiedostoja ja useita (50 tai enemmän) tasoja, aseta välimuistin tasojen määräksi yksi tai kaksi. Jos välimuistin tasojen arvoksi asetetaan yksi, kuvavälimuisti poistetaan käytöstä. Ainoastaan nykyinen näytön kuva viedään välimuistiin.
  • Jos käytössä on tiedostoja, joiden pikselimitat ovat suuremmat, esim. 50 megapikseliä tai enemmän, aseta välimuistien tasojen määräksi yli neljä. Suuremmat välimuistitasot nopeuttavat uudelleenpiirtämistä.

Huomautus:

Et ehkä saa korkealaatuisia tuloksia joillakin Photoshopin ominaisuuksilla, jos välimuistitaso on 1.

Historiatilojen rajoittaminen

Voit säästää työlevytilaa ja parantaa suorituskykyä rajoittamalla tai vähentämällä Photoshopin Historiapaneeliin tallentamien tilojen määrää. Säästettävän tilan määrä vaihtelee sen mukaan, kuinka monta pikseliä toiminto muuttaa. Esimerkiksi historiatila, joka vastaa pientä siveltimen vetoa tai ei-tuhoavaa toimintoa, kuten säätötason luomista tai muokkausta, kuluttaa vähän tilaa. Suotimen käyttö koko kuvaan taas puolestaan käyttää paljon enemmän tilaa.

Photoshop voi tallentaa jopa 1 000 historiatilaa. Oletusarvo on 20. Pienennä tätä arvoa siirtymällä Suorituskyvyn oletusasetukset -valintaikkunaan ja valitsemalla Historia ja välimuisti > Historiatilat. Vedä arvoa tarvittaessa pienemmäksi Historiatilat-ponnahdusikkunassa.

Grafiikkasuorittimen asetusten määrittäminen

Paras tapa optimoida grafiikkasuodattimen kiihdytys, joka nopeuttaa näytön uudelleenpiirtoja, on pitää näyttösovittimen ohjain ajan tasalla. Lisätietoja grafiikkasuorittimen kiihdytyksestä ja näyttösovittimen ohjainten päivittämisohjeet ovat Photoshopin grafiikkasuorittimen ja näyttökortin usein kysytyissä kysymyksissä.

OpenCL:n, tekniikan, jolla sovellukset voivat käyttää grafiikkasuoritinta, ottaminen käyttöön todennäköisesti parantaa suorituskykyä, jos käytät näitä Photoshopin toimintoja:

  • Videopanoraama
  • Sumennusgalleria (Iiriksen sumennus, Sumennuskenttä ja Tilt-Shift-sumennus)

Ota OpenCL käyttöön suorituskyvyn oletusarvojen paneelissa valitsemalla Lisäasetukset ja valitsemalla käytä OpenCL:ää.

Grafiikkasuorittimen asetukset

Erillisen grafiikkasuorittimen asetukset ovat Photoshopissa Asetukset-valintaikkunan Suorituskyky- ja 3D-osioissa.

Asetukset > Suorituskyky

Jos järjestelmässäsi on sopiva näytönohjain, se näkyy Suorituskyky-osion Grafiikkasuorittimen asetukset -alueella.

  • Jos haluat ottaa GPU-grafiikkakiihdytyksen käyttöön, varmista, että Käytä OpenGL-piirtoa -vaihtoehto on valittuna.
  • Jos haluat hienosäätää ohjaimen suorituskykyä, napsauta Lisäasetukset-painiketta ja valitse Perus, Normaali tai Edistynyt tarpeidesi mukaan.
    • Perus: Käyttää vähiten grafiikkasuorittimen muistia OpenGL-perustoimintoihin, kun grafiikkasuoritin jaetaan muiden sovellusten kanssa tai kun vaste on hidas. Valitse tämä vaihtoehto, jos käynnissä on muita ohjelmia, jotka käyttävät myös grafiikkasuoritinta tai jos näyttö päivittyy huonosti tai hitaammin käytettäessä GPU-kiihdytettyjä toimintoja.
    • Normaali: Tämä on oletusasetus. Tämä asetus käyttää suuren määrän grafiikkasuorittimen muistia OpenGL-lisätoimintojen tukemiseen. Valitse tämä vain, jos käytät GPU-kiihdytettyjä toimintoja säännöllisesti Photoshopissa.
    • Edistynyt: Käyttää saman määrän muistia kuin Normaali-tila, mutta käyttää lisätoimintoja piirtotoimintojen tehostamiseksi. Tämä asetus on paras, kun käytetään 3D-toimintoja tai kun käytetään pääasiassa GPU-kiihdytettyjä toimintoja.

Huomautus: tilan muutokset tulevat voimaan Photoshopin uudelleen käynnistämisen jälkeen.

Asetukset > 3D

Asetukset-valintaikkunan 3D-osio sisältää VRAM-liukusäätimen, joka on samanlainen kuin muistin säädin, joka sijaitsee Suorituskyky-osiossa. Määritä liukusäätimen avulla Photoshop 3D -ohjelman käytettävissä oleva VRAM-muistin yläraja. Kokonaisarvo on prosenttiosuus käytettävissä olevasta VRAM-muistin kokonaismäärästä. Jos luku on asetettu 100 %:iin, VRAM-muistin kokonaismäärästä on silti varattu osuus käyttöjärjestelmää varten. Korkeammat arvot auttavat parantamaan yleistä 3D-suorituskykyä, mutta ne saattavat kilpailla resursseista muiden grafiikkasuoritinta käyttävien sovellusten kanssa.

memory-usage-3D
3D: muistin käyttö

Työlevyjen hallinta

Työlevy voi olla mikä tahansa ulkoinen tai sisäinen asema tai osio, jossa on vapaata muistitilaa. Oletusarvon mukaan Photoshop käyttää ensisijaisena työlevynään sitä levyasemaa, johon käyttöjärjestelmä on asennettu. Työlevyjen asetuksia voi säätää kohdassa Asetukset > Työlevyt.

  1. Valitse Muokkaa > Asetukset > Työlevyt (Windows) tai Photoshop > Asetukset > Työlevyt (Mac OS).
  2. Ota työlevy käyttöön tai poista se käytöstä valitsemalla Aktiivinen-valintaruutu tai poistamalla sen valinta. Muuta työlevyjen järjestystä napsauttamalla nuolinäppäimiä.
  3. Valitse OK.
  4. Ota muutokset käyttöön käynnistämällä Photoshop uudelleen.

Suosituksia työlevyn asetusten määrittämiseen

  • Paras mahdollinen tulos saavutetaan, kun työlevyt kytketään yhteensopivaan porttiin, jolla kaikkien saatavilla olevien porttien kaistanleveysraja on korkein. Kaistanleveysrajat eri porteille ovat seuraavat:
    Thunderbolt = 10 Gt/s
    eSATA = 600 Mt/s
    PCIe = 500 Mt/s
    USB3 = 400 Mt/s
    USB2 = 35 Mt/s
  • Paranna suorituskykyä määrittämällä työlevy eheytettyyn kiintolevyyn, jossa on paljon vapaata tilaa ja nopea luku/kirjoitus-nopeus. Jos kiintolevyasemia on useampia, voit määrittää useita työlevyjä. Photoshop tukee enintään 64 eksatavua työlevytilaa enintään neljällä levyllä. (Eksatavu vastaa miljardia gigatavua.)
  • Jos käynnistyslevysi on kiintolevy eikä SSD-levy, kokeile käyttää eri kiintolevyä ensisijaisena työlevynä. SSD-levy sen sijaan toimii hyvin sekä ensisijaisena käynnistyslevynä että työlevynä. SSD-levyn käyttäminen itse asiassa on todennäköisesti parempi kuin erillisen kiintolevyn käyttäminen ensisijaisena työlevynä.
  • Työlevyjen tulisi sijaita eri levyasemassa kuin muokattavat suuret tiedostot.
  • Työlevyt on suositeltavaa määrittää eri levyasemaan kuin siihen, jota käytetään näennäismuistina.
  • RAID-levyasemat ja levyasemaklusterit ovat hyviä ratkaisuja työlevyasemiksi.
  • Eheytä säännöllisesti asemat, joissa työlevyt sijaitsevat.

Huomautus:

Jos Photoshop ei käynnisty työlevyn täyttymisen vuoksi, ota käyttöön uusi työlevy pitämällä käynnistyksessä Komento- ja Opt-näppäimiä (Mac) tai Ctrl- ja Alt-näppäimiä (Windows) painettuna.

Palautus- ja taustatallennusasetukset

Asetus Suorituskyky > Tiedostojen käsittely > Tallenna automaattisesti palautustiedot n minuutin välein saattaa myös vaikuttaa suorituskykyyn. Tallenna taustalla -asetus on oletusarvoisesti käytössä. Kun se on käytössä, Photoshop antaa jatkaa työskentelyä samalla, kun Tallenna- ja Tallenna nimellä -komennot suoritetaan, eikä sinun tarvitsee odottaa niiden valmistumista.Tallenna automaattisesti palautustiedot seuraavin välein -asetus on käytössä vain, jos Taustatallennus-toiminto on käytössä. Kun se on käytössä, palautustiedot tallennetaan jokaiselle avoimelle tiedostolle määrätyin välein. (Palautustiedot tallennetaan vikasietoisena varmuuskopiona. Alkuperäistä tiedostoa ei muokata.)

Tavallisesti taustatallennustoimenpiteet eivät vaikuta huomattavasti Photoshopin normaalien toimintojen suorituskykyyn tai reagointiin. Jos kuitenkin muokkaat tiedostoa, joka on paljon suurempi kuin käytettävissä oleva RAM-muisti, tallennustoiminto voi vaikuttaa reagointiin tai suorituskykyyn, kunnes tallennus on valmis.

Jos Photoshop vaikuttaa hidastuvan ajoittain, voit tarkistaa, vaikuttaako taustatallennus suorituskykyyn. Valitse Tallennuksen tila kuvaikkunan vasemman alakulman tilaponnahdusvalikosta.

Jos havaitset suorituskykyongelmia, kun Tallennuksen tila -palkki liikkuu, valitse Oletusarvot > Tiedoston käsittely ja pienennä Tallenna automaattisesti palautustiedot -asetuksen tiheyttä. Vaihtoehtoisesti voit poistaa käytöstä tämän asetuksen.

Photoshopin hienosäätö

Alemman arvon määrittäminen palautusvälille antaa paremman suojauksen kaatumista vastaan. Useimmissa tapauksissa palautustietojen tallennus ei vaikuta Photoshopin suorituskykyyn tai reagointiin. Suorituskyvyn hidastuminen on todennäköisempää, jos muokkaamasi tiedosto on suurempi kuin saatavilla olevan muistin määrä.

Palautustiedot tallennetaan samaan sijaintiin kuin Photoshopin työtiedostot. Jos pidät säännöllisesti useita suuria tiedostoja auki työnteon aikana, tilan määrä voi olla huomattava. Jos saat levytilan loppumisesta varoittavia virheilmoituksia muiden komentojen kuin tallennuskomentojen aikana, lisää työlevytilaa. Vaihtoehtoisesti voit poistaa käytöstä taustatietojen automaattisen tallennuksen asetuksen.

Tehokkuuden ilmaisin

Tarkkaile suorituskykyä Photoshopin käytön aikana katselemalla Tehokkuusilmaisinta.Napsauta dokumentti-ikkunan alareunassa ponnahdusvalikkoa ja valitse Tehokkuus.

Jos ilmaisimen arvo on alle 100 %, Photoshop on käyttänyt kaiken saatavilla olevan muistin ja käyttää työlevyä, mikä hidastaa suorituskykyä. Jos tehokkuus on alle 90 %, varaa Photoshopiin lisää muistia suorituskyvyn oletusarvoissa. Tai voit lisätä RAM-muistia järjestelmääsi.

Tehokkuusilmaisin
Tehokkuuden ilmaisin

Photoshopin toimintojen hienosäätö suorituskyvyn optimoimiseksi

Työskentele tiedostokoon rajoitusten mukaisesti

Erittäin suuret tiedostot ovat usein suorituskykyongelmien aiheuttajia. Photoshopin suurin tuettu tiedostokoko on 300 000 x 300 000 pikseliä lukuun ottamatta PDF-tiedostoja, joiden koko voi olla enintään 30 000 x 30 000 pikseliä ja 200 x 200 tuumaa.

Photoshopin tiedostokokokapasiteetti:

  • PSD-tiedostot: 2 Gt
  • TIFF-tiedostot: 4 Gt
  • PSB-tiedostot: 4 eksatavua (4 096 petatavua eli 4 miljoonaa teratavua)
  • PDF-tiedostot: 10 Gt (sivujen osalta enimmäiskoko on 200 tuumaa)

Sulje tarpeettomat dokumentti-ikkunat

Jos saat muisti on loppunut -virheilmoituksia tai jos Photoshop toimii hitaasti, syynä voi olla liian monta avoinna olevaa kuvaa. Jos sinulla on useita avoinna olevia ikkunoita, kokeile sulkea osa niistä.

Vähennä kuvioiden ja siveltimien kärkien määrää esimäärityksissä

Jos sinun on pienennettävä Photoshopin käyttämän työlevyn tilan määrää, voit minimoida esimäärityksissä käyttämiesi kuvioiden ja sivellinkärkien määrän. Tallenna esimääritykset, joita et tarvitse heti tiedoston esimääritysten määrittämiseksi. Vaihtoehtoisesti voit poistaa ne, jos ne ladattiin esimääritystiedostosta.

Huomautus:

Lisätietoja esimäärityskuvioiden hallinnasta ja siveltimen kärjistä on kohdassa Esimääritysten hallinnan käyttäminen.

Pienennä Esikatselu-paneelin miniatyyrikuvat tai poista ne käytöstä

Joka kerta, kun muutat dokumenttia, Photoshop päivittää kaikki miniatyyrikuvat, jotka näkyvät Tasot- ja Kanavat-paneeleissa. Tämä päivitys voi vaikuttaa ohjelman reagointinopeuteen maalattaessa, siirrettäessä tai työnnettäessä tasoja. Mitä enemmän miniatyyrikuvia näkyy, sitä suurempi tämä vaikutus on.

Pienennä nämä miniatyyrikuvat tai poista ne käytöstä napsauttamalla Paneeli-valikkoa ja valitsemalla Paletin asetukset. Valitse pienempi miniatyyrikuvan koko tai valitse Ei mitään ja valitse OK.

Tasot-välilehti

Muuta tiedoston yhteensopivuusasetuksia

Jos sinun ei tarvitse käsitellä PSD- ja PSB-tiedostojasi Photoshopin vanhemmissa versioissa tai sovelluksissa, jotka eivät tue tasoja, voit poistaa tiedostojen yhteensopivuusominaisuuden nopeuttaaksesi tiedostojen tallennusta:

  1. Valitse Oletusarvot > Tiedoston käsittely -kohdasta 16- ja 32-bittisten PSD- ja PSB-dokumenttien tapauksessa Poista PSD- ja PSB-tiedostojen pakkaus käytöstä.

  2. Valitse Maksimoi PSD- ja PSB-yhteensopivuus -valikosta Kysy tai Ei koskaan.

    Maksimoi PSD- ja PSB-yhteensopivuus

Ota käyttöön 8-bittisten kuvien tila

Photoshop voi suorittaa useita toimintoja 16- ja 32-bittisille kuville. Nämä kuvat vaativat kuitenkin enemmän muistia, työtilaa ja käsittelyaikaa kuin 8-bittiset kuvat.

Jos haluat muuttaa kuvasi 8-bittiseksi kanavaa kohti, valitse Kuva > Tila > 8 bittiä/kanava. Katso lisätietoja Photoshopin ohjeen kohdasta Bittisyvyys.

Huomautus:

Muuntaminen 8-bittiseksi kanavaa kohti poistaa kuvasta tietoja. Tallenna kopio alkuperäisestä 16- tai 32-bittisestä kuvasta ennen kuin muunnat sen 8-bittiseksi kanavaa kohti.

Ota kirjasinten WYSIWYG-esikatselu pois käytöstä

Nopeuta fontin käsittelyä Photoshopissa poistamalla WYSIWYG- fontin esikatseluluettelon käytöstä valitsemalla Tyyppi > Kirjasinten esikatselun koko > Ei mitään.

Pienennä kuvan resoluutiota

Mitä suurempi erotuskyky on, sitä enemmän muistia ja levytilaa Photoshop tarvitsee kuvan näyttämiseen, käsittelemiseen ja tulostamiseen. Lopullisen tulosteen mukaan suurempi erotuskyky ei välttämättä tarjoa parempaa kuvan laatua, mutta se voi hidastaa suorituskykyä, käyttää enemmän työlevytilaa ja hidastaa tulostamista.Kuvien ihanteellinen erotuskyky määräytyy siitä, miten kuvat näytetään tai tulostetaan. 

Näytössä esitettävien kuvien osalta kannattaa ajatella pikselimittasuhteita. Esimerkiksi monet verkkokuvat ovat leveydeltään enintään 725 pikseliä. Kuvan mittoja voidaan pienentää valitsemalla Kuva > Kuvan koko. Varmista Kuvan koko -valintaikkunassa, että Interpoloi-asetus. Anna uusi mittojen Leveys- tai Korkeus-arvo (arvon antaminen yhteen muuttaa kumpaakin).

Pienennä kuvan resoluutiota

Jos kyseessä on tulostettava kuva, resoluution lisääminen noin 360 DPI:n yli saa aikaan enintään minimaalisia hyötyjä. Jos tulostat useita tulosteita, kokeile eri resoluutioita, jotta löydät sinua miellyttävimmän tuloksen antavan resoluution. Kuvan resoluutiota voidaan pienentää valitsemalla Kuva > Kuvan koko. Valitse Kuvan koko -valintaikkunassa Interpoloi. Muuta Leveys- ja Korkeus-arvoja vastaamaan tulosteen fyysistä kokoa. Pienennä sitten resoluutioarvoa ja valitse OK.

Jos aiot lisätä tulostusta varten kuvan resoluutiota etkä pienentää sitä, suorita tämä resoluution lisäys yhtenä viimeisistä vaiheista ennen kuvan tulostamista. Näin toimimalla sinun ei tarvitse käsitellä kaikkea ylimääräistä tietoa aiemmissa vaiheissa.

Tyhjennä muisti

Voit parantaa järjestelmän suorituskykyä vapauttamalla käyttämätöntä muistia ja työlevytilaa Photoshopista muiden ohjelmien käyttöön. Tee tämä suorittamalla jokin näistä vaihtoehdoista:

  • Muokkaa > Tyhjennä > Kaikki
  • Muokkaa > Tyhjennä > Kumoa
  • Pidä Optio- (Mac OS) tai Alt-näppäintä (Windows) painettuna ja valitse Tietoja Photoshop CC:stä.

Jos muut ohjelmat yrittävät varata tai käyttää muistia, muistin vapauttaminen Photoshopissa parantaa suorituskykyä. Työlevytilan vapauttaminen auttaa, jos levytila on vähissä. Jos vapautat merkittävästi muistia tai levytilaa, suuren Photoshop-tiedoston avaaminen on hitaampaa seuraavalla kerralla, koska Photoshop varaa tilaa.

Jos haluat Photoshopin aina käyttävän vähemmän muistia, valitse Muokkaa > Oletusarvot > Suorituskyky (Windows) tai Photoshop > Oletusarvot > Suorituskyky (Mac OS) ja työnnä Muistin käyttö -liukusäädintä vasemmalle. Katso Muistin käytön säätäminen.

Huomautus:

Toimintojen valvontatoiminnoilla, tehtävien hallintatoiminnoilla ja levyapuohjelmilla muutoksen rekisteröinti voi kestää muutaman sekunnin. Itse asiassa joissakin apuohjelmissa päivitystä on erityisesti pyydettävä.

Tyhjennä leikepöytä

Leikepöydällä on usein paljon sisältöä, jos olet kopioinut ja liittänyt tietoja suurissa asiakirjoissa. Lisäksi tuosta sisällöstä ei ole paljon hyötyä, kun olet lopettanut liittämisen. Vapauta leikepöydällä olevan kuvadatan käyttämää muistia valitsemalla Muokkaa > Tyhjennä > Leikepöytä.

Huomautus:

Tyhjennä-komentoa ei voi kumota.

Käytä suodinvalikoimaa

Suodinvalikoima mahdollistaa yhden tai useamman suotimen testaamisen kuvaan ennen kuin tehosteet otetaan käyttöön, mikä voi säästää huomattavasti aikaa ja muistia. Lisätietoja on kohdassa Suodinvalikoiman yleiskuvaus.

Vedä tiedostojen välillä kopioimisen ja liittämisen asemesta

Tasojen tai tiedostojen vetäminen on paljon tehokkaampaa kuin niiden kopiointi ja liittäminen. Vetäminen ohittaa leikepöydän ja siirtää tiedot suoraan. Kopiointiin ja liittämiseen voi liittyä enemmän tiedonsiirtoa ja se on paljon tehottomampaa.

Käytä tasoja harkitusti

Tasot ovat Photoshop-työskentelyssä keskeisessä asemassa, mutta ne kasvattavat tiedostokokoa ja uudelleen piirtämiseen kuluvaa aikaa. Photoshop koostaa kunkin tason uudelleen jokaisen tiedostoon tehdyn muutokset jälkeen. Kun olet tehnyt muutokset tasoihin, pienennä tiedoston kokoa yhdistämällä ne. Valitse tasot Tasot-osiosta, napsauta niitä kakkospainikkeella (Windows) tai Ctrl-osoita (Mac OS) ja valitse Yhdistä tasot. Yhdistä kaikki tiedoston tasot valitsemalla Taso > Yhdistä kaikki tasot. Muista myös poistaa tiedostosta kaikki tyhjät tasot.

Huomautus:

Photoshop ei anna erottaa tasoja niiden yhdistämisen jälkeen. Voit valita Muokkaa > Kumoa tai palata yhdistämättömään tilaan Historia-paneelista.

Jos jotkin tasot ovat käyttämättöminä pitkiä aikoja, kannattaa harkita tasojen tai tasoryhmien muuntamista älykkäiksi objekteiksi. Näin säästyy levytilaa ja suorituskyky paranee. Valitse tasot tai tasoryhmät Tasot-osiosta, napsauta niitä kakkospainikkeella (Windows) tai Ctrl-osoita niitä (Mac OS) ja valitse Muunna älykkääksi objektiksi (Smart Object). Katso Älykkäiden objektien käyttö.

Tallenna TIFF-tiedostot ilman tasoja

Photoshop voi tallentaa tasot TIFF-tiedostoihin. Tasoja sisältävät TIFF-tiedostot ovat suurempia kuin yhdistetyt TIFF-tiedostot. Niiden käsittely ja tulostaminen vaatii enemmän resursseja. Jos työstät tasoista koostuvaa TIFF-tiedostoa, tallenna alkuperäinen tasoja sisältävä tiedosto Adobe Photoshop (.psd) -tiedostoksi. Kun olet valmis tallentamaan tiedoston TIFF-muotoon, valitse Tiedosto > Tallenna nimellä. Valitse Tallenna nimellä -valintaikkunasta Muoto > TIFF, valitse Tallenna kopio, poista Tasojen valinta ja napsauta Tallenna.

Jos haluat nopeuttaa TIFF-tiedostojen vientiä, älä valitse ZIP-pakkausta. (ZIP-pakkauksessa TIFF-tiedostoista tulee kuitenkin pienimpiä.)

Älä vie leikepöytää

Kirjoita leikepöytä -asetus saa Photoshopin antamaan leikepöydän sisällön muiden ohjelmien käyttöön. Jos kopioit suuria tietomääriä Photoshopissa, muttet liitä niitä muihin sovelluksiin, voit säästää aikaa poistamalla tämän toiminnon käytöstä:

  1. Valitse Photoshop > Oletusarvot > Suorituskyky (Mac OS) tai Muokkaa > Oletusarvot > Suorituskyky (Windows).

  2. Poista valinta kohdasta Kirjoita leikepöytä.

  3. Valitse OK.

Poista Kirjastot-paneeli käytöstä

  1. Valitse Kirjastot-pikaikkunavalikosta Sulje.

    Kirjastot-pikaikkunavalikko
  2. Käynnistä Photoshop uudelleen.

Laitteen esikatselun poistaminen käytöstä

  1. Valitse Poista laite -pikaikkunavalikosta Sulje.

    Laitteen poistaminen pikaikkunavalikosta
  2. Käynnistä Photoshop uudelleen.

Luontitoiminnon poistaminen käytöstä

  1. Valitse Muokkaa > Oletusarvot > Laajennukset.

  2. Poista valinta kohdasta Ota luontitoiminto käyttöön.

  3. Valitse OK.

Poista viivaimet käytöstä

Voit poistaa viivaimet käytöstä kumoamalla Näkymä-valikossa Viivaimet.

Käynnistä uudelleen Creative Cloud -työpöytäsovellus

Optimoi laitteistokokoonpano Photoshopille

Jos olet kiinnostunut nykyisen laitteistokokoonpanon muokkaamisesta (tai jos olet ostamassa uutta järjestelmää), käytä seuraavia tietoja optimoidessasi sitä Photoshopille.

Käytä nopeaa suoritinta

Tietokoneen suorittimen nopeus rajoittaa Photoshopin suoritusnopeutta. Photoshop vaatii moniytimisen Intel-suorittimen (Mac OS) tai 2 GHz:n tai sitä nopeamman suorittimen (Windows).

Kaikki Photoshopin toiminnot ovat nopeampia monisuoritinjärjestelmässä, vaikkakin tietyt toiminnot hyötyvät monisuoritinjärjestelmän ominaisuuksista enemmän. Huomaa, että suorittimiin pätee vähenevän tuoton laki: mitä useampia suorittimia on käytössä, sitä vähemmän hyötyä saadaan kustakin lisäsuorittimesta. Siksi Photoshop ei toimi neljä kertaa nopeammin 16 suoritinta sisältävällä tietokoneella kuin neljällä suorittimella varustetulla tietokoneella. Useimmille käyttäjille yli kuuden ytimen mukanaan tuoma suorituskyvyn parannus ei ole kannattava, koska suorittimet maksavat niin paljon.

Huomautus:

Jos käytät Photoshopia virtuaalisessa ympäristössä, Photoshopin grafiikkasuoritin voi aiheuttaa suorituskykyongelmia. Virtuaalikoneet eivät pysty käyttämään grafiikkasuoritinta.

Lisää muistia

Photoshop käyttää keskusmuistia (RAM) kuvien käsittelyyn. Jos Photoshopin käytettävissä ei ole riittävästi muistia, tietojen käsittelyyn käytetään kiintolevytilaa (työlevy). Tiedot saadaan muistista nopeammin käyttöön kuin kiintolevyltä. Niinpä Photoshopin toiminta onkin nopeimmillaan, kun se voi käsitellä kaikki tai enimmät kuvatiedot RAM-muistissa.

Photoshopin uusimmassa versiossa suositellaan vähintään 8 Gt muistia.

Photoshopiin varattavan muistin määritysohjeet ovat kohdassa Muistin käytön säätäminen.

Käytä nopeaa ja suurikokoista kiintolevyä

Photoshop lukee ja kirjoittaa kuvatietoja levylle, kun järjestelmässä ei ole tarpeeksi muistia kaikkien kuvatietojen säilyttämiseen. Tehokkuusilmaisin auttaa selvittämään, parantaisiko nopeampi kiintolevy tai SSD-kiintolevy suorituskykyä tietokoneellasi. Jos tehokkuusluku on yleensä yli 95 %, nopeamman työlevyn hankkimisesta ei ole juuri hyötyä.

Jos haluat parantaa Photoshopin suorituskykyä, käytä levyä, jolla on nopeampi tiedonsiirtonopeus. Käytä esim. sisäistä kiintolevyä tai ulkoista levyä, joka on liitetty nopealla liitännällä, jollaisia ovat mm. Thunderbolt, FireWire 800, eSATA ja USB3. Verkkopalvelimilla (verkon kautta käytettävät kiintolevyt) on hitaammat tiedonsiirtonopeudet.

Photoshopin uusin versio vaatii vähintään 2,5 Gt (Windows) tai 3,2 Gt (Mac OS). Asennukseen tarvitaan lisätilaa, ja Adobe suosittelee lisäkiintolevytilan hankkimista virtuaalista muistia ja työlevytilaa varten.

Nopeat RAID 0 -ryhmät ovat paras vaihtoehto työlevyille varsinkin, jos ryhmää käytetään ainoastaan työlevyä varten. Muista myös eheyttää ryhmä säännöllisesti äläkä käytä sitä käynnistysasemana.

Käytä SSD-asemaa

Suurin hyöty SSD-levystä saadaan, kun sitä käytetään työlevynä. Kun SSD-levyä käytetään työlevynä, suorituskyky paranee huomattavasti, jos kuvat eivät mahdu RAM-muistiin kokonaisuudessaan. Esimerkiksi ruutujen vaihtaminen RAM- ja SSD-muistin välillä on paljon nopeampaa kuin RAM- ja kiintolevyn välillä.

Jos SSD-levylläsi ei ole paljon vapaata tilaa (työtiedosto kasvaa suuremmaksi kuin SSD-levylle mahtuu), lisää toinen tai kolmas kiintolevy. (Lisää se SSD:n jälkeen.) Varmista, että nämä levyt valitaan työlevyiksi Suorituskyky-oletusarvoissa.

SSD-levyjen suorituskyky vaihtelee myös huomattavasti, paljon enemmän kuin kiintolevyillä. Aiemman, hitaamman aseman käyttäminen ei ole huomattava parannus kiintolevyyn verrattuna.

Huomautus:

Muistin lisääminen suorituskyvyn parantamiseksi on kustannustehokkaampaa kuin SSD-muistin hankkiminen.

Jos tehokkuusilmaisin on jo korkealla, SSD ei paranna suorituskykyä. Mitä pienempi tehokkuusilmaisimen arvo on, sitä enemmän SSD suorituskykyä parantaa.

Lisätietoja suorituskyvystä ja 64-bittisestä Photoshopista on artikkelissa 64-bittisen käyttöjärjestelmän edut ja rajoitukset.

käyttöjärjestelmän optimointi Photoshopille.

Käytä seuraavia tietoja määrittämään ja käyttämään käyttöjärjestelmää tehokkaasti Photoshopin kanssa.

Sulje tarpeettomat sovellukset ja käynnistyskohteet

Muut avoinna olevat ohjelmat ja käynnistysohjelmat vähentävät Photoshopin käytettävissä olevan muistin määrää. Vapauta lisää muistia lopettamalla tarpeettomat sovellukset, käynnistyskohteet ja laajennukset. Vapauta sitten muistia Photoshopin käyttöön.

App Napin poistaminen käytöstä (Mac)

Suorita Järjestä uudelleen -toiminto (Windows)

Suorita säännöllisesti Järjestä uudelleen -toiminto, joka poistaa väliaikaiset kopiot ja muut tarpeettomat tiedostot järjestelmästä.

  1. Napsauta Käynnistä-painiketta, kirjoita hakukenttään Levyn uudelleenjärjestäminen ja valitse ohjelmaluettelosta Levyn uudelleenjärjestäminen.

  2. Valitse puhdistettava asema.

  3. Valitse väliaikaiset tiedostot ja muut tiedostot, jotka haluat poistaa.

  4. Valitse OK.

Eheytä kiintolevy

Jos tiedosto on pirstoutunut, sen lukeminen ja kirjoittaminen kestää Photoshopissa pidempään kuin jos se olisi tallennettu yhteen paikkaan.

Ohjeita kiintolevyjen eheyttämiseen Windowsissa on Microsoftin ohjeissa:

  • (Windows 7 ja Vista) "Suorituskyvyn parantaminen kiintolevyn eheytyksellä"
  • (Windows 8) ”Kiintolevyn optimointi”

Huomautus:

Eheyttäminen on harvoin ongelma Mac OS -järjestelmässä, ellei tallennustila ole yleensä lähes täynnä.

SSD-asemat eivät vaadi eheyttämistä, koska niiden suorituskyky ei heikkene merkittävästi tavallisen pirstoutumisen myötä.

Huomautus:

RAID-ryhmät eivät pirstoudu. Pirstoutuminen on huomattavasti todennäköisemmin ongelma silloin, kun yhtä levyä käytetään kaikkeen Jos pysyvät tiedostot ja Photoshopin työlevy ovat samassa taltiossa voi muodostaa ongelman, varsinkin jos asemassa ei ole paljon vapaata tilaa. Tällöin levyn eheyttämisestä voi olla paljon apua.

Ota automaattiset käyttöjärjestelmäpäivitykset käyttöön

Windows- tai Mac OS -käyttöjärjestelmän päivitykset parantavat niiden suorituskykyä ja yhteensopivuutta sovellusten kanssa.

Ota Windows Update käyttöön Windowsissa.

Käytä Ohjelmiston päivitystä Mac OS X:ssä.

Määritä kiinteä virtuaalimuisti (Windows)

Kiinteän näennäismuistiasetuksen määrittäminen auttaa estämään sen, että Photoshopin työlevytiedostot kilpailevat samasta tilasta näennäismuistin kanssa (varsinkin silloin, kun näennäismuistiasetus on asetettu muulle kuin ensisijaiselle työlevylle). Saat parhaan suorituskyvyn käyttämällä asemaa, jossa on tarpeeksi yhtenäistä tilaa. Säilytä lisäksi sivutustiedostoa erillisellä, tyhjällä, eheytetyllä kiintolevyllä.

Kuten aina, ohje erillisten levyjen käyttämistä virtuaalimuistille ja työlevyille ei koske SSD-levyjä. Kun käytössä on SSD-asema useimmin käytettyjen tiedostojen asettaminen SSD-asemaan auttaa eikä aiheuta juuri lainkaan haittoja.

Jos haluat muuttaa virtuaalimuistia, sulje kaikki sovellukset ja toimi sen jälkeen seuraavasti:

  1. Valitse Käynnistä > Ohjauspaneeli ja kaksoisnapsauta Järjestelmä.

  2. Valitse Tehtävät-luettelosta Järjestelmän lisäasetukset ja valitse Lisäasetukset-välilehti.

  3. Valitse Suorituskyky-osassa Asetukset.

  4. Valitse Lisäasetukset-välilehto ja valitse Muuta.

  5. Poista valinta kohdasta Hallitse kaikkien asemien sivutustiedostojen kokoa automaattisesti.

  6. Kunkin aseman käytettävissä oleva tila saadaan näkyviin napsauttamalla kyseisen kiintolevyn kirjainta. Valitse kiintolevy, jolla on kolme kertaa tietokoneeseen asennetun RAM-muistin verran tilaa ja joka ei sisällä työlevyä.

  7. Valitse Mukautettu koko ja kirjoita Aloituskoko-ruutuun fyysisen muistin määrä lisättynä 300 megatavulla. Kirjoita Enimmäiskoko-ruutuun tietokoneeseen asennetun muistin määrä kolminkertaisena.

  8. Valitse Aseta ja valitse OK. Poistu kaikista valintaikkunoista napsauttamalla kaikissa OK.

  9. Käynnistä tietokone uudelleen. Jos ohjelmia on avoinna, valitse Käynnistä uudelleen myöhemmin, sulje ohjelmat ja käynnistä sitten Windows uudelleen. Valitse muussa tapauksessa Käynnistä uudelleen.

Jos haluat muuttaa virtuaalimuistia Windows 8:ssa, sulje kaikki sovellukset ja toimi sen jälkeen seuraavasti:

  1. Valitse Käynnistä > Ohjauspaneeli. Jos Käynnistä-kuvaketta ei ole, valitse kansiokuvake ja hae ohjauspaneeli tietokoneesta.

  2. Valitse Järjestelmä ja suojaus > Järjestelmä.

  3. Suorita edellä olevat vaiheet vaiheesta 3 alkaen.

Aseta virranhallinta-asetukset

  • (Mac OS) Vaöitse Järjestelmäasetukset > Energiansäästäjä ja kumoa valinta Automaattinen grafiikkakytkentä.
  • (Windows) Valitse OhjauspaneeliVirranhallinta-asetukset ja valitse Paras suorituskyky.

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö