Käyttöopas Peruuta

Kuvaresurssien luominen tasoista

  1. Photoshop-käyttöopas
  2. Photoshopin esittely
    1. Haaveile. Luo.
    2. Photoshopin uudet ominaisuudet
    3. Muokkaa ensimmäinen kuvasi
    4. Dokumenttien luonti
    5. Photoshop | Yleisiä kysymykset
    6. Photoshop-järjestelmävaatimukset
    7. Tutustu Photoshopiin
  3. Photoshop ja muut Adoben tuotteet ja palvelut
    1. Illustrator-teosten käsitteleminen Photoshopissa
    2. Photoshop-tiedostojen käsittely InDesignissa
    3. Substance 3D -materiaalit Photoshopille
    4. Capture-sovelluslaajennuksen käyttäminen Photoshopissa
  4. Photoshopin iPad-versio (ei saatavilla Manner-Kiinassa)
    1. Photoshopin iPad-versio | Yleisiä kysymykset
    2. Tutustu työtilaan
    3. Järjestelmävaatimukset | Photoshopin iPad-versio
    4. Dokumenttien luominen, avaaminen ja vieminen
    5. Valokuvien lisääminen
    6. Tasojen käyttäminen
    7. Siveltimillä piirtäminen ja maalaaminen
    8. Tee valintoja ja lisää maskeja
    9. Sommitelmien retusoiminen
    10. Säätötasojen käyttäminen
    11. Sommitelman sävyjen säätäminen käyrien avulla
    12. Muunnosten käyttäminen
    13. Sommitelmien rajaus ja kääntäminen
    14. Piirtoalueen kierto, panorointi, zoomaus ja palautus
    15. Tekstitasojen käyttäminen
    16. Photoshopin ja Lightroomin käyttäminen
    17. Puuttuvien Photoshop-kirjasinten asentaminen iPadille
    18. Japanilainen teksti Photoshopin iPad-versiossa
    19. Hallitse sovelluksen asetuksia
    20. Kosketustoiminnot ja -eleet
    21. Pikanäppäimet
    22. Kuvan koon muokkaaminen
    23. Reaaliaikainen suoratoisto Photoshopin iPad-versiossa
    24. Korjaa virheitä korjaussiveltimen avulla
    25. Luo siveltimiä Capture-ohjelmistossa ja käytä niitä Photoshopin iPad-versiossa
    26. Camera Raw -tiedostojen käsitteleminen
    27. Älykkäiden objektien luominen ja käyttäminen
    28. Kuvien valotuksen säätäminen varjostuksen ja lisävalotuksen avulla
    29. Automaattisäädön komennot Photoshopin iPad-versiossa
    30. Kuvan alueiden hankaaminen Photoshopin iPad-versiossa
    31. Kuvien kyllästäminen tai haalistaminen pesusienityökalulla
    32. Sisältötietoinen täyttö iPad-versiossa
  5. Photoshopin verkkoversio (ei saatavilla Manner-Kiinassa)
    1. Yleisiä kysymyksiä
    2. Järjestelmävaatimukset
    3. Pikanäppäimet
    4. Tuetut tiedostotyypit
    5. Työtilan esittely
    6. Pilvidokumenttien avaaminen ja käyttäminen
    7. Generatiiviset tekoälyominaisuudet
    8. Muokkaamisen peruskäsitteet
    9. Pikatoiminnot
    10. Tasojen käyttäminen
    11. Kuvien retusointi ja virheiden poistaminen
    12. Nopeiden valintojen tekeminen
    13. Kuvan parantaminen säätötasojen avulla
    14. Kuvien siirtäminen, muuntaminen ja rajaaminen
    15. Piirtäminen ja maalaaminen
    16. Tekstitasojen käyttäminen
    17. Työskentele verkossa kenen tahansa kanssa
    18. Hallitse sovelluksen asetuksia
    19. Generoi kuva
    20. Generoi tausta
    21. Viitekuva
  6. Photoshop (Beta) (ei saatavana Manner-Kiinassa)
    1. Creative Cloud (Beta) -sovellusten käytön aloittaminen
    2. Photoshop (Beta) -tietokoneversio
    3. Generoi kuva kuvailevien tekstikehotteiden avulla
    4. Generoi tausta kuvailevien tekstikehotteiden avulla
  7. Generatiivinen tekoäly (ei saatavilla Manner-Kiinassa) 
    1. Yleisiä kysymyksiä Photoshopin uusista tekoälytoiminnoista
    2. Generatiivinen täyttö Photoshopin tietokoneversiossa
    3. Generatiivinen laajennus Photoshopin tietokoneversiossa
    4. Generatiivinen täyttö Photoshopin iPad-versiossa
    5. Generatiivinen laajennus Photoshopin iPad-versiossa
    6. Generatiiviset tekoälyominaisuudet Photoshopin verkkoversiossa
  8. Content Authenticity (ei saatavilla Manner-Kiinassa)
    1. Sisällön valtuudet Photoshopissa
    2. NFT-teosten identiteetti- ja käsittelyhistoriatiedot
    3. Tilien liittäminen teoksen määritetietoihin
  9. Pilvidokumentit (ei saatavilla Manner-Kiinassa)
    1. Photoshop-pilvidokumentit | Yleisiä kysymyksiä
    2. Photoshop-pilvidokumentit | Työnkulkuun liittyviä kysymyksiä
    3. Pilvidokumenttien hallinta ja käyttö Photoshopissa
    4. Photoshopin pilvitallennustilan lisääminen
    5. Pilvidokumentin luominen tai tallennus ei onnistu
    6. Photoshop-pilvidokumenttien ongelmien ratkaiseminen
    7. Pilvidokumenttien synkronointilokien kerääminen
    8. Kutsu muita muokkaamaan pilvidokumenttejasi
    9. Tiedostojen jakaminen ja kommentointi sovelluksessa
  10. Työtila
    1. Perustietoja työtilasta
    2. Oletusasetukset
    3. Opi nopeammin Photoshopin Tutustu-paneelin avulla
    4. Dokumenttien luonti
    5. Tiedostojen sijoittaminen
    6. Oletuspikanäppäimet
    7. Pikanäppäinten mukauttaminen
    8. Työkaluvalikoimat
    9. Suorituskyvyn oletusarvot
    10. Työkalujen käyttö
    11. Esimääritykset
    12. Ruudukko ja apulinjat
    13. Kosketuseleet
    14. Käytä Touch Baria Photoshopissa
    15. Kosketustoiminnot ja mukautettavat työtilat
    16. Tekninen esikatselu
    17. Metatiedot ja muistiinpanot
    18. Kosketustoiminnot ja mukautettavat työtilat
    19. Photoshop-kuvien sijoittaminen muihin sovelluksiin
    20. Viivaimet
    21. Tulostumattomien ylimääräisten elementtien näyttäminen ja piilottaminen
    22. Palstojen määrittäminen kuvalle
    23. Kumoa ja Historia
    24. Paneelit ja valikot
    25. Elementtien sijoittelu kohdistamalla
    26. Sijoittaminen viivaintyökalulla
  11. Web-, näyttö- ja sovellussuunnittelu
    1. Photoshop suunnitteluun
    2. Piirtoalustat
    3. Laitteen esikatselu
    4. CSS:n kopioiminen tasoista
    5. Verkkosivun osittaminen
    6. Osien HTML-asetukset
    7. Osien asettelun muuttaminen
    8. Web-grafiikan käsitteleminen
    9. Web-valokuvagallerioiden luominen
  12. Perustietoja kuvista ja väreistä
    1. Kuvien koon muuttaminen
    2. Rasterikuvien ja vektorigrafiikan käyttäminen
    3. Kuvan koko ja tarkkuus
    4. Kuvien tuominen kameroista tai skannereista
    5. Kuvien luominen, avaaminen ja tuominen
    6. Kuvien tarkasteleminen
    7. Virheellinen JPEG-merkki -virhe | Kuvien avaaminen
    8. Useiden kuvien katseleminen
    9. Värimuokkainten ja värimallien mukauttaminen
    10. High Dynamic Range -kuvat
    11. Värien sovittaminen kuvassasi
    12. Muuntaminen väritilasta toiseen
    13. Väritilat
    14. Kuvan osan pyyhkiminen
    15. Sekoitustilat
    16. Värien valitseminen
    17. Indeksiväritaulukoiden mukauttaminen
    18. Kuvien tiedot
    19. Vääristyssuodattimet eivät ole käytettävissä
    20. Tietoja väreistä
    21. Väri- ja mustavalkosäädöt kanavia käyttämällä
    22. Värien valitseminen Väri- ja Värimallit-paneeleista
    23. Näyte
    24. Väritila tai kuvatila
    25. Värivääristymä
    26. Ehdollisen tilan muunnoksen lisääminen makroon
    27. Värimallien lisääminen HTML-, CSS- ja SVG-tiedostoista
    28. Bittisyvyys ja oletusarvot
  13. Tasot
    1. Tasojen perusteet
    2. Tiedot säilyttävä muokkaus
    3. Tasojen ja ryhmien luominen ja hallinta
    4. Tasojen valinta, ryhmittäminen ja linkittäminen
    5. Kuvien sijoittaminen kehyksiin
    6. Tason peittävyys ja sekoitus
    7. Tasojen maskaaminen
    8. Älykkäiden suodatinten käyttö
    9. Tasovedokset
    10. Tasojen siirtäminen, pinoaminen ja lukitseminen
    11. Tasojen maskaaminen vektorimaskeilla
    12. Tasojen ja ryhmien hallinta
    13. Tasotehosteet ja -tyylit
    14. Tasomaskien muokkaus
    15. Erota resurssit
    16. Tasojen paljastaminen rajausmaskeilla
    17. Kuvaresurssien luominen tasoista
    18. Älykkäiden objektien käyttö
    19. Sekoitustilat
    20. Usean kuvan yhdistäminen ryhmäkuvaksi
    21. Kuvien yhdistäminen automaattisella tasojen sekoituksella
    22. Tasojen tasaaminen ja jakaminen
    23. CSS:n kopioiminen tasoista
    24. Valintojen lataaminen tasosta tai tasomaskin reunoista
    25. Muiden tasojen sisällön paljastaminen syrjäytysasetuksilla
  14. Valinnat
    1. Valintojen perusteet
    2. Valintojen tekeminen sommitelmissa
    3. Valinta ja maski -työtila
    4. Valintatyökaluilla valitseminen
    5. Valitseminen lassotyökalulla
    6. Pikselivalintojen muokkaaminen
    7. Valittujen pikselien siirtäminen, kopiointi ja poistaminen
    8. Tilapäisen pikamaskin luominen
    9. Värialueen valitseminen kuvasta
    10. Reittien muuntaminen valintareunuksiksi ja päinvastoin
    11. Kanavien perusteet
    12. Valintojen tallentaminen ja alfakanavamaskit
    13. Kuvan tarkkuusalueiden valitseminen
    14. Kanavien monistaminen, jakaminen ja yhdistäminen
    15. Kanavien laskenta
  15. Kuvan säädöt
    1. Objektin värien korvaaminen
    2. Perspektiivin käyristäminen
    3. Kameran tärinän aiheuttaman sumennuksen vähentäminen
    4. Esimerkkejä korjaussiveltimen käytöstä
    5. Vie värihaun taulukoita
    6. Kuvan terävyyden ja sumeuden säätäminen
    7. Värinsäädöt
    8. Kirkkaus/kontrasti-säädön käyttäminen
    9. Tummien ja vaaleiden yksityiskohtien säätäminen
    10. Tasojen säätö
    11. Sävyn ja kylläisyyden säätäminen
    12. Värikirkkauden säätäminen
    13. Kuvan alueiden värikylläisyyden säätäminen
    14. Nopeiden säätöjen tekeminen sävyihin
    15. Väritehosteiden lisääminen kuviin
    16. Kuvan paranteleminen väritasapainoa säätämällä
    17. High Dynamic Range -kuvat
    18. Histogrammien ja pikseliarvojen tarkasteleminen
    19. Värien sovittaminen kuvassasi
    20. Valokuvien rajaaminen ja suoristaminen
    21. Värikuvan muuntaminen mustavalkokuvaksi
    22. Säätö- ja täyttötasot
    23. Käyrien säätö
    24. Sekoitustilat
    25. Kuvien kohdearvojen valmisteleminen kirjapainoa varten
    26. Värien ja sävyjen säätäminen Tasot- ja Käyrät-pipettityökaluilla
    27. HDR-valotuksen ja -sävytyksen säätäminen
    28. Kuvan alueiden varjostaminen tai lisävalottaminen
    29. Selektiivisten värinsäätöjen tekeminen
  16. Adobe Camera Raw
    1. Camera Raw’n järjestelmävaatimukset
    2. Camera Raw’n uudet ominaisuudet
    3. Johdanto Camera Raw -ohjelmistoon
    4. Panoraamojen luonti
    5. Tuetut objektiivit
    6. Vinjetointi, rakeisuus ja udun poisto Camera Raw'ssa
    7. Oletuspikanäppäimet
    8. Automaattinen perspektiivin korjaus Camera Raw'ssa
    9. Säteittäinen suodatin Camera Raw'ssa
    10. Camera Raw -asetusten hallinta
    11. Kuvien avaaminen, käsittely ja tallentaminen Camera Raw’ssa
    12. Korjaa kuvia Camera Raw’n parannetulla täplänpoistotyökalulla
    13. Kuvien kiertäminen, rajaus ja säätäminen
    14. Värinmuodostuksen säätö Adobe Camera Raw’ssa
    15. Camera Raw'n prosessiversiot
    16. Paikallisten säätöjen tekeminen Camera Raw -sovelluksessa
  17. Kuvien korjaaminen ja retusoiminen
    1. Kohteiden poistaminen valokuvista sisältötietoisen täytön avulla
    2. Sisältötietoinen paikkaus ja siirto
    3. Valokuvien retusointi ja korjaus
    4. Kuvan vääristymien ja kohinan korjaaminen
    5. Vianmäärityksen perusvaiheet useimpien ongelmien ratkaisemiseen
  18. Kuvan parantaminen ja muuntaminen
    1. Taivaan korvaaminen kuvissa
    2. Objektien muuntaminen
    3. Rajauksen, käännön ja piirtoalueen koon säätäminen
    4. Valokuvien rajaaminen ja suoristaminen
    5. Panoraamakuvien luominen ja muokkaaminen
    6. Kuvien, muotojen ja reittien käyristykset
    7. Pakopiste
    8. Sisältötietoinen skaalaus
    9. Kuvien, muotojen ja reittien muuntaminen
  19. Piirtäminen ja maalaaminen
    1. Symmetristen kuvioiden maalaaminen
    2. Suorakulmioiden piirtäminen ja viivan asetusten muokkaaminen
    3. Tietoja piirtämisestä
    4. Muotojen piirtäminen ja muokkaus
    5. Maalaustyökalut
    6. Siveltimien luominen ja muokkaaminen
    7. Sekoitustilat
    8. Värin lisääminen reitteihin
    9. Reittien muokkaus
    10. Maalaaminen sekoitussiveltimellä
    11. Siveltimien esimääritykset
    12. Liukuvärit
    13. Liukuvärien interpolointi
    14. Täyttö- ja viivavalinnat, tasot ja reitit
    15. Piirtäminen kynätyökaluilla
    16. Kuvioiden luominen
    17. Kuvion muodostaminen Kuvion luominen -toiminnolla
    18. Reittien hallinta
    19. Kuviokirjastojen ja esimääritysten hallinta
    20. Piirtäminen tai maalaaminen piirtopöydällä
    21. Pintakuvioitujen siveltimien luominen
    22. Dynaamisten elementtien lisääminen siveltimiin
    23. Liukuväri
    24. Tyyliteltyjen viivojen maalaaminen taidehistoriasiveltimellä
    25. Maalaaminen kuviolla
    26. Synkronoi esimääritykset eri laitteisiin
    27. Esimääritysten, makrojen ja asetusten siirto
  20. Teksti
    1. Tekstin lisääminen ja muokkaaminen
    2. Unified Text Engine
    3. OpenType SVG -kirjasinten käyttö
    4. Merkkien muotoileminen
    5. Kappaleiden muotoileminen
    6. Tekstitehosteiden luominen
    7. Tekstin muokkaus
    8. Rivien ja merkkien välit
    9. Arabian- ja hepreankielinen teksti
    10. Kirjasimet
    11. Kirjasinten vianmääritys
    12. Aasialainen teksti
    13. Tekstin luonti
  21. Suodattimet ja tehosteet
    1. Sumennusgallerian käyttö
    2. Perustietoja suodattimista
    3. Suodatintehosteiden luettelo
    4. Valaistustehosteiden lisääminen
    5. Mukautuvan laajakuvasuodattimen käyttö
    6. Öljymaalaussuodattimen käyttö
    7. Sulata-suodattimen käyttö
    8. Tasotehosteet ja -tyylit
    9. Erityisten suodatinten käyttö
    10. Kuvan alueiden hankaaminen
  22. Tallentaminen ja vieminen
    1. Tiedostojen tallentaminen Photoshopissa
    2. Tiedostojen vieminen Photoshopissa
    3. Tuetut tiedostomuodot
    4. Tiedostojen tallentaminen kuvamuodoissa
    5. Suunnittelutiedostojen siirtäminen Photoshopin ja Illustratorin välillä
    6. Videoiden ja animaatioiden tallentaminen ja vienti
    7. PDF-tiedostojen tallentaminen
    8. Digimarc-tekijänoikeuksien suojaus
  23. Color Management
    1. Perustietoja värinhallinnasta
    2. Värien tasalaatuisuuden säilyttäminen
    3. Väriasetukset
    4. Kaksisävyt
    5. Väriprofiilien käyttäminen
    6. Julkaisujen värinhallinta online-katselua varten
    7. Dokumenttien värinhallinta tulostuksessa
    8. Tuotujen kuvien värinhallinta
    9. Värien tarkastaminen
  24. Web-, näyttö- ja sovellussuunnittelu
    1. Photoshop suunnitteluun
    2. Piirtoalustat
    3. Laitteen esikatselu
    4. CSS:n kopioiminen tasoista
    5. Verkkosivun osittaminen
    6. Osien HTML-asetukset
    7. Osien asettelun muuttaminen
    8. Web-grafiikan käsitteleminen
    9. Web-valokuvagallerioiden luominen
  25. Videot ja animaatiot
    1. Videoiden muokkaus Photoshopissa
    2. Video- ja animaatiotasojen muokkaaminen
    3. Videoiden ja animaatioiden yleiskatsaus
    4. Videoiden ja animaatioiden esikatseleminen
    5. Ruutujen maalaaminen videotasoille
    6. Videotiedostojen ja kuvasarjojen tuominen
    7. Ruutuanimaatioiden luominen
    8. Creative Cloud 3D -animaatio (esikatselu)
    9. Aikajana-animaatioiden luonti
    10. Kuvien luonti videoita varten
  26. Tulostaminen
    1. 3D-objektien tulostus
    2. Tulostaminen Photoshopista
    3. Tulostaminen käyttäen värinhallintaa
    4. Kontaktiarkit ja PDF-esitykset
    5. Kuvien tulostaminen kuvapakkausasettelussa
    6. Spottivärit tulostuksessa
    7. Kuvien tulostaminen kirjapainossa
    8. Photoshopin väritulosteiden parantaminen
    9. Tulostusongelmien vianmääritys | Photoshop
  27. Automaatio
    1. Makrojen luominen
    2. Tieto-ohjatun grafiikan luominen
    3. Komentosarjat
    4. Tiedostoerän käsitteleminen
    5. Makrojen toistaminen ja hallitseminen
    6. Ehdollisten tilan muutosten lisääminen
    7. Tietoja makroista ja Makrot-paneelista
    8. Työkalujen tallentaminen makroihin
    9. Ehdollisen tilan muunnoksen lisääminen makroon
    10. Photoshop-käyttöliittymän työkalusarja plug-ineille ja komentosarjoille
  28. Vianmääritys
    1. Ratkaistut ongelmat 
    2. Tunnetut ongelmat
    3. Optimoi Photoshopin suorituskyky
    4. Perusvianmääritys
    5. Kaatumisen tai jumiutumisen vianmääritys
    6. Ohjelmavirheiden vianmääritys
    7. Työlevy täynnä -virheiden vianmääritys
    8. Grafiikkasuorittimen ja näytönohjaimen ongelmien vianmääritys
    9. Puuttuvien työkalujen etsiminen
    10. Photoshop | Yleisiä kysymyksiä poistetuista 3D-ominaisuuksista

PSD-tiedoston tason tai tasoryhmän sisällöstä voi luoda JPEG-, PNG- GIF- tai SVG-muotoisia kuvaresursseja. Resurssit luodaan automaattisesti, kun tuetun kuvatiedostomuodon tunniste liitetään tason tai tasoryhmän nimeen. Voit halutessasi määrittää luotaville kuvaresursseille myös laatu- ja kokoparametrit.

Kuvaresurssien luominen PSD-tiedostosta on kätevää etenkin, kun verkkosisältöä luodaan useita eri laitteita silmällä pitäen.

Tietoja verkkografiikan luonnista ja viennistä on artikkelissa Tiedostojen vienti Photoshopista eri tiedostomuodoissa.

Kuvaresurssien luominen tasoista tai tasoryhmistä

Kuvaresurssien luomista oppii ymmärtämään, kun ajattelee PSD-tiedostoa (lataus tästä linkistä), jossa on seuraavat tasot:

Kuvaresurssien luominen Photoshopissa
PSD-esimerkkitiedosto tasoineen

Tässä tiedostossa on kaksi tasoryhmää, Nelikulmiot ja Ellipsit. Kummassakin ryhmässä on viisi tasoa.

Voit luoda tästä PSD-tiedostosta kuvaresursseja seuraavasti:

  1. Kun PSD-tiedosto on avattu, valitse Tiedosto > Luo > Kuvaresurssit.
  2. Lisää tarvittavat tiedostotunnisteet (.jpg, .png.gif, tai .svg) niiden tasojen tai tasoryhmien nimiin, joista haluat luoda kuvaresursseja. Voit vaihtaa tasoryhmien Nelikulmiot ja Ellipsit nimiksi Nelikulmiot.jpg ja Ellipsit.png ja tason Ellipsi_4 nimeksi Ellipsi_4.gif.
Huomautus:

Tasojen nimissä ei voi käyttää erikoismerkkejä : ja *.

Photoshop luo kuvaresurssit ja tallentaa ne alikansioon alkuperäisen PSD-tiedoston yhteyteen. Jos alkuperäistä PSD-tiedostoa ei ole vielä tallennettu, Photoshop tallentaa resurssit uuteen kansioon Työpöydälle.

Kuvaresurssien nimet Photoshopissa
Kuvaresurssien nimet luodaan tasojen tai tasoryhmien nimistä.

Huomautus:

Kuvaresurssien luonti on käytössä työstettävässä dokumentissa. Kun toiminto on otettu käyttöön, se on käytössä myös, kun dokumentti avataan seuraavan kerran. Jos haluat poistaa kuvaresurssien luonnin käytöstä, poista valinta kohdasta Tiedosto > Luo > Kuvaresurssit.

Resurssien luominen pilvidokumenteille

Kun käsittelet pilvidokumenttia, resurssit tallennetaan Photoshop Cloud Associates -hakemistoon:

  • Windows: C:\Users\käyttäjänimi\Documents\Adobe\Photoshop Cloud Associates
  • macOS: /Users/käyttäjänimi/Documents/Adobe/Photoshop Cloud Associates

Useiden kuvaresurssien luominen tasosta tai tasoryhmästä

Jos haluat luoda tasosta tai tasoryhmästä useita resursseja, erota resurssien nimet pilkuin. Kun taso nimetään esimerkiksi seuraavasti, siitä luodaan kolme resurssia:

Ellipsi_4.jpg, Ellipsi_4b.png, Ellipsi_4c.png

Resurssien tallentaminen alikansioon

Tietyistä tasoista tai tasoryhmistä luodut kuvaresurssit voi tallentaa alikansioon, joka on heti dokumentin resurssikansion alla. Lisää alikansion nimi tason tai tasoryhmän nimeen, esimerkiksi:

[alikansio]/Ellipsi_4.jpg 

Verkkosisältöesimerkki

Kuvaresurssien luominen PSD-tiedostosta on kätevää etenkin, kun verkkosisältöä luodaan useita eri laitteita silmällä pitäen. Otetaan esimerkiksi seuraava verkkosivu ja sen tasorakenne:

Verkkosivu ja sen tasorakenne

Erotetaanpa yläreunan symboli ja Global Hotspots -kuvaruudukon ylärivi kuvaresursseiksi:

  • Lisätään kuvatiedostotunnisteet tasojen nimiin.
Tasojen tai tasoryhmien nimeäminen uudelleen Photoshopissa

Tasojen tai tasoryhmien nimeäminen uudelleen Photoshopissa

Tasojen tai tasoryhmien nimeäminen uudelleen

Huomautus:

Tason tai tasoryhmän sisällöstä luodaan yksi kuvaresurssi. Esimerkiksi yllä olevan kuvan AdventureCo-logo-tasoryhmä sisältää muototason ja tekstitason. Tasot yhdistetään, kun tasoryhmästä luodaan kuvaresurssi.

Photoshop luo resurssit ja tallentaa ne alkuperäisen PSD-tiedoston kanssa samaan paikkaan.

Luodut kuvaresurssit Photoshopissa
Luodut kuvaresurssit

Laatu- ja kokoparametrien määrittäminen

JPEG-resurssien oletuslaatuasetuksena on 90 %. PNG-resurssit luodaan oletusarvoisesti 32-bittisinä kuvina. GIF-resurssien luonnissa käytetään tavallista alfaläpinäkyvyyttä.

Samalla kun nimeät tasoja ja tasoryhmiä uudelleen, voit muokata luotavien resurssien laatu- ja kokoasetuksia.

JPEG-resurssien parametrit

  • Liitä haluttu laatuarvo resurssin nimeen muodossa .jpg(1–10) tai .jpg(1–100%). Esimerkki:
    • Ellipsi_4.jpg5
    • Ellipsi_4.jpg50%
  • Liitä kuvaresurssin nimen eteen sen haluttu koko joko suhteellisessa koossa tai tuetuissa yksiköissä (px, in, cm tai mm) ilmaistuna. Photoshop skaalaa kuvan arvon mukaisesti. Esimerkki:
    • 200% Ellipsi_4.jpg
    • 300 x 200 Nelikulmio_3.jpg
    • 10in x 200mm Nelikulmio_3.jpg

Huomautus: Muista lisätä välilyönti etuliitteen ja resurssin nimen väliin. Jos annat koon pikseleinä, yksikön tunnusta ei tarvitse lisätä. Esimerkiksi 300 x 200.

Huomautus:

Kuten esimerkeistä käy ilmi, voit käyttää eri yksiköitä ja pikseliarvoja samassa resurssissa määrittäessäsi sen kokoa. Esimerkiksi 4in x 100 Nelikulmio_3.jpg on resurssin luontiin kelpaava nimi.

PNG-resurssien parametrit

  • Liitä resurssin nimeen haluttu laatuarvo 8, 24 tai 32. Esimerkki:
    • Ellipsi_4.png24
  • Liitä kuvaresurssin nimen eteen sen haluttu koko joko suhteellisessa koossa tai tuetuissa yksiköissä (px, in, cm tai mm) ilmaistuna. Photoshop skaalaa kuvan arvon mukaisesti. Esimerkki:
    • 42% Ellipsi_4.png
    • 300mm x 20cm Nelikulmio_3.png
    • 10in x 50cm Nelikulmio_3.png

Huomautus: Muista lisätä välilyönti etuliitteen ja resurssin nimen väliin. Jos annat koon pikseleinä, yksikön tunnusta ei tarvitse lisätä. Esimerkiksi 300 x 200.

Huomautus:

Kuten esimerkeistä käy ilmi, voit käyttää eri yksiköitä ja pikseliarvoja samassa resurssissa määrittäessäsi sen kokoa. Esimerkiksi 4in x 100 Nelikulmio_3.png on resurssin luontiin kelpaava nimi.

GIF-resurssien parametrit

  • Liitä kuvaresurssin nimen eteen sen haluttu koko joko suhteellisessa koossa tai tuetuissa yksiköissä (px, in, cm tai mm) ilmaistuna. Esimerkki:
    • 42% Ellipsi_4.gif
    • 300mm x 20cm Nelikulmio_3.gif
    • 20in x 50cm Nelikulmio_3.gif

Huomautus: Muista lisätä välilyönti etuliitteen ja resurssin nimen väliin. Jos annat koon pikseleinä, yksikön tunnusta ei tarvitse lisätä. Esimerkiksi 300 x 200.

Huomautus:

Kuten esimerkeistä käy ilmi, voit käyttää eri yksiköitä ja pikseliarvoja samassa resurssissa määrittäessäsi sen kokoa. Esimerkiksi 4in x 100 Nelikulmio_3.gif on resurssin luontiin kelpaava nimi.

GIF-resursseille ei voi määrittää laatuparametreja.

Monimutkaiset tasojen nimet

Kun tasoa nimetään resurssien luontia varten, sille voidaan kerralla määrittää useita resurssinimiä tarvittavin parametrein. Esimerkki:

120% Herkku.jpg, 42% Herkku.png24, 100x100 Herkku_2.jpg90%, 250% Herkku.gif

Photoshop luo tästä tasosta seuraavat resurssit:

  • Herkku.jpg (JPG-kuva laatuarvolla 8 ja skaalauksella 120 %)
  • Herkku.png (24-bittinen PNG-kuva skaalauksella 42 %)
  • Herkku_2.jpg (JPG-kuva laatuarvolla 90 % ja absoluuttisessa koossa 100×100 pikseliä)
  • Herkku.gif (GIF-kuva skaalauksella 250 %).

Esimerkkejä absoluuttisesta skaalauksesta

Hyviä esimerkkejä absoluuttisesta skaalauksesta

  • 100x80 foo.png (yksinkertainen absoluuttinen skaalaus)
  • 80 x 100px foo.png (välit pituuksien välissä)
  • 4in x100 foo.png (yksikkö ja ei yksikköä)
  • 90mm x120cm foo.png (eri yksiköt)
  • 100x? foo.png (yleismerkki)
  • ?x60in foo.png (yleismerkki alussa)

Huonoja esimerkkejä absoluuttisesta skaalauksesta

  • 100x100foo.png (ei väliä ennen tiedostonimeä)
  • 80x100 60% foo.png (absoluuttisen ja suhteellisen skaalauksen yhdistelmä)
  • 50% 80x100 foo.png (absoluuttisen ja suhteellisen skaalauksen yhdistelmä)
  • 20in cm x50cm foo.png (useita yksikköjä)
  • 30nm x20 nano.png (virheellinen yksikkö)

Usean tiedoston muotoileminen ja erottaminen

Hyviä esimerkkejä

  • Layer 1.png (väli on sallittu tiedostonimessä – tuloksena on yksi tiedosto nimeltä Layer 1.png)
  • Layer 1.png,Layer 2.jpg (pilkku erottimena)
  • Layer 1.png, Layer 2.jpg (pilkku ja väli(t) erottimena)
  • Layer 1.png+Layer 2.jpg (plusmerkki erottimena)
  • Layer 1.png + Layer 2.jpg (plusmerkki ja väli(t) erottimena)

Resurssien yhdistäminen

Resursseista 100% Herkku, 42% Layer 1.png24 + 100x100 Layer.jpg-90%, 250% Quux/Foo Bar Baz.gif on tuloksena kolme tiedostoa (100% Herkku -merkkijono ohitetaan, koska se ei ole tiedostonimi):

  • Layer 1.png skaalauksella 42 % 24-bittisenä png-tiedostona
  • Layer.jpg absoluuttisessa 100x100 pikselin koossa jpg-tiedostona, jonka laatu on 90 %
  • Foo Bar Baz.gif alikansiossa Quux skaalauksella 250 % gif-tiedostona.

Resurssien oletusasetusten määrittäminen

Luoduille resursseille voi määrittää koko dokumentin laajuiset oletusasetukset. Noudata seuraavia ohjeita:

  1. Luo dokumenttiin tyhjä taso.
  2. Aloita tason nimi avainsanalla default. Määritä seuraavaksi asetukset, joita haluat käyttää kaikissa dokumentista luoduissa kuvaresursseissa. Esimerkki:

default hi-res/

Kaikki kuvaresurssit luodaan hi-res-nimiseen kansioon. Esimerkki: [resurssikansio]/hi-res/Herkku.jpg.

default hi-res/@2x

Kaikki kuvaresurssit luodaan hi-res-nimiseen kansioon. Lisäksi resurssien nimien perään lisätään @2x. Esimerkki: [resurssikansio]/hi-res/Herkku@2x.jpg.

default 50% lo-res/

Kuvaresursseja pienennetään 50 prosenttia, ja ne tallennetaan lo-res-nimiseen alikansioon, joka on dokumentin resurssikansiossa. 

default hi-res/@2x + 50% lo-res/

Tasosta luodaan kaksi kuvaresurssia:

  • Hi-res-nimiseen alikansioon luodaan kuvaresurssi, jonka nimen perässä on @2x.
  • Lo-res-nimiseen alikansioon luodaan kuvaresurssi, jota on pienennetty 50 prosenttia
    .
Huomautus:

Yksittäisille tasoille määritetyt skaalauskertoimet korvaavat oletusarvoiset skaalauskertoimet.

Kuvaresurssien luonnin poistaminen käytöstä kaikissa dokumenteissa

Voit poistaa kuvaresurssien luonnin käytöstä kaikissa Photoshop-dokumenteissa muokkaamalla Oletusasetuksia.

  1. Valitse Muokkaa > Oletusasetukset > Plug-Init.
  2. Poista valinta kohdasta Ota luontitoiminto käyttöön.
  3. Valitse OK.
Huomautus:

Tiedosto-valikon Luo-kohdan komento poistuu käytöstä, kun kuvaresurssien luonti poistetaan käytöstä Oletusasetuksissa. Toiminnon voi ottaa uudelleen käyttöön vain Oletusasetukset-valintaikkunasta.

Usein kysytyt kysymykset

Samaan dokumenttiin liittyvien resurssien nimien on oltava yksilöllisiä.

JPG-resurssien oletuslaatuasetuksena on 90 %. PNG-resurssit luodaan oletusarvoisesti 32-bittisinä kuvina. GIF-resurssien luonnissa käytetään tavallista alfaläpinäkyvyyttä.

Kyllä. Läpinäkyvyys ja muut tasoon lisätyt tehosteet näkyvät tasosta luoduissa resursseissa. Tällaiset tehosteet saatetaan kuitenkin sulauttaa luotaviin resursseihin.

Resurssit rajataan asiakirjan rajojen mukaan. Jos kuva ei mahdu asiakirjan rajojen sisäpuolelle, Generator ei luo vastaavia kuvaresursseja.

Pilkun (,) lisäksi kuvaresurssien nimet voi erottaa plusmerkillä (+). Esimerkki:

42% Nelikulmio_1.png24 + 100x100 Nelikulmio_1.jpg90%

tarkoittaa samaa kuin

42% Nelikulmio_1.png24, 100x100 Nelikulmio_1.jpg90%.

Lisää samantyyppisiä

 Adobe

Pyydä apua nopeammin ja helpommin

Oletko uusi käyttäjä?