Návrhové plochy v aplikaci Photoshop
Návrhové plochy pro různá zařízení na stejném plátně

Pokud navrhujete weby nebo uživatelská rozhraní, pravděpodobně stále častěji navrhujete weby nebo aplikace pro různá zařízení. Návrhové plochy zjednodušují zpracování návrhu. Uživatelům nabízejí nekonečné plátno, na kterém mohou rozložit návrhy pro různá zařízení a obrazovky. Při vytváření návrhových ploch si můžete vybrat z různých přednastavených rozměrů nebo můžete definovat vlastní rozměry návrhové plochy.

Návrhové plochy jsou praktické, i když normálně navrhujete jen pro jeden rozměr obrazovky. Například při návrhu webových stránek můžete návrhové plochy použít k zobrazení návrhů různých stránek vedle sebe nebo v kontextu.

Poznámka:

Návrhové plochy jsou optimalizovány pro barevný režim RGB a pokročilý režim kreslení GPU.

Co je tedy návrhová plocha?

Návrhovou plochu si můžete představit jako speciální typ skupiny vrstev. Omezuje obsah jakýchkoli prvků, které obsahuje, do hranic. Hierarchie prvků v návrhové ploše se zobrazuje na panelu Vrstvy společně s vrstvami a skupinami vrstev. Návrhové plochy mohou obsahovat vrstvy a skupiny vrstev, ale ne ostatní kreslicí plátna.

Vizuálně slouží jako samostatná plátna v dokumentu. Jakékoli vrstvy v dokumentu, které nejsou součástí kresby, jsou seskupeny v horní části panelu Vrstvy a nebudou omezeny žádnými návrhovými plochami.

Předvolby návrhové plochy

Pro přizpůsobení vzhledu návrhových ploch vyberte možnosti Předvolby >Rozhraní > Vzhled > Návrhové plochy. Máte možnost vybrat matnou barvu návrhové plochy a zobrazit nebo skrýt hranice návrhové plochy. 

Předvolby návrhových ploch v aplikaci Photoshop

Vytvoření dokumentu návrhové plochy

  1. V aplikaci Photoshop vyberte Soubor > Nový.
  2. V dialogovém okně Nový zadejte název dokumentu. Příklad: Web iPhone.
  3. V rozevírací nabídce Typ dokumentu vyberte možnost Návrhová plocha.
  4. Vyberte Velikost návrhové plochy z více než 35 přednastavení.
Velikosti návrhových ploch v aplikaci Photoshop
Široká škála přednastavení velikostí návrhové plochy

  1. Začněte přidávat prvky návrhu na návrhovou plochu. Na návrhovou plochu můžete přidávat inteligentní objekty, skupiny vrstev atd.

Převod jakéhokoli existujícího dokumentu na dokument návrhové plochy

Pokud máte standardní dokument aplikace Photoshop, můžete ho rychle převést na dokument návrhové plochy.

  1. V dokumentu vyberte jednu nebo více vrstev nebo skupin vrstev.
  2. Klikněte pravým tlačítkem myši na výběr a vyberte možnost Návrhová plocha z vrstev nebo Návrhová plocha ze skupiny.

Přidání kreslicích pláten do stávajícího dokumentu

  1. Na panelu Nástroje kliknutím na ikonu vyberte nástroj Návrhová plocha.
  1. Nakreslete návrhovou plochu na plátně.
  2. V případě potřeby změňte její velikost. Na panelu možností nástroje vyberte přednastavenou velikost v rozevírací nabídce Velikost. Případně můžete nechat nastavenou vlastní velikost návrhové plochy.
Změna velikosti návrhové plochy v aplikaci Photoshop
Změna velikosti návrhové plochy

  1. Podle potřeby přejmenujte návrhovou plochu. Postupujte takto:
    1. Vyberte návrhovou plochu a klikněte na položky Vrstva > Přejmenovat návrhovou plochu
    2. Zadejte nový název návrhové plochy a stiskněte klávesu Enter.
  2. Začněte přidávat prvky návrhu na návrhovou plochu. Na návrhovou plochu můžete přidávat inteligentní objekty, skupiny vrstev atd.

Rychlé přidání nových návrhových ploch do dokumentu

Návrhové plochy můžete do dokumentu přidávat kliknutím na ikonu +, která se zobrazuje podél návrhových ploch v dokumentu již obsažených. Tyto ikony + se zobrazí, kdykoli je možné na plátno umístit další návrhové plochy. Chcete-li návrhovou plochu duplikovat i s jejím obsahem, stiskněte klávesu Alt (Windows) nebo Option (Mac) a ikonu +.

  1. Vyberte návrhovou plochu. 
  2. Klikněte na ikonu + u návrhové plochy. Aplikace Photoshop přidá návrhovou plochu do dokumentu ve směru ikony +.
Přidání návrhových ploch pomocí ikon plus v aplikaci Photoshop
Přidání návrhových ploch pomocí ikon plus

Poznámka:

Stisknutím klávesy Alt (Windows) nebo Option (Mac) a ikony + můžete duplikovat aktuálně vybranou návrhovou plochu i s jejím obsahem. Nová návrhová plocha se přidá ve směru ikony +, na kterou kliknete.

Práce s návrhovými plochami

Nastavení pozadí návrhové plochy

Na panelu Vlastnosti (Okno > Vlastnosti) dané návrhové plochy nastavte hodnotu v poli Barva pozadí návrhové plochy. Barvu pozadí můžete nastavit i na průhlednou.

Nastavení pozadí návrhové plochy

Přesouvání prvků mezi návrhovými plochami

Stačí na plátně přetáhnout prvky z jedné návrhové plochy do jiné. Když přesunete prvek mezi návrhovými plochami, aplikace Photoshop se pokusí umístit ho do stejného umístění vzhledem k počátkům pravítka v levých horních rozích návrhové plochy.

Když na návrhovou plochu přidáte nebo přesunete nějaký prvek, přemístí se do horní strany panelu Vrstvy tak, aby odpovídaly opačnému pořadí dané návrhové plochy.

S existujícími návrhovými plochami také můžete seskupit vrstvy nebo prvky, které nejsou součástí žádné návrhové plochy. Stačí na plátně přetáhnout prvek na cílovou návrhovou plochu. Případně ho můžete přemístit na cílovou návrhovou plochu na panelu Vrstvy.

Duplikování vrstev a skupin vrstev

Když duplikujete vrstvu nebo skupinu vrstev v dokumentu obsahujícím návrhové plochy, můžete si vybrat, do které návrhové plochy umístíte kopírovanou vrstvu.

Duplikování vrstev: Vyberte návrhovou plochu, do které chcete umístit kopírovanou vrstvu

Přesunutí

S vybranou plochou nebo nástrojem Přesunout klikněte na popisek návrhové plochy. Tím ji vyberete. Nyní návrhovou plochu přesuňte do požadovaného umístění na plátně.

Změna velikosti

S vybranou plochou nebo nástrojem Přesunout klikněte na popisek návrhové plochy. Tím ji vyberete. Nyní pro návrhovou plochu vyberte novou předvolbu Velikost na panelu možností nástroje.

Pokud chcete změnit velikost návrhové plochy podle vlastních představ, stačí změnit její hranice pomocí táhel.

Mřížky

Vyberte návrhovou plochu a výběrem možností Zobrazení > Zobrazovat > Mřížka zobrazte mřížky v návrhové ploše.

Vodítka

Když je vybraná návrhová plocha, přetáhněte vodítka z pravítka na plátno. Tato vodítka se nyní pohybují s návrhovou plochou. Návrhovou plochu je také možné duplikovat pomocí přidělených vodítek, aby se duplikované návrhové ploše přiřadila totožná vodítka. Můžete případně vybrat možnosti Zobrazit > Nové rozvržení vodítek, abyste vodítka zaměřili na požadované návrhové plochy. Pokud chcete nastavit možnosti viditelnosti vodítka, vyberte možnosti Zobrazení > Zobrazovat.

Nové rozvržení vodítek v aplikaci Photoshop
(Levé) Nové rozvržení vodítek | (Pravé) Možnosti viditelnosti vodítka

Kontrola vlastností návrhové plochy

Vyberte návrhovou plochu a výběrem položek Okno > Vlastnosti rychle projděte klíčové vlastnosti. Velikost návrhové plochy můžete změnit také z panelu Vlastnosti.

Při výběru návrhové plochy se také zobrazí její vlastnosti na panelu možností nástroje. 

Panel Vlastnosti návrhové plochy v aplikaci Photoshop
Panel Vlastnosti návrhové plochy

Zobrazovat názvy návrhové plochy

Pokud chcete zobrazit nebo skrýt názvy návrhové plochy, vyberte možnosti Zobrazení > Zobrazovat > Názvy návrhové plochy. Názvy návrhové plochy se automaticky zkrátí podle šířky návrhové plochy.

Filtrování vrstev podle návrhové plochy

Na panelu Vrstvy vyberte v rozevírací nabídce Hledání možnost Návrhová plocha. Vyberte návrhovou plochu nebo jakoukoli její vrstvu. Zobrazení panelu Vrstvy je nyní omezeno pouze na vybranou návrhovou plochu. Pokud se chcete vrátit do úplného zobrazení panelu Vrstvy, zrušte výběr všech vrstev nebo vyberte něco mimo návrhovou plochu.

Zabránění automatickému vnoření do návrhových ploch a mimo ně

Přiřaďte zámek na obrázku návrhové ploše k zakázání automatického vnoření do návrhové plochy nebo mimo ni, případně do konkrétních vrstev v návrhové ploše k zakázání automatického vnoření těchto konkrétních vrstev. K obnovení normálního chování automatického vnoření odeberte jakékoli zámky automatického vnoření z návrhových ploch nebo vrstev.

Zabránění automatickému vnoření do návrhových ploch a mimo ně v aplikaci Photoshop

Zámek polohy návrhové plochy

Vyberte návrhovou plochu a přidělte jí zámek polohy. Návrhová plocha zůstane upevněná na svém místě na plátně, ale je dále možné běžným způsobem přidávat, posouvat nebo odebírat prvky. 

Zamčení polohy v aplikaci Photoshop

Přejmenování

Dvakrát klikněte na název návrhové plochy na panelu Vrstvy a zadejte nový název. Případně použijte příkaz Vrstva > Přejmenovat návrhovou plochu.

Rozložení návrhových ploch

Návrhové plochy lze snadno rozložit na prvky, které je tvoří. Vyberte návrhovou plochu a klikněte na položky Vrstva > Rozdělit návrhové plochy.  Návrhové plochy jsou rozloženy a prvky, kterými jsou tvořeny, se všechny přesunou o úroveň výš na panelu Vrstvy. Pokud je rozložena nebo rozdělena poslední návrhová plocha v dokumentu, dokument se stane dokumentem bez návrhové plochy.

Export návrhových ploch

Exportování návrhových ploch jako obrazových datových zdrojů

Návrhové plochy teď můžete exportovat jako obrazové datové zdroje ve formátu JPEG, GIF, PNG, PNG-8 nebo SVG přímo z panelu Vrstvy.

Další informace naleznete v tématu Export návrhových ploch a vrstev.

Export návrhových ploch ve formátu PDF

Návrhové plochy můžete exportovat jako dokumenty ve formátu PDF. Postupujte takto:

  1. V aplikaci Photoshop vyberte možnosti Soubor > Export > Návrhové plochy do PDF.
  2. V dialogovém okně Návrhové plochy do PDF proveďte následující akce:
    • Vyberte cíl nebo umístění, kam chcete generovanou prezentaci ve formátu PDF uložit.
    • Zadejte prefix názvu souboru pro generované PDF dokumenty. Například Pojišťovací_kampaň.
    • Určete, zda chcete exportovat pouze obsah návrhových ploch nebo také obsah oblastí, které překrývají návrhové plochy.
    • Určete, zda chcete exportovat všechny návrhové plochy nebo pouze aktuálně vybrané návrhové plochy.
    • Určete, zda chcete spolu s návrhovými plochami exportovat také jejich pozadí.
    • Určete, zda chcete generovat jeden PDF soubor pro všechny návrhové plochy v aktuálním dokumentu, nebo zda chcete generovat PDF dokument pro každou návrhovou plochu. Pokud zvolíte generování více PDF dokumentů, bude pro všechny dokumenty použit prefix názvu souboru, který jste zadali dříve.
    • Zvolte kódování exportovaných PDF dokumentů: ZIP nebo JPEG. Pokud zvolíte JPEG, určete také nastavení kvality (0–12).
    • Zvolte, zda chcete do exportovaných PDF dokumentů zahrnout profil ICC (International Color Consortium). Profil ICC obsahuje data, která charakterizují barvu vstupního nebo výstupního zařízení.
    • Určete, zda chcete spolu s návrhovými plochami exportovat také jejich názvy. Při výběru této možnosti můžete nastavit vlastní písmo, jeho velikost a barvu a barvu přidaného plátna.
  3. Klikněte na Spustit. Aplikace Photoshop vygeneruje PDF dokument.

Export návrhových ploch jako souborů

Návrhové plochy můžete exportovat jako samostatné soubory. Postupujte takto:

  1. V aplikaci Photoshop vyberte možnosti Soubor > Export > Návrhové plochy do souborů.
  2. V dialogovém okně Návrhové plochy do souborů proveďte následující akce:
    • Vyberte umístění, kam chcete uložit vygenerované soubory.
    • Zadejte prefix názvu souboru.
    • Určete, zda chcete pouze exportovat obsah návrhové plochy nebo zahrnout také překrývající se oblasti.
    • Určete, zda chcete exportovat všechny návrhové plochy nebo pouze aktuálně vybrané návrhové plochy.
    • Určete, zda chcete spolu s návrhovými plochami exportovat také jejich pozadí.
    • Vyberte typ souboru, který chcete exportovat. Soubor můžete exportovat ve formátu BMP, JPEG, PDF, PSD, Targa, TIFF, PNG-8 nebo PNG-24.
    • Určete možnosti exportu pro vybraný typ souboru.
      • Určete, zda chcete spolu s návrhovými plochami exportovat také jejich názvy. Při výběru této možnosti můžete nastavit vlastní písmo, jeho velikost a barvu a barvu přidaného plátna.
  3. Klikněte na Spustit. Aplikace Photoshop exportuje návrhové plochy jako soubory ve vybraném formátu.

Náhled v zařízení a doprovodná aplikace Preview CC

Náhled návrhů na cílových zařízeních v aplikaci Photoshop

Pomocí funkce Náhled v zařízení v aplikaci Photoshop a doprovodné aplikace Preview CC můžete rychle zobrazit náhled návrhů na cílových zařízeních iOS. Doprovodná aplikace Preview CC se k aplikaci Photoshop připojuje prostřednictvím portu USB nebo Wi-Fi a vykresluje náhled vašeho návrhu. Veškeré změny, které v návrhu provedete, budou automaticky odeslány do zařízení, abyste mohli zobrazit jejich náhled.

U dokumentů s návrhovými plochami funkce náhledu v zařízení porovná rozměry a polohu návrhové plochy s rozměry připojeného zařízení s iOS a pokusí se zobrazit správnou návrhovou plochu. K zobrazení náhledu určité návrhové plochy na zařízení můžete také použít navigační pruh nebo můžete potažením prstem procházet návrhové plochy v pořadí, ve kterém jsou uvedeny na panelu Vrstvy aplikace Photoshop.

Další informace o náhledu zařízení a aplikaci Preview CC naleznete v tématech:

Časté otázky

Je možné do návrhové plochy přidat návrhovou plochu?

Ne. Vkládání návrhových ploch do sebe není v současné době podporováno.

Je návrhová plocha typ vrstvy?

Návrhové plochy si můžete představit jako speciální typ skupiny vrstev. Návrhové plochy jsou umístěny na panelu Vrstvy aplikace Photoshop stejně jako skupiny vrstev.

Je možné návrhové plochy vytvořit ve standardním dokumentu aplikace Photoshop?

Ano. Použijte funkci Návrhové plochy z vrstev.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online