Pro dobrý přehled v projektu je důležité dbát na organizaci vrstev a skupin. Vrstvy můžete přejmenovávat, pomocí barev označovat související vrstvy, ale také je můžete podle potřeby mazat nebo exportovat.

Přejmenování vrstvy nebo skupiny vrstev

Při přidávání vrstev nebo skupin vrstev do obrazu je užitečné pojmenovat je podle obsahu. Popisné názvy usnadňují identifikaci vrstev na panelu Vrstvy.

  1. Proveďte jeden z následujících úkonů:
    • Dvakrát klikněte na název vrstvy nebo skupiny na panelu Vrstvy a zadejte nový název. Stiskněte Enter.
    • Vyberte vrstvu nebo skupinu a proveďte tento postup:
      • Zvolte Vrstva> Přejmenovat vrstvu nebo Vrstva > Přejmenovat skupinu.
      • Na panelu Vrstvy zadejte nový název vrstvy nebo skupiny.
      • Stiskněte Enter.

Přiřazení barvy vrstvě nebo skupině

Barevným rozlišením vrstev a skupin si usnadníte hledání podobných vrstev na panelu Vrstvy. Jednoduše na vrstvu nebo skupinu klikněte pravým tlačítkem a vyberte barvu.

Rastrování vrstev

Kreslicí nástroje a filtry nemůžete použít na vrstvách, které obsahují vektorová data (například textové vrstvy, vrstvy tvarů a vektorové masky) a generovaná data (například vrstvy výplně). Tyto vrstvy ale můžete rastrovat a tím převést jejich obsah na normální rastrový obraz.

  1. Vyberte vrstvy, které chcete rastrovat, zvolte Vrstva > Rastrovat, a pak vyberte volbu z podnabídky:

    Text

    Rastruje text na textové vrstvě. Nerastruje žádná jiná vektorová data ve vrstvě.

    Tvar

    Rastruje vrstvu tvaru.

    Obsah vrstvy

    Rastruje jakoukoli výplň vrstvy tvaru a ponechá vektorovou masku.

    Vektorová maska

    Rastruje vektorovou masku ve vrstvě a změní ji na masku vrstvy.

    Inteligentní objekt

    Převede inteligentní objekt na rastrovou vrstvu.

    Video

    Rastruje aktuální snímek videa na obrazovou vrstvu.

    3D (pouze Photoshop Extended)

    Rastruje aktuální pohled 3D dat na sloučenou rastrovou vrstvu.

    Vrstva

    Rastruje všechna vektorová data ve vybraných vrstvách.

    Všechny vrstvy

    Rastruje všechny vrstvy, které obsahují vektorová a generovaná data.

    Poznámka:

    Chcete-li rastrovat svázané vrstvy, vyberte svázanou vrstvu, zvolte příkaz Vrstva > Vybrat svázané vrstvy, a pak rastrujte vybrané vrstvy.

Odstranění vrstvy nebo skupiny

Odstraněním vrstev, které již nepotřebujete, se zmenší velikost souboru obrazu.

Poznámka:

Chcete-li rychle odstranit prázdné vrstvy, vyberte položku Soubor > Skripty > Odstranit všechny prázdné vrstvy.

  1. Vyberte jednu nebo více vrstev nebo skupin z panelu Vrstvy.
  2. Proveďte jeden z následujících úkonů:
    • Chcete-li je odstranit s potvrzením, klikněte na ikonu Odstranit . Nebo zvolte příkaz Vrstva > Odstranit > Vrstva nebo zvolte příkaz Odstranit vrstvu nebo Odstranit skupinu z nabídky panelu Vrstvy.
    • Chcete-li vrstvu nebo skupinu smazat bez potvrzení, přetáhněte ji na ikonu Odstranit , klikněte s podrženou klávesou Alt na ikonu Odstranit nebo stiskněte klávesu Delete.
    • Chcete-li mazat skryté vrstvy, zvolte Vrstva > Odstranit > Skryté vrstvy.

    Poznámka:

    Chcete-li odstranit svázané vrstvy, vyberte svázanou vrstvu, zvolte Vrstva > Vybrat svázané vrstvy, a pak tyto vrstvy odstraňte.

Export vrstev

Můžete exportovat všechny vrstvy nebo viditelné vrstvy do samostatných souborů.

  1. Zvolte Soubor > Skripty > Exportovat vrstvy do souborů.

Sloučení vrstev

Po dokončení obsahu vrstev můžete vrstvy sloučit, abyste udrželi přijatelnou velikost obrazových souborů. Když vrstvy sloučíte, data z vyšších vrstev nahradí všechna data v nižších vrstvách, která překrývají. Průsečík všech průhledných oblastí sloučených vrstev zůstane průhledný.

Poznámka:

Jako cílovou vrstvu pro sloučení nemůžete použít vrstvu úprav ani vrstvu výplně.

Kromě sloučení vrstev je můžete také otisknout. Obtisknutí umožní sloučit obsah více vrstev do jedné cílové vrstvy a přitom ponechat ostatní vrstvy nedotčené.

Poznámka:

Když uložíte sloučený dokument, nemůžete se vrátit zpět ke stavu před sloučením; vrstvy jsou sloučené natrvalo.

Sloučení dvou vrstev nebo skupin

  1. Zkontrolujte, že vrstvy a skupiny, které chcete sloučit, jsou viditelné.
  2. Vyberte vrstvy a skupiny, které chcete sloučit.
  3. Zvolte Vrstva > Sloučit vrstvy.

Poznámka:

Dvě sousedící vrstvy nebo skupiny můžete sloučit tak, že vyberete horní položku a pak zvolíte příkaz Vrstva > Sloučit vrstvy. Svázané vrstvy můžete sloučit tak, že zvolíte příkaz Vrstva > Vybrat svázané vrstvy a pak sloučíte vybrané vrstvy. Dvě 3D vrstvy můžete sloučit tak, že zvolíte příkaz Vrstva > Sloučit vrstvy. Vrstvy budou sdílet stejnou scénu a horní vrstva zdědí 3D vlastnosti spodní vrstvy (aby to bylo možné, musí být pohledy kamer totožné).

Sloučení vrstev v ořezové masce

  1. Skryjte všechny vrstvy, které nechcete sloučit.
  2. Vyberte základní vrstvu v ořezové masce. Základní vrstva musí být rastrová vrstva.
  3. Zvolte Sloučit ořezovou masku z nabídky Vrstva nebo z nabídky panelu Vrstvy.

Další informace o ořezových maskách najdete v části Maskování vrstev ořezovými maskami.

Sloučení všech viditelných vrstev a skupin v obraze

  1. Vyberte z panelu Vrstvy nebo z nabídky panelu Vrstvy volbu Sloučit viditelné. Sloučí se všechny vrstvy se zobrazenou ikonou oka .

    Poznámka:

    Aby bylo možné použít příkaz Sloučit viditelné, musí být vybraná viditelná vrstva.

Obtisknutí více vrstev nebo svázaných vrstev

Když obtisknete více vybraných vrstev nebo svázaných vrstev, Photoshop vytvoří novou vrstvu obsahující sloučený obsah těchto vrstev.

  1. Vyberte více vrstev.
  2. Stiskněte Ctrl+Alt+E (Windows) nebo Apple+Alt+E (Mac OS).

Obtisknout všechny viditelné vrstvy najednou můžete takto:

  1. Zapněte viditelnost vrstev, které chcete sloučit.
  2. Stiskněte klávesy Shift+Ctrl+Alt+E (v systému Windows) nebo Shift+Apple+Alt+E (v systému Mac OS).

    Photoshop vytvoří novou vrstvu obsahující sloučený obsah.

Sloučení všech vrstev

Sloučení do jedné vrstvy zmenší velikost souboru sloučením všech viditelných vrstev do pozadí a vypuštěním skrytých vrstev. Všechny zbývající průhledné oblasti se vyplní bílou. Když uložíte sloučený obraz, nemůžete se vrátit zpět ke stavu před sloučením; vrstvy jsou sloučené natrvalo.

Poznámka:

Při převodu obrazu mezi některými barevnými režimy se vrstvy obrazu sloučí. Budete-li chtít obraz po převodu dále upravovat, uložte si jeho kopii obsahující všechny vrstvy.

  1. Zkontrolujte, zda jsou viditelné všechny vrstvy, které chcete zachovat.
  2. Zvolte příkaz Vrstva > Do jedné vrstvy nebo zvolte z nabídky panelu Vrstvy volbu Do jedné vrstvy.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online