Příručka uživatele Zrušit

Vytváření grafických souborů řízených daty

  1. Uživatelská příručka k aplikaci Photoshop
  2. Úvod do aplikace Photoshop
    1. Přetvořte své sny v realitu
    2. Co je nového v aplikaci Photoshop
    3. Úprava vaší první fotky
    4. Vytváření dokumentů
    5. Photoshop | Časté otázky
    6. Systémové požadavky aplikace Photoshop
    7. Seznamte se s aplikací Photoshop
  3. Photoshop a další produkty a služby Adobe
    1. Práce s kresbou aplikace Illustrator v aplikaci Photoshop
    2. Práce se soubory aplikace Photoshop v aplikaci InDesign
    3. Materiály aplikace Substance 3D pro Photoshop
    4. Použití rozšíření Capture v aplikaci Photoshop
  4. Photoshop na iPadu (není k dispozici v kontinentální Číně)
    1. Photoshop na iPadu | Časté otázky
    2. Seznámení s pracovní plochou
    3. Systémové požadavky | Photoshop na iPadu
    4. Vytváření, otevírání a export dokumentů
    5. Přidání fotografií
    6. Práce s vrstvami
    7. Kreslení a malování štětci
    8. Výběry a přidání masek
    9. Retušování kompozic
    10. Práce s vrstvami úprav
    11. Úprava tónů kompozice pomocí křivek
    12. Používání transformací
    13. Oříznutí a otočení kompozic
    14. Otáčení, posouvání, přiblížení a obnovení plátna
    15. Práce s textovými vrstvami
    16. Práce s aplikacemi Photoshop a Lightroom
    17. Získání chybějících písem v aplikaci Photoshop na iPadu
    18. Japonský text v aplikaci Photoshop na iPadu
    19. Správa nastavení aplikace
    20. Dotykové zkratky a gesta
    21. Klávesové zkratky
    22. Úprava velikosti obrázku
    23. Živý přenos během tvorby v aplikaci Photoshop na iPadu
    24. Opravy nedokonalostí pomocí retušovacího štětce
    25. Vytváření štětců v rozšíření Capture a jejich použití v aplikaci Photoshop na iPadu
    26. Práce se soubory Camera Raw
    27. Vytváření inteligentních objektů a práce s nimi
    28. Úprava expozice na snímcích pomocí možností Zesvětlení a Ztmavení
    29. Příkazy pro automatické úpravy v aplikaci Photoshop na iPadu
    30. Rozmazání oblastí obrazu pomocí aplikace Photoshop na iPadu
    31. Zvýšení nebo snížení sytosti obrazu pomocí nástroje Houba
    32. Výplň podle obsahu pro iPad
  5. Photoshop na webu (není k dispozici v kontinentální Číně)
    1. Časté otázky
    2. Systémové požadavky
    3. Klávesové zkratky
    4. Podporované typy souborů
    5. Úvod do pracovní plochy
    6. Otevření cloudových dokumentů a práce s nimi
    7. Funkce generativní umělé inteligence
    8. Základní koncepty úprav
    9. Rychlé akce
    10. Práce s vrstvami
    11. Retušování a odstraňování nedostatků
    12. Rychlé výběry
    13. Vylepšení obrazu pomocí vrstev úprav
    14. Přesouvání, transformace a oříznutí obrázků
    15. Kreslení a malování
    16. Práce s textovými vrstvami
    17. Spolupráce s uživateli na webu
    18. Správa nastavení aplikace
    19. Generování obrázků
    20. Generování pozadí
    21. Referenční obrázek
  6. Photoshop (beta) (není k dispozici v kontinentální Číně)
    1. Začínáme s betaverzemi aplikací Creative Cloud
    2. Photoshop (beta) na počítači
    3. Generování obrázku pomocí popisných textových pokynů
    4. Generování pozadí pomocí popisných textových pokynů
  7. Generativní umělá inteligence (není k dispozici v kontinentální Číně) 
    1. Časté týkající se generativní umělé inteligence v aplikaci Photoshop
    2. Generativní výplň v aplikaci Photoshop na počítači
    3. Generativní rozšíření v aplikaci Photoshop na počítači
    4. Generativní výplň v aplikaci Photoshop na iPadu
    5. Generativní rozšíření v aplikaci Photoshop na iPadu
    6. Funkce generativní umělé inteligence v aplikaci Photoshop na webu
  8. Autenticita obsahu (není k dispozici v kontinentální Číně)
    1. Pověření k obsahu v aplikaci Photoshop
    2. Identita a původ pro NFT
    3. Propojení účtů pro atribuci kreativního díla
  9. Dokumenty v cloudu (nejsou k dispozici v kontinentální Číně)
    1. Cloudové dokumenty aplikace Photoshop | Časté otázky
    2. Cloudové dokumenty aplikace Photoshop | Otázky k pracovním postupům
    3. Práce s cloudovými dokumenty a jejich správa v aplikaci Photoshop
    4. Upgrade cloudového úložiště pro aplikaci Photoshop
    5. Nelze vytvořit nebo uložit dokument v cloudu
    6. Řešení chyb dokumentů aplikace Photoshop v cloudu
    7. Shromažďování protokolů synchronizace cloudových dokumentů
    8. Pozvání uživatelů k úpravám cloudových dokumentů
    9. Sdílení souborů a komentářů v aplikaci
  10. Pracovní plocha
    1. Základy práce s pracovní plochou
    2. Předvolby
    3. Rychlejší učení s panelem Prohledávání aplikace Photoshop
    4. Vytváření dokumentů
    5. Vkládání souborů
    6. Výchozí klávesové zkratky
    7. Přizpůsobení klávesových zkratek
    8. Galerie nástrojů
    9. Předvolby výkonu
    10. Použití nástrojů
    11. Přednastavení
    12. Mřížka a vodítka
    13. Dotyková gesta
    14. Používání panelu Touch Bar s aplikací Photoshop
    15. Možnosti dotykového ovládání a přizpůsobitelné pracovní plochy
    16. Technologické náhledy
    17. Metadata a poznámky
    18. Možnosti dotykového ovládání a přizpůsobitelné pracovní plochy
    19. Umístění obrázků aplikace Photoshop do jiných aplikací
    20. Pravítka
    21. Zobrazení nebo skrytí netištěných doplňků
    22. Nastavení sloupců pro obraz
    23. Příkaz Zpět a historie
    24. Panely a nabídky
    25. Umísťování elementů pomocí přitahování
    26. Nastavení polohy nástrojem Pravítko
  11. Design webu, obrazovky a aplikací
    1. Photoshop pro vytváření návrhů
    2. Návrhové plochy
    3. Náhled v zařízení
    4. Kopírování CSS z vrstev
    5. Rozdělení webové stránky na řezy
    6. Volby HTML pro řezy
    7. Úprava rozvržení řezů
    8. Práce s webovou grafikou
    9. Vytváření webových fotogalerií
  12. Základy práce s obrázky a barvami
    1. Změna velikosti snímků
    2. Práce s rastrovými a vektorovými obrazy
    3. Velikost obrazu a rozlišení
    4. Načítání obrazů z fotoaparátů a skenerů
    5. Vytváření, otevírání a import obrazů
    6. Zobrazení obrázků
    7. Chyba neplatného markeru JPEG | Otevírání obrazů
    8. Zobrazování více obrazů
    9. Přizpůsobení dialogů pro výběr barvy a vzorků barev
    10. Obrázky s vysokým dynamickým rozsahem
    11. Srovnání barev v obraze
    12. Převádění mezi barevnými režimy
    13. Barevné režimy
    14. Vymazání částí obrazu
    15. Režimy prolnutí
    16. Výběr barev
    17. Úpravy tabulek indexovaných barev
    18. Informace o obrazu
    19. Nedostupné filtry deformace
    20. O barvách
    21. Úpravy barevných a monochromatických obrazů pomocí kanálů
    22. Výběr barev na panelech Barvy a Vzorník
    23. Vzorek
    24. Barevný režim (režim obrázku)
    25. Barevný nádech
    26. Přidání podmíněné změny režimu do akce
    27. Přidávání vzorků barev ze souborů HTML, CSS a SVG
    28. Bitová hloubka a předvolby
  13. Vrstvy
    1. Základy práce s vrstvami
    2. Nedestruktivní úpravy
    3. Vytváření a správa vrstev a skupin
    4. Výběr, seskupení a svázání vrstev
    5. Vložení obrázků do rámečku
    6. Krytí a prolnutí vrstev
    7. Maskování vrstev
    8. Aplikování inteligentních filtrů
    9. Kompozice vrstev
    10. Přesunutí, překrývání a zamykání vrstev
    11. Maskování vrstev pomocí vektorových masek
    12. Správa vrstev a skupin
    13. Efekty a styly vrstev
    14. Úpravy masek vrstev
    15. Extrahování datových zdrojů
    16. Odhalení vrstev s ořezovými maskami
    17. Generování obrazových datových zdrojů z vrstev
    18. Práce s inteligentními objekty
    19. Režimy prolnutí
    20. Zkombinování více obrazů do skupinového portrétu
    21. Spojování obrázků pomocí příkazu Automaticky prolnout vrstvy
    22. Zarovnání a rozmístění vrstev
    23. Kopírování CSS z vrstev
    24. Načítání výběrů z hranic vrstvy nebo z hranic masky vrstvy
    25. Odkrytí obsahu jiných vrstev vyseknutím
  14. Výběry
    1. Začínáme s výběry
    2. Provádění výběrů v kompozici
    3. Pracovní plocha Vybrat a maskovat
    4. Výběr pomocí nástrojů výběru
    5. Výběr pomocí nástrojů lasa
    6. Úpravy výběrů obrazových bodů
    7. Přesouvání, kopírování a odstraňování vybraných obrazových bodů
    8. Vytvoření dočasné rychlé masky
    9. Výběr rozsahu barev v obrázku
    10. Změna cest na hranice výběru a naopak
    11. Základní informace o kanálech
    12. Ukládání výběrů a masek alfa kanálů
    13. Výběr důležitých oblastí obrazu
    14. Duplikování, rozdělení a sloučení kanálů
    15. Výpočty s kanály
  15. Úpravy obrázků
    1. Nahrazení barev objektů
    2. Pokřivení perspektivy
    3. Redukce chvění fotoaparátu
    4. Příklady použití retušovacího štětce
    5. Export vyhledávacích tabulek barev
    6. Nastavení ostrosti a rozmazání obrazu
    7. Jak fungují úpravy barev
    8. Použití nastavení Jas a kontrast
    9. Úpravy detailů v oblastech stínů a světel
    10. Nastavení úrovní
    11. Nastavení odstínu a sytosti
    12. Úprava živosti
    13. Nastavení sytosti barev v oblastech obrazu
    14. Provádění rychlých úprav tónů
    15. Aplikování speciálních barevných efektů na obrazy
    16. Vylepšení obrázku pomocí úprav vyvážení barev
    17. Obrázky s vysokým dynamickým rozsahem
    18. Prohlížení histogramů a hodnot obrazových bodů
    19. Srovnání barev v obraze
    20. Oříznutí a narovnání fotografií
    21. Převedení barevného obrázku na černobílý
    22. Vrstvy úprav a vrstvy výplně
    23. Nastavení křivek
    24. Režimy prolnutí
    25. Příprava obrazů pro komerční tisk
    26. Nastavení barev a tónů pomocí kapátek Úrovně a Křivky
    27. Nastavení expozice a tónování HDR
    28. Zesvětlení nebo ztmavení určitých oblastí obrázku
    29. Nastavení selektivní barvy
  16. Adobe Camera Raw
    1. Systémové požadavky modulu Camera Raw
    2. Co je nového v modulu Camera Raw
    3. Úvod do aplikace Camera Raw
    4. Vytváření panoramat
    5. Podporované objektivy
    6. Efekty vinětování, zrnění a odstranění oparu v aplikaci Camera Raw
    7. Výchozí klávesové zkratky
    8. Automatická korekce perspektivy v Camera Raw
    9. Kruhový filtr v Camera Raw
    10. Správa nastavení nástroje Camera Raw
    11. Otevírání, zpracování a ukládání obrazů v aplikaci Camera Raw
    12. Oprava obrazů pomocí vylepšeného nástroje Odstranění bodů v aplikaci Camera Raw
    13. Otočení, oříznutí a úpravy obrazů
    14. Úprava vykreslení barev v aplikaci Camera Raw
    15. Verze zpracování v nástroji Camera Raw
    16. Vytváření místních úprav v modulu Camera Raw
  17. Oprava a obnovení obrázků
    1. Odebrání objektů z fotografií pomocí funkce Výplň podle obsahu
    2. Záplata a přesun podle obsahu
    3. Retušování a opravování fotografií
    4. Korekce deformace a šumu obrazu
    5. Základní postupy při řešení potíží, které pomohou vyřešit většinu problémů
  18. Vylepšení a transformace obrázku
    1. Nahrazení oblohy na snímcích
    2. Transformace objektů
    3. Nastavení oříznutí, otočení a velikosti plátna
    4. Oříznutí a narovnání fotografií
    5. Vytváření a úpravy panoramatických obrázků
    6. Pokřivení obrazů, tvarů a cest
    7. Úběžný bod
    8. Změna měřítka s ohledem na obsah
    9. Transformace obrázků, tvarů a cest
  19. Kreslení a malování
    1. Kreslení symetrických vzorů
    2. Kreslení obdélníků a úprava voleb tahu
    3. O kreslení
    4. Kreslení a úpravy tvarů
    5. Malovací nástroje
    6. Vytváření a úpravy štětců
    7. Režimy prolnutí
    8. Přidání barev k cestám
    9. Úpravy cest
    10. Malování míchacím štětcem
    11. Přednastavené stopy
    12. Přechody
    13. Interpolace přechodu
    14. Vyplnění a vytažení výběrů, vrstev a cest
    15. Kreslení pomocí nástrojů pera
    16. Vytváření vzorků
    17. Generování vzorku pomocí filtru Pattern Maker (Vytvořit vzorek)
    18. Správa cest
    19. Správa knihoven a přednastavení vzorků
    20. Kreslení nebo malování na grafickém tabletu
    21. Vytváření stop s texturami
    22. Přidávání dynamických prvků do stop štětců
    23. Přechod
    24. Malování stylizovaných tahů pomocí uměleckého štětce historie
    25. Malování vzorkem
    26. Synchronizace přednastavení na více zařízeních
    27. Migrace přednastavení, akcí a nastavení
  20. Text
    1. Přidání a úpravy textu
    2. Sjednocený textový modul
    3. Práce s písmy OpenType SVG
    4. Formátování znaků
    5. Formátování odstavců
    6. Vytváření textových efektů
    7. Úpravy textu
    8. Mezery mezi řádky a znaky
    9. Arabský a hebrejský text
    10. Písma
    11. Řešení potíží s písmy
    12. Asijský text
    13. Vytváření textu
  21. Filtry a efekty
    1. Použití galerie nástroje Rozostření
    2. Základy používání filtrů
    3. Přehled efektů filtrů
    4. Přidávání světelných efektů
    5. Použití filtru Adaptivní široký úhel
    6. Použití filtru Olejová malba
    7. Používání filtru Zkapalnění
    8. Efekty a styly vrstev
    9. Použití specifických filtrů
    10. Rozmazání oblastí obrazu
  22. Ukládání a export
    1. Ukládání souborů v aplikaci Photoshop
    2. Export souborů v aplikaci Photoshop
    3. Podporované formáty souborů
    4. Ukládání souborů v grafických formátech
    5. Přesouvání návrhů mezi aplikacemi Photoshop a Illustrator
    6. Ukládání a export videa a animací
    7. Ukládání souborů PDF
    8. Ochrana autorských práv systémem Digimarc
  23. Správa barev
    1. Principy správy barev
    2. Zachování shodných barev
    3. Nastavení barev
    4. Duplexy
    5. Práce s profily barev
    6. Správa barev v dokumentech pro zobrazování online
    7. Správa barev v dokumentech při tisku
    8. Správa barev pro importované obrazy
    9. Kontrolní náhled barev
  24. Design webu, obrazovky a aplikací
    1. Photoshop pro vytváření návrhů
    2. Návrhové plochy
    3. Náhled v zařízení
    4. Kopírování CSS z vrstev
    5. Rozdělení webové stránky na řezy
    6. Volby HTML pro řezy
    7. Úprava rozvržení řezů
    8. Práce s webovou grafikou
    9. Vytváření webových fotogalerií
  25. Video a animace
    1. Úpravy videa v aplikaci Photoshop
    2. Úpravy vrstev videa a animací
    3. Video a animace – přehled
    4. Zobrazení náhledu videa a animací
    5. Malování na snímky ve vrstvách videa
    6. Import videí a obrázkových sekvencí
    7. Vytváření animací snímků
    8. Creative Cloud 3D Animation (Náhled)
    9. Vytváření animací na časové ose
    10. Vytváření obrazů pro video
  26. Tisk
    1. Tisk 3D objektů
    2. Tisk z aplikace Photoshop
    3. Tisk se správou barev
    4. Stránky miniatur a prezentace PDF
    5. Tisk fotografií v rozvržení sady obrazů
    6. Tisk přímých barev
    7. Tisk obrazů na komerčních tiskových strojích
    8. Zvýšení kvality barevného tisku z aplikace Photoshop
    9. Řešení problémů s tiskem | Photoshop
  27. Automatizace
    1. Vytváření akcí
    2. Vytváření grafických souborů řízených daty
    3. Skriptování
    4. Zpracování dávky souborů
    5. Přehrávání a správa akcí
    6. Přidání podmíněných akcí
    7. O akcích a panelu Akce
    8. Záznam nástrojů v akcích
    9. Přidání podmíněné změny režimu do akce
    10. Sada nástrojů uživatelského rozhraní aplikace Photoshop pro moduly plug-in a skripty
  28. Řešení problémů
    1. Opravené problémy 
    2. Známé problémy
    3. Optimalizace výkonu aplikace Photoshop
    4. Základní postupy při řešení potíží
    5. Poradce při potížích s chybovým ukončením nebo zamrznutím aplikace
    6. Řešení chyb programu
    7. Řešení chyb zaplnění odkládacího disku
    8. Řešení problémů s grafickým procesorem a ovladačem grafické karty
    9. Vyhledání chybějících nástrojů
    10. Photoshop 3D | Časté otázky týkající se ukončených funkcí

Používání grafik řízených daty a práce se šablonami vytvořenými v aplikaci Photoshop

Představte si tuto situaci: 

Jste první týden v práci a potřebujete vytvořit pět verzí webového reklamního proužku s různými texty a obrázky pomocí jednoho návrhu šablony.

Věděli jste, že nejlepším způsobem, jak to udělat, bude grafika řízená daty?

Při vytváření konzistentních návrhů s různými texty a obrázky pomocí sad dat postupujte podle těchto obecných kroků:

  1. Vytvořte základní grafiku, kterou chcete použít jako šablonu. 

    K oddělení prvků, které chcete v grafice měnit, použijte vrstvy.

  2. Definujte v grafice proměnné. Jak víme, proměnné určují ty části obrazu, které je třeba měnit.

  3. Vytvořte nebo importujte sady dat. Sady dat můžete vytvořit v šabloně nebo je můžete importovat z textového souboru. 

  4. Zobrazte náhled dokumentu s každou sadou dat. Před exportem souboru zkontrolujte náhled, abyste se ujistili, jak bude výsledný obrázek vypadat. 

  5. Vygenerujte grafické soubory tím, že je exportujete s příslušnými daty. Doporučujeme použít formát Photoshop (PSD). 

    Použití proměnných k vytvoření různých verzí obrázku v aplikaci Photoshop
    Použití proměnných k vytvoření různých verzí obrázku

Proměnné

Pomocí proměnných můžete definovat, které prvky v šabloně se mají měnit. Můžete definovat tři typy proměnných.

Proměnné typu Viditelnost umožňují zobrazit nebo skrýt obsah vrstvy.

Proměnné typu Nahrazení textu umožňují nahradit textový řetězec v textové vrstvě.

Proměnné typu Nahrazení obrazových bodů umožňují nahradit obrazové body ve vrstvě obrazovými body z jiného obrazového souboru.

Poznámka:

Proměnné nelze definovat při práci s vrstvou Pozadí

Práce s proměnnou

  1. Přejděte na Obraz > Proměnné > Definovat.

  2. V rozbalovací nabídce Vrstva vyberte vrstvu s obsahem, který bude definován jako proměnná.

  3. Vyberte jeden nebo více typů proměnných: Viditelnost, Nahrazení obrazových bodůNahrazení textu.

    Viditelnost: Zobrazí nebo skryje obsah vrstvy nebo skupiny vrstev.

    Nahrazení obrazových bodů: Nahradí obrazové body ve vrstvě obrazovými body z jiného obrazového souboru.

    Nahrazení textu: Nahradí textový řetězec v textové vrstvě.

  4. Proveďte některou z následujících akcí:

    • Zadejte název proměnné do pole Název. Názvy proměnných můžou začínat písmenem, podtržítkem nebo dvojtečkou. Nesmí obsahovat mezery ani speciální znaky (s výjimkou tečky, pomlčky, podtržítka a dvojtečky).

      Nebo

    • Vyberte v rozbalovací nabídce Název existující proměnnou, se kterou chcete propojit tuto vrstvu. Vrstvy propojené se stejnou proměnnou se zobrazí vedle nabídky Název spolu s ikonou propojení.

  5. Při používání proměnných typu Nahrazení obrazových bodů postupujte následovně.

    1. Zvolte požadovanou metodu změny velikosti náhradního obrázku:
      • Metoda Přizpůsobit proporcionálně změní velikost obrazu tak, aby se vešel do ohraničovacího rámečku se zachováním proporcí.
      • Metoda Vyplnit změní velikost obrazu tak, aby vyplnil ohraničovací rámeček se zachováním proporcí. Obraz může v jednom směru přesahovat přes okraje.
      • Metoda Jak je zachová velikost náhradního obrazu. Ten může v jednom nebo obou směrech přesahovat přes okraje. 
      • Metoda Přizpůsobit neproporcionálně změní velikost obrazu tak, aby vyplnil ohraničovací rámeček. Nemusí se zachovat původní proporce. 
    2. Výběrem táhla v ikoně zarovnání zvolte zarovnání pro umístění obrazu uvnitř ohraničovacího rámečku. (Tato volba není dostupná pro metodu Přizpůsobit neproporcionálně.)
    3. Pokud zaškrtnete políčko Oříznout podle ohraničovacího rámečku, budou se moct oříznout oblasti obrazu, které se nevejdou do ohraničovacího rámečku. Tato volba je k dispozici, jen když vyberete metodu nahrazení Vyplnit nebo Jak je. (Tato volba není dostupná pro metodu Přizpůsobit neproporcionálně.)
    Metoda Přizpůsobit proporcionálně změní velikost obrazu tak, aby se vešel do ohraničovacího rámečku se zachováním proporcí.
    Metoda Přizpůsobit proporcionálně změní velikost obrazu tak, aby se vešel do ohraničovacího rámečku se zachováním proporcí.

  6. Pokud chcete definovat proměnné pro jinou vrstvu, zvolte vrstvu v rozbalovací nabídce Vrstva a vyberte OK.

    Vedle názvu vrstvy obsahující proměnné se zobrazí hvězdička. Mezi vrstvami se můžete pohybovat pomocí navigačních šipek.

Přejmenování proměnné

  1. Přejděte na Obraz > Proměnné > Definovat.

  2. V rozbalovací nabídce Vrstva zvolte vrstvu obsahující proměnnou.

  3. Chcete‑li proměnnou přejmenovat, zadejte nový název do textového pole Název.

    Názvy proměnných musí začínat písmenem, podtržítkem nebo dvojtečkou a nesmí obsahovat mezery nebo speciální znaky (s výjimkou tečky, pomlčky, podtržítka a dvojtečky).

  4. Zrušením výběru proměnné ji odeberete.

Sady dat

Sada dat je kolekce proměnných a s nimi spojených dat. Sadu dat můžete definovat pro každou verzi grafiky, kterou chcete generovat.

  1. Proveďte některou z následujících akcí:

    • Přejděte na Obraz > Proměnné > Sady dat

    Nebo

    • Pokud je otevřené dialogové okno Proměnné, vyberte možnost Sady dat v rozbalovací nabídce nebo klikněte na tlačítko Další.
    Poznámka:

    Před úpravou výchozí datové sady je třeba definovat alespoň jednu proměnnou. 

  2. Výběrem tlačítka Nová sada dat () můžete vytvořit novou sadu dat na základě aktuální sady dat.

  3. Vyberte proměnnou v rozevíracím seznamu Název.

  4. Upravte data proměnné:

    • Pro proměnné typu Viditelnost vyberte možnost Viditelná (pokud obsah vrstvy chcete zobrazit) nebo Neviditelná (pokud obsah vrstvy chcete skrýt).

    • Pro proměnné typu Nahrazení obrazových bodů zvolte Vybrat soubor a pak vyberte náhradní obrazový soubor. Chcete‑li nechat vrstvu v jejím současném stavu, zvolte před aplikováním sady dat možnost Nenahrazovat.

    Poznámka:

    Tlačítko Nenahrazovat nevrátí soubor do původního stavu v případě, že již předtím bylo použito jiné nahrazení.

    • Pro proměnné typu Nahrazení textu zadejte textový řetězec do textového pole Hodnota.
  5. Definujte další sady dat pro každou verzi grafiky, kterou chcete generovat.

Sadu dat můžete upravit, přejmenovat nebo odstranit tak, že ji vyberete v nabídce Sada dat a upravíte příslušné volby. Pro pohyb mezi sadami dat používejte ikony šipek. Chcete‑li sadu dat odstranit, klikněte na ikonu Odstranit.

Zobrazení náhledu nebo aplikování sady dat

Obsah sady dat můžete aplikovat na základní obraz a přitom nechat proměnné a sady dat nezměněné.

Tím se změní vzhled obrazu tak, aby obsahoval hodnoty sady dat. Pomocí možnosti Náhled si můžete prohlédnout, jak budou vypadat jednotlivé verze s jednotlivými sadami dat.

Pokud chcete vybrat sadu dat ze seznamu a zobrazit náhled obrazu v okně dokumentu, přejděte na Obraz > Aplikovat sadu dat.

Výběrem tlačítka Použít můžete sadu dat aplikovat. Pokud chcete jen zobrazit náhled a nechcete změnit základní obraz, vyberte tlačítko Zrušit.

Sadu dat můžete také aplikovat a zobrazit její náhled tak, že přejdete na Obraz > Proměnné > Sady dat a zaškrtnete políčko Náhled.

Poznámka:

Aplikováním sady dat se přepíše původní dokument.

Generování grafických souborů s použitím sady dat

Po nadefinování proměnných a jedné nebo více sad dat můžete pomocí hodnot v těchto sadách dat dávkově generovat výstupní obrazy. Vygenerovaný výstup bude ve formě souborů PSD.

  1. Přejděte na Soubor > Exportovat > Sady dat jako soubory.

  2. Zadejte základní název pro všechny generované soubory. Pokud chcete, můžete vytvořit své vlastní schéma pojmenování.
  3. Pomocí tlačítka Vybrat složku můžete pro soubory vybrat cílový adresář.

  4. Vyberte sady dat, které chcete exportovat, a zvolte OK.

Vytváření sad dat v externích souborech

Velký počet sad dat můžete rychle vytvořit tak, že použijete externí textový soubor, který obsahuje všechny informace o proměnných, a tento soubor naimportujete do souboru PSD obsahujícího proměnné.

Jedna z metod je zadat data do textového souboru nebo do tabulky v Microsoft Excelu a pak je exportovat do souboru s textem odděleným tabulátory nebo čárkami.

Syntaxe externího textového souboru je následující (každý řádek, který začíná názvem proměnné nebo hodnotou, je samostatný řádek v souboru):

NázevProměnné1<sep>NázevProměnné2<sep> <sep>NázevProměnnéN<nl> 
Hodnota1-1<sep>Hodnota2-1<sep> <sep>HodnotaN-1<nl> 
Hodnota1-2<sep>Hodnota2-2<sep> <sep>HodnotaN-2<nl> 
Hodnota1-M<sep>Hodnota2-M<sep> <sep>HodnotaN-M<nl>

Názvy všech proměnných jsou uvedené v prvním řádku a jejich hodnoty v následujících řádcích. Každý další řádek představuje jednu sadu dat s hodnotami pro všechny proměnné.

Poznámka:

Chcete-li vytvořit více řádků textu na jednom řádku textu v sadě dat, uzavřete text do uvozovek a do souboru odděleného tabulátory nebo čárkami vložte tvrdé konce řádků v místech, kde chcete mít konce řádků.  

Externí textový soubor Elementy syntaxe

<sep>

Čárka (soubor CSV) nebo tabulátor (text oddělený tabulátory) oddělující názvy nebo hodnoty proměnných

<nl>

Znak nového řádku, který ukončuje sadu dat, přičemž to může být znak LF, CR nebo oba

„true“ a „false“

Povolené hodnoty pro proměnné typu Viditelnost

Mezery

Mezery kolem oddělovačů se při analýze souboru odstraní; mezery mezi slovy v řetězci hodnoty (například dvě stejné za sebou) se zachovají; a mezery na začátku a na konci se zachovají, pokud jsou uzavřené v uvozovkách (například "jeden druh ").

Uvozovky

Můžou být součástí hodnoty, pokud je předchází ještě jedna uvozovka (např. ""B"" bude v sadě dat reprezentovat "B").

Pokud je <sep> nebo <nl> součástí hodnoty proměnné, musí být celá hodnota uzavřená do uvozovek.

Všechny proměnné definované v souboru PSD musí být definované v textovém souboru. V případě nesouladu mezi počtem proměnných v textovém souboru a v dokumentu se zobrazí chyba.

Příklad sady dat

Můžete třeba vytvořit textový soubor používající šablonu pro květiny, který obsahuje proměnné pro tulipány a slunečnice. Mohl by vypadat takto:

{contents of Květiny.txt} 
Proměnná 1, Proměnná 2, Proměnná 3 
true, TULIPÁN, c:\Dokumenty\tulipán.jpg 
false, SLUNEČNICE, c:\Dokumenty\slunečnice.jpg 
false, KALA, c:\Dokumenty\kala.jpg 
true, FIALKA, c:\Dokumenty\fialka.jpg
Poznámka:

Pokud je textový soubor ve stejné složce jako soubor obrazu, můžete pro umístění obrazů použít relativní cesty. Například poslední položka v příkladu může být: true, FIALKA, fialka.jpg.

Import sady dat

  1. Proveďte některou z následujících akcí:

    • Přejděte na Soubor > Importovat > Sady dat proměnných.

    Nebo

    • Přejděte na Obraz > Proměnné > Sady dat a pomocí tlačítka Importovat vyhledejte textový soubor k importu.
  2. Nastavte volby importu.

    • Použít první sloupec jako názvy sady dat: Nazve každou sadu dat pomocí obsahu prvního sloupce textového souboru (hodnoty pro první proměnnou v seznamu). Jinak se sady dat pojmenují Sada dat 1, Sada dat 2 a tak dál.
    • Nahradit stávající sady dat: Před importem odstraní všechny stávající sady dat.
  3. Nastavte kódování textového souboru nebo nechte nastavení na Automaticky a pak zvolte OK.

 Adobe

Získejte pomoc rychleji a snáze

Nový uživatel?

Adobe MAX 2024

Adobe MAX
Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX

Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX 2024

Adobe MAX
Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX

Konference věnovaná tvořivosti

14.–16. října Miami Beach a online