Dopasowywanie kolorów

Dopasowywanie kolorów na różnych obrazach

Polecenie Dopasuj kolor pozwala uzgodnić kolory pomiędzy różnymi obrazami, różnymi warstwami lub różnymi zaznaczeniami. Polecenie to umożliwia także korektę kolorów obrazu poprzez zmianę luminancji i zakresu kolorów oraz wyeliminowanie kolorowej poświaty. Polecenie Dopasuj kolor działa tylko w trybie RGB.

Uwaga:

Po wybraniu polecenia Dopasuj kolor wskaźnik zmienia się w kursor narzędzia Kroplomierz. Podczas dopasowywania obrazu można za pomocą narzędzia Kroplomierz sprawdzać na panelu Informacje wartości kolorów poszczególnych pikseli. Informacje te pozwalają obserwować zmiany wartości kolorów w wyniku stosowania polecenia Dopasuj kolor. Zobacz Wyświetlanie wartości kolorów na obrazie.

Polecenie Dopasuj kolor pozwala dopasować kolory jednego obrazu (obrazu źródłowego) do kolorów innego obrazu (obrazu docelowego). Jest ono przydatne, gdy trzeba utrzymać spójność kolorów na różnych zdjęciach albo dopasować określone kolory jednego obrazu (na przykład kolory karnacji) do kolorów innego obrazu.

Oprócz uzgadniania kolorów pomiędzy obrazami polecenie Dopasuj kolor pozwala uzgadniać kolory między poszczególnymi warstwami tego samego obrazu.

Dopasowywanie kolorów dwóch obrazów

  1. (Opcjonalnie) Utwórz zaznaczenia na obrazie źródłowym i docelowym.

    Jeżeli nie utworzy się zaznaczenia, dopasowanie będzie miało za podstawę ogólne dane statystyczne o kolorystyce obrazów.

  2. Uaktywnij obraz, który chcesz zmienić, a następnie wybierz polecenie Obraz > Dopasowania > Dopasuj kolor.

    Jeżeli polecenie Dopasuj kolor jest stosowane do konkretnej warstwy na obrazie docelowym, należy pamiętać o wcześniejszym uaktywnieniu tej warstwy.

  3. Z menu Źródło (w sekcji Statystyki obrazka w oknie dialogowym Dopasuj kolor) wybierz obraz źródłowy, na podstawie którego będą dopasowywane kolory obrazu docelowego. Jeżeli w trakcie korekty kolorów program ma nie korzystać z innego obrazu, wybierz opcję Brak. Gdy opcja Brak jest zaznaczona, obraz docelowy jest zarazem obrazem źródłowym.

    Jeżeli to konieczne, wybierz z menu Warstwa tę warstwę obrazu źródłowego, która ma stanowić podstawę dopasowania kolorów. Z menu Warstwa możesz wybrać też opcję Złączone, która pozwala dopasować kolory na podstawie wszystkich warstw obrazu źródłowego.

  4. Jeżeli na obrazie utworzono zaznaczenie, wykonaj przynajmniej jedną z następujących czynności:
    • Jeżeli korekta ma dotyczyć całego obrazu, to w sekcji Obraz docelowy zaznacz opcję Ignoruj zaznaczenie jeśli stosowane jest dopasowanie. Spowoduje to zignorowanie zaznaczenia na obrazie docelowym: korekta zostanie zastosowana do całego obrazu docelowego.

    • Jeżeli w obrazie źródłowym utworzono zaznaczenie, możesz zaznaczyć opcję Użyj zaznaczenia w pliku źródłowym do obliczania kolorów (w sekcji Statystyki obrazu), co spowoduje użycie kolorów z tego zaznaczenia do wykonania obliczeń korekcyjnych. Nie zaznaczenie tej opcji spowoduje zignorowanie zaznaczenia w obrazie źródłowym: do obliczeń korekcyjnych użyte zostaną kolory z całego obrazu źródłowego.

    • Jeżeli w obrazie docelowym utworzono zaznaczenie, można zaznaczyć opcję Użyj zaznaczenia w pliku docelowym do obliczania kolorów (w sekcji Statystyki obrazu), co spowoduje użycie kolorów z tego zaznaczenia do wykonania obliczeń korekcyjnych. Nie zaznaczenie tej opcji spowoduje zignorowanie zaznaczenia w obrazie docelowym: do obliczeń korekcyjnych użyte zostaną kolory z całego obrazu docelowego.

  5. Aby automatycznie wyeliminować kolorową poświatę z obrazu docelowego, zaznacz opcję Neutralizuj. Upewnij się, że opcja Podgląd jest zaznaczona — gwarantuje to, że obraz będzie uaktualniany w miarę wprowadzania kolejnych dopasowań.
  6. Przeciągnij suwak Luminancja, aby zwiększyć lub zmniejszyć jasność obrazu docelowego. Można także wprowadzić wartość w polu Luminancja. Maksymalna dopuszczalna wartość to 200, wartość minimalna to 1, a wartość domyślna to 100.
  7. Przeciągnij suwak Intensywność koloru, aby skorygować nasycenie kolorów w obrazie docelowym. Można także wprowadzić wartość w polu Intensywność koloru. Maksymalna dopuszczalna wartość to 200, wartość minimalna to 1 (powstaje obraz w skali szarości), a wartość domyślna to 100.
  8. Przeciągnij suwak Zanik, aby zmienić intensywność korekty obrazu. Przesunięcie suwaka w prawo zmniejsza intensywność korekty.
  9. Kliknij przycisk OK.

Dopasowywanie kolorów na dwóch warstwach tego samego obrazu

  1. (Opcjonalnie) Utwórz zaznaczenie na warstwie, która ma zostać dopasowana. Ta metoda jest przydatna podczas dopasowywania obszaru kolorów (na przykład odcieni skóry na twarzy) z jednej warstwy do obszaru na innej warstwie.

    Jeżeli nie zostanie utworzone zaznaczenie, kolory zostaną dopasowane na całej warstwie źródłowej.

  2. Upewnij się, że warstwa docelowa (do której chcesz zastosować dopasowanie koloru) jest aktywna, a następnie wybierz polecenie Obraz > Dopasowania > Dopasuj kolor.
  3. W menu Źródło (w sekcji Statystyki obrazu w oknie dialogowym Dopasuj kolor) upewnij się, że obraz źródłowy jest tożsamy z obrazem docelowym.
  4. Z menu Warstwa wybierz tę warstwę, która ma stanowić podstawę dopasowania kolorów. W menu Warstwa możesz także wybrać opcję Scalone, co spowoduje dopasowanie kolorów ze wszystkich warstw.
  5. Jeżeli na obrazie utworzono zaznaczenie, wykonaj przynajmniej jedną z następujących czynności:
    • Jeżeli korekta ma dotyczyć całej warstwy docelowej, to w sekcji Obraz docelowy zaznacz opcję Ignoruj zaznaczenie jeśli stosowane jest dopasowanie. Spowoduje to zignorowanie zaznaczenia na warstwie docelowej: korekta zostanie zastosowana do całej warstwy docelowej.

    • Jeżeli w obrazie źródłowym utworzono zaznaczenie, możesz zaznaczyć opcję Użyj zaznaczenia w pliku źródłowym do obliczania kolorów (w sekcji Statystyki obrazka), co spowoduje użycie kolorów z tego zaznaczenia do wykonania obliczeń korekcyjnych. Usuń zaznaczenie tej opcji, aby zignorować zaznaczenie na warstwie źródłowej i użyć kolorów z całej tej warstwy do obliczenia dopasowania.

    • Jeżeli podstawę obliczeń korekcyjnych mają stanowić tylko kolory z zaznaczonego obszaru warstwy docelowej, zaznacz opcję Użyj zaznaczenia w pliku docelowym do obliczania kolorów (w sekcji Statystyki obrazu). Opcji nie należy zaznaczać, aby zignorować zaznaczenie i obliczyć korektę na podstawie kolorów z całej warstwy docelowej.

  6. Aby automatycznie wyeliminować kolorową poświatę z warstwy docelowej, zaznacz opcję Neutralizuj. Upewnij się, że opcja Podgląd jest zaznaczona — gwarantuje to, że obraz będzie uaktualniany w miarę wprowadzania kolejnych dopasowań.

  7. Przeciągnij suwak Luminancja, aby zwiększyć lub zmniejszyć jasność warstwy docelowej. Można także wprowadzić wartość w polu Luminancja. Maksymalna dopuszczalna wartość to 200, wartość minimalna to 1, a wartość domyślna to 100.
  8. Przeciągnij suwak Intensywność koloru, aby skorygować nasycenie kolorów na warstwie docelowej. Można także wprowadzić wartość w polu Intensywność koloru. Maksymalna dopuszczalna wartość to 200, wartość minimalna to 1 (powstaje obraz w skali szarości), a wartość domyślna to 100.
  9. Przesuń suwak Zanik, aby zmienić intensywność korekty obrazu. Przesunięcie suwaka w prawo zmniejsza intensywność korekty.
  10. Kliknij przycisk OK.

Zapisywanie i stosowanie ustawień w oknie Dopasuj kolor

  • Przejdź do sekcji Statystyki obrazka w oknie dialogowym Dopasuj kolor i kliknij przycisk Zapisz statystyki. Nazwij i zapisać ustawienia.
  • Przejdź do sekcji Statystyki obrazu w oknie dialogowym Dopasuj kolor i kliknij przycisk Wczytaj statystyki. Odszukaj i wczytaj zapisany plik ustawień.

Zastępowanie kolorów

Zastępowanie kolorów obiektów obrazu

Program Photoshop udostępnia wiele technik zastępowania kolorów obiektów. Dużą elastyczność i dobre wyniki można osiągnąć, stosując do wybranych obiektów dopasowanie Barwa/Nasycenie. Mniej elastyczne, ale wygodnie zgrupowane opcje są dostępne w oknie dialogowym Zastąp kolor. Szybką pracę przy mniejszej dokładności umożliwia narzędzie Zastępowanie kolorów.

Samouczek wideo: Zmienianie koloru obiektu

Samouczek wideo: Zmienianie koloru obiektu
Deke McClelland

Stosowanie dopasowania Barwa/Nasycenie do zaznaczonych obiektów

Najczęściej ta elastyczna technika pozwala w najlepszy sposób zastąpić kolory. Warstwy masek i dopasowania są bezpieczne, dzięki czemu można później swobodnie dopasować efekty. Niepowtarzalna opcja Koloruj pozwala wprowadzać bezwzględne zmiany kolorów (zamiast zmian względnych, co zapobiega zabarwianiu kolorami pierwotnymi).

  1. Zaznacz obiekt, który ma zostać zmieniony. Narzędzie Szybkie zaznaczanie często daje dobre rezultaty. Dodatkowe techniki opisano w artykułach Zaznaczanie zakresu kolorów i Dostosowywanie krawędzi zaznaczenia.

  2. Kliknij ikonę Barwa/Nasycenie w panelu Dopasowania.

    Zaznaczenie stanie się maską w warstwie dopasowania.

  3. W panelu Właściwości zmień ustawienia Barwa i Nasycenie, aby zastąpić kolory obiektu. Jeśli kolor pierwotny zabarwia nowy kolor, zaznacz opcję Koloruj i ponownie dopasuj ustawienia. (Zobacz Dopasowywanie odcieni i nasycenia).

    Uwaga:

    Pozostawiając wartość ustawienia Jasność równą zero, można zachować kontrast. Aby zachować zarówno kontrast, jak i nasycenie, wybierz tryb mieszania barwy dla warstwy dopasowania.

  4. W razie konieczności powiększ lub zmniejsz obszar objęty efektem, malując na masce kolorem białym lub czarnym. (Zobacz Edytowanie maski warstwy).

Więcej informacji można znaleźć w artykule Omówienie panelu Dopasowania.

Korzystanie z okna dialogowego Zastąp kolor

Okno dialogowe Zastąp kolor łączy narzędzia do zaznaczania zakresu kolorów z suwakami barwy, nasycenia i jasności, dzięki którym można zastąpić kolor. Nowy kolor można wybrać w próbniku kolorów.

Okno dialogowe Zastąp kolor nie zawiera dostępnej w dopasowaniu Barwa/Nasycenie opcji Koloruj, która może być potrzebna w celu całkowitego zastąpienia koloru. Technika oparta na warstwie dopasowania może być łatwiejsza w użyciu w przypadku zmieniania określonych obiektów. Polecenie Zastąp kolor jest przydatne podczas globalnego zmieniania kolorów, szczególnie przy zmianach kolorów spoza palety przed drukowaniem.

  1. Wybierz polecenie Obraz > Dopasowania > Zastąp kolor.
  2. (Opcjonalnie) W przypadku zaznaczania podobnych, sąsiadujących kolorów na obrazie wybierz opcję Zlokalizowane klastry kolorów, aby uzyskać dokładniejszą maskę.
  3. Wybierz opcję podglądu:

    Zaznaczenie

    W polu podglądu jest wyświetlana maska. Obszary maskowane mają kolor czarny, a obszary bez maski — biały. Obszary zamaskowane częściowo (pokryte maską półprzezroczystą) są wyświetlane w różnych odcieniach szarości, stosownie do stopnia krycia.

    Obraz

    W polu podglądu jest wyświetlany obraz. Opcja jest przeznaczona do pracy nad powiększonym obrazem lub pracy w warunkach ograniczonego miejsca na ekranie.

  4. Aby zaznaczyć kolory, które chcesz zastąpić, użyj narzędzia Kroplomierz . Kliknij nim na obrazie lub w polu podglądu i zaznacz obszary, na które nałożona zostanie maska.
  5. Aby poprawić zaznaczenie, wykonaj dowolną z następujących czynności:
    • Aby dodać obszary, kliknij z wciśniętym klawiszem Shift lub użyj narzędzia kroplomierza Dodaj do próbki .

    • Aby usunąć obszary, kliknij z wciśniętym klawiszem Alt (Windows), kliknij z wciśniętym klawiszem Option (Mac OS) lub użyj narzędzia kroplomierza Odejmij od próbki .

    • Kliknij próbkę Kolor zaznaczenia, aby otworzyć próbnik kolorów. Ustaw kolor docelowy, który ma zostać zastąpiony, korzystając z próbnika kolorów. Wybór koloru powoduje uaktualnienie maski w polu podglądu.

  6. Przeciągnij suwak Nieostrość lub wpisz wartość Nieostrość, aby kontrolować stopień, w jakim powiązane kolory będą dodawane do zaznaczenia.
  7. Wybierz kolor Zastępowanie, wykonując następujące czynności:
    • Przeciągnij suwaki Barwa, Nasycenie lub Jasność (lub wprowadzić wartości w odpowiednich polach tekstowych).

    • Dwukrotnie kliknij próbkę Wynik, a następnie wybierz kolor docelowy z próbnika kolorów.

    Uwaga:

    Nie można zastąpić kolorem czystego odcienia szarości, czerni ani koloru białego. Można zamiast tego zmienić ustawienie Jasność. (Ustawienia Barwa i Nasycenie są względne w stosunku do istniejących kolorów, dlatego w tym przypadku nie działają).

  8. (Opcjonalnie) Kliknij przycisk Zapisz, aby zapisać ustawienia w celu wczytania ich później dla innych obrazów.

Korzystanie z narzędzia Zastępowanie kolorów

Narzędzie Zastępowanie kolorów pozwala zamalować określony kolor kolorem zastępczym. To narzędzie umożliwia szybkie edytowanie, ale często nie daje odpowiednich efektów, szczególnie w przypadku ciemnych kolorów i czerni. Jeśli eksperymenty z opcjami narzędzi nie przyniosą dobrych wyników, zapoznaj się z artykułem Dopasowywanie barwy i nasycenia.

Narzędzie Zastępowanie kolorów nie działa w trybie bitmapy, koloru indeksowanego lub koloru wielokanałowego.

  1. Wybierz narzędzie Zastępowanie kolorów . (Jeśli narzędzie nie jest widoczne, można uzyskać do niego dostęp, przytrzymując naciśnięty przycisk narzędzia Pędzel.)
  2. Na pasku opcji wybierz końcówkę pędzla,. W większości sytuacji tryb mieszania powinien być ustawiony na Kolor.
  3. Wybierz jedno z następujących ustawień opcji Próbka:

    Ciągłe 

    Kolory są próbkowane w sposób ciągły, w miarę przeciągania.

    Raz 

    Kolor docelowy jest zastępowany tylko na obszarach zawierających pierwszy kliknięty kolor.

    Próbka tła 

    Wymazywane są tylko obszary zawierające bieżący kolor tła.

  4. Z menu Ograniczenia wybierz jedną z następujących opcji:

    Nieciągłe

    Próbkowany kolor jest zastępowany w każdym miejscu, które znajdzie się pod wskaźnikiem.

    Ciągłe

    Zastępowane są kolory przylegające do koloru znajdującego się bezpośrednio pod kursorem.

    Szukanie krawędzi

    Zastępowane są połączone obszary zawierające próbkowany kolor; zostaje zachowana ostrość krawędzi kształtów.

  5. Aby zastępować kolory bardzo podobne do koloru klikniętego piksela, wybierz niską wartość procentową opcji Tolerancja. Aby zastępować szerszy zakres kolorów, wybierz wyższą wartość procentową.
  6. Aby wygładzić krawędzie korygowanych obszarów, zaznacz opcję Wygładzony.
  7. Wybierz kolor narzędzia, który ma zastąpić niepożądany kolor. (Zobacz Wybieranie kolorów z przybornika).
  8. Na obrazie, kliknij kolor, który ma zostać zastąpiony.
  9. Przeciągnij kursorem narzędzia po wybranym obszarze obrazu, aby zastąpić niepożądany kolor.

Uwaga:

Jeśli zakres zastępowanych kolorów jest zbyt mały, zwiększ ustawienie Tolerancja na pasku opcji.

Selektywne mieszanie kolorów

Dopasowania koloru selektywnego

Selektywna korekta koloru jest techniką stosowaną w profesjonalnych skanerach i programach rozbarwiających. Służy do zmieniania liczby kolorów podstawowych we wszystkich składnikach podstawowych kolorów obrazu. Ilość koloru podstawowego w innym kolorze zmienia się selektywnie—bez wpływu na inne kolory podstawowe. Na przykład, opisaną technikę można wykorzystać do zmniejszenia ilości koloru niebieskozielonego w zielonym składniku kolorów i jednoczesnego utrzymania dotychczasowych proporcji koloru niebieskozielonego w składowej niebieskiej.

Chociaż podczas korekty selektywnej są wykorzystywane kolory CMYK, technikę tę można stosować także do obrazów RGB.

  1. Upewnij się, że na panelu Kanały jest zaznaczony kanał kompozytowy. Dopasowanie Kolor selektywny jest dostępne tylko podczas wyświetlania kanału kompozytowego.
  2. Wykonaj jedną z następujących czynności:
    • Kliknij ikonę Kolor selektywny w panelu Dopasowania.

    • Wybierz polecenie Warstwa > Nowa warstwa dopasowania > Kolor selektywny. W oknie dialogowym Nowa warstwa kliknij przycisk OK.

    Uwaga:

    Można też wybrać polecenie Obraz > Dopasowania > Kolor selektywny. Używanie tej metody powoduje stosowanie dopasowań bezpośrednio do warstwy obrazu i usuwanie informacji z obrazu.

  3. Wykonaj jedną z następujących czynności:
    • Wybierz kolor, który chcesz dopasować, z menu Kolory w panelu Właściwości. Można również wybrać zapisane wcześniej ustawienie predefiniowane.

    • Wybierz ustawienie predefiniowane Kolor selektywny z menu Ustawienia predefiniowane w panelu Właściwości.

  4. Wybierz metodę w panelu Właściwości:

    Względnie

    Są dopasowywane aktualne wartości CMYK (niebieskozielony, karmazynowy, żółty i czarny). Na przykład, piksel zawierający 50% koloru karmazynowego po korekcie o 10% będzie zawierał 55% koloru karmazynowego (10% z 50% to 5%). (Czysta biel nie może być dopasowana tą metodą, ponieważ nie ma składowych kolorowych.)

    Absolutny

    Są dopasowywane wartości bezwzględne kolorów. Na przykład, piksel zawierający 50% koloru karmazynowego po korekcie o 10% będzie miał 60% koloru karmazynowego.

    Uwaga:

    Dopasowanie opiera się na odległości koloru od jednego ze wskazanych punktów korekty. Na przykład, piksel zawierający 50% karmazynowego jest położony dokładnie pomiędzy bielą i czystym kolorem karmazynowym, w związku z czym jego korekta będzie sumą korekt przewidzianych dla tych dwóch kolorów.  

  5. Przeciągnij suwaki, zmniejszając lub zwiększając udział składowych w wybranym kolorze.

    Można też zapisać ustawienia utworzone dla dopasowania Kolor selektywny, a następnie użyć ich z innymi obrazami.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online