Podręcznik użytkownika Anuluj

Cofanie i historia

  1. Podręcznik użytkownika programu Photoshop
  2. Wprowadzenie do programu Photoshop
    1. Dream it. Make it.
    2. Nowości w programie Photoshop
    3. Edytowanie pierwszego zdjęcia
    4. Tworzenie dokumentów
    5. Photoshop | Częste pytania
    6. Wymagania systemowe programu Photoshop
    7. Migracja ustawień predefiniowanych, operacji i ustawień
    8. Poznaj program Photoshop
  3. Program Photoshop a inne produkty i usługi firmy Adobe
    1. Korzystanie z kompozycji programu Illustrator w programie Photoshop
    2. Korzystanie z plików programu Photoshop w programie InDesign
    3. Materiały Substance 3D w programie Photoshop
    4. Program Photoshop a usługa Adobe Stock
    5. Używanie rozszerzenia Capture w programie Photoshop
    6. Biblioteki Creative Cloud
    7. Biblioteki Creative Cloud w programie Photoshop
    8. Używanie paska Touch Bar w programie Photoshop
    9. Siatka i linie pomocnicze
    10. Tworzenie operacji
    11. Cofanie i historia
  4. Photoshop na tablet iPad
    1. Photoshop na tablet iPad | Częste pytania
    2. Zapoznanie z przestrzenią roboczą
    3. Wymagania systemowe | Photoshop na tablet iPad
    4. Tworzenie, otwieranie i eksportowanie dokumentów
    5. Dodawanie zdjęć
    6. Korzystanie z warstw
    7. Rysowanie i malowanie przy użyciu pędzli
    8. Tworzenie zaznaczeń i dodawanie masek
    9. Retuszowanie kompozycji
    10. Korzystanie z warstw dopasowania
    11. Dopasowanie odcieni kompozytów przy użyciu krzywych
    12. Stosowanie przekształceń
    13. Kadrowanie i obracanie obrazów kompozytowych
    14. Obracanie, przesuwanie, powiększanie i zerowanie obszaru roboczego
    15. Korzystanie z warstw tekstowych
    16. Korzystanie z programów Photoshop i Lightroom
    17. Pobieranie brakujących czcionek w programie Photoshop na tablecie iPad
    18. Tekst w języku japońskim w programie Photoshop na tablecie iPad
    19. Zarządzanie ustawieniami aplikacji
    20. Skróty i gesty dotykowe
    21. Skróty klawiaturowe
    22. Edytowanie rozmiaru obrazu
    23. Nadawanie na żywo podczas tworzenia w programie Photoshop na tablecie iPad
    24. Retuszowanie niedoskonałości za pomocą narzędzia Pędzel korygujący
    25. Tworzenie pędzli w rozszerzeniu Capture i używanie ich w programie Photoshop
    26. Praca z plikami Camera Raw
    27. Tworzenie i używanie obiektów inteligentnych
    28. Modyfikowanie ekspozycji obrazów przy użyciu funkcji rozjaśniania i ściemniania
  5. Photoshop w Internecie (beta)
    1. Często zadawane pytania | Photoshop w Internecie (beta)
    2. Wprowadzenie do przestrzeni roboczej
    3. Wymagania systemowe | Photoshop w Internecie (beta)
    4. Skróty klawiaturowe | Photoshop w Internecie (beta)
    5. Obsługiwane typy plików | Photoshop w Internecie (beta)
    6. Otwieranie plików w chmurze i korzystanie z nich
    7. Współpraca z uczestnikami projektu
    8. Stosowanie ograniczonych zmian do plików w chmurze
  6. Pliki w chmurze
    1. Pliki w chmurze — Photoshop | Częste pytania
    2. Pliki w chmurze — Photoshop | Pytania dotyczące obiegów pracy
    3. Zarządzanie plikami w chmurze i korzystanie z nich w programie Photoshop
    4. Zwiększanie ilości przestrzeni dyskowej dla programu Photoshop
    5. Nie można utworzyć ani zapisać pliku w chmurze
    6. Rozwiązywanie błędów z plikami w chmurze programu Photoshop
    7. Zbieranie dzienników synchronizacji plików w chmurze
    8. Udostępnianie i wspólne edytowanie plików w chmurze
    9. Udostępnianie plików i komentowanie w aplikacji
  7. Przestrzeń robocza
    1. Podstawy pracy z przestrzenią roboczą
    2. Szybsza nauka dzięki panelowi Odkrywanie w programie Photoshop
    3. Tworzenie dokumentów
    4. Używanie paska Touch Bar w programie Photoshop
    5. Galerie narzędzi
    6. Preferencje wydajności
    7. Korzystanie z narzędzi
    8. Gesty dotykowe
    9. Funkcje dotykowe i dostosowywanie obszarów roboczych
    10. Zapowiedzi technologii
    11. Metadane i uwagi
    12. Domyślne skróty klawiaturowe
    13. Funkcje dotykowe i dostosowywanie obszarów roboczych
    14. Umieszczanie obrazów programu Photoshop w innych aplikacjach
    15. Preferencje
    16. Domyślne skróty klawiaturowe
    17. Miarki
    18. Pokazywanie i ukrywanie dodatków niedrukowanych
    19. Określanie kolumn dla obrazu
    20. Cofanie i historia
    21. Panele i menu
    22. Umieszczanie plików
    23. Rozmieszczanie elementów za pomocą przyciągania
    24. Określanie położenia przy użyciu narzędzia Miarka
    25. Ustawienia predefiniowane
    26. Dostosowywanie skrótów klawiszowych
    27. Siatka i linie pomocnicze
  8. Projektowanie stron internetowych, materiałów ekranowych i aplikacji
    1. Photoshop dla projektantów
    2. Obszary kompozycji
    3. Podgląd urządzenia
    4. Kopiowanie kodu CSS z warstw
    5. Cięcie stron internetowych na plasterki
    6. Opcje HTML dotyczące plasterków
    7. Modyfikowanie układu plasterków
    8. Korzystanie z grafiki internetowej
    9. Tworzenie internetowych galerii zdjęć
  9. Podstawowe informacje o obrazie i kolorach
    1. Zmienianie rozmiarów obrazów
    2. Korzystanie z obrazów rastrowych i wektorowych
    3. Rozmiar a rozdzielczość obrazu
    4. Pozyskiwanie obrazów z aparatów fotograficznych i skanerów
    5. Tworzenie, otwieranie i importowanie obrazów
    6. Wyświetlanie obrazów
    7. Błąd nieprawidłowego znacznika JPEG | Otwieranie obrazów
    8. Wyświetlanie wielu obrazów
    9. Dostosowywanie próbników kolorów i próbek
    10. Obrazy HDR
    11. Dopasowywanie kolorów na obrazie
    12. Konwertowanie obrazów z jednego trybu kolorów na inny
    13. Tryby kolorów
    14. Wymazywanie części obrazu
    15. Tryby mieszania
    16. Wybieranie kolorów
    17. Dostosowywanie tablic kolorów indeksowanych
    18. Informacje o obrazie
    19. Filtry zniekształcania są niedostępne
    20. Informacje o kolorach
    21. Dopasowania kolorowe i monochromatyczne przy użyciu kanałów
    22. Wybieranie kolorów w panelach Kolor i Próbki
    23. Próbka
    24. Tryb kolorów (tryb obrazu)
    25. Poświata kolorowa
    26. Dodawanie warunkowej zmiany trybu do operacji
    27. Dodawanie próbek z arkuszy CSS HTML i plików SVG
    28. Głębia bitowa i preferencje
  10. Warstwy
    1. Podstawy pracy z warstwami
    2. Bezpieczna edycja
    3. Tworzenie warstw i grup oraz zarządzanie nimi
    4. Zaznaczanie, grupowanie i łączenie warstw
    5. Umieszczanie obrazów w ramkach
    6. Krycie warstw i mieszanie
    7. Warstwy masek
    8. Stosowanie filtrów inteligentnych
    9. Kompozycje warstw
    10. Przenoszenie, układanie i blokowanie warstw
    11. Maskowanie warstw przy użyciu masek wektorowych
    12. Zarządzanie warstwami i grupami
    13. Efekty i style warstw
    14. Edytowanie masek warstw
    15. Wyodrębnianie zasobów
    16. Odsłanianie warstw przy użyciu masek przycinających
    17. Generowanie zasobów obrazów z warstw
    18. Korzystanie z obiektów inteligentnych
    19. Tryby mieszania
    20. Łączenie kilku obrazów w portret grupowy
    21. Łączenie obrazów przy użyciu automatycznego mieszania warstw
    22. Wyrównywanie i rozmieszczanie warstw
    23. Kopiowanie kodu CSS z warstw
    24. Wczytywanie zaznaczeń z warstwy lub obramowania maski warstw
    25. Odcinanie w celu odkrycia zawartości innych warstw
    26. Warstwa
    27. Spłaszczanie
    28. Obrazy kompozytowe
    29. Tło
  11. Zaznaczenia
    1. Przestrzeń robocza zaznaczania i maskowania
    2. Szybkie zaznaczanie
    3. Podstawy zaznaczania
    4. Zaznaczanie narzędziami do zaznaczania prostokątnego
    5. Zaznaczanie przy użyciu narzędzi Lasso
    6. Zaznaczanie zakresu kolorów na obrazie
    7. Dopasowywanie zaznaczeń pikseli
    8. Konwertowanie pomiędzy ścieżkami i krawędziami zaznaczenia
    9. Podstawy stosowania kanałów
    10. Przenoszenie, kopiowanie i usuwanie zaznaczonych pikseli
    11. Tworzenie tymczasowej szybkiej maski
    12. Zapisywanie zaznaczeń i masek kanału alfa
    13. Zaznaczanie ostrych obszarów obrazu
    14. Powielanie, dzielenie i scalanie kanałów
    15. Obliczenia dotyczące kanałów
    16. Zaznaczenie
    17. Obwiednia
  12. Dopasowywanie obrazów
    1. Wypaczenie perspektywy
    2. Redukcja rozmyć wywołanych potrząśnięciami aparatu
    3. Przykłady użycia narzędzia Pędzel korygujący
    4. Eksportowanie tablic wyszukiwania kolorów
    5. Dopasowywanie ostrości i rozmycia obrazu
    6. Omówienie dopasowań kolorów
    7. Stosowanie dopasowania Jasność/Kontrast
    8. Dopasowywanie szczegółów cieni i obszarów oświetlonych
    9. Dopasowanie Poziomy
    10. Dopasowywanie barwy i nasycenia
    11. Dopasowanie jaskrawości
    12. Dopasowywanie nasycenia koloru na obszarach obrazu
    13. Szybkie dopasowania tonalne
    14. Stosowanie do obrazów specjalnych efektów kolorów
    15. Ulepszanie obrazu przy użyciu korekt balansu kolorów
    16. Obrazy HDR
    17. Wyświetlanie histogramów i wartości pikseli
    18. Dopasowywanie kolorów na obrazie
    19. Kadrowanie i prostowanie zdjęć
    20. Konwertowanie obrazów kolorowych na czarno-białe
    21. Warstwy dopasowań i wypełnień
    22. Dopasowywanie krzywych
    23. Tryby mieszania
    24. Przygotowywanie obrazów do druku
    25. Dopasowywanie kolorów i odcieni obrazu przy użyciu kroplomierzy Poziomy i Krzywe
    26. Dopasowywanie ekspozycji i tonowania obrazu HDR
    27. Filtr
    28. Rozmycie
    29. Rozjaśnianie lub ściemnianie obszarów obrazu
    30. Dopasowania koloru selektywnego
    31. Zastępowanie kolorów obiektu
  13. Adobe Camera Raw
    1. Wymagania systemowe wtyczki Camera Raw
    2. Nowości we wtyczce Camera Raw
    3. Wprowadzenie do wtyczki Camera Raw
    4. Tworzenie obrazów panoramicznych
    5. Obsługiwane obiektywy
    6. Efekty winiety, ziarnu i usuwania zmętnienia atmosferycznego we wtyczce Camera Raw
    7. Domyślne skróty klawiaturowe
    8. Automatyczna korekcja perspektywy we wtyczce Camera Raw
    9. Edytowanie z zachowaniem danych oryginału we wtyczce Camera Raw
    10. Filtr promieniowy we wtyczce Camera Raw
    11. Zarządzanie ustawieniami wtyczki Camera Raw
    12. Otwieranie, przetwarzanie i zapisywanie obrazów we wtyczce Camera Raw
    13. Naprawa obrazów za pomocą ulepszonego narzędzia Usuwanie plam we wtyczce Camera Raw
    14. Obracanie, kadrowanie i dopasowywanie obrazów
    15. Dopasowywanie renderowania koloru we wtyczce Camera Raw
    16. Podsumowanie funkcji | Adobe Camera Raw | Wydania z 2018 r.
    17. Podsumowanie nowych funkcji
    18. Wersje procesu we wtyczce Camera Raw
    19. Wprowadzanie lokalnych dopasowań we wtyczce Camera Raw
  14. Naprawianie i przywracanie obrazów
    1. Usuwanie obiektów ze zdjęć przy użyciu funkcji Wypełnij z uwzględnieniem zawartości
    2. Uwzględniające zawartość narzędzia Łatka i Przesuwanie
    3. Retuszowanie i naprawianie zdjęć
    4. Korygowanie zniekształceń i szumu na obrazie
    5. Podstawowe czynności pozwalające rozwiązać większość problemów
  15. Przekształcenia obrazów
    1. Przekształcanie obiektów
    2. Dopasowywanie kadrowania, obrotów i obszaru roboczego
    3. Kadrowanie i prostowanie zdjęć
    4. Tworzenie i edytowanie obrazów panoramicznych
    5. Wypaczanie obrazów, kształtów i ścieżek
    6. Punkt zbiegu
    7. Korzystanie z filtra Formowanie
    8. Skalowanie z uwzględnieniem zawartości
    9. Przekształcanie obrazów, kształtów i ścieżek
    10. Wypaczenie
    11. Przekształcanie
    12. Panorama
  16. Rysowanie i malowanie
    1. Malowanie wzorków symetrycznych
    2. Rysowanie prostokątów i modyfikowanie opcji obrysu
    3. Informacje o rysowaniu
    4. Rysowanie i edytowanie kształtów
    5. Narzędzia do malowania
    6. Tworzenie i modyfikowanie pędzli
    7. Tryby mieszania
    8. Dodawanie koloru do ścieżek
    9. Edytowanie ścieżek
    10. Malowanie za pomocą pędzla mieszającego
    11. Pędzle predefiniowane
    12. Gradienty
    13. Interpolacja gradientów
    14. Wypełnianie oraz obrysowywanie zaznaczeń, warstw i ścieżek
    15. Rysowanie narzędziami Pióro
    16. Tworzenie wzorków
    17. Generowanie wzorku przy użyciu wtyczki Tworzenie wzorku
    18. Zarządzanie ścieżkami
    19. Zarządzanie bibliotekami i wzorkami predefiniowanymi
    20. Rysowanie lub malowanie przy użyciu tabletów graficznych
    21. Tworzenie pędzli z teksturami
    22. Dodawanie dynamicznych elementów do pędzli
    23. Gradient
    24. Malowanie stylizowanych pociągnięć pędzlem przy użyciu narzędzia Artystyczny pędzel historii
    25. Malowanie wzorkiem
    26. Synchronizacja ustawień predefiniowanych między urządzeniami
  17. Tekst
    1. Dodawanie i edytowanie tekstu
    2. Jednolity mechanizm tekstowy
    3. Korzystanie z czcionek SVG OpenType
    4. Formatowanie znaków
    5. Formatowanie akapitów
    6. Tworzenie efektów tekstowych
    7. Edytowanie tekstu
    8. Odstępy między wierszami i między znakami
    9. Tekst arabski i hebrajski
    10. Czcionki
    11. Rozwiązanie problemów z czcionkami
    12. Tekst azjatycki
    13. Tworzenie tekstu
    14. Błąd mechanizmu wyszukiwania w tekście podczas używania narzędzia do pisania w programie Photoshop | Windows 8
  18. Wideo i animacja
    1. Edytowanie materiałów wideo w programie Photoshop
    2. Edytowanie warstw wideo i animacji
    3. Omówienie zagadnień dotyczących wideo i animacji
    4. Wyświetlanie podglądu wideo i animacji
    5. Malowanie klatek na warstwach wideo
    6. Importowanie plików wideo i sekwencji obrazów
    7. Tworzenie animacji poklatkowych
    8. Creative Cloud 3D Animation (zapowiedź)
    9. Tworzenie animacji z osią czasu
    10. Tworzenie obrazów do materiałów wideo
  19. Filtry i efekty
    1. Korzystanie z filtra Formowanie
    2. Korzystanie z galerii rozmyć
    3. Podstawowe informacje dotyczące filtrów
    4. Dokumentacja efektów filtrów
    5. Dodawanie efektów świetlnych
    6. Korzystanie z filtra Adaptacyjny szeroki kąt
    7. Korzystanie z filtra Farba olejna
    8. Efekty i style warstw
    9. Stosowanie określonych filtrów
    10. Smużenie obszarów obrazu
  20. Zapisywanie i eksportowanie
    1. Zapisywanie plików w programie Photoshop
    2. Eksportowanie plików w programie Photoshop
    3. Obsługiwane formaty plików
    4. Zapisywanie plików w formatach graficznych
    5. Przenoszenie projektów między programami Photoshop i Illustrator
    6. Zapisywanie i eksportowanie materiałów wideo i animacji
    7. Zapisywanie plików PDF
    8. Technologia ochrony praw autorskich Digimarc
  21. Drukowanie
    1. Drukowanie obiektów 3D
    2. Drukowanie w programie Photoshop
    3. Drukowanie z zastosowaniem zarządzania kolorami
    4. Stykówki i prezentacje PDF
    5. Drukowanie zdjęć w układzie pakietu obrazów
    6. Drukowanie kolorów dodatkowych
    7. Bichromia
    8. Profesjonalne drukowanie obrazów
    9. Poprawianie jakości wydruków w kolorze z programu Photoshop
    10. Rozwiązywanie problemów z drukowaniem | Photoshop
  22. Automatyzacja
    1. Tworzenie operacji
    2. Tworzenie grafiki zależnej od danych
    3. Korzystanie ze skryptów
    4. Przetwarzanie wsadowe plików
    5. Odtwarzanie operacji i zarządzanie nimi
    6. Dodawanie operacji warunkowych
    7. Informacje o operacjach i panelu Operacje
    8. Nagrywanie narzędzi w operacjach
    9. Dodawanie warunkowej zmiany trybu do operacji
    10. Zestaw narzędzi do tworzenia wtyczek i skryptów interfejsu programu Photoshop
  23. Zarządzanie kolorami
    1. Omówienie zarządzania kolorami
    2. Utrzymywanie spójności kolorów
    3. Ustawienia kolorów
    4. Korzystanie z profilów kolorów
    5. Zarządzanie kolorami dokumentów przeznaczonych do wyświetlania w Internecie
    6. Zarządzanie kolorami w dokumentach podczas drukowania
    7. Zarządzanie kolorami w przypadku obrazów importowanych
    8. Próby kolorów
  24. Content Authenticity
    1. Informacje o poświadczeniach zawartości
    2. Identyfikacja i pochodzenie tokenów NFT
    3. Łączenie kont na potrzeby uznania udziału w pracy twórczej
  25. Grafika 3D i techniczne przetwarzanie obrazów
    1. Photoshop 3D | Często zadawane pytania dotyczące wycofanych funkcji 3D
    2. Creative Cloud 3D Animation (zapowiedź)
    3. Drukowanie obiektów 3D
    4. Malowanie 3D
    5. Ulepszenia panelu 3D | Photoshop
    6. Podstawowe pojęcia i narzędzia związane z grafiką 3D
    7. Renderowanie i zapisywanie grafiki 3D
    8. Tworzenie obiektów i animacji 3D
    9. Stosy obrazów
    10. Obieg pracy z grafiką 3D
    11. Pomiary
    12. Pliki DICOM
    13. Programy Photoshop i MATLAB
    14. Zliczanie obiektów na obrazie
    15. Łączenie i konwertowanie obiektów 3D
    16. Edytowanie tekstur 3D
    17. Dopasowywanie ekspozycji i tonowania obrazu HDR
    18. Ustawienia panelu 3D

W tym artykule omówiono sterowanie stanem obrazów w programie Adobe Photoshop przy użyciu poleceń cofania i ponawiania operacji oraz panelu Historia.

Polecenia cofania i ponawiania oraz panel Historia ułatwiają sterowanie stanem obrazów.

Stosowanie poleceń Cofnij i Ponów

Zaktualizowane w programie Photoshop CC 20.0 (październik 2018)

Od wersji z października 2018 — Photoshop CC (20.0) — można cofać wiele kroków wykonanych w dokumencie programu Photoshop, korzystając ze skrótu Control + Z (Windows) / Command + Z (macOS). Nowy tryb wielokrotnego cofania jest domyślnie włączony.

Aby cofnąć lub ponownie wykonać operację, wykonaj następujące czynności:

  • Cofnij: cofa jeden krok w łańcuchu cofania. Wybierz polecenie Edycja > Cofnij lub użyj skrótu klawiaturowego Control + Z (Windows) / Command + Z (macOS).
  • Ponów: przechodzi o jeden krok do przodu. Wybierz polecenie Edycja > Ponów lub użyj skrótu klawiaturowego Shift + Control + Z (Windows) / Shift + Command + Z (macOS).

Menu Edycja zawiera też nazwę kroku, który zostanie cofnięty lub wykonany przy następnym użyciu polecenia Cofnij lub Ponów. Na przykład może być dostępne polecenie Edycja > Cofnij Edycja tekstu.

(Photoshop)

Aby przywrócić starszy tryb cofania w programie Photoshop, wykonaj następujące czynności:

  1. Na pasku menu wybierz polecenie Edycja > Skróty klawiaturowe.
  2. W oknie dialogowym Skróty klawiszowe i menu wybierz opcję Używaj starszych skrótów klawiaturowych i kliknij przycisk OK.
  3. Uruchom ponownie program Photoshop.

(Adobe Camera Raw)

Aby przywrócić starszy tryb cofania we wtyczce Adobe Camera Raw, wykonaj następujące czynności:

  1. Na pasku menu programu Photoshop wybierz polecenie Edycja > Preferencje > Obsługa plików.
  2. W obszarze Zgodność pliku kliknij opcję Preferencje wtyczki Camera Raw.
  3. W oknie dialogowym Preferencje wtyczki Camera Raw zaznacz opcję Używaj starszych skrótów cofania i kliknij przycisk OK.
  4. Uruchom ponownie program Photoshop.

Przywracanie ostatnio zapisanej wersji

  1. Wybierz polecenie Plik > Przywróć.
    Uwaga:

    Informacje dotyczące przywracania są dodawane jako stan historii do panelu Historia, co umożliwia cofnięcie operacji.

Przywróć część obrazu do poprzednio zapisanej wersji

  1. Wykonaj jedną z następujących czynności:
    • Użyj narzędzia Pędzel historii , aby malować stanem historii lub migawką wybraną na palecie Historia.

    • Użyj narzędzia Gumka  z zaznaczoną opcją Wymaż do historii.

    • Zaznacz obszar przeznaczony do odtworzenia i wybierz polecenie Edycja > Wypełnij. W polu Użyj wybierz opcję Historia i kliknij OK.

    Uwaga:

    Aby odtworzyć obraz przy użyciu migawki początkowego stanu dokumentu, wybierz polecenie Opcje historii z menu panelu i upewnij się, że jest zaznaczona opcja Automatyczne tworzenie pierwszej migawki.

Anulowanie operacji

  1. Przytrzymaj wciśnięty klawisz Esc, aż do zatrzymania operacji. W systemie Mac OS można także wcisnąć klawisze Command+kropka.

Powiadomienie o zakończeniu operacji

Pasek wykonywanej operacji wskazuje stopień jej zaawansowania. Użytkownik może przerwać wykonywanie operacji. Może też ustawić preferencję powiadamiania o zakończeniu operacji.

  1. Wykonaj jedną z następujących czynności: Wybierz polecenie Edycja > Preferencje > Ogólne (Windows) albo Photoshop > Preferencje > Ogólne (Mac OS).

  2. Zaznacz opcję Sygnał po zakończeniu.
  3. Kliknij przycisk OK.

Korzystanie z panelu Historia

Korzystając z panelu Historia, można przejść do dowolnego niedawnego stanu obrazu utworzonego w trakcie bieżącej sesji. Po każdej zmianie obrazu do panelu jest dodawany nowy stan obrazu.

Jeśli na przykład część obrazu zostanie zaznaczona, pomalowana i obrócona, każdy z tych stanów zostanie wyświetlony na tym panelu. Można będzie wówczas zaznaczyć dowolny z tych stanów, a obraz powróci do takiego wyglądu, jaki miał przy pierwszym zastosowaniu danej zmiany. Potem można pracować dalej.

Panel Historia może być używany do usuwania stanów obrazu. W programie Photoshop można za jego pomocą utworzyć dokument na podstawie stanu lub migawki.

Aby wyświetlić panel Historia, wybierz polecenie Okno > Historia lub kliknij zakładkę panelu Historia.

Panel Historia programu Photoshop
Panel Historia programu Photoshop

A. Ustalenie źródła dla pędzla historii B. Miniaturka migawki C. Stan historii D. Suwak stanu historii 

Korzystając z panelu Historia, należy pamiętać o następujących kwestiach:

  • Zmiany obejmujące cały program (zmiany paneli, ustawień kolorów, operacji i preferencji) nie są zmianami stosowanymi do konkretnego obrazu, dlatego nie są odzwierciedlane na panelu Historia.

  • Domyślnie panel Historia obejmuje 20 wcześniejszych stanów obrazu. Maksymalną liczbę zapamiętywanych stanów określa się za pomocą odpowiedniej preferencji (Preferencje > Wydajność). Wcześniejsze stany są automatycznie usuwane, aby zwolnić pamięć programu Photoshop. Aby utrzymać wybrany stan w czasie całej sesji, zrób migawkę stanu. Zobacz Wykonywanie migawki obrazu.

  • Po zamknięciu i ponownym otwarciu dokumentu wszystkie stany i migawki z ostatniej sesji są usuwane z tego panelu.

  • Domyślnie u góry panelu jest wyświetlana migawka początkowego stanu dokumentu.

  • Stany są dodawane na końcu listy. Znaczy to, że najwcześniejszy stan znajduje się na początku listy, a ostatnio wprowadzony, na końcu.

  • Do każdego stanu jest dołączana nazwa użytego narzędzia lub polecenia.

  • Zaznaczenie danego stanu powoduje wyszarzenie stanów widocznych poniżej. W ten sposób z łatwością można zauważyć, które zmiany zostaną usunięte, jeśli praca będzie kontynuowana od zaznaczonego stanu.

  • Zaznaczenie pewnego stanu i wprowadzenie zmian do obrazu powoduje usunięcie z palety wszystkich stanów, które następowały po nim (ustawienie domyślne).

  • Po zaznaczeniu stanu i wprowadzeniu zmian do obrazu można użyć polecenia Cofnij, które spowoduje cofnięcie ostatnio wprowadzonej zmiany i przywrócenia stanów usuniętych z palety.

  • Usunięcie zaznaczonego stanu powoduje usunięcie stanów, które następują po nim (ustawienie domyślne). Jeśli jednak jest zaznaczona opcja Historia nieliniowa, usunięcie zaznaczonego stanu dotyczy tylko tego stanu.

Przywracanie poprzedniego stanu obrazu

  1. Wykonaj jedną z następujących czynności:
    • Kliknij nazwę stanu.

    • Aby przejść do następnego lub poprzedniego stanu, wybierz z menu panelu Historia lub z menu Edycja polecenie Krok do przodu lub Krok do tyłu.

Usunięcie stanu lub stanów obrazu

  1. Wykonaj jedną z następujących czynności:
    • Aby usunąć zmianę i wszystkie kolejne, kliknij nazwę stanu i wybierz polecenie Usuń z menu panelu Historia.

    • Aby usunąć zmianę i wszystkie kolejne, przeciągnij stan na ikonę Usuń .

    • Aby usunąć listę stanów z panelu Historia bez zmieniania obrazu, wybierz polecenie Wyczyść historię z menu panelu Historia. Ta opcja nie zmniejsza ilości pamięci używanej przez program Photoshop.

    • Aby wyczyścić listę stanów bez zmieniania obrazu, przytrzymaj naciśnięty klawisz Alt (Windows) lub Option (Mac OS) i wybierz polecenie Wyczyść historię z menu panelu. Jeśli na ekranie pojawi się komunikat o braku pamięci, polecenie to może okazać się użyteczne, ponieważ powoduje usunięcie stanów z bufora Cofnij i zwolnienie pamięci. Polecenia Wyczyść historię nie można cofnąć.

    • Aby wyczyścić listę stanów dla wszystkich otwartych dokumentów, wybierz polecenie Edycja > Wyczyść > Historia. Czynności tej nie można cofnąć.

Tworzenie lub zastępowanie dokumentu dokument na podstawie stanu obrazu

  1. Wykonaj jedną z następujących czynności:
    • Przeciągnij stan albo migawkę na przycisk Utwórz dokument na podstawie stanu obecnego w panelu Historia. Lista historii dla nowo utworzonego dokumentu zawiera tylko wpis Powiel stan.

    • Zaznacz stan lub migawkę i kliknij przycisk Utwórz dokument na podstawie stanu obecnego . Lista historii dla nowo utworzonego dokumentu zawiera tylko wpis Powiel stan.

    • Zaznacz stan lub migawkę i wybierz z menu panelu Historia polecenie Nowy dokument. Lista historii dla nowo utworzonego dokumentu zawiera tylko wpis Powiel stan.

    • Przeciągnąć stan na istniejący dokument.

    Uwaga:

    Aby zapisać jedno lub więcej migawek lub stanów obrazu potrzebnych do późniejszej edycji, utwórz i zapisz nowy plik dla każdego zachowanego stanu. Po ponownym otwarciu oryginalnego pliku otwórz także inne zapisane pliki. Początkową migawkę każdego pliku można przeciągnąć na oryginalny obraz, uzyskując na panelu Historia oryginalnego obrazu dostęp do migawek.

Ustawianie opcji historii

Można określić maksymalną liczbę elementów uwzględnianych na panelu Historia i ustawić inne opcje panelu.

  1. Z menu panelu Historia wybierz polecenie Opcje historii.
  2. Wybierz opcję:

    Automatyczne tworzenie pierwszej migawki

    Przy otwieraniu dokumentu jest tworzona migawka pierwszego stanu.

    Automatyczne tworzenie nowej migawki podczas zapisywania

    Przy każdym zapisywaniu pliku jest tworzona migawka.

    Historia nieliniowa

    Wprowadzanie zmian w zaznaczonym stanie nie powoduje usunięcia stanów, które pierwotnie nastąpiły po nim. Standardowo po zaznaczeniu stanu i wprowadzeniu zmian wszystkie stany następujące po nim są usuwane. Dzięki tej opcji panel Historia może zawierać listę etapów edycji w takiej kolejności, w jakiej były przeprowadzane. Funkcja rejestrowania stanów w sposób nieliniowy umożliwia zaznaczenie pewnego stanu, wprowadzenie zmian i usunięcie tylko tego stanu. Zmiana jest dopisywana na końcu listy.

    Domyślnie pokaż okno dialogowe Nowa migawka

    Wymusza w programie Photoshop monitowanie o nazwy migawek nawet w przypadku, gdy są używane przyciski panelu.

    Wyłącz cofanie zmian widoczności warstw

    Ta opcja jest domyślnie zaznaczona. Przełączanie widoczności warstwy jest rejestrowane jako krok w historii. Aby nie uwzględniać zmian widoczności warstw jako kroków historii, usuń zaznaczenie tej opcji.

Ustaw opcje Dziennika historii zmian

Program Photoshop umożliwia monitorowanie zmian wprowadzanych w pliku — czy to na własne potrzeby, czy do przedstawienia klientowi, czy też ze względu na wymagania prawne. Służy do tego Dziennik historii zmian, który zawiera w postaci tekstowej historię wszystkich czynności edycyjnych. Metadane dziennika historii zmian można wyświetlać za pomocą programu Adobe Bridge albo w oknie dialogowym Informacje o pliku.

Tekst ten można wyeksportować do zewnętrznego pliku dziennika albo zapisać w metadanych edytowanych plików. Przechowywanie historii zmian edycyjnych w postaci metadanych zwiększa rozmiar pliku, a w konsekwencji wydłuża czas jego otwierania i zapisywania.

Uwaga:

Jeżeli konieczne jest zagwarantowanie, że plik dziennika nie został w żaden sposób naruszony, zachowaj go w metadanych pliku. Następnie użyj programu Adobe Acrobat i umieść w pliku dziennika podpis elektroniczny.

Dane o historii poszczególnych sesji są zapisywane domyślnie w postaci metadanych osadzonych w pliku obrazu. Przede wszystkim można określić, czy dane takie mają być w ogóle zapisywane, a jeśli tak, określić stopień ich szczegółowości.

  1. Wybierz polecenie Edycja > Preferencje > Ogólne (Windows) albo Photoshop > Preferencje > Ogólne (Mac OS).
  2. Kliknij preferencje Dziennika historii, aby go włączyć lub wyłączyć.
  3. Wybierz jedno z następujących ustawień opcji Zapisz dziennik w:

    Metadane

    Dane są zapisywane w postaci metadanych osadzonych w każdym pliku.

    Plik tekstowy

    Eksportuj Dziennik historii do pliku tekstowego. Program monituje o podanie nazwy pliku tekstowego i wyborze miejsca zapisania pliku.

    Obie

    Są zapisywane metadane i jest tworzony plik tekstowy.

    Uwaga:

    Aby zapisać plik tekstowy w innym miejscu lub zapisać inny plik tekstowy, kliknij przycisk Wybierz, wybierz miejsce zapisania pliku, określ jego nazwę (w razie potrzeby) i kliknij Zapisz.

  4. Z wysuwanego menu Dziennik zmian wybrać jedną z następujących opcji:

    Sesje

    Rejestruje pozycje dla każdego uruchomienia i zamknięcia programu Photoshop, a także każdego otwarcia i zamknięcia plików (zapisywana jest nazwa każdego pliku obrazu). Nie są rejestrowane żadne informacje o zmianach zawartości pliku.

    Skrócony

    Dołącza do informacji o sesjach tekst pojawiający się na panelu Historia.

    Szczegółowy

    Dołącza do informacji skróconych tekst pojawiający się na panelu Operacje. Aby była rejestrowana pełna historia zmian plików, wybierz opcję Szczegółowy.

Tworzenie migawki obrazu

Polecenie Migawka pozwala na utworzenie czasowej kopii (lub migawki) dowolnego stanu obrazu. Nowa migawka jest dodawana do listy migawek w górnej części panelu Historia. Zaznaczenie migawki pozwala na kontynuację pracy od danej wersji obrazu.

Migawki przypominają stany dostępne na liście panelu Historia, ale w porównaniu z nimi mają następujące zalety:

  • Migawce można nadać nazwę, a to ułatwia jej identyfikację.

  • Migawki mogą być przechowywane w trakcie całej sesji.

  • Ułatwiają porównywanie efektów. Na przykład, możesz zrobić jedną migawkę obrazu przed zastosowaniem filtra, a drugą — po jego zastosowaniu. Następnie możesz zaznaczyć pierwszą migawkę i wypróbować ten sam filtr z innymi ustawieniami. Być może takie porównania pozwolą dokonać najlepszego wyboru.

  • Migawki umożliwiają powrót do wybranego etapu pracy. Przed rozpoczęciem sekwencji bardziej skomplikowanych i nie do końca znanych operacji, warto zrobić migawkę. Jeśli wynik tych operacji nie będzie zadawalający, zawsze można będzie wrócić do migawki (czyli cofnąć wykonane operacje).

Uwaga:

Migawki nie są zachowywane wraz z obrazem. Zamknięcie obrazu powoduje usunięcie migawek. Jeśli nie jest zaznaczona opcja Zezwalaj na historię nieliniową, wybranie migawki i wprowadzenie zmian na obrazie powoduje usunięcie wszystkich stanów wyświetlanych na liście panelu Historia.

Utwórz migawkę

  1. Zaznacz stan i wykonaj jedną z następujących czynności:
    • Aby automatycznie utworzyć migawkę, kliknij przycisk Utwórz nową migawkę w panelu Historia lub (w razie zaznaczenia opcji historii Automatyczne tworzenie nowej migawki podczas zapisywania) wybierz polecenie Nowa migawka z menu panelu Historia.

    • Aby ustawić opcje podczas tworzenia migawki, wybierz polecenie Nowa migawka z menu panelu Historia lub kliknij przycisk Utwórz nową migawkę, trzymając wciśnięty klawisz Alt (Windows) albo Option (Mac OS).

  2. Wprowadź nazwę migawki w polu tekstowym Nazwa.

  3. Określ zawartość migawki za pomocą menu Z:

    Pełny dokument

    Migawka obejmuje wszystkie warstwy obrazu (w danym stanie).

    Warstwy scalone

    Migawka obejmuje wszystkie warstwy obrazu, ale zostają one złączone (w danym stanie).

    Bieżąca warstwa

    Migawka obejmuje tylko zaznaczoną warstwę obrazu (w danym stanie).

Praca z migawkami

  1. Wykonaj jedną z następujących czynności:
    • Aby zaznaczyć migawkę, kliknij jej nazwę lub przeciągnij suwak migawki (po jego lewej stronie) w kierunku innej migawki.

    • Aby zmienić nazwę migawki, dwukrotnie kliknij zdjęcie i wpisz jego nazwę.

    • Aby usunąć migawkę, zaznacz ją, a następnie wybierz polecenie Usuń z menu panelu, kliknij ikonę Usuń  albo przeciągnij migawkę na ikonę Usuń.

Malowanie na podstawie stanu lub migawki obrazu

Narzędzie Pędzel historii  służy do kopiowania wybranego stanu lub migawki obrazu do okna bieżącego obrazu. Program tworzy kopię lub próbkę obrazu, a następnie użytkownik maluje przy jej pomocy.

Na przykład, można zrobić migawkę zmiany wprowadzonej narzędziem malarskim lub filtrem (przy wykonywaniu migawki zaznaczona musi być opcja Pełny dokument). Po jej cofnięciu może zastosować zmianę miejscowo, przy użyciu Pędzla historii. Dopóki nie zaznaczyłeś migawki połączone, narzędzie Pędzel historii maluje z warstwy w zaznaczonym stanie na tę samą warstwę o innym stanie.

Narzędzie Pędzel historii kopiuje z jednego stanu lub migawki do drugiego, ale tylko w tym samym miejscu. W programie Photoshop możesz również malować Artystycznym pędzlem historii, który pozwala tworzyć efekty specjalne.

  1. Wybierz Narzędzie Pędzel historii  .
  2. Na pasku opcji wykonaj jedną z następujących czynności:
    • Określ krycie i tryb mieszania.

    • Wybierz pędzel i jego opcje.

  3. Na panelu Historia kliknij lewą kolumnę stanu lub migawki do użycia jako źródło dla narzędzia Pędzel historii.
  4. Rozpocznij malowanie, przeciągając kursor narzędzia Pędzel historii.
Logo Adobe

Zaloguj się na swoje konto