Zarządzanie warstwami i grupami pozwala zachować porządek w projekcie. Można zmieniać nazwy warstw, kodować je przy użyciu kolorów, aby ułatwić odnajdowanie podobnych warstw, a także usuwać i eksportować warstwy w razie potrzeby.

Zmienianie nazwy warstwy lub grupy

Nazwy warstw i grup warstw dodawanych do obrazu warto wybierać tak, aby odpowiadały ich zawartości. Nazwy opisowe ułatwiają identyfikację warstw w panelu Warstwy.

  1. Wykonaj jedną z następujących czynności:
    • Kliknij dwukrotnie nazwę warstwy lub grupy warstw w panelu Warstwy, a następnie wprowadź nową nazwę. Naciśnij klawisz Enter (Windows) lub Return (Mac OS).
    • Zaznacz warstwę lub grupę i wykonaj następujące kroki:
      • Wybierz opcję Warstwa > Zmień nazwę warstwy lub Warstwa > Zmień nazwę grupy.
      • Wprowadź nową nazwę grupy lub warstwy w panelu Warstwy.
      • Naciśnij klawisz Enter (Windows) lub Return (Mac OS).

Przypisywanie koloru do warstwy lub grupy

Kodowanie warstw i grup przy użyciu kolorów ułatwia ich wyszukiwanie w panelu Warstwy. Kliknij prawym przyciskiem myszy warstwę lub grupę i wybierz kolor.

Rasteryzacja warstw

Narzędzi do malowania oraz filtrów malarskich nie można stosować do warstw, które zawierają dane wektorowe (np. warstw tekstowych, warstw kształtów, masek wektorowych i obiektów inteligentnych) oraz dane wygenerowane (np. warstw wypełnień). Istnieje jednak możliwość przeprowadzenia rasteryzacji takich warstw, tj. przekształcenia ich zawartości w płaski obraz rastrowy.

  1. Zaznacz warstwy przeznaczone do rasteryzacji, wybierz polecenie Warstwa > Rasteryzuj, a następnie wybierz jedną z poniższych opcji:

    Tekst

    Pozwala zrasteryzować tekst na warstwie tekstowej. Nie umożliwia jednak rasteryzowania żadnych innych danych wektorowych na warstwie.

    Kształt

    Pozwala zrasteryzować warstwę kształtu.

    Zawartość wypełnienia

    Pozwala zrasteryzować wypełnienie warstwy kształtu, przy czym maska wektorowa pozostaje bez zmian.

    Maska wektorowa

    Pozwala zrasteryzować maskę wektorową na warstwie kształtu. (Maska zostaje przekształcona w maskę warstwy).

    Obiekt inteligentny

    Umożliwia przekonwertowanie obiektu inteligentnego na warstwę rastrową.

    Wideo

    Rasteryzuje bieżącą klatkę wideo, tworząc warstwę obrazu.

    3D (tylko wersja Extended)

    Umożliwia zrasteryzowanie bieżącego widoku danych 3D do płaskiej warstwy rastrowej.

    Warstwa

    Pozwala zrasteryzować wszystkie dane wektorowe na zaznaczonych warstwach.

    Wszystkie warstwy

    Pozwala zrasteryzować wszystkie warstwy, które zawierają dane wektorowe i wygenerowane.

    Uwaga:

    Aby zrasteryzować warstwy połączone, zaznacz warstwę połączoną, wybierz polecenie Warstwa > Zaznacz połączone warstwy i zrasteryzuj wszystkie zaznaczone warstwy.

Usuwanie warstwy lub grupy

Usunięcie z pliku obrazu nieużywanych warstw umożliwia zmniejszenie jego rozmiaru.

Uwaga:

Aby szybko usunąć puste warstwy, wybierz opcję Plik > Skrypty > Usuń wszystkie puste warstwy.

  1. Na panelu Warstwy zaznacz co najmniej jedną warstwę lub grupę.
  2. Wykonaj jedną z następujących czynności:
    • Aby usunięcie elementów wiązało się z potwierdzeniem, kliknij ikonę Usuń . Można też wybrać polecenie Warstwy > Usuń > Warstwa, Usuń warstwę lub Usuń grupę z menu panelu Warstwy.
    • Aby usunąć warstwę lub grupę bez potwierdzenia, przeciągnij ją na ikonę Usuń , kliknij tę ikonę z wciśniętym klawiszem Alt (Windows) lub Option (Mac OS) albo naciśnij klawisz Delete.
    • Aby usunąć warstwy ukryte, wybierz polecenie Warstwy > Usuń > Warstwy ukryte.

    Uwaga:

    Aby usunąć warstwy połączone, zaznacz warstwę połączoną, wybierz polecenie Warstwa > Wybierz połączone warstwy, a następnie usuń wszystkie zaznaczone warstwy.

Eksportowanie warstw

W programie Photoshop istnieje możliwość eksportowania wszystkich warstw lub warstw widocznych do osobnych plików.

  1. Wybierz polecenie Plik > Skrypty > Eksportuj warstwy do plików.

Scalanie warstw

Po ukończeniu prac nad poszczególnymi warstwami użytkownik może scalić je w obraz końcowy, co pozwala zmniejszyć rozmiar poszczególnych plików. Przy przeprowadzaniu operacji scalania dane znajdujące się na głębszych warstwach są zastępowane przez dane warstw wierzchnich, które się na nie nakładają. Miejsca przecinania się wszystkich przezroczystych obszarów w scalanych warstwach pozostają przezroczyste.

Uwaga:

Warstwą docelową operacji scalania nie może być ani warstwa dopasowania, ani warstwa wypełnienia.

Oprócz scalania warstw użytkownik może je również stemplować. Operacja ta umożliwia połączenie zawartości kilku warstw na warstwie docelowej bez modyfikowania innych.

Uwaga:

Po zapisaniu scalonego dokumentu nie można już powrócić do poprzedniego stanu — warstwy zostają scalone nieodwracalnie.

Scalanie dwu warstw lub grup

  1. Sprawdź, czy wszystkie warstwy, które mają zostać scalone, są widoczne.
  2. Zaznacz warstwy i grupy przeznaczone do scalenia.
  3. Wybierz polecenie Warstwa > Złącz warstwy.

Uwaga:

Aby scalić dwie sąsiednie warstwy lub grupy, zaznacz górny element i wybierz polecenie Warstwa > Scal warstwy. Aby scalić warstwy połączone, wybierz polecenie Warstwa > Zaznacz połączone warstwy, a następnie scal zaznaczone warstwy. Aby scalić dwie warstwy 3D, wybierz polecenie Warstwa > Scal warstwy. Scalone warstwy będą miały wspólną scenę, a warstwa znajdująca się na wierzchu odziedziczy właściwości 3D warstwy znajdującej się na spodzie. Aby włączyć tę funkcję, widoki kamer muszą być takie same.

Scalanie warstw w masce przycinającej

  1. Ukryj wszystkie warstwy, które nie są przeznaczone do scalenia.
  2. Wybierz warstwę podstawową maski przycinającej. Warstwa podstawowa musi być warstwą rastrową.
  3. Wybierz polecenie Scal maskę przycinającą z menu Warstwy lub z menu panelu Warstwy.

Więcej informacji o maskach przycinających zawiera rozdział Maskowanie warstw przy użyciu masek przycinających.

Scalanie wszystkich widocznych warstw i grup obrazu

  1. Wybierz polecenie Scal widoczne z menu Warstwy lub z menu panelu Warstwy. Wszystkie warstwy, na których będzie wyświetlana ikona oka , zostaną scalone.

    Uwaga:

    W celu uaktywnienia polecenia Scal musi być zaznaczona widoczna warstwa.

Stemplowanie kilku warstw lub warstw połączonych

W wyniku ostemplowania warstw zaznaczonych lub warstw połączonych program Photoshop tworzy nową warstwę, która zawiera scaloną zawartość poszczególnych warstw.

  1. Zaznacz kilka warstw.
  2. Wciśnij klawisze Ctrl+Alt+E (Windows) lub Command+Option+E (Mac OS).

Aby ostemplować wszystkie widoczne warstwy, wykonaj następujące czynności:

  1. Uaktywnij widoczność warstw przeznaczonych do scalenia.
  2. Naciśnij klawisze Shift + Ctrl + Alt + E (Windows) lub Shift + Command + Option + E (Mac OS).

    Program Photoshop tworzy nową warstwę obejmującą scaloną zawartość.

Spłaszczanie wszystkich warstw

Operacja spłaszczania polega na scaleniu wszystkich widocznych warstw na warstwie tła (z pominięciem warstw ukrytych). Zwykle powoduje to zmniejszenie wielkości pliku obrazu. Wszystkie wynikowe obszary przezroczyste są wypełniane kolorem białym. Po zapisaniu spłaszczonego obrazu nie można już powrócić do poprzedniego stanu — warstwy zostają scalone nieodwracalnie.

Uwaga:

Niekiedy obraz zostaje spłaszczony w wyniku konwersji trybu kolorów. Jeśli obraz taki ma być edytowany po konwersji, zapisz jego kopię ze wszystkimi warstwami.

  1. Upewnij się, że wszystkie warstwy, które mają pozostać na obrazie, są widoczne.
  2. Wybierz polecenie Warstwa > Spłaszcz obraz (to samo polecenie można wybrać z menu panelu Warstwy).

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online