Användarhandbok Avbryt

Generera bildresurser från lager

  1. Användarhandbok för Photoshop
  2. Introduktion till Photoshop
    1. Föreställ det. Skapa det.
    2. Nyheter i Photoshop
    3. Redigera ditt första foto
    4. Skapa dokument
    5. Photoshop | Vanliga frågor
    6. Systemkrav för Photoshop
    7. Lär dig Photoshop
  3. Photoshop och andra Adobe-produkter och -tjänster
    1. Arbeta med Illustrator-bilder i Photoshop
    2. Arbeta med Photoshop-filer i InDesign
    3. Substance 3D-material för Photoshop
    4. Använd apptillägget Capture i Photoshop
  4. Photoshop på iPad (inte tillgängligt i Fastlandskina)
    1. Photoshop på iPad | Vanliga frågor
    2. Kom igång med arbetsytan
    3. Systemkrav | Photoshop på iPad
    4. Skapa, öppna och spara dokument
    5. Lägg till foton
    6. Arbeta med lager
    7. Rita och måla med penslar
    8. Gör markeringar och lägg till maskering
    9. Retuschera dina sammansatta bilder
    10. Arbeta med justeringslager
    11. Justera färgtonen i den sammansatta bilden med Kurvor
    12. Använda omformningsåtgärder
    13. Beskär och rotera dina sammansättningar
    14. Rotera, panorera, zooma och återställa arbetsytan
    15. Arbeta med textlager
    16. Arbeta med Photoshop och Lightroom
    17. Skaffa saknade typsnitt i Photoshop på iPad
    18. Japansk text i Photoshop på iPad
    19. Hantera appinställningar
    20. Tryckkortkommandon och gester
    21. Kortkommandon
    22. Redigera bildstorlek
    23. Livestreama samtidigt som du skapar i Photoshop på iPad
    24. Reparera defekter med verktyget Lagningspensel
    25. Skapa penslar i Capture och använd dem i Photoshop för iPad
    26. Arbeta med Camera Raw-filer
    27. Skapa och arbeta med smarta objekt
    28. Justera exponering i dina bilder med skugga och efterbelys
    29. Automatiska justeringskommandon i Photoshop för iPad
    30. Smeta ut områden i dina bilder med Photoshop på iPad
    31. Öka eller minska färgmättnad i bilder med svampverktyget
    32. Innehållsanpassad fyllning på iPad
  5. Photoshop på webben (inte tillgängligt i Fastlandskina)
    1. Vanliga frågor
    2. Systemkrav
    3. Kortkommandon
    4. Filformat som stöds
    5. Introduktion till arbetsytan
    6. Öppna och arbeta med molndokument
    7. Generativa AI-funktioner
    8. Grundläggande koncept för redigering
    9. Snabbåtgärder
    10. Arbeta med lager
    11. Retuschera bilder och ta bort defekter
    12. Göra snabbmarkeringar
    13. Förbättrade bilder med justeringslager
    14. Flytta, omforma och beskära bilder
    15. Rita och måla
    16. Arbeta med textlager
    17. Arbeta med vem som helst på webben
    18. Hantera appinställningar
    19. Generera bild
    20. Generera bakgrund
    21. Referensbild
  6. Photoshop för datorer (beta) (inte tillgängligt i Fastlandskina)
    1. Kom igång med Creative Cloud-betaprogram
    2. Photoshop för datorer (beta)
    3. Generera bild med textbeskrivningar
    4. Generera bakgrund med textbeskrivningar
  7. Generativ AI (inte tillgängligt i Fastlandskina) 
    1. Vanliga frågor om generativ AI i Photoshop
    2. Generativ fyllning i Photoshop för datorer
    3. Generativ utökning i Photoshop för datorer
    4. Generativ fyllning i Photoshop på iPad
    5. Generativ utökning i Photoshop på iPad
    6. Funktioner med generativ AI i Photoshop på webben
  8. Innehållsautentisering (inte tillgängligt i Fastlandskina)
    1. Innehållsuppgifter i Photoshop
    2. Identitet och ursprung – NFT
    3. Anslut konton för kreativ tillskrivning
  9. Molndokument (inte tillgängligt i Fastlandskina)
    1. Photoshop-molndokument | Vanliga frågor
    2. Photoshop-molndokument | Arbetsflödesfrågor
    3. Hantera och arbeta med molndokument i Photoshop
    4. Uppgradera molnlagringsutrymmet för Photoshop
    5. Det går inte att skapa eller spara ett molndokument
    6. Lös fel med Photoshops molndokument
    7. Samla in loggar för synkronisering av molndokument
    8. Bjud in andra till att redigera dina molndokument
    9. Dela filer och kommentera i appen
  10. Arbetsyta
    1. Grundläggande om arbetsytan
    2. Inställningar
    3. Lär dig snabbare med panelen Upptäck i Photoshop
    4. Skapa dokument
    5. Montera filer
    6. Standardkortkommandon
    7. Anpassa kortkommandon
    8. Verktygsgallerier
    9. Prestandainställningar
    10. Använda verktyg
    11. Förinställningar
    12. Stödraster och stödlinjer
    13. Tryckgester
    14. Använda Touch Bar med Photoshop
    15. Funktioner för pekskärmar och anpassningsbara arbetsytor
    16. Förhandstitt på teknik
    17. Metadata och anteckningar
    18. Funktioner för pekskärmar och anpassningsbara arbetsytor
    19. Montera Photoshop-bilder i andra program
    20. Linjaler
    21. Visa eller dölj extrainnehåll som inte skrivs ut
    22. Ange kolumner för en bild
    23. Ångra och historik
    24. Paneler och menyer
    25. Placera element med fästfunktionen
    26. Placera med linjalen
  11. Webb-, skärm- och appdesign
    1. Photoshop för design
    2. Ritytor
    3. Device Preview
    4. Kopiera CSS från lager
    5. Segmentera webbsidor
    6. HTML-alternativ för segment
    7. Ändra snittlayout
    8. Arbeta med webbilder
    9. Skapa webbfotogallerier
  12. Grundläggande om bilder och färger
    1. Så ändrar du storlek på bilder
    2. Arbeta med raster- och vektorbilder
    3. Bildstorlek och upplösning
    4. Hämta bilder från kameror och skannrar
    5. Skapa, öppna och importera bilder
    6. Visa bilder
    7. Fel ogiltig JPEG-markör | Öppna bilder
    8. Visa flera bilder
    9. Anpassa färgväljare och färgrutor
    10. High Dynamic Range-bilder
    11. Matcha färger i bilden
    12. Konvertera bilder till andra färglägen
    13. Färglägen
    14. Radera delar av en bild
    15. Blandningslägen
    16. Välja färger
    17. Anpassa indexerade färgtabeller
    18. Bildinformation
    19. Förvrängningsfilter är inte tillgängliga
    20. Färg
    21. Färg- och monokromjusteringar med kanaler
    22. Välja färger i Färgpanelen och Färgrutor
    23. Ta färgprov
    24. Färg- eller bildläge
    25. Färgskiftning
    26. Lägga till en villkorsstyrd lägesändring i ett funktionsmakro
    27. Lägga till färgrutor från HTML-, CSS- och SVG-dokument
    28. Bitdjup och inställningar
  13. Lager
    1. Grundläggande om lager
    2. Icke-förstörande redigering
    3. Skapa och hantera lager och grupper
    4. Markera, gruppera och länka lager
    5. Montera bilder i ramar
    6. Lageropacitet och -blandning
    7. Maskeringslager
    8. Använda smarta filter
    9. Lagerkompositioner
    10. Flytta, stapla och låsa lager
    11. Maskera lager med vektormasker
    12. Hantera lager och grupper
    13. Lagereffekter och lagerstilar
    14. Redigera lagermasker
    15. Extrahera resurser
    16. Visa lager med urklippsmasker
    17. Generera bildresurser från lager
    18. Arbeta med smarta objekt
    19. Blandningslägen
    20. Kombinera flera bilder till ett grupporträtt
    21. Kombinera bilder med Blanda lager automatiskt
    22. Justera och fördela lager
    23. Kopiera CSS från lager
    24. Läs in markering från ett lager eller en lagermasks gränser
    25. Med alternativen för ursparning kan du se innehåll från andra lager
  14. Markeringar
    1. Komma igång med markering
    2. Gör markeringar i din sammansatta bild
    3. Arbetsytan Markera och maskera
    4. Markera med hjälp av markeringsramsverktygen
    5. Markera med hjälp av lassoverktygen
    6. Justera pixelmarkeringar
    7. Flytta, kopiera och ta bort markerade pixlar
    8. Skapa en tillfällig snabbmask
    9. Markera ett färgintervall i en bild
    10. Konvertera mellan banor och markeringsgränser
    11. Grundläggande om kanaler
    12. Spara markeringar och alfakanalmasker
    13. Välja de bildområden som är i fokus
    14. Duplicera, dela och sammanfoga kanaler
    15. Kanalberäkningar
  15. Bildjusteringar
    1. Ersätt objektfärger
    2. Tänja perspektiv
    3. Reducera oskärpa från kameraskak
    4. Exempel med Lagningspensel
    5. Exportera tabeller för färgsökning
    6. Justera bildens skärpa och oskärpa
    7. Färgjusteringar
    8. Använda intensitets-/kontrastjusteringar
    9. Förbättra skugg- och högdagerdetaljer
    10. Nivåjustering
    11. Justera nyans och mättnad
    12. Justera lyster
    13. Justera färgmättnad i bildområden
    14. Göra snabba toningsjusteringar
    15. Använda färgeffekter på bilder
    16. Förbättra bilden med färgbalansjusteringar
    17. High Dynamic Range-bilder
    18. Visa histogram och pixelvärden
    19. Matcha färger i bilden
    20. Beskära och räta upp foton
    21. Konvertera en färgbild till en svartvit bild
    22. Justerings- och fyllningslager
    23. Kurvanpassning
    24. Blandningslägen
    25. Välja bilder för tryck
    26. Justera färg och ton med pipetterna för Nivåer och Kurvor
    27. Justera HDR-exponering och HDR-toning
    28. Skugga eller efterbelysa bildområden
    29. Selektiv färgjustering
  16. Adobe Camera Raw
    1. Systemkrav för Camera Raw
    2. Nyheter i Camera Raw
    3. Introduktion till Camera Raw
    4. Skapa panoramor
    5. Objektiv som stöds
    6. Effekterna Vinjettering, Kornighet och Ta bort dis i Camera Raw
    7. Standardkortkommandon
    8. Automatisk perspektivkorrigering i Camera Raw
    9. Radiellt filter i Camera Raw
    10. Hantera Camera Raw-inställningar
    11. Öppna, bearbeta och spara foton i Camera Raw
    12. Reparera foton med hjälp av det förbättrade verktyget Fläckborttagning i Camera Raw
    13. Rotera, beskära och justera foton
    14. Justera färgåtergivning i Camera Raw
    15. Processversioner i Camera Raw
    16. Göra lokala justeringar i Camera Raw
  17. Reparera och återställa bilder
    1. Använda Innehållsanpassad fyllning till att ta bort objekt från foton
    2. Innehållsanpassad lappning och flyttning
    3. Retuschera och reparera foton
    4. Korrigera förvrängning och brus
    5. Grundläggande felsökningssteg för att korrigera de flesta problem
  18. Bildförbättring och -omformning
    1. Ersätt himlen i dina bilder
    2. Omforma objekt
    3. Justera beskärning, rotation och storlek på arbetsyta
    4. Så beskär du och rätar upp foton
    5. Skapa och redigera panoramabilder
    6. Tänj bilder, former och banor
    7. Gränspunkt
    8. Innehållsanpassad skalförändring
    9. Omforma bilder, former och banor
  19. Rita och måla
    1. Måla symmetriska mönster
    2. Rita rektanglar och ändra linjealternativ
    3. Rita
    4. Rita och redigera former
    5. Målningsverktyg
    6. Skapa och ändra penslar
    7. Blandningslägen
    8. Lägga till färger till banor
    9. Redigera banor
    10. Måla med blandpenseln
    11. Penselförinställningar
    12. Övertoningar
    13. Övertoningsinterpolation
    14. Fylla i och rama in markeringar, lager och banor
    15. Rita med hjälp av ritstiftsverktygen
    16. Skapa mönster
    17. Skapa ett mönster med mönsterverktyget
    18. Hantera banor
    19. Hantera mönsterbibliotek och förinställningar
    20. Rita eller måla med hjälp av ett ritbord
    21. Skapa texturerade penslar
    22. Lägga till dynamiska element i penslar
    23. Övertoning
    24. Måla stiliserade penseldrag med hjälp av Konsthändelsepensel
    25. Måla med ett mönster
    26. Synkronisera förinställningar på flera enheter
    27. Migrera förinställningar, funktionsmakron och inställningar
  20. Text
    1. Lägga till och redigera text
    2. Unified Text Engine
    3. Arbeta med OpenType-teckensnitt med SVG-specialtecken
    4. Formatera tecken
    5. Formatera stycken
    6. Så här skapar du texteffekter
    7. Redigera text
    8. Rad- och teckenavstånd
    9. Arabisk och hebreisk text
    10. Teckensnitt
    11. Felsök teckensnitt
    12. Asiatisk text
    13. Skapa text
  21. Filter och effekter
    1. Använd Oskärpegalleri
    2. Grundläggande om filter
    3. Referens för filtereffekter
    4. Lägga till ljuseffekter
    5. Använda filtret Adaptiv vidvinkel
    6. Använda oljemålningsfilter
    7. Använda filtret Gör flytande
    8. Lagereffekter och lagerstilar
    9. Använda filter
    10. Smeta ut bildområden
  22. Spara och exportera
    1. Spara dina filer i Photoshop
    2. Exportera dina filer i Photoshop
    3. Filformat som stöds
    4. Spara filer med grafikformat
    5. Flytta designer mellan Photoshop och Illustrator
    6. Spara och exportera videofilmer och animeringar
    7. Spara PDF-filer
    8. Digimarc-copyrightskydd
  23. Färghantering
    1. Färghantering
    2. Bibehålla konsekventa färger
    3. Färginställningar
    4. Duplexfärgbilder
    5. Arbeta med färgprofiler
    6. Färghantera dokument för visning online
    7. Färghantera dokument vid utskrift
    8. Färghantera importerade bilder
    9. Granska korrektur av färger
  24. Webb-, skärm- och appdesign
    1. Photoshop för design
    2. Ritytor
    3. Device Preview
    4. Kopiera CSS från lager
    5. Segmentera webbsidor
    6. HTML-alternativ för segment
    7. Ändra snittlayout
    8. Arbeta med webbilder
    9. Skapa webbfotogallerier
  25. Video och animering
    1. Videoredigering i Photoshop
    2. Redigera video- och animeringslager
    3. Översikt över video och animering
    4. Förhandsvisa video och animeringar
    5. Måla bildrutor i videolager
    6. Importera videofiler och bildsekvenser
    7. Skapa bildruteanimeringar
    8. Creative Cloud 3D Animation (förhandstitt på teknik)
    9. Skapa tidslinjeanimeringar
    10. Skapa bilder för videofilmer
  26. Utskrift
    1. Skriva ut 3D-objekt
    2. Skriva ut från Photoshop
    3. Skriva ut med färghantering
    4. Kontaktkartor och PDF-presentationer
    5. Skriva ut foton i bildpaketslayout
    6. Skriva ut dekorfärger
    7. Skriva ut bilder till en kommersiell tryckpress
    8. Förbättra färgutskrifter från Photoshop
    9. Felsöka utskriftsproblem | Photoshop
  27. Automatisering
    1. Skapa funktionsmakron
    2. Skapa databaserade bilder
    3. Skript
    4. Bearbeta en grupp med filer
    5. Spela upp och hantera funktionsmakron
    6. Lägg till villkorstyrda funktionsmakron
    7. Funktionsmakron och panelen Funktionsmakron
    8. Spela in verktyg i funktionsmakron
    9. Lägga till en villkorsstyrd lägesändring i ett funktionsmakro
    10. Användargränssnittsverktygslåda för Photoshop för plugin-program och skript
  28. Felsökning
    1. Åtgärdade fel 
    2. Kända problem
    3. Optimera Photoshop-prestanda
    4. Grundläggande felsökning
    5. Felsök vid krasch eller frysning
    6. Felsök programfel
    7. Felsök problem med fullt virtuellt minne
    8. Felsök problem med grafikprocessor och grafikdrivrutiner
    9. Hitta verktyg som saknas
    10. Photoshop 3D | Vanliga frågor om borttagna funktioner

Du kan generera bildresurser i formaten JPEG, PNG eller SVG från innehållet i ett lager eller en grupp av lager i en PSD-fil. Resurser genereras automatiskt när du anger ett tilläggsnamn för bildformat som stöds i ett lagernamn eller i en lagergrupps namn. Du kan även ange kvalitets- och storleksparametrar för de genererade bildresurserna.

Att skapa bildresurser från PSD-filer är särskilt användbart vid webbdesign för flera enheter.

Information om hur du skapar och exporterar webbilder finns i Exportera filer i olika format från Photoshop.

Generera bildresurser från lager eller lagergrupper

Om du bättre vill förstå hur bildresurser genereras kan du använda en enkel PSD-fil (hämtas från länken) med följande lagerhierarki som exempel:

Photoshop: Generera bildresurser
Exempel på PSD-fil och lagerhierarki.

Lagerhierarkin i filen består av två lagergrupper – Rounded_rectangles och Ellipses. Vardera grupp innehåller fem lager.

Följ dessa anvisningar för att generera bildresurser från PSD-filen:

  1. PSD-filen ska vara öppen. Välj Arkiv > Generera > Bildresurser.
  2. Lägg till lämpligt fillformat som tillägg (.jpg, .png.gif, eller .svg) till namn på de lager eller lagergrupper som du vill använda för att generera bildresurser. Du kan exempelvis ändra namn på lagergrupperna Rounded_rectangles och Ellipses till Rounded_rectangles.jpg och Ellipses.png, samt lagret Ellipse_4 till Ellipse_4.gif.
Obs!

Specialtecknen : och * stöds inte i lagernamn.

Photoshop genererar bildresurserna och sparar dem i en undermapp vid sidan av PSD-källfilen. Om PSD-källfilen inte är sparad kommer Photoshop att spara genererade bildresurser i en ny mapp på skrivbordet.

Photoshop: Namn på bildresurser
Namn på bildresurserna genereras från namn på lager eller lagergrupper

Obs!

Generering av bildresurser är aktiverad för aktuellt dokument. När funktionen väl har aktiverats är den tillgänglig varje gång dokumentet öppnas på nytt. Gör så här för att avaktivera generering av bildresurser för aktuellt dokument: Avmarkera Arkiv > Generera > Bildresurser.

Skapa molndokumentsresurser

Om du arbetar med ett molndokument sparas resurserna i katalogen ”Photoshop Cloud Associates”:

  • Windows: C:\Users\yourname\Documents\Adobe\Photoshop Cloud Associates
  • macOS: /Users/yourname/Documents/Adobe/Photoshop Cloud Associates

Generera flera bildresurser från ett lager eller en lagergrupp

Om du vill generera flera bildresurser från ett lager eller en lagergrupp avgränsar du namnen på resurserna med kommatecken. Följande lagernamn genererar till exempel tre resurser:

Ellipse_4.jpg, Ellipse_4b.png, Ellipse_4c.png

Spara resurser i en undermapp

Du kan välja att spara bildresurser som genererats från specifika lager eller lagergrupper i en undermapp direkt under dokumentets resursmapp. Inkludera undermappens namn i namnet för lagret eller lagergruppen, till exempel:

[undermapp]/Ellipse_4.jpg 

Exempel på användning i webbdesign

Att skapa bildresurser från PSD-filer är speciellt användbart vid webbdesign för flera enheter. Ta en titt på följande webbdesign och dess lagerstruktur:

Webbdesign och dess lagerhierarki

Vi ska extrahera ikonen högst upp och den översta raden på Global Hotspots-bildens stödraster som bildresurser:

  • Ange bildformatstillägget i önskat lagernamn.
Photoshop: Ändra namn på lager eller lagergrupper

Photoshop: Ändra namn på lager eller lagergrupper

Ändra namn på önskade lager eller lagergrupper

Obs!

En enda bildresurs genereras från innehållet i ett lager eller en lagergrupp. Exempel: Lagergruppen AdventureCo Logo i skärmbilden ovan innehåller ett formlager och ett animerat textlager. Båda lagren förenklas när en bildresurs genereras från lagergruppen.

Photoshop genererar bildresurserna och sparar dem på samma plats som PSD-källfilen.

Photoshop: Genererade bildresurser
Genererade bildresurser

Ange kvalitets- och storleksparametrar

JPEG-resurser genereras med kvaliteten 90 % som standard. PNG-resurser genereras som 32-bitars bilder som standard. GIF-resurser genereras med grundläggande alfa-genomskinlighet.

Samtidigt som du byter namn på lager eller lagergrupper som förberedelse inför att generera resurser, kan du anpassa kvalitet och storlek.

Parametrar för JPEG-resurser

  • Lägg till önskad utdatakvalitet som ett suffix till resursnamnet: .jpg(1-10) eller .jpg(1-100 %). Exempel:
    • Ellipse_4.jpg5
    • Ellipse_4.jpg50%
  • Lägg till önskad utdatabildstorlek (relativt eller med ett format som stöds: px, in, cm och mm) som prefix till resursnamnet. Photoshop formaterar bilden i skalan enligt ditt val. Exempel:
    • 200% Ellipse_4.jpg
    • 300 x 200 Rounded_rectangle_3.jpg
    • 10in x 200mm Rounded_rectangle_3.jpg

Obs! Glöm inte att lägga till ett mellanrum mellan prefixet och resursnamnet. Om du anger storleken i pixlar kan du utesluta måttenheten. Till exempel 300 x 200.

Obs!

Som du ser kan du blanda olika måttenheter och pixlar när du anger önskat utvärde för bildstorlek. Exempel: 4in x 100 Rounded_rectangle_3.jpg är ett giltigt lagernamn för att generera en resurs.

Parametrar för PNG-resurser

  • Lägg till önskad utdatakvalitet som ett suffix till resursnamnet: 8, 24 eller 32. Exempel:
    • Ellipse_4.png24
  • Lägg till önskad utdatabildstorlek (relativt eller med ett format som stöds: px, in, cm och mm) som prefix till resursnamnet. Photoshop formaterar bilden i skalan enligt ditt val. Exempel:
    • 42% Ellipse_4.png
    • 300mm x 20cm Rounded_rectangle_3.png
    • 10in x 50cm Rounded_rectangle_3.png

Obs! Glöm inte att lägga till ett mellanrum mellan prefixet och resursnamnet. Om du anger storleken i pixlar kan du utesluta måttenheten. Till exempel 300 x 200.

Obs!

Som du ser kan du blanda olika måttenheter och pixlar när du anger önskat utvärde för bildstorlek. Exempel: 4in x 100 Rounded_rectangle_3.jpg är ett giltigt lagernamn för att generera en resurs.

Parametrar för GIF-resurser

  • Lägg till önskad utdatabildstorlek (relativt eller med ett format som stöds: px, in, cm och mm) som prefix till resursnamnet. Exempel:
    • 42% Ellipse_4.gif
    • 300mm x 20cm Rounded_rectangle_3.gif
    • 20in x 50cm Rounded_rectangle_3.gif

Obs! Glöm inte att lägga till ett mellanrum mellan prefixet och resursnamnet. Om du anger storleken i pixlar kan du utesluta måttenheten. Till exempel 300 x 200.

Obs!

Som du ser kan du blanda olika måttenheter och pixlar när du anger önskat utvärde för bildstorlek. Exempel: 4in x 100 Rounded_rectangle_3.gif är ett giltigt lagernamn för att generera resurser.

Kvalitetsparametrar är inte tillgängliga för GIF-resurser.

Skapa komplexa lagernamn

Du kan ange flera resursnamn när du namnger ett lager för att generera en resurs. Exempel:

120% Delicious.jpg, 42% Delicious.png24, 100x100 Delicious_2.jpg90%, 250% Delicious.gif

Photoshop genererar följande resurser från detta lager:

  • Delicious.jpg (en JPG-bild med kvalitet 8 och i skala 120 %)
  • Delicious.png (en 24-bitars PNG-bild i skala 42 %)
  • Delicious_2.jpg (en JPG-bild med 90 % i kvalitet och en absolut storlek om 100x100 px)
  • Delicious.gif (en GIF-bild i skala 250 %)

Exempel på absolut skalförändring

Bra exempel på absolut skalförändring

  • 100 x 80 foo.png (enskild absolut skalförändring)
  • 80 x 100 px foo.png (mellanrum mellan längder)
  • 4 tum x 100 foo.png (blandning av måttenheter eller inga måttenheter)
  • 90 mm x 120 cm foo.png (blandning av olika måttenheter)
  • 100x? foo.png (jokertecken)
  • ?x60in foo.png (jokertecken i början)

Dåliga exempel på absolut skalförändring

  • 100x100foo.png (inget blanksteg före filnamn)
  • 80x100 60% foo.png (blandning av absolut och relativ skalförändring)
  • 50% 80x100 foo.png (blandning av absolut och relativ skalförändring)
  • 20in cm x50cm foo.png (flera måttenheter)
  • 30nm x20 nano.png (ogiltig måttenhet)

Formatera och separera flera filer

Bra exempel

  • Layer 1.png (blanksteg i filnamn tillåts – skapar en enskild fil med namnet ”Layer 1.png”)
  • Layer 1.png,Layer 2.jpg (komma som avgränsare)
  • Layer 1.png, Layer 2.jpg (komma följt av blanksteg som avgränsare)
  • Layer 1.png+Layer 2.jpg (plus som avgränsare)
  • Layer 1.png + Layer 2.jpg (plus följt av blanksteg som avgränsare)

Lägga ihop allt

100% Delicious, 42% Layer 1.png24 + 100x100 Layer.jpg-90% , 250% Quux/Foo Bar Baz.gif -resultat i tre filer (strängen ”100% Delicious” ignoreras eftersom det inte är ett filnamn):

  • Layer 1.png, i 42 % skala, som en 24-bitars png
  • Layer.jpg, med en absolut storlek på 100x100 pixlar, som en jpg med kvalitet på 90 %
  • Foo Bar Baz.gif i undermappen Quux, i 250 % skala, som gif.

Ange standardinställningar för resurser

Du kan ange omfattande standardinställningar för dokument för genererade resurser. Gör så här:

  1. Skapa ett tomt lager i dokumentet.
  2. Börja lagernamnet med nyckelordet standard. Ange inställningarna som du vill använda på samtliga bildresurser genererade från dokumentet. Exempel:

standard-hi-res/

Genererar alla bildresurser i en undermapp med namnet hi-res. Exempel:[resurs_mapp]/hi-res/Delicious.jpg.

standard-hi-res/@2x

Genererar alla bildresurser i en undermapp med namnet hi-res. Dessutom läggs @2x till resursnamnet. Exempel:[resursmapp]/hi-res/Delicious@2x.jpg.

standard 50 %-lo-res/

Sparar bildresurser som förminskats med 50 % i undermappen lo-res under dokumentets resursmapp 

standard-hi-res/@2x + 50 %-lo-res/

Genererar två bildresurser från ett lager:

  • I undermappen hi-res läggs en bildresurs till med tillägget @2x
  • I undermappen lågupplösta förminskas en bildresurs med 50 %
Obs!

Standardskalfaktorer skrivs över av skalfaktorer som angetts för enskilda lager.

Avaktivera generering av bildresurser för alla dokument

Du kan avaktivera generering av bildresurser globalt i alla Photoshop-dokument genom att ändra dina Inställningar.

  1. Välj Redigera > Inställningar > Plugin-program.
  2. Avmarkera Aktivera Generator.
  3. Klicka på OK.
Obs!

Menyalternativet Arkiv > Generera är inte tillgängligt när du avaktiverar generering av bildresurser i Inställningar. Funktionen kan aktiveras på nytt, men enbart i dialogrutan Inställningar.

Vanliga frågor

Resursnamn måste vara unika på dokumentnivån.

JPG-resurser genereras med kvaliteten 90 % som standard. PNG-resurser genereras som 32-bitars bilder som standard. GIF-resurser genereras med grundläggande alfa-genomskinlighet.

Ja. Genomskinlighet och övriga effekter som används i ett lager avspeglas i resurserna som genereras från detta lager. Dessa effekter kan i vissa fall bli förenklade i genererade resurser.

Resurser beskärs efter dokumentgränserna. Om en bild inte faller inom dokumentgränserna skapar inte Generator de associerade bildresurserna.

Förutom kommatecken (,) kan du använda plustecken (+) som skiljetecken mellan bildresursernas namn. Exempel:

42% Rounded_rectangle_1.png24 + 100x100 Rounded_rectangle_1.jpg90%

är lika med:

42% Rounded_rectangle_1.png24 + 100x100 Rounded_rectangle_1.jpg90%

 Adobe

Få hjälp snabbare och enklare

Ny användare?

Adobe MAX 2024

Adobe MAX
Kreativitetskonferensen

14–16 okt i Miami Beach och online

Adobe MAX

Kreativitetskonferensen

14–16 okt i Miami Beach och online

Adobe MAX 2024

Adobe MAX
Kreativitetskonferensen

14–16 okt i Miami Beach och online

Adobe MAX

Kreativitetskonferensen

14–16 okt i Miami Beach och online