Lär dig hur du exporterar dokument, ritytor och lager i olika format och storlekar.

Exportera filer i olika format

Du kan använda alternativen Snabbexportera som och Exportera som för att exportera ett Photoshop-dokument, ritytor, lager och lagergrupper i PNG-, JPG-, GIF- och SVG-filformat.

Exportera dokument, ritytor och lager i Photoshop

Snabbexportera som

Använd alternativet Snabbexportera som när du snabbt vill exportera ditt arbete med de inställningar du har angett i inställningarna för Snabbexport.

Gör något av följande för att komma åt alternativet Snabbexportera som:

  • Gå till Arkiv > Exportera > Snabbexportera som [bildformat].
  • Gå till panelen Lager. Markera de lager, lagergrupper eller ritytor du vill exportera. Högerklicka på markeringen och välj Snabbexportera som [bildformat] på snabbmenyn.

Inställningar för snabbexport

Som standard genererar Snabbexport resurser som PNG med genomskinlighet och dessutom visas en uppmaning om att välja exportplats varje gång.

Gör något av följande för att ändra inställningarna för Snabbexportera:

  • Gå till Redigera > Inställningar > Exportera
  • Välj Arkiv > Exportera > Exportinställningar
Snabbexportera din PSD som en bild
Ange exportinställningar i Photoshop

Du kan ange följande alternativ i dialogrutan Inställningar:

Snabbexportformat: Välj ett bildfilsformat för export – PNG, JPG, GIF och SVG. Du kan ställa in formatspecifika parametrar ytterligare. Med PNG kan du till exempel ange om du vill exportera resurser med Genomskinlighet aktiverat (32 bitar) eller exportera mindre filer (8 bitar). För JPG kan du ställa in exportkvaliteten.

Plats för snabbexport: Välj det här alternativet för att välja plats för bilder som exporterats med Snabbexport. Välj något av följande:

  • Fråga vart du vill exportera varje gång: Uppmanar dig att välja en plats varje gång du exporterar resurser.
  • Exportera filer till en resursmapp bredvid det aktuella dokumentet: Placerar bildresursen i en undermapp med namnet Resurser i den mapp som innehåller Photoshop-källdokumentet.

Snabbexportera metadata: använd det här alternativet för att inkludera metadata – Copyright och kontaktinformation, i exporterade resurser.

Snabbexportera färgrymd: Välj om du vill konvertera resurserna till färgrymden sRGB.

Exportera som plats: se Exportera som.

Exportera som

Använd alternativet Exportera som när du vill finjustera dina exportinställningar varje gång du exporterar lager, lagergrupper, ritytor eller hela Photoshop-dokumentet som bilder. Varje lager, lagergrupp och rityta exporteras som en separat bildresurs.

Gör något av följande för att använda dialogrutan Exportera som:

  • Gå till Arkiv > Exportera > Exportera som om du vill exportera det aktuella Photoshop-dokumentet. Om dokumentet innehåller ritytor exporteras alla ritytor i det med den här dialogrutan.
  • Gå till panelen Lager. Markera de lager, lagergrupper eller ritytor du vill exportera. Högerklicka på markeringen och välj Exportera som på snabbmenyn.

Inställningar för dialogrutan Exportera som och platsinställningar

Du kan ange följande alternativ i dialogrutan Exportera som:

Format: Välj PNG, JPG, GIF eller SVG.

Formatspecifik inställning: Med PNG anger du om du vill exportera resurser med Genomskinlighet aktiverat (32 bitar) eller exportera bilder med mindre storlek (8 bitar). För JPEG anger du önskad bildkvalitet (0–100 %). GIF-bilder är genomskinliga som standard. Tänk på följande när du exporterar PNG-resurser:

  • Om du väljer Genomskinlighet genereras 32-bitars PNG-resurser
  • Om du väljer Mindre fil genereras 8-bitars PNG-resurser
  • Om du inte väljer något av ovanstående alternativ genereras 24-bitars PNG-resurser

Storlek: Ange bildresursens bredd och höjd. Bredd och höjd är låsta tillsammans som standard. Om du ändrar bredden ändras höjden automatiskt proportionerligt. Om du vill ange arbetsytegränser för den exporterade resursen läser du i Arbetsytestorlek.

Skala: Ange storlek för den exporterade bilden. Det här alternativet är användbart när du exporterar resurser med stor eller liten upplösning. Om du ändrar skalan påverkas bildstorleken.

Omsampling: Välj en omsamplingsmetod. Omsampling syftar på att ändra bilddatamängden när du ändrar bildens pixeldimensioner eller dess upplösning, vanligen genom att ändra bildens storlek.

  • Bilinjär: Lägger till pixlar genom att beräkna färgmedelvärden för de omgivande pixlarna. Den här metoden ger resultat av medelhög kvalitet.
  • Bikubisk: En långsammare men mer exakt metod som bygger på en undersökning av omgivande pixelvärden. Med hjälp av komplexa beräkningar ger Bikubisk mjukare tonövergångar än omsamplingsmetoderna Bilinjär och Närmast intilliggande.
  • Bikubisk mjukare: En bra metod för att förstora bilder. Metoden bygger på bikubisk interpolation men ger jämnare resultat.
  • Bikubisk skarpare: En bra metod för att minska storleken på bilder baserat på bikubisk interpolation samtidigt som skärpan förbättras. Med den här metoden bibehålls detaljnivån i omsamplade bilder. Om vissa områden i bilden blir för skarpa med Bikubisk skarpare kan du prova Bikubisk i stället.
  • Bikubisk automatisk: Väljer automatiskt den bikubiska färgprovsmetod som passar bäst för bilden.
  • Närmast intilliggande: En snabb men mindre exakt metod som replikerar pixlarna i en bild. Den här metoden är avsedd för illustrationer som innehåller kantlinjer som inte är kantutjämnade. Den bevarar skarpa kantlinjer och ger en mindre fil. Metoden kan däremot ge taggiga effekter, vilket blir extra tydligt när du skalförändrar en bild eller utför flera ändringar i en markering.
  • Bevara detaljer: Den här metoden är främst inriktad på att bevara bildens detaljer och skärpa samtidigt som storleken ändras.

Storlek på arbetsyta: Om du vill använda en viss bredd och höjd för resursen anger du de värdena som storlek på arbetsyta. Förhandsvisningen i dialogrutan Exportera som uppdateras så att bilden centreras inom de gränserna. Den här funktionen är användbar i flera olika situationer, som följande:

  • Du exporterar ikoner som har olika storlekar men som måste centreras i rutor med storleken 50 x 50 px.
  • Du exporterar banderrollbilder som är mindre eller större än de dimensioner som krävs.

Om bilden är större än arbetsytestorleken kapas den till de värden för bredd och höjd du har angett för arbetsytan. Du kan klicka på Återställ om du vill återställa värdena till de som är angivna i Bildstorlek.

Metadata: Ange om du vill infoga metadata – information om upphovsrätt och kontakt – i de exporterade resurserna.

Färgrymd: Ange följande:

  • Om du vill konvertera den exporterade resursen till färgrymden sRGB. Alternativet är markerat som standard.
  • Om du vill bädda in färgprofilen i den exporterade resursen.

Gör något av följande för att använda dialogrutan Exportera som:

  • Gå till Redigera > Inställningar > Exportera
  • Välj Arkiv > Exportera > Exportinställningar

I dialogrutan Inställningar väljer du ett alternativ under Exportera som plats.

  • Exportera resurser till platsen för det aktuella dokumentet.
  • Exportera resurser till den senast angivna platsen.

Exportera filer i olika storlekar

Du kan exportera valda lager, ritytor och dokument som resurser i flera olika storlekar med hjälp av dialogrutan Exportera som.

Om du vill göra det gör du så här:

  1. I den vänstra delen av dialogrutan Exportera som väljer du en relativ resursstorlek, till exempel 1,25x.
  2. Välj ett suffix för den exporterade resursen och dess storlek. Till exempel @1,25x. Med hjälp av suffix kan du enkelt hantera de exporterade resurserna.
  3. Klicka på +-ikonen för att .

De skalförändringsalternativ du väljer används för alla dina markerade lager och ritytor.

exportera resurser i flera olika storlekar
Exportera filer i olika storlekar med dialogrutan Exportera som

Exportera lager som filer

Du kan exportera och spara lager som enskilda filer med olika format, till exempel PSD, BMP, JPEG, PDF, Targa och TIFF. Lagren namnges automatiskt när de sparas. Du kan ange alternativ för att styra genereringen av namn.

Gör så här för att exportera lager som filer:

  1. Välj Arkiv > Exportera > Exportera lager som filer.
  2. I dialogrutan Exportera lager som filer, under Mål, klickar du på Bläddra och väljer en plats för de exporterade filerna. Som standard sparas de genererade filerna i samma mapp som källfilen.
  3. Ange ett namn i textrutan Filnamnsprefix för att ange ett gemensamt namn för filerna.
  4. Markera alternativet Endast synliga lager om du bara vill exportera lager med aktiverad synlighet på panelen Lager. Använd det här alternativet om du inte vill att alla lager ska exporteras. Stäng av synligheten för lager som du inte vill exportera.
  5. Välj ett filformat på menyn Filtyp. Ange alternativ.
  6. Markera alternativet Inkludera ICC-profil om du vill att profilen för arbetsfärgrymd ska bäddas in i den exporterade filen. Det är viktigt för färghanterade arbetsflöden.
  7. Klicka på Kör.
Exportera lager som filer
Exportera lager som filer

Exportera ritytor som filer

Du kan exportera ritytor som separata filer. Gör så här:

  1. Välj Arkiv > Exportera > Ritytor till filer i Photoshop.
  2. Gör följande i dialogrutan Ritytor till filer:
    • Välj de mål där du vill spara de genererade filerna.
    • Ange ett namnprefix.
    • Ange om du endast vill exportera ritytans innehåll eller om du också vill inkludera överlappande områden.
    • Ange om du vill exportera alla ritytor eller endast de som är markerade.
    • Ange om du även vill exportera ritytebakgrunder med ritytorna.
    • Välj det filformat du vill exportera till. Du kan exportera som BMP, JPEG, PDF, PSD, Targa, TIFF, PNG-8 och PNG-24.
    • Ange exportalternativ för det filformat du har markerat.
      • Ange om du också vill exportera ritytornas namn tillsammans med de exporterade ritytorna. Du kan ange ett anpassat teckensnitt, teckenstorlek, teckenfärg och arbetsytetillägg när du väljer den här inställningen.
  3. Klicka på Kör. Ritytorna exporteras som filer med det valda formatet.
Exportera ritytor som filer
Exportera ritytor som filer

Exportera ritytor som PDF

Du kan exportera ritytor som PDF-dokument. Gör så här:

  1. Välj Arkiv > Exportera > Ritytor till PDF i Photoshop.
  2. Gör följande i dialogrutan Ritytor till PDF:
    • Välj var du vill spara det genererade PDF-dokumentet.
    • Ange ett filnamnsprefix för de genererade PDF-dokumenten. Exempel: Campaign_insurance.
    • Ange om du endast vill exportera innehåll på ritytorna eller även innehållet i områden som överlappar ritytorna.
    • Ange om du vill exportera alla ritytor eller endast de som är markerade.
    • Ange om du även vill exportera ritytebakgrunder med ritytorna.
    • Ange om du vill generera en PDF-fil för alla ritytor i det aktuella dokumentet eller om du vill generera ett PDF-dokument per rityta. Om du väljer att generera flera PDF-dokument får alla dokument samma filnamnsprefix som du angav tidigare.
    • Ange en kodning för de exporterade PDF-dokumenten: ZIP eller JPEG. Om du väljer JPEG måste du också ange en kvalitetsinställning (0-12).
    • Ange om du vill inkludera ICC-profilen (International Color Consortium) i de exporterade PDF-dokumenten. En ICC-profil innehåller data som karaktäriserar en färgindata- eller utdataenhet.
    • Ange om du också vill exportera ritytornas namn tillsammans med de exporterade ritytorna. Du kan ange ett anpassat teckensnitt, teckenstorlek, teckenfärg och arbetsytetillägg när du väljer den här inställningen.
  3. Klicka på Kör. PDF-dokumentet genereras.
Exportera rityta som PDF
Exportera rityta som PDF

Vanliga frågor

Vilken färgrymd är bäst för att exportera ett Photoshop-dokument?

sRGB rekommenderas när bilder förbereds för webben, eftersom färgrymden definieras för standardbildskärmar som används för att visa bilder på webben. sRGB är även ett bra alternativ när du arbetar med bilder från icke-professionella digitalkameror, eftersom sRGB används som standardfärgrymd i de flesta av dessa. 

Mer information om färgrymder och inställningar finns i Färginställningar.

Vad är exportsegment?

Segment delar en bild i mindre bilder som sätts ihop igen på en webbsida med en HTML-tabell eller CSS-lager. Genom att dela upp bilden kan du tilldela olika webbadresslänkar för att skapa en sidnavigering eller optimera varje del av en bild med egna optimeringsinställningar. Du exporterar och optimerar en segmenterad bild med alternativet Spara för webben (äldre). Photoshop sparar varje segment som en separat fil och skapar den HTML- eller CSS-kod som behövs för att visa den segmenterade bilden.

Mer information finns i Segmentera webbsidor.

Kan jag exportera mitt Photoshop-dokument med hjälp av Spara för webben?

Ja. Du kan fortfarande använda alternativet Spara för webben (äldre) för att exportera resurser. Om du vill exportera dokumentet med det äldre exportalternativet väljer du Arkiv > Exportera > Spara för webben (äldre).

Mer information finns i Spara för webben i Photoshop.

Vanliga fel och begränsningar

Fel: Adobe Spara för webben

När du använder Photoshop i macOS 10.15.x och väljer Arkiv > Exportera > Spara för webben visas felmeddelandet ”Adobe Spara för webben – Fel: Det gick inte att slutföra åtgärden. Det uppstod ett okänt fel.”

Mer information om den tillfälliga lösningen finns i Photoshop och macOS Catalina (10.15).

Fel: Videoåtergivningen startar men slutförs aldrig

När du väljer Arkiv > Exportera > Återge video... slutförs aldrig processen.

Mer information om den tillfälliga lösningen finns i Photoshop och macOS Catalina (10.15).

Fel: ”Det har uppstått ett problem med generatorn” inträffar när Photoshop startas

Felet: Det har uppstått ett problem med generatorn. Avsluta Photoshop och försök sedan igen. Om problemet kvarstår tar du bort alla plugin-program från tredje part eller försöker installera om Photoshop. kan inträffa när du startar Photoshop eller använder generatorrelaterade funktioner. 

Om du vill lära dig mer om den provisoriska lösningen kan du läsa Felet ”Det finns ett problem med generatorn” inträffar när du startar Photoshop.

Fel: Lagret är tomt

Lager som är tomma eller inte kan återge bilder kan inte återges i dialogrutan Exportera som. Det kan vara lager som urklippsmasker, justeringslager eller lager som inte innehåller några pixlar.

Fel: Bilden ligger utanför dokumentgränsen

Exportåtgärden kunde inte återge bilden eftersom den har utfall från arbetsytan. Flytta bilden så att den får plats på arbetsytan

Begränsningar vid SVG-export

  • Text återges eventuellt inte på rätt sätt. För bästa resultat bör du konvertera textlagret till en form innan du exporterar det till en SVG-bild.
  • Lagermasker och urklippsmasker återges eventuellt inte på rätt sätt. Du bör eventuellt använda vektormasker i stället för SVG-export.
  • Bakgrundslager exporteras som genomskinliga till SVG-bilder. Duplicera bakgrundslagret i panelen Lager om du vill att det ska visas i den exporterade SVG-bilden.